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16 Chapter 1: Introducing the IDL iTools
Introducing the iTools 

The new IDL Intelligent Tools (iTools) are a set of interactive utilities that combine 
data analysis and visualization with the task of producing presentation quality 
graphics. Based on the IDL Object Graphics system, the iTools are designed to help 
you get the most out of your data with minimal effort. They allow you to continue to 
benefit from the control of a programming language, while enjoying the convenience 
of a point-and-click environment.

In IDL 6.1, six pre-built iTools are exposed for immediate interactive use. Each of 
these six tools is designed around a specific data or visualization type, including:

• Two- and three- dimensional plots (line, scatter, polar, and histogram style)

• Surface representations

• Contour data

• Map data

• Image displays

• Volume visualizations

The iTools are built upon a new object-oriented framework, or set of object classes, 
that serve as the building blocks for the interface and functionality of the iTools. IDL 
programmers can easily use this framework to create custom data analysis and 
visualization environments. Such custom iTools may be called from within a larger 
IDL application, or they may serve as the foundation for a complete application in 
themselves.

A Single Tool with Many Faces

What sets the iTools apart from precursors such as the Live Tools (now obsolete) — 
and what gives them their optimal power, flexibility, and extensibility — is the 
cohesive, open architecture of the iTools system. The iTools system is actually 
comprised of a single tool, which adapts to handle the data that you pass to it. The 
plot, surface, image, contour, and volume tools are simply shortcut configurations, 
which facilitate ad hoc data analysis and visualization. Each tool encapsulates the 
functionality (data operations, display manipulations, and visualization types) 
required to handle its data or visualization type. However, you are not constrained to 
work with a single data or visualization type. Instead, using the iTools system, you 
may start by bringing up a surface plot in a surface tool and then import scattered 
point data into the same plot to see the relationship between two data sets. Or, you 
may start with an image display, overlay contours from another data set, and map 
Introducing the iTools iTool User’s Guide
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both the image and contours onto a three-dimensional surface representation of a 
third data set. By throwing new data into an iTool, it is easy to end up with a hybrid 
tool that can handle complex, composite visualizations.

Of course, you have always been able to create these kinds of powerful, composite 
visualizations in IDL to reveal important relationships and trends in data. The main 
enhancements the new iTools provide are more mouse interactivity, WYSIWYG 
(What-You-See-Is-What-You-Get) printing, built-in analysis, undo-redo capabilities, 
layout control, and better-looking plots. These robust, pre-built tools reduce the 
amount of programming IDL users must do to create interactive visualizations. At the 
same time, the iTools integrate in a seamless manner with the IDL Command Line, 
user interface controls, and custom algorithms. In this way, the iTools maintain and 
enhance the control and flexibility IDL users rely on for data exploration, algorithm 
design, and rapid application development.

Foundation for the Future

As you will discover, the iTools are compelling new tools to add to your arsenal. They 
complement the strong foundation that IDL has maintained over the course of its 
evolution. This foundation has made possible countless valuable user-written 
applications across many disciplines and industries. However, the iTools also 
represent the start of a new, updated display paradigm for IDL. While the iTools 
system in IDL 6.1 is a powerful and flexible environment that will allow you to 
immediately accelerate your data interpretation and reporting, it is only the 
beginning. We will continue to build on this new technology in future releases. You 
can look forward to more functionality, flexibility, and optimization as the iTools 
system continues to grow.

We look forward to members of the IDL community building on the iTools system as 
well. The iTools source code is included in the IDL distribution to allow you to:

• extend the pre-built tools with your own operations, manipulations, 
visualization types, and GUI controls

• create your own custom tools based on the iTools component framework

• share your inventions with others in the IDL community via the RSI User-
Contributed Library (www.RSInc.com/codebank) or other avenues of 
collaboration and distribution

Note
For more information on building your own iTools or building hybrid iTools, see 
the iTool Developer’s Guide. 

Tips and instructions for using this guide are detailed in the following section.
iTool User’s Guide Introducing the iTools
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Using this Guide

The iTool User Guide can show you important iTool functionality such as how to start 
the iTools, how to import data into an iTool, how to export data out of an iTool, the 
general layout of the iTools, and how to perform common iTool tasks.

This User Guide is organized to help you make the most of the IDL iTools. The User 
Guide contains the following chapters:

• Chapter 2, “Importing and Exporting Data” — This chapter introduces you to 
bringing data into the iTools as well as exporting data.

• Chapter 3, “Visualizations” — This chapter introduces what an iTool 
visualization is and how to work with visualizations.

• Chapter 4, “Manipulating the Display” — This chapter describes the various 
ways that you can manipulate your displays within an iTool.

• Chapter 5, “Adding Annotations” — This chapter describes the various types 
of annotations available in iTools and how to work with them.

• Chapter 6, “Property Sheets and Browsers” — This chapter describes the 
property sheets and browsers that are common to all iTools.

• Chapter 7, “Common Operations” — Many iTool operations are common to 
each tool. These operations are described in this chapter.

• Chapter 8, “Working with Macros” — This chapter describes macros in iTools 
and how they are created and used.

• Chapter 9, “Working with Styles” — This chapter describes iTool styles and 
how to create and work with them.

• Chapter 10, “Working with Images” — This chapter describes the iImage tool 
and gives you insight into unique image visualization and manipulation tasks.

• Chapter 11, “Working with Surfaces” — This chapter describes the iSurface 
tool and gives you insight into unique surfacing and surface manipulation 
tasks.

• Chapter 12, “Working with Contours” — This chapter describes the iContour 
tool and gives you insight into unique contouring and contour manipulation 
tasks.

• Chapter 13, “Working with Plots” — This chapter describes the iPlot tool and 
gives you insight into unique plotting and plot manipulation tasks.
Using this Guide iTool User’s Guide
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• Chapter 14, “Working with Volumes” — This chapter describes the iVolume 
tool and gives you insight into unique volume visualization and volume 
manipulation tasks.

• Chapter 15, “Working with Maps” — This chapter describes the iMap tool and 
gives you insight into unique mapping and map manipulation tasks.

• Appendix A, “iTools Interface Reference” — This appendix gives you a 
detailed look at the iTool interface and its components.

• Appendix B, “Property Controls” — This appendix describes the iTool 
controls used to set properties in the iTool property sheets.

• Appendix C, “Operations Properties” — This appendix describes the 
properties of the iTools found in the Operations Browser of each iTool.

• Appendix D, “Visualization Properties” — This appendix describes the 
properties of the iTools found in the Visualization Browser of each iTool.
iTool User’s Guide Using this Guide
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22 Chapter 2: Importing and Exporting Data
About the Data Manager 

All data used by any iTool is first loaded into the iTools Data Manager, which keeps 
track of which data items are associated with an iTool visualization. The Data 
Manager provides a convenient and structured environment in which to import and 
view files and variables.

The process of loading data into the Data Manager is entirely automatic if you 
specify data when launching an iTool at the IDL command line or if you open a data 
file using the Open command from the iTool’s File menu. In these cases, the iTool 
will import the data in the specified file or variable and create a visualization of the 
default type for the selected data and the iTool you are using.

If you want more control over the process of creating a visualization, you can load 
data into the Data Manager manually, either from a data file or from one or more 
variables that exist in your current IDL session. Once a data item is placed in the Data 
Manager, it is available to all iTools until it is removed. Methods used to place data 
into the Data Manager are described in this chapter.

The IDL iTools support several data types. Data import and export capabilities within 
each iTool allow you to access these various types of data. File readers allow you to 
import data stored in binary formats, ASCII files, and several image file types.

Note
You can also create file readers for other data types besides those provided in IDL. 
For more information on creating file readers and creating your own iTools, see 
Chapter 9, “Creating a File Reader” in the iTool Developer’s Guide manual.
About the Data Manager iTool User’s Guide
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Data Manager Interface

The Data Manager’s graphical user interface consists of these elements:

• Data Tree View — This window, on the left side of the dialog, shows all of the 
data items available within the Data Manager. Depending on how data items 
were added to the Data Manager, they may be collected into groups of related 
items; for example, individual image channels associated with a true-color 
image will show up underneath the Data Manager entry for the image itself. 
The data tree view will be empty unless you have read or imported data into 
the Data Manager.

• Data Properties— This window, on the right side of the dialog, shows you all 
properties and their values for the data item selected in the data tree view.

• Help — This button will invokes the IDL online help system.

• Import Variable — This button allows you to select a variable in the IDL 
Main scope to import into the Data Manager. For more information on 
importing a variable into your Data Manager, see “Importing Data From the 
IDL Session” on page 44.

• Import File — This button allows you to select a data file to import into the 
Data Manager.

• Dismiss — This button will dismiss the dialog.

Figure 2-1: The iTools Data Manager
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Data Item Management

In addition to the ability to import new data into the Data Manager, you can rename, 
duplicate, or remove existing data items.

• Renaming data — To rename a data item, enter a new name in the Name field 
on the data property sheet.

• Deleting data — To delete an unused or outdated data item, select the item in 
the tree view, click the right mouse button to display the Data Manager context 
menu, and choose the Delete option.

• Duplicating data — To create a copy of an existing data item, select the item 
in the tree view, click the right mouse button to display the Data Manager 
context menu, and choose the Duplicate option.
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Data Import Methods 

Data items in the Data Manager are available to all iTools until it they are removed. 
You can bring data into the iTool Data Manager in the following ways:

• Using the Data Import Wizard (File → Import)

• By opening a data file directly (File → Open)

• Using the Import Variable ... or Import File... buttons on the Data Manager 
dialog (Window → Data Manager)

• By specifying data parameters at the IDL command line. For example, 
specifying the following at the IDL command line:

iPlot, myDataVariable

places the variable myDataVariable in the Data Manager.

These methods are described in the following sections.

Note
Once data has been imported into the iTool and is visible in the Data Manager, there 
are a numerous ways to visualize the data. To learn more about visualizing data, see 
Chapter 3, “Visualizations”.
iTool User’s Guide Data Import Methods



26 Chapter 2: Importing and Exporting Data
Using the Data Import Wizard 
The iTool Data Import Wizard steps you through the process of importing data into 
the Data Manager. Launch the Data Import Wizard by selecting File → Import... The 
Data Import Wizard has three screens:

1. Select the data source.

You can import data either from a data file or from the IDL session:

• From a File — allows you to select a data file to import.

• From an IDL Variable — allows you to select an IDL variable to import. 
For more information on importing a variable into your Data Manager, see 
“Importing Data From the IDL Session” on page 44.

2. Select the data and specify a data name. 

If you are importing data from a file, the second screen of the Data Import Wizard 
contains the following items:

• File Name — The full path of the file want to open. You can populate this 
field using a standard dialog by clicking the File Open button.

• File Open button  — Displays the standard file-selection dialog.

• File Type — After a file is selected, the File Type field displays the format 
of the file.

• Type Properties Window — After a file is selected the properties window 
shows properties of the file reader that will import the data, if any exist. 
Modify these properties as necessary to import your data correctly.

Note
For more information about file format types that are available in iTools, see 
“File Readers” in Chapter 6, Property Sheets and Browsers.

• Data Import Name — The name that will be used for the imported data in 
the Data Manager.

Importing some types of data files may cause IDL to present additional screens that 
describe the data before import.

• For image data see “Importing Image Data” on page 32

• For ASCII data see “Importing ASCII Data” on page 32

• For binary data see “Importing Binary Data” on page 36
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If you are importing data from an IDL variable, the second screen of the Data Import 
Wizard contains the following items:

• List of IDL Variables — All variables available in the current IDL session 
are listed in a tree view.

• Variable Information — Information about the selected variable is 
displayed to the right of the tree view.

• Data Import Name — The name that will be used for the imported data in 
the Data Manager.

3. Select the type of visualization you want to create. 

The Data Import Wizard will automatically create a new visualization of the selected 
type. Choosing <Default> will create the default visualization for the selected data 
type, regardless of the type of iTool into which you are importing the data.

Example: Importing a JPEG File

The following example describes how to import a JPEG image file using the Data 
Import Wizard and display the image:

1. From an iTool window select File → Import.

Figure 2-2: The IDL Data Import Wizard, Showing Step 1 of 3
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2. Select From a File and click Next.

3. Click the File Open button  just to the right of the File Name field and 
select the endocell.jpg file from the examples/data directory of the IDL 
distribution. Click Next.

Figure 2-3: The IDL Data Import Wizard, Showing Step 2 of 3

Figure 2-4: The IDL Data Import Wizard, Showing Step 3 of 3
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4. Select Image as the desired visualization to create since we have a JPEG 
image.

5. Click Finish. The data is imported into the Data Manager, and a new image 
visualization appears in the iTool window.

Note
The process of creating visualizations is discussed in detail in Chapter 3, 
“Visualizations”.
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Using File Open

Selecting a data file using File → Open will open the file using the default iTool file 
reader for the type of file you select. The data will be added to the Data Manager and 
the iTool will automatically create the default visualization for the data contained in 
the file.

If the data in the file you select is binary or ASCII, you will be prompted to specify 
further information that will allow the binary or ASCII file readers to correctly import 
the data. For an explanation of the handling of various file types see the following 
sections:

• For ASCII data see “Importing ASCII Data” on page 32

• For binary data see “Importing Binary Data” on page 36.
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Using the Data Manager Dialog

Selecting Window → Data Manager opens the Data Manager dialog. You can then 
click the Import Variable... or Import File... button.

Importing a File

If you are importing data from a file, the File Import dialog appears. It contains the 
following items:

• File Name — The full path of the file want to open. You can populate this 
field using a standard dialog by clicking the File Open button.

• File Open button  — displays the standard file-selection dialog.

• File Type — After a file is selected, the File Type field displays the format 
of the file.

• Options Button — After a file is selected, click Options to display a 
properties window shows properties of the file reader that will import the 
data, if any exist. Modify these properties as necessary to import your data 
correctly.

Note
For more information about file format types that are available in iTools, see 
“File Readers” in Chapter 6, Property Sheets and Browsers.

• Data Import Name — The name that will be used for the imported data in 
the Data Manager.

Importing a Variable

If you are importing data from an IDL variable, the IDL Variable Browser appears. It 
contains the following items:

• List of IDL Variables — All variables available in the current IDL session 
are listed in a tree view.

• Variable Information — Information about the selected variable is 
displayed to the right of the tree view.

• Data Import Name — The name that will be used for the imported data in 
the Data Manager.
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Importing Data From a File

You can import data from several types of files into the iTool Data Manager. The 
following sections describe the process of importing different types of data.

• “Importing Image Data” on page 32

• “Importing ASCII Data” on page 32

• “Importing Binary Data” on page 36

• “Importing Shapefile Data” on page 39

Importing Image Data

You can visualize image data stored in many common file formats. Common image 
file formats accepted are:

Note
You can also use the iTool’s export and export variable features to export image data 
and variables. For more information on exporting, see “Exporting Data” on page 47.

Note
For more information on the iImage tool and its functions and features, see Chapter 
10, “Working with Images”.

Importing ASCII Data

When you open a file containing ASCII data, you must specify the format of the file 
before the iTool can read the data and place it into the Data Manager. The iTool opens 
the ASCII Template dialog to allow you to specify the format of the ASCII data.

• DICOM Image • Joint Photographic 
Experts Group (JPEG)

• JPEG2000 (JP2 or JPX) • Macintosh PICT

•  Portable Network 
Graphics (PNG)

•  Tag Image File Format 
(TIFF)

• Windows Bitmap (BMP)
Importing Data From a File iTool User’s Guide



Chapter 2: Importing and Exporting Data 33
Note
You can also use the iTool’s export and export variable features to export ASCII 
data and variables. For more information on exporting, see “Exporting Data” on 
page 47.

The following example opens an ASCII file using the ASCII Template:

1. From the iTool window open an example file named sine_waves.txt from 
the examples\data subdirectory of your IDL distribution. You can open the 
file either by selecting File → Open or by clicking the Import File button in 
the Data Manager or Insert Visualization dialog.

2. The ASCII Template window is displayed:

The first step of the ASCII Template contains the following items:

• Field Type — select the field type which best describes your data. Choose 
from fixed width or delimited.

• Comment Strings to Ignore — allows you to note any comment strings 
you wish to be ignored.

• Data Starts at Line — allows you to specify from which line data should 
first be read.

Figure 2-5: The ASCII Template Step 1, Defining Data Type and Range
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• Selected Text File — shows the real data from the selected text file. The 
option is also given to Get next 50 Lines.

3. Choose the field type. Here it is delimited by white space.

4. There are no comment strings to ignore here, and the line upon which to begin 
your data is 1. Now select Next.

The second step of the ASCII Template contains the following items:

• Number of Fields Per Line — allows you to specify how many fields 
should appear per line.

• Delimiter Between Data Elements — allows you to select the delimiter 
type between data elements.

• Value to Assign to Missing Data — allows you to choose a value to 
assign any missing data.

• Selected Records — shows the data itself in its desired column-delimited 
format.

Figure 2-6: The ASCII Template Step 2, Defining Delimeters/Fields
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5. Next, enter the Number of Fields Per Line as two, and the Delimiter 
Between Data Elements should be set to White Space. Click Next.

The third step of the ASCII Template contains the following items:

• Name — allows you to name your fields. Default values are Field1, 
Field2, and so on. You can enter the name into the Name field to the right.

• Data Type — allows you to set the data type for your fields. You can enter 
the type by selecting it from the Type drop-down menu.

• Grouping — allows you the option of joining fields to be manipulated or 
displayed as a group. You can group certain fields, group all, ungroup 
certain fields and ungroup all. The default is no grouping.

• Sample Record — shows you a sample of the configuration you have set.

6. Next, at step three, the defaults are all correct for the data to visualize. Click 
Finish and the data is imported (and also in this case, plotted).

Note
Once data has been imported into the iTool and is visible in the Data Manager, there 
are a few ways to visualize the data. To learn more about visualizing data, see 
Chapter 3, “Visualizations”.

Figure 2-7: ASCII Template Step 3, Field Specifications
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For more information on using the ASCII file reader, see “ASCII_TEMPLATE” in 
the IDL Reference Guide manual.

Importing Binary Data

When you open a file containing binary data that is not of a format recognized by any 
other file reader available to your iTool, you must specify the format of the file before 
the iTool can read the data and place it into the Data Manager. The iTool opens the 
Binary Template dialog to allow you to specify the format of the binary data.

Note
If the file contains binary data of a recognized format, such as TIFF or JPEG, the 
iTool will automatically choose the correct file reader to read the binary data.

Note
You can also use the iTool’s export and export variable features to export binary 
data and variables. For more information on exporting, see “Exporting Data” on 
page 47.

The following example opens a binary file using the Binary Template:

1. From the iTool window open an example file named damp_sn.dat from the 
examples\data subdirectory of your IDL distribution. You can open the file 
either by selecting File → Open or by clicking the Import File button in the 
Data Manager or Insert Visualization dialog. This is a data file containing a 
damped sine wave with severe high frequency noise.

2. The Binary Template window is then displayed. 

Figure 2-8: The Binary Template
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The Template Name is optional, and can be any string.

The byte order in the file is selected using the using the File’s byte ordering: 
pull-down menu. The choices are:

• Native — the type of storage method that is native to the machine you are 
currently running. Little Endian for Intel microprocessor-based machines 
and Big Endian for Motorola microprocessor-based machines. No byte 
swapping will be performed.

• Little Endian — a method of storing numbers so that the least significant 
byte appears first in the number. Specify this if the original file was created 
on a machine that uses an Intel microprocessor.

• Big Endian — a method of storing numbers so that the most significant 
byte appears first in the number. Specify this if the original file was created 
on a machine that uses a Motorola microprocessor.

3. From this template, click New Field.

The New Field dialog contains the following items:

• The Field Name can be any string.

• The Type of each Template-specified field is selected from a droplist that 
offers the following IDL types: byte, integer, long, float, double, complex, 

Figure 2-9: Defining a New Field in the Binary Template
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dcomplex, uint, ulong, long64 and ulong64. Strings are read as an array of 
bytes for later conversion to type STRING. 

• Offsets can be specified using integer values, field names, or any valid 
IDL expression. An absolute integer offset specifies a fixed location (in 
bytes) from the beginning of the file (or the initial file position for an 
externally opened file). A relative integer offset specifies a position relative 
to the current file position pointer after the previous field (if any) is read. 
Relative offsets are shown in the binary template user interface with a 
preceding > or < character, to indicate a positive (>) or negative (<) byte 
offset. Expressions can include the names of fields that will be read before 
the current field — that is, the field number of the referenced field must be 
lower than the field number of the field being defined.

• The Verify field can contain an integer, field name, or any valid IDL 
expression. Only scalar fields can be verified. 

• The Number of Dimensions of a field can be set via a droplist of values 0 
(scalar) to 8 (which is the maximum number of dimensions that an IDL 
variable can have.) The size of each dimension can be an integer, field 
name, or any valid IDL expression. Any of the first three dimensions of 
array data can also be specified to be reversed in order. 

Click OK to create the new field definition, and repeat to define all necessary 
fields. 

Note
If the iTool is running in the IDL Virtual Machine, the Offsets, Verify, and 
Size fields can contain integers or field names, but not an IDL expression. For 
additional information on the binary template, see “BINARY_TEMPLATE” 
in the IDL Reference Guide manual.

4. In this example, name the field “dampsn”. The type is Byte data. The number 
of dimensions is 1 and the dimension size is 512. 

5. Click OK and then OK again to close the Binary Template dialog. The data is 
not imported into the Data Manager (and in this case, the plot appears in the 
iTool window).

Note
Once data has been imported into the iTool and is visible in the Data Manager, there 
are a few ways to visualize the data. To learn more about visualizing data, see 
Chapter 3, “Visualizations”.
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For more information on the binary file reader, see “BINARY_TEMPLATE” in the 
IDL Reference Guide manual.

For more information on plotting and plot functions, see Chapter 13, “Working with 
Plots”.

Importing Shapefile Data

For more information on shapefiles and inserting them into an iTool, see “Inserting an 
IDL Shapefile” in Chapter 15.

Note
Once data has been imported into the iTool and is visible in the Data Manager, there 
are a few ways to visualize the data. To learn more about visualizing data, see 
Chapter 3, “Visualizations”.
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Working with Unknown Data 

If you supply data in a format not recognized by the current iTool, the Create 
Visualization dialog allows you to specify how the data is to be used.

You will see this dialog if the data you supply when launching an iTool from the IDL 
command line does not match a known data organization for the selected tool, or if 
you open an ASCII text file containing data that appears to be irregularly gridded.

The Create Visualization dialog contains the following choices:

• Launch the gridding wizard

This option lets you transform irregularly-gridded data into regularly-gridded 
data using IDL’s gridding routines. The resulting data is displayed by the iTool. 
See “Using the Gridding Wizard” on page 41 for details.

• Select a visualization and specify parameters

This option lets you manually specify how the data should be assigned to a 
selected visualization’s parameters.

• Do not create a visualization

Figure 2-10: The iTools Create Visualization Dialog
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Using the Gridding Wizard

The iTools Gridding Wizard allows you to convert irregularly-gridded data into 
regularly-gridded data using a variety of methods. The gridding wizard processes 
your irregularly-gridded data in three steps.

The IDL Gridding Wizard Step 1 of 3 dialog contains the following items:

• Number of points entered

• X Coordinates — The X coordinate range

• Y Coordinates — The Y coordinate range

• Data values — The data minimum and maximum values

• Spherical data checkbox — Check this box if the data is spherical

• Coordinate diagram — Shows coordinates of grid data

• Show points checkbox — Select to show all points (default = checked)

• Help — Obtain help on this dialog

• Back — Return to previous step

• Next — Proceed to Step 2 of 3

• Cancel — Dismiss the Gridding Wizard

Figure 2-11: The IDL Gridding Wizard Step 1 of 3
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The IDL Gridding Wizard Step 2 of 3 dialog contains the following items:

• X Coordinates — modify dimension, start or end

• Y Coordinates — modify dimension, start or end

• Coordinate diagram — shows coordinates of grid data

• Show points checkbox — select to show all points (default = checked)

• Help — obtain help on this dialog

• Back — return to previous step

• Next — proceed to Step 3 of 3

• Cancel — dismiss the Gridding Wizard

Figure 2-12: The IDL Gridding Wizard Step 2 of 3
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The IDL Gridding Wizard Step 3 of 3 dialog contains the following items:

• Choose gridding method — choose from pull-down list. See “GRIDDATA” 
in the IDL Reference Guide manual for a discussion of the gridding methods.

• Preview — click to preview selected method and data

• Auto preview — checkbox to turn auto preview on (default = off)

• Statistics tab — shows data statistics

• Options tab — set options for missing values, smoothing, weighting, and 
anisotropy between axes

• Search tab — set options for using search ellipse

• Coordinate diagram — shows coordinates of grid data

• Show points checkbox — select to show all points (default = checked)

• Help — obtain help on this dialog

• Back — return to previous step

• Finish — dismiss the Gridding Wizard with data gridded

• Cancel — dismiss the Gridding Wizard

Figure 2-13: The IDL Gridding Wizard Step 3 of 3
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Importing Data From the IDL Session

Variables in your current IDL session can be imported into the Data Manager to be 
visualized in an iTool. Once you have entered variables into the IDL session at the 
command line, you can import a variable directly from the Data Manager dialog, or 
by using File → Import. 

Note
If you specify a variable as a parameter to the iTool at the IDL command line, the 
variable is automatically imported into the Data Manager.

The following is an example of importing a variable using the Data Manager dialog:

1. From the Data Manager dialog, select Import Variable. The IDL Variable 
Browser appears.

Figure 2-14: The IDL Variable Browser
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2. From the IDL Variable Browser you can select available variables which you 
have entered at the Command Line and click OK to add them to your Data 
Manager as available variables.

Importing Graphic Objects

You can import graphic objects into your iTool using the Visualization pull-down 
menu on the Insert Visualization window. Select IDL Graphics Object and then 
import your variable from the Data Manager into the Graphics Object field and 
select Insert.

When importing graphic objects into an iTool it is important to remember: 

• If the object hierarchy being inserted as a graphic object does not have the 
REGISTER_PROPERTIES keyword set, then no properties will be available 
in your iTool when the object is visualized.

If the object hierarchy being inserted as a graphic object includes an image object, 
rotation may not behave as expected. For more information on image objects and 
their behavior, see “Transformations of IDLgrImage Objects” in Chapter 8 of the IDL 
Reference Guide manual.

Figure 2-15: Imported Variable with Imported Files
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Parameter Data and the Command Line

Parameter data can often be entered at the IDL command line in IDL when creating 
an iTool. Consider the following example: 

1. At the IDL Command Line, enter the following:

myPlotData = RANDOMU(seed, 30)
iPlot, myPlotData

2. The variable myPlotData is inserted into the iTool Data Manager.

3. The following is produced in an iPlot window:

Figure 2-16: Reading Parameter Data in at the IDL Command Line
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Exporting Data 

Data of many common file formats can be exported by IDL iTools. File formats that 
are exportable are:

You can export data from an iTool to a data file or back to the current IDL session:

• Exporting Data to a File (following)

• Exporting Data to the IDL Session (page 51)

These methods are discussed next.

• iTools State • Windows Bitmap (BMP)

• Encapsulated Postscript 
(EPS)

• Windows Enhanced 
Metafile (WMF)

• Joint Photographic 
Experts Group (JPG)

• JPEG2000

• Macintosh PICT • Portable Network 
Graphics (PNG)

• Tag Image File Format 
(TIFF)

• ASCII text

• Binary data
iTool User’s Guide Exporting Data



48 Chapter 2: Importing and Exporting Data
Exporting Data to a File

You can export the contents of an entire iTool window into a single image or data file 
using the IDL Data Export Wizard.

For example, to export a file:

1. Select File → Export. The IDL Data Export Wizard appears.

2. The first step asks you to choose to export the data to either a file or an IDL 
variable. Select To a File and then Next.

Figure 2-17: The IDL Data Export Wizard, Showing Step 1 of 3
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For more information on exporting data to an IDL variable, see the following section, 
“Exporting Data to the IDL Session” on page 51.

3. From the next screen, select the data which you wish to export. Notice that 
only the Window level or View level can be exported. Click Next.

Figure 2-18: The IDL Data Export Wizard, Showing Step 2 of 3

Figure 2-19: The IDL Data Export Wizard, Showing Step 3 of 3
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4. You are now prompted for selection of the destination and file type. After 
entering a desired filename, extension, and destination, click Finish. The file is 
then exported.
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Exporting Data to the IDL Session

You can export data from an iTool into a single variable using the IDL Data Export 
Wizard.

For example, to export data to an IDL variable:

1. Select File → Export. The IDL Data Export Wizard appears.

Figure 2-20: The IDL Data Export Wizard, Exporting a Variable Step 1 of 3
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2. Select To an IDL Variable.

Figure 2-21: The IDL Data Export Wizard, Exporting a Variable Step 2 of 3
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3. From the next screen, select the data that you wish to export. Notice that only 
data items can be exported as variables. Click Next.

4. The final screen and step allow you to name your variable as you wish. A 
default name also appears as representative of the data item. Name your 
variable and click Finish.

5. The variable will now appear in the Data Manager.

Exporting via Context Menu

An alternate way to export a variable to IDL is to select the variable within the 
Visualization browser and right-click to choose Export to IDL. For more 
information on the Visualization browser, see Appendix D, “Visualization 
Properties”.

Figure 2-22: The IDL Data Export Wizard, Exporting a Variable Step 3 of 3
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Chapter 3:

Visualizations 
This chapter describes how working with visualizations within the iTool.
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About Visualizations

A visualization is a graphical representation of data that has been imported into the 
iTool Data Manager. This might mean a plot, image, or surface just to name a few. 
Visualizations can be created in any iTool window either automatically or manually. 
Visualizations can also be modified and exported. These topics are all discussed in 
this chapter.

When data is imported into the IDL iTools system, it resides in the Data Manager. 
The Data Manager provides a convenient interface within which you can organize 
and manage data. For more information on importing and exporting data in an iTool 
and the use of the Data Manager, see Chapter 2, “Importing and Exporting Data”.

This chapter deals with the process of visualizing data that is already imported into an 
iTool. Visualizations can be created automatically at the IDL Command Line or can 
be inserted manually within an existing tool window. Once created, visualizations 
contain parameters which can be modified in various ways. Visualizations can also be 
exported from an iTool. These topics are all discussed in detail in this chapter.
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Visualization Creation Methods

Visualizations can be created either automatically or manually. The following 
sections discuss automatic and manual creation methods.

Creating Visualizations Automatically

Visualizations can be created automatically in the following ways:

• By specifying some data when creating an iTool at the IDL Command Line. 
For example: 

myPlotData = RANDOMU(seed, 30)
iPlot, myPlotData

These statements will create a new data item in the iTool Data Manager and 
create a new iPlot tool that visualizes the data in a line plot.

• By opening a file in an existing iTool, either by selecting File → Open or 
using the Data Import Wizard (File → Import...). 

• By using the Data Import Wizard (File → Import...) to import a variable from 
the IDL Session.

Both the Data Import Wizard and the process of using File → Open are described in 
detail in Chapter 2, “Importing and Exporting Data”.

Note
Certain data types (such as binary or ASCII) may require you to supply IDL with 
further information before they can be visualized. For more information about 
reading certain data types into iTools, see “Importing Data From a File” in Chapter 
2, "Importing and Exporting Data".
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Inserting Visualizations 

If you already have the necessary data in the iTool Data Manager, you can manually 
create a visualization in your iTool. This is done from your desired iTool window by 
selecting Insert → Visualization.

To access data using Insert → Visualization from your tool:

1. Start an iTool.

2. Select Insert → Visualization. The Insert Visualization Dialog appears

The Insert Visualization dialog contains the following items:

• Data Tree View — this tree contains any imported data and/or variables 
available for visualization in the Data Manager.

• Data Properties — this area, to the right of the Data Tree View, shows the 
properties of any selected Data Tree elements.

• Select a Visualization Drop-down Menu — this menu allows you to 
select the visualization type to use with the selected data. 

Figure 3-1: Insert Visualization Dialog With Image Visualization Type Selected
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• Parameter Property Sheet— these are the input parameters for the 
visualization type selected in the Visualization Type Drop-down Menu. 
These input variables will change per visualization type.

• Parameter Data Types Window — this window to the right of the 
parameters table shows the properties of the selected parameter.

• Help — this button will invoke the help system.

• Import Variable — gives you the ability to select a variable to import into 
the Data Manager. For more information on importing a variable into your 
Data Manager, see “Importing Data From the IDL Session” on page 44.

• Import File — gives you the ability to select data from a file to import into 
the Data Manager. For more information on importing a file into your Data 
Manager, see “Importing Data From a File” on page 32.

• Insert Button — this button will insert the specified visualization into the 
current iTool. Insert is only active if data is associated with all required 
parameters.

• Dismiss — this button will dismiss the dialog.

3. Select the visualization type from the visualization type drop-down menu.

4. Next, assign data in the dialog to the parameters of the visualization being 
inserted.

5. Now click Insert to finish inserting the visualization.
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Modifying Existing Visualizations 

Once you have created your visualization, you can modify it as you wish. Use the 
Parameter Editor to modify parameter data.

The Parameter Editor

The Parameter Editor is very similar to the Insert Visualization dialog. It shows the 
data tree view and parameter property sheet and parameter data types window.

If you have already created a visualization, you can change the data associated with 
one or more visualization parameters using the Parameter Editor. To display the 
Parameter Editor, select your visualization, then select Edit → Parameters....

Note
The Parameter Editor contains all of the fields shown in the Insert Visualization 
dialog, with the exception that you cannot change the visualization type of the 
selected visualization. See “Inserting Visualizations” on page 58 for details.

Figure 3-2: Parameter Editor
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To associate data with a visualization’s parameters using the Parameter Editor:

1. Select Edit → Parameters.

2. Do one of the following:

• Select an item already in the Data Tree View.

• Click Import File to import a file into the Data Tree View, and select the 
file.

• Click Import Variable to import a variable into the Data Tree View, and 
select the variable.

3. Assign items to the appropriate input parameter and data item, then double-
clicking or by selected the down arrow just below the Data Tree View.

4. Click Apply to apply your new changes or Dismiss to close the Parameter 
Editor.

Note
The Apply button will not be available unless all required parameters have been 
assigned within a visualization.

Removing Data Associations

Once a visualization has been created, you can always remove associations within the 
parameter editor. Select the parameter in the parameter property sheet and click the X 
button between the data tree view and the parameter property sheet.

Note
If you remove a required parameter, you will not be able to apply your changes until 
you select a new data item for that parameter.

Replacing Data Associations

To replace the data associated with a given parameter, select the parameter in the 
parameter property sheet, then select a new data item in the data tree. Double-click or 
click the down arrow button to replace the data associated with the selected 
parameter.
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Exporting Visualizations

Any iTool visualization can be saved. In order to save your visualization, select 
File → Save As... and then name the file. The file will automatically be assigned the 
extension .isv.

Exporting to a File

You can export data from an iTool to a data file or back to the current IDL session. 
For more information on exporting to a file, see “Exporting Data” in Chapter 2, 
"Importing and Exporting Data".
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Chapter 4:

Manipulating 
the Display
This chapter describes the following common tasks that can be performed with all of the IDL 
Intelligent Tools:
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Introduction

The Standard IDL iTools supplied in the IDL distribution comprise six distinct tools: 
iImage, iPlot, iSurface, iContour, iVolume, and iMap. Each tool performs a specific 
set of tasks related to the type of data it is designed to use. In addition to these 
specific tasks, all six tools have a number of manipulation tasks in common. This 
chapter describes only these common display manipulation tasks; for information 
about specific tasks performed by the individual iTools, refer to the chapters 
describing those tools.

Note
This chapter describes manipulation tasks related only to the Standard IDL iTools, 
those iTools supplied in the IDL distribution. Other iTools written by users and 
third-party developers share a common interface with the RSI iTools because the 
iTools framework is used to create all iTools. However, the specific functionality of 
such iTools may be different from the functionality of the iTools described here.
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Selection of Objects

iTool elements such as axes and annotations have objects associated with them. These 
objects have their own associated properties  — such as color, line style, size, and so 
on. There are two ways to select objects in IDL iTools:

• With the Select arrow

• From the Visualization Browser

To select an object or group of objects with the Select arrow:

1. If necessary, click the Select button  on the toolbar to enter Select mode.

2. Position the arrow mouse pointer over the object and click. A selection box 
appears around the object.

3. To select additional objects, hold down the SHIFT key while clicking them.

To select an object or group of objects from the Visualization Browser:

1. Select Window → Visualization Browser.

2. Click the name of the object in the Visualization Browser list. A selection box 
or selection highlight appears on that object in the iTool window.

3. To select additional objects, hold down the Shift key while selecting the names 
of additional objects in the Visualization Browser list.

Select All

Select All selects all objects (visualizations, annotations, legends, etc.) displayed in 
the iTool window.

To select all objects:

1. Select Edit → Select All. All displayed objects are selected.

2. CTRL + click to deselect any objects that you do not want to include.
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Undo/Redo

Any action performed in an iTool window can be undone or redone. The Undo and 
Redo mechanism provides a useful way of retracing and repeating steps that have 
been performed in the iTool window.

Note
Operations which cannot be undone are Open, Save, Export, Export variable, Print, 
Exit, and window moving and resizing.

To undo the most recent action, do one of the following:

• Select Edit → Undo

• Click 

To undo multiple actions, simply repeat these commands. When no more actions 
remain to be undone, the Undo menu item or toolbar button is no longer active.

To repeat actions that have been undone, do one of the following:

• Select Edit → Redo

• Click 

Tip
Look at the text following the Undo or Redo menu item, or hover the mouse pointer 
over the Undo or Redo button on the toolbar to display the tooltip, to identify the 
action that will be undone or redone.
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Adding a Data Space

The data space is the area within your visualization window where imported data 
appears. A data space is added automatically when data is visualized directly into an 
iTool window. However, if you desire to add a data space manually to any of the 
iTools, you can select Insert → Data Space from the iTool window.
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Translation

Translation moves an object or group of objects in a specified direction. When an 
object is selected, a bounding box appears around the object. 

To translate a selected object to another location: 

1. Position the pointer inside the bounding box. The mouse pointer changes to the 
translation pointer .

2. Drag in the desired direction. The entire object moves to the new location.

Note
For information on creating a surface visualization which you can translate such as 
the one shown in the previous figure, see Chapter 11, “Working with Surfaces”.

Figure 4-1: Translating Objects
Translation iTool User’s Guide



Chapter 4: Manipulating the Display 69
Scaling

Two types of scaling are possible: constrained scaling and unconstrained scaling. 

Constrained Scaling

Constrained scaling permits scaling of only one dimension while preserving the other 
dimensions.

Constrained Scaling of 2-D Objects

To scale one dimension of a 2-D object, click on the object so that eight small 
selection-boxes appear at each corner of the object and also midway along each side 
of the object. Then position the mouse onto one of these boxes so that the mouse 
pointer changes to a four-headed arrow pointer (see the following figure). Drag the 
mouse in the desired direction to scale the object in the selected dimension.

Constrained Scaling of 3-D Objects

Two types of constrained scaling are available for 3-D objects: multiple-axis scaling 
and single-axis scaling. 

Figure 4-2: Resizing a 2-D Plot
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The multiple-axis scaling mouse pointer for 3-D objects is a three-headed arrow  
displayed when the mouse pointer is positioned over a corner of a 3-D object’s data 
space. Dragging the constrained scaling pointer scales the object a fixed distance 
along all axes in the direction of the drag.

Figure 4-3: Constrained Scaling
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The single-axis scaling pointer for 3-D objects is a two-headed arrow , displayed 
when the pointer is positioned over an axis “whisker” in a 3-D image. Dragging an 
axis “whisker” scales the object only in the direction of the arrows.

Unconstrained Scaling

Unconstrained scaling allows you to scale all dimensions of an object at once from 
any point within the object. Unconstrained scaling is different for 2-D and 3-D 
objects.

Figure 4-4: Resizing a 3-D Surface
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Unconstrained Scaling of 2-D Objects

Unconstrained scaling of 2-D objects occurs when a corner of the data set bounding 
box is dragged. The mouse pointer changes to an unconstrained scaling pointer , 
and the object is scaled in the direction of the drag.

Figure 4-5: Unconstrained Scaling of a 2-D Plot
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Unconstrained Scaling of 3-D Objects

Unconstrained scaling of 3-D objects occurs when a single side of the data set 
bounding box is dragged. The mouse pointer changes to an unconstrained scaling 
pointer , and the object is scaled along the dimensions of the selected side.

Figure 4-6: Unconstrained Scaling of a 3-D Surface
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Zooming

Two types of zooming are available in all iTools: Canvas Zoom, which increases or 
decreases the magnification of the entire display canvas by a specified percentage, 
and View Zoom, which zooms in or out on a specific portion of the display area.

Canvas Zoom

Canvas Zoom increases or decreases magnification of the entire iTool window 
without moving the observer’s “eye.”

To zoom in or out with Canvas Zoom:

1. Select Window → Canvas Zoom and select a percentage from the list.

• To increase magnification, choose a percentage greater than 100%.

• To decrease magnification, choose a percentage less than 100%.

2. Select 100% to return to the default magnification.

View Zoom

View Zoom increases or decreases magnification at a specific point in the iTool 
window. This is similar to moving the observer’s “eye” closer to or farther away from 
the object. The two ways to view zoom are using the view zoom button or by using 
the view zoom pull-down menu. 

To use the view zoom button:

1. Click Zoom  on the toolbar to enter Zoom mode.

2. Position the mouse pointer on the viewplane. The pointer changes to a zoom 
pointer .

3. Do either of the following:

• Drag the zoom pointer toward the top of the iTool window to enlarge the 
display

• Drag the zoom pointer toward the bottom of the iTool window to make the 
display smaller
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4. Click on the arrow Select button to leave Zoom mode and return to Select 
mode. The mouse pointer changes to an arrow pointer. In Select mode, 
dragging the arrow pointer positions the zoomed image.

The view zoom combobox is located just to the right of the view zoom manipulator 
button on the toolbar and always reports the zoom factor of the currently selected 
view. You can also use this combobox to set a requested zoom factor for the currently 
selected view by simply using the pull-down menu to select a value.
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View Panning

The view pan button appears on the iTool’s toolbar as a hand (shown depressed 
below) and allows panning within an iTool view by clicking and dragging the mouse. 

Notice that panning will only be possible if the iTool view is not completely within 
the window, or the iTool view is larger than viewable area of the window.

Figure 4-7: 
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Adding Annotations
This chapter describes the following common tasks that can be performed with all of the IDL 
Intelligent Tools:
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Introduction

The six Standard IDL iTools supplied in the IDL distribution (iImage, iPlot, iSurface, 
iContour, iVolume, and iMap) each posses common annotation capabilities. This 
chapter describes this common annotation functionality and how it can be used. 

Note
This chapter describes Annotation functionality for only the Standard IDL iTools, 
those iTools supplied in the IDL distribution. Other iTools written by users and 
third-party developers share a common interface with the RSI iTools because the 
iTools framework is used to create all iTools. However, the specific functionality of 
such iTools may be different from the functionality of the iTools described here.
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Legends

Legends identify the visualizations displayed in the iTool window. For example, a 
legend displayed in an iPlot window can include a description of each plot line in a 
plot. Or a legend can be displayed in an iSurface window to identify surfaces and 
contour levels displayed on those surfaces.

To insert a legend for a surface or contour:

1. Select specific items to include in the legend, or click in an empty area of the 
iSurface window dataspace to select the dataspace and include all items in the 
legend.

2. Select Insert → New Legend.

To add to a legend:

1. Select the visualization item or items to add to the legend.

2. If there are multiple legends, add the desired legend to the selection by shift-
clicking the legend border.

3. Select Insert → Legend Item.

Note
Only a single legend item may exist for a given visualization. If you are inserting 
multiple visualization items into an existing legend, only legend items for those 
visualizations not already represented will be added to the legend.
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Each legend entry consists of a sample and a label. For example, in Figure 5-1, the 
sample for the first entry is an unbroken line of thickness 1, and the label is Noisy 
Sine Plot. The sample for the second is a broken blue line of thickness 2, and the label 
is Clean Sine Plot.

Tip
To alter your legend’s properties such as in the example shown previously, display 
the property sheet. To do this, double-click the border of the legend box.

Figure 5-1: Legend for Two Plot Lines
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Annotations

The following types of annotations can be added to iTool visualizations:

Note
Annotations are 2-D in nature and are defined in their own data space. They are 
most useful for adding notes to a data visualization for which the orientation has 
been finalized.

Text Annotations

To add a text annotation:

1. Click the Text Annotation button  on the toolbar. 

2. Click anywhere on the canvas. A text insertion bar appears where you click.

3. Type the annotation text.

• To add a new line, press Ctrl + Enter

• To add superscript characters, press Ctrl + U

Annotation 
Type Description

Text Single lines or multiple lines of text can be added to a 
visualization to provide a label or description.

Line Straight line annotations can be added to a visualization to link 
labels to objects or to identify an object.

Rectangle Rectangular annotations can be added to a visualization to 
identify rectangular areas.

Oval Oval annotations can be added to a visualization to identify 
circular areas.

Polygon Polygon annotations can be added to a visualization to identify 
areas bounded by a multi-sided polygon.

Freehand Freehand annotations can be added to a visualization to 
identify an area.

Table 5-1: Types of Annotations
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• To add subscript characters, press Ctrl + D

• To return to normal characters, press Ctrl + N

Note
For information on how to embed these and other formatting commands from 
the Text Annotation property sheet, refer to “Text Annotation Properties” in 
Appendix D.

4. Press Enter. A bounding box appears around the annotation text.

• To position the annotation, position the mouse pointer within the bounding 
box so that it changes to a translation pointer . Click and drag the 
annotation to the desired location.

• To display and modify text annotation properties such as font, text color 
and transparency, double-click the bounding box or inside the bounding 
box.

Line Annotations

To add a line annotation:

1. Click the Line Annotation button  on the toolbar.

2. Click in an empty part of the canvas and, without releasing the mouse button, 
drag to draw a line of the desired length.

• To constrain in the direction that you are drawing, hold down the Shift key 
while drawing

• To draw the line from the center, hold down the Ctrl key while drawing

3. Release the mouse button. Selection handles appear at both ends of the line 
annotation.

• To position the line annotation, position the mouse pointer over the 
selected line so that it changes to a translation pointer . Click and drag 
the annotation to the desired location.

• To resize the line annotation, position the mouse pointer over the selection 
handle at one end of the line so that it changes to a resize pointer . Click 
and drag the selection handle to obtain the desired line length.

• To display and modify line annotation properties such as line thickness and 
arrow style, double-click the annotation.
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Rectangle Annotations

To add a rectangle annotation:

1. Click the Rectangle Annotation button  on the toolbar.

2. Click in an empty part of the canvas and, without releasing the mouse button, 
drag to draw a rectangle of the desired size.

• To constrain the rectangle to a square, hold down the Shift key while 
drawing

• To draw the rectangle from the center, hold down the Ctrl key while 
drawing

3. Release the mouse button. Selection handles appear at the corners and sides of 
the rectangle annotation.

• To position the rectangle annotation, position the mouse pointer inside the 
selected rectangle so that it changes to a translation pointer . Click and 
drag the annotation to the desired location.

• To resize the rectangle annotation, position the mouse pointer over the 
selection handle on one side of the rectangle so that it changes to a resize 
pointer . Click and drag the selection handle to obtain the desired shape.

• To scale the rectangle annotation, position the mouse pointer over the 
selection handle at one corner of the rectangle so that it changes to an 
unconstrained scaling pointer . Click and drag the selection handle to 
obtain the desired scaling.

• To display and modify rectangle annotation properties such as background 
color and transparency, double-click the annotation.

Oval Annotations

To add an oval annotation:

1. Click the Oval Annotation button  on the toolbar.

2. Click in an empty part of the canvas and, without releasing the mouse button, 
drag to draw a circular annotation of the desired size.

• To constrain the oval to a circle, hold down the Shift key while drawing.

• To draw the oval from the center, hold down the Ctrl key while drawing.

3. Release the mouse button. Selection handles appear at the corners and sides of 
the oval annotation.
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• To position the oval annotation, position the mouse pointer inside the 
selected oval so that it changes to a translation pointer . Click and drag 
the annotation to the desired location.

• To resize the oval annotation, position the mouse pointer over the selection 
handle on one side of the oval so that it changes to a resize pointer . 
Click and drag the selection handle to obtain the desired shape.

• To scale the oval annotation, position the mouse pointer over the selection 
handle at one corner of the oval so that it changes to an unconstrained 
scaling pointer . Click and drag the selection handle to obtain the 
desired scaling.

• To display and modify oval annotation properties such as background 
color and transparency, double-click the annotation.

Polygon Annotations

To add a polygon annotation:

1. Click the Polygon Annotation button  on the toolbar.

2. Click in an empty part of the canvas to specify the first point of the polygon.

3. Click again to specify the second point of the polygon. A line is drawn to 
connect the first and second points.

4. Click to specify the third and each consecutive point of the polygon. Lines are 
drawn to connect each subsequent point, forming a multi-sided shape. 

Tip
To remove the last point, press the Esc key.

5. Double-click to specify the last point of the polygon. Selection boxes appear at 
the corners and sides of the newly-created annotation.

• To position the polygon annotation, position the mouse pointer inside the 
selected polygon so that it changes to a translation pointer . Click and 
drag the annotation to the desired location.

• To resize the polygon annotation, position the mouse pointer over the 
selection handle on one side of the polygon so that it changes to a resize 
pointer . Click and drag the selection handle to obtain the desired shape.

• To scale the polygon annotation, position the mouse pointer over the 
selection handle at one corner of the polygon so that it changes to an 
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unconstrained scaling pointer . Click and drag the selection handle to 
obtain the desired scaling.

• To display and modify polygon annotation properties such as background 
color and transparency, double click the annotation.

Freehand Annotations

To add a freehand annotation:

1. Click the Freehand Annotation button  in the toolbar.

2. Click in an empty part of the canvas and, without releasing the mouse button, 
drag to draw a freehand shape.

3. Release the mouse button. Selection handles appear at the corners and sides of 
the selected freehand annotation.

• To position the freehand annotation, position the mouse pointer inside the 
selected freehand shape so that it changes to a translation pointer . Click 
and drag the annotation to the desired location.

• To resize the freehand annotation, position the mouse pointer over the 
selection handle on one side of the freehand shape so that it changes to a 
resize pointer . Click and drag the selection handle to obtain the desired 
shape.

• To scale the freehand annotation, position the mouse pointer over the 
selection handle at one corner of the freehand shape so that it changes to an 
unconstrained scaling pointer . Click and drag the selection handle to 
obtain the desired scaling.

• To display and modify rectangle annotation properties such as background 
color and transparency, double-click the annotation.
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Additional Axes

By default, X, Y, and (for 3-D data spaces) Z axes are displayed in the iTool window. 
The display of these axes is controlled by property sheets for the axes container and 
for individual axes (see “Axes” in Appendix D). Additional X, Y or Z axes can be 
added to most data spaces to make it easier to identify characteristics.

To add an additional axis to your data space:

1. Select the data space.

2. Select Insert → Axis.

3. Choose from the following options:

• X axis

• Y axis

• Z axis

Use the mouse to position the new axis, and double-click the axis to display the axis 
property sheet.

Note
For a 3-D visualization, you can use the Shift + Ctrl to translate an axis in the 
opposite direction. This will be shown in the Status message when an axis is 
selected for translation. You can also use the arrow keys to change axes placement 
direction.
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Property Sheets 
and Browsers
This chapter describes the following common tasks that can be performed with all of the IDL 
Intelligent Tools:
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Introduction

The six Standard IDL iTools supplied in the IDL distribution (iPlot, iSurface, 
iContour, iVolume, and iMap) each share several common property sheets and 
browsers. This chapter discusses those property sheets and browsers and their uses.

Note
This chapter describes only the Standard IDL iTools, those iTools supplied in the 
IDL distribution. Other iTools written by users and third-party developers share a 
common interface with the RSI iTools because the iTools framework is used to 
create all iTools. However, the specific functionality of such iTools may be different 
from the functionality of the RSI iTools described here.
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Property Sheets

Most iTool visualizations and operations have attributes or properties that can be 
modified to change their characteristics. These properties are organized into property 
sheets for each operation and visualization type. For example, the skin of a surface 
visualization has a gold color by default. To change this color, modify the surface 
color property in the surface visualization property sheet.

A property sheet consists of rows and columns. The left-most column identifies the 
properties, and the other column or columns identify the property values of one or 
more objects. A single property value can be selected at one time. When a single 
property value is clicked on, the associated property name appears indented. In the 
Style Editor and Macro Editor, multiple properties can be selected at a single time as 
shown in the following figure. Hold down the Ctrl key while left-clicking with the 
mouse to make nonadjacent selections, or hold down the Shift key to select an 
adjacent range of properties. 

Figure 6-1: Property Sheet with Multiple Property Selections
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Visualization Property Sheets

Visualization property sheets can be displayed from the Visualization Browser or 
from the iTool window.

To display a visualization’s property sheet from the Visualization Browser:

1. Select Window → Visualization Browser.

2. Select the name of the object in the Visualization Browser list. The object’s 
properties are displayed in the right-hand pane of the Visualization Browser 
window (the small arrows at the top-left of the Browser window will allow you 
to display both panes).

To display a visualization’s property sheet from the iTool window:

1. Click to select the object in the iTool window.

2. Do one of the following to display the property sheet for the selected 
visualization:

• Double-click the visualization in the iTool window

• Select Edit → Properties

• Right-click to display the Context Menu, and select the Properties menu 
item

Note
For detailed information on Visualization Browser properties, see Appendix D, 
“Visualization Properties”.
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Operations Property Sheets

Operations property sheets can only be displayed from the Operations Browser. To 
display an operations property sheet:

1. Select Operations → Operations Browser.

2. Select the name of the operation in the Operations Browser list. The operation 
properties are displayed in the right-hand pane of the Operations Browser 
window (the small arrows at the top-left of the Browser window will allow you 
to display both panes).

Note
For detailed information on Operations Browser properties, see Appendix C, 
“Operations Properties”.
iTool User’s Guide Property Sheets
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The Visualization Browser

The Visualization Browser provides access to visualizations (objects displayed in the 
iTool window) and the properties of those visualizations. When the Visualization 
Browser is displayed, you can select graphical objects from a nested list and display 
the property sheets for those objects. For example, if a surface visualization is 
displayed and you would like to change the appearance of the X axis in that 
visualization, you can select the axis in the Visualization Browser (Figure 6-2), 
display the property sheet for that axis (Figure 6-3), and modify the properties to 
change the appearance of the axis.

To select an object with the visualization browser:

1. Select Window → Visualization Browser.

2. Select the name of the object in the list. The element is highlighted in the iTool 
window.

• To expand a list item, click the + icon 

• To collapse an expanded list item, click the - icon 

Figure 6-2: Visualization Browser with Axis 0 Selected

Property Sheet Expansion ButtonElement name selected

Element highlighted in iTool window
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3. To display the property sheet for the object, click the expansion button to the 
right of the list or double-click the property.

4. To change a property setting, click in the settings column. 

• If a drop-down button  appears in the settings column, click the button 
to choose a new setting from the list of options, activate a slider to change 
the setting value, display a selection dialog or list, or display an Edit button 
providing access to a user-defined property control.

• If the text is editable, edit the text to change the setting.

See Appendix B, “Property Controls” for a detailed description of the 
types of property settings included in property sheets.

5. Click the Close button  to close the Visualization Browser.

Figure 6-3: Visualization Browser with Property Sheet Displayed
iTool User’s Guide The Visualization Browser
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Note
Properties of standard graphical objects are described in detail in Appendix D, 
“Visualization Properties” and in the “IDL Commands” chapter of the IDL 
Reference Guide.
The Visualization Browser iTool User’s Guide
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The Operations Browser

The Operations Browser provides a quick way to display and modify the properties 
for a given iTool operation (task performed on iTool data) before that operation is 
performed. For example, to display the properties of the Convolution filter, select the 
name of the filter in the left pane of the Operations Browser (see Figure 6-4), and 
modify the Scale factor property value in the right pane to change the default scale 
factor for convolution. 

The Operations Browser displays a nested list of operations available in the current 
iTool in the left pane, and a property sheet for the currently selected operation in the 
right pane. 

• To expand a list item, click the + icon 

• To collapse an expanded list item, click the - icon 

To change the properties of an operation from the Operations Browser:

1. Select Operations → Operations Browser.

2. Select the name of the operation in the list. A list of properties and the property 
settings appears in the right-hand pane of the Operations Browser window.

3. Locate the property you want to change in the list, and click in the settings 
column. 

Figure 6-4: Operations Browser with Convolution Filter Properties Displayed
iTool User’s Guide The Operations Browser
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• If a drop-down button  appears in the settings column, click the button 
to choose a new setting from the list of options, activate a slider to change 
the setting value, display a selection dialog or list, or display an Edit button 
providing access to a user-defined property control.

• If the text is editable, edit the text to change the setting.

See Appendix B, “Property Controls” for a detailed description of the 
types of property settings included in property sheets.

4. Click the Close button  to close the Operations Browser.

Note
Properties of standard iTool operations are described in Appendix C, “Operations 
Properties” and in the “IDL Commands” chapter of the IDL Reference Guide.
The Operations Browser iTool User’s Guide
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The Preferences Browser 

The Preferences Browser provides a means of setting preferences, or default 
properties, for the general settings and file readers and writers used by all iTools. For 
example, if you prefer default drag quality to be low rather than high, you can change 
the default property for Default drag quality from High to Low in the Preferences 
Browser, as shown in Figure 6-5.

For more information on the property sheets displayed in the right-hand pane of the 
Preferences Browser, see Appendix D, “Visualization Properties”.

The Preferences Browser displays a nested list of general preferences, file readers, 
and file writers available for all iTools in the left pane, and a property sheet for the 
currently selected item in the right pane. 

• To expand a list item, click the + icon 

• To collapse an expanded list item, click the - icon 

To change the properties of a general setting, file reader, or file writer from the 
Preferences Browser:

1. Select File → Preferences.

Figure 6-5: Preferences Browser with Contour Projection Properties Displayed
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2. Select the name of the general setting, file reader, or file writer in the list. A list 
of properties and the current property settings appears in the right-hand pane of 
the Preferences Browser window.

3. Locate the property you want to change in the list, and click in the settings 
column. 

• If a drop-down button  appears in the settings column, click the button 
to choose a new setting from the list of options, activate a slider to change 
the setting value, display a selection dialog or list, or display an Edit button 
providing access to a user-defined property control.

• If the text is editable, edit the text to change the setting.

See Appendix B, “Property Controls” for a detailed description of the 
types of property settings included in property sheets.

4. Click the Close button  to close the Preferences Browser.

Note
Changes to preferences are saved between iTool sessions. When the OK button is 
clicked, preferences are saved in their current state.

General Settings 

The first option on the Preferences Browser is the General Settings option. Settings 
listed here will be applied to all iTools if altered. The properties listed here are:

Property Control Type: Values

Unlimited Buffer Boolean: Set to determine buffer size as limited or unlimited:

• True

• False

Default = True

Zoom on Window 
Resize

Boolean: Set to determine if iTool data resizes upon window 
resizing:

• True

• False

Default = False

Table 6-1: General Settings Properties
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Note
The Restore Defaults button at the bottom of the Preferences Browser restores all 
default settings immediately.

Change directory 
on open

Boolean: Set to be prompted to change directory upon open:

• True

• False

Default = True

Default working 
directory

Select Edit to bring up the Browse for folder dialog. 

Default = none

Default style Boolean: Select from existing style list. 

Default = none

Default drag 
quality

Boolean: Set the window drag quality. 

• Low

• Medium

• High

Default = High

Printer output 
format

Boolean: Set the format for printing output. 

• Bitmap

• Vector

Default = Bitmap

Clipboard output 
format

Boolean: Set the output format for clipboard copied data.

• Bitmap

• Vector

Default = Bitmap

Property Control Type: Values

Table 6-1: General Settings Properties (Continued)
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File Readers 

Select this folder to edit file reader preferences and properties. Available file reader 
types and their editable properties are listed in the following tables. For more 
information on reading in data of various types, see Chapter 2, “Importing and 
Exporting Data”.

iTools State

The iTools State File Reader properties are:

Windows Bitmap

The Windows Bitmap File Reader properties are:

Joint Photographic Experts Group

The Joint Photographic Experts Group File Reader properties are:

Property Control Type: Values

None The iTools State File Reader has no configurable properties 
other than Name and Description.

Table 6-2:  iTools State File Reader Properties

Property Control Type: Values

None The Windows Bitmap File Reader has no configurable 
properties other than Name and Description.

Table 6-3: Windows Bitmap File Reader Properties

Property Control Type: Values

None The Joint Photographic Experts Group File Reader has no 
configurable properties other than Name and Description.

Table 6-4:  Joint Photographic Experts File Reader Properties
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JPEG2000

The JPEG2000 File Reader properties are:

Macintosh PICT

The Macintosh PICT File Reader properties are:

Property Control Type: Values

Levels to discard A droplist giving the number of highest resolution levels 
which will not appear in the result. Image dimensions are 
divided by 2 to the power of this number. For example, if the 
image in the object has dimensions of 1024 x 1026, and 
DISCARD_LEVELS is set to 3, the resulting image will have 
dimensions of 128 x 129, which is the ceiling of [1024, 1026] 
divided by 23. The default is "None", implying that the full 
resolution image will be returned.

Quality layers A droplist giving the maximum number of quality layers 
which will be returned in the result. Each layer contains the 
information required to represent the image at a higher quality, 
given the information from all the previous layers. A value of 
"All", the default, implies that all layers should be returned. 

Table 6-5:  JPEG2000 File Reader Properties

Property Control Type: Values

None The Macintosh PICT File Reader has no configurable 
properties other than Name and Description.

Table 6-6:  Macintosh PICT File Reader Properties
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Portable Network Graphics

The Portable Network Graphics File Reader properties are:

Tag Image File Format

The Tag Image File Format File Reader properties are:

Property Control Type: Values

None The Portable Network Graphics File Reader has no 
configurable properties other than Name and Description.

Table 6-7:  Portable Network Graphics File Reader Properties

Property Control Type: Values

Image index Number: Level at which to begin image index. Edit the 
number to change the value. Default = 0

Image Stacking String List: Image stacking method. Select a method from the 
list. Choose between these values:

• +X

• -X

• +Y

• -Y

• +Z

• -Z

Default = Read Single Image

Table 6-8:  Tag Image File Format File Reader Properties
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DICOM Image

The DICOM Image File Reader properties are:

Windows Waveform Audio Stream

The Windows Waveform Audio Stream File Reader properties are:

ESRI Shapefile

The ESRI Shapefile File Reader properties are:

Property Control Type: Values

None The DICOM Image File Reader has no configurable properties 
other than Name and Description.

Table 6-9:  DICOM Image File Reader Properties

Property Control Type: Values

None The Windows Waveform Audio Stream File Reader has no 
configurable properties other than Name and Description.

Table 6-10:  Windows Waveform Audio Stream File Reader Properties

Property Control Type: Values

Combine all 
shapes

Boolean: If True then combine all of the shapes within the file 
into a single visualization (ShapePolygon, ShapePolyline, or 
ShapePoint). The default is to create a separate visualization 
for each shape.

Name attribute String List: If the shapefile has attributes associated with each 
shape, then the Shapefile reader will attempt to use one of 
these attributes for the Name of the newly-created data and 
visualizations. The droplist contains all of the available 
attributes, and allows you to choose a different attribute to be 
used for the visualization name. If "Combine all shapes" is 
True then this property is insensitive, and the filename will be 
used for the Name of the resulting data and visualization.

Table 6-11:  ESRI Shapefile File Reader Properties
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ASCII text

The ASCII text File Reader properties are:

Binary data

The Binary data File Reader properties are:

Property Control Type: Values

None The ASCII text File Reader has no configurable properties 
other than Name and Description.

Table 6-12:  ASCII Text File Reader Properties

Property Control Type: Values

None The Binary data Graphics File Reader has no configurable 
properties other than Name and Description.

Table 6-13:  Binary Data File Reader Properties
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File Writers 

Select this folder to edit file write preferences and properties. Available file writer 
types and their editable properties are shown in the following tables. For more 
information on writing data of various types, see Chapter 2, “Importing and 
Exporting Data”.

iTools State

The iTools State File Writer properties are:

Windows Bitmap

The Windows Bitmap File Writer properties are:

Property Control Type: Values

None The iTool State File Writer has no configurable properties 
other than Name and Description.

Table 6-14:  iTools State File Writer Properties

Property Control Type: Values

Bit depth String List: Bit depth in bits. Select a depth from the list. 
Choose between these values:

• Automatic

• 8 bit

• 24 bit

Default = Automatic

Table 6-15:  Windows Bitmap File Writer Properties
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Encapsulated Postscript

The Encapsulated Postscript File Writer properties are:

Windows Enhanced Metafile

The Windows Enhanced Metafile File Writer properties are:

Joint Photographic Experts Group

The Joint Photographic Experts Group File Writer properties are:

Property Control Type: Values

Graphics format Bitmap or Vector: Render graphics using bitmap or vector 
output

Note - Only a Window or View can be exported to EPS.

Color model RGB or CMYK

Table 6-16:  Encapsulated Postscript File Writer Properties

Property Control Type: Values

Graphics format Bitmap or Vector: Render graphics using bitmap or vector 
output

Note - Only a Window or View can be exported to EMF.

Table 6-17:  Windows Enhanced Metafile File Writer Properties

Property Control Type: Values

Color String List: Select a depth from the list. Choose between these 
values:

• TrueColor

• Grayscale

Default = TrueColor

Table 6-18:  Joint Photographic Experts Group File Writer Properties
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JPEG2000

The JPEG2000 File Writer properties are:

Macintosh PICT

The Macintosh PICT File Writer properties are:

Quality Number: Factor from 0 - 100 determining the level of quality. 
Move slider to change the level.

Default = 75

Property Control Type: Values

Reversible Boolean: Use reversible (lossless) compression.

Wavelet levels Number: The number of wavelet decomposition levels, or 
stages, in the range of 0...15. Higher values take longer to store 
and read, but may give better compression. The default is 5.

Quality layers Number: A positive integer specifying the number of quality 
layers. Each layer contains the information required to 
represent the image at a higher quality, given the information 
from all the previous layers. A larger number of layers takes 
longer to encode and produces a larger file, but provides more 
flexibility when decoding. 

Table 6-19:  JPEG2000 File Writer Properties

Property Control Type: Values

None The Macintosh PICT File Writer has no configurable 
properties other than Name and Description.

Table 6-20:  Macintosh PICT File Writer Properties

Property Control Type: Values

Table 6-18:  Joint Photographic Experts Group File Writer Properties 
iTool User’s Guide The Preferences Browser



108 Chapter 6: Property Sheets and Browsers
Portable Network Graphics

The Portable Network Graphics File Writer properties are:

Tag Image File Format

The Tag Image File Format File Writer properties are:

Property Control Type: Values

Bit depth String List: Bit depth in bits. Select a depth from the list. 
Choose between these values:

• Automatic

• 8 bit

• 24 bit

Default = Automatic

Table 6-21:  Portable Network Graphics File Writer Properties

Property Control Type: Values

Bit depth String List: Bit depth in bits. Select a depth from the list. 
Choose between these values:

• Automatic

• 8 bit

• 24 bit

Default = Automatic

Compression String List: Compression type. Select a type from the list. 
Choose between these values:

• None

• Packbits

• JPEG

Default = None

Table 6-22:  Tag Image File Format File Writer Properties
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ASCII text

The ASCII text File Writer properties are:

Binary data

The Binary data File Writer properties are:

Property Control Type: Values

Separator Enter a value.

Default = None

Use default 
format

Boolean: Use default format? Choose True or False. 

Default = True

Format string Number: Enter a number to change the value. 

Default = G9.2

Table 6-23:  ASCII Text File Writer Properties

Property Control Type: Values

Byte ordering String List: Byte ordering type. Select from the list. Choose 
between these values:

• Native

• Little endian

• Big endian

Default = Native

Table 6-24:  Binary Data File Writer Properties
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Common Operations
This chapter describes the following common tasks that can be performed with all of the IDL 
Intelligent Tools:
Introduction . . . . . . . . . . . . . . . . . . . . . . . .  112
Window Layouts  . . . . . . . . . . . . . . . . . . . .  113
File Operations  . . . . . . . . . . . . . . . . . . . . .  115
Rotation . . . . . . . . . . . . . . . . . . . . . . . . . . .  118
Transformations . . . . . . . . . . . . . . . . . . . . .  122

Filtering  . . . . . . . . . . . . . . . . . . . . . . . . . .  125
Morphing  . . . . . . . . . . . . . . . . . . . . . . . . .  130
Additional Operations  . . . . . . . . . . . . . . .  131
Rendering Translucent Objects  . . . . . . . .  135
Operations on Regions of Interest  . . . . . .  136
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Introduction

The six Standard IDL iTools supplied in the IDL distribution (iPlot, iSurface, 
iContour, iVolume, and iMap) each have many common operations. This chapter 
discusses the use of these common operations.

Note
This chapter describes only the Standard IDL iTools, those iTools supplied in the 
IDL distribution. Other iTools written by users and third-party developers share a 
common interface with the RSI iTools because the iTools framework is used to 
create all iTools. However, the specific functionality of such iTools may be different 
from the functionality of the iTools described here.
Introduction iTool User’s Guide
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Window Layouts

You can change the minimum size of the canvas displayed in the iTool window, 
display multiple views in the iTool window, or select a preset arrangement of views, 
with the Window Layout dialog. 

Note
If you are in Freeform mode, canvas size can also be changed interactively by 
dragging the corners or sides of the iTool window.

To change the minimum size of the canvas displayed in the iTool window:

1. Select Window → Layout.

2. Edit the pixel values in the Width and Height text boxes (Default = Width 
512, Height 384). A preview of the shape of the new canvas size is displayed in 
the Preview window.

3. Click OK to apply the changes or Cancel to close the window without 
applying changes.

To change the number of views displayed:

1. Select Window → Layout.

2. Select Gridded from the Layout list.

3. Edit the number of columns and rows in the Grid text boxes (Default = 1 by 1).

Figure 7-1: Window Layout Tool
iTool User’s Guide Window Layouts
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4. Click OK to apply the changes or Cancel to close the window without 
applying changes.

To select a preset arrangement of views:

1. Select Window → Layout.

2. Select from the following arrangements in the Layout list:

3. Click OK to apply the changes, or Cancel to close the window without 
applying changes.

1 x 1 Gridded Trio Left

Inset Trio Right

Trio Top Freeform

Trio Bottom
Window Layouts iTool User’s Guide
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File Operations

File operations are provided in the iTools to allow you to open files, save files, import 
variables and files, export variables, or export the contents of the iTool window as an 
image file. Printing and exiting the iTool are additional file operations.

Opening Files

Data files, text files, and previously saved iTools State (*.isv) files can be opened 
with File → Open. For more information on opening files, see “Using File Open” on 
page 30.

Importing Variables and Files

IDL variables and files can be imported into the current iTool with File → Import. 
The IDL Data Import Wizard offers you the choice of importing a variable or a file, 
and then asks you to identify the location of the data source and the type of 
visualization to be created with the data. 

Import a Variable

The Data Import Wizard can import an IDL variable created at the IDL command line 
or exported from an iTool session into the current iTool. For more information on 
importing variables, see “Importing Data From the IDL Session” on page 44.

Import a File

The Data Import Wizard can import text files, data files, or image files into the 
current iTool. For more information on importing files, see “Importing ASCII Data” 
on page 32, “Importing Binary Data” on page 36, or “Importing Image Data” on 
page 32.

Saving Files

The current state of the iTool can be saved as an iTools State (*.isv) file. Whenever 
you close an iTool window, you will be prompted to save the current state as an 
*.isv file so that you can return to the current state of the data later when you open 
the *.isv file. Other IDL users running IDL 6.1 for Windows, UNIX or Mac OS X 
can open *.isv files.
iTool User’s Guide File Operations
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Save

File → Save saves the state of the current iTool to a file. If the file has already been 
saved, it will be saved under the same filename it was previously saved under. If the 
state has not been previously saved and has no filename, enter a filename. The saved 
file can be opened by IDL on either the Windows or the UNIX platform.

Save As...

File → Save As also saves the state of the current iTool to a file, but it prompts you to 
enter a filename even if the file has been saved previously. Use Save As to save an 
existing iTools State file under a different name.

Exporting Variables and Files

Data items created within the current iTool can be exported as IDL Variables, and the 
contents of the current iTool window can be exported as an image file. Select 
File → Export, and follow the instructions in the IDL Data Export Wizard.

Export as a Variable

Data from the currently selected object can be exported as a variable from the IDL 
Data Export Wizard to the main IDL program.

For more information, see “Exporting Data to the IDL Session” on page 51.

Export as a File

The contents of the current window can be exported from the IDL Data Export 
Wizard as an image file.

For more information, see “Exporting Data to a File” on page 48.

Printing

File → Print sends the current view of the contents of the graphics window to the 
specified printer via the standard Windows or Motif printer dialog. If the contents 
have been modified in the current view, they will appear modified in the printer 
output.

To print the contents of the graphics window:

1. Select File → Print. The standard Windows or Motif printer dialog appears.

2. Select the desired printer and printer properties from the printer dialog. 
File Operations iTool User’s Guide



Chapter 7: Common Operations 117
3. Click Print. The contents of the graphics window are sent to the chosen 
printer, with the chosen options.

Exiting the iTool

Clicking the Close button  on the iTool window will close the selected window. 
File → Exit also closes the iTool window. You will be prompted to save any changes 
to the current state (see File → Save above for details). All visualizations and views 
within the window are removed from memory. 
iTool User’s Guide File Operations



118 Chapter 7: Common Operations
Rotation

The iTools provide a number of ways to rotate graphical objects. Objects that are 3-D 
can be rotated freely or along an axis using the mouse. In addition, both 2-D and 3-D 
objects can be rotated left or right in 90-degree increments, or they can be rotated by 
a specified number of degrees. These tools rotate the entire data space.

Note
Special consideration should be given when attempting to rotate a graphic image 
object within iImage. See for more details.

Mouse Rotation

To rotate a 3-D object with the mouse:

1. Select the object in the iTool window.

2. Click Rotate  on the toolbar to enter Rotate mode. The rotation sphere, 
consisting of circular x-, y-, and z-dimension axes, is displayed around the 
object, as illustrated in Figure 7-2 and Figure 7-3:

3. 3-D objects can be constrained to rotate only along one of the three displayed 
axes, or they can be rotated freely.
Rotation iTool User’s Guide
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• To rotate an object along an axis, position the mouse pointer on the axis. 
The constrained rotation pointer  is displayed. Drag in the desired 
direction to rotate the object along the selected axis.

Figure 7-2: Rotating a 3-D Object
iTool User’s Guide Rotation
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• To rotate an object freely, position the mouse pointer anywhere on the 
object.The free rotation pointer  is displayed. Drag in any direction to 
rotate the object in that direction.

4. Click  or select Edit → Undo to undo the rotation, or click  to leave 
rotate mode.

Rotate Left and Rotate Right

To rotate a selected 2-D or 3-D object 90° left or right, select 
Operations → Rotate → Rotate Left or Operations → Rotate → Rotate Right.

Note
For three-dimensional objects, the rotation is about the Z axis.

Figure 7-3: Free Rotation
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Rotate by Specified Angle

To rotate a selected 2-D or 3-D object a specific number of degrees, select 
Operations → Rotate → Rotate by Angle, specify the number of degrees in the 
Rotate Angle dialog, and click OK.

Note
For two-dimensional objects (such as plots, images, annotations, contours, and so 
on) the angle is absolute. The rotation angle is remembered and displayed in the 
Rotate By Angle dialog. So for example, you can set the angle to zero degrees to 
make your visualization angle rotate back to zero.

Figure 7-4: Rotate Angle Dialog
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Transformations

Three types of transforms are common to all iTools: Resample, Rotate Data, and 
Scale Data.

Resample

The Resample transform resamples the selected data. Resampling operation 
properties include factors for each dimension of the data, as well as the interpolation 
method to be used. 

For example, if the X, Y, or Z value of a visualization needs to be different from the 
original data value, you can resample the data to adjust the X, Y, or Z value by the 
specified resample factor. Or, if the default interpolation method produces 
undesirable artifacts in the visualization of the data, you can resample the data with a 
different interpolation method.

To resample data:

1. Select one or more objects in the iTool window for resampling.

2. Select Operation → Transform → Resample.

3. Use the property sheet that appears to specify the resampling factor in each 
dimension, along with the interpolation method. See “Resample Properties” on 
page 377 for details.

4. Click OK to resample the data, or Cancel to abort the operation.

Figure 7-5: Resample Dialog
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Note
For more information on the iTool’s Operations Browser, see Appendix C, 
“Operations Properties”.

Rotate Data

The Rotate Data transform makes it possible to rotate the data within the visualization 
by a specified number of degrees without affecting the rest of the data space 
(graphical objects and axes).

To rotate data:

1. Select the visualization.

2. Select Operation → Transform → Rotate Data. The Rotate Data dialog is 
displayed.

3. Specify the number of degrees to rotate by clicking the up-down control, or by 
editing the text.

4. Click OK.

Figure 7-6: Rotate Data Dialog
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Scale Data

The Scale Data transform makes it possible to scale the data within an object by a 
specified scale factor.

To scale data:

1. Select one or more objects which contain the data to be scaled.

2. Select Operations → Scale Data. The Scale Data dialog appears.

3. Change the scale factor, if necessary, by editing the number in the Scale Factor 
field, and click OK to scale the selected object(s) or Cancel to close the Scale 
Data dialog without scaling the object(s).

Figure 7-7: Scale Data Dialog
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Filtering

Four types of filters are common to all iTools: Smooth filtering, Median Filtering, 
Convolution, and Unsharp Masking.

Smooth Filter

To remove unwanted noise from data, apply the Smooth filter to the data.

To apply the Smooth filter:

1. Select the data that you want to smooth.

2. Select Operations → Filter → Smooth.

3. The smooth filter editor appears (as shown in the following figure) and desired 
settings can be edited.

4. Click OK and the filter is applied.

Median Filter

Median smoothing replaces each point with the median (a value in an ordered set of 
values with an equal number of values above and below it) of the one- or two-

Figure 7-8: The Smooth Filter Editor
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dimensional neighborhood of a given width. It is similar to smoothing with a boxcar 
or average filter, but does not blur edges larger than the neighborhood. Median 
filtering is effective in removing “salt and pepper” noise (isolated high or low values). 

To apply the Median filter:

1. Select the data that you want to smooth.

2. Select Operations → Filter → Median.

3. The median filter editor appears (as shown in the following figure) and desired 
settings can be edited.

4. Click OK and the filter is applied.

Figure 7-9: The Median Filter Editor
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Convolution Filter

To convolve data:

1. Select the data to be convolved.

2. Select Operations → Filter → Convolution. The Convolution Kernel Editor 
window is displayed.

3. Change Convolution Kernel Editor settings as necessary by modifying any of 
the following:

• Select a filter type from the list. The default filter is named Default.

• Edit the number of Columns and Rows, if necessary.

• Choose between a One Dimensional and a Two Dimensional 
convolution.

• Scaling is automatic by default. To choose a different scaling factor, clear 
the Automatic scaling check box and enter a new factor in the Scale by 
text box.

• Position is Centered by default. Clear the check box to turn centering off.

Figure 7-10: Convolution Kernel Editor
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• Edges Wrap by default. To choose a different edge format, select Zero or 
Repeat from the list.

• If Show dialog next time is selected, the Convolution Kernel Editor 
window will be displayed the next time the Convolution filter is selected. 
Clear the check box to apply the filter without displaying the dialog.

4. Click OK to apply the filter with the current settings and close the Convolution 
Kernel Editor window, or click Cancel to close the window without applying 
the filter.
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Unsharp Mask Filter

An unsharp-mask filter can be applied to any two-dimensional array or a TrueColor 
image. The unsharp mask enhances the contrast between neighboring pixels in an 
image, and is widely used for astronomical images and for digital photographs.

To apply the Unsharp Mask filter:

1. Select the data that you want to unsharp mask.

2. Select Operations → Filter → Unsharp Mask.

3. The unsharp mask filter editor appears (as shown in the following figure) and 
desired settings can be edited.

4. Click OK and the filter is applied.

Figure 7-11: The Unsharp Mask Filter Editor
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Morphing

Mathematical morphology is a method of processing digital images on the basis of 
shape. Morphing is available when working with images, surfaces, and contours. Six 
morphing options are available for use in iTools: dilate, erode, morph open, morph 
close, morph gradient, and morph tophat.

To apply a morphology option:

1. Select the object to be morphed.

2. Select Operations → Morph → <option>.

Morphing 
Option Description

Dilate Dilate is commonly known as “fill”, “expand”, or “grow.” It 
can be used to fill “holes” of a size equal to or smaller than the 
structuring element.

Erode  Erode does to the background what dilation does to the 
foreground. Given an image and a structuring element, erode 
can be used to remove islands smaller than the structuring 
element. 

Morph open  Morph open is simply an erosion operation followed by a 
dilation operation. Applying morph open more than once 
produces no further effect.

Morph close  Morph close is simply a dilation operation followed by an 
erosion operation. Applying morph close more than once 
produces no further effect.

Morph gradient  Morph gradient is the subtraction of an eroded version of the 
original image from a dilated version of the original image. 

Morph tophat Morph tophat is implemented by first applying the opening 
operator to the original image, then subtracting the result from 
the original image. Applying tophat shows the bright peaks 
within the image. 

Table 7-1: Morph Menu Options
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Additional Operations

The Histogram, Statistics, and Console tools display additional information about 
data displayed in the iTool windows, and about operations performed with the iTools.

Plotting a Histogram

Histogram displays a histogram plot of the data currently selected in the iTool 
window. The Histogram plot appears in a separate iPlot window.

To display a histogram plot:

1. Select an object or group of objects in the iTool window. 

2. Select Operations → Histogram.

Figure 7-12: Histogram Plot
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Displaying Statistics

The Statistics dialog displays all available statistical information pertaining to the 
object or objects currently selected in the iTool window.

To display the Statistics dialog:

1. Select an object or a group of objects in the iTools window.

2. Select Operations → Statistics. The Statistics window is displayed.

Figure 7-13: The iTools Statistics Window
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The information displayed in the Statistics window varies depending upon the type of 
objects selected.

• For scalars, the name of the variable and its value are displayed in the Statistics 
window.

• For arrays, the following information is displayed:

• Name

• Maximum and location

• Dimensions

• Standard deviation

• Mean

• Variance

• Absolute deviation

• Total

• Skewness

• Minimum & location

• Kurtosis - 3

The information in the Statistics window can be edited (by selecting Edit), printed, or 
saved as a file.

• On Windows platforms, the standard Windows editing context menu 
containing Cut, Copy, Paste and Delete commands can be displayed by right-
clicking anywhere in the Statistics window.

• On UNIX platforms, use the left or right mouse buttons to cut, copy or paste.

To save the text as an ASCII file:

1. Select File → Save As.

2. Enter a filename. If the filename already exists, you will be asked if you want 
to replace the file.

3. Select Cancel to return to the Statistics window without saving the file.

To print the text, select File → Print. The standard Windows or Motif printer dialog 
is displayed.

To close the Statistics window, select File → Close.
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Resetting Dataspace Ranges

You can reset the ranges of your data space to accommodate all your contained 
visualizations. When you reset your ranges, the following properties of the data space 
are reset to a value of True:

• Automatic X range updates

• Automatic Y range updates

• Automatic Z range updates

To reset the ranges of your data space, select Window →  Reset Dataspace Range.
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Rendering Translucent Objects

Within iTools, you can set the transparency of an object to make it appear totally 
opaque, transparent, or translucent. Isosurface objects are just such a case. Text 
objects can also be made partially transparent so that you can see through the labels 
on a complex plot and still see both the labels and the data. In the majority of 
scenarios where you will utilize opaque data objects and translucent text labeling, this 
translucent rendering works very well.

It is important to know, however, that translucent rendering does not always work 
well in more complex situations. This is because translucent objects must be strictly 
rendered from the back (far from the viewer) towards the front (closer to the viewer). 
IDL accomplishes translucent rendering by blending the pixels already drawn on the 
device with the pixels that are drawn to represent a translucent object. Therefore, it is 
important that the objects that are positioned behind the translucent object be 
rendered before the translucent object. If the ordering is not correct, then you will not 
be able to see the objects behind the translucent object.

For most cases in iTools, ordering is not a problem. If you encounter it as a problem, 
the Bring to Front (and related) operation can help you improve the appearance of 
your translucent objects. In some cases, however, the ordering is not easily 
accomplished. For example, a complex isosurface rendered as a translucent object 
does not always appear correct from all angles. 

An isosurface is composed of a large number of triangles stored in an IDLgrPolygon 
object. The triangles are always drawn in the same order, the order in which they are 
stored in the object. Thus, as the viewing angle changes, the apparent back-to-front 
ordering of the triangles also changes. In some cases, the triangles closest to the 
viewer draw first and end up blocking the view of other triangles drawn later and 
behind them that should be visible through the translucent triangles drawn first.

For all these reasons, transparency should be used with care in dealing with objects 
like a complex isosurface. The rendering of these objects ultimately may not appear 
correct.

Note
For more detailed information on alpha channel support in IDL Object Graphics, 
see “Alpha Channel and Objects” in Chapter 23 in the Using IDL manual.
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Operations on Regions of Interest

A region of interest (or ROI) is an area that contains data you wish to identify. An 
ROI can be drawn anywhere within your image and can be selected from rectangular, 
elliptical, polygonal, and freehand region of interest buttons on the iImage Image 
Panel. You can also apply operations to image data contained within an ROI area.

Some operations applied to ROIs affect the ROI data while others affect the ROI 
vertices.

Operations Modifying ROI Data

If the operation acts on the pixel values of the underlying data, the pixels that are 
contained within the ROI are changed as a result of the operation. Pixel values 
outside of the ROI area remain unchanged but pixel values within the ROI are set to 
correspond with the pixel result of the chosen operation.

Examples of operations acting upon the ROI data are:

• Filter operations including Convolution, Median, Smooth, Roberts, and Sobel

• Morphological operations

• Transform operations including scaling and inverting data

Operations Modifying ROI Vertices

If the operation acts on the vertices of the ROI itself, the vertices are changed as a 
result of the operation. If the entire image is selected for an operation, the ROI will 
follow the behavior of the entire image as the operation acts upon it. If only the ROI 
is selected, then only the ROI will respond to the operation.

Examples of operations acting upon the ROI vertices are:

• Rotate right, left, or by a specified angle

• Flip horizontal or vertical

• Region grow
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Working with Macros
This chapter describes how to use the iTool macros.
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Introduction

The macros in IDL iTools provide a shortcut mechanism that lets you quickly and 
automatically repeat a sequence of operations. You can record a series of actions in 
one iTool or several iTools, save the series as a macro, and then apply it to a new set 
of data to save you from having to repeat the actions manually.

This chapter discusses the following areas:

• More information about macros (see “What Are Macros?” on page 139)

• Recording macros (see “Recording Macros” on page 141)

• Running macros (see “Running Macros” on page 142)

• Editing macros (see “Using the Macro Editor” on page 145)

• Making selection and tool changes within a macro (see “Making Selection and 
Tool Changes” on page 167)

• Importing and exporting macros (see “Importing and Exporting Macros” on 
page 174)
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What Are Macros?

In the context of the iTools, a macro is a collection of operations and property values 
that can be applied to an existing visualization or visualizations. There are two kinds 
of macros, depending on what you have selected when you start recording. For more 
information, see “Macro Type Based on Recording Selection” on page 167.

Macros are not linked to the objects or visualizations to which they are applied. When 
you run a macro, the operations or property settings apply to the objects currently 
selected. (The macro system does include functionality to change selections and tools 
during the execution of a macro. For more information, see “Making Selection and 
Tool Changes” on page 167.) This means that property settings can be applied to 
multiple visualization types, unlike property settings in styles.

Note
Property settings in macros apply to the selection, but are not tied to visualization 
type, whereas in styles they are tied to visualization type and might or might not 
apply to selection.

The following figure shows part of the display of the Macro Editor, covered in detail 
in “Using the Macro Editor” on page 145:

Figure 8-1: A Macro in the iTools Macro Editor

This figure shows an example macro called New Macro, composed of several 
operations and property settings. Operations in this macro change the selection and 
apply the smooth operation. Property settings change the color and minor ticks 
properties.
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Macro information is stored in one or more macro files located on your system. 
Macros are stored in IDL SAVE files. Macros are stored in a subdirectory of the 
user’s .idl directory. When you create a new macro within an iTool, it will 
automatically be saved in the specified location.

Note
Macro information is never stored along with an iTool.
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Recording Macros

You can create macros in two ways:

• Using the recording functionality in the iTools Operations → Macros menu, 
described in this section

• Using the Macro Editor, described in “Using the Macro Editor” on page 145

To record a macro:

1. Start an iTool.

2. Select Operations → Macros → Start Recording, which puts the iTools 
system into recording mode.

3. Select operations or set properties as desired to create the macro.

4. Select Operations → Macros → Stop Recording to complete the recording.

Putting the iTools system into recording mode creates a new macro folder in the 
macro registry, using a unique name based on ‘New Macro’ (as shown in the macro 
tree; see “The Macro Tree” on page 148). If the New Macro folder already exists, 
then the new name is New Macro (1) and so on until the system finds a uniquely 
numbered name. You can change the macro’s name when macro recording finishes.

At the end of recording, IDL saves the completed macro, and the Macro Editor opens. 
Note that using the Stop Recording menu command is the only way to stop recording 
without exiting the iTools system. Changing tools or closing the tool does not stop 
recording, and a recording started in one iTool will continue to other iTools. You can 
select the Stop Recording command in any active iTool.

Note
What you select in the iTools system before starting recording will dictate what 
happens when you run the completed macro. For more information, see “Macro 
Type Based on Recording Selection” on page 167.
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Running Macros

When you run a macro, its operations apply to the item or items selected in the active 
iTool. 

Note
For more information on a macro’s application to the current selection, see “Macro 
Type Based on Recording Selection” on page 167.

To run a macro, do one of the following:

• From an iTool window, select Operations → Macros → Run Macro

• From the Macro Editor, select the macro to run and then select Run → Run 
Macro

• At the IDL command line, use the MACRO_NAMES keyword with an iTool 
command

Macro items are processed sequentially, each item either applying an operation or 
applying property values. Macros can contain operations that change the selection so 
that subsequent operations or property settings apply to different visualization objects 
in one or more iTools. For more information, see “Making Selection and Tool 
Changes” on page 167.

After running a macro, you can use the Undo/Redo operation, which treats the 
actions performed by a macro as a single event. This means that if you run a macro 
and then select Undo, all of the operations and properties changed by the macro revert 
to their pre-macro values.
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Running from the Operations Menu

You can run a macro by selecting Operations → Macros → Run Macros from any 
open iTool. This selection opens the Run Macro dialog, as shown in Figure 8-2. 

Figure 8-2: Run Macro Dialog

This dialog lets you select the macro to run. The macro names are obtained from all 
saved macros. Macros that have been created in the macro editor, but not saved are 
not available. By default, the first item in the list is selected, and the description of 
that first macro appears in the Macro Description field. After you select a macro 
name from the list, the Macro Description field is updated with the description of the 
selected macro. The Display Intermediate Steps option is set based on the value of the 
macro property of the same name. Set it to display each step of the macro as it runs, 
or clear it to prevent any updates of the display until the macro is complete.

Running from the Macro Editor

You can run macros from within the Macro Editor by doing the following:

1. In the macro tree panel (top left), select the macro to run.

2. Select Run → Run Macro.

The macro runs on the selected visualization or visualizations in the active iTool.

For more information, see “Using the Macro Editor” on page 145.
iTool User’s Guide Running Macros



144 Chapter 8: Working with Macros
Running from the Command Line

You can also apply macros in a non-interactive situation by running them from the 
IDL command line.

The iTools routines (such as IPLOT) have a MACRO_NAMES keyword that you can 
set when calling them. For example, you can enter the following at the command line, 
if you have a macro named ‘plotmacro’ already defined:

IPLOT, RANDOMU(1, 20), MACRO_NAMES='plotmacro'

This command creates a simple two-dimensional plot of 20 randomly generated data 
points and then applies the ‘plotmacro’ macro to it.

The keyword can take either a single string, as in the example above, or an array of 
strings. In the latter case, the macro names are retrieved and run sequentially at the 
conclusion of the iTool’s actions. This action follows the creation of the iTool and, if 
applicable, any visualization created by the command.

Note
For more information on the MACRO_NAMES keyword, see the iTools routine 
commands in the IDL Reference Guide.
Running Macros iTool User’s Guide



Chapter 8: Working with Macros 145
Using the Macro Editor

You can use the Macro Editor to modify existing macros and create new macros. The 
Macro Editor is launched automatically after you record a macro interactively. You 
can also launch the Macro Editor at any time by selecting Operations → Macros → 
Macro Editor from any iTool.

The Macro Editor is a system-wide dialog, shared by all current iTools. Closing all 
current iTools does not close the Macro Editor.

Figure 8-3: The Macro Editor
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Figure 8-3 shows the Macro Editor with the History folder expanded to show the 
history items that were generated while the iImage tool was open (that is, all iImage 
operations, whether recorded in a macro or not). The Macros folder in the upper-right 
panel shows a macro with its SetProperty item selected.

Understanding the Macro Editor

The Macro Editor consists of four panels and two sets of add/remove buttons. The 
four panels consist of the two macro panels on the top and the two source panels on 
the bottom. You use the add/remove buttons to move operations and settings from the 
source panels to the macro panels.

The Menu Bar

The following menus appear on the Macro Editor menu bar:

• File

• Edit

• Run

• Help

You can use the Edit and Run operations in a right-click context menu on items in the 
macro and source trees.

The File menu, shown in Table 8-1, contains tools for creating, importing, exporting, 
and saving macros.

Menu 
Selection

Function

New Creates a new macro in the macro tree, with a name based on 
‘New Macro.’ If New Macro already exists, then the new name 
is New Macro (1) and so on until the system finds a uniquely 
numbered name.

Import... Imports a macro from an external file. See “Importing and 
Exporting Macros” on page 174 for details.

Export... Exports the selected macro to an external file. See “Importing 
and Exporting Macros” on page 174 for details.

Table 8-1: The File Menu
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The Edit menu, shown in Table 8-2, contains tools for editing, deleting, duplicating, 
and moving items within the macro and source trees.

The Run menu contains only one operation: Run Macro, which runs the selected 
macro. See “Running from the Macro Editor” on page 143 for details.

The Help menu opens the online help for the Macro Editor.

Save Saves all macros to external IDL SAVE files with names based 
on the macro names.

Close Closes the Macro Editor, prompting you to save any unsaved 
macro changes. 

Menu 
Selection

Function

Cut Copies the selected item to an internal clipboard and removes 
the item from the tree.

Copy Copies the selected item to an internal clipboard.

Paste Pastes the contents of the internal clipboard into the tree.

Delete Deletes the selected item without making a copy. If the 
selected item is a SetProperty item and the last selection was 
in the macro property sheet, this action deletes selected 
properties from the SetProperty item. If the last selection was 
in the macro tree, the whole SetProperty item is deleted.

Duplicate Duplicates the selected item.

Move Item Up Moves the selected item up one position in the tree.

Move Item Down Moves the selected item down one position in the tree.

Table 8-2: The Edit Menu

Menu 
Selection Function

Table 8-1: The File Menu (Continued)
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The Macro Tree

The macro tree (top left) contains folders for existing macros, as shown in Figure 8-4. 
Macros are indicated by the gears folder icon. Macro items are indicated by their own 
object icons or by the SetProperty icon.

Figure 8-4: Macro Editor’s Macro Tree

Clicking on an item in the tree selects the item and displays its property sheet to the 
right of the tree panel. Right-clicking within the tree brings up the context menu of 
available actions (see “The Menu Bar” on page 146). If you right-click on a tree item, 
then that item is selected.

For more information on these items, see “Macro Items” on page 155.
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The Macro Property Sheet

The macro property sheet (top right) lets you set properties of macro folders and 
items.

To see a macro’s properties, click on its folder in the macro tree. The macro’s 
properties appear in the macro property sheet, as shown in Figure 8-5. To change any 
of the properties, click on it in the sheet and make the modification you want.

Figure 8-5: Macro Editor’s Macro Property Sheet: Macro Properties

A macro has several properties. The Name property is used to select the desired 
macro from the Run Macro dialog (for more information, see “Running from the 
Operations Menu” on page 143). In addition, this property is the basis for the 
filename of a saved macro. The Description property can be used to describe the 
behavior or purpose of the macro. This property’s value appears in the Run Macro 
dialog’s Description field when you select a macro from the list. The Display 
Intermediate Steps property is typically set to False so that the display updates only 
on completion of the macro. You can set this property to True to display each step of 
the macro, which might be useful when using a macro to animate a series of actions.

Note
if Display Intermediate Steps is False (the default) then updates to the display are 
suppressed while a macro is being run. Operations that typically update the display 
such, as the Volume Render operation, will not change the display if Display 
Intermediate Steps is False.
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Figure 8-6: Macro Editor’s Macro Property Sheet: Macro Item

To see an individual macro item’s properties, click on the item in the macro tree. The 
properties appear in the macro property sheet, as shown in Figure 8-6. To change any 
of the properties, click on a property in the sheet and make the modification you 
want.

You can modify any properties of macro items except for user-defined properties, 
which are not available for modification.

The Source Tree

The source tree (bottom left), as shown in Figure 8-7, contains the following items 
that you can use for macro creation:

• History items, grouped by tool (see “History Items” on page 157)

• Visualizations (see “Visualization Items” on page 160)

• Annotations (see “Annotation Items” on page 161)

• Macro tool items (see “Macro Tools Items” on page 162)

• Tool menu items (see “Tool Menus Items” on page 166)
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Figure 8-7: Macro Editor’s Source Tree

You can use these property settings and operations as a source for macro items. 
Selecting one of these items displays its properties in the source property sheet next 
to the tree panel. While the visualizations and annotations cannot be used directly in 
macros, you can use their properties as the source for macro property settings. The 
source tree also contains operations for the current tool, in the Tool Menus → 
Operations subfolder, which you can use as a source for macro operations.

Clicking on an item in the tree selects the item and displays its property sheet to the 
right of the tree panel. You cannot multi-select within the tree. Right-clicking within 
the tree brings up the context menu of available actions (see “The Menu Bar” on 
page 146). If you right-click on a tree item, then that item is selected.
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The Source Property Sheet

The source property sheet (bottom right) displays the properties of items in the source 
tree to its left. As described above, properties can be used as source items for macros.

Figure 8-8: Macro Editor’s Source Property Sheet

Figure 8-8 shows the properties for the Line operation, found in the source tree’s 
Annotations folder. You can multi-select properties in the sheet. Selected properties 
may be moved to a macro property setting item. Although all properties in the source 
property sheet are grayed out (desensitized), you can select them for creation of 
SetProperty macro items (for more information, see “SetProperty Settings” on 
page 156).

Note
User-defined properties are available only if they are part of a macro recording; they 
will apply like any other property during playback. You cannot otherwise use a 
user-defined property (moving, copying, modifying, etc.) in the macros system.

The Add and Remove Buttons

There are two sets of Add and Remove buttons, one for the source and macro trees 
and one for the source and macro property sheets. Both sets have similar behavior.
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The Item Add Button

The item Add button (in the left pair) copies items from the History and operations 
folders up into macros. If a macro folder is selected in the macro tree then the new 
item is placed at the end of existing items. If a macro item is currently selected in the 
macro tree, then the new item is added to the macro folder, immediately following the 
selected macro item. If the top-level Macros folder is selected, then a new macro is 
created, and the item is placed within it.

With a visualization selected, the Add button adds a ‘Visualization…’ operation to 
the macro. This item will make a running macro present the Insert Visualization 
dialog to let you define parameters and insert a new visualization. Note that the Show 
Dialog property is set to True because you must define the parameters interactively, 
unlike with an Insert Visualization operation that has been recorded or copied from 
history.

You can select annotations in the source tree to select their properties, but you cannot 
move the annotations directly up into macros because they require initialization with 
data. The exception is annotations in the History folder (for more information, see 
“Annotation Items” on page 161).

The Item Remove Button

The item Remove button (in the left pair) removes the selected item or folder from the 
macro tree.

The Property Add Button

The property Add button (in the right pair) moves selected properties up into a new or 
existing SetProperty operation in a macro. Running a macro with a SetProperty 
operation applies the property setting to the selected visualization, letting you set the 
specified property on any applicable object.

Note
Once a property setting is added to a macro, it is no longer tied to a particular 
visualization type. 

If you add a desensitized property to a macro item, the property will be sensitized 
(not grayed out) in the macro property sheet.

If you select an existing SetProperty item in the macro tree, IDL adds properties to it 
instead of creating a new SetProperty item.
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Figure 8-9: An Example Using the Property Add Button

Figure 8-9 shows a SetProperty macro item created by selecting the Plot visualization 
in the source tree and three properties (Color, Line Style, and Thickness) in the 
source property sheet. The property Add button copied the desired property settings 
up into a SetProperty macro item containing all three properties.

The Property Remove Button

The property Remove button (in the right pair) removes any selected properties from 
SetProperty items. It is not enabled for other types of macro items.
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Understanding Items in the Macro Editor

In the Macro Editor, you work with two main groups of items: those that make up a 
macro (items in the macro tree) and those that you use to create a macro (items in the 
source tree).

Macro Items

Macro items are the elements that make up a macro, namely operations and property 
settings. You insert them into a macro either during recording or, in the Macro Editor, 
by moving them from the source tree up into the macro tree. The properties of a 
selected macro item appear in the macro property sheet.

Figure 8-10: Macro Items in the Macro Editor

Figure 8-10 shows the macro items in the Sample Macro macro, both operations 
(Selection Change and Smooth) and property settings (SetProperty: Color, 
SetProperty: Minor ticks). The first SetProperty item is selected to show the property 
value (Color) that it will set on the selected object during playback.

Operations

Operations are the actions that you want the macro to perform on the selected object 
or objects, such as inserting a plot legend or applying a convolution filter. You can 
modify an operation’s properties to customize it.

Some operations have the Show Dialog property set to False by default when the 
operation is added to a macro, either by recording or in the editor. This setting lets the 
operation run without displaying its dialog when the macro is run. In this case, any 
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operation properties will be obtained from the saved macro item and used during 
playback. You can alter the value of this property to allow customization of operation 
properties during playback. If the Show Dialog property of the macro item is set to 
True, then during macro playback the operation's dialog will be displayed, letting you 
alter any operation properties. Once the dialog is closed, the execution of the macro 
will continue.

SetProperty Settings

SetProperty settings contain only the properties being modified, which will apply to 
the currently active object during macro playback. They do not contain the NAME 
and DESCRIPTION properties typically displayed for an object because the property 
can apply to whatever object is selected (that is, these fields are no longer tied to a 
certain type). However, if the name and description properties are selected in the 
editor or modified in a recording, the SetProperty item will display these properties as 
expected.

You can modify properties in the Macro Editor to customize your macros.

Source Items

This group consists of history items and four folders of operation items that you can 
use in macro creation: Visualizations, Annotations, Macro Tools, and Tool Menus. 
The items in all five groups are also available as a source for property settings to be 
added to a SetProperty macro item.
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History Items

The History folder in the source tree, shown in Figure 8-11, contains history items. 
The properties of a selected history item appear in the source property sheet.

Figure 8-11: Macro Editor’s History Folder

The History folder records actions that occur in an iTool. The history items are 
grouped into folders for each tool in current or past use, with each folder named by its 
tool identifier (e.g., ‘PLOT TOOL’ for an open iPlot tool). History items will 
continue to be added to history folders for the duration of the iTools session. This 
sequence of history items thus represents an audit trail for actions taken in a tool. It 
also serves as a source for the creation of macros.

Note
The History folder is cleared at the end of an iTools session (through the itreset 
command or by exiting IDL).

When you change a property value in an iTool, IDL creates a corresponding history 
item. The name of the property being changed is appended to the name of that item 
(e.g., ‘SetProperty: Color’ instead of simply ‘SetProperty’). When you select or 
deselect an object in an iTool, the name of the object selected or deselected is 
concatenated to the name of that item (e.g., ‘Selection Change: Axes’). In both cases, 
this additional information in the audit trail can show which properties were changed 
or which objects were selected or deselected.
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Note
The object name is specified on history items but not on macro items, because when 
you run the macro, it might be operating on different objects based on the current 
selection. For more information, see “Selection Changes” on page 168.

Items from Closed Tools

When a tool is closed, the name and identifier of the history folder changes to 
indicate that the tool has been closed. The string ‘(Closed-N)’ is appended to the 
name of the history folder, where N is an integer starting at 1 and is incremented each 
time the tool with the same identifier is closed. After a tool is closed and the History 
folder renamed, creation of another tool of the same type causes the creation of a new 
tool with the name of the tool identifier. Actions in this tool would be recorded in a 
history folder named by the simple tool identifier.

For example, the following sequence creates the History folder items shown in Figure 
8-12:

1. Start iImage, open an image, and apply the Smooth operation.

2. Close iImage.

3. Start iImage, open an image, and apply the Median operation.

4. Close iImage.

5. Start iImage, open an image, and apply the Convolution operation.

6. Keep iImage open, start a new iImage tool, open an image in the new iImage, 
and apply the Dilate operation to it.

7. Close the second (newer) iImage.
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8. Open the Macro Editor from the existing iImage tool.

Figure 8-12: History Example with Open and Closed Tools

Run Macro Items

The Run Macro operation is itself an operation that will show up in the history and 
can be added to a macro. Using the Run Macro macro item lets you nest macros for 
grouping of common tasks.

If a macro has been run, you can copy a Run Macro item to a macro from the History 
folder. You can also add it from the Tool Menus → Operations → Macros subfolder 
in the source tree. The item contains a Macro Name property to allow specifying the 
name of the macro to run. If you copy the item from history, this property is set to the 
name of the macro that was run, but you can set it to the name of any macro. If you 
add the item from the Tool Menus → Operations → Macros subfolder, the macro 
name property will be blank and should be set to the name of the desired macro to 
run. If you try to run a macro containing a nested Run Macro operation, you will get 
an error dialog if the macro name is invalid or the macro cannot be found.
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Visualization Items

The Visualizations folder, shown in Figure 8-13, contains the visualizations that you 
can use in the iTools.

Figure 8-13: The Macro Editor’s Visualizations folder

Visualizations require data for their creation, and so you cannot copy default items 
from this folder directly into a macro. When you add a visualization to a macro from 
the Visualizations folder, using the item Add button, the ‘Visualization…’ operation 
appears as a macro item with the Show Dialog property set to True because you must 
define the visualization parameters interactively to define the data. If you want to add 
a visualization without having to show the Insert Visualization dialog, add an Insert 
Visualization operation from the History folder because that visualization already 
contains data.

You can select visualization items in the source tree to select their properties and add 
them to a macro (e.g., while editing a recorded macro, you could add a SetProperty 
item that changes the isovalue of an isosurface).
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Annotation Items

The Annotations folder, shown in Figure 8-14, contains the operations that create 
text, line (including geometric shapes), and legend annotations in a tool.

Figure 8-14: The Macro Editor’s Annotations folder

Annotations require data for their creation, and so default items from those folders 
cannot be copied directly to a macro. You can select annotations in the source tree to 
select their properties and add them to a macro (e.g., a SetProperty item that changes 
the caption of a text annotation), but you cannot move these items directly up into 
macros because they require initialization with data. If you want to add an annotation 
directly, you can only add an Insert Annotation operation from the History folder 
because that annotation already contains data.
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Macro Tools Items

The Macro Tools folder, shown in Figure 8-16, contains operations that are not in the 
standard menu system. You can use these items to build macros.

Figure 8-15: The Macro Editor’s Macro Tools Folder

The operations in this folder deal with selection changes, tool changes, and the Scale, 
Translate, View Pan, Rotate, View Zoom, and Range Change manipulations.

For information on selection and tool changes, see “Making Selection and Tool 
Changes” on page 167.

Scale Operation Item

The Scale operation stores the scaling factors from an interactive scale manipulation.

Table 8-3 shows the Scale operation’s properties and values.

Property Value

Description Operation description, set by default to Scale

X Scale Factor to scale the selected object’s data in the x direction

Y Scale Factor to scale the selected object’s data in the y direction

Z Scale Factor to scale the selected object’s data in the z direction
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Table 8-3: Scale Operation Property Values

Note that you could have unpredictable behavior if you modify those properties in the 
Macro Editor and then run the macro containing the modified operation (e.g., an 
object scaled further than desired and thus obscuring important details). Be careful 
with estimating these values.

Translate Operation Item

The Translate operation stores the translation in pixels in the x and y directions from 
an interactive translate manipulation. This operation lets the macro system record and 
play back movements made with the Translate manipulator from the iTools toolbar 
(the Arrow icon).

Table 8-4 shows the Translate operation’s properties.

Table 8-4: Translate Operation Properties

Because the [x, y] translation is relative to the selected object’s current position, not 
absolute within an iTool view, you could have unpredictable behavior if you modify 
those properties in the Macro Editor and then run the macro containing the modified 
operation (e.g., an object moving out of view). Be careful with estimating these 
values.

View Pan Operation Item

The View Pan operation stores the movement in pixels in the x and y directions from 
an interactive view pan manipulation. This operation lets the macro system record 
and play back movements made with the View Pan manipulator from the iTools 
toolbar (the Hand icon).

Table 8-5 shows the View Pan operation’s properties and values.

Property Value

Description Operation description, set by default to Translate

X Translation Number of pixels to move the selected object in the x direction

Y Translation Number of pixels to move the selected object in the y direction

Property Value

Description Operation description, set by default to View Pan

X Pan Number of pixels to pan the view in the x direction 
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Table 8-5: View Pan Operation Property Values

Note that you could have unpredictable behavior if you modify those properties in the 
Macro Editor and then run the macro containing the modified operation (e.g., a view 
panned further than desired and thus obscuring important details). Be careful with 
estimating these values.

Rotate Operation Item

The Rotate operation stores the rotation angles from an interactive rotate 
manipulation. This operation lets the macro system record and play back movements 
made with the Rotate manipulator from the iTools toolbar.

Table 8-6 shows the Rotate operation’s properties and values.

Table 8-6: Rotate Operation Property Values

Because the [x, y, z] rotation is relative to the selected object’s current position, not 
absolute within an iTool view, you could have unpredictable behavior if you modify 
those properties in the Macro Editor and then run the macro containing the modified 
operation (e.g., an object rotating further than desired and thus obscuring important 
details). Be careful with estimating these values.

View Zoom Operation Item

The View Zoom operation stores the zoom percentage from an interactive zoom 
manipulation. This operation lets the macro system record and play back movements 
made with the View Zoom manipulator from the iTools toolbar.

Y Pan Number of pixels to pan the view in the y direction 

Property Value

Description Operation description, set by default to Rotate

X Rotation Angle to rotate the selected object about the x-axis

Y Rotation Angle to rotate to move the selected object about the y-axis

Z Rotation Angle to rotate to move the selected object about the z-axis

Property Value
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Table 8-7 shows the View Zoom operation’s properties and values.

Table 8-7: View Zoom Operation Property Values

Because the zoom percentage is relative to the selected object’s current position, not 
absolute within an iTool view, you could have unpredictable behavior if you modify 
this property in the Macro Editor and then run the macro containing the modified 
operation (e.g., an object zooming further in than desired). Be careful with estimating 
this value.

Range Change Operation Item

The Range Change operation stores the changes to the dataspace range from 
interactive range zoom, range pan and range box manipulators. This operation lets 
the macro system record and play back changes made with the Data Range 
manipulator from the iTools toolbar (the graph icon). 

Table 8-8 shows the Range Change operation’s properties and values.

Table 8-8: Range Change Operation Property Values

Note that you could have unpredictable behavior if you modify those properties in the 
Macro Editor and then run the macro containing the modified operation (e.g., the data 
range scaled up or down further than desired and thus obscuring important details). 
Be careful with estimating these values.

Property Value

Description Operation description, set by default to Zoom

Zoom Percentage Zoom percentage on the selected object

Property Value

Description Operation description, set by default to Range Change

X Minimum Minimum value for the x coordinate of the data set

X Maximum Maximum value for the x coordinate of the data set

Y Minimum Minimum value for the y coordinate of the data set

Y Maximum Maximum value for the y coordinate of the data set

Z Minimum Minimum value for the z coordinate of the data set

Z Maximum Maximum value for the z coordinate of the data set
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Tool Menus Items

The Tool Menus folder, shown in Figure 8-16, contains the operations from the 
iTools’ menus.

Figure 8-16: The Macro Editor’s Tool Menus Folder

You can use items from the Tool Menus folder as a source for property settings or as 
a direct source for macro items. When you add one of these operations to a macro 
(e.g., to change the view layout of an iTool), you can modify the resulting macro 
item’s property values to customize the actions taken by the operation when the 
macro runs.

Note
These operations are for the current tool. Therefore, this folder is no longer 
available if all tools are closed.
Understanding Items in the Macro Editor iTool User’s Guide



Chapter 8: Working with Macros 167
Making Selection and Tool Changes

You can change the selection of objects and even iTools in the course of a macro, to 
let you apply macro items to different objects within and across iTools. You can add 
these operations during macro recording or by using the Macro Editor, where you can 
find the selection change operations in the Macro Tools folder of the source tree.

Macro Type Based on Recording Selection

What you have selected when you start recording a macro gives rise to two general 
types of macros, where one of the following states is true:

• A visualization or annotation selected

• No visualization or annotation selected (e.g., a view selected instead)

In the first case, the macro’s first item is a Selection Change operation with the 
Selection Type property set to Existing Selection. This item represents the selection 
active when recording starts. When you play back the macro, it begins to apply its 
items (operations, property settings, or both) to the object that is selected when 
playback begins.

In the second case, the macro’s first item is a Selection Change operation with the 
Selection Type property set to No Items (De-Select All). When you play back the 
macro, the current selection is cleared before additional macro items are processed. 
You can create this type of macro if you want it to work on only specific objects or 
selections. The macro would typically clear the selection and then select the 
particular objects and then operate on them.

About Containers

The following discussion on the creation of these change operations and the 
properties of the operation introduces the concept of a container and position in the 
container. These concepts apply to both selection and tool changes, with some 
differences in the details.

For both changes, the term container is a generic term for one of the iTools objects 
that contains other objects. In relation to selection changes, the commonly referenced 
containers are the Data Space, the Annotation Layer, and the Window.

The Data Space contains visualizations that can be referenced by their position in the 
container. If you use the Visualization Browser to look at the visualization hierarchy, 
you can see that the order of the visualizations within the tree view represents their 
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positions in the container. This arrangement is also true of annotations within the 
Annotation Layer.

You can see the Window in the Visualization Browser as well. The Window is a 
container that holds Views, and the order of Views within the Window folder of the 
Visualization Browser is equivalent to the Views’ positions in the container.

In relation to tool changes, the container is the current iTools session, containing all 
the tools. The tools container contains the individual tools, which can be referenced 
by their zero-based position in the container. The order of the tools is determined by 
their order of creation.

Selection Changes

The Selection Change operation is a macro item that can alter the current selection so 
that subsequent macro items are applied to different objects. During the recording of 
a macro, the selection change operations are added to the macro when the selection is 
changed interactively. In addition, when you start recording a macro, a Selection 
Change operation is added to reflect the current state of the selection (for more 
information, see “Macro Type Based on Recording Selection” on page 167).

Adding a Selection Change Operation

You can add a Selection Change operation either when you start recording a macro or 
during recording.

A Selection Change operation is inserted during recording if the selection is changed 
interactively. In this case, the type of the selection change operation is set to Position 
in Container. The values of the Container and Item Identifier properties are set. The 
value of the Selection Mode property is set to the applicable value of ['New 
Selection', 'Add to selection', 'Remove from selection'].

As with other operations, you can modify and delete the Selection Change operation 
by using the Macro Editor. You can also add the operation from the Macro Tools 
folder in the source tree.
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Selection Change Operation Properties

Figure 8-17 shows a Selection Change operation’s property sheet. 

Figure 8-17: The Selection Change Operation’s Property Sheet

The Description property is set by default to Selection Change.

The Selection Type property indicates the selection upon which the macro will act 
when you run it. This property can have the following values:

Property Value Description

Existing Selection Applies macro to the current selection.

Position in 
Container

Applies macro to the object indicated by the Position in 
Container property.

All in Container Applies macro to all objects in the container.

Next in Container Applies macro to the next object in the container based on the 
currently selected object or objects in the container. If multiple 
objects in the container are selected, the object with the 
highest position index is used as the starting point from which 
to determine the next in container. If the currently selected 
object is the last in the container, this operation wraps to the 
beginning when selecting the next in container.
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Table 8-9: Selection Type Property Values

As Table 8-9 indicates, several Selection Change properties deal with containers (for 
more information, see “About Containers” on page 167). For example, if the 
Container property is set to Data Space, a Selection Change operation with a 
Selection Type property of All in Container selects all visualizations.

The Selection Mode property indicates the selection upon which the macro will act 
when you run it. This property can have the following values (Table 8-10):

Table 8-10: Selection Mode Property Values

The Container property defines the container within which the Selection Change 
operation will act (e.g., Window/View_1/Visualization Layer/Data Space for the first 
View’s data space).

The Item Identifier property names the object upon which the Selection Change 
operation will act (e.g., View_1 for the first View in the Window). 

Previous in 
Container

Applies macro to the previous object in the container based on 
the currently selected object or objects in the container. If 
multiple objects in the container are selected, the object with 
the lowest position index is used as the starting point from 
which to determine the previous in container. If the currently

selected object is the first in the container, this operation wraps 
to the end when selecting the previous in container.

By Identifier Applies macro to the object indicated by the Item Identifier 
property.

All Items Applies macro to all items in all containers.

No Items (De-
select All)

Applies macro to no items (requires a Selection Change 
operation in the macro to select an object).

Property Value Description

New Selection Makes the current object the selection

Add to Selection Adds the current object to the selection

Remove from 
Selection

Removes the current object from the selection

Property Value Description
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The Position in Container property identifies the selected object’s position by number 
(e.g., 0 for the first item in the Visualization Layer).

Tool Changes

The Tool Change operation represents a macro item that sets the current tool so that 
subsequent macro items are applied in a different tool. During macro recording, a 
Tool Change operation is added when the currently selected tool is changed 
interactively. Note that when the tool selection changes because of an operation such 
as Histogram rather than changing interactively, a Tool Change operation is not added 
because it would be redundant (that is, the tool change is part of such an operation).

Adding a Tool Change Operation

You can add a Tool Change operation either when you record a macro or by adding 
the operation from the Macro Editor’s source tree, in the Macro Tools folder.

If the operation is added during recording, the Change Type property is set to By 
Identifier, and the identifier and position values are set. If it is added through the 
Macro Editor, only the Change Type and Position in Container properties are set (to 
By Identifier and 0, respectively).

As with other operations, you can modify and delete the Tool Change operation by 
using the Macro Editor.
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Tool Change Operation Properties

Figure 8-18 shows a Tool Change operation’s property sheet.

Figure 8-18: The Tool Change Operation’s Property Sheet

The Description property is set by default to Tool Change.

The Change Type property indicates the kind of tool change that the macro will 
perform when you run it. This property can have the following values (Table 8-11):

Property Value Description

By Identifier Change selection to the tool indicated by the Tool Identifier 
property

Position in 
Container

Change selection to the tool indicated by the Position in 
Container property

Next in Container Change selection to the next tool in the container. If the 
current tool is the last in the container, the search for the next 
tool will wrap to the beginning of the container, and the first 
tool in the container will become the current tool
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Table 8-11: Change Type Property Values

Recall that in terms of tool changes, the container means simply the current iTools 
session, encompassing all tools. For more information, see “About Containers” on 
page 167.

The Tool Identifier property names the tool to which the Tool Change operation will 
change (e.g., ‘IMAGE TOOL’ for an iImage tool). This property is used only if the 
value of the Change Type property is By Identifier; otherwise, it is ignored.

The Position in Container property identifies the tool to which the Tool Change 
operation will change by number (e.g., 0 for the first tool in the session). This 
property is used only if the value of the Change Type property is Position in 
Container; otherwise, it is ignored.

Previous in 
Container

Change selection to the previous tool in the container. If the 
current tool is the first in the container, the search for the next 
tool will wrap to the end of the container, and the last tool in 
the container will become the current tool

Property Value Description
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Importing and Exporting Macros

You can import a macro from a file by selecting File → Import from the Macro 
Editor, which opens a dialog that lets you select one or more macro files to import. 
Macro files are IDL SAVE files created by exporting an existing macro.

You can export a macro to a file by selecting File → Export from the Macro Editor. 
The filename that you specify will be used to create an IDL SAVE file containing the 
macro. The macro to be saved is specified by either the macro folder selected 
explicitly or the macro folder containing the selected macro item.

Note
If a Run Macro operation is in the macro being exported, you must export the macro 
to which that operation refers as well, to ensure proper playback behavior of the 
original exported macro.
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Working with Styles
This chapter introduces IDL iTool styles and discusses the following related-tasks:
What Are Styles? . . . . . . . . . . . . . . . . . . . .  176
Creating Styles . . . . . . . . . . . . . . . . . . . . . .  178
Applying Styles . . . . . . . . . . . . . . . . . . . . .  185
Editing Styles . . . . . . . . . . . . . . . . . . . . . . .  191

Editing Styles . . . . . . . . . . . . . . . . . . . . . .  191
Setting the Default Style  . . . . . . . . . . . . .  194
Importing and Exporting Styles . . . . . . . .  195
iTool User’s Guide 175



176 Chapter 9: Working with Styles
What Are Styles?

iTool styles provide a convenient way to store and apply a set of properties to items in 
your iTool. While modifying individual property items within a style has the same 
effect as creating a new style that sets the same properties, a new style can be created, 
customized, and applied in a current session or in later sessions. Styles provide a 
shortcut mechanism that allows you to quickly apply groups of properties to your 
visualization, and to automatically alter the properties of newly-created 
visualizations. Styles are available across all iTools. For example, a style created in 
the iPlot tool will also appear as a Style selection when working in the iImage tool. 
However, only relevant style properties are applied to a selected visualization. 
Property settings for absent visualization items in the style are ignored.

Nearly all properties can be stored in styles. The only exception to this are user-
defined properties (such as the color look-up table associated with an image). 
Individual property styles are never global, that is, the color property associated with 
a plot object applies only to a plot, and does not affect the color property of a surface. 
Nevertheless, a style can easily be created to set the color property for these 
individual visualization types.

When applied, styles are not permanently linked to a visualization. In other words, 
the visualization is exactly the same as it would be if individual properties had been 
set instead of the style being applied. Changes to the style are not automatically 
updated in the visualization unless the style is re-applied to the visualization. All of 
these characteristics ensure that when an iTool is saved and then shared with any 
other users, it will display identically. There is no need to send an associated style 
file.

Note
You can share styles with other users. See “Importing and Exporting Styles” on 
page 195 for details. 
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Type of Styles

Style information is stored in one or more style files located on your system. The two 
classes of style files are System Styles and Personal Styles:

• System Styles — IDL System Styles are pre-loaded in your IDL distribution. 
IDL’s supplied System Styles are: 

• IDL Classic - This System Style contains IDL Direct Graphics’ common 
black background with white text and white linestyle.

• IDL Standard - This System Style is the iTools default and contains a 
white background with black text and black lines.

• Personal Styles — IDL Personal Styles are styles which you create. These are 
stored inside your .idl directory. When you create a new style within an iTool, 
it is automatically saved in this location.

Note
Style information is stored independently of any iTool. Styles are never 
automatically saved by simply making style changes in an iTool. They must always 
be saved explicitly.

Applying a Style

As mentioned, System Styles exist in your IDL distribution and are ready to use 
immediately (creating your own new Personal Styles is discussed at-length in the 
Creating Styles section). From an iTool window, in order to apply a style, select 
Edit → Style → Apply Style... or Edit → Style → Style Editor...

For more in-depth information on style application, see “Applying Styles” on 
page 185.
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Creating Styles

There are two ways a new Personal Style can be created. You can use the iTool’s 
Style Editor or you can select one or more visualizations within your iTool view (or 
the view itself) and create a new style. Both of these options are discussed here.

Creating a Style from the Current Visualization

You can create a new style by selecting one or more visualization objects within the 
view (or by selecting the entire view). A new style created in this manner will contain 
all property settings of the selected objects (or all objects in the view if nothing was 
selected).

Creating a Style From All Items in a View

The following example shows how to create a new style from all items in a view:

1. From the IDL Command Line, plot a simple line graph within iPlot: 

iPlot, RANDOMU(seed, 30)

2. From the iPlot window, select one or more visualization objects or the entire 
view within the window. Then select: Edit → Style → Create Style from 
Selection...

3. Enter a name for your new style (in this example it is named MyNewStyle1) in 
the Create Style from Selection dialog shown in the following figure. 

4. Now you can select between creating the new style using the selected items or 
using all items in the view. In this instance, choose Create using all items in 
view.

5. Select OK and the iTools Style Editor appears.

Figure 9-1: Create Style from Selection Dialog
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6. You can now expand the newly named style to view its properties. Under 
MyNewStyle1, select Plot and change the Color to your preference as shown 
here:

7. Change the Symbol to Asterisk.

8. Now, from the Style Editor window, select the Axis object and change the 
color.

9. Select File → Save to save changes to MyNewStyle1.

10. Next, from the iPlot window, select Edit → Style → Apply Style and select 
MyNewStyle1 from the Apply Style dialog that appears. Your new style, 
which contains changes to your line style color, plot symbol type (asterisks) 
and color of plot axes, is applied to the plot object.

Note
If multiple items of the same class are within a container (e.g. the axes container), 
the first one within the container will be used when creating the style.

Figure 9-2: Selecting Background Color
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Creating a Style From Selected Items

The following example shows how to create a new style from selected items within 
an iTool view:

1. From your existing iPlot window, select the text annotation tool (the letter A on 
the top of the window on the annotation toolbar).

2. Click anywhere in the window you wish to add a title for your plot. Type in 
“My Plot”.

3. Double-click on your new text annotation and the Visualization Browser 
appears. Here you can edit the properties of your annotation. Change the text 
font, size, and color.

4. Next, ensuring that your text annotation “My Plot” is selected (a box appears 
around the title when selected), select Edit → Style → Create Style from 
Selection...

5. Enter a name for your new style in the Create Style from Selection dialog 
shown in the following figure. 

6. Name your new style: NewTextStyle1. Now you can select between creating 
the new style using the selected items or using all items in the view. In this 
instance, choose Create using selected items.

7. Select OK and the iTools Style Editor appears.

8. Since we have already set our text options as we want them to appear, you can 
close the Style Editor.

9. Now open a new iPlot window and add a new title (for example, “My New 
Plot”) using the text annotation tool.

10. Select Edit → Style → ApplyStyle and select to apply NewTextStyle1. This 
applies the personal text style to the new annotation.

Figure 9-3: Create Style from Selection Dialog
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For details on applying a style to selected items or to all items within a view, or when 
launching an iTool, see “Applying Styles” on page 185. For information on 
modifying existing styles, see “Editing Styles” on page 191.

Note
If nothing is currently selected, then the Visualization Layer within the current view 
will be used when creating the style.

Creating a Style from Multiple Selected Items

Within an iTool view, you can select one or more visualization objects or annotations 
(or a combination of the two) to be included in a new Personal Style. To select one 
object or annotation simply click on the item. To select multiple items, select the first 
and then, holding down the Ctrl key, click on the other items. 

Changes to the properties of the object or annotation can be made prior to creating a 
new style (by double-clicking on the item and altering the properties in the 
Visualization browser) or after creating a new style (within the iTools Style Editor).

Note
If multiply items of the same class are selected (say two axes), the first one selected 
will be used when creating the style.

Creating a New Style from the Style Editor

The Style Editor can be used to manually create a new style and specify the values of 
individual properties. Options are available in the Style Editor to duplicate existing 
styles, or to copy items from one style to another.

The following example shows how to create a new style using the iTool’s Style 
Editor:

1. First, open any iTool window and import some data.

2. From the iTool window, select Edit → Style → Style Editor... The iTools 
Style Editor window appears.

3. You will see My Styles, System Styles, and Current Style listed. Select Current 
Style and right-click and select Duplicate. A Copy of Current Style appears 
under My Styles and is named Copy of Current Style.

Note
From the iTool window you can also select File → New Style.
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4. Select the Copy of Current Style and rename it to your desired name in the 
right-hand side of the Editor.

Note
To avoid confusion, styles should be given unique names. You may not name 
a style the same name as an IDL system style.

5. You are now able to make any changes within the new style by expanding the 
new style’s object tree and making changes to the properties of individual 
visualization objects. 

6. When finished, select File → Save.

Note
For more information on how to populate the new style with properties, see 
“Editing Styles” on page 191. 

Figure 9-4: The iTool’s Style Editor
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Working with the Current Style

The Current Style contains the properties that will be used to create new 
visualizations in the current tool. The Current Style can be found in the iTools Style 
Editor. The Current Style can be modified by:

• Changing individual property values. These changes can be copied into 
another style, or applied to a visualization when the Current Style item is 
selected.

• Updating the Current Style when applying style modifications. See “Applying 
Styles” on page 185 for details.

• Updating the Current Style from a style in the Style Editor. Select a Personal or 
System style and select Update Current Tool Style from the context menu or 
Apply menu.

Note
The Current Style is not saved between IDL sessions or between iTools. Because of 
this, one use of the Current Style can be as a practice area to define new styles. 
Changes can be made to the Current Style and then used to create your desired 
style. You can then save this new style under a new name. The new style can be set 
as the "Default style" in the Preferences. For more information on setting a default 
style, see “Setting the Default Style” on page 194.
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Copying an Existing Style

Any existing style can be copied within the Style Editor. This is useful when you 
want to change only a few style properties while maintaining the majority of a style’s 
existing properties. Simply click on the style name and choose Edit → Copy or Edit 
→ Duplicate. Alternately, you can right-click on the style and choose Duplicate (or 
Copy and then Paste). A style named "Copy of style name" is then added in the My 
Styles folder of the Style Editor. 

Note
Styles may be named and renamed as you wish.
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Applying Styles

Styles can be applied to a single item or all items within a view. When a new 
visualization is added to an existing tool, the style of any previous visualization will 
not be automatically applied unless the preferred style is set as the default style (as 
described in “Setting the Default Style” on page 194) or unless the STYLE_NAME 
keyword is used. For more information on this keyword, see “IDL Routine 
Enhancements” on page 57.

Changes to style properties are not automatically reflected in your visualization. To 
update a visualization with a modified style, you must reapply the style.

When the Update current tool style checkbox is selected on the Apply Style dialog, 
the Current Style is updated. Any properties set in the style you have just applied are 
also changed in the Current Style. Other properties are left unchanged. Any new 
visualizations added from that point on will have the updated style applied.

Applying a style modifies only applicable items. If the style does not contain any 
properties that are relevant to the selected item or visualization, no changes are made 
to the visualization.

Note
Selecting Edit → Undo/Redo will completely undo the application of a style. If a 
style is applied and Undo is selected, all properties changed by the style revert to 
their pre-application values.

Applying a Style to a Selected Item

You can apply a style to selected items in a visualization. For example:

1. From the IDL Command Line, again visualize the simple line graph: 

iPlot, RANDOMU(seed, 30)

2. Using your mouse, highlight and select the plot line by clicking on the line.

3. Next, choose Edit → Style → Apply Style...
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4. The Apply Style dialog appears (as shown in the following figure), here you 
can select your preferred style to be applied to the plot item.

5. After selecting your preferred style (here MyNewStyle1 has been selected), 
choose Apply to selected items so that the style changes will only be made to 
the selected item. MyNewStyle1 was created to contain properties to change 
line color, plot symbol type, and axis color. Because Apply to selected items 
is selected and not Apply to all items in view, you can expect that the axes will 
remain their original color (black).

Note
If a particular existing style does not contain style information for an item that you 
have selected (for instance, if a style does not contain text information and you have 
selected a text item), no changes will be made to that item when the style is applied.

Figure 9-5: The Apply Style Dialog
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6. Click OK and your style changes will be visualized (as shown in the following 
figure).

Note
If nothing is currently selected, then style will be applied to the Visualization Layer 
within the current view.

Figure 9-6: iPlot Window Before (background) and After (foreground) Style 
Selection Application Changes Line Color and Plot Symbol Only
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Applying a Style to All Items

You can also apply a style to all items within a view. For example:

1. Visualize a surface from the IDL Command Line by typing: 

iSurface, dist(20)

2. Next add a text annotation to your image reading: New Surface.

3. Now select Edit → Style → Apply Style...

4. The Apply Style dialog appears (as shown in the following figure), here you 
can select your preferred style to be applied to the text item.

5. After selecting your preferred style (here IDL Classic has been selected), 
choose Apply to all items in view so that the style changes will be made to all 
the items.

Figure 9-7: The Apply Style Dialog
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6. Click OK and the style is applied to the entire visualization.

Note
Applying a style to all items will ignore items that have the Show property is set to 
False (i.e. hidden items).

Figure 9-8: iSurface Window Before (background) and After (foreground) Entire 
Style Application
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Applying a Style When Launching an iTool

The STYLE_NAME keyword allows you to apply a style to a visualization when an 
iTool is launched from the command line. This keyword can be used with any of the 
iTool routines (ICONTOUR, IIMAGE, IMAP, IPLOT, ISURFACE, and IVOLUME). 
For more information on this keyword, see “IDL Routine Enhancements” on page 57. 

Several system styles are included in your IDL distribution. For more information on 
setting a system style or created style, see “Setting the Default Style” on page 194.

Note
Styles specified in the STYLE_NAME string override the default style. 
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Editing Styles

The iTools Style Editor makes it possible to edit your existing personal styles as well 
as copies of IDL System Styles. The Style Editor is shown in the following figure.

It is important to note that IDL’s System Styles cannot be edited. These can, 
however, be copied as a new style and then edited. For information on copying styles, 
see “Copying an Existing Style” on page 184. The following section describes 
various editing tasks related to styles.

Copying Properties within Styles

You can copy properties from the Current Style, My Styles, and System Styles within 
the iTools Style Editor and paste these into any new or existing personal style. For 
example: 

1. Select a style by clicking on it.

2. Select the style visualization object whose properties you wish to copy. The 
properties appear in the right panel of the editor.

Figure 9-9: The iTools Style Editor
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3. Select a property by clicking on the property name and selecting Edit → Copy 
or right-clicking and selecting Copy.

4. Select the style name of the style in which you wish to add the copied property. 
The properties will be copied to corresponding visualization object within that 
style.

5. Select Edit → Paste or right click to select Paste. Your selected property is 
added to your selected style.

Cutting and Deleting Properties within Styles

You can cut or delete properties from your personal styles but not from the Current 
Style or from the System Styles. For example: 

1. From the iTools Style Editor, select a personal style and select a visualization 
object property you wish to delete.

2. Select Edit → Cut or Edit → Delete. Alternately, you can right-click on the 
property and select Cut or Delete.

Note
Deleting a property from a personal style cannot be undone. Cutting a property 
places the property on the clipboard and the property may then be pasted within 
another style.

Selecting Multiple Properties for Editing

Multiple properties may be copied and pasted (for all styles), and cut or deleted (only 
for personal styles) as shown for individual properties in the previous sections. To 
select multiple properties for these operations: 

1. Select a style by clicking on it.

2. Select the style visualization object whose properties you wish to copy, The 
properties appear in the right panel of the editor.

3. Click on the property name and then, for the selection of multiple 
discontinuous items, hold down the Ctrl key while clicking on any other 
properties you wish to select. For continuous selection, hold down the Shift 
key while clicking on the final property you wish to select in your group. All 
selected property names should appear depressed.
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4. With your cursor over one of the property names and all desired properties 
selected, right-click and select Copy. Alternately, with all properties selected, 
you can select Edit → Copy.

5. You can now select the style name of the style in which you wish to add the 
copied properties and find and highlight the corresponding visualization object 
within that style.

6. Select Edit → Paste or right click to select Paste. Your selected properties are 
added to your selected style.

Figure 9-10: The iTools Style Editor with Multiple Properties Selected to Copy
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Setting the Default Style

The default iTools style for your system can be set via the Preferences Browser. The 
Preferences Browser contains default property values used by all iTools. You can 
assign a personal style or any of the System Styles as the default iTools style 
preference. The default setting is none. To set a default style:

1. Select File → Preferences.

2. Select General Settings.

3. Select the desired style from the Default Style field drop-down list.

Once a default style is set, when a new iTool is started, the Current Style will contain 
a set of default values. That is, the default style is read into the Current Style.

Note
Because a default style is applied over the IDL system default settings, a default 
style does not need to include properties for all visualization types.

Figure 9-11: Selecting the Default Style
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Importing and Exporting Styles

You can use the Styles import/export functionality to share style files between 
yourself and other users. 

Exporting a File to Share

You can save (export) a style file to a place on your system to then share with other 
users. To do this: 

1. From the Style Editor, select File → Export... and name the file, then save it 
into a directory as a style file (.sav). 

2. This file can then be saved to a disk or sent via E-mail, FTP, etc. to another 
user.

Importing a Received File

You can import a saved style file. To do this: 

1. From the Style Editor, select File → Import... and locate the desired file.

2. Click Open.

3. The style should now appear in your style listing in the iTools Style Editor.
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Working with Images 
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Introduction

The IDL iImage tool displays your data in image form. The iImage tool then allows 
you great flexibility in manipulating and visualizing image data. To use iImage, from 
the IDL Command Line, type iImage. An empty iImage tool appears. You can then 
import image data using any of several data import methods. For more information 
importing image data see Chapter 2, “Importing and Exporting Data”.

Note
For more information on accepted arguments and keywords, see “IIMAGE” in the 
IDL Reference Guide manual.

The iImage tool can be launched in many different ways:

• At the IDL Command Line without arguments or keywords

• At the IDL Command Line with arguments or keywords

• Through the File → New → Visualization → iImage menu option in the IDL 
Development Environment

• Through the File → New → iImage menu option in an iTool

Common image file formats accepted are:

• BMP • DICOM

• JPEG • JPEG2000

• PICT • PNG

• TIFF
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Displaying Images

The iImage tool’s primary design is to visualize image data, though the tool is 
capable of much more once the data is displayed. The iImage tool also allows you to 
manipulate and edit the displays. The first task is to display the image data.

Your options for invoking the iImage tool are:

• At the IDL Command Line without arguments or keywords

• At the IDL Command Line with arguments or keywords

For more information on accepted arguments and keywords, see “IIMAGE” in the 
IDL Reference Guide manual.

• Through the File → New → Visualization → iImage menu option in the IDL 
Development Environment

• Through the File → New → iImage menu option in an iTool

To visualize image data in the iImage tool:

1. Image data can be loaded into the data manager. Image data of any supported 
type can also be directly visualized into the iImage tool using File → Open or 
the File Open icon  at the top left of your iImage window, and the File Open 
Dialog appears.
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2. Select the desired image file from your directory structure. For example here 
we will visualize an examples/data file named afrpolitsm.png. Select 
the file name and click Open.

Note
The examples/data subdirectory of your IDL distribution contains a text file 
named index.txt. This file lists all data files available in the example directory 
and also lists their dimensions and values.

Displaying Multiple Images

You can use the window layout dialog to provide for multiple image display within 
your window. To add another image to the window containing the image you just 
visualized:

Figure 10-1: A JPEG File Visualized Using the iImage Tool
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1. From the iImage window displaying the political map of Africa JPEG image, 
select Window → Layout.

The Window Layout dialog contains these items:

• Dimensions — Allows you to enter specific window dimensions.

• Layout — Allows you to pick from a scroll-down list of layout options 
and grids.

• Preview — Gives you a visual preview of the selected layout.

For more information on working with window layouts, see “Window 
Layouts” in Chapter 7, Common Operations.

2. Select a layout, in this case select Gridded and then enter 2 and 1 for Columns 
and Rows and then OK.

Figure 10-2: The Window Layout Dialog
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3. The window now displays a two by two arrangement of views. You will notice 
the original political map of Africa image is shifted to the top-left view. Select 
and highlight the top-right view.

4. Select File → Open or the File Open icon  at the top left of your iImage 
window, and from the File Open Dialog select the examples/data image 
named africavlc.png and click Open.

5. The second image of the African continent now appears in the top-right view.

Figure 10-3: Displaying Multiple Images in iImage
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Using the Image Panel

The image panel appears to the right of the visualization window of the iImage tool. 
This panel allows you to view and manipulate various image properties such as pixel 
location and values and color properties. You can also draw ROIs within your 
visualization. The components and functions of the image panel are discussed in the 
following figure and list.

• ROIs — The ROI buttons on the image panel allow you to draw regions of 
interest within your visualization. For more information on ROIs, see Image 
ROIs in the following section.

• Pixel Location — If your pointer/cursor is held over the visualization, the 
precise pixel location will be shown in this area.

• Pixel Value — Pixel color values are shown in this area.

Figure 10-4: The Image Panel
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Note
If the byte scaled pixel value (used for display) is different from the image 
data value at that pixel, it will be displayed in parentheses.

• Pixel Scale — Pixel scale data is shown in this area.

• Edit Palette — This button is enabled for indexed binary and greyscale color 
images. For more information on the Palette Editor, see The Palette Editor in 
the following section.

• Window Level Control — The window level control allows you to adjust and 
manipulate the image brightness and contrast by changing the RGBA or 
indexed channel values. For more information on the window level control, 
see Window Level Control in the following section.

Image ROIs

The ROI buttons (shown in the Image Panel in the preceding figure) allow you to 
draw regions of interest within your visualization. You can select from rectangular, 
elliptical, polygonal, and freehand region of interest buttons. Once you have created 
your ROI, you can also apply operations to image data contained within an ROI area.

Note
For more information on operations and regions of interest, see “Operations on 
Regions of Interest” in Chapter 7.

Select the desired button and then hold your cursor over the area in the visualization 
where you wish your ROI to appear. Click the left mouse button and drag until the 
ROI is the desired shape and location. ROIs can be selected and moved or deleted 
after they are drawn.

The Palette Editor

RGB images contain their own color information while color information for indexed 
images is separate from the image itself. Color information can be modified for 
indexed and greyscale images. 

The easiest way to modify color attributes for a selected indexed, binary, or greyscale 
image is to click on the Edit Palette... button on the image panel to the right of your 
visualization.

The various components and functions of the Palette Editor are discussed in 
“CW_PALETTE_EDITOR” in the IDL Reference Guide manual.
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Note
You can also access the palette editor by selecting the image visualization (clicking 
once on the visualization and then double-clicking on it to bring up the 
Visualization Browser) and selecting Image Palette → Edit Color Table → Edit.

Window Level Control

The Window Level Control on the iImage tool allows you to adjust and manipulate 
the image brightness and contrast for each channel of the currently selected image. 
The Channel droplist allows you to select the channel to be adjusted. The Link All 
checkbox may be selected to cause all channels to be adjusted simultaneously. A 
small plot window shows the histogram for the currently selected channel. For 
indexed color images, Channel 0 represents the image data values. For RGBA 
images, Channel 0 represents the red values, Channel 1 represents the green values, 
Channel 2 the blue values, and Channel 3 the alpha values (if present). Within the plot 
area is a red bar representing minimum values and a green bar representing maximum 
values. You can click on each bar to manipulate these values. The dotted black bar 
represents the level; you can click and drag this bar to move both the minimum and 
maximum values simultaneously.
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Image Properties

The iImage tool is a self-contained image display and manipulation tool. You can 
import, export, modify, and manipulate image data. For more information on the 
basic iImage interface and its layout, see Appendix A, “iTools Interface Reference”.

Modifying Properties

By selecting Edit → Properties from the iImage tool, you may modify your image 
properties. You may modify your image’s name, description, transparency, 
interpolation, pixel dimensions, pixel origin, and so on. For more information on 
editing properties in the iTools, see Appendix D, “Visualization Properties”.
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Adding a Colorbar

You can add a colorbar to your visualized image which will show on a color scale the 
minimum to maximum pixel values. To add a colorbar, click on the image and then 
from the iImage window, select Insert → Colorbar. A colorbar will be placed in the 
visualization window. This colorbar can be resized and moved around the window. 
You can also double-click on the colorbar to invoke the Visualization Browser, which 
will allow you to change properties for the colorbar.

Figure 10-5: Image With Inserted Colorbar
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Adding Axes

You can add X and Y axes to your image data by selecting Insert → Axis from the 
iTool window. From here you can select X Axis or Y Axis. You can modify axis 
properties by opening the Visualization Browser and selecting Axes and then 
changing the Style property from None to the desired style. Another option is to 
double-clicking on the axis itself within the visualization and modify its properties.

Figure 10-6: Image in iImage with Axes Inserted and Placed
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Resampling an Image

Resampling re-imports the selected image data using parameters specified in the 
Resample properties. Resampling parameters include factors for adjusting the X, Y, 
or Z dimensions of the data, as well as the interpolation method to be used.

To resample image data:

1. Select one or more images in the iImage window for resampling.

2. If necessary, use the Operations Browser to set the desired parameters through 
the Resample properties. See “Resample Properties” on page 377 for details.

3. Select Operation → Transform → Resample.
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Filtering an Image

There are six types of filters available in the iImage tool.

Convolving an Image

To convolve an image:

1. Select the image to be convolved.

2. Select Operations → Filter → Convolution.

3. The convolution filter editor appears (as shown in the following figure) and 
desired settings can be edited.

4. Click OK and the filter is applied.

For more details on the convolution filter, see “Convolution Filter” on page 127 in 
Chapter 8, "Common Operations".

Applying a Median Filter

The median filter replaces each pixel with the median (a value in an ordered set of 
values with an equal number of values above and below it) of the two-dimensional 
neighborhood of a given width.

To apply the median filter to an image:

1. Select the image.

2. Select Operations → Filter → Median.

For more details on the median filter, see “Median Filter” on page 125 in Chapter 8, 
"Common Operations".

Smoothing an Image

The smooth filter removes unwanted noise from an image using a weighted average.

To apply the smooth filter to an image:

1. Select the image.

2. Select Operations → Filter → Smooth.

For more details on the smooth filter, see“Smooth Filter” on page 125 in Chapter 8, 
"Common Operations".
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Applying a Roberts Filter

The Roberts filter uses the Roberts edge enhancement operator to detect edges within 
the image.

To apply the Roberts filter to an image:

1. Select the image.

2. Select Operations → Filter → Roberts.

3. The Roberts filter is applied.

Applying a Sobel Filter

The Sobel filter uses the Sobel edge enhancement operator to detect edges within the 
image.

To apply the Sobel filter to an image:

1. Select the image.

2. Select Operations → Filter → Sobel.

3. The Sobel filter is applied.

Applying an Unsharp Mask

The unsharp mask enhances the contrast between neighboring pixels in an image.

To apply the Unsharp Mask filter:

1. Select the data that you want to unsharp mask.

2. Select Operations → Filter → Unsharp Mask.

For more details on the unsharp mask filter, see “Unsharp Mask Filter” on page 129 
in Chapter 8, "Common Operations".
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Applying a Morphological Operator

Mathematical morphology is a method of processing digital images on the basis of 
shape. Six morphing options are available for use in iImage: dilate, erode, morph 
open, morph close, morph gradient, and morph tophat. For more information on 
morphing, see “Morphing” on page 130 in Chapter 8, "Common Operations". To 
morph your image, select Operations → Morph → <option>.
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Contouring an Image

You can also insert a contoured representation of your image data into your 
visualization. To do this: 

1. From the iImage window containing a visualized image, select 
Operations → Contour.

2. The Contour dialog appears (shown below) allowing you to adjust contour 
setting, including: 

• Number of levels: Set the number of contouring levels

• Value: Set the contour value to use

• Projection: Choose the contour type (Planar or 3D)

3. After making any contour property changes, select OK to contour your image 
data.

Figure 10-7: The Contour Dialog
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The following figure shows contouring added to the image of a meteor surface.

You can highlight and double-click your contoured image data, invoking the 
Visualization Browser which allows you to edit Contour Level properties and 
Contour Level color table data. For more information on these edit options, see 
“Contour” in Appendix D, "Visualization Properties".

Figure 10-8: A Contoured Image in iImage
Contouring an Image iTool User’s Guide
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Surfacing an Image

You can also insert a surface representation of your image data into your visualization 
by selecting Operations → Surface. This causes the display to become three-
dimensional. The following figure shows a surface added to the image of the African 
political map.

You can highlight and double-click your new surface, invoking the Visualization 
Browser which allows you to edit surface properties. For more information on these 
edit options, see “Surface” in Appendix D, "Visualization Properties".

Figure 10-9: Image Data Shown as a Surface
iTool User’s Guide Surfacing an Image
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Manipulating the Image Display

The iImage tool allows you many options to manipulate your existing image displays. 
Once you have visualized your image, you may rotate, flip, translate, scale, and zoom 
as well as modify image properties, scroll, and select image ROIs. The following 
options are available for manipulating images.

For more information on manipulation tasks which are common to iImage as well as 
other iTools, see Chapter 4, “Manipulating the Display”.

Rotating an Image

The rotate operation makes it possible to rotate the image within the visualization by 
a specified number of degrees. To rotate your selected image, select 
Operations → Transform → Rotate Data. For more information about rotating, 
see “Rotation” on page 118 in Chapter 8, "Common Operations".

Scaling an Image and Byte Scaling an Image

It is possible to scale the pixel values within an image by a specified scale factor. To 
scale your image, select Operations → Transform → Scale Data. For more 
information on scaling data, see “Scaling” on page 69 in Chapter 4, "Manipulating 
the Display".

Note
When working with byte data, the default bytescale range is always 0-255. 
Therefore, even if data ranges from 0-100, it will display using 0-255. This may 
cause visualized data to appear darker.

Inverting an Image

You can also invert the data associated with your image, or with each channel of an 
RGB or RGBA image. If the data is byte data, the inversion occurs relative to the 
maximum byte value (255). Otherwise, the inversion occurs relative to the maximum 
data value per channel. To invert your image, select 
Operations → Transform → Invert Image.
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Flipping an Image

You can flip your image within the data space either horizontally or vertically. These 
operations flip the actual data associated with the image. To flip your data, select 
Operations → Flip → Flip Horizontal or Operations → Flip → Flip Vertical.

View Zoom

View Zoom allows you to zoom in or out on a specific area of the image display area. 
To zoom in or out in View Zoom mode click Zoom  on the toolbar or select a 
percentage value from the View Zoom droplist. For more information on working 
with View Zoom, see “Zooming” in Chapter 4, "Manipulating the Display".

Canvas Zoom

Canvas Zoom allows you to increase or decrease the magnification of the entire 
display canvas (which may contain multiple views, depending on the layout) by a 
specified percentage. Canvas Zoom is available by selecting a percentage from the 
Window → Canvas Zoom menu. For more information on working with Canvas 
Zoom, see “Zooming” in Chapter 4, "Manipulating the Display".

Pixel Scaling

The pixel scale represents the number of window pixels used to display a single 
image pixel (horizontally and vertically). Pixel scaling is shown on the image panel 
(which appears on the right side of the iImage tool) and can be manipulated via the 
View Zoom manipulator on the iImage window toolbar and using its accompanying 
pull-down menu.

When an image is first loaded into iImage, the X and Y pixel scales are by default set 
to 100% (one window pixel is used to display one image pixel horizontally). 
Typically, when iImage first displays an image, the view zoom factor matches the X 
pixel scale. Changing the view zoom factor also updates the pixel scale labels.

If the currently selected image has been rotated, or if the visualization has switched to 
3D (for example, because a surface was inserted), then the pixel scale labels are set to 
an empty string.

Region Growing

The iImage region growing operation lets you apply a region growing algorithm to 
the currently selected ROI. A new ROI is then created and displayed. To apply region 
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growing to your ROI, select Operations →  Region Grow. You can then select the 
region grow method (by threshold or by standard deviation).

Adding Annotations

Annotations can be added to label or describe image visualizations displayed in the 
iImage tool.

The following types of annotations can be added to iImage displays:

For more information on creating and using annotations, see Chapter 5, “Adding 
Annotations”.

Line Profiles

You can plot image pixel values along a selected line. These values are extracted as a 
line profile of part of your image visualization and displayed in a new iPlot window:

1. From an iImage window with a visualized image, click on the Line Profile 
icon on the toolbar.

Image 
Annotation 

Type
Description

Text Single lines or multiple lines of text can be added to a 
visualization to provide a label or description

Line Straight line annotations can be added to a visualization to link 
labels to objects or to identify an object

Rectangle Rectangular annotations can be added to a visualization to 
identify rectangular areas

Oval Oval annotations can be added to a visualization to identify 
circular areas

Polygon Polygon annotations can be added to a visualization to identify 
areas bounded by a multi-sided polygon

Freehand Freehand annotations can be added to a visualization to 
identify an area

Table 10-1: Types of Image Annotations
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2. Use the mouse to position the jagged-edge line profile tool over the place 
which you wish your line profile to begin and click.

3. Drag to the ending point of your line profile and release.

4. A new plot window appears showing a plot of the image pixel values that fall 
along that line. 

Once a line profile has been drawn, it will remain until deleted. The line may be 
translated (or its endpoints moved individually). If it is translated or edited, the profile 
plot will automatically update.

View Panning

To pan an image, select the View Pan tool button  on the toolbar and then click on 
the image and drag until it is in the desired location. Panning causes the extents of the 
visible portion of the view to be shifted.

Cropping an Image

The iImage crop manipulator button allows you to crop your image to your specified 
size and dimension. It also allows you to translate and resize the crop box, and then 
apply the crop to the currently selected image or images. The button appears in the 
toolbar as shown in the following figure.

The crop box will appear only if information has been set and is applicable to the 
currently-selected image. If the crop box information has not been set for the crop 
operation, or does not fit within your image, then no crop box appears. For more 
information see “Cropping Images” on page 221

If no crop box visual is present, you can click using the mouse anywhere on an image 
and drag to create a crop box.

Figure 10-10: The Crop Manipulator Button on the Toolbar

Crop Manipulator Button
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Note
All portions of the image that fall outside of the crop box are grayed out.

Once a crop box is present, it may be translated (by clicking and dragging anywhere 
within the crop box, or along its edges) or scaled (by clicking and dragging on one of 
the scale handles). A new crop box can also be created by clicking anywhere within 
the gray area outside of the current crop box.

The arrow keys can also be used to translate the crop box (when the mouse location is 
anywhere within the crop box or along its edges).

When your crop box is correctly sized and positioned, you can crop the image by:

• Double-clicking anywhere within the defined crop box

• Right clicking to invoke the context menu, and then selecting Crop

• Selecting Operations →  Crop from the iImage tool.
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iImage Tool Operations

The iImage tool provides the following operations:

Viewing a Histogram

A histogram is a density plot showing a distribution of data values. To view a 
histogram of image data, use the iTool’s histogram feature by selecting 
Operations →  Histogram. For information on histogram creation, see “Plotting a 
Histogram” in Chapter 7, "Common Operations".

Viewing Image Statistics

To view statistics for image data or for ROIs, use the iTool’s statistics feature by 
selecting Operations →  Statistics. For information on viewing statistics, see 
“Displaying Statistics” in Chapter 7, "Common Operations".

Cropping Images

The iImage cropping operation allows you to crop one or more selected images at a 
specified location and specified dimensions. To activate the cropping operation, select 
Operations →  Crop. The Crop manipulator is automatically activated.

Note
The appearance of this dialog can be disabled for future uses of the crop operation 
by setting the Show dialog property to False.

Figure 10-11: The Crop Operation Dialog
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The X, Y and Width, Height properties in the dialog represent the location and 
dimensions of the crop box to be applied. If these values have never been set, they are 
by default initialized to match the full extent of your first selected image. If these 
values have previously been set, they are constrained to fit within the first selected 
image. You can enter new values manually, or the mouse can be used to define, resize, 
and/or translate the crop box.

The Units property can be set to indicate the units of measure to be used for reporting 
crop box coordinates. The default is data units. This property will automatically reset 
to data units (and become de-sensitized) if multiple images are selected and their 
pixel origins or pixel sizes differ.

Once your crop dialog is present on your image, you can crop by doing the following:

• Double-clicking anywhere within your defined crop box (in the primary 
visualization window).

• Pressing the Crop button within the crop operation dialog.

Once your image is cropped, the original image is replaced by the new, cropped 
image data. You can only retrieve your original data by selecting Edit →  Undo crop, 
or by reloading the original image data as a separate visualization.

Note
If your original image contains any ROIs, those that do not lie completely within the 
crop box will be lost in the new image.
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Working with Surfaces 
This chapter describes how to work with surfaces in the iSurface tool.
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Introduction

The IDL iSurface tool provides interactive access to surface data. You can visualize 
surfaces and then modify and manipulate those surfaces in the ways that you need. 
The following sections describe how surfaces can be displayed, modified, and 
manipulated in iSurface.

To use iSurface from the IDL Command Line, type iSurface. An empty iSurface tool 
appears. You can then import surface data using any of several data import methods. 
For more information on importing surface data, see Chapter 2, “Importing and 
Exporting Data”.

Note
For more information on accepted arguments, see “ISURFACE” in the IDL 
Reference Guide manual.

The iSurface tool can be launched in the following ways:

• At the IDL Command Line without arguments or keywords

• At the IDL Command Line with arguments and keywords

• Through the File → New → Visualization → iSurface menu option in the 
IDL Development Environment

• Through the File → New → iSurface menu option in an existing iTool
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Displaying Surfaces

Three-dimensional visualizations of surfaces can be displayed in the iSurface 
window.

To open an iSurface window, do one of the following:

• At the IDL command line, enter ISURFACE

• From an iTool window, select File → New and select iSurface

Surface data can be displayed by specifying data parameters at the IDL command 
line, or by importing a binary or ASCII text file containing surface data.

To import a file containing surface data into the iSurface tool:

1. Select File → Open from the iSurface tool and locate the file to open. For 
example, from your IDL examples/data directory, select idemosurf.dat.

2. Double-click the filename or select the filename and click Open to open the 
surface data file. You will be prompted to enter information regarding your file 
type (for example, ASCII or binary). For more information on entering this 
information and on importing data, see Chapter 2, “Importing and Exporting 
Data”. In this example, enter demosurface for your template name and then 
select New Field and specify demosurface as the Field Name and specify it as 
a two-dimensional 200 by 200 Floating type. 
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3. Then select OK and OK to dismiss and visualize.

Figure 11-1: Surface Data Visualized in iSurface
Displaying Surfaces iTool User’s Guide
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Surface Properties

Surfaces have attributes or properties that can be modified to change their 
characteristics. These properties are organized into property sheets for each operation 
and visualization type. For example, the skin of a surface visualization has a gold 
color by default. To change this color, modify the surface color property in the 
surface visualization property sheet.

To display the property sheet for a surface, do one of the following:

• Double-click the surface in the iTool window

• Select the surface, and select Edit → Properties

• Display the Visualization Browser, and double-click the entry for the surface

For more information, see Chapter 6, “Property Sheets and Browsers”.

The Visualization Browser

The Visualization Browser provides a nested list of all visualizations displayed in the 
iSurface window. From the Visualization Browser, you can select visualizations and 
display property sheets for those visualizations.

To display the Visualization Browser:

1. Select Window → Visualization Browser.

2. Do either of the following:

• Click an item to select it in the Visualization Browser

• Double-click an item in the iTool window to display its property sheet

For more information, see Chapter 6, “Property Sheets and Browsers” and Appendix 
D, “Visualization Properties”.
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The Operations Browser

The Operations Browser provides a nested list of all operations available from the 
iSurface Operations menu. From the Operations Browser, you can display property 
sheets for each of the items in the iSurface Operations menu.

To display the Operations Browser:

1. Select Operations → Operations Browser

2. Click an item to display its property sheet

For more information, see Chapter 6, “Property Sheets and Browsers” and Appendix 
C, “Operations Properties”.
Surface Properties iTool User’s Guide
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Adding a Colorbar

If you have added vertex coloring or texture to your surface visualization, you can 
add a colorbar that will show on a color scale the minimum to maximum values of 
data in the visualization. To add a colorbar, click on the surface data and then from 
the iSurface window, select Insert → Colorbar. A colorbar will be placed in the 
visualization window. This colorbar can be resized and moved around the data space. 
You can also double-click on the colorbar to invoke the Visualization Browser which 
will allow you to change the values for the colorbar. For more information on the 
colorbar, see “Colorbar” in Appendix D, Visualization Properties.
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Adding a Light

Adding a light to your surface display allows you to highlight various parts of the 
surface. To add a light to your surface display, select Insert → Light. you can click 
on the light bulb which appears and drag it around the display area to manipulate the 
lighting. You can also adjust the lighting settings using the Visualization Browser by 
double-clicking on the light bulb.

Figure 11-2: Inserting Light into a Surface Display
Adding a Light iTool User’s Guide
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Adding a Legend

Legends identify the visualizations displayed in the iTool window. Legends can be 
displayed in the iSurface window to identify surfaces and contours on those surfaces.

To insert a legend for a surface or contour:

1. Select specific items to include in the legend, or click in an empty area of the 
iSurface dataspace to deselect and include all dataspace items in the legend.

2. Select Insert → New Legend.

To add to a legend:

1. Select the visualization item or items to add to the legend.

2. If there are multiple legends, add the desired legend to the selection by shift-
clicking the legend border.

3. Select Insert → Legend Item.

Note
Only a single legend item may exist for a given visualization. If you are inserting 
multiple visualization items into an existing legend, only legend items for those 
visualizations not already represented will be added to the legend.

For more information, see “Legends” on page 79 in Chapter 5, "Adding 
Annotations".
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Adding Axes

By default, surfaces are displayed with X, Y and Z axes. The display of these axes is 
controlled by property sheets for the axes container and for individual axes (see 
“Axes” in Appendix D). Additional X, Y or Z axes can be added to a surface 
visualization to make it easier to identify surface characteristics.

To add an axis to your surface visualization:

1. Select the surface.

2. Select Insert → Axis.

3. Choose from the following options:

• X axis

• Y axis

• Z axis

Use the mouse to position the new axis, and double-click the axis to display the axis 
property sheet. 

For more information on adding axes, see “Additional Axes” on page 86 in Chapter 5, 
"Adding Annotations".
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Imaging a Surface

You can insert an image of your surface data by using Operations → Image. An 
image visualization of your original surface data is then displayed with your original 
surface visualization.

For example at the IDL command line, 

1. Enter iSurface, DIST (10)

2. Now select Operations → Image

Figure 11-3: Surface Visualization with Image Added
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Contouring a Surface

Contour lines can be drawn directly on a surface to provide information about the 
levels of the surface, such as elevation. Two types of contours can be applied: 
multiple-level contour operations that apply to the surface in general, and single-level 
contour objects applied at a specific location on the surface.

To add contour lines to a surface:

1. Select the surface in the iTools window. For example, select the 
isurfdemo.dat surface data previously visualized.

2. Select Operations → Contour. 

3. The Contour dialog appears (shown below) allowing you to adjust contour 
setting, including: 

• N_LEVELS: Set the number of contouring levels

• Value: Set the contour value to use

• Projection: Choose the contour type (Planar or 3D)

4. After making any contour property changes, select OK to contour your 
surface.

Figure 11-4: The Contour Dialog
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5. Contour lines are applied to the surface at the interval specified in the contour 
dialog.

6. To adjust the properties of the contour, double-click the contour in the iTool 
window or in the Visualization Browser to display the Contour property sheet. 
For information on the contour properties, see “Contour” in Appendix D, 
"Visualization Properties".

To insert a contour object at a specific location on a surface:

1. Select a surface in the iSurface window.

2. Click the Surface Contour button  in the Manipulator toolbar. 

3. Click the level on the surface at which you would like the contour to appear. 
Contour lines are displayed on the surface at that level.

4. To adjust the properties of the contour object, double-click the contour object 
in the iTool window or in the Visualization Browser to display the Contour 
property sheet. For information on the contour properties, see “Contour” in 
Appendix D, "Visualization Properties".

Figure 11-5: Surface with Contours Added
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Resampling a Surface

Once surface data has been imported into the iSurface window, that data can be re-
imported using different import parameters by resampling the data. See “Resample” 
on page 122, in Chapter 4, "Common Operations" for details.

To resample a surface:

1. Select a surface in the iSurface window. For example, select the 
isurfdemo.dat surfaced data.

2. Select Operations → Transform → Resample.

Figure 11-6: Resampled Surface in iSurface
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Filtering a Surface

Three types of filters are available in the iSurface tool: smooth filtering and 
convolution filtering.

Convolving a Surface

To convolve a surface:

1. Select the surface to be convolved.

2. Select Operations → Filter → Convolution. 

For details on using the convolution filter, see “Convolution Filter” on page 127 in 
Chapter 8, "Common Operations".

Median a Surface

The median filter replaces each point with the median (a value in an ordered set of 
values with an equal number of values above and below it) of the one- or two-
dimensional neighborhood of a given width.

to median a surface:

1. Select the surface.

2. Select Operations → Filter → Median.

For details about using the median filter, see “Median Filter” on page 125 in Chapter 
8, "Common Operations".

Smoothing a Surface

The smooth filter removes unwanted noise from a surface. 

To apply the smooth filter to a surface:

1. Select the surface.

2. Select Operations → Filter → Smooth.

For details on using the smooth filter, see “Smooth Filter” on page 125 in Chapter 8, 
"Common Operations".
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Adding a Texture Map

An image file can be imported into a surface visualization to serve as a texture map: 
an image projected onto the surface skin in place of the default red skin.

To add a texture map to a surface:

1. Select the surface.

2. Select Edit → Parameters to open the Parameter Editor.

3. Click Import File to import the image file to be used as a texture map into the 
Data Manager.

4. Find the image file in the list of files in the Data Manager tree and select either 
a specific image channel to import, or select Image Planes to import all 
channels of the image.

5. Click the Assign Data button  under TEXTURE. The name of the data to 
import appears in the TEXTURE field.

6. Click OK. The Parameter Editor window closes, and the texture map appears 
on the surface.

Figure 11-7: TEXTURE Field in Parameter Editor

Clear data

Assign data
Data name
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Manipulating Surface Displays

The iSurface tool provides options for manipulating surface data. You can rotate as 
well as scale surfaces. These manipulations are described in the following sections.

Rotating a Surface

Rotation tools are provided in the iSurface tool to make it easier to see all aspects of a 
3-D surface visualization. Surfaces can be rotated freely or along an axis with the 
mouse, and they can be rotated in fixed or arbitrary increments from the Operations 
menu.

To rotate a surface freely or along an axis with the mouse:

1. Select the surface in the iSurface window.

2. Click Rotate  on the Manipulator toolbar. The rotation sphere is displayed 
around the surface.

Figure 11-8: Surface with Rotation Sphere Displayed
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• To rotate the surface freely, position the mouse pointer over the surface so 
that it changes to a free rotation pointer . Click and drag to rotate the 
surface in the desired direction.

• To rotate the surface along an axis, position the mouse pointer over an axis 
so that it changes to an axis rotation pointer . Click and drag to rotate 
the surface along the axis in the desired direction.

To rotate a surface in 90° increments left or right from the Operations menu:

1. Select the surface in the iTool window.

2. Select Operations → Rotate → Rotate Left or Operations → Rotate → 
Rotate Right.

To rotate a surface an arbitrary number of degrees from the Operations menu:

1. Select the surface in the iTool window.

2. Select Operations → Rotate → Rotate by Angle.

3. In the Rotate Angle dialog, enter the desired number of degrees to rotate the 
surface.

For more information, see “Rotation” on page 118 in Chapter 8, "Common 
Operations".

Scaling a Surface

Surfaces can be scaled freely, or scaling can be constrained to one or more 
dimensions.

To scale a surface freely:

1. Select the surface in the iTool window.

2. Position the mouse pointer over a side of the data set bounding box so that it 
changes to an unconstrained scaling pointer . 

3. Click and drag to scale all points of the surface in the desired direction.

To constrain scaling of a surface:

1. Select the surface in the iTool window.
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2. Position the mouse pointer over an axis “whisker” to scale along only one axis, 
or over a corner of the bounding box for multi-axis scaling.

3. Click and drag to scale in the desired direction.

For more information, see “Scaling” in Chapter 4, "Manipulating the Display".

Adding Annotations

Annotations can be added to label or describe surface visualizations displayed in the 
iSurface tool.

The following types of annotations can be added to iSurface displays:

Figure 11-9: Constrained Single-Axis (left) and Multi-Axis (right) Scaling

Plot 
Annotation 

Type
Description

Text Single lines or multiple lines of text can be added to a 
visualization to provide a label or description.

Line Straight line annotations can be added to a visualization to link 
labels to objects or to identify an object.

Table 11-1: Types of Surface Annotations
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For more information on creating and using annotations, see Chapter 5, “Adding 
Annotations”.

View Zoom

View Zoom allows you to zoom in or out on a specific area of the surface display 
area. To zoom in or out in View Zoom mode click Zoom  on the toolbar. For more 
information on working with View Zoom, see “Zooming” in Chapter 4, 
"Manipulating the Display".

Canvas Zoom

Canvas Zoom allows you to increase or decrease the magnification of the entire 
display canvas (which may contain multiple views, depending on the layout) by a 
specified percentage. Canvas Zoom is available by selecting the pull-down 
percentage list from the top of the tool just under the Help menu. For more 
information on working with Canvas Zoom, see “Zooming” in Chapter 4, 
"Manipulating the Display".

Extracting a Line Profile

To extract a line profile of part of your surface visualization in an iPlot window:

1. Click on the Line Profile icon on the iSurface window toolbar.

Rectangle Rectangular annotations can be added to a visualization to 
identify rectangular areas.

Oval Oval annotations can be added to a visualization to identify 
elliptical areas.

Polygon Polygon annotations can be added to a visualization to identify 
areas bounded by a polygon.

Freehand Freehand annotations can be added to a visualization to 
identify an area.

Plot 
Annotation 

Type
Description

Table 11-1: Types of Surface Annotations (Continued)
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2. use the mouse to position the jagged-edge line profile tool over the place which 
you wish your line profile to begin.

3. Drag to the ending point of your line profile.

4. The profile plot appears in an iPlot window.

Once a line profile has been drawn, it will remain until deleted. The line may be 
translated (or its endpoints moved individually) by switching back to the arrows. If it 
is translated or edited, the profile plot will automatically update.
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iSurface Tool Operations

The iSurface tool provides the following operations:

Viewing a Histogram Plot

To display a histogram plot of your surface:

1. Select the surface.

2. Select Operations → Histogram. 

For more information, see “Plotting a Histogram” in Chapter 7, "Common 
Operations".

Viewing Statistics

To display the Statistics dialog:

1. Select an object or a group of objects in the iTools window.

2. Select Operations → Statistics. The Statistics window displays the statistics 
for the selected object(s).

For more information, see “Displaying Statistics” in Chapter 7, "Common 
Operations".
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Working with Contours 
This chapter describes how to work with contours in the iContour tool.
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Introduction

The IDL iContour tool allows you interactive access to contour data. You may 
visualize contours and then modify and manipulate those contours in the ways that 
you need.

The IDL iContour tool displays your data as contours and allows you great flexibility 
in manipulating and visualizing these contours. The iContour tool can be used for 
irregular or regular grid data. Irregularly-grid data arranged as three fields (three one-
dimensional vectors) are gridded by a Gridding Wizard if this data is imported into 
the iTool. Regular grid data arranged as a two-dimensional array is directly imported.

To use iContour from the IDL Command Line, type iContour. An empty iContour 
tool appears. You can then import contour data using any of several data import 
methods. For more information on importing contour data, see Chapter 2, “Importing 
and Exporting Data”.

Note
For more information on accepted arguments and keywords, see “ICONTOUR” in 
the IDL Reference Guide manual.

The iContour tool can be launched in the following ways:

• At the IDL Command Line without arguments or keywords

• At the IDL Command Line with arguments and keywords

• Through the File → New → Visualization → iContour menu option in the 
IDL Development Environment

• Through the File → New → iContour menu option in an existing iTool
Introduction iTool User’s Guide
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Displaying Contours

The iContour tool’s primary purpose is to display contours, though the tool is capable 
of much more once the data is displayed. The iContour tool can display regular-grid 
data or irregular-grid data. Gridding is the creation of uniformly-spaced planar data 
from data points. These points may initially be irregular.

Displaying Regular-grid Data

Regular-grid data points are presented by two-dimensional arrays. The following 
example shows one way of importing and displaying this type of data into the 
iContour tool. The 248-by-248 two-dimensional array contained within the 
convec.dat binary file in the examples/data directory is imported into IDL with 
the READ_BINARY function. The iContour tool then displays this data as contours.

At the IDL Command Line, enter:

file = FILEPATH('convec.dat', SUBDIRECTORY = ['examples', 'data'])
data = READ_BINARY(file, DATA_DIMS = [248, 248])
iTool User’s Guide Displaying Contours
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iContour, data

Note
The examples/data directory of your IDL 6.1 distribution contains a text file 
named index.txt. This file lists all data files available in the example directory 
and also lists their dimensions and values.

Displaying Irregular-grid Data

Irregular-grid data points are presented by three one-dimensional vectors, usually 
known as fields. The following example shows one way of importing and displaying 
this type of data into the iContour tool. The three fields contained within the 
irreg_grid1.txt ASCII file in the examples/data directory is imported into 
IDL with the File → Open option in the iContour tool. This option uses the ASCII 
Template wizard to import the data, which is then gridded into contour data with the 
Gridding Wizard. The iContour tool then displays this data as contours.

Figure 12-1: Earth Convection Contours in the iContour Tool
Displaying Contours iTool User’s Guide
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1. At the IDL Command Line, enter:

ICONTOUR

2. Select File → Open from the pulldown menus of the empty iContour tool. The 
Open dialog will appear.

3. Use the Open dialog to find and select the irreg_grid1.txt file in the 
example/data directory. The ASCII Template wizard will appear.

The irreg_grid1 file contains three columns of data points. These columns 
represent the x-locations, y-locations, and the elevation (respectively) of this 
data. These columns are specified as three fields (vectors) of data with the 
ASCII Template wizard.

4. Click Next on the first and second step of the wizard, then click Finish on the 
third (last) step of the wizard. The IDL iTools Create Visualization dialog 
will appear.

The IDL iTools Create Visualization dialog contains the following choices:

• Launch the gridding wizard

• Select a visualization and specify parameters

• Do not create a visualization

Figure 12-2: The iTools Create Visualization Dialog
iTool User’s Guide Displaying Contours
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5. Select the Launch the gridding wizard radio button, then click OK. The IDL 
Gridding Wizard Step 1 of 3 dialog will appear.

The Gridding Wizard allows you to specify the method of gridding while 
showing you the possible results for that method. The IDL Gridding Wizard 
Step 1 of 3 dialog contains the following items:

• Number of points entered

• X Coordinates — X coordinate range

• Y Coordinates — Y coordinate range

• Data values — Data values are shown here

• Spherical data checkbox — Check to make data spherical

• Coordinate diagram — Shows coordinates of grid data

• Show points checkbox — Select to show all points (default is checked)

• Help — Obtain help on this dialog

• Back — Return to previous step

• Next — Proceed to Step 2 of 3

Figure 12-3: The IDL Gridding Wizard Step 1 of 3
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• Cancel — Dismiss the Gridding Wizard

6. In the Gridding Wizard Step 1, click Next to accept the interpolation of data 
values and locations. The IDL Gridding Wizard Step 2 of 3 dialog will 
appear.

The IDL Gridding Wizard Step 2 of 3 dialog contains the following items:

• X Coordinates — modify dimension, start or end

• Y Coordinates — modify dimension, start or end

• Coordinate diagram — Shows coordinates of grid data

• Show points checkbox — Select to show all points (default is checked)

• Help — Obtain help on this dialog

• Back — Return to previous step

• Next — Proceed to Step 3 of 3

• Cancel — Dismiss the Gridding Wizard

Figure 12-4: The IDL Gridding Wizard Step 2 of 3
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7. At Step 2, click Next to accept the dimensions, start and spacing. The IDL 
Gridding Wizard Step 3 of 3 dialog will appear.

The IDL Gridding Wizard Step 3 of 3 dialog contains the following items:

• Choose gridding method — Choose from pull-down list of methods

• Preview — Click to preview selected method and data

• Auto preview — Checkbox to turn auto preview on (default = off)

• Statistics tab — Shows data statistics

• Options tab — Set options for missing values, smoothing, weighting, 
andanistropy between axes

• Search tab — Set options for using search ellipse

• Coordinate diagram — Shows coordinates of grid data

• Show points checkbox — Select to show all points (default = checked)

• Help — Obtain help on this dialog

• Back — Return to previous step

• Finish — Dismiss the Gridding Wizard with data gridded

Figure 12-5: The IDL Gridding Wizard Step 3 of 3
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• Cancel — Dismiss the Gridding Wizard

8. At Step 3, select Inverse Distance as the gridding method and click Finish to 
display the surface.

9. The resulting contours are displayed in the iContour tool.

Figure 12-6: Irregular-grid Elevation Contours in the iContour Tool
iTool User’s Guide Displaying Contours
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Contour Properties

The iContour window is a self-contained contour display and manipulation device. 
You can import and export contour data, and modify and manipulate contours. For 
more information on the basic iContour interface and its layout, see Appendix A, 
“iTools Interface Reference”.

With the contour selected, the Edit → Properties... option allows access to the 
contour property sheet. You can change many contour properties through this sheet.

The following examples show how to modify some contour properties. These 
examples are performed on the contours imported by using the following steps:

1. At the IDL Command Line, enter:

ICONTOUR

2. Select File → Open from the pulldown menus of the empty iContour tool. The 
Open dialog will appear.

Figure 12-7: Contour Property Sheet
Contour Properties iTool User’s Guide
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3. Use the Open dialog to find and select the convec.dat file in the 
example/data directory. The Binary Template wizard will appear.

4. In the Binary Template dialog, click New Field, and enter the following 
information in the New Field dialog:

• Field name: data (or a name of your choosing)

• Type: byte

• Number of dimensions: 2

• 1st dimension Size: 248

• 2nd dimension Size: 248

5. Click OK to close the New Field dialog and the Binary Template dialog, and 
the contours are displayed in the tool.

Figure 12-8: Earth Convection Contours in the iContour Tool
iTool User’s Guide Contour Properties
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Labelling Contours

Each contour level line has its own properties. You can access these properties 
through Contour level properties in the contour property sheet by clicking Contour 
level properties, clicking on the arrow button, and then clicking Edit... The Contour 
Levels property sheet will appear.

Figure 12-9: Contour Levels Property Sheet
Labelling Contours iTool User’s Guide
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The first column of the Contour Levels property sheet contains the property values 
for all the levels. In this column, change the Label setting from None to Value. The 
value of each contour line appears as labels in the iContour display.

Figure 12-10: Labelled Contour Levels
iTool User’s Guide Labelling Contours
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Changing the Contour Colors

The columns after the first one are for each individual contour level. In each level 
column, change the Color setting from black to a different color making sure to use a 
different color for each level. When a level color is changed in the property sheet, that 
level is updated in the iContour display.

The resulting display contains a different color contour for each level.

After changing the colors of each level, click OK in the Contour Levels property 
sheet. The Contour Labels property sheet closes.

Figure 12-11: Color Contour Levels
Changing the Contour Colors iTool User’s Guide



Chapter 12: Working with Contours 259
Filling Contours

The Fill contours setting in the original contour property sheet controls whether the 
contour levels are filled or not. Change the Fill contours setting to True.

Note
You must also change the Use palette color setting to True as well before colors 
can be used. After that, you can choose or set your own color scheme from the 
Levels Color Table → Edit color table function.

The contour colors are now more distinctive.

Even more detail can be added by increasing the number of levels in the contour 
display. Change the Number of levels from 6 to 20.

Figure 12-12: Filled Contour Levels Using the Predefined Blue Waves Scheme
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The color set for each of the original seven levels is repeated every set of seven within 
the 20 new levels.

Figure 12-13: 20 Filled Contour Levels Reset at 20 Levels
Filling Contours iTool User’s Guide
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Adding a Colorbar

You can add a colorbar to your visualized contour which will show on a color scale 
the minimum to maximum values of data in the visualization. To add a colorbar, click 
on the contour data and then from the iContour window, select Insert → Colorbar. 
A colorbar will be placed in the visualization window.

Note
Be sure that the Use palette color setting in the Visualization Browser is True so 
that colors can be used. After that, you can choose or set your own color scheme 
from the Levels Color Table → Edit color table function.

This colorbar can be resized and moved around the data space. You can also double-
click on the colorbar to invoke the Visualization Browser which will allow you to 
change the values for the colorbar and edit color tables. For more information on the 
colorbar, see “Colorbar” in Appendix D, "Visualization Properties".
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Adding a Legend

You can add a legend to your contour which shows the levels of the contour in their 
increments. To add a legend, select Insert → New Legend from the iContour tool 
window.

Once you have placed a legend on your contour can edit the legend settings such as 
the title and level increments as well as the color options on the legend. Double-
clicking on the legend itself will show you the Visualization Browser. For more 
information on the options available, see “Legend Properties” in Appendix D, 
"Visualization Properties".

Figure 12-14: A Contour With Legend Added Showing Levels
Adding a Legend iTool User’s Guide
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Adding Axes

You can also add axes to your contour as visual aids for reading contour data. 
Although axes are added to two-and three dimensional contour data there are 
advantages to adding additional axes. For example in the figure which follows, 
additional axes have been added in order to create a box-style contour showing the 
tick marks and increments on all sides of the image. You can add X, Y and Z axes 
depending on your contour and needs. To insert axes, select Insert → Axis and then 
select X Axis, Y Axis, or Z Axis or from the Visualization Browser, select the Axes 
group and then set Style to Box Axes.

Once you have placed an axis on your contour you can edit the axis settings by 
changing the title and increments as well as the color options on the axis. Double-
clicking on the axis itself will show you the Visualization Browser.

Figure 12-15: A Contour With Axes Added and Altered in Box-Style
iTool User’s Guide Adding Axes
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Filtering a Contour

The iContour tool allows you to modify your contour data in the following ways:

Contour Smoothing

Within the iContour tool, contours can also be smoothed to refine edges or 
compensate for random noise in the data. To smooth your data from the iContour 
window, select Operations →  Filter →  Smooth.

Note
The previous figure shows brain MRI data taken from the IDL examples\data 
directory in a file named mr_brian.dcm.

Note
The window’s default size is three, however this can be changed via the operations 
browser. For more information on smoothing properties, see “Smooth Properties” in 
Appendix C, “Operations Properties”.

Figure 12-16:  Brain MRI Data (left) and Smoothed Data (right)
Filtering a Contour iTool User’s Guide
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Contour Convolution

You can also use iContour convolution feature by selecting Operations →  Filter →  
Convolution. By selecting this, the Convolution Editor appears:

Figure 12-17: Default Convolution Editor Dialog
iTool User’s Guide Filtering a Contour
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From this dialog, you can select the desired convolution type from a drop-down list or 
you may manipulate the columns and rows and scale factor and details manually.

For more information on convolution properties, see “Convolution Properties” in 
Appendix C, “Operations Properties”.

Figure 12-18: Brain MRI Data (left) and Convolved (right) Using the Default 
Gaussian Convolution
Filtering a Contour iTool User’s Guide
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Manipulating the Contour Display

The iContour tool allows you many options to manipulate your existing plot displays. 
Once you have visualized your contours, you may rotate, flip, translate, scale, and 
zoom as well as modify contour properties, scroll, and select contour ROIs. The 
following options are available for manipulating contours.

Translating

Translation moves an object or group of objects in a specific direction. When an 
object is selected, a bounding box appears around the object. For information on 
translating objects, see “Translation” in Chapter 4, "Manipulating the Display".

View Zoom

View Zoom allows you to zoom in or out on a specific area of the contour display 
area. To zoom in or out in View Zoom mode click Zoom  on the toolbar. For more 
information on working with View Zoom, see “Zooming” in Chapter 4, 
"Manipulating the Display".

Flipping a Contour

You can flip your contour within the data space either horizontally or vertically. 
These operations flip the actual data associated with the contour. To flip your data, 
select Operations → Flip → Flip Horizontal or Operations → Flip → Flip 
Vertical.

Canvas Zoom

Canvas Zoom allows you to increase or decrease the magnification of the entire 
display canvas (which may contain multiple views, depending on the layout) by a 
specified percentage. Canvas Zoom is available by selecting the pull-down 
percentage list from the top of the tool just under the Help menu. For more 
information on working with Canvas Zoom, see “Zooming” in Chapter 4, 
"Manipulating the Display".
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Scaling a Contour Display

The iContour tool allows you to scale your contour data by selecting 
Operations → Transform → Scale Data. You can scale your data by a factor which 
you provide in the Scale Factor dialog.

Once you have set the scale factor, select OK and the scaling takes place.

You may zoom in and out from your plot using either the Zoom In and Zoom Out 
buttons on the iPlot toolbar, or by selecting Window → Zoom In or 
Window → Zoom Out. 

Adding Annotations

The following types of annotations can be added to iContour displays:

Figure 12-19: Setting the Contour Scale Factor

Plot 
Annotation 

Type
Description

Text Single lines or multiple lines of text can be added to a 
visualization to provide a label or description.

Line Straight line annotations can be added to a visualization to link 
labels to objects or to identify an object.

Rectangle Rectangular annotations can be added to a visualization to 
identify rectangular areas.

Oval Oval annotations can be added to a visualization to identify 
oval areas.

Table 12-1: Types of Contour Annotations
Manipulating the Contour Display iTool User’s Guide



Chapter 12: Working with Contours 269
For more information on creating and using annotations, see Chapter 5, “Adding 
Annotations”.

Polygon Polygon annotations can be added to a visualization to identify 
areas bounded by a polygon.

Freehand Freehand annotations can be added to a visualization to 
identify an area.

Plot 
Annotation 

Type
Description

Table 12-1: Types of Contour Annotations
iTool User’s Guide Manipulating the Contour Display



270 Chapter 12: Working with Contours
iContour Tool Operations

Viewing a Histogram

A density histogram is a density plot showing the distribution of data values. The X-
axis represents data values and the Y-axis represents density or frequency. Another 
type of histogram is a style plot histogram. To view a density histogram of contour 
data, use the iTool’s histogram feature by selecting Operations →  Histogram. For 
information on histogram creation, see “Plotting a Histogram” in Chapter 7, 
"Common Operations".

Viewing Statistics

To view statistics for contour data, use the iTool’s statistics feature by selecting 
Operations →  Statistics. For information on viewing statistics, see “Displaying 
Statistics” in Chapter 7, "Common Operations".
iContour Tool Operations iTool User’s Guide
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Working with Plots
This chapter describes plotting tasks and the iPlot tool.
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Introduction

The IDL iPlot tool displays your data in plot form. The iPlot tool then allows you 
great flexibility in manipulating and visualizing plot data. iPlot can be used for any 
type of two- or three-dimensional plot, including scatter plots, line plots, polar plots, 
and histogram plots. To use iPlot, from the IDL Command Line, type iPlot. An 
empty iPlot tool appears. You can then import plot data using any of several data 
import methods. For more information importing plot data see Chapter 2, “Importing 
and Exporting Data”.

Note
For more information on accepted arguments, see “IPLOT” in the IDL Reference 
Guide manual.

The iPlot tool can be launched in many different ways:

• At the IDL Command Line without arguments or keywords

• At the IDL Command Line with arguments or keywords

• Through the File → New → Visualization → iPlot menu option in the IDL 
Development Environment

• Through the File → New → iPlot menu option in an iTool
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Displaying Two-Dimensional Plots

The iPlot tool’s primary design is to display plot data, though the tool is capable of 
much more once the data is plotted. The iPlot tool can display multiple types of plots 
and allows you to manipulate and edit the displays. 

The first task is to display plot data. Here is a simple example of how to display a 
plot.

At the IDL command line, enter:

iPlot, RANDOMU(seed, 20)

Figure 13-1: A Simple 2D Plot Using the iPlot Tool
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Note
The examples/data directory of your IDL 6.1 distribution contains a text file 
named index.txt. This file lists all data files available in the example directory 
and also lists their dimensions and values.
Displaying Two-Dimensional Plots iTool User’s Guide
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Displaying Three-Dimensional Plots

iPlot can display multiple types of plots and allows you to manipulate and edit the 
displays. You can also display three-dimensional plots. Here is a simple example of 
how to display a 3D plot. 

At the IDL command line, enter:

iPlot, FINDGEN(20), FINDGEN(20), RANDOMU(seed, 20)

Figure 13-2: A Simple 3D Plot Using the iPlot Tool
iTool User’s Guide Displaying Three-Dimensional Plots
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Displaying Polar Plots

iPlot can display multiple types of plots and allows you to manipulate and edit the 
displays. You can also display polar plots. Here is a simple example of how to display 
a polar plot.

At the IDL command line, enter:

iPlot, FINDGEN(20), FINDGEN(20), /POLAR

Note
The examples/data directory of your IDL 6.1 distribution contains a text file 
named index.txt. This file lists all data files available in the example directory 
and also lists their dimensions and values.

Figure 13-3: A Simple Polar Plot Using the iPlot Tool
Displaying Polar Plots iTool User’s Guide
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Overplotting

Once you have plotted data, you may overplot new plot data in the original iPlot 
window. Overplotting is the process of plotting new data over the top of original data 
or datasets for the purpose of analyzing or comparing more than one dataset at a time.

For example, in order to overplot cosine data onto a plot of sine wave data follow 
these steps:

1. Create a variable named “theory” to contain sine wave data to be plotted:

theory = SIN(2.0*FINDGEN(200)*!PI/25.0)*EXP(-0.02*FINDGEN(200))

2. Plot theory using iPlot:

iPlot, theory 

Figure 13-4: Sin Wave Data Plotted
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3. Create a variable named “newtheory” which stores cosine data to be used for 
overplotting:

newtheory = COS(2.0*FINDGEN(200)*!PI/25.0)*EXP(-0.02*FINDGEN(200))

4. Now overplot the new cosine data onto your original plot:

iPlot, newtheory, /OVERPLOT

Figure 13-5: Cosine Data Overplotted on Sine Data
Overplotting iTool User’s Guide
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Plot Properties

The iPlot window is a self-contained plot display and manipulation device. You can 
import and export plot data, and modify and manipulate plot data. For more 
information on the basic iPlot interface and its layout, see Appendix A, “iTools 
Interface Reference”.

Modifying Properties

By selecting Edit → Properties from the iPlot tool, you may modify your plot 
properties. You may modify your plot’s name, description, fill type and fill color, 
opacity as well as the show/hide properties and the line color, style and thickness. For 
more information on editing properties in the iTools, see Appendix D, “Visualization 
Properties”.
iTool User’s Guide Plot Properties
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Adding Legends

A legend is text that describes aspects of a visualization. For example, a legend might 
show the plot line or plot points. If multiple plots are present the legend may show 
which colors and linestyles represent which plots. An inserted legend will include 
items selected at the time of insertion. If no specific dataset is selected, the legend 
will include all datasets in the plot. 

To add a legend to your plot, select Insert → New Legend. 

You can add new information to your existing legend, or you can also use the 
Insert → Legend option can be used over again to add more legends. For example, 
in the theory plot with newtheory overplot displayed in the previous section, you 
can add a legend for each plot:

1. Select the newtheory plot by clicking once on the line. 

Figure 13-6: A Simple Sine Plot with Default Legend Added
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2. Select Insert → New Legend. A new legend appears on top of the previous 
legend (this new legend can be selected and repositioned).

You can double-click on the legend to bring up a property sheet to alter its settings. 
Through the property sheet, you can also access the Visualization Browser, which can 
be used to navigate through other legends and objects within the visualization. In the 
previous example the names of the legends have been altered to reflect the data 
names. For more information on editing settings in the Visualization Browsers, see 
“The Visualization Browser” in Appendix D, “Visualization Properties”.

Figure 13-7: Plot and Overplot in iPlot with Legend Added for Each
iTool User’s Guide Adding Legends
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Adding a Colorbar

If you have added vertex coloring to your plot visualization, you can add a colorbar 
which will show on a color scale the minimum to maximum values of data in the 
visualization. 

To add a colorbar, 

1. Click on the plot data

2. From the iPlot window, select Insert → Colorbar. 

3. A colorbar will be placed in the visualization window. 

This colorbar can be resized and moved around the data space. You can also double-
click on the colorbar to invoke the Visualization Browser which will allow you to 
change the values for the colorbar. For more information on the colorbar, see 
“Colorbar” in Appendix D, "Visualization Properties".
Adding a Colorbar iTool User’s Guide
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Adding Error Bars

Error bars are used to show uncertainty in data values. These uncertainties may be 
caused by measurement errors or instrument noise, and are usually specified in terms 
of standard deviations away from the data value.

For example, to create a 2D plot with asymmetric error bars on the X and Y axes, 
follow these steps:

1. To set asymmetric error bars for X and Y with X bars initially hidden, enter:

err = FLTARR(2,10)
err[0, *] = FINDGEN(10)/10.
err[1, *] = FLTARR(10) + 0.5

2. Plot the error bars in the iPlot window:

iPlot, FINDGEN(10), COLOR = [255, 0, 255],$
ERRORBAR_COLOR = [255, 0, 0], $
ERRORBAR_CAPSIZE = 0.25, X_ERRORBARS = 0, $
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XERROR = err, YERROR = err

Also, to create a 3D plot with asymmetric error bars on the X, Y and Z axes:

1. To set asymmetric error bars for a 3D plot, enter:

nVerts = 30
x = FINDGEN(nVerts)/10.
y = (SIN(x*2) + 1.)*25.
z = x
err = FLTARR(2, nVerts)
err[0, *] = RANDOMU(seed, nVerts)
err[1, *] = RANDOMU(seed, nVerts)

2. Plot the error bars in the iPlot window with 3D plot and name the plot “3D Plot 
with Error Bars”:

iPlot, x, y, z, COLOR = [0, 0, 255], $
THICK = 2, ERRORBAR_COLOR = [255, 0, 0], $
XERROR = err/2., YERROR = err*5., ZERROR = err, $

Figure 13-8: 2D Plot with Error Bars
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NAME = '3D Plot with Error Bars'

For more information on error-bar properties, see “Plot” in Appendix D, 
“Visualization Properties”.

Figure 13-9: 3D Plot with Error Bars and Name
iTool User’s Guide Adding Error Bars
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Curve Fitting

Curve fitting is the process of finding various ways to fit a curve to a series of data 
points which best represents all points. More specifically, since data, such as plot 
data, is often given as values along a continuum, you may wish at times to give 
estimates at points between values. Curve fitting allows you to find intermediate 
estimates for these values.

Note
For both 2D and 3D plots, the curve fitting operation is performed on the X versus 
Y plot dimensions.

For example, to fit a curve to the damped sine plot we have already created:

1. Select Operations →  Filter →  Curve Fitting.

2. The Curve Fitting dialog appears. 

The Curve Fitting dialog contains the following fields:

• Curve fitting model — used to select the type of model used to try to fit a 
curve to the data.

• Initial parameters and results — used to specify the initial values of the 
parameters of the model used to fit a curve to the data and to display the 
resulting values of these parameters for the model selected in the Curve 
fitting model drop-down list. The initial values are specified in the text 

Figure 13-10: The Curve Fit Dialog with Curve Fitting Model Choices
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boxes on the left side and the results are shown in the labels on the right 
side.

• Equation of the model — shows the equation of the model used to try to 
fit a curve to the data. This model is selected from the Curve fitting 
model.

• Display of resulting fit — graphically shows how well the model 
specified by the Curve fitting model drop-down menu and the Initial 
parameters text boxes fits the data.

• Chi-square value — shows the resulting chi-square value, which is a 
measure of goodness-of-fit.

You can use this dialog to determine what type of model would best fit your 
data by changing the Curve fitting model drop-down menu setting and the 
Initial parameters text boxes values.
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3. Select the desired curve fit from the Curve fitting model drop-down list. You 
can also set initial parameters if desired.

The new curve created by the curve fitting operation is added to the Data 
Manager.

Figure 13-11: A Quintic Curve Fit to a Sin Wave Plot
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Filtering a Plot

The iPlot tool allows you to modify your plot data in the following ways:

Plot Smoothing

Within the iPlot tool, plots can also be smoothed to soften edges or compensate for 
random noise in the plot. To smooth your plot from the iPlot window, select 
Operations →  Filter →  Smooth.

Note
The example shown in the previous figures is taken from example data available in 
the examples\data directory of your IDL installation. The data is contained in a 
file called damp_sn.dat.

Note
The window’s default size is three, however this can be changed via the operations 
browser. For more information on smoothing properties, see “Smooth Properties” in 
Appendix C, “Operations Properties”.

Figure 13-12:  Damped Sine Plotted Data (left) and Smoothed Data (right)
iTool User’s Guide Filtering a Plot
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Plot Convolution

You can also use iPlots convolution feature by selecting Operations →  Filter →  
Convolution. By selecting this, the Convolution Editor appears. From this dialog, 
you can select the desired convolution type from a drop-down list or you can 
manually manipulate the columns, rows, scale factor, and details.

For more information on convolution properties, see “Convolution Properties” in 
Appendix C, “Operations Properties”.

Plot Median

The median filter replaces each point with the median (a value in an ordered set of 
values with an equal number of values above and below it) of the one- or two-
dimensional neighborhood of a given width.

To apply the smooth filter to an image:

1. Select the plot.

2. Select Operations → Filter → Median.

For more details on the median filter, see “Median Filter” on page 125 in Chapter 8, 
"Common Operations".
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Manipulating the Plot Display

The iPlot tool allows you many options to manipulate your existing plot displays. 
Once you have visualized your plot data, you may rotate, flip, translate, scale, and 
zoom as well as modify plot properties, scroll, and select plot ROIs. The following 
options are available for manipulating plots.

Translating

Translation moves an object or group of objects in a specific direction. When an 
object is selected, a bounding box appears around the object. For information on 
translating objects, see “Translation” in Chapter 4, "Manipulating the Display".

Adding Annotations

The following types of annotations can be added to iPlot displays:

For more information on creating and using annotations, see Chapter 5, “Adding 
Annotations”.

Plot 
Annotation 

Type
Description

Text Single lines or multiple lines of text can be added to a 
visualization to provide a label or description.

Line Straight line annotations can be added to a visualization to link 
labels to objects or to identify an object.

Rectangle Rectangular annotations can be added to a visualization to 
identify rectangular areas.

Oval Oval annotations can be added to a visualization to identify 
elliptical areas.

Polygon Polygon annotations can be added to a visualization to identify 
areas bounded by a multi-sided polygon.

Freehand Freehand annotations can be added to a visualization to 
identify an area.

Table 13-1: Types of Plot Annotations
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View Zoom

View Zoom allows you to zoom in or out on a specific area of the plot display area. 
To zoom in or out in View Zoom mode click Zoom  on the toolbar. For more 
information on working with View Zoom, see “Zooming” in Chapter 4, 
"Manipulating the Display".

Canvas Zoom

Canvas Zoom allows you to increase or decrease the magnification of the entire 
display canvas (which may contain multiple views, depending on the layout) by a 
specified percentage. Canvas Zoom is available by selecting the pull-down 
percentage list from the top of the tool just under the Help menu. For more 
information on working with Canvas Zoom, see “Zooming” in Chapter 4, 
"Manipulating the Display".

Selecting the Data Range

In a two-dimensional plot, your data range can be manipulated in several ways. First, 
enter into the Data Range tool mode by clicking on the Data Range button on the 
toolbar. You can then manipulate your data range in the following ways:

• Clicking and dragging a selection box within the view. The selected range 
becomes the new data range.

• Panning in one direction or another along a single axis by clicking on the arrow 
manipulators.

• Zooming in or out by clicking on one of the plus or minus symbols. When 
isotropic scaling is in effect (the default for the iPlot tool), these symbols 
appear at the axis origin, and will impact both the X and Y ranges 
simultaneously.

Note
Plots are clipped to fit within newly selected data ranges.
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iPlot Tool Operations

The iPlot tool allows you many operations for your existing plot displays. Once you 
have visualized your plot data, you can scale and filter as well as creating a histogram 
or viewing statistics for your plot. The following operations are available for plots.

Scaling a Plot Display

iPlot allows you to scale your plotted data by selecting Operations → Transform 
→ Scale Data. You can scale your data by a factor which you provide in the Scale 
Factor dialog.

Once you have set the scale factor, select OK and the scaling takes place.

Viewing a Histogram

A density histogram is a plot consisting of either horizontal or vertical bars. The 
widths or heights of these bars represent data values. Another type of histogram is a 
style plot histogram which plots different data sets side-by-side using differently 
styled points or bars to represent the data. To view a density histogram of plot data, 
use the iTool’s histogram feature by selecting Operations →  Histogram. For 
information on histogram creation, see “Plotting a Histogram” in Chapter 7, 
"Common Operations".

Viewing Statistics

To view statistics for plot data, use the iTool’s statistics feature by selecting 
Operations →  Statistics. For information on viewing statistics, see “Displaying 
Statistics” in Chapter 7, "Common Operations".

Figure 13-13: Setting the Plot Scale Factor
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Working with Volumes
This chapter describes how to use the iVolume tool.
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Introduction

The IDL iVolume tool displays your data in volume form. The iVolume tool then 
allows you great flexibility in manipulating and visualizing volume data. To use 
iVolume, from the IDL Command Line, type iVolume. An empty iVolume tool 
appears. You can then import volume data using any of several data import methods. 
For more information importing volume data see Chapter 2, “Importing and 
Exporting Data”.

Note
For more information on accepted arguments, see “IVOLUME” in the IDL 
Reference Guide manual.

The iVolume tool can be launch in many different ways:

• At the IDL Command Line without arguments or keywords

• At the IDL Command Line with arguments or keywords

• Through the File → New → Visualization → iVolume menu option in the 
IDL Development Environment

• Through the File → New → iVolume menu option in an iTool

Note
The iVolume tool continues to be updated in IDL 6.1. This chapter will be written to 
accommodate additional iVolume functionality and this chapter reflects only 
current configuration.
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Displaying Volumes

The iVolume tool’s primary purpose is to visualize volume data, though the tool is 
capable of much more once the data is displayed. The iVolume tool also allows you to 
manipulate and edit the displays. The first task is to display the volume data.

Before displaying, volume data must be loaded into the tool. Here is a simple 
example of one way to load in some data.

At the IDL command line, enter:

file = FILEPATH('head.dat', $
SUBDIRECTORY = ['examples', 'data'])

data = READ_BINARY(file, DATA_DIMS = [80, 100, 57])
IVOLUME, data

Note
The examples/data directory of your IDL 6.1 distribution contains a text file 
named index.txt. This file lists all data files available in the example directory 
and also lists their dimensions and values.

Multi-Channel Volumes

The data in the previous example is a single-channel volume which is volume data 
specified in a single parameter. This is the simplest and most common way to display 
volume data. The iVolume tool also supports two-channel and four-channel volume 
rendering. Two-channel rendering allows you to combine or blend two volume arrays 
together. Four-channel rendering is useful when your volume data is composed of a 
volume array for each of the red, green, blue, and alpha display channels. Note that 
the dimensions of all the volume arrays used in multi-channel volume rendering must 
be the same.

In the following example, the second volume array of a two-channel volume is used 
as a mask to cut out a portion of the volume to create a hole. With the head.dat data 
already loaded from the examples/data directory, a mask volume is created and 
displays the result:

mask = BYTARR(80, 100, 57)
mask[*] = 255
mask[30:50, *, 20:30] = 0
IVOLUME, data, mask

A rectangular hole through the middle of the head is created, making portions of the 
inside more visible.
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The following is an example of a four-channel volume:

red = BYTARR(20,20,20)
green = BYTARR(20,20,20)
blue = BYTARR(20,20,20)
alpha = BYTARR(20,20,20)

red[10:*,*,*]=255
green[*,10:*,*]=255
blue[*,*,10:*]=255
alpha[*] = 128
IVOLUME, red, green, blue, alpha

Rendering Volumes

Volume data does not automatically appear in the tool window since volume 
rendering can be a time consuming operation. To render the volume, click the 
Render button on the tool. Auto render is available but not set by default since it can 
slow down your iTool session if you have simultaneous operations.

Note
Volume data is only rendered if the volume data space is selected. Thus, if you have 
multiple volumes in your data space, auto render must be turned on in order to 
render both simultaneously.
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The data loaded earlier can be displayed by clicking the Render button.

Rendering Quality

The volume can be rendered in two quality modes:

• Low — Done with a stack of 2D texture-mapped semi-transparent polygons. 
The polygons are oriented so that the flat sides face the viewer as directly as 
possible. On most systems, Low-quality mode renders faster than High-quality 
mode, but not as accurately.

• High — Done with the IDLgrVolume ray-casting volume renderer. This 
quality mode is CPU-intensive and will usually take much longer than the 
Low-quality mode.

Extents

Since the volume is not always rendered, iVolume drawswireframe volume extents to 
help you locate and select the volume. You can select the volume by selecting on the 

Figure 14-1: Rendered MRI Head Volume Data
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extents, without rendering the volume. By default, iVolume draws a translucent solid 
cube with internal extents. You can also select a wire frame, or no extents within the 
visualization browser.

Note
Use caution when turning off extents. If extents are turned off and auto render is 
also off, you may need to use the Visualization Browser to select the volume again.
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Using the Volume Panel

The volume panel appears to the right of the visualization window of the iVolume 
tool. This panel allows you to render and manipulate rendering properties. The 
components and functions of the volume panel are discussed in the following figure 
and list.

• Name — The volume object’s name (if any).

• Data Channels — The volume’s data channels.

• Render — This button will render the volume data.

• Auto-Render — Select this checkbox to enable auto-rendering.

• Quality — Pull-down menu to select desired volume rendering quality. Select 
Low (textures) or High (volume).

Figure 14-2: The Volume Panel
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• Boundary — Pull-down menu to select desired volume data space boundaries. 
Select none, wire frame, or solid walls.

• Render Step — Enter desired order for rendering here (if any).
Using the Volume Panel iTool User’s Guide
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Volume Properties

The iVolume window is a self-contained volume display and manipulation device. 
You can import and export volume data, and modify and manipulate volume data. For 
more information on the basic iVolume interface and its layout, see Appendix A, 
“iTools Interface Reference”.

Modifying Properties

By selecting Edit → Properties from the iVolume tool, you can modify your volume 
properties. You may modify your volume’s name, description as well as the 
show/hide properties and the line color, style, and thickness. For more information on 
editing properties in the iTools, see Appendix D, “Visualization Properties”.
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Adding a Colorbar

You can add a colorbar to your visualized volume which will show on a color scale 
the minimum to maximum values of data in the visualization. To add a colorbar, click 
on the volume visualization and then from the iVolume window, select 
Insert → Colorbar. A colorbar will be placed in the visualization window. This 
colorbar can be resized and moved around the data space. You can also double-click 
on the colorbar to invoke the Visualization Browser which will allow you to change 
the properties for the colorbar.

Figure 14-3: Rendered Volume with Colorbar Added
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Adding Axes

By default, volumes are displayed with X, Y, and Z axes. The display of these axes is 
controlled by property sheets for the axes container and for individual axes (see 
“Axes” in Appendix D). Additional X, Y, or Z axes can be added to a volume 
visualization to make it easier to identify volume characteristics.

To add an axis to your volume visualization:

1. Select the volume.

2. Select Insert → Axis.

3. Choose from the following options:

• X axis

• Y axis

• Z axis

Use the mouse to position the new axis and double-click the axis to display the axis 
property sheet. 

For more information on adding axes, see “Additional Axes” in Chapter 5, "Adding 
Annotations".
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Resampling Volumes

Resampling re-imports the selected volume data using parameters specified in the 
Resample properties. Resampling parameters include factors for adjusting the X, Y, 
or Z dimensions of the data, as well as the interpolation method to be used.

To resample volume data:

1. Select one or more volumes in the iVolume window for resampling.

2. If necessary, use the Operations Browser to set the desired parameters through 
the Resample properties. See “Resample Properties” on page 377 for details.

3. Select Operation → Transform → Resample.

Figure 14-4: Resampled and Rendered Volume
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Showing an Image Plane

An image plane is a visualization of a slice of the volume. An image plane can be 
dragged and rotated within the volume. To show an image plane for a portion of 
volume data, first be sure your volume is selected and then choose 
Operations → Volume → Image Plane. An image plane appears showing a cross-
section of your volume data. You can change the orientation of an image plane by 
double-clicking on the image plane to bring up the property browser. You can also 
click on the edge of the plane and move it to various other points in the volume data.

Viewing the Image Plane in iImage

Image plane data is available in Data Manager and can be utilized in the iImage tool 
for closer image analysis. The image plane image data is always a four-channel 
RGBA truecolor image. To view your image plane in iImage, from the iVolume tool 
select Operations → Image Plane → Launch iImage.

Figure 14-5: Image Plane of a Rendered Volume
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Extracting an IsoSurface

An isosurface is a set of polygons drawn in the volume to represent a surface that has 
a specific constant value (the isovalue). An isosurface cannot be translated, scaled, or 
rotated relative to the volume but does move with the volume.

To create an isosurface, select Operations → Volume → Isosurface and iVolume 
displays a dialog allowing you to specify the isovalue. If the volume is multi channel, 
you can select a channel and set its isovalue.

Figure 14-6: Isosurface Value Selector for iVolume
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You will then create an isosurface for that channel by selecting OK.

Note
Isosurfaces often contain a large number of polygons, which may degrade 
iVolume’s display performance. When selecting the isovalue, you can also specify a 
decimation percentage to reduce the number of polygons in the resulting isosurface. 
This decimation step requires additional time, but the resulting isosurface will 
contain fewer triangles and will draw faster.

Figure 14-7: Isosurfaced Rendered Volume
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Extracting an Interval Volume

An interval volume is a set of tetrahedra that span a space between two isovalues 
within a volume. Since a tetrahedral mesh is a solid, iVolume displays the outer 
surface of the mesh as a set of polygons. This surface cannot be translated, scaled, or 
rotated relative to the volume but does move with the volume.

To create an interval volume, select Operations → Volume → Interval Volume, and 
a dialog appears allowing you to set two isovalues.

Figure 14-8: Interval Volume Value Selector for iVolume
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If the volume is multi channel, you can select a channel for setting the isovalues and 
then create an interval volume for that channel by selecting OK.

Note
Vertex colors are not persevered during decimation.

Note
Interval volume surfaces often contain a large number of polygons, which can 
degrade iVolume’s display performance. When selecting isovalues, you can specify 
a decimation percentage to reduce the number of polygons in the resulting surface. 
This decimation step requires additional time, but the resulting surface will contain 
fewer triangles and will draw faster.

Figure 14-9: Original Volume Visualization and Interval Volume
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Manipulating the Volume Display

The iVolume tool allows you many options to manipulate your existing volume 
displays. Once you have visualized your volume data, you may rotate, translate, 
scroll, and zoom as well as modify volume properties. The following options are 
available for manipulating volumes.

Rotating a Volume

Rotating makes it possible to rotate the volume within the visualization without 
affecting the rest of the data space (graphical objects and axes). To rotate your 
volume, from the toolbar on the iVolume window, select the Rotate button. For more 
information about rotating, see “Rotation” on page 118 in Chapter 8, "Common 
Operations".

Scaling a Volume

It is possible to scale the data within a volume by a specified scale factor. To scale 
your volume, select Operations → Transform → Scale Data. For more information 
on scaling data, see “Scaling” on page 69 in Chapter 4, "Manipulating the Display".

View Zoom

View Zoom allows you to zoom in or out on a specific area of the volume display 
area. To zoom in or out in View Zoom mode click Zoom  on the toolbar. For more 
information on working with View Zoom, see “Zooming” in Chapter 4, 
"Manipulating the Display".

Canvas Zoom

Canvas Zoom allows you to increase or decrease the magnification of the entire 
display canvas (which may contain multiple views, depending on the layout) by a 
specified percentage. Canvas Zoom is available by selecting the pull-down 
percentage list from the top of the tool just under the Help menu. For more 
information on working with Canvas Zoom, see “Zooming” in Chapter 4, 
"Manipulating the Display".
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Adding Annotations

Annotations can be added to label or describe volume visualizations displayed in the 
iVolume tool.

The following types of annotations can be added to iVolume displays:

For more information on creating and using annotations, see Chapter 5, “Adding 
Annotations”.

Plot 
Annotation 

Type
Description

Text Single lines or multiple lines of text can be added to a 
visualization to provide a label or description.

Line Straight line annotations can be added to a visualization to link 
labels to objects or to identify an object.

Rectangle Rectangular annotations can be added to a visualization to 
identify rectangular areas.

Oval Oval annotations can be added to a visualization to identify 
circular areas.

Polygon Polygon annotations can be added to a visualization to identify 
areas bounded by a multi-sided polygon.

Freehand Freehand annotations can be added to a visualization to 
identify an area.

Table 14-1: Types of Volume Annotations
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iVolume Tool Operations

The iVolume tool allows you operations for your existing volume displays. Once you 
have visualized your volume data, you can scale and filter as well as creating a 
histogram or viewing statistics for your volume. The following operations are 
available for volumes.

Viewing a Histogram

A density histogram is a plot consisting of either horizontal or vertical bars. The 
widths or heights of these bars represent data values. Another type of histogram is a 
style plot histogram which plots different data sets side-by-side using differently 
styled points or bars to represent the data. To view a density histogram of volume 
data, use the iTool’s histogram feature by selecting Operations →  Histogram. For 
information on histogram creation, see “Plotting a Histogram” in Chapter 7, 
"Common Operations".

Viewing Statistics

To view statistics for volume data, use the iTool’s statistics feature by selecting 
Operations →  Statistics. For information on viewing statistics, see “Displaying 
Statistics” in Chapter 7, "Common Operations".

Smoothing a Volume

Within the iVolume tool, plots can also be smoothed to soften edges or compensate 
for random noise in the volume.

To apply the smooth filter to a volume:

1. Select the volume.

2. Select Operations → Filter → Smooth.
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Working with Maps
This chapter describes how to use the map iTool.
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Introduction

The IDL iMap tool displays image and contour data that are georeferenced and 
mapped to particular projections, as well as shapefile data. The iMap tool gives you 
great flexibility in manipulating and visualizing these data. To use iMap, from the 
IDL Command Line, type iMap. An empty iMap tool appears. You can then import 
image or contour data using any of several data import methods. For more 
information on importing data, see Chapter 2, “Importing and Exporting Data”.

Note
For more information on accepted arguments and keywords, see “IMAP” in the IDL 
Reference Guide manual.

The iMap tool can be launched in many different ways:

• At the IDL Command Line without arguments or keywords

• At the IDL Command Line with arguments or keywords

• Through the File → New → Visualization → iMap menu option in the IDL 
Development Environment

• Through the File → New → iMap menu option in an iTool

• On Windows platforms, from the Start menu (Start → Programs → RSI IDL 
6.1 → iTools → iMap)
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Displaying Maps

The iMap tool’s primary goal is to visualize map data, though the tool is capable of 
much more once the data is displayed. The iMap tool also allows you to manipulate 
and edit the displays. The first task is to display the map data.

Your options for calling the iMap tool are:

• At the IDL Command Line without arguments or keywords

• At the IDL Command Line with arguments or keywords

Note
Arguments and keywords are accepted at the IDL Command Line for the 
iMap tool, for more information on accepted arguments and keywords, see 
“IMAP” in the IDL Reference Guide manual.

• Through the File → New → Visualization → iMap menu option in the IDL 
Development Environment

• Through the File → New → iMap menu option in an iTool

• On Windows platforms, from the Start menu (Start → Programs → RSI IDL 
6.1 → iTools → iMap)

You have two options for getting started with displaying a map. You can:

• Apply a map projection and then visualize data within it

• Visualize image or contour data and then apply a map projection to it

To get started with one of these options, see the following sections:

• “Applying a Map Projection” on page 318

• “Displaying an Image” on page 324

• “Displaying a Contour” on page 332
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Applying a Map Projection

A map projection establishes the axis type and coordinate conversion mechanism for 
mapping points on the earth’s surface, expressed in latitude and longitude, to points 
on a plane, according to one of several possible map projections.

You can apply a map projection before or after you import image or contour data into 
the iMap tool. To do so, select Operations →  Map Projection. This command 
opens the Map Projection dialog, shown in Figure 15-1.

You can apply a map projection to another iTool as well. If you do, the tool will adapt 
to expose iMap functionality, including the iMap operations and the Map panel.

Table 1 shows the common projection properties.

Figure 15-1: The Map Projection Dialog

Name Description

Description Description of the map projection

Table 1: Common Map Projection Properties
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In addition to these properties, the following properties (Table 2) become available 
depending on the selected projection:

Show dialog Show this dialog before executing the Map Projection 
operation

Projection Name of the map projection

Ellipsoid (datum) Semimajor and -minor axes that define the ellipsoid

Semimajor axis Length of the semimajor axis, in meters, for the reference 
ellipsoid

Semiminor axis Length of the semiminor axis, in meters, for the reference 
ellipsoid

Center longitude (degrees) Longitude in degrees of the projection’s center

Center latitude (degrees) Latitude in degrees of the projection’s center

Longitude minimum (deg) Minimum longitude to include in the projection, in degrees

Longitude maximum (deg) Maximum longitude to include in the projection, in degrees

Latitude minimum (deg) Minimum latitude to include in the projection, in degrees

Latitude maximum (deg) Maximum latitude to include in the projection, in degrees

False easting (meters) False easting to be added to each x-coordinate, in meters

False northing (meters) False northing to be added to each y-coordinate, in meters

Name Description

Height (meters) Height above surface, in meters, for satellite projections

Hemisphere Hemisphere for UTM and Polar projections

HOM azimuth angle (deg) Hotine Oblique Mercator azimuth angle (degrees) east

HOM latitude 1 (deg) Hotine Oblique Mercator latitude, in degrees, of the first 
point

Table 2: Properties for Selected Map Projections

Name Description

Table 1: Common Map Projection Properties (Continued)
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HOM latitude 2 (deg) Hotine Oblique Mercator latitude, in degrees, of the second 
point

HOM longitude 1 (deg) Hotine Oblique Mercator longitude, in degrees, of the first 
point

HOM longitude 2 (deg) Hotine Oblique Mercator longitude, in degrees, of the 
second point

IS longitudinal zones Intergerized Sinusoidal number of longitudinal zones

IS row justify flag Integerized Sinusoidal flag that indicates what to do with 
rows with an odd number of columns. The following values 
are allowed:

• 0 — Indicates the extra column is on the right of the 
projection y-axis

• 1 — Indicates the extra column is on the left of the 
projection y-axis

• 2 — Calculates an even number of columns

Mercator scale Scale factor at the central meridian (for the Transverse 
Mercator projection) or the center of the projection (for the 
Hotine Oblique Mercator projection)

NAD27 Zone name (FIPS) NAD27 State Plane Coordinate System Zone (FIPSZone)

NAD83 Zone name (FIPS) NAD83 State Plane Coordinate System Zone (FIPSZone)

OEA horizontal shape m Oblated equal area horizontal (m) shape parameter

OEA vertical shape n Oblated equal area vertical (n) shape parameter

OEA rotation angle (deg) Oblated equal area rotation angle, in degrees

SOM end-of-path flag Space Oblique Mercator Landsat end-of-path flag, where 0 
is the start and 1 is the end

SOM inclination (deg) Space Oblique Mercator orbit inclination angle, in degrees, 
of the ascending node, counter-clockwise from the equator

SOM Landsat number Space Oblique Mercator Landsat number (Worldwide 
Reference System)

Name Description

Table 2: Properties for Selected Map Projections (Continued)
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Note
The map projection properties are normally taken from the currently selected 
dataspace. However, in the Operations Browser, the map projection properties are 
registered on the operation itself. Changing these properties in the Operations 
Browser will have no affect on the currently selected dataspace. If the Show Dialog 
property is set to false and then the Map Projection operation is activated, the 
projection properties will be copied directly from the Map Projection operation onto 
the currently selected dataspace.

Note
Each projection has default longitude and latitude limits. If you have not modified 
one of these limits (the longitude and latitude minimum and maximum properties), 
the Map Projection operation will automatically use its default limit. However, if 
you have modified one of these limits, the Map Projection operation will use either 
your desired limit or the default limit, whichever is smaller.

SOM Landsat path Space Oblique Mercator Landsat path number

SOM longitude (deg) Space Oblique Mercator longitude, in degrees, of the 
ascending node

SOM period (minutes) Space Oblique Mercator satellite period, in minutes

SOM ratio Space Oblique Mercator Landsat ratio that compensates for 
confusion at the northern end of orbit

Standard parallel 1 (deg) First standard parallel (degrees latitude) of true scale

Standard parallel 2 (deg) Second standard parallel (degrees latitude) of true scale

Zone (1-60) Universal Transverse Mercator (UTM) grid zone number

Name Description

Table 2: Properties for Selected Map Projections (Continued)
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Using the Map Panel

The iMap tool has a Map panel (Figure 15-2) that lets you manipulate the map 
display. The panel also appears when you apply a map projection or shapefile into 
another iTool.

Figure 15-2: The Map Panel in the iMap Tool
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Table 3 describes the items on the Map panel.

Name Description

Location Displays the following information:

• If no map projection is applied — the cursor location in 
degrees longitude/latitude or meters, depending on the 
image units

• If a map projection is applied — the cursor location in 
degrees longitude/latitude and the corresponding 
Cartesian X/Y (or U/V) coordinates in meters

Sensitive only if an image or a contour is selected.

Data Value Displays the following information:

• For an image — the data value and corresponding 
grayscale or RGB value for the current cursor location 
(identical to Pixel Value on the Image panel)

• For a contour — the data value for the current cursor 
location

Sensitive only if an image or contour visualization is 
selected.

Longitude limits Displays the active map projection’s maximum and 
minimum longitude values. Enter new values to update 
these limits.

Sensitive only if a dataspace (or a visualization within the 
dataspace) with a map projection is selected.

Latitude limits Displays the active map projection’s maximum and 
minimum latitude values. Enter new values to update these 
limits.

Sensitive only if a dataspace (or a visualization within the 
dataspace) with a map projection is selected.

Edit Projection... Opens the Map Projection dialog for the currently active 
dataspace. For more information, see “Applying a Map 
Projection” on page 318.

Table 3: Items on the Map Panel
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Displaying an Image

You can visualize image data in the iMap tool as you would in the iImage tool. To 
learn more about visualizing image data, see “Displaying Images” on page 199.

Note
By default, the iMap tool creates an image visualization if given a 2D array or a 
Truecolor image. This image is warped internally to fit the map projection, if one is 
present. The actual image data itself remains unchanged.

When you open an image in the iMap tool, you need to register the image to define 
how the pixel data correspond to points on the earth’s surface. For more information 
on this process, see “Registering an Image” on page 325.

Once you have image data in the iMap tool, all of the features of the iImage tool are 
available. For more information, see Chapter 10, “Working with Images”.

You can export the mapped image by selecting File → Export. When the IDL Data 
Export wizard opens, choose the "To a file" option, the image visualization to save, 
and the output file format. The result will be the image warped to the current map 
projection.

Note
Depending on the map projection, the alpha channel might be used to mask out 
pixels outside the map boundary. In this case, you can export the image to a file 
format that supports four channels, such as TIFF, PNG, or JPEG2000.
Displaying an Image iTool User’s Guide



Chapter 15: Working with Maps 325
Registering an Image

The Map Register Image wizard, shown in Figure 15-3, registers an image’s data, 
creating a correspondence between the image pixels and points on the earth’s surface. 
This registration step is necessary to let the iMap tool properly display the image data 
in the map projection you select.

The wizard launches automatically when you import image data or open an image 
file. To launch the wizard after the image is open and registered (e.g., if you want to 
change the registering properties), select Operations → Map Register Image.

The coordinates are in either meters or degrees; which units you choose for the 
translation can affect how the image appears in a map projection. Selecting meters 
means that the image data have already been warped to a particular projection, and 
you need to tell IDL which projection to use in displaying the image. Selecting 
degrees, on the other hand, means that the image data are not already warped, so you 

Figure 15-3: The Map Register Image Wizard — Step 1
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do not need to specify a map projection for the image. It is important that you know 
in which units your data are, to make the correct decision when registering the image 
for display.

The Map Register Image wizard reflects this difference between the units by having 
three steps for meters and two for degrees:

1. Select the coordinate units.

2. Set the pixel minimum, maximum, and size values.

3. (Meters only) Specify the map projection to associate with the image and, if 
desired, with the dataspace as well.

Once you have set these registering properties and map projection (if applicable), 
IDL registers the image data, and the iMap tool displays the image and the Image 
panel along with the Map panel.

The rest of this section describes the two registration pathways, with meters or with 
degrees, in more detail.
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Registering an Image in Meters

If you select Meters as the coordinate units in Step 1 and click on Next, you see the 
wizard’s Step 2 dialog for meters, shown in Figure 15-4.

Table 4 shows the properties associated with meter coordinates.

Figure 15-4: The Map Register Image Wizard — Step 2 (Meters)

Name Description

X (or U) minimum (meters) Minimum position in the x (or u) 
direction, in meters, of the image data

X (or U) maximum (meters) Maximum position in the x (or u) 
direction, in meters, of the image data

Table 4: Meter Coordinate Properties
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Note
The (u.v) coordinates refer to the UV plane of a cylindrical projection.

Entering the minimum value and the pixel size automatically updates the maximum 
value.

X (or U) pixel size (meters) Pixel size, in meters, in the x (or u) 
direction

Y (or V) minimum (meters) Minimum position in the y (or v) 
direction, in meters, of the image data

Y (or V) maximum (meters) Maximum position in the y (or v) 
direction, in meters, of the image data

Y (or V) pixel size (meters) Pixel size, in meters, in the y (or v) 
direction

Name Description

Table 4: Meter Coordinate Properties (Continued)
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Figure 15-5 shows the final step in the Map Register Image wizard for the Meters 
option.

In this step, you can select a map projection to associate with the image. You also 
have the option of updating the dataspace map projection to use this projection.

Figure 15-5: The Map Register Image Wizard: Step 3 (Meters)
iTool User’s Guide Registering an Image



330 Chapter 15: Working with Maps
Registering an Image in Degrees

If you select Degrees as the coordinate units in Step 1 and click on Next, you see the 
wizard’s Step 2 dialog for degrees, shown in Figure 15-6.

Table 5 shows the properties associated with degree coordinates.

Figure 15-6: The Map Register Image Wizard: Step 2 (Degrees)

Name Description

Longitude minimum (deg) Minimum longitude position, in 
degrees, of the image data

Longitude maximum (deg) Maximum longitude position, in 
degrees, of the image data

Table 5: Degree Coordinate Properties
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Entering the minimum value and the pixel size automatically updates the maximum 
value.

Longitude pixel size (deg) Pixel size, in degrees, in the longitude 
direction

Latitude minimum (deg) Minimum latitude position, in degrees, 
of the image data

Latitude maximum (deg) Maximum latitude position, in 
degrees, of the image data

Latitude pixel size (deg) Pixel size, in degrees, in the latitude 
direction

Name Description

Table 5: Degree Coordinate Properties (Continued)
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Displaying a Contour

You can visualize contour data in the iMap tool as you would in the iContour tool. To 
learn more about visualizing contour data, see “Displaying Contours” on page 247.

Once you have contour data in the iMap tool, all of the features of the iContour tool 
are available. For more information, see Chapter 12, “Working with Contours”.
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Creating a Shape Visualization

A shapefile stores nontopological geometry and attribute information for the spatial 
features in a data set. The shapefile format was created by ESRI, and is widely used 
in the geographic information systems community. The iTools display a shapefile’s 
data by creating one of three special visualization types: ShapePolygon, 
ShapePolyline, and ShapePoint. The type of visualization created depends on the 
type of data in the shapefile.

Note
For more information on the shape visualizations, see “Visualization Type 
Properties” on page 406.

You can create a shape visualization in one of the following ways:

• Using File → Open and selecting the shapefile

• Using File → Import to launch the Data Import Wizard, and selecting the 
shapefile

• Using Insert → Visualization and either selecting the appropriate shape 
visualization type (if you have already imported the shape data into an iTool) 
or selecting the shapefile whose data you want to import for a shape 
visualization

Note
When creating a shape visualization using File → Import or 
Insert → Visualization, if the shapefile contains more than one item (polygon, 
polyline, or point), you can choose to create a single visualization containing all of 
the included items, or to create an individual visualization for each item in the file.
iTool User’s Guide Creating a Shape Visualization
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Inserting a Map Grid

The Insert → Map → Grid operation creates a longitude-latitude grid (Figure 15-7) 
within the current dataspace, using the current projection. If no projection is active, 
then IDL uses geographic coordinates.

The gridlines appear as a single MapGrid object within the current dataspace. For 
information on this visualization, see “Map Grid” on page 461.

Note
When you insert a map grid, the Axes container within the dataspace is 
automatically hidden. To display the axes, use the Visualization Browser to change 
the Show property of the Axes container.

Figure 15-7: The Map Grid
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Inserting an IDL Shapefile

IDL comes with several shapefiles that you can insert in the iMap tool or in another 
iTool that has a map projection already applied. These files originated from the ESRI 
Data and Maps CD-ROM data set (1999, 2000, 2002) and can be found, along with 
their associated database (.dbx) and index (.shx) files, in the 
resource/maps/shape directory of the IDL installation.

Inserting the Continents

The Insert → Map → Continents operation loads the continents.shp file and 
displays the continents as a single ShapePolygon (Figure 15-8) in the current 
dataspace, using the current projection. If no projection is active, then IDL uses 
geographic coordinates.

Figure 15-8: The Continents Shapefile
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Inserting the Countries (Low Resolution)

The Insert → Map → Countries (low res) operation loads the country.shp file 
and displays the countries (boundaries as of 2002) as separate ShapePolygons (Figure 
15-9) in the current dataspace, using the current projection. If no projection is active, 
then IDL uses geographic coordinates. The ShapePolygons exist in a Countries (low 
res) visualization container.

Inserting the Countries (High Resolution)

The Insert → Map → Countries (high res) operation loads the cntry02.shp file 
and displays the countries (boundaries as of 2002) as separate ShapePolygons (Figure 
15-10) in the current dataspace, using the current projection. If no projection is active, 

Figure 15-9: The Countries (Low Res) Shapefile
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then IDL uses geographic coordinates. The ShapePolygons exist in a Countries (high 
res) visualization container.

Inserting the Rivers

The Insert → Map → Rivers operation loads the rivers.shp file and displays the 
rivers as separate ShapePolylines (Figure 15-11) in the current dataspace, using the 

Figure 15-10: The Countries (High Res) Shapefile
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current projection. If no projection is active, then IDL uses geographic coordinates. 
The ShapePolylines exist in a Rivers visualization container.

Inserting the Lakes

The Insert → Map → Lakes operation loads the lakes.shp file and displays the 
lakes as separate ShapePolygons (Figure 15-12) in the current dataspace, using the 

Figure 15-11: The Rivers Shapefile (Continents Added for Context)
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current projection. If no projection is active, then IDL uses geographic coordinates. 
The ShapePolygons exist in a Lakes visualization container.

Inserting the United States

The Insert → Map → United States operation loads the states.shp file and 
displays the states as separate ShapePolygons (Figure 15-13) in the current dataspace, 

Figure 15-12: The Lakes Shapefile (Continents Added for Context)
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using the current projection. If no projection is active, then IDL uses geographic 
coordinates. The ShapePolygons exist in a United States visualization container.

Inserting the Canadian Provinces

The Insert → Map → Canadian Provinces operation loads the 
canadaprovince.shp file and displays the provinces as separate ShapePolygons 
(Figure 15-14) in the current dataspace, using the current projection. If no projection 

Figure 15-13: The United States Shapefile
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is active, then IDL uses default longitude-latitude coordinates. The ShapePolygons 
exist in a Canadian Provinces visualization container.

Figure 15-14: The Canadian Provinces Shapefile
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Introduction

The Standard IDL Intelligent Tools comprise five distinct tools: iImage, iPlot, 
iSurface, iContour, and iVolume. Each tool has a specific set of functions related to 
the type of data it is designed to use. In addition to these specific tasks, all four tools 
have a number of functions in common. This appendix describes those functions that 
all iTools have in common; for information about the functions unique to the 
individual iTools, refer to the chapters describing those tools.

This appendix is an overview of these menu items and toolbar buttons that are 
common to all iTools:

Menu Bar Items

The following menus appear on the iTool menu bar:

• File Menu

• Edit Menu

• Insert Menu

• Operations Menu

• Window Menu

• Help Menu

Toolbar Items

The following toolbars appear at the top of each iTool window:

• The File toolbar, containing the New, Open, Save, and Print buttons.

• The Edit toolbar, containing the Undo, Redo, Cut, Copy, and Paste buttons.

• The Manipulator toolbar, containing the Select, Rotate, and View Pan buttons.

• The View Zoom button and View Zoom drop-down list.

• The Annotation toolbar, containing the Text and line buttons as well as the 
Line, Rectangle, Oval, Polygon, and Freehand annotation buttons.
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File Menu 

The File menu contains tools for creating, opening, printing and saving files, as well 
as tools for importing and exporting data and images. The File menu items are 
common to all standard iTools.

Menu 
Selection

Keyboard 
Accelerator

Function

New Ctrl+N Creates a new iTool of the specified type. 
Options: iImage, iPlot, iSurface, iContour, 
iVolume.

Open... Ctrl+O Opens a file for import into the current iTool. 
If this is a data file, such as an image file, 
ASCII file, or binary file, a new data object 
will be created and, if applicable, a new 
visualization will be created. 

Import... Imports an IDL variable or file to the current 
iTool. See “Data Import Methods” on page 25 
for details.

Export... Exports the data from the currently-selected 
object to the IDL main program level, or 
exports the current window to an image file. 

Save Ctrl+S Saves the state of the current iTool to a file. If 
the state has not been previously saved and has 
no filename, enter a filename. 

Save As... Prompts you to enter a filename and then saves 
the state of the current iTool.

Print Preview... Shows a preview of the visualization to print 
and allows you to reorient (Portrait or 
Landscape) as well as Center, Print, Close, or 
change printer Setup.

Print... Ctrl+P Prints the entire contents of the graphics 
window. 

Table A-1: The File Menu
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Preferences... Displays the Preferences Browser. See “The 
Preferences Browser” on page 97 for details.

Exit Ctrl+Q Exits the iTool window, closing all 
visualizations and views within the window 
and removing them from memory. 

Menu 
Selection

Keyboard 
Accelerator Function

Table A-1: The File Menu
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Edit Menu

The Edit menu contains tools for editing and deleting data within the tool, retracing 
your steps with the Undo/Redo commands, and displaying properties for selected 
objects. The Edit menu items are common to all standard iTools.

Menu 
Selection

Keyboard 
Accelerator

Function

Undo Ctrl+Z Nullifies the previous operation and restores 
the iTool to its state before that operation. The 
name of the previous operation appears after 
Undo.

Note - Operations such as open, save, export, 
export variable, print, exit, and window 
moving and resizing cannot be undone.

Redo Ctrl+Y Nullifies the previous Undo command and 
restores the iTool to its state before the Undo 
command was issued. Any action that can be 
undone can also be redone.

Cut Ctrl+X Deletes the selected item(s) and places a copy 
on the local clipboard.

Copy Ctrl+C Copies the selected item to the local clipboard. 
If a view is copied, then a bitmap copy of that 
view (not the entire Window) is also put on the 
System clipboard. 

Paste Ctrl+V Pastes the current local clipboard contents into 
the selected view. If a view is pasted, it is 
added to the current Window layout and 
becomes the currently-selected view.

Paste Special Pastes the current local clipboard contents into 
the selected view, and makes a reference to all 
contained data.

Table A-2: The Edit Menu
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Delete Del Deletes the currently-selected item(s), without 
putting a copy on the local or system 
clipboards. Deletion can be reversed with 
Undo.

Select All Selects all items in the current view.

Grouping Select Group to add all selected objects to a 
group, Ungroup to remove them from the 
group.

Order Change the display order of the selected 
object(s).Choose from these options:

• Bring to Front: Move selected object(s) 
to the top display level.

• Send to Back: Move selected object(s) to 
the bottom display level.

• Bring Forward: Move selected object(s) 
up one display level.

• Send Backward: Move selected object(s) 
down one display level.

Style Selections related to iTool’s styles.

• Apply Style: Applies current style to your 
iTool visualization.

• Create Style from Selection: Creates a 
new style from selected visualization 
items.

• Style Editor: Brings up the Style Editor 
dialog.

Parameters... Displays the Parameter Editor. See “Data 
Import Methods” on page 25 for details.

Menu 
Selection

Keyboard 
Accelerator Function

Table A-2: The Edit Menu (Continued)
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Properties... Brings up the property sheet for the currently-
selected item(s). If only the view is selected, 
the property sheet for the view layer is 
presented. Only one property sheet may be 
displayed at a time. If a different item or view 
is selected, the contents of the property sheet 
change to the properties of the new item or 
view. For grouped items, a single property 
sheet with the intersection of the properties is 
displayed. When the property values are not 
the same for the grouped items, those 
properties are set to undefined or default. 
Setting a property for a grouped item sets that 
property for all items in the group.

Menu 
Selection

Keyboard 
Accelerator Function

Table A-2: The Edit Menu (Continued)
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Insert Menu

The Insert menu contains tools for adding visualization elements to the displayed 
data. Contents of the Insert menu vary from iTool to iTool.

Menu 
Selection Function

Visualization Inserts a new visualization into the current window. See 
“Inserting Visualizations” on page 58 for details.

View Inserts a new view into the current window.

• If the window is currently locked, this menu item will be 
grayed out.

• If the window is not locked, the new view is added to the 
layout in the appropriate location, depending on the 
currently active layout.

Dataspace Inserts data space. (useful when overplotting such as in iPlot)

Axis Inserts a new axis. Choose from these options:

• X: inserts an additional X axis

• Y: inserts an additional Y axis

• Z: inserts an additional Z axis

See “Additional Axes” on page 86 for details.

Legend Inserts a legend for the data set or for the selected 
visualization(s) into the current window. See “Legends” on 
page 79 for details.

Colorbar Inserts a colorbar for the selected item.

Note - Only available for indexed color images.

{Additional items vary depending on the iTool selected.} For example:

Light Inserts a new light into the current window. See “Lights” in 
Appendix D for details.

Table A-3: The Insert Menu
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Operations Menu

The Operations menu contains commands for performing operations on the selected 
data. Contents of the Operations menu vary from iTool to iTool.

Menu 
Selection Function

Operations 
Browser

Displays a hierarchical nested list of all tools in the menus and 
toolbars. See “The Operations Browser” on page 95 for 
details.

Macros Selections related to iTool’s macros.

• Run Macro: Select to run a macro.

• Start Recording: Select to begin recording a macro.

• Stop Recording: Select to cease macro recording.

• Macro Editor: Select to bring up the Macro Editor 
dialog.

Statistics Computes the statistical properties of the selected item(s), and 
displays the results in a separate dialog.

See “Displaying Statistics” on page 132 for details.

Histogram Displays a histogram plot of the selected data. See “Plotting a 
Histogram” on page 131 for details.

Filter Choose from these options:

• Convolution

• Median

• Smooth

See “Filtering” on page 125 in Chapter 8, "Common 
Operations" for details.

{Additional filters vary depending on the iTool selected.}

Rotate

Table A-4: The Operations Menu
iTool User’s Guide Operations Menu



352 Appendix A: iTools Interface Reference
Rotate Left

Rotate Right

Rotate by Angle

Rotate the selected data space left 90°.

Rotate the selected data space right 90°.

Specify the number of degrees to rotate the selected data 
space.

Transform • Resample — Resample the selected data using 
parameters specified in Resample property settings.

• Rotate Data — Rotate the data within the visualization by 
a specified number of degrees without affecting the rest of 
the data space.

• Scale Data — Scale the selected object by a specified 
scale factor.

See “Transformations” on page 122 in Chapter 8, "Common 
Operations" for details.

{Additional transformations vary depending on the iTool 
selected.}

Menu 
Selection Function

Table A-4: The Operations Menu (Continued)
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Morph Choose from the following options:

• Dilate is commonly known as “fill”, “expand”, or “grow.” 
It can be used to fill “holes” of a size equal to or smaller 
than the structuring element.

• Erode does to the background what dilation does to the 
foreground. Given an image and a structuring element, 
erode can be used to remove islands smaller than the 
structuring element. 

• Morph open is simply an erosion operation followed by a 
dilation operation. Applying morph open more than once 
produces no further effect.

• Morph close is simply a dilation operation followed by an 
erosion operation. Applying morph close more than once 
produces no further effect.

• Morph gradient is the subtraction of an eroded version of 
the original image from a dilated version of the original 
image. 

• Morph tophat is implemented by first applying the 
opening operator to the original image, then subtracting 
the result from the original image. Applying tophat shows 
the bright peaks within the image. 

See “Morphing” on page 130 in Chapter 8, "Common 
Operations" for details.

{Additional items vary depending on the iTool selected.}

Menu 
Selection Function

Table A-4: The Operations Menu (Continued)
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Window Menu

The Window menu contains commands for displaying the Data, Operations and 
Visualization browsers, for zooming in and out of the display, for modifying the 
window layout, and for displaying a log of system messages. The Window menu 
items are common to all iTools.

Menu 
Selection Function

Data Manager Displays the Data Manager for the current iTool. See “About 
the Data Manager” on page 22 for details.

Visualization 
Browser

Displays a hierarchical nested list of all visualization elements 
in the display area. See “The Visualization Browser” on 
page 92 for details.

Canvas Zoom Set to increase or decrease magnification of the entire iTool 
window without moving the observer’s “eye.”

• 800%

• 400%

• 200%

• 100%

• 75%

• 50%

• 25%

Default is 100%.

Zoom on Resize If this menu item is checked, views will be resized whenever a 
visualization is zoomed in any way.

By default, the view will not be resized if zoom is performed.

Layout... Displays the window layout dialog, which allows the user to 
change the current view layout and the window dimensions.

Fit to View Select to fit window to view.

Table A-5: The Window Menu
Window Menu iTool User’s Guide
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Help Menu

The Help menu contains commands for displaying online help and information about 
the iTools. The Help menu items are common to all iTools.

Note
In the Operations and Preferences browser windows, help for the selected item is 
also available on the context menu.

Menu Selection Function

Help on iTools Displays help for the iTools system.

Help on the iTools 
Data Manager

Displays help on the Data manager.

Help on the iTools 
Parameter Editor

Displays help on the Parameter Editor

Help on Selected Item Displays help for the item selected in the iTool 
visualization or browser window.

Help on this iTool Displays help for the current iTool.

About iTools Displays a dialog describing the iTools and giving the 
version number.

Table A-6: The Help Menu
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File Toolbar

The File toolbar contains the following buttons:

Button Tool Name Function

New Creates a new iTool of the same type as the current 
tool with no data or visualizations.

Open Opens a file for import into the current iTool. If this is 
a data file, such as an image file, ASCII file, or binary 
file, a new data object will be created and, if 
applicable, a new visualization will be created. 

Save  Saves the state of the current iTool to a file. If the 
state has not been previously saved and has no 
filename, enter a filename. The saved file is cross-
platform.

Print Prints the entire contents of the graphics window. 

Table A-7: File Toolbar Buttons
File Toolbar iTool User’s Guide
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Edit Toolbar

The Edit Toolbar contains the following buttons:

Button Tool Name Function

Undo Nullifies the previous operation and restores the iTool 
to its state before that operation.

Note - Operations such as open, save, export, export 
variable, print, exit, and window moving and resizing 
cannot be undone.

Redo Nullifies the previous Undo command and restores 
the iTool to its state before the Undo command was 
issued. Any action that can be undone can also be 
redone.

Cut Deletes the selected item(s) and places a copy on the 
local clipboard. If the window layout is locked, you 
will be asked if a copy of the view should be placed 
on the System clipboard.

Copy Copies the selected item to the local clipboard. If a 
view is copied, then a bitmap copy of that view (not 
the entire Window) is also put on the System 
clipboard. 

Paste Pastes the current local clipboard contents into the 
selected view. If a view is pasted, it is added to the 
current Window layout and becomes the currently-
selected view.

Table A-8: Edit Toolbar Buttons
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Manipulator Toolbar

The Manipulator Toolbar contains the following buttons:

Button Tool Name Function

Select Click to enter select mode. The arrow pointer is 
displayed, and objects can be selected in the display 
area. Click to select an object; a selection box appears 
around the current selection.

Rotate Click to enter rotate mode. A rotation sphere appears 
around the currently selected object. 

• Position the mouse pointer on an axis, and the 
axis rotation pointer is displayed. Drag in the 
desired direction to rotate the object along the 
axis. 

• Position the mouse pointer anywhere on the 
selected object, and the free rotation pointer is 
displayed. Drag in the desired direction to rotate 
the object freely.

View Pan Click and drag across the view to pan.

View Zoom Click to enter zoom mode. The zoom cursor is 
displayed, and dragging the mouse closer to or farther 
from the center of the canvas decreases or increases 
magnification at the initial point of clicking.

View Zoom Click to select a magnification percentage for the 
entire view.

Table A-9: Manipulator Toolbar Buttons
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Annotation Toolbar

The Annotation Toolbar contains the following buttons:

Button Tool Name Function

Text Click to enter text annotation mode. The insert pointer 
is displayed, and text can be entered from the 
keyboard.

Line Click to enter line annotation mode. The crosshairs 
pointer is displayed. Click at the starting point for the 
line and drag in the desired direction. Release the 
mouse button to terminate the line.

Rectangle Click to enter rectangle annotation mode. 

Oval Click to enter oval annotation mode.

Polygon Click to create a polygon annotation. Click to define 
vertices, double-click to complete polygon.

Freehand Click to enter freehand annotation mode. The cross-
hairs pointer is displayed. Click at a starting point and 
drag to create the desired shape. Release the mouse 
button to complete the polygon.

Table A-10: Annotation Toolbar Buttons
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Context Menu

Right-clicking on the visualization window brings up a context menu at that location. 
The context menu is common to all iTools, and it contains the following menu items:

Menu 
Selection Description

Cut Deletes the selected item(s) and places a copy on the local 
clipboard. If the window layout is locked, you will be asked if 
a copy of the view should be placed on the System clipboard.

Copy Copies the selected item to the local clipboard. If a view is 
copied, then a bitmap copy of that view (not the entire 
Window) is also put on the System clipboard. 

Paste Pastes the current local clipboard contents into the selected 
view. If a view is pasted, it is added to the current Window 
layout and becomes the currently-selected view.

Delete Deletes the currently-selected item(s), without putting a copy 
on the local or system clipboards. Deletion can be reversed 
with Undo.

Grouping: Grouping gives you the advantage of allowing desired items to 
operate together and be manipulated as a single unit.

Group

Ungroup

Groups the currently-selected items into a single unit.

If the selected item is currently a group, then it is ungrouped.

Note - You cannot group items across separate visualization 
and annotation layers.

Order:

Table A-11: The Context Menu
Context Menu iTool User’s Guide
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Bring To Front

Send To Back

Bring Forward

Send Backward

Brings the selected item(s) to the front of the graphics 
hierarchy.

Sends the selected item(s) to the back of the graphics 
hierarchy.

Bring the selected item(s) forward one position in the graphics 
hierarchy.

Send the selected item(s) back one position in the graphics 
hierarchy.

Export to IDL Exports the currently selected item(s) to your IDL session.

Parameters... Brings up the parameter editor for the currently selected 
item(s).

Properties… Brings up the property sheet for the currently selected item(s). 
If only the view is selected, the property sheet for the view 
layer is presented. Only one property sheet may be displayed at 
a time. If a different item or view is selected, the contents of 
the property sheet change to the properties of the new item or 
view. For grouped items, a single property sheet with the 
intersection of the properties is displayed. When the property 
values are not the same for the grouped items, those properties 
are set to undefined or default. Setting a property for a grouped 
item sets that property for all items in the group.

Menu 
Selection Description

Table A-11: The Context Menu (Continued)
iTool User’s Guide Context Menu
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Appendix B:

Property Controls
The following user interface controls are used in iTool property sheets. The general 
function of these controls is described here. Refer to the individual property 
descriptions in Appendix C, “Operations Properties” and Appendix D, “Visualization 
Properties” for specific information on how to set individual property controls.
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Control Type Function

Boolean Click the browse button  to 
expand the list. Select either of the 
two choices (Show or Hide, True 
or False, etc.) from the list.

Number If the number is editable, type in a new value. You may be 
restricted to whole numbers or a range of numbers. Entering a 
value outside of the valid range causes the number to snap to 
the nearest allowable value.

If a slider is displayed, slide the 
marker to select a new value.

If a spinner control is displayed, 
click, or click and hold the up or 
down buttons to change the value.

String Enter a string in the text box. If the 
string exceeds the length of the 
text box, a browse button is 
provided to expand the text box.

Table B-12: Controls Used in Property Sheets
iTool User’s Guide
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Color Select a color from the palette displayed in the color selector:

Or click Custom Color (UNIX users right-click the color bar 
at the bottom of the window) to specify RGB or HSL values:

Windows users: 
enter Hue, Sat, 
Lum or Red, 
Green, Blue 
values and click 
OK to apply the 
new values. 
Click Add to 
Custom Colors 
to save your 
values.

UNIX users: 
drag the Red, 
Green, Blue or 
Hue, Lightness, 
Saturation 
sliders to change 
values, and click 
OK to apply the 
new values.

Control Type Function

Table B-12: Controls Used in Property Sheets (Continued)

Windows Color Picker

UNIX Color Picker
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Line Style Select a line style from the list. To 
make the line invisible, select No 
Line.

Line Thickness Select a line thickness from the list. 
Numbers indicate line thickness in 
pixels. Use the scroll bar to display 
additional items.

Symbol Select a symbol to appear at regular 
intervals on the selected line from 
the list. To remove a symbol from a 
line, select No Symbol. Use the 
scroll bar to display additional items.

String List Select an item from the list. Use 
the scroll bar to display additional 
items.

User Defined Click the Edit button to 
display the user-defined 
property control.

Control Type Function

Table B-12: Controls Used in Property Sheets (Continued)
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Operations 
Properties

This appendix describes the following properties of the IDL Intelligent Tools interface found in the 
Operations Browser of each iTool:
The Operations Browser  . . . . . . . . . . . . . .  368
Macros Properties  . . . . . . . . . . . . . . . . . . .  369
Statistics Properties . . . . . . . . . . . . . . . . . .  370
Filter Properties . . . . . . . . . . . . . . . . . . . . .  372
Rotate Properties . . . . . . . . . . . . . . . . . . . .  376
Rotate Properties . . . . . . . . . . . . . . . . . . . .  376
Transform Properties . . . . . . . . . . . . . . . . .  377
Map Projection Properties . . . . . . . . . . . . .  381
Map Register Image Properties . . . . . . . . .  382

Morphing Properties . . . . . . . . . . . . . . . . .  383
Crop Properties . . . . . . . . . . . . . . . . . . . . .  384
Region Grow Properties . . . . . . . . . . . . . .  385
Contour Properties  . . . . . . . . . . . . . . . . . .  387
Image Properties . . . . . . . . . . . . . . . . . . . .  388
Surface Properties  . . . . . . . . . . . . . . . . . .  389
Volume Properties  . . . . . . . . . . . . . . . . . .  390
Image Plane Properties . . . . . . . . . . . . . . .  392
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The Operations Browser 

The Operations Browser provides a hierarchical tree view of the tools and operations 
available from the iTool Operations menu. The Operations Browser is used to set 
properties for operations and tools used in the iTool window. See “The Operations 
Browser” on page 95 for details on how to display and use the Operations Browser.

The property sheet for each operation displayed in the Operations Browser contains 
the Name and Description properties described in the following table. For each 
property, the type of control and the values that can be assigned are listed. For a 
description of how a particular control is used, refer to Appendix B, “Property 
Controls”

Figure C-15: The Operations Browser

Property Control Type: Options

Name String: Name assigned to this statistics dialog. Edit the text to 
change the name.

Description String: Description of this statistics function. Edit the text to 
change the description.

Table C-13: Statistics Operation Properties
The Operations Browser iTool User’s Guide
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Macros Properties 

Macros provide a shortcut mechanism that lets you quickly and automatically repeat 
a sequence of interactive operations. The Macros tools appears in the Operation 
Browser for all iTools. See Chapter 8, “Working with Macros” for details on how to 
use macros.

This browser has no properties that can be configured other than Name and 
Description.
iTool User’s Guide Macros Properties
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Statistics Properties 

The Statistics tool displays statistical information relating to the currently selected 
object or group of objects. The Statistics tool appears in the Operation Browser for all 
iTools. See “Displaying Statistics” on page 132 for details on how to use the Statistics 
tool.

This browser has no properties that can be configured other than Name and 
Description.
Statistics Properties iTool User’s Guide
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Histogram Properties 

The Histogram tool displays a histogram plot of the data selected in the iTool 
window. The Histogram tool appears in the Operation Browser for all iTools. See 
“Plotting a Histogram” on page 131 for details on how to use the Histogram tool.

Histogram has no configurable properties other than Name and Description.
iTool User’s Guide Histogram Properties
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Filter Properties 

The following properties control the iTool filters. 

Convolution Properties

Convolution smooths data by using a weighted moving average. Convolution filter 
properties appear on the Operations Browser for all iTools. See “Convolution Filter” 
on page 127 in Chapter 8, "Common Operations" for details on applying convolution. 

For each property, the type of control and the values that can be assigned are listed. 
For a description of how a particular control is used, refer to.

Property Control Type: Options

Show dialog Boolean: Display the Convolution Kernel Editor dialog when 
the Convolution filter is selected from the 
Operations → Filter menu. Choose True to display the 
dialog, or False to apply the Convolution filter without 
displaying the dialog. Default = True

Kernel User Defined: Display the Convolution Kernel Editor dialog. 
Click Edit to display the dialog. Default = <Default>

Center Boolean: Select True (to center) or False (no centering).

Default = True

Automatic scaling Boolean: Select True (for automatic scaling) or False (no 
automatic scaling).

Default = True

Scale factor Default = 16

Edge values Boolean: Select for edge value type:

• Zero

• Wrap

• Repeat

Default = Wrap

Table C-14: Convolution Filter Properties
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Median Properties

Median smoothing replaces each point with the median (a value in an ordered set of 
values with an equal number of values above and below it) of the one- or two-
dimensional neighborhood of a given width. See “Median Filter” on page 125 in 
Chapter 8, "Common Operations" for details on applying the median filter. 

For each property, the type of control and the values that can be assigned are listed. 
For a description of how a particular control is used, refer to Appendix B, “Property 
Controls”. 

Smooth Properties

The Smooth filter reduces noise within an image by applying low pass filters. Smooth 
filter properties appear on the Operations Browser for all iTools. See “Smooth Filter” 
on page 125 in Chapter 8, "Common Operations" for details on applying the smooth 
filter. 

One dimensional Boolean: Select True or False.

Default = False

Property Control Type: Options

WIDTH Number: Width of the smooth window. Enter a whole number 
between 1 (no smoothing) and the width of the data. 
Default = 3

Even Average Boolean: If set to true and the Width property is set to an even 
number, the operation will return the average of the two 
middle numbers.

Table C-15: Median Filter Properties

Property Control Type: Options

Table C-14: Convolution Filter Properties (Continued)
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For each property, the type of control and the values that can be assigned are listed. 
For a description of how a particular control is used, refer to Appendix B, “Property 
Controls”. 

Roberts Filter Properties

Roberts filter appears on the Operations Browser for the iImage tool only. Roberts 
filter has no configurable properties other than Name and Description. For more 
information on the Roberts filter, see “ROBERTS” in the IDL Reference Guide 
manual.

Sobel Filter Properties

Sobel filter appears on the Operations Browser for the iImage tool only. Sobel filter 
has no configurable properties other than Name and Description. For more 
information on the Sobel filter, see “SOBEL” in the IDL Reference Guide manual.

Unsharp Mask Properties

An unsharp-mask filter can be applied to any two-dimensional array or a TrueColor 
image. The unsharp mask enhances the contrast between neighboring pixels in an 
image, and is widely used for astronomical images and for digital photographs. For 

Property Control Type: Options

WIDTH Number: Width of the smooth window. Enter a whole number 
between 1 (no smoothing) and the width of the data. 
Default = 3

Table C-16: Smooth Filter Properties
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more information on curve fitting a plot, see “Unsharp Mask Filter” in Chapter 7, 
"Common Operations".

Property Control Type: Options

Show dialog Boolean: Display the Unsharp Mask Editor dialog when the 
Unsharp Mask filter is selected from the Operations → Filter 
menu. Choose True to display the dialog, or False to apply the 
Unsharp Mask filter without displaying the dialog. 

Default = True

Amount of filter 
(%)

Number: Click and slide to select percentage amount of filter 
to be applied.

Default = 100%

Radius in pixels Number: Click and slide to select filter radius in pixels.

Default = 3

Clipping 
threshold

Number: Click and slide to select clipping threshold.

Default = 0

Table C-17: Unsharp Mask Filter Properties
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Rotate Properties 

The following properties control the iTool Rotate tools. Rotate properties appear on 
the Operations Browser for all iTools (for iImage it is Rotate or Flip).

Rotate Left Properties

Rotate Left has no configurable properties other than Name and Description.

Rotate Right Properties

Rotate Right has no configurable properties other than Name and Description.

Rotate By Angle Properties

Rotate by Angle has no configurable properties other than Name and Description.

Flip Horizontal

Flip Horizontal has no configurable properties other than Name and Description.

Flip Vertical

Flip Vertical has no configurable properties other than Name and Description.
Rotate Properties iTool User’s Guide
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Transform Properties 

The following properties control the iTool Transform tools. 

Resample Properties

The Resample transform resamples the selected data using the resampling factors and 
method specified in these properties. Resample Transform properties appear on the 
Operations Browser for all iTools. See “Resample” on page 122 in Chapter 8, 
"Common Operations" for details on how to resample data.

For each property, the type of control and the values that can be assigned are listed. 
For a description of how a particular control is used, refer to Appendix B, “Property 
Controls”.

Property Control Type: Options

1st dimension 
factor

Number: The resampling factor for the first dimension (X). 
Edit the number to change the value. Default = 2

2nd dimension 
factor

Number: The resampling factor for the second dimension (Y). 
Edit the number to change the value. Default = 2

3rd dimension 
factor

Number: The resampling factor for the third dimension (Z). 
Edit the number to change the value. Default = 2

Interpolation 
method

String List: Method of interpolation to use in resampling. 
Select a method from the list. Choose from these values:

• Nearest neighbor: Assign the value of the nearest pixel to 
the pixel in the output image. Fastest method, but may 
cause jagged edges.

• Linear: Surveys the two closest pixels, drawing a line 
between them and designating a value along that line as 
the output pixel value.

• Cubic: Use cubic polynomial waveforms instead of linear 
waveforms. Most accurate method, but may require more 
processing time.

Default = Nearest neighbor

Table C-18: Resample Transform Properties
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Rotate Data Properties

The Rotate Data operation allows you to rotate the data within the visualization by a 
specified number of degrees without affecting the rest of the data space (graphical 
objects and axes). See “Rotation” on page 118 in Chapter 8, "Common Operations" 
for details on using the Rotate Data operation.

The following properties control the Rotate Data tool. For each property, the type of 
control and the values that can be assigned are listed. For a description of how a 
particular control is used, refer to Appendix B, “Property Controls”.

Property Control Type: Options

Angle Number: The angle of rotation in degrees clockwise. 
Default = 0

X center offset Number: X subscript of the center of rotation. Default = 0

Y center offset Number: Y subscript of the center of rotation. Default = 0

Magnification Number: Magnification factor. Default = 1

Interpolation 
method

String List: Method of interpolation to use when rotating. 
Select a method from the list. Choose from these values:

• Nearest neighbor: Assign the value of the nearest pixel to 
the pixel in the output image. Fastest method, but may 
cause jagged edges.

• Linear: Surveys the two closest pixels, drawing a line 
between them and designating a value along that line as 
the output pixel value.

• Cubic: Use cubic polynomial waveforms instead of linear 
waveforms. Most accurate method, but may require more 
processing time.

Default = Nearest neighbor

Extrapolate 
missing

Boolean: Extrapolate the value of a missing pixel from the 
value of nearby pixels. Default = True

Table C-19: Rotate Data Properties
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Scale Data Properties

The Scale Data operation scales the selected objects by a specified scale factor. Scale 
Data properties appear on the Operations Browser for all iTools. See “Scaling” on 
page 69 for details on using the Scale Data operation.

The following properties control the Scale Data tool. For each property, the type of 
control and the values that can be assigned are listed. For a description of how a 
particular control is used, refer to Appendix B, “Property Controls”.

Missing value Number: A value to be substituted for pixels in the rotated 
image that fall outside the bounds of the unrotated image. This 
property is only used if the Extrapolate missing property is set 
to false. 

Default = 0

Pivot Boolean: If set to true, the image will be rotated around the 
point defined by the X center offset and Y center offset. If set 
to false, the image will be rotated around its center. 
Default = False

Property Control Type: Options

Show dialog Boolean: Display the Scale Data Editor dialog when Scale 
Data is selected from the Operations → Scale Data menu. 
Choose True to display the dialog, or False to apply the Scale 
Data without displaying the dialog. 

Default = True

Scale Factor Number: Scale the selected data by this factor. Edit the number 
to change the factor that appears in the Scale Factor dialog. 
Scale Factor may be positive or negative. 

Default = 2

Table C-20: Scale Data Properties

Property Control Type: Options

Table C-19: Rotate Data Properties
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Invert Image Properties

Invert Image Transform properties appear on the Operations Browser for iImage only. 
The operation has no unique properties. 

Byte Scale Properties

Byte Scale properties appear on the Operations Browser for iImage only. For each 
property, the type of control and the values that can be assigned are listed. For a 
description of how a particular control is used, refer to Appendix B, “Property 
Controls”.

Note
When working with byte data, the default bytescale range is always 0-255. 
Therefore, even if data is bytescaled from 0-100, it will display using 0-255. This 
may cause visualized data to appear darker.

Property Control Type: Options

Automatic 
Min/Max

Boolean: Automatically compute minimum and maximum 
values? Choose True or False. Default = True

Minimum cutoff Number: Minimum value of array to be considered. Edit the 
number to change the value. Default = 0

Maximum cutoff Number: Maximum value of array to be considered. Edit the 
number to change the value. Default = 255

Bottom byte Number: Minimum value of scaled result. Edit the number to 
change the value. Range = 0-255. Default = 0

Top byte Number: Maximum value of scaled result. Edit the number to 
change the value. Range = 0-255. Default = 255

Table C-21: Byte Scale Transform Properties
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Map Projection Properties 

The map projection functionality displays image and contour data that are 
georeferenced and mapped to particular projections. See Chapter 15, “Working with 
Maps” for details on how to use mapping functionality.

For a comprehensive list of map projection properties, see “Applying a Map 
Projection” in Chapter 15.

Map Projection has no configurable properties other than Description.

Property Control Type: Options

Show dialog Boolean: Display the Map Projection dialog when 
Operations → Map Projection is chosen. Choose True to 
display the dialog, or False to apply the Map Projection dialog 
without displaying the dialog. 

Default = True

Table C-22: Map Projection Properties
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Map Register Image Properties 

The map projection functionality displays image and contour data that are 
georeferenced and mapped to particular projections. See Chapter 15, “Working with 
Maps” for details on how to use mapping functionality.

Map Register Image has the following configurable properties.

Property Control Type: Options

Origin (x) Number: Set the longitudinal minimum in degrees.

Default = 0

End (x) Number: Set the longitudinal maximum in degrees.

Default = 0

Pixel size (x) Number: Set the longitudinal pixel size in degrees.

Default = 0

Origin (y) Number: Set the latitudinal minimum in degrees.

Default = 0

End (y) Number: Set the latitudinal maximum in degrees.

Default = 0

Pixel size (y) Number: Set the latitudinal pixel size in degrees.

Default = 0

Table C-23: Map Register Properties
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Morphing Properties 

Morphing is available for iImage, iSurface, and iContour.

Mathematical morphology is a method of processing digital images on the basis of 
shape. Six morphing options are available for use in iTools: dilate, erode, morph 
open, morph close, morph gradient, and morph tophat. All six options share the same 
properties. See “Morphing” on page 130 in Chapter 8, "Common Operations" for 
details on morphing data. 

For each property, the type of control and the values that can be assigned are listed. 
For a description of how a particular control is used, refer to Appendix B, “Property 
Controls”. 

Property Control Type: Options

Structure Shape String List: The shape of the structuring element used in the 
morph operation. Choose from these values:

• Square

• Circle

 Default = Square

Structure Width Number: The width of the structuring element.

Default = 3

Table C-24: Morphological Filter Properties
iTool User’s Guide Morphing Properties



384 Appendix C: Operations Properties
Crop Properties 

Cropping is available for the iImage tool. The iImage cropping operation allows you 
to crop one or more selected images at a specified location and specified dimensions. 

See “iImage Tool Operations” in Chapter 10 for details on cropping. 

For each property, the type of control and the values that can be assigned are listed. 
For a description of how a particular control is used, refer to Appendix B, “Property 
Controls”. 

Property Control Type: Options

X Number: The X cropping value.

Default = 0

Y Number: The Y cropping value.

Default = 0

Width Number: The crop operation width setting.

Default = <width of selected image>

Height Number: The crop operation height setting.

Default = <height of selected image>

Units String List: 

• Data

• Pixel

Default = Data

Table C-25: Crop Properties
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Region Grow Properties 

Region growing expands a selected area to include nearby pixels that fall within a 
threshold range of the current selection. See “REGION_GROW” in the IDL 
Reference Guide manual for additional details. For a description of how a particular 
control is used, refer to Appendix B, “Property Controls”.

Property Control Type: Options

Region grow 
method

String List: The method used to select pixels that are similar to 
the current selection. Choose from these values:

• By threshold: The expanded region includes neighboring 
pixels that fall within the range defined by the Threshold 
minimum and Threshold maximum values.

• By standard deviation: The expanded region includes 
neighboring pixels that fall within the range of the mean of 
the region’s pixel values plus or minus the given multiplier 
times the sample standard deviation as follows: 

Mean +/- StdDevMultiplier * StdDev 

where Mean is the mean value of the selected pixels, 
StdDevMultiplier is the value specified by the 
Standard Deviation Multiplier property, and StdDev is the 
standard deviation of the selected pixels.

Default = By threshold

Pixel search 
method

String List: Specifies which pixels should be considered 
during region growing. Four-neighbor searching searches only 
the neighbors that are exactly one unit in distance from the 
current pixel; Eight-neighbor searching searches all 
neighboring pixels.

Choose from these values:

• 4-neighbor

• 8-neighbor

Default = 4-neighbor

Table C-26: Region Grow Operation Properties
iTool User’s Guide Region Grow Properties
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Threshold to use String List: Specifies the threshold values to use. Choose from 
these values:

• Source ROI/Image threshold: Base the threshold values 
on the pixel values in the currently selected region.

• Explicit: Specify the threshold values using the Threshold 
minimum and Threshold maximum properties.

Default = Source ROI/Image threshold

Threshold 
minimum

Number: The explicitly specified minimum threshold value. 
Default = 0

Threshold 
maximum

Number: The explicitly specified maximum threshold value. 
Default = 256

Standard 
deviation 
multiplier

Number: The number of standard deviations to use if the 
region growing method is By standard deviation. Default = 1

For an RGB(A) 
image use

String List: If the image has separate color channels, use the 
selected channel when growing the region. Choose from these 
values:

• Luminosity: Luminosity values

• Red Channel: Red values

• Green Channel: Green values

• Blue Channel: Blue values

• Alpha Channel: Transparency values.

Default = Luminosity

Property Control Type: Options

Table C-26: Region Grow Operation Properties (Continued)
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Contour Properties 

Contour Properties appear on the Operations Browser for iImage and iSurface only. 
The following properties control the contour operation. For each property, the type of 
control and the values that can be assigned are listed. For a description of how a 
particular control is used, refer to Appendix B, “Property Controls”.

Property Control Type: Options

N_LEVELS Number: Set the number of contour levels.

Default = 5

Value Number: Set the contour value to use.

Default = 0

Projection Boolean: Choose the contour type:

• Planar

• 3D

Default = Planar

Table C-27: Contour Properties
iTool User’s Guide Contour Properties
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Image Properties 

Image Properties appear on the Operations Browser for iSurface and iContour only. 
Image has no configurable properties other than Name and Description.
Image Properties iTool User’s Guide
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Surface Properties 

Surface Properties appear on the Operations Browser for iImage and iContour only. 
Surface has no configurable properties other than Name and Description.
iTool User’s Guide Surface Properties
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Volume Properties 

Volume Properties appear on the Operation Browser for the iVolume tool only.

Image Plane

Image Plane has no configurable properties other than Name and Description.

Isosurface

For each property, the type of control and the values that can be assigned are listed. 
For a description of how a particular control is used, refer to Appendix B, “Property 
Controls”.

Render Volume

Render Volume has no configurable properties other than Name and Description.

Property Control Type: Options

Show Dialog Boolean: Display the Isosurface Value Selector dialog when 
Isosurface is selected from the Operations → Volume menu. 
Choose True to display the dialog, or False to apply the 
isosurface without displaying the dialog. 

Default = True

Table C-28: Isosurface Properties
Volume Properties iTool User’s Guide
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Interval Volume

For each property, the type of control and the values that can be assigned are listed. 
For a description of how a particular control is used, refer to Appendix B, “Property 
Controls”.

Property Control Type: Options

Show Dialog Boolean: Display the Isosurface Value Selector dialog when 
Isosurface is selected from the Operations → Volume menu. 
Choose True to display the dialog, or False to apply the 
isosurface without displaying the dialog. 

Default = True

Table C-29: Interval Volume Properties
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Image Plane Properties 

Image Plane Properties appear on the Operation Browser for the iVolume tool only.

Property Control Type: Options

Show Boolean: Display the image plane after Image Plane is 
selected from the Operations → Volume → Image Plane 
menu. Choose True to display, or False to apply the image 
plane without displaying. 

Default = True

Opacity control Boolean: Choose opacity control type.

• Use opacity table

• Opaque

• Opacity value

Default = Use opacity table

Opacity value Number: Set opacity value.

Default = 50

Orientation Boolean: Choose image plane orientation.

• X

• Y

• Z

Default = X

Opacity Number: Set opacity.

Default = 1

Color Boolean: Set color.

Default = White [255, 255, 255]

Bottom color Boolean: Set bottom color.

Default = White [255, 255, 255]

Table C-30: Image Plane Properties
Image Plane Properties iTool User’s Guide
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Launch iImage

Launch iImage has no configurable properties other than Name and Description.

Depth offset Number: Set depth offset value.

Default = 1

Skip zero opacity Boolean: Choose True to skip zero opacity or False to use 
zero opacity.

Default = True

Texture 
interpolation

Boolean: Set texture interpolation type.

• Nearest neighbor

• Bilinear

Default = Nearest neighbor

Property Control Type: Options

Table C-30: Image Plane Properties
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Appendix D:

Visualization 
Properties

This appendix describes the following visualization properties of the IDL Intelligent Tools 
interface found in the Visualization Browser of each iTool:
Introduction . . . . . . . . . . . . . . . . . . . . . . . .  396
The Visualization Browser  . . . . . . . . . . . .  397
Window Properties  . . . . . . . . . . . . . . . . . .  398
View Properties  . . . . . . . . . . . . . . . . . . . . .  400
Visualization Layer Properties  . . . . . . . . .  401

Data Space Properties . . . . . . . . . . . . . . . .  403
Visualization Type Properties . . . . . . . . . .  406
2D Annotation Layer Properties  . . . . . . .  469
Legend Properties . . . . . . . . . . . . . . . . . . .  480
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Introduction

The IDL iTools comprise six distinct tools: iImage, iPlot, iSurface, iContour, 
iVolume, and iMap. Each tool has a specific set of functions related to the type of data 
it is designed to use. In addition to these specific tasks, all five tools have a number of 
functions in common. 

This appendix describes those functions that all iTools have in common; for 
information about the functions unique to the individual iTools, refer to 

• Chapter 10, “Working with Images”

• Chapter 11, “Working with Surfaces”

• Chapter 12, “Working with Contours”

• Chapter 13, “Working with Plots”

• Chapter 14, “Working with Volumes”

• Chapter 15, “Working with Maps”

This appendix is an overview of the menu items and toolbar buttons that are common 
to all iTools. 
Introduction iTool User’s Guide
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The Visualization Browser

The Visualization Browser provides a hierarchical tree view of all objects displayed 
in the iTool window. The Visualization Browser is used to select objects and to 
display the property sheets for selected objects. See “The Visualization Browser” on 
page 92 for details on how to display and use the Visualization Browser.

The Visualization Browser displays a list of the contents of the iTool window in the 
left pane. The property sheet for the object currently selected in the left pane can be 
displayed in the right pane of the Visualization Browser window by clicking on the 
small arrows to the top-right of the left pane and top-left of the right pane (in the 
middle if both are displayed). For example, to display the properties of the current 
window, select Window in the left pane of the Visualization Browser as shown in the 
following figure.
iTool User’s Guide The Visualization Browser
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Window Properties 

These properties control the display of the iTool window. For each property, the type 
of control and the values that can be assigned are listed. For a description of how a 
particular control is used, refer to Appendix B, “Property Controls”.

Figure D-16: The Visualization Browser with Window Properties Displayed

Property Control Type: Values

Zoom on Resize Boolean: Zoom visualization upon resize of window? Choose 
True or False. Default = False

Window Width Number: Width of the current iTool window in pixels. Edit the 
number to change the value. Default = 640

Note - The minimum width of the window correlates to the 
width of the menubar.

Window Height Number: Height of the current iTool window in pixels. Edit 
the number to change the value. Default = 512 Minimum = 
100

Table D-31: iTool Window Properties
Window Properties iTool User’s Guide
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All property sheets displayed in the Visualization Browser, with the exception of the 
Window property sheet displayed above, include the Name, Description, and Show 
properties described in the following table:

Drag Quality Boolean: Drag quality to define the level of detail shown when 
a visualization is translated, scaled, zoomed, or otherwise 
moved by mouse. Choose High, Medium, or Low. 
Default = Low.

Property Control Type: Values

Name String: Name assigned to this view. Edit the text to change the 
name. 

Description String: Description of this view. Edit the text to change the 
description. 

Show Boolean: Show this view? Choose True or False. 
Default = True

Table D-32: Name and Description Properties

Property Control Type: Values

Table D-31: iTool Window Properties
iTool User’s Guide Window Properties
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View Properties

Each iTool window contains at least one view. If multiple views have been created 
from the Window Layout dialog, each view will be listed separately.

These properties control the display of the view or views contained in the iTool 
window. For each property, the type of control and the values that can be assigned are 
listed. For a description of how a particular control is used, refer to Appendix B, 
“Property Controls”

Figure D-17: Visualization Browser with View Properties Displayed

Property Control Type: Values

Zoom Factor Number: Increase or decrease magnification of the view by 
this factor. Edit the number to change the value. Default = 1

Layout Position Displays the currently selected layout view

X margin Number: Set horizontal margin size. Valid range = 0.0 to 0.49.

Y margin Number: Set vertical margin size. Valid range = 0.0 to 0.49.

Background color Color: Sets the background color of the contained 
Visualization Layer. Default = [255, 255, 255] (white)

Table D-33: View Properties
View Properties iTool User’s Guide
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Visualization Layer Properties

The Visualization Layer contains the data space and, for three-dimensional objects, 
the lights, associated with a visualization. 

These properties control the visualization of the data space. For each property, the 
type of control and the values that can be assigned are listed. For a description of how 
a particular control is used, refer to Appendix B, “Property Controls”.

Figure D-18: Visualization Browser with Visualization Layer Properties Displayed

Property Control Type: Values

Background 
Color 

Color: Visualization layer background color. Transparent must 
be set to False. Click to choose from the default color palette, 
or specify RGB values. Default = [255, 255, 255] (white)

Transparent Boolean: Make visualization layer transparent? Choose True 
or False. Default = True

Table D-34: Visualization Layer Properties
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Projection String List: Projection method for displaying the visualization 
layer. Select a method from the list. Choose from these values:

• Orthogonal: Orthographic projection (objects are 
projected onto the visualization layer along lines 
perpendicular to the view plane)

• Perspective: Objects are projected onto the visualization 
layer along perspective lines that converge in the distance.

Default = Orthogonal

Stretch to Fit Boolean: Stretch visualization layer to fit window? Choose 
True or False. Default = False

Depth cue bright Number: The distance of the near Z plane used for depth 
cueing. Objects closer than this distance will be painted in 
their normal color. Objects further than this distance will fade 
into the background.

Depth cue dim Number: The distance of the far Z plane used for depth cueing. 
Objects further than this distance will be painted in the 
background color. Setting Depth cue bright and Depth cue 
dim to the same value will disable depth cueing.

Property Control Type: Values

Table D-34: Visualization Layer Properties (Continued)
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Data Space Properties

The data space contains the data type(s) displayed within the visualization, plus the 
axes associated with the data.

Figure D-19: Visualization Browser with Data Space Properties Displayed
iTool User’s Guide Data Space Properties
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These properties control the visualization of the data space. For each property, the 
type of control and the values that can be assigned are listed. For a description of how 
a particular control is used, refer to Appendix B, “Property Controls”.

Property Control Type: Values

Isotropic scaling Scaling method. Select a method from the list. Choose 
between these values:

• Automatic: automatic scaling

• Isotropic: isotropic scaling

• Anistropic: anistropic scaling

Default = Automatic

Anistropic 2D 
scale

Presentation scale factor applied along Y axis

Anistropic 3D 
scale

Presentation scale factor applied along Z axis

Map projection

Default = No projection (click to edit)

X Minimum String: Minimum value for X coordinate of data set. 

X Maximum String: Maximum value for X coordinate of data set.

Y Minimum String: Minimum value for Y coordinate of data set.

Y Maximum String: Maximum value for Y coordinate of data set.

Z Minimum String: Minimum value for Z coordinate of 3-D data set.

Z Maximum String: Maximum value for Z coordinate of 3-D data set.

Automatic X 
range updates

Boolean: Automatically updates the range of X values. Choose 
True or False. Default = True

Automatic Y 
range updates

Boolean: Automatically updates the range of Y values. Choose 
True or False. Default = True

Automatic Z 
range updates

Boolean: Automatically updates the range of Z values. Choose 
True or False. Default = True

X log

Table D-35: Data Space Properties
Data Space Properties iTool User’s Guide
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Y log

Z log

Color Color: Data space bounding box border color. Border Style 
must not be No line. Click to choose from the default color 
palette, or specify RGB values. Default = [0,0,0] (black)

Linestyle Line Style: Data set bounding box border line style. Select a 
line style from the list. Default = No line

Thickness Line Thickness: Data set bounding box border line thickness. 
Select a thickness from the list. Default = 1. 

Fill Background Boolean: Fills data space background with background color. 
Choose True or False. Default = True

Fill Color Color: Data space background color. Fill Background must be 
set to True. Click to choose from the default color palette, or 
specify RGB values. Default = [255, 255, 200] (cream)

Transparency Number: Transparency of data space background from 0% to 
100%. Fill Background must be set to True. Move slider to 
select a new percentage. Default = 100

Property Control Type: Values

Table D-35: Data Space Properties (Continued)
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Visualization Type Properties

There are many types of visualizations that can be displayed in the six iTools. Each 
data type has its own property sheet, which can be displayed in the Visualization 
Browser.

Image

These properties control image object visualizations. For each property, the type of 
control and the values that can be assigned are listed. For a description of how a 
particular control is used, refer to Appendix B, “Property Controls”.

Figure D-20: Visualization Browser with Image Properties Displayed

Property Control Type: Values

Image Palette User Defined: By selecting Edit Color → Table Edit access 
the color table to manipulate plot color values

Table D-36: Image Properties
Visualization Type Properties iTool User’s Guide
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Interpolation String List: Method used for interpolating the image. Select a 
method from the list. Choose from these values:

• Nearest Neighbor: Assign the value of the nearest pixel 
to the pixel in the output image. Fastest method, but may 
cause jagged edges.

• Bilinear: Create a weighted average based on the nearness 
and brightness of the closest four pixels, and assign that 
value to the pixel in the output image. 

Default = Nearest Neighbor

Z value Number: z value. 3D data must be present to enable Z value.

Default = 0

Pixel size (x) Number: Pixel size for x value.

Default = 1

Pixel size (y) Number: Pixel size for y value.

Default = 1

Origin (x) Number: Origin point for x value.

Default = 0

Origin (y) Number: Origin point for y value.

Default = 0

Units Number: Number of units.

Default = None

Image 
transparency

Number: Transparency of the image, 0% - 100%. Move the 
slider to change the value. Default = 0 (no transparency)

Note - The transparency is changed by adding an alpha 
channel to the image. If your image has an alpha channel then 
the Transparency property is ignored.

Property Control Type: Values

Table D-36: Image Properties (Continued)
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Row Order String List: Select an order from the list. Choose from these 
values:

• Bottom-to-top

• Top-to-bottom

Default = Bottom-to-top

Property Control Type: Values

Table D-36: Image Properties (Continued)
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Plot

These properties control plot object visualizations. For each property, the type of 
control and the values that can be assigned are listed. For a description of how a 

Figure D-21: Visualization Browser with Plot Properties Displayed
iTool User’s Guide Visualization Type Properties
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particular control is used, refer to Appendix B, “Property Controls”.

Property Control Type: Values

Vertex Colors 
Color Table

User Defined: By selecting Edit Color → Table Edit access 
the color table to manipulate plot color values

Color Color: Color for the plot line. Click to choose from the default 
color palette, or specify RGB values. Default = [0,0,0] 
(black)

Line style Line Style: Style for the plot line. Select a style from the list. 
Default = (solid line)

Thickness Line Thickness: Thickness for the plot line. Select a thickness 
from the list. Default = 1

Minimum value Number: Minimum value to include in the plot. Edit the 
number to change the value. 

Table D-37: Plot Properties
Visualization Type Properties iTool User’s Guide
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Maximum value Number: Maximum value to display in the plot. Edit the 
number to change the value. 

Histogram plot Boolean: Display plot as a histogram? Choose True or False. 
Default = False

Points to average Number: Number of points to average when drawing the plot. 
Edit to change the value. Default = 1

Polar plot Boolean: Display plot as a polar plot? Choose True or False. 
Default = False

Fill plot Boolean: Fill between plot lines? Choose True or False. 
Default = False

Fill level Number: Level at which to begin the plot fill. Edit the number 
to change the value. Default = 0

Fill color Color: Color for the plot fill. Fill transparency must be less 
than 100%. Click to choose from the default color palette, or 
specify RGB values. Default = [128, 128, 128]

Fill transparency Number: Transparency of the plot fill from 0% to 100%. Move 
the slider to change the value. Default = 0

Symbol Symbol: Symbol to appear at regular intervals on the plot line. 
Choose a symbol from the list. Default = No symbol

Symbol size Number: Factor from 0 - 1 determining the size of the selected 
symbol. Move slider to change the size. Default = 0.2

Use default color Boolean: Activate Symbol color property. Choose True or 
False. Default = False

Symbol color Color: Color for the selected symbol. Click to choose from the 
default color palette, or specify RGB values. Default = 
[0,0,0] (black)

Symbol thickness Number: Line thickness from 1 - 9.9 for the selected symbol. 
Move slider to change the thickness. Default = 1.

Property Control Type: Values

Table D-37: Plot Properties (Continued)
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Symbol 
increment

Number: Interval at which symbols will be displayed on the 
plot line. Influenced by Number of points to average (listed 
previously). Edit to change the value. Default = 1

Property Control Type: Values

Table D-37: Plot Properties (Continued)
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Plot 3D

These properties control three-dimensional plot object visualizations. For each 
property, the type of control and the values that can be assigned are listed. For a 

Figure D-22: Visualization Browser with 3D Plot Properties Displayed
iTool User’s Guide Visualization Type Properties
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description of how a particular control is used, refer to Appendix B, “Property 
Controls”.

Property Control Type: Values

Vertex color table User Defined: By selecting Edit Color → Table Edit access 
the color table to manipulate plot color values.

XY Shadow Boolean: Show XY shadow? Choose Hide or Show. 

Default = Hide

YZ Shadow Boolean: Show YZ shadow? Choose Hide or Show. 

Default = Hide

XZ Shadow Boolean: Show XZ shadow? Choose Hide or Show. 

Default = Hide

Table D-38: Plot 3D Properties
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Color Color: Color for the plot line. Click to choose from the default 
color palette, or specify RGB values. Default = [0,0,0] 
(black)

Line style Line Style: Style for the plot line. Select a style from the list. 
Default = (solid line)

Thickness Line Thickness: Thickness for the plot line. Select a thickness 
from the list. Default = 1

Shading String List: Shading method. Select a method from the list. 
Choose between these values:

• Flat: Flat shading

• Gouraud: Gouraud shading

Default = Flat

Symbol Symbol: Symbol to appear at regular intervals on the plot line. 
Choose a symbol from the list. Default = No symbol

Symbol size Number: Factor from 0 - 1 determining the size of the selected 
symbol. Move slider to change the size. Default = 0.2

Use default color Boolean: Activate Symbol color property. Choose True or 
False. Default = False

Symbol color Color: Color for the selected symbol. Click to choose from the 
default color palette, or specify RGB values. Default = 
[0,0,0] (black)

Symbol thickness Number: Line thickness from 1 - 9.9 for the selected symbol. 
Move slider to change the thickness. Default = 1.

Symbol 
increment

Number: Interval at which symbols will be displayed on the 
plot line. Influenced by Number of points to average (above). 
Edit to change the value. Default = 1

Property Control Type: Values

Table D-38: Plot 3D Properties (Continued)
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Surface

These properties control surface object visualizations. For each property, the type of 
control and the values that can be assigned are listed. For a description of how a 
particular control is used, refer to Appendix B, “Property Controls”.

Figure D-23: Visualization Browser with Surface Properties Displayed

Property Control Type: Values

Color Color: Color of the surface visualization. Click to choose from 
the default color palette, or specify RGB values. Default = 
[255,184,0] (gold)

Use color on 
bottom

Boolean: Display a color for the bottom of the surface. Choose 
True or False. 

Default = False

Table D-39: Surface Properties
Visualization Type Properties iTool User’s Guide
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Image palette User Defined: By selecting Edit Color → Table Edit access 
the color table to manipulate surface color values.

Bottom color Color: Color to be used for the bottom of the surface. Click to 
choose from the default color palette, or specify RGB values. 
Default = [255,255,255] (white)

Minimum value Number: Minimum Z-Axis value of the surface plot. Edit the 
number to change the value.

Maximum value Number: Maximum Z-Axis value of the surface plot. Edit the 
number to change the value.

Surface style String List: Style used for rendering the surface. Select a style 
from the list. Choose from these values: 

• Points: Data points in the surface are rendered as points.

• Wire mesh: Data points in the surface are connected with 
lines, forming a mesh.

• Filled: Data points in the surface are connected with filled 
quadrangles or triangles, forming a solid surface.

• Ruled XZ: Data points in the surface are connected with 
horizontal (Z-direction) lines, forming a grid.

• Ruled YZ: Data points in the surface are connected with 
vertical (Y-direction) lines, forming a grid.

• Lego: Stacked histogram-style plot in which each data 
value is rendered as an outline box covering the XY extent 
of the cell and with a height proportional to the Z value.

• Lego filled: Same as Lego, but the boxes are filled.

Default = Filled

Property Control Type: Values

Table D-39: Surface Properties (Continued)
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Fill shading String List: Method used for shading the surface polygons. 
Select a shading method from the list. Choose from these 
values:

• Flat: Shades polygons with a uniform fill.

• Gouraud: Interpolates intensities from each vertex along 
each edge. Then, when the polygons are converted, 
interpolates the shading along each scan line from the edge 
intensities. Results in a more natural appearance.

Default = Flat

Draw method String List: Method used for drawing the surface. Select a 
method from the list. Choose from these values:

• Quads: Draw a surface composed of quadrangles.

• Triangles: Draw a surface composed of triangles.

Default = Quads

Line style Line Style: Style of lines used for constructing the surface. 
Select a style from the list. Default = (solid 
line)

Line thickness Line Thickness: Thickness of lines used for constructing the 
surface. Select a thickness from the list. Default = 1

Remove hidden 
lines

Boolean: Hide lines that show through the surface mesh or 
grid. Choose True or False. 

Default = False

Show skirt Boolean: Display the edges of the surface as a filled skirt? 
Choose True or False. 

Default = False

Skirt bottom 
height

Number: Set bottom of displayed skirt to this height. Edit the 
number to change the value. 

Default = 0

Property Control Type: Values

Table D-39: Surface Properties (Continued)
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Texture 
interpolation

String List: Method used for interpolating selected texture 
map. Select a method from the list. Choose from these values:

• Nearest Neighbor: Assign the value of the nearest pixel to 
the pixel in the output image. Fastest method, but may 
cause jagged edges.

• Bilinear: Create a weighted average based on the nearness 
and brightness of the closest four pixels, and assign that 
value to the pixel in the output image. 

Default = Nearest Neighbor

Texture hires String List: Method used for tiling the selected high-resolution 
texture map. Select a tiling method from the list. Choose from 
these values:

• No tiling: Do not use tiling

• LOD tiling: Use level of detail tiling

• Tiling: Use tiling

Default = No tiling

Skip zero opacity Boolean: Skip zero opacity for surface? Choose True or False. 

Default = True

Vertex Color 
Scale

User Defined: Select vertex color scale bottom/top.

Texture Map 
Scale

User Defined: Select texture map scale bottom/top.

Property Control Type: Values

Table D-39: Surface Properties (Continued)
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Contour

These properties control contour object visualizations. For each property, the type of 
control and the values that can be assigned are listed. For a description of how a 

Figure D-24: Visualization Browser with Contour Properties Displayed
Visualization Type Properties iTool User’s Guide
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particular control is used, refer to Appendix B, “Property Controls”.

Property Control Type: Values

Contour level 
properties

User Defined: Click to edit individual or all contour level 
properties. Click  and Edit... to display the Contour Levels 
window.

Use palette color Boolean: Use palette color? Choose True or False. Default = 
False

Planar Z Value Number: Z value of plane on to which to project contours. Edit 
the number to change the value. Default = 0

Number of levels Number: Number of contour levels to display. Edit the number 
to change the value. Default = 5

Projection String List: Method of projection. Select a method from the 
list. Choose from these values:

• Three-D: Project in three dimensions

• Planar: Project onto a plane

Default = Planar

Fill contours Boolean: Fill space between contours? Choose True or False. 
Default = False

Table D-40: Contour Properties
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Shading String List: Shading method. Select a method from the list. 
Choose between these values:

• Flat: Flat shading

• Gouraud: Gouraud shading

Default = Flat

Minimum value Number: Minimum value to display in the contour. Edit 
number to change value. No default value.

Maximum value Number: Maximum value to display in the contour.Edit number 
to change value. No default value.

Downhill ticks Boolean: Show downhill ticks? Choose Hide or Show. Default 
= Hide

Downhill tick 
interval

Number: Distance between downhill tick marks. Edit number 
to change value. Default = 0.2

Downhill tick 
length

Number: Length of downhill tick marks. Edit number to change 
value. Default = 0.2

Figure D-25: Contour Levels Window

Property Control Type: Values

Table D-40: Contour Properties (Continued)
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The Contour Levels window contains properties that control the contour levels.

Property Control Type: Values

Value Number: Value of the contour level. Edit the number to change 
the value. Default comes from contour data.

Color Color: Color for the contour level. Click to choose from the 
default color palette, or specify RGB values. Default = 
[0,0,0] (black)

Line style Line Style: Style for the contour level. Select a style from the 
list. Default = (solid line)

Line thickness Line Thickness: Thickness for the contour level. Select a 
thickness from the list. Default = 1

Label String List: Choose the kind of label to use for each contour 
level. Choose from these values:

• None

• Value

• Text

• Symbol

Label interval Number: Distance between labels on the contour level. Edit 
number to change value. Default = 0.4

No label gaps Boolean: Interrupt the contour level for the label. Choose True 
or False. Default = False

Use label color Boolean: Display a color for the contour level’s label. Choose 
True or False. Default = False

Label color Color: Color for the contour level label. Click to choose from 
the default color palette, or specify RGB values. Default = 
[0,0,0] (black)

Symbol label Symbol: Symbol to appear at regular intervals on the contour 
level. Choose a symbol from the list. Default = No symbol

Symbol size Number: Factor from 0 - 1 determining the size of the selected 
symbol. Move slider to change the size. Default = 0.2

Table D-41: Contour Levels Properties
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Text label String: Text that labels the contour object in the legend. Edit 
string to change value. Default = none

Tick format code String: Text that defines the tick format. Edit string to change 
format. You can edit this value only if Tick Format is set to 
Use Tick Format Code. Default = none

Tick format String List: Choose a format code or time interval to use for 
each tick interval. Choose from these values:

• None

• Use Tick Format Code

• Filled Fixed Width Integer

• Freeform Integer or Float

• Float with 2 or 4 decimal places

• Exponential with 2 or 4 decimal places

• Date (13 formats)

• Time (11 formats)

Default = None

Text font String List: Font used for label text. Select a font from the list. 
Choose from these values:

• Helvetica

• Courier

• Times

• Symbol

• Hershey

Default = Helvetica

Property Control Type: Values

Table D-41: Contour Levels Properties (Continued)
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Text style String List: Style used for label text. Select a style from the list. 
Choose from these values:

• Normal

• Bold

• Italic

• Bold italic

Default = Normal

Text font size Number: Font size in points for the label text. Edit the number 
to change the size. Default = 9

Property Control Type: Values

Table D-41: Contour Levels Properties (Continued)
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Volume

These properties control volume object visualizations. For each property, the type of 
control and the values that can be assigned are listed. For a description of how a 
particular control is used, refer to Appendix B, “Property Controls”.

Figure D-26: Visualization Browser with Volume Properties Displayed
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Property Control Type: Values

Display Scale Set the display scale for the selected volume.

Select Display Scale Bottom/Top → Edit 

Table D-42: Volume Properties
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Color & Opacity 
Table 0

Color: By selecting Edit Color → Table Edit access the color 
table to manipulate plot color values

Note - To edit the opacity only in the editor, uncheck the R, G, 
and B boxes in both the Modify and Display rows. Edit the 
remaining line by clicking on and dragging the line in the 
window. Click OK when finished.

Color & Opacity 
Table 1

Color: By selecting Edit Color → Table Edit access the color 
table to manipulate plot color values.

Property Control Type: Values

Table D-42: Volume Properties (Continued)
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Subvolume String: Edit SubVolume Extents.

Auto render Boolean: Automatically render the volume each time the 
window is redrawn? Choose True or False. Default = False

Quality String List: Quality of the volume. Choose between these 
values:

• Low (texture maps)

• High (volume)

Default = Low

Boundary String List: Boundary around the volume. Choose between 
these values:

• Off

• Wire frame

• Solid walls

Default = Solid walls

Property Control Type: Values

Table D-42: Volume Properties (Continued)
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Boundary 
transparency

Number: Percent transparency of the boundary around the 
volume (wire frame or solid walls). Move slider to change 
value.

Default = 90

Render step X Number: Stepping factor through the voxel matrix in the x 
direction.

Default = 1

Render step Y Number: Stepping factor through the voxel matrix in the y 
direction.

Default = 1

Render step Z Number: Stepping factor through the voxel matrix in the z 
direction.

Default = 1

Extents color Color: Color for the volume. Click to choose from the default 
color palette, or specify RGB values. 

Default = [0,0,0] (black)

Ambient color String: Choose from default color palette or specify RGB 
values. 

Default = [255, 255, 255] (white)

Composite 
function

String: Choose composite function.

Default = Alpha Blending

Acceleration hints Boolean: Use acceleration hints? Choose Enable or Disable. 
Default = Disable

Interpolation String List: Set interpolation type. Choose between these 
values:

• Nearest neighbor

• Trilinear

Default = Nearest neighbor

Use lighting Boolean: Use lighting? Choose True or False. Default = False

Property Control Type: Values

Table D-42: Volume Properties (Continued)
Visualization Type Properties iTool User’s Guide



Appendix D: Visualization Properties 431
Voxel gradient Color: Color of the volume. Click to choose from the default 
color palette, or specify RGB values. 

Default = [0,0,0] (black)

Update Z Buffer Boolean: Update Z Buffer? Choose True or False. 

Default = True

Skip zero opacity Boolean: Skip zero opacity? Choose True or False. 

Default = True

Property Control Type: Values

Table D-42: Volume Properties (Continued)
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Isosurface

These properties control isosurface object visualizations. For each property, the type 
of control and the values that can be assigned are listed. For a description of how a 
particular control is used, refer to Appendix B, “Property Controls”.

Figure D-27: Visualization Browser with Isosurface Properties Displayed

Property Control Type: Values

Color Color: Color to be used for the isosurface lines in this 
visualization. Click to choose from the default color palette, or 
specify RGB values. 

Default = [0,0,0] (black)

Linestyle Line Style: Style of the isosurface lines. Select a line style 
from the list. 

Default = No line

Thickness Line Thickness: Thickness of the isosurface lines in points. 
Select a thickness from the list. 

Default = 1

Table D-43: Isosurface Properties
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Fill background Boolean: Fill background? Choose True or False.

Default = True

Fill color Color: Color to fill. Click to choose from the default color 
palette, or specify RGB values.

Default = [255,0,0] (red)

Transparency Number: Level of transparency.

Default = 0

Isovalue String: Edit isovalue.

Source color String List: Choose from the following:

• Isovalue selected (Volume color table)

• User selected (Fill Color Property)

Default = Isovalue selected (Volume color table)

Property Control Type: Values

Table D-43: Isosurface Properties
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Interval Volume

These properties control interval volume object visualizations. For each property, the 
type of control and the values that can be assigned are listed. For a description of how 
a particular control is used, refer to Appendix B, “Property Controls”.

Figure D-28: Visualization Browser with Interval Volume Properties Displayed

Property Control Type: Values

Color Color: Color to be used for the interval volume lines in this 
visualization. Click to choose from the default color palette, or 
specify RGB values.

Default = [0,0,0] (black)

Linestyle Line Style: Style of the interval volume lines. Select a line 
style from the list. 

Default = No line

Thickness Line Thickness: Thickness of the interval volume lines in 
points. Select a thickness from the list. 

Default = 1

Table D-44: Interval Volume Container Properties
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Fill background Boolean: Fill background? Choose True or False.

Default = True

Fill color Color: Color to fill. Click to choose from the default color 
palette, or specify RGB values.

Default = [255,0,0] (red)

Transparency Number: Level of transparency.

Default = 0

Isovalues String: Edit isovalue.

Source Color String List: Set source color. Choose from the following:

• Isovalue selected (Volume color table)

• User selected (Fill Color Property)

Default = Isovalue selected (Volume color table)

Property Control Type: Values

Table D-44: Interval Volume Container Properties
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Image Plane

These properties control image plane object visualizations. For each property, the 
type of control and the values that can be assigned are listed. For a description of how 
a particular control is used, refer to Appendix B, “Property Controls”.

Figure D-29: Visualization Browser with Image Plane Properties Displayed

Property Control Type: Values

Opacity Control String List: Set opacity. Choose from the following:

• Use Opacity Table

• Opaque

• Opacity Value

Default = Use Opacity Table

Opacity Value Number: Factor from 0 - 100 determining the level of opacity. 
Move slider to change the size.

Default = 50

Table D-45: Image Plane Container Properties
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Orientation Set orientation.

Default = X

Color Color: Color to be used for the image plane lines in this 
visualization. Click to choose from the default color palette, or 
specify RGB values.

Default = [255, 255, 255] (white)

Bottom color Color: Color to be used for the image plane bottom color in 
this visualization. Click to choose from the default color 
palette, or specify RGB values.

Default = [255, 255, 255] (white)

Linestyle Line Style: Style of lines used for constructing the surface. 
Select a style from the list. 

Default = (solid line)

Thickness Line Thickness: Thickness of lines used for constructing the 
surface. Select a thickness from the list. 

Default = 1

Style Style: Style of lines used. Choose from the following:

• Points

• Lines

• Filled

Default = Filled

Depth offset Number: Set depth offset value. Enter value. 

Default = 1

Remove hidden Boolean: Remove hidden? Choose True or False.

Default = False

Skip zero opacity Boolean: Skip zero opacity? Choose True or False.

Default = True

Property Control Type: Values

Table D-45: Image Plane Container Properties
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Polygon rejection String List: Set polygon rejection color. Choose from the 
following:

• None

• Normals point away

• Normals point toward

Default = None

Shading String List: Shading method. Select a method from the list. 
Choose between these values:

• Flat: Flat shading

• Gouraud: Gouraud shading

Default = Flat

Texture 
interpolation

String List: Set texture interpolation type. Choose between 
these values:

• Nearest neighbor

• Bilinear

Default = Nearest neighbor

Property Control Type: Values

Table D-45: Image Plane Container Properties
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Colorbar

These properties control colorbar object visualizations. For each property, the type of 
control and the values that can be assigned are listed. For a description of how a 
particular control is used, refer to Appendix B, “Property Controls”.

Figure D-30: Visualization Browser with Colorbar Properties Displayed

Property Control Type: Values

Border Boolean: Set border on or off. Choose True or False.

Default = False

Orientation Boolean: Set orientation of colorbar. Choose Horizontal or 
Vertical.

Default = Horizontal

Table D-46: Colorbar Container Properties
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Color Color: Color to be used for the colorbar in this visualization. 
Click to choose from the default color palette, or specify RGB 
values. Default = [0,0,0] (black)

Line style Line Style: Style of the colorbar lines. Select a line style from 
the list. Default = (solid line)

Line thickness Line Thickness: Thickness of the colorbar lines in points. 
Select a thickness from the list. Default = 1

Major ticks Number: Set number of major tick marks. Enter value. 

Default = 3

Minor ticks Number: Set number of minor tick marks. Enter value. 

Default = 0

Major tick length Number: Factor from 0 - 1 determining major tick length. 
Move slider to change the size. 

Default = .05

Minor tick length Number: Factor from 0 - 1 determining minor tick length. 
Move slider to change the size.

Default = 1

Tick interval Number: Set tick interval. Enter value. 

Default = 0

Tick layout String List: Set tick layout type. Choose between these values:

• Axis plus labels

• Labels only

• Box style

Default = Axis plus labels

Tick direction String List: Set tick direction. Choose between these values:

• Right/Above

• Left/Below

Default = Right/Above

Property Control Type: Values

Table D-46: Colorbar Container Properties
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Text show Boolean: Set text to show or not show. Choose True or False.

Default = True (show)

Text position String List: Set text position. Choose between these values:

• Below/left

• Above/right

Default = Below/left

Tick format String List: Choose a format code or time interval to use for 
each tick interval. Choose from these values:

• None

• Use Tick Format Code

• Filled Fixed Width Integer

• Freeform Integer or Float

• Float with 2 or 4 decimal places

• Exponential with 2 or 4 decimal places

• Date (13 formats)

• Time (11 formats)

Default = None

Title Title: Enter title for colorbar.

Default = RGB Table 0

Text color Color: Color to be used for the legend text. Click to choose 
from the default color palette, or specify RGB values. Default 
= [0,0,0] (black)

Property Control Type: Values

Table D-46: Colorbar Container Properties
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Text font String List: Font used for legend text. Select a font from the 
list. Choose from these values:

• Helvetica

• Courier

• Times

• Symbol

• Hershey

Default = Helvetica

Text style String List: Style used for legend text. Select a style from the 
list. Choose from these values:

• Normal

• Bold

• Italic

• Bold italic

Default = Normal

Text font size Number: Font size in points for the legend text. Edit the 
number to change the size. Default = 12

Property Control Type: Values

Table D-46: Colorbar Container Properties
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Histogram

These properties control histogram object visualizations. For each property, the type 
of control and the values that can be assigned are listed. For a description of how a 

Figure D-31: Visualization Browser with Histogram Properties Displayed
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particular control is used, refer to Appendix B, “Property Controls”.

Property Control Type: Values

Vertex Colors 
Color Table

Color: By selecting Edit Color → Table Edit access the 
color table to manipulate plot color values

Histogram binsize Number: Set histogram binsize. 

Default = 1

Color Color: Color to be used for the plot lines. RGB values are 
assigned or you may edit your color. 

Default = varies

Line style Line Style: Style of the colorbar lines. Select a line style from 
the list. 

Default = (solid line)

Table D-47: Histogram Container Properties
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Thickness Line Thickness: Thickness of the colorbar lines in points. 
Select a thickness from the list. 

Default = 1

Minimum value Number: Minimum histogram value. Enter a number. 

Default = varies

Maximum value Number: Maximum histogram value. Enter a number. 

Default = varies

Histogram plot Boolean: Set histogram to show or not show. Choose True or 
False.

Default = True (show)

Number of points 
to average

Number: Number of points in plot to be averaged. Enter a 
number. 

Default = 1

Polar plot Boolean: Set histogram to show or not show as a polar plot. 
Choose True or False.

Default = False (hide)

Fill plot Boolean: Set histogram to show or not show as a filled plot. 
Choose True or False.

Default = False (hide)

Fill level Number: Level to fill if fill plot is selected. Enter a number. 

Default = varies

Fill color Color: Color to be used for fill plot if selected. 

Default = [128, 128, 128] (grey)

Fill transparency Number: Value of transparency if fill plot is selected. Enter a 
number. 

Default = 0

Property Control Type: Values

Table D-47: Histogram Container Properties
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Symbol String List: Font used for legend text. Select a font from the 
list. Choose from the list of symbols.

Default = No symbol

Symbol size Number: Value for symbol size in points if fill symbol is 
selected. Enter a number. 

Default = 0.2

Use default color Boolean: Set to use default color for symbols. Choose True or 
False.

Default = True (use default color)

Symbol color Color: Color to be used for symbols if default color is set to 
False. Enter a value.

Default = varies

Symbol thickness Number: Value for symbol thickness in points if symbol is 
selected. Enter a number.

Default = 1

Symbol 
increment

Number: Value for symbol increments if fill symbol is 
selected. Enter a number. 

Default = 1

Property Control Type: Values

Table D-47: Histogram Container Properties
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Axes

These properties control axis object visualizations. For each property, the type of 
control and the values that can be assigned are listed. For a description of how a 
particular control is used, refer to Appendix B, “Property Controls”.

Figure D-32: Visualization Browser with Axis Properties Displayed
iTool User’s Guide Visualization Type Properties



448 Appendix D: Visualization Properties
The following table contains the properties that control the container for the 
visualization axes.

Property Control Type: Values

Style String List: Select display style for axes. Choose from these 
values:

• None: Do not display axes.

• At Dataspace Minimum: Display 2 axes for 2-D 
visualization, 3 axes for 3-D visualization.

• Box Axes: Display 4 axes for 2-D visualization, 12 axes 
for 3-D visualization.

• Crosshairs: Display crosshair style axes.

Default = At Dataspace Minimum

Color Color: Color to be used for the axis lines in this visualization. 
Click to choose from the default color palette, or specify RGB 
values. Default = [0,0,0] (black)

Line style Line Style: Style of the axis tick lines. Select a line style from 
the list. Default = (solid line)

Line thickness Line Thickness: Thickness of the axis tick lines. Select a 
thickness from the list. Default = 1

Major ticks Number: Set number of major tick marks. Enter value. 

Default = 0

Minor ticks Number: Set number of minor tick marks. Enter value. 

Default = 0

Major Tick 
Length

Number: Normalized length of major tick marks for all axes 
from 0 (no ticks) to 1 (major tick marks span the 
visualization). Move the slider to change the value. Default = 
0.05.

Table D-48: Axes Container Properties
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Minor tick length Number: Relative length of minor tick marks for all axes from 
-1 (minor tick marks extend the length of major tick marks on 
left side of axes) to 1 (minor tick marks extend same length as 
major tick marks on right side of axes). Move the slider to 
change the value. Default = 0.5 (minor tick marks extend 
one-half the length of major tick marks on right side of axes).

Tick interval Number: Interval between ticks. Edit the number to change the 
value. Default = 0

Tick layout String List: Select layout style for major and minor tick 
visualization on all axes. Choose from these values:

• Axis plus labels: Display tick labels and marks.

• Labels only: Display tick labels only (no tick marks).

• Box style: Display tick labels and marks, with labels 
enclosed in boxes.

Default = Axis plus labels

Tick direction String List: Select a direction for tick marks. Choose from 
these values:

• Right/Above: Place tick marks to the right of or above the 
axis line.

• Left/Below: Place text to the left of or below the axis line.

Default = Right/Above

Text show Boolean: Set text to show or not show. Choose True or False.

Default = True (show)

Text position String List: Select a position for tick and label text. Choose 
from these values:

• Below/left: Place text below or to the left of the axis line.

• Above/right: Place text above or to the right of the axis 
line.

Default = Below/left

Property Control Type: Values

Table D-48: Axes Container Properties
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Tick format String List: Choose a format code or time interval to use for 
each tick interval. Choose from these values:

• None

• Use Tick Format Code

• Filled Fixed Width Integer

• Freeform Integer or Float

• Float with 2 or 4 decimal places

• Exponential with 2 or 4 decimal places

• Date (13 formats)

• Time (11 formats)

Default = None

Title String: Title to apply to all axes for this visualization. Enter 
title text for the axes. No default value.

Text color Color: Color to be used for the text. Click to choose from the 
default color palette, or specify RGB values. 

Default = [0,0,0] (black)

Text font String List: Font used for tick and label text. Select a font from 
the list. Choose from these values:

• Helvetica

• Courier

• Times

• Symbol

• Hershey

Default = Helvetica

Property Control Type: Values

Table D-48: Axes Container Properties
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This table contains the properties that control axis visualization X, Y, or (for three-
dimensional visualizations) Z. For each property, the type of control and the values 
that can be assigned are listed. For a description of how a particular control is used, 
refer to Appendix B, “Property Controls”.

Text style String List: Style used for tick and label text. Select a style 
from the list. Choose from these values:

• Normal

• Bold

• Italic

• Bold italic

Default = Normal

Text font size Number: Font size in points for the tick and label text. Edit the 
number to change the size. Default = 12

Property Control Type: Values

Color Color: Color to be used for the axis line. Click to choose from 
the default color palette, or specify RGB values. Default = 
[0,0,0] (black)

Line style Line Style: Style of the axis tick lines. Select a line style from 
the list. Default = (solid line)

Line thickness Line Thickness: Thickness of the axis tick lines in points. 
Select a thickness from the list. Default = 1

Major ticks Number: Number of major ticks marks to display along the 
axis. Edit the number to change the value. Default = 5

Minor ticks Number: Number of minor ticks to display between major 
ticks. Edit the number to change the value. Default = 3

Table D-49: Property Settings for Individual Axes

Property Control Type: Values

Table D-48: Axes Container Properties
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Major tick length Number: Normalized length of major tick marks for this axis 
from 0 (no ticks) to 1 (major tick marks span the 
visualization). Move the slider to change the value. Default = 
0.05

Minor tick length Number: Relative length of minor tick marks for this axis from 
-1 (minor tick marks extend the length of major tick marks on 
left side of axis) to 1 (minor tick marks extend same length as 
major tick marks on right side of axis). Move the slider to 
change the value. Default = 0.5 (Minor tick marks extend 
one-half the length of major tick marks on right side of axis).

Tick interval Number: Interval between major tick marks. Edit the number 
to change the value. Default = 0 (use the default interval for 
the specified range)

Tick layout String List: Select layout style for major and minor tick 
visualization. Choose from these values:

• Axis plus labels: Display tick labels and marks.

• Labels only: Display tick labels only (no tick marks).

• Box style: Display tick labels and marks, with labels 
enclosed in boxes.

Default = Axis plus labels

Tick direction String List: Select a direction for tick marks. Choose from 
these values:

• Right/Above: Place tick marks to the right of or above the 
axis line.

• Left/Below: Place text to the left of or below the axis line.

Default = Right/Above

Text show Boolean: Show tick and label text? Choose True or False. 
Default = True.

Property Control Type: Values

Table D-49: Property Settings for Individual Axes (Continued)
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Text position String List: Select a position for tick and label text. Choose 
from these values:

• Below/left: Place text below or to the left of the axis line.

• Above/right: Place text above or to the right of the axis 
line.

Default = Below/left

Tick format String List: Choose a format code or time interval to use for 
each tick interval. Choose from these:

• None

• Use Tick Format Code

• Filled Fixed Width Integer

• Freeform Integer or Float

• Float with 2 or 4 decimal places

• Exponential with 2 or 4 decimal places

• Date (13 formats)

• Time (11 formats)

Default = None

Title String: Title to apply to this axis. Enter title text for the axes. 
No default value.

Text color Color: Color to be used for the text. Click to choose from the 
default color palette, or specify RGB values. Default = 
[0,0,0] (black) 

Property Control Type: Values

Table D-49: Property Settings for Individual Axes (Continued)
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Text font String List: Font used for tick and label text. Select a font from 
the list. Choose from these values:

• Helvetica

• Courier

• Times

• Symbol

• Hershey

Default = Helvetica

Text style String List: Style used for tick and label text. Select a style 
from the list. Choose from these values:

• Normal

• Bold

• Italic

• Bold italic

Default = Normal

Text font size Number: Font size in points for the tick and label text. Edit the 
number to change the size. Default = 12

Property Control Type: Values

Table D-49: Property Settings for Individual Axes (Continued)
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Lights

Lights properties control the lighting of the data space. These properties are available 
only for 3-D Surface and Volume visualizations. 

Three types of lights can be configured through the Lights properties: Ambient Light, 
Light 1 (from above), and Light 2 (from below). Each type of light has the same set of 
properties, as described in Table D-50.

Figure D-33: Visualization Browser with Light Properties Displayed
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For each property, the type of control and the values that can be assigned are listed. 
For a description of how a particular control is used, refer to Appendix B, “Property 
Controls”.

Property Control Type: Values

Type String List: Type of light source for this light. Select a type of 
light from the list. Choose from these options:

• Ambient: Universal light source with no direction or 
position. An ambient light illuminates every surface in the 
scene equally, which means that no edges are made visible 
by contrast. Ambient light controls the overall brightness 
and color of the scene.

• Positional: Supplies divergent light rays so that the edges 
of surfaces can be made visible by contrast. A positional 
light source can be located anywhere in the scene.

• Directional: Supplies parallel light rays from a light 
source located at an infinite distance from scene.

• Spotlight: Illuminates only a specific area defined by the 
light's position, direction, and the cone angle (angle the 
spotlight covers).

Default = Positional

Distance Number: Distance of the light source from the visualization 
from -1 (in front of the visualization) to 1 (behind the 
visualization). Move the slider to change the value. 
Default = -1 for Ambient Light and Light 1, 1 for Light 2

Intensity Number: Intensity of this light from 0 (no light) to 1 (bright 
light). Move the slider to change the value. Default = 0.5 for 
Ambient Light, 0.8 for Light 1 and Light 2

Color Color: Color of this light. Click to choose from the default 
color palette, or specify RGB values. 

Default = [255,255,255] (white) 

Table D-50: Property Settings for Lights
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Cone angle Number: Angle the spotlight covers from 0º to 180º. Active 
only when Spotlight type is selected. Move the slider to 
change the value. 

Default = 60

Focus attenuation Number: Floating-point value from 0 to 128 that attenuates the 
intensity of spotlights as the distance from the center of the 
cone of coverage increases. This factor is used as an exponent 
to the cosine of the angle between the direction of the spotlight 
and the direction from the light to the vertex being lighted. 
Active only when Spotlight type is selected. Move the slider to 
change the value. 

Default = 0

Property Control Type: Values

Table D-50: Property Settings for Lights (Continued)
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Polygonal ROI

These properties control polygonal ROI object visualizations. For each property, the 
type of control and the values that can be assigned are listed. For a description of how 
a particular control is used, refer to Appendix B, “Property Controls”

Figure D-34: Visualization Browser with Polygon ROI Properties Displayed

Property Control Type: Values

Color Color: Color to be used for the line. Click to choose from the 
default color palette, or specify RGB values. Default = 
[0,0,0] (black)

Linestyle Line Style: Style of the polygon lines. Select a line style from 
the list. Default = (solid line)

Thickness Line Thickness: Thickness of the polygon lines in points. 
Select a thickness from the list. Default = 1

Fill background Boolean: Fill background? Choose True or False.

Default = True

Table D-51: Property Settings for Polygonal ROI
Visualization Type Properties iTool User’s Guide
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Fill color Color: Color to fill. Click to choose from the default color 
palette, or specify RGB values.

Default = [255,255, 255] (white)

Transparency Number: Level of transparency.

Default = 0

Property Control Type: Values

Table D-51: Property Settings for Polygonal ROI
iTool User’s Guide Visualization Type Properties
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IDL Graphics Objects

You can import an IDL graphics object into an iTool and display it directly by 
selecting the “IDL Graphics Object” visualization type. The properties available will 
depend on the type of graphics object. See the properties listing for the specific 
graphics object in the IDL Reference Guide for details.

Note
The behavior of IDL graphics objects imported into an iTool may not be the same as 
that of the corresponding iTool visualization. While importing an existing graphics 
object into an iTool will often work, you will generally obtain better results using an 
iTool visualization type.

Tip
In order to display properties for a generic IDL graphics object in the iTool property 
sheet interface, the graphics object must have been created with the 
REGISTER_PROPERTIES keyword set. If no properties are registered, only the 
three standard iTool properties (Name, Description, and Show) will be present, as 
displayed in the previous figure.

Figure D-35: Visualization Browser with 
IDL Graphics Object Properties Displayed
Visualization Type Properties iTool User’s Guide
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Map Grid

These properties control map grid object visualizations. For each property, the type of 
control and the values that can be assigned are listed. For a description of how a 
particular control is used, refer to Appendix B, “Property Controls”.

Figure D-36: Visualization Browser with 
Map Grid Object Properties Displayed

Name Description

Longitude minimum (deg) Number: Minimum longitude, in degrees, to include in the 
grid

Longitude maximum (deg) Number: Maximum longitude, in degrees, to include in the 
grid

Latitude minimum (deg) Number: Minimum latitude, in degrees, to include in the 
grid

Latitude maximum (deg) Number: Maximum latitude, in degrees, to include in the 
grid

Longitude spacing Number: Longitude grid spacing, in degrees

Table D-52: Property Settings for Map Grid
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Latitude spacing Number: Latitude grid spacing, in degrees

Longitude lines User Defined: Click to edit individual or all longitude line 
properties. Click  and Edit... to display the Map Grid 
Lines dialog.

Latitude lines User Defined: Click to edit individual or all latitude line 
properties. Click  and Edit... to display the Map Grid 
Lines dialog.

Color Color: Color for the grid lines. Click to choose from the 
default color palette, or specify RGB values. Default = 
[0,0,0] (black)

Name Description

Table D-52: Property Settings for Map Grid
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Thickness Line Thickness: Thickness for the grid lines. Select a 
thickness from the list. Default = 1

Transparency Number: Transparency of the grid lines from 0% to 100%. 
Move the slider to change the value. Default = 0

Label Boolean: Use labels on the grid lines. Choose True or 
False. Default = True

Label position Number: Normalized label position. Default = 0.5

Use label color Boolean: Use default color instead of Label color. Choose 
True or False. Default = False

Label color Color: Color for the grid label. Click to choose from the 
default color palette, or specify RGB values. Default = 
[0,0,0] (black)

Label fill background String List: Choose the kind of fill background for the 
label. Choose from these values:

• None

• View color

• Fill color

Label fill color Color: Color for the label background’s fill. Click to 
choose from the default color palette, or specify RGB 
values. Default = [255, 255, 255] (white)

Text font String List: Font used for label text. Select a font from the 
list. Choose from these values:

• Helvetica

• Courier

• Times

• Symbol

• Hershey

Default = Helvetica

Name Description

Table D-52: Property Settings for Map Grid
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The Map Grid Lines dialog displays a property sheet for the longitude or latitude 
lines, depending on which set you want to edit. This sheet includes the same 
properties as the overall Map Grid object, from Color to Text font size.

Text style String List: Style used for label text. Select a style from the 
list. Choose from these values:

• Normal

• Bold

• Italic

• Bold italic

Default = Normal

Text font size Number: Font size in points for the label text. Edit the 
number to change the size. Default = 12

Name Description

Table D-52: Property Settings for Map Grid
Visualization Type Properties iTool User’s Guide
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ShapePolygon

These properties control ShapePolygon visualizations. For each property, the type of 
control and the values that can be assigned are listed. For a description of how a 
particular control is used, refer to Appendix B, “Property Controls”.

Figure D-37: Visualization Browser with
ShapePolygon Properties Displayed

Name Description

Color Color: Color for the ShapePolygon line. Click to choose 
from the default color palette, or specify RGB values. 
Default = [0,0,0] (black)

Line style Line Style: Style for the ShapePolygon line. Select a style 
from the list. Default = (solid line)

Thickness Line Thickness: Thickness for the ShapePolygon line. 
Select a thickness from the list. Default = 1

Fill background Boolean: Fill background? Choose True or False.

Default = False

Table D-53: Property Settings for ShapePolygon
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Fill color Color: Color for the ShapePolygon fill. Click to choose 
from the default color palette, or specify RGB values. 
Default = [255, 255, 255] (white)

Transparency Number: Transparency of the ShapePolygon fill from 0% 
to 100%. Move the slider to change the value. Default = 0

Name Description

Table D-53: Property Settings for ShapePolygon
Visualization Type Properties iTool User’s Guide
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ShapePolyline

These properties control ShapePolyline visualizations. For each property, the type of 
control and the values that can be assigned are listed. For a description of how a 
particular control is used, refer to Appendix B, “Property Controls”.

Figure D-38: Visualization Browser with
ShapePolyline Properties Displayed

Name Description

Transparency Number: Transparency of the ShapePolyline from 0% to 
100%. Move the slider to change the value. Default = 0

Color Color: Color for the ShapePolyline. Click to choose from 
the default color palette, or specify RGB values. Default = 
[0,0,0] (black)

Line style Line Style: Style for the ShapePolyline. Select a style from 
the list. Default = (solid line)

Thickness Line Thickness: Thickness for the ShapePolyline. Select a 
thickness from the list. Default = 1

Table D-54: Property Settings for ShapePolyline
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ShapePoint

These properties control ShapePoint visualizations. For each property, the type of 
control and the values that can be assigned are listed. For a description of how a 
particular control is used, refer to Appendix B, “Property Controls”.

Name Description

Symbol Symbol: Symbol to represent each ShapePoint. Choose a 
symbol from the list. Default = No symbol

Symbol size Number: Factor from 0 to 1 determining the size of the 
selected symbol. Move slider to change the size. Default = 
0.2

Symbol color Color: Color for the selected symbol. Click to choose from 
the default color palette, or specify RGB values. Default = 
[0,0,0] (black)

Symbol thickness Number: Symbol thickness from 1 to 9.9 for the selected 
symbol. Move slider to change the thickness. Default = 1.

Transparency Number: Transparency of the ShapePoint fill from 0% to 
100%. Move the slider to change the value. Default = 0

Table D-55: Property Settings for ShapePoint
Visualization Type Properties iTool User’s Guide
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2D Annotation Layer Properties

The following types of annotations can be added to iTool visualizations: Text, Line, 
Line Profile, Rectangle, Oval, Polygon, and Freehand annotations. The following 
table contains properties that control the Annotation layer. Subsequent tables describe 
the properties specific to each type of annotation.

Figure D-39: Visualization Browser with Annotation Properties Displayed

Property Control Type: Values

Background color Color: Color to be used for the Annotation Layer background. 
For background to display, Transparent property must be set to 
False. Click to choose from the default color palette, or 
specify RGB values. 

Default = [255,255,255] (white)

Transparent Boolean: Make the annotation layer transparent? Choose True 
or False. 

Default = True

Table D-56: Annotation Layer Properties
iTool User’s Guide 2D Annotation Layer Properties
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Text Annotation Properties

These properties control text annotation visualizations. For each property, the type of 
control and the values that can be assigned are listed. For a description of how a 
particular control is used, refer to Appendix B, “Property Controls”.

Property Control Type: Values

Text string String: Text that appears in the annotation. Edit to change the 
text, or to add formatting commands such as the following: 

• !C: Add new line.

• !U: Add superscript characters.

• !D: Add subscript characters.

• !N: Return to normal characters.

For a complete list of embedded text formatting commands, 
refer to “Embedded Formatting Commands” in Appendix H of 
the IDL Reference Guide. No default value.

Horizontal 
alignment

String List: Horizontal alignment of multiple lines within text 
box. Choose from these values:

• Left: Align text along the left border of the text box.

• Center: Align text in the center of the text box.

• Right: Align text along the right border of the text box.

Default = Left

Color Color: Color to be used for the text. Click to choose from the 
default color palette, or specify RGB values. 

Default = [0,0,0] (black)

Fill background Boolean: Fill the background of the text with the background 
color? Choose True or False. 

Default = False

Transparency Number: Transparency of the text annotation from 0% to 
100%. Move the slider to change the value. 

Default = 0

Table D-57: Text Annotation Properties
2D Annotation Layer Properties iTool User’s Guide
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Text font String List: Font used for text annotation. Select a font from 
the list. Choose from these values:

• Helvetica

• Courier

• Times

• Symbol

• Hershey

Default = Helvetica

Text style String List: Style used for text annotation. Select a style from 
the list. Choose from these values:

• Normal

• Bold

• Italic

• Bold italic

Default = Normal

Text font size Number: Font size in points for the text annotation. Edit the 
number to change the size. Default = 12

Property Control Type: Values

Table D-57: Text Annotation Properties (Continued)
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Line Annotation Properties

These properties control line annotation visualizations. For each property, the type of 
control and the values that can be assigned are listed. For a description of how a 
particular control is used, refer to Appendix B, “Property Controls”.

Property Control Type: Values

Color Color: Color to be used for the line. Click to choose from the 
default color palette, or specify RGB values. Default = 
[0,0,0] (black)

Linestyle Line Style: Style of the line annotation. Select a line style from 
the list. Default = (solid line)

Thickness Line Thickness: Thickness of the line annotation in points. 
Select a thickness from the list. Default = 1

Arrow style Arrow Style Selector: Select an arrow style from the list. 
Choose from these values:

Default =  (no arrow)

Arrowhead size Number: Size of arrowhead in normalized units. Arrow style 
must be selected for arrowhead to display. Move the slider to 
change the value. Default = 0.05

Table D-58: Line Annotation Properties
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Line Profile Annotation Properties

These properties control line profile annotation visualizations. For each property, the 
type of control and the values that can be assigned are listed. For a description of how 
a particular control is used, refer to Appendix B, “Property Controls”.

Property Control Type: Values

Vertex Colors 
Color Table

User Defined: By selecting Edit Color → Table Edit access 
the color table to manipulate plot color values

Color Color: Color to be used for the line. Click to choose from the 
default color palette, or specify RGB values. Default = 
[0,0,0] (black)

Line style Line Style: Style of the line profile annotation. Select a line 
style from the list. Default = (solid line)

Table D-59: Line Profile Annotation Properties
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Thickness Line Thickness: Thickness of the line profile annotation in 
points. Select a thickness from the list. Default = 1

Minimum value Number: Minimum value for line profile. Edit number to 
change value. No default value.

Maximum value Number: Maximum value for line profile.Edit number to 
change value. No default value.

Histogram plot Boolean: Show line profile as a histogram plot? Choose True 
or False. 

Default = False

Number of points 
to average

Number: Set number of points to average. Enter a value. 

Default = 1

Polar plot Boolean: Show line profile as a polar plot? Choose True or 
False. 

Default = False

Fill plot Boolean: Fill plot? Choose True or False. 

Default = False

Fill level Number: Set level to fill. Enter value.

Default = 71

Fill color Color: Color used for fill. For color to display, Fill Plot 
property must be set to True. Click to choose from the default 
color palette, or specify RGB values. 

Default = [255,255,255] (white)

Fill transparency Number: Transparency of the plot fill from 0% to 100%. Move 
the slider to change the value. Default = 0

Symbol Symbol: Symbol to appear at regular intervals on the plot line. 
Choose a symbol from the list. Default = No symbol

Symbol size Number: Factor from 0 - 1 determining the size of the selected 
symbol. Move slider to change the size. Default = 0.2

Property Control Type: Values

Table D-59: Line Profile Annotation Properties
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Use default color Boolean: Activate Symbol color property. Choose True or 
False. Default = False

Symbol color Color: Color for the selected symbol. Click to choose from the 
default color palette, or specify RGB values. Default = 
[0,0,0] (black)

Symbol thickness Number: Line thickness from 1 - 9.9 for the selected symbol. 
Move slider to change the thickness. Default = 1.

Symbol 
increment

Number: Interval at which symbols will be displayed on the 
plot line. Influenced by Number of points to average (above). 
Edit to change the value. Default = 1

Property Control Type: Values

Table D-59: Line Profile Annotation Properties
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Rectangle Annotation Properties

These properties control rectangle annotation visualizations. For each property, the 
type of control and the values that can be assigned are listed. For a description of how 
a particular control is used, refer to Appendix B, “Property Controls”.

Property Control Type: Values

Color Color: Color to be used for the rectangle outline. Click to 
choose from the default color palette, or specify RGB values. 
Default = [0,0,0] (black)

Linestyle Line Style: Style of the rectangle outline. Select a line style 
from the list. 

Default = (solid line)

Thickness Line Thickness: Thickness of the rectangle outline in points. 
Select a thickness from the list. 

Default = 1

Fill background Boolean: Fill rectangle background? Choose True or False. 
Default = True

Fill color Color: Color to be used for the background. For background 
color to display, Fill Background property must be set to True. 
Click to choose from the default color palette, or specify RGB 
values. 

Default = [255,255,255] (white) 

Transparency Number: Transparency of the rectangle background fill from 
0% to 100%. Move the slider to change the value. Default = 0

Table D-60: Rectangle Annotation Properties
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Oval Annotation Properties

These properties control oval annotation visualizations. For each property, the type of 
control and the values that can be assigned are listed. For a description of how a 
particular control is used, refer to Appendix B, “Property Controls”.

Property Control Type: Values

Color Color: Color to be used for the oval outline. Click to choose 
from the default color palette, or specify RGB values. Default 
= [0,0,0] (black)

Linestyle Line Style: Style of the oval outline. Select a line style from 
the list. Default = (solid line)

Thickness Line Thickness: Thickness of the oval outline in points. Select 
a thickness from the list. Default = 1

Fill background Boolean: Fill oval background? Choose True or False. 
Default = True

Fill color Color: Color to be used for the background. For background 
color to display, Fill Background property must be set to True. 
Click to choose from the default color palette, or specify RGB 
values. Default = [255,255,255] (white) 

Transparency Number: Transparency of the oval background fill from 0% to 
100%. Move the slider to change the value. Default = 0

Table D-61: Oval Annotation Properties
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Polygon Annotation Properties

These properties control polygon annotation visualizations. For each property, the 
type of control and the values that can be assigned are listed. For a description of how 
a particular control is used, refer to Appendix B, “Property Controls”.

Property Control Type: Values

Color Color: Color to be used for the polygon outline. Click to 
choose from the default color palette, or specify RGB values. 
Default = [0,0,0] (black)

Linestyle Line Style: Style of the polygon outline. Select a line style 
from the list. Default = (solid line)

Thickness Line Thickness: Thickness of the polygon outline in points. 
Select a thickness from the list. Default = 1

Fill background Boolean: Fill polygon background? Choose True or False. 
Default = True

Fill color Color: Color to be used for the background. For background 
color to display, Fill Background property must be set to True. 
Click to choose from the default color palette, or specify RGB 
values. Default = [255,255,255] (white) 

Transparency Number: Transparency of the polygon background fill from 
0% to 100%. Move the slider to change the value. Default = 0

Table D-62: Polygon Annotation Properties
2D Annotation Layer Properties iTool User’s Guide
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Freehand Annotation Properties

These properties control freehand annotation visualizations. For each property, the 
type of control and the values that can be assigned are listed. For a description of how 
a particular control is used, refer to Appendix B, “Property Controls”.

Property Control Type: Values

Color Color: Color to be used for the freehand shape outline. Click to 
choose from the default color palette, or specify RGB values. 
Default = [0,0,0] (black)

Linestyle Line Style: Style of the freehand shape outline. Select a line 
style from the list. Default = (solid line)

Thickness Line Thickness: Thickness of the freehand shape outline in 
points. Select a thickness from the list. Default = 1

Fill background Boolean: Fill freehand shape background. Choose True or 
False. Default = True

Fill color Color: Color to be used for the background. For background 
color to display, Fill Background property must be set to True. 
Click to choose from the default color palette, or specify RGB 
values. Default = [255,255,255] (white) 

Transparency Number: Transparency of the freehand background fill from 
0% to 100%. Move the slider to change the value. Default = 0

Table D-63: Freehand Annotation Properties
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Legend Properties

These properties control legend annotations. For each property, the type of control 
and the values that can be assigned are listed. For a description of how a particular 
control is used, refer to Appendix B, “Property Controls”.

Note
This section discusses the properties of the legend container, which can contain 
multiple legend items of different types. The individual legend types are described 
in:

“Legend Contour Items” on page 484
“Legend Contour Level Items” on page 485
“Legend Plot Items” on page 487
“Legend Surface Items” on page 488

Figure D-40: Visualization Browser with Legend Properties Displayed
Legend Properties iTool User’s Guide
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Property Control Type: Values

Location String List: Position of the legend within the iTool window. 
Select a location from the list. Choose from these values:

• Top Right

• User Specified

• Top Left

• Top Center

• Bottom Left

• Bottom Center

• Bottom Right

Default = Top Right

Layout String List: Arrange the legend elements in columns or rows. 
Select a layout from the list. Choose from these values:

• Columns

• Rows

Default = Columns

Sample width Number: Width in normalized units of the element sample that 
appears in the legend box. Range = 0.0 to 0.5. Move the 
slider to change the value. Default = 0.15

Horizontal 
spacing

Number: Space in normalized units between samples and text 
in the legend box. Range = 0.0 to 0.25. Move the slider to 
change the value. Default = 0.02

Vertical spacing Number: Space in normalized units between lines in the 
legend box. Move the slider to change the value. Default = 
0.02

Text color Color: Color to be used for the legend text. Click to choose 
from the default color palette, or specify RGB values. Default 
= [0,0,0] (black)

Table D-64: Legend Properties
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Text font String List: Font used for legend text. Select a font from the 
list. Choose from these values:

• Helvetica

• Courier

• Times

• Symbol

• Hershey

Default = Helvetica

Text style String List: Style used for legend text. Select a style from the 
list. Choose from these values:

• Normal

• Bold

• Italic

• Bold italic

Default = Normal

Text font size Number: Font size in points for the legend text. Edit the 
number to change the size. Default = 10

Color Color: Color to use for the legend border. Legend object must 
be deselected for border attributes to be visible. Click to 
choose from the default color palette, or specify RGB values. 
Default = [0,0,0] (black)

Linestyle Line Style: Style of the legend border. Select a line style from 
the list. Default = (solid line)

Thickness Line Thickness: Thickness of the legend border in points. 
Select a thickness from the list. Default = 1

Fill background Boolean: Fill legend background? Choose True or False. 
Default = True

Property Control Type: Values

Table D-64: Legend Properties (Continued)
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Fill color Color: Color to be used for the background. For background 
color to display, Fill Background property must be set to True. 
Click to choose from the default color palette, or specify RGB 
values. Default = [255,255,255] (white) 

Transparency Number: Transparency of the background fill from 0% to 
100% Move the slider to change the value. Default = 0%

Property Control Type: Values

Table D-64: Legend Properties (Continued)
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Legend Contour Items 

The following are properties of the top-level Contour legend item. For a description 
of how a particular control is used, refer to Appendix B, “Property Controls”.

Property Control Type: Values

Show Levels Boolean: Show contour levels in the legend. Choose True 
or False. Default = True

Text String: Text that labels the contour object in the legend.

Text color Color: Color to be used for the legend text. Click to choose 
from the default color palette, or specify RGB values. Default 
= [0,0,0] (black)

Text font String List: Font used for legend text. Select a font from the 
list. Choose from these values:

• Helvetica

• Courier

• Times

• Symbol

• Hershey

Default = Helvetica

Text style String List: Style used for legend text. Select a style from the 
list. Choose from these values:

• Normal

• Bold

• Italic

• Bold italic

Default = Normal

Text font size Number: Font size in points for the legend text. Edit the 
number to change the size. Default = 12

Table D-65: Contour Legend Properties
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Legend Contour Level Items 

The following are properties of individual Contour level legend items. For a 
description of how a particular control is used, refer to Appendix B, “Property 
Controls”

Property Control Type: Values

Text String: Text that labels the contour in the legend.

Text color Color: Color to be used for the legend text. Click to choose 
from the default color palette, or specify RGB values. Default 
= [0,0,0] (black)

Use text from String List: Choose a source for the legend text. Choose from 
these values:

• Level value

• Level label

• User defined

Default = Level value

Text format code String: Text that defines the tick format. Edit string to change 
format. You can edit this value only if Text Format is set to 
Use Tick Format Code. Default = none

Text format String List: Choose a format code or time interval to use for 
each legend item. Choose from these values:

• None

• Use Text Format Code

• Filled Fixed Width Integer

• Freeform Integer or Float

• Float with 2 or 4 decimal places

• Exponential with 2 or 4 decimal places

• Date (13 formats)

• Time (11 formats)

Default = None

Table D-66: Contour Level Legend Properties
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Text font String List: Font used for legend text. Select a font from the 
list. Choose from these values:

• Helvetica

• Courier

• Times

• Symbol

• Hershey

Default = Helvetica

Text style String List: Style used for legend text. Select a style from the 
list. Choose from these values:

• Normal

• Bold

• Italic

• Bold italic

Default = Normal

Text font size Number: Font size in points for the legend text. Edit the 
number to change the size. Default = 12

Property Control Type: Values

Table D-66: Contour Level Legend Properties (Continued)
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Legend Plot Items 

The following are properties of Plot legend items. For a description of how a 
particular control is used, refer to Appendix B, “Property Controls”.

Property Control Type: Values

Text String: Text that labels the plot object in the legend.

Text color Color: Color to be used for the legend text. Click to choose 
from the default color palette, or specify RGB values. Default 
= [0,0,0] (black)

Text font String List: Font used for legend text. Select a font from the 
list. Choose from these values:

• Helvetica

• Courier

• Times

• Symbol

• Hershey

Default = Helvetica

Text style String List: Style used for legend text. Select a style from the 
list. Choose from these values:

• Normal

• Bold

• Italic

• Bold italic

Default = Normal

Text font size Number: Font size in points for the legend text. Edit the 
number to change the size. Default = 12

Table D-67: Plot Legend Properties
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Legend Surface Items 

The following are properties of individual Surface legend items. For a description of 
how a particular control is used, refer to Appendix B, “Property Controls”.

Property Control Type: Values

Text String: Text that labels the surface object in the legend.

Text color Color: Color to be used for the legend text. Click to choose 
from the default color palette, or specify RGB values. Default 
= [0,0,0] (black)

Text font String List: Font used for legend text. Select a font from the 
list. Choose from these values:

• Helvetica

• Courier

• Times

• Symbol

• Hershey

Default = Helvetica

Text style String List: Style used for legend text. Select a style from the 
list. Choose from these values:

• Normal

• Bold

• Italic

• Bold italic

Default = Normal

Text font size Number: Font size in points for the legend text. Edit the 
number to change the size. Default = 12

Table D-68: Surface Legend Properties
Legend Properties iTool User’s Guide
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annotating

countours, 268
freehand type, 85
images, 218
line type, 82
oval type, 83
plots, 291
polygon type, 84
rectangle type, 83

annotating (continued)
text type, 81
toolbar for, 359
types of, 81
volumes, 313

axes
adding to

contours, 263
images, 208
surfaces, 232
volumes, 305

additional, 86
properties, 447

B
big endian data, 37
iTool User’s Guide 489



490
byte ordering
big endian, 37
binary data, 37
little endian, 37
native method, 37

byte scale properties, 380

C
canvas zooming, 74
colorbars

adding to
contours, 261
images, 207
plots, 282
surfaces, 229
volumes, 304

properties, 439
colors

changing in contours, 258
in iImage, 204

containers, definition, 167
contour, 387
contours

adding an axis, 263
adding statistics, 270
annotations, 268
colobar, 261
colorbar, 262
colors in, 258
displaying

in iContour, 247
in iMap, 332

filling, 259
filtering, 264
flipping, 267
histogram, 270
labelling, 256
legend level properties, 485
legend properties, 484
on surface data, 234

contours (continued)
properties, 254
propertiesof, 420

convolution
filtering, 127
properties, 372

cropping, 384
curve fitting, for plots, 286

D
data

importing, 25
manager, 22

data associations
removing, 61
replacing, 61

data manager, 22
data space, 67
dataspace

properties, 403
range resetting, 134

displaying
2D plots, 273
3D plots, 275
contours

in iContour, 247
in iMap, 332

images
in iImage, 199
in iMap, 324

irregular-grid data, 248
maps, 317
multi-channel volumes, 297
regular-grid data, 247
statistics, 132
surfaces, 225
volumes, 297

drag quality, 399
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E
edit menu, 347
edit toolbar, 357
error bar plots, 283

F
files

menu, 345
operations, 115
reading, 100
toolbar, 356
writing, 105

filling contours, 259
filtering

contours, 264
convolution, 127
data, 125
images, 210
median, 125
plots, 289
smooth filter, 125
surfaces, 237

flipping contours, 267
flipping images, 217
freehand annotations, 85, 479

G
general settings, 98
gridding wizard, 249

H
help menu, 355
histogram

adding to a volume, 314
for contours, 270
for plots, 293

histogram (continued)
plot, 131
properties, 371, 443
surface, 244

I
IDL shapefiles, inserting, 335
iImage, properties, 406
iImage color, 204
iimages, ROIs, 204
image plane, 392
images

adding
axis to, 208
colorbar to, 207
surface, 215

annotating, 218
brightness, 204, 205
contouring, 213
cropping, 219
displaying

in iImage, 199
in iMap, 324

displaying multiple, 200
filtering, 210
flipping, 217
image panel, 203
inverting, 216
line profiling, 218
manipulating, 216
modifying properties, 206
morphing, 212
of surface data, 233
panning, 219
pixel scaling, 217
plane

for volumes, 307
properties, 390, 436

region growing, 217
registering, 325
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images (continued)
resampling, 209
rotating, 216
scaling, 216
zooming, 217

importing data, 25
insert menu, 350
inserting

IDL shapefiles, 335
map grid, 334

interval volume
extracting in volumes, 310
properties, 434

inverting images, 216, 380
iplot, properties, 409
irregular-grid data, 248
isosurface

extracting in volumes, 308
properties, 432

isurface, properties, 416
iTools

annotation toolbar, 359
common operations, 112
edit menu, 347
edit toolbar, 357
file menu, 345
file toolbar, 356
help menu, 355
insert menu, 350
inserting a visualization, 58
manipulator toolbar, 358
operations menu, 351
view properties, 400
window menu, 354
window properties, 398

L
labelling contours, 256
layout window, 113

legends
adding, 79

to contours, 262
to plots, 280
to surfaces, 231

properties, 480
lights

adding to a surface, 230
properties, 455

lines
annotating, 82, 472
profiles

annotating, 473
extracting for a surface, 242
in images, 218

little endian data, 37

M
Macro Editor

Add and Remove buttons, 152
items

annotation, 161
history, 157
macro, 155
Macro Tools, 162
Tool Menus, 166
visualization, 160

macro property sheet, 149
macro tree, 148
menu bar, 146
source property sheet, 152
source tree, 150
using, 145

macros
definition, 139
exporting, 174
importing, 174
properties, 369
recording, 141
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macros (continued)
running, 142

from the IDL command line, 144
from the Macro Editor, 143
from the Operations menu, 143

Selection Change operation
adding, 168
properties, 169

Tool Change operation
adding, 171
properties, 172

types, 167
manipulating images, 216
manipulator toolbar, 358
map grid, inserting, 334
Map panel, 322
map projection, 381

applying, 318
common properties, 318
definition, 318
selected properties, 319

map register image, 382
maps, displaying, 317
median filtering, 125
morphing, 383

data, 130
images, 212

multi-channel volumes, 297

O
objects

rendering translucent, 135
scaling, 69
selecting, 65
selecting all, 65
translating, 68

operations
browser, 95, 368
common, 112
file, 115

operations (continued)
menu, 351
property sheets, 91

oval annotations, 83
overplotting, 277

P
panel, Map, 322
panning images, 219
parameter editor, 60
parameters, editor, 60
plots

adding a histogram to, 293
adding statistics to, 293
annotating, 291
colorbar, 282
curve fitting, 286
displaying 2-D, 273
displaying 3-D, 275
displaying polar, 276
error bars, 283
filtering, 289
histogram, 131
legend, 280, 487
modifying properties for, 279
overplotting, 277
scaling, 293
translating, 291

polar plots, 276
polygon annotations, 84, 478
polygonal ROIs, 458, 461, 465, 467, 468
preferences browser, 97
properties

2D annotation layer, 469
3D plot, 413
axis, 447
byte scale, 380
colorbar, 439
contour, 387, 420
contour legend, 484
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properties (continued)
contour legend level, 485
contours, 254
convolution, 372
cropping, 384
dataspace, 403
freehand annotation, 479
histogram, 371, 443
image, 406
image plane, 390, 392, 436
interval volume, 434
inverting image, 380
isosurface, 432
legend, 480
lights, 455
line annotation, 472
line profile annotation, 473
macros, 369
map projection, 381
map register image, 382
modifying volume, 303
morphing, 383
operations browser, 368
plot, 409
plot legend, 487
polygon annotation, 478
polygonal ROIs, 458, 461, 465, 467, 468
rectangle annotation, 476
region grow, 385
render volume, 390
resample, 377
Roberts filter, 374
rotate, 376
rotate data, 378
scale data, 379
sheets

defined, 89
operations, 91
visualization, 90

smooth filter, 373, 373
Sobel filter, 374

properties (continued)
statistics, 370
surface legend, 488
surfaces, 416
transform, 377
unsharp mask filter, 374
view, 400
visualization layer, 401
visualization type, 406
volume, 426
window, 398

R
reading files, 100
rectangle annotations, 83, 476
redo, 66
region grow, 385
region of interest, operations and, 136
registering images, 325

in degrees, 330
in meters, 327

regular-grid data displays, 247
rendering translucent objects, 135
rendering volumes, 298, 390
resampling

data, 122
images, 209
properties, 377
surfaces, 236
volumes, 306

resetting dataspace, 134
Roberts filter, 374
rotating

data, 118, 123
image, 216
left, 120
properties, 376, 378
right, 120
surfaces, 239
volumes, 312
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rotating (continued)
with a mouse, 118

S
scaling

3-D objects, 69
constrained, 69
data, 124
images, 216
objects, 69
plots, 293
properties, 379
surfaces, 240
unconstrained, 71
unconstrained 2-D objects, 72
unconstrained 3-D objects, 73
volumes, 312

selecting objects, 65
shape visualization, creating, 333
shapefile

creating a visualization, 333
definition, 333
inserting

Canadian provinces, 340
continents, 335
countries (high resolution), 336
countries (low resolution), 336
lakes, 338
rivers, 337
United States, 339

smooth filtering, 125, 373, 373
smoothing volumes, 314
Sobel filter, 374
statistics

adding to plots, 293
adding to volumes, 314
displaying, 132
properties, 370
surface, 244

styles
applying, 177
copying, 184
creating, 178
current style, 183
default style, 194
definition, 176
editing, 191
exporting, 195
importing, 195
types, 177

surfaces
adding a texture map to, 238
adding to an image, 215
colorbar, 229
creating contours on, 234
creating images of, 233
displaying, 225
extracting a line profile, 242
filtering, 237
histogram for, 244
legends, 231, 488
lights, 230
rotating, 239
scaling, 240
statistics, 244

T
text annotations, 81
texture maps, 238
three-dimensional plots, 413
transforming

data, 122
properties, 377
resampling, 122
rotate data, 123
scale data, 124

translating
objects, 68
plots, 291
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translucent object rendering, 135

U
undo, 66
unsharp mask filter, 374

V
view zooming, 74
visualizations

browser, 92
creating, 57
definition of, 56
exporting, 62
inserting, 58
layers, 401
modifying, 60
object selection, 92
property sheets, 90
type properties, 406

volumes
adding a colorbar to, 304
adding a histogram to, 314
adding an axis to, 305
adding statistics to, 314
annotating, 313
displaying, 297
displaying multi-channel, 297
extents, 299
extracting an interval volume in, 310
extracting an isosurface for, 308
properties, 303, 426
rendering, 298
resampling, 306
rotating, 312
scaling, 312
showing an image plane for, 307
smoothing, 314

W
window layout, 113
window menu, 354
writing files, 105

Z
zooming, 74
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