
 

  
Release Notes
This document contains release notes which explain modifications and changes between EnSight releases.  
This document is only useful if you are a current EnSight user and have upgraded to a new version of 
EnSight.  New users need not view these notes.

Index:
Release notes from EnSight 8.0 to EnSight 8.2
Release notes from EnSight 7.6 to EnSight 8.0

Release notes from EnSight 8.0 to EnSight 8.2
Index

Installation
Licensing
Documentation
GUI Changes
New and Modified Features
APIs and Data Formats
Compatibilities
Other Components
Mac PDF Reader Issue

Installation
EnSight 8.2 will install itself under INSTALL_DIRECTORY/CEI/ensight82/ and will not modify any files 
previously installed with earlier versions.

By design, the ensight8, ensight8_client, ensight8_server, and ensight8_sos scripts in the bin directory will 
run the version of EnSight installed last (in this case 8.2).  If you wish to run older versions of EnSight, 
such as 8.0, you may do so by specifically running this version such as "ensight80".

Licensing
EnSight 8.2 uses the same SLiM license manager and same license keys as 8.0.  No change to the licensing 
is necessary if you are currently running 8.0.

Documentation
The User, How-To, Command Language, and Getting Started manuals have all been updated to reflect 
changes in 8.2.

Additionally, a new Interface Manual has been created. It eliminates a number of README files which 
were scattered in various locations, and contains the information needed for producing user-defined 
readers, producing user-defined writers, producing user-defined math functions, using the EnSight external 
command driver, and using the EnSight Python interpreter.

GUI Changes
A new User Defined icon is now visible in the feature icons.  This icon will pull up a user defined GUI as 
explained in the New and Modified Features section.  If no user defined elements are available the icon 
will not be shown.

Under the File pulldown the following changes have been made:

"Connect server..." has been removed.  The connection settings have now been moved to the Case 
pulldown.
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"Open..." and "Data (reader)..." have been consolidated into a "Open..." option with a "Simple" and 
"Advanced" capability

"Record current animation..." has been moved to the File->Save options

The "Sort..." button immediately under the part list has been renamed "List..."  The List... pulldown 
contains several new options for tree list view - see the New and Modified Features section.

The Variable list found in the Feature Detail Editor for Variables and Calculator now shows the Case that a 
variable belongs to.

All of the detail editors now show all variables available in any variable chooser.  The variable will be 
activated as needed.  In 8.0 the detail editors showed only the active variables.

In the Feature Detail Editor (Calculator) dialog all variables are now shown in the calculator section.  
EnSight now activates the variables as needed.

The Displacement icon in Part mode has been modified.

New icons have been added to Annot mode to reflect new capabilities.

The View->Static Lighting option has been removed

Up/Down arrows to control value fields have been added in several places such as particle trace animation 
controls and vector arrow scale factor.

The Print/Save Image dialog has been modified to show new options available for printing.

New and Modified Features

Connections Under the Case pulldown you will find two new options.

Connection details... brings up a dialog showing some information for the case 
selected such as amount of data transferred and what data is 
loaded.

Connection settings... pulls up a new dialog.  In this dialog you can switch your 
server or SoS connection to a different machine, save 
preferences for these machines and add/replace cases. This 
essentially allows you to change the connection settings after 
EnSight starts up (but before you read data).

Commands and 
Macros

The command dialog is all new.  If you play a command file you can now see the 
upcoming commands as well as the history.  You can also right click to set 
breakpoints as well as save/execute the selected commands.
A separate tab will allow you to see, modify, and define macros.
Another tab will allow you to execute Python scripts.

Part List The part list can be organized into different tree list views by List->Show Tree and 
selecting one of the options.  In 8.0 a parent/child tree list was available (still is).  In 
8.2 we add the ability to view in part tree mode part attributes such as visibility, line 
vs. shaded, etc.
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Save Image 
Formats

EnSight 8.2 utilizes a user defined image library (UDIL). Incorporated into this 
image library is support for the following image/movie formats: AVI (raw, mpeg, 
mpg4), BMP, EVO, QuickTime (mpg4) Animated GIF, JPEG, PNG, PPM, XPM, 
SGI, LLNL SM, TIFF, MPEG1, MPEG2, MPEG4.  In addition, it is possible for the 
user to define his own formats which are seen by EnSight at run time.
Also changed with the UDIL support are options to save the images in stereo (even 
if you are not currently in stereo mode or are running on stereo capable hardware) 
render the images to an offscreen buffer, set the anti-aliasing quality settings, and 
render to arbitrary size images.

All platforms support the ability to copy the current window contents to the system 
native clipboard.

User Defined 
Interface

It is possible to add your own user interface to EnSight in order to enhance the 
current GUI or you can replace the entire GUI with your own.  This is done through 
Python.  Several examples of this can be found in the 8.2 installation.

Right Click User 
Defined 
capabilities

It is possible to define a right click action.  Upon the right click action a custom user 
interface will pop up.  With this customer right click interface you can query what 
was selected at the time of the right click event and perform actions accordingly.  
For example, from your code you can find that a certain part number and certain 
node number was selected.  You could then query this node over time and plot the 
results.  Or have the ability to make the selected part invisible, etc.

Tools The quadric tools now have rotate handles.  The Transformation dialog has been 
modified to allow you to rotate these tools from the dialog. Given the quadric tools 
now have an axis system, they now translate in the tools axis system instead of 
transforming in the global coordinate system
The line tool now has rotate handles.  The Transformation dialog has been modified 
to allow you to rotate the line tool from this dialog. Given the line tool now has an 
axis system it now translates in the tools axis system instead of transforming in the 
global coordinate system.
The plane tool can now be defined by three node numbers.  As these node numbers 
move over time the plane tool will update.  The line tool has also been modified 
similarly, i.e., it can be defined by two node numbers.  The pick option has been 
extended to allow you to pick the line and plane tools via node numbers.

Clips The quadric clips can now be finite.
The line clips can be of type mesh or grid - previous versions of EnSight only did a 
uniform sampling (grid clip) for the line clip option.  A mesh line clip can be infinite 
or finite.  A line clip can also now be of type "Crinkly"
In/Out clips can now be finite for all tools.
A plane clip can be defined by three node numbers.  Over time the node numbers 
may move in which case the plane clip will update accordingly.
The line clip can be defined by two node numbers.  Over time the node numbers 
may move in which case the line clip will update accordingly.
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Query The X/Y query as well as the Interactive query now show markers that update to 
new locations if you change timesteps.  The markers also update if the model is 
displaced.
In Interactive Query mode it is now possible to query the min/max values
In Interactive Query mode it is possible to "expand" the query out to show the 
neighboring nodes and elements.  You have control over the number of levels you 
wish to see.  The "expand" capability is done through the subset part capability and 
thus when you turn off the interactive query you will get a pop-up dialog asking if 
you want to save the subset part used by the query expansion.

Displacements The coordinates of Model parts can be modified on the EnSight server by scaling the 
original coordinates and scaling/adding to this a scalar for each of the x/y/z 
coordinate values.  Thus is possible to entirely swap out a model parts coordinates to 
another variable or apply displacements on the server side of EnSight.

Element 
Representation

It is possible, for any element representation, to load the geometry as 
points+normals only.  For large datasets this can substantially reduce the amount of 
graphics processing while adequately displaying the data.

Fast Display Mode An option of "Invisible" has been added to the part choices for fast display mode.

Texture mapping The color dialog in Part mode now has a button "Edit texture...." which brings up a 
dialog that allows you to read and apply 2D textures to any part.  Many options are 
available.

Annotation New annotations are available as follows:

Dial - a round gauge that shows the value of a constant variable

Bar - a bar graph that shows the value of a constant variable

2d arrows, circles,
and rectangles

The text annotation capability between New and Edit have been consolidated and is 
consistent with the other annotation types.
Text annotations can span multiple lines.
Text annotations can use a number of True-Type fonts and has support for 
international character fonts (Windows)
While updating text annotations it is possible to have the updates occur dynamically, 
i.e.  the updates are shown in the graphics window while you type.
The default annotation font and size (used for node/element labels, the axis system 
labels, etc.) can be set as a preference.  See Edit->Preferences->Annotation

Particle Traces Massed Particle trace settings have been simplified.
Massed Particles can now have Rebound with a coefficient of restitution and 
friction.

Case Map The CaseMap computed variable has been improved to give the user the option of 
finding the closest node if a search fails practically eliminating the problem of 
obtaining Undefined values.
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APIs and Data Formats
Yaw/Pitch/Roll have been added to the rigid body capability of the data format and the user defined 
readers.

The user defined reader API has added the option to read data in a decomposed manner - this used during 
EnSight's auto decompose capability for parallel servers.  The API has also added a time-history capability.  
If implemented the time-history information is available as query items in the EnSight Query interaction 
area.

Variable names can now be up to 49 characters (up from 19).  In order to provide backwards compatibility 
for the command language EnSight keeps the old shorter name as well as the new longer name.  User 
defined readers, in order to have command language compatibility, should modify the variable name but 
also provide the shorter name. The user defined reader API explains this.  The only known possible 
problem with command language is if multiple queries have been created from the same variable (EnSight 
then creates a query name which is a combination of the variable name and a number) and then a query 
combine is created with these new, longer and modified names.  Users that hit this situation will have to 
modify their command files.

Compatibilities
Archives are NOT compatible between 8.0 and version 8.2

Command language is compatible between earlier 8.0 and 8.2

Since the command language is compatible context files are also compatible between 8.0 and 8.2

Some data formats have changed their default element representation (see ensight_reader_extension.map 
in your home directory or the site_preferences directory of the 8.2 install).  This can cause parts to be 
loaded in different element representations if using an older command file.  This in turn can cause a 
difference in created parts.  Should you experience this you could consider (a) changing the .map file or (b) 
setting the element representation in the command file (which would have to be done after the parts are 
loaded).

The MRU (most recently used) list is not brought forward from 8.0 to 8.2.  The number and details of the 
MRU is completely different between the two versions and it was thus deemed impractical to preserve this.

Timeout You can set up a maximum amount of time you are willing to wait for any server 
operation.  See Edit->Preferences->Performance

SoS It is now possible to read any file format while using the SoS. Previous versions 
required the use of a sos case file.
It is now possible to use the SoS with multiple servers even if the data is not 
decomposed.  This version of EnSight has the ability to auto-decompose datasets 
"on the fly".

Resources A resource file may be defined and specified to EnSight describing what computer 
resources are available to run the various EnSight components.  This greatly 
simplifies parallel setup.  It is also possible to use environment variables to define 
resources which makes it convenient to use with cluster management allocation 
software.

DR The distributed rendering capabilities can take advantage of the Resources 
definitions which greatly simplifies parallel distributed rendering when using the 
image compositing mode.
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Other Components
EnLiten remains essentially unchanged in look, feel, and functionality.  Like EnSight, it does use UDILs to 
save/print images and TrueType fonts for display.

EnVe adds a user interface allowing it to be used effectively for simple video editing.  This complements 
the release of quicktime plugins for the EVO format to popular non-linear video editing applications.

Reveal (formerly Vista) adds the ability to save multiple variables from EnSight and thus you can switch 
which variables you wish to view.

Mac PDF Reader Issue
Mac Users: if you don’t want to use Preview for EnSight documentation viewing (since hyperlinks don’t 
work well), you have the following alternative options:

1. If you have xpdf on your system, and in your path:
setenv CEI_PDFREADER xpdf

2. If you have Adobe Reader on your system and want to just have EnSight use it for pdf files:
setenv CEI_PDFREADER “/Applications/Adobe Reader 7.0.7/Adobe Reader 7.0.7.app”

        (Modify the string appropriately for your Adobe Reader)

3. If you have Adobe Reader on your system and want to have it be the default app for all pdf files - 
including EnSight’s Documentation:
Go to:

 “Apple” -> System Preferences -> Default Apps
and set the default app for pdf files to be the Adobe Reader.
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Release notes from EnSight 7.6 to EnSight 8.0 
Index

Installation
Licensing
Documentation
GUI Changes
New and Modified Features
Archives and Command Language

Installation
EnSight 8.0 will install itself under INSTALL_DIRECTORY/CEI/ensight80/  and will not modify any files 
previously installed with earlier versions.

The environment variable CEI_HOME must be set to point to the INSTALL_DIRECTORY/CEI directory 
and the user’s path must include $CEI_HOME/bin.  For example:

setenv CEI_HOME /usr/local/CEI
set path=($path $CEI_HOME/bin)

It is not necessary to set the CEI_ARCH environment variable unless you want to override the default.

We no longer distribute 32 bit versions for SGI, HP, SUN, and IBM. Only 64 bit executables are 
distributed.  We no longer build a True64 (Compaq) EnSight client under OpenGL.  Only batch rendering 
is now available for this platform.

By design, the ensight8, ensight8_client, ensight8_server, and ensight8_sos scripts in the bin directory will 
run the version of EnSight installed last (in this case 8.0).  The ensight7 scripts remain unmodified and will 
run the ensight7 binaries you have installed.

Licensing
EnSight 8.0 uses a new version of the SLiM license manager.  It will be necessary to install the new license 
manager and the new license key.  The new license key must be installed in the INSTALL_DIRECTORY/
CEI/license2 directory.

If you are upgrading from EnSight 7.6 and wish to run both EnSight 8.0 and the older 7.6 binaries you 
must install EnSight 7.6.7(a) available for download from our ftp site.  This will enable EnSight 7.6 to 
utilize the new license manager.  If you do not install 7.6.7 you will continue to be able to use EnSight 7.6 
until the license expires.

Documentation
The User, How-To, Command Language, and Getting Started manuals have all been updated to reflect 
changes in 8.0.

GUI Changes
Most of the feature icons across the top have been recreated.  The icons are also smaller.  The order has 
been adjusted.  If you do not care for the current default order you may adjust it by File->Preferences-
>General User Interface-> Modify and save icon layout...

The application background color is now set to a medium gray as opposed to following windowing system 
color settings.  You can continue to set the GUI colors by specifying the -bg, -fg, etc. start parameters.

The solution time icon in the feature bar is removed if a dataset is loaded that does not contain multiple 
timesteps.

The displacement and color icons have been moved from the feature icon bar to the part mode icon bar.
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Parts in the part list can be right clicked for a number of part functions.

The part list can be shown as a flat (default) representation or switched to show a hierarchical 
representation.

The options available immediately above the graphics window have been iconified.  Pick has been moved 
from part mode to the first icon on the left (the black arrow).  A new icon has been added for displaying the 
selection tool (to the left of the cursor icon).

All of the mode icons have been revamped and now use tabs for access.

All toggles under Unix now show a check mark when selected.

All modes have the common icons (such as visibility and color) at the top of the icon bar.  If you wish to 
move the order to what is used in 7.6 see File->Preferences->General User Interface-> Modify and save 
icon layout...

View mode has been removed.  Use the View pulldown for this functionality.

In part mode:

The color icon now brings up a dialog controlling not only color, but also transparency, shading, and 
lighting parameters.  The new dialog incorporates a new color chooser and a color patch which shows 
the effects of the lighting parameters.  The new color dialog also has a link to bring up the color palette 
editor.  Coloring by a variable has been simplified such that the variable is immediately used when 
selected.  Old mode icons for shading and transparency have been removed.

Displacement dialog has been simplified to apply the displacement when the variable is selected.

The node and element icons have been combined into a single icon which now brings up a dialog that 
controls the node/element toggles as well as the global filtering options.

Select all and the delete icons have been removed as they are now available via the buttons immediately 
under the part list.

In Annotate Mode:

Massive changes to minimize the number of icons and create a common tabbed dialog for easier 
manipulation.

All of the quick interaction dialogs for part creation now contain an Advanced... button which will bring up 
the detail editor for that part creation.

Tool Tips under Unix now works much better.

The default window size for recording animations is now NTSC. The default image type for recording is 
now EVO.

And many other minor changes.
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New and Modified Features

Part List Immediately under the part list you will find:

Select...

All Select all parts in the part list

Invert Invert the part list selection

Invisible Select the invisible parts

Visible Select the visible parts

Region Select all the parts that are within the selection tool

Showing Select all the parts that are wholly or partially visible in the 
current viewport

Keyword brings up a dialog for selection

Unselect Unselect all parts

Delete... Brings up a confirmation dialog prior to deleting the selected 
parts

Sort... Allows the part list to be sorted in various ways.  Also controls 
how the part list will be viewed (flat or with parent hierarchical 
information) and what will be shown

(+)/(-) Expands or contracts the part list to be the vertical size of 
EnSight.

Fit Button A Fit button has been added to the row of buttons immediately under the 
graphics window.  This will keep the current transformations and make the 
currently visible parts “fit” the graphics window.

Selection Tool A Selection Tool transformation mode icon has been added to the right of 
rubber band zoom.  This tool brings up a selection tool that can be used for:
    (a) Rubber band zoom
    (b) Selecting all parts inside the box
    (c) Element blank (see below) the elements within the box
The Selection tool has also been added to the Reset and Transformation dialogs.

Element Visual 
Representation

Element Visual Representation now contains new options:
    3D feature, 2D full
    3D Non-Visual, 2D full

Palette Legend You can now modify the title of a palette legend

Record Button A record button (red circle icon located immediately above the graphics 
window) has been added.  The icon is not available if there is no animation 
available to record.  The following will activate the icon:

flipbook running
particle traces animating
clip/iso in interactive auto mode
spin mode
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Flipbook Dialog The flipbook dialog has been rearranged to separate run from load. The run tab 
has been changed to show vcr style buttons and a display option (flipbook or 
original model) has been added.  A triple slider is now in use controlling the 
begin/current/end display page.  The record button has been removed - use the 
record button (red circle) found immediately above the graphics window.  
When a flipbook is loaded it will automatically start playing.

Solution Time Dialog The solution time dialog has been rearranged and now includes a VCR type 
interface which will stream through the timesteps.  A triple slider has been 
created which shows the start, current, and end time. When in play mode the 
timesteps may be recorded by going to the record button (red circle) 
immediately above the graphics window.  The solution time dialog also 
contains a shortcut that will display a time annotation.

Animating Time
Queries

Animating time queries can now show a marker on the curve instead of 
sweeping the curve out on the plotter (which was previously the only behavior).

Contour Dialog Contour dialog now includes an option to color the resulting contour part by the 
creation variable.  It is on by default.

Isosurface Dialog The isosurface dialog by default sets the value to “MID-RANGE”.  If not 
replaced by the user the resulting value will be at the mid variable value.  Also 
added is user interface which allows multiple surfaces to be created with a delta 
value.

Clip Dialog Clip dialog includes the same default behavior as the isosurface dialog.  Also 
contains the multiple clip creation via a delta value.

Vector Arrows Vector arrow dialog contains same default behavior as the isosurfaces.

Vector arrows may now have cone shaped arrow tips.

Subset Parts There is now the ability to pick (one at a time) elements from the graphics 
window into the subset part.  You can also select a region of elements using the 
selection/region tool.

File File pulldown now contains a Open... button which will bring up a dialog 
allowing a dataset with a known file extension to be read using a configured 
part load method.  The file extensions are mapped to the readers via the 
ensight_reader_extension.map file located in the CEI_HOME/ensight80/
site_preferences directory and overwritten by the same file found in the user’s 
.ensight8 directory.

A most recently read list is now maintained and is available from
File->Open Recent Data File (unix - windows available from the File pulldown 
directly). If the file was opened from File->Open, the dataset will be read and 
loaded.  If the file was opened from File->Data(reader), the Data Reader dialog 
will appear with the information filled in the fields.

File->Save->Commands from this Session has been added.  This will save the 
command file up to the point of saving the file.

File->Save->Scenario now contains a file format for CSF
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POVRAY POVRAY has been added as a print format.  This creates an interface which 
will produce high quality images via ray tracing which include reflections, 
shadows, etc.

Edit Preferences Edit->Preferences->Mouse&Keyboard now contains many more options to 
allow mouse button combinations.

Edit->Preferences->Performance contains a “Save Under” option.  This option 
will save the pixels from the screen and repaint them if a expose event is 
detected.  The option is off by default.  IT IS HIGHLY RECOMMENDED 
THAT USERS WITH LARGE MODELS TURN THIS TOGGLE ON.

Simple Palette Editor The “Simple” palette editor now contains an option to set the palette min/max 
value to the value of the parts selected

P-Buffer Support P-Buffer support has been added for Linux (if available).

Failed Element
Support

Failed element support has been added.  This function will remove elements 
(complete elements) based on a failure criteria.  The elements are removed on 
the EnSight server so removal affects all functionality such as variable creation, 
element representation, part creation, etc.  A User Defined Reader (UDR) can 
set a failure criteria from within the reader.  If this is the case, failed elements 
will be used (culled) by default.

Element Blanking Element blanking has been added.  This allows a user to select an element 
(either pointing to it via the mouse or using the Selection tool) and remove it 
from the display.  This is a client only function. The removed elements are the 
ones closest to the viewer.  The function has no concept of changing 
connectivity transient problems.  The elements that were blanked before a time 
change will be the same elements after the time change.

Light Source Light source location has been added to viewport mode.  The light source can 
either be placed at an absolute location or be offset from the viewer.

The default diffused lighting intensity has been changed from 0.1 to 0.2.

Viewport
Background

Viewports can now display a bit map image.  EnSight Gold only. The bitmap 
can be .xpm or .bmp

Logo Files Annotation logo files can now read .bmp files in addition to .xpm files.

Tracking A Viewport may now track the movement of an object.  Several options exist 
for what it tracks.

Fast Display Mode Fast display mode now allows a reduced polygon representation.

Partice Traces Patricle traces can now have arrows drawn along the trace indicating direction.  
The number and size may be controlled.  The trace time is automatically set to a 
reasonable default value.

Tool Hotpoints While in Part and Frame mode, the mouse cursor now changes when over the 
tool (cursor, line, etc.) hotpoints.

Boundary Layer
Variables

Added Distance to Value and Y1 Plus variables. Both are found in the 
calculator.
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Archives and Command Language
Archives are NOT compatible between earlier 7.x versions and 8.0
Command language IS compatible between earlier 7.x versions and 8.0

Readers By default (see CEI_HOME/ensight80/site_preferences/
ensight_reader_prefs.def) the following readers have been removed from the 
Format list in the Data Reader dialog:

ANSYS (replaced by new Ansys reader)
ESTET
Fluent Universal
Movie.BYU,
MPGS 4.1
N3S
Vectis

If you wish to make these available, you can turn them back on by simply 
editing or removing the above file.
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