
 

  
Release Notes
This document contains release notes which explain modifications and changes between EnSight releases.  
This document is only useful if you are a current EnSight user and have upgraded to a new version of 
EnSight.  New users need not view these notes.

Index:
Release notes from EnSight 7.6 to EnSight 8.0
Release notes from EnSight 7.4 to EnSight 7.6
Release notes from EnSight 7.3 to EnSight 7.4

Release notes from EnSight 7.6 to EnSight 8.0 
Index

Installation
Licensing
Documentation
GUI Changes
New and Modified Features
Archives and Command Language

Installation
EnSight 8.0 will install itself under INSTALL_DIRECTORY/CEI/ensight80/  and will not modify any files 
previously installed with earlier versions.

The environment variable CEI_HOME must be set to point to the INSTALL_DIRECTORY/CEI directory 
and the user’s path must include $CEI_HOME/bin.  For example:

setenv CEI_HOME /usr/local/CEI
set path=($path $CEI_HOME/bin)

It is not necessary to set the CEI_ARCH environment variable unless you want to override the default.

We no longer distribute 32 bit versions for SGI, HP, SUN, and IBM. Only 64 bit executables are 
distributed.  We no longer build a True64 (Compaq) EnSight client under OpenGL.  Only batch rendering 
is now available for this platform.

By design, the ensight8, ensight8_client, ensight8_server, and ensight8_sos scripts in the bin directory will 
run the version of EnSight installed last (in this case 8.0).  The ensight7 scripts remain unmodified and will 
run the ensight7 binaries you have installed.

Licensing
EnSight 8.0 uses a new version of the SLiM license manager.  It will be necessary to install the new license 
manager and the new license key.  The new license key must be installed in the INSTALL_DIRECTORY/
CEI/license2 directory.

If you are upgrading from EnSight 7.6 and wish to run both EnSight 8.0 and the older 7.6 binaries you 
must install EnSight 7.6.7(a) available for download from our ftp site.  This will enable EnSight 7.6 to 
utilize the new license manager.  If you do not install 7.6.7 you will continue to be able to use EnSight 7.6 
until the license expires.

Documentation
The User, How-To, Command Language, and Getting Started manuals have all been updated to reflect 
changes in 8.0.
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GUI Changes
Most of the feature icons across the top have been recreated.  The icons are also smaller.  The order has 
been adjusted.  If you do not care for the current default order you may adjust it by File->Preferences-
>General User Interface-> Modify and save icon layout...

The application background color is now set to a medium gray as opposed to following windowing system 
color settings.  You can continue to set the GUI colors by specifying the -bg, -fg, etc. start parameters.

The solution time icon in the feature bar is removed if a dataset is loaded that does not contain multiple 
timesteps.

The displacement and color icons have been moved from the feature icon bar to the part mode icon bar.

Parts in the part list can be right clicked for a number of part functions.

The part list can be shown as a flat (default) representation or switched to show a hierarchical 
representation.

The options available immediately above the graphics window have been iconified.  Pick has been moved 
from part mode to the first icon on the left (the black arrow).  A new icon has been added for displaying the 
selection tool (to the left of the cursor icon).

All of the mode icons have been revamped and now use tabs for access.

All toggles under Unix now show a check mark when selected.

All modes have the common icons (such as visibility and color) at the top of the icon bar.  If you wish to 
move the order to what is used in 7.6 see File->Preferences->General User Interface-> Modify and save 
icon layout...

View mode has been removed.  Use the View pulldown for this functionality.

In part mode:

The color icon now brings up a dialog controlling not only color, but also transparency, shading, and 
lighting parameters.  The new dialog incorporates a new color chooser and a color patch which shows 
the effects of the lighting parameters.  The new color dialog also has a link to bring up the color palette 
editor.  Coloring by a variable has been simplified such that the variable is immediately used when 
selected.  Old mode icons for shading and transparency have been removed.

Displacement dialog has been simplified to apply the displacement when the variable is selected.

The node and element icons have been combined into a single icon which now brings up a dialog that 
controls the node/element toggles as well as the global filtering options.

Select all and the delete icons have been removed as they are now available via the buttons immediately 
under the part list.

In Annotate Mode:

Massive changes to minimize the number of icons and create a common tabbed dialog for easier 
manipulation.

All of the quick interaction dialogs for part creation now contain an Advanced... button which will bring up 
the detail editor for that part creation.

Tool Tips under Unix now works much better.

The default window size for recording animations is now NTSC. The default image type for recording is 
now EVO.

And many other minor changes.
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New and Modified Features

Part List Immediately under the part list you will find:

Select...

All Select all parts in the part list

Invert Invert the part list selection

Invisible Select the invisible parts

Visible Select the visible parts

Region Select all the parts that are within the selection tool

Showing Select all the parts that are wholly or partially visible in the 
current viewport

Keyword brings up a dialog for selection

Unselect Unselect all parts

Delete... Brings up a confirmation dialog prior to deleting the selected 
parts

Sort... Allows the part list to be sorted in various ways.  Also controls 
how the part list will be viewed (flat or with parent hierarchical 
information) and what will be shown

(+)/(-) Expands or contracts the part list to be the vertical size of 
EnSight.

Fit Button A Fit button has been added to the row of buttons immediately under the 
graphics window.  This will keep the current transformations and make the 
currently visible parts “fit” the graphics window.

Selection Tool A Selection Tool transformation mode icon has been added to the right of 
rubber band zoom.  This tool brings up a selection tool that can be used for:
    (a) Rubber band zoom
    (b) Selecting all parts inside the box
    (c) Element blank (see below) the elements within the box
The Selection tool has also been added to the Reset and Transformation dialogs.

Element Visual 
Representation

Element Visual Representation now contains new options:
    3D feature, 2D full
    3D Non-Visual, 2D full

Palette Legend You can now modify the title of a palette legend

Record Button A record button (red circle icon located immediately above the graphics 
window) has been added.  The icon is not available if there is no animation 
available to record.  The following will activate the icon:

flipbook running
particle traces animating
clip/iso in interactive auto mode
spin mode
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Flipbook Dialog The flipbook dialog has been rearranged to separate run from load. The run tab 
has been changed to show vcr style buttons and a display option (flipbook or 
original model) has been added.  A triple slider is now in use controlling the 
begin/current/end display page.  The record button has been removed - use the 
record button (red circle) found immediately above the graphics window.  
When a flipbook is loaded it will automatically start playing.

Solution Time Dialog The solution time dialog has been rearranged and now includes a VCR type 
interface which will stream through the timesteps.  A triple slider has been 
created which shows the start, current, and end time. When in play mode the 
timesteps may be recorded by going to the record button (red circle) 
immediately above the graphics window.  The solution time dialog also 
contains a shortcut that will display a time annotation.

Animating Time
Queries

Animating time queries can now show a marker on the curve instead of 
sweeping the curve out on the plotter (which was previously the only behavior).

Contour Dialog Contour dialog now includes an option to color the resulting contour part by the 
creation variable.  It is on by default.

Isosurface Dialog The isosurface dialog by default sets the value to “MID-RANGE”.  If not 
replaced by the user the resulting value will be at the mid variable value.  Also 
added is user interface which allows multiple surfaces to be created with a delta 
value.

Clip Dialog Clip dialog includes the same default behavior as the isosurface dialog.  Also 
contains the multiple clip creation via a delta value.

Vector Arrows Vector arrow dialog contains same default behavior as the isosurfaces.

Vector arrows may now have cone shaped arrow tips.

Subset Parts There is now the ability to pick (one at a time) elements from the graphics 
window into the subset part.  You can also select a region of elements using the 
selection/region tool.

File File pulldown now contains a Open... button which will bring up a dialog 
allowing a dataset with a known file extension to be read using a configured 
part load method.  The file extensions are mapped to the readers via the 
ensight_reader_extension.map file located in the CEI_HOME/ensight80/
site_preferences directory and overwritten by the same file found in the user’s 
.ensight8 directory.

A most recently read list is now maintained and is available from
File->Open Recent Data File (unix - windows available from the File pulldown 
directly). If the file was opened from File->Open, the dataset will be read and 
loaded.  If the file was opened from File->Data(reader), the Data Reader dialog 
will appear with the information filled in the fields.

File->Save->Commands from this Session has been added.  This will save the 
command file up to the point of saving the file.

File->Save->Scenario now contains a file format for CSF
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POVRAY POVRAY has been added as a print format.  This creates an interface which 
will produce high quality images via ray tracing which include reflections, 
shadows, etc.

Edit Preferences Edit->Preferences->Mouse&Keyboard now contains many more options to 
allow mouse button combinations.

Edit->Preferences->Performance contains a “Save Under” option.  This option 
will save the pixels from the screen and repaint them if a expose event is 
detected.  The option is off by default.  IT IS HIGHLY RECOMMENDED 
THAT USERS WITH LARGE MODELS TURN THIS TOGGLE ON.

Simple Palette Editor The “Simple” palette editor now contains an option to set the palette min/max 
value to the value of the parts selected

P-Buffer Support P-Buffer support has been added for Linux (if available).

Failed Element
Support

Failed element support has been added.  This function will remove elements 
(complete elements) based on a failure criteria.  The elements are removed on 
the EnSight server so removal affects all functionality such as variable creation, 
element representation, part creation, etc.  A User Defined Reader (UDR) can 
set a failure criteria from within the reader.  If this is the case, failed elements 
will be used (culled) by default.

Element Blanking Element blanking has been added.  This allows a user to select an element 
(either pointing to it via the mouse or using the Selection tool) and remove it 
from the display.  This is a client only function. The removed elements are the 
ones closest to the viewer.  The function has no concept of changing 
connectivity transient problems.  The elements that were blanked before a time 
change will be the same elements after the time change.

Light Source Light source location has been added to viewport mode.  The light source can 
either be placed at an absolute location or be offset from the viewer.

The default diffused lighting intensity has been changed from 0.1 to 0.2.

Viewport
Background

Viewports can now display a bit map image.  EnSight Gold only. The bitmap 
can be .xpm or .bmp

Logo Files Annotation logo files can now read .bmp files in addition to .xpm files.

Tracking A Viewport may now track the movement of an object.  Several options exist 
for what it tracks.

Fast Display Mode Fast display mode now allows a reduced polygon representation.

Partice Traces Patricle traces can now have arrows drawn along the trace indicating direction.  
The number and size may be controlled.  The trace time is automatically set to a 
reasonable default value.

Tool Hotpoints While in Part and Frame mode, the mouse cursor now changes when over the 
tool (cursor, line, etc.) hotpoints.

Boundary Layer
Variables

Added Distance to Value and Y1 Plus variables. Both are found in the 
calculator.
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Archives and Command Language
Archives are NOT compatible between earlier 7.x versions and 8.0
Command language IS compatible between earlier 7.x versions and 8.0

Readers By default (see CEI_HOME/ensight80/site_preferences/
ensight_reader_prefs.def) the following readers have been removed from the 
Format list in the Data Reader dialog:

ANSYS (replaced by new Ansys reader)
ESTET
Fluent Universal
Movie.BYU,
MPGS 4.1
N3S
Vectis

If you wish to make these available, you can turn them back on by simply 
editing or removing the above file.
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Release notes from EnSight 7.4 to EnSight 7.6 
Index

   Installation
   Licensing
   Documentation
   GUI Changes
   New and Modified Features
   Archives and Command Language

Installation
EnSight 7.6 will install itself under INSTALL_DIRECTORY/CEI/ensight76 and will not modify any files 
previously installed with earlier versions.

The environment variable CEI_HOME must now be set to point to the INSTALL_DIRECTORY/CEI 
directory and the user’s path must include $CEI_HOME/bin. For example:

setenv CEI_HOME /usr/local/CEI
set path = ($path $CEI_HOME/bin)

It is not necessary to set the CEI_ARCH environment variable unless you want to override the default (i.e., 
you’re running on a 64 bit architecture and you want to run a 32 bit executable).

By design, the ensight7, ensight7.client, ensight7.server, and ensight7.sos scripts in the bin directory will 
run the version of EnSight installed last (7.6). You can also run version specific scripts if you want to run 
an older version (i.e., you can run 7.4 by executing “ensight74”).

Licensing
If you are upgrading from EnSight 7.3 please see the EnSight 7.3 to EnSight 7.4 release notes.

If you are upgrading from EnSight 7.4 and you are using a floating license (i.e., the slim7.key file located 
in the license directory contains a “slimd” line) you will need to be sure to install the new version of the 
license manager which comes with 7.6 as you install EnSight.  You then must restart the license manager.

Documentation
The User, How-To, Command Language, and Getting Started manuals have all been updated to reflect 
changes in 7.6.

GUI Changes
The z-clip button has been removed from the transformation icon list at the bottom of the interface. If you 
need to modify the z-clip parameters you will now need to access it via Transf.Edit...->EditorFunction->Z-
Clip.

The “Last” button has been removed from the standard view icon list at the bottom of the interface. It has 
been replaced with “Store” and “Recall” buttons.

The Scale icon has been removed from the transformation icon list at the bottom of the interface. To scale 
bring up the Transformation Editor (Transf.Edit...).

The Transformation editor has been modified to decouple it from the transformation mode set in the main 
interface. The “About Axis” pulldown has been removed in favor of toggle buttons.

The Part Element Representation icon has been changed to Part Element Settings and is now a pop-up 
dialog which incorporates element representation and polygon reduction.

The mirror symmetry icon has been replaced by a Visual Symmetry icon which now pops up a dialog. The 
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pop-up controls not only mirror symmetry but also rotational symmetry.

The slider bars for isosurfaces and clip parts are now active even when the part is not in interactive mode - 
the update to the part value occurs when the slider is released.

It is now possible to indicate surface restricted traces from the particle trace quick interaction dialog.

The keyframe animation dialog has been significantly modified to take into account new functionality as 
well as rearrange current functionality.

Part defaults attributes have, in the past, been editable when modified with no parts selected. Now they are 
editable only if the Preference (see Preferences->Parts) is set to allow this.

New and Modified Features

Besides the many bug fixes provided in 7.6, new/modified functionality includes:

Autorecover Should EnSight terminate an auto-recover file (EnSight command file) is usually 
available at the next execution.

Animated Traces A new head type of “arrow” is now available for animated particle traces.

Anti-aliasing Can now start with a -multi_sampling option to produce anti-aliased images.

Axis The coordinate axis is now on by default and sporting a new look. To set the 
default to not show the axis see Edit->Preferences->View, set the Axis display off 
and select the “Save to Preference File” button.

Batch Stereo Stereo images can be generated in batch mode - even on non-stereo capable 
hardware.

Clips R, Theta, Z clips are now possible.
The box clip now uses a box tool which can be interactively transformed. The box 
clip now performs the same clip operations as the other tools, i.e., intersect, in, 
out, in/out, crinkly

Collaboration Is now available to standard EnSight users. The collaboration hub will, however, 
check out an ensight token from the license manager (at most one token will be 
checked out) if a collaborator does not have a gold license token.
Collaborators can join up at any time and can break off at any time.
Is now available for Windows users.
Multiple collaborators are supported.

Context Context files can now be saved/restored for multiple cases.

Contours Can now be generated either tied to the variable palette (default), or by specifying 
the min/max values.
Labels now show value (previously showed level) for contour. Format can also be 
specified as either “floating” or “exponential”.
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Data Material fractions are now supported.
The SoS case file now supports multiple network interfaces.
The SoS case file can now auto-distribute block structured datasets to multiple 
servers.

Data Reader A HDF5 user defined reader is available.
The STL user defined reader has been improved to support multiple parts.

Display Offset Has been removed from the quick interaction dialogs. EnSight now uses hardware 
display offset (when turned on).

Emitters Particle traces can now be generated using a file emitter. 

Hidden Line Is now active during transformations.

Keyframe Animation Timelines have been added that give you the ability to easily control when and 
how transient data is used.
Quick animation has been added which gives you the ability to create fly-around, 
rotate, and exploded view standard animations.
If a detached display is used you can record images from these displays.
Acceleration control has been added.
Spline control has been added for translates and look-from modifications.
Resets and/or view restores can now be used with the keyframer. The “shortest” 
path is used between current transform state and the new state.

Material Interface Given material volume fractions you can create the interface or domain between 
multiple materials.

Mouse Space mouse and ball are now supported.

New Variables OffsetField to compute a scalar field which is the distance from the surface in the 
normal direction.
Dist2Nodes to compute the distance between two nodes.
Constant variables can now be used in place of numeric input for all of the Plot3D 
functions.

Periodicity Rotational periodicity can now be about any axis.

Plane Tool Can now be specified by an origin and a normal. The origin and normal can also 
be picked.

Polygon Reduction The number of polygons used for the graphics display can be reduced in order to 
improve interactivity (at the cost of fidelity)

Textures 1D texture maps can be used for coloring by a variable. The default continues to 
be RGB mode. See Edit->Preferences->Color Palettes.

Plotting A query can be independently scaled in the x and y directions for display 
purposes. 
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Archives and Command Language
Archives are NOT compatible between earlier 7.x versions and 7.6
Command language is compatible between earlier 7.x version and 7.6

Preferences To set RGB vs. 1D textures
To set the default view orientation.
To automatically reset the legends when a time step occurs.
To use a click-slide-hold for zoom operations as opposed to the default 
click_drag.

Save Geometry Brick of Bytes and Brick of Floats formats now supported for volume rendering.
User defined writers are now supported. Implemented are a STL, HDF5, and 
comma delimited writers.

SoS Incorporates full functionality except interactive operations.

Store/Recall A Store/Recall (view) button has been added next to the standard view buttons.

Undo Transformations including tool transforms can now be undone or redone.

User-defined Reader 
API 

Material fractions are now supported.
N-sided/N-faced elements are now supported.
Structured block ranges are now supported 

Visual Symmetry Mirror or rotational visual symmetry can now be specified (but not at the same 
time). 

VR A time slider is now available through the HUM
A variable list is now available through the HUM
A command now exists to color a part selected in the HUM by a variable selected 
in the HUM.
Can now display annotations and plots on VR walls

Zoom A new preference exists (see above) to allow you to click and drag/hold to zoom 
the scene. The zoom continues as long as the mouse button is down.
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Release notes from EnSight 7.3 to EnSight 7.4 
Index

   Installation
   Licensing
   Documentation
   GUI Changes
   New and Modified Features
   Performance
   Archives and Command Language

Installation
EnSight 7.4 will install itself under INSTALL_DIRECTORY/CEI/ensight74 and will not modify any files 
previously installed with earlier versions.

The environment variable CEI_HOME must now be set to point to the INSTALL_DIRECTORY/CEI 
directory and the user’s path must include $CEI_HOME/bin. For example:

setenv CEI_HOME /usr/local/CEI
set path = ($path $CEI_HOME/bin)

The scripts that start EnSight will figure out what architecture you are running, thus it is no longer 
necessary to set the CEI_ARCH environment variable unless you want to override the default (i.e., you’re 
running on a 64 bit architecture and you want to run a 32 bit executable). In this case use the CEI_ARCH 
environment variable (EnSight 7.4 does not use the ENSIGHT7_ARCH environment variable).

By design, the ensight7, ensight7.client, ensight7.server, and ensight7.sos scripts in the bin directory will 
run the version of EnSight which was installed last. Starting with EnSight 7.4, EnSight versions will also 
get version specific scripts (i.e., you can run 7.4 by executing “ensight74”).

Should you currently have EnSight 7.3 installed, be sure that the user’s path includes $CEI_HOME/bin 
before $ENSIGHT7_HOME/bin so that ensight7 will run the latest version.

Licensing
The license key must now be installed in the INSTALL_DIRECTORY/CEI/license/ directory. If you are a 
current EnSight user (i.e., using EnSight 7.3 or earlier) you do not need to restart the current license 
manager (slimd) - simply place a copy of the slim7.key file from your old installation into the new license 
directory. However, future updates to the SLiM will apply only to the version found in 
INSTALL_DIRECTORY/CEI/license/. So you will wish to switch over to this version of SLiM in the near 
future.

Documentation
A new Command Language Manual is now available.

GUI Changes
Command files will now play when the mouse is in the graphics window.

Animations (animated iso/clips, flipbooks, animated traces, etc.) will play even when the mouse is not in 
the graphics window.

Access to the surface restricted particle options have been added to the particle trace quick interaction area.
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New and Modified Features

Besides the many bug fixes provided in 7.4, new/modified functionality includes:

Animation Holds have been added to the keyframe animator.
An auto mode has been added to XYZ and IJK clips similar to the isosurface 
functionality.

Bounds Bounding box with tick marks and coordinates can be displayed for both 2D and 
3D viewports.

Case When new cases are added it is now possible to automatically place the new case 
geometry into a new viewport, apply a mirror symmetry, and/or apply a context 
file from case 1.

Center of Transform Previous versions of EnSight use the Look-At point as the center of transform. 
The transformation centroid has now been separated from the look-at point. In 
addition the centroid can be modified without having to reset previous transforms.

Clips A “crinkly” surface can now be generated.

Collaboration Collaboration between two EnSight Gold sessions are now possible.

Data A general cell type is now supported. 
Per element variables can now be shown as continuously colored without having 
to generate a per-node variable. Further, the ability to contour a per-element 
variable has been added.
Ghost cells are now supported.

Data Reader A boundary file can now be read which defines the IJK bounds for surface 
extractions from structured data (Plot3D, EnSight6, and EnSight Gold). EnSight’s 
boundary format, as well as Fieldview’s .fvbnd format are supported. Parts 
described in the boundary file will be unstructured. Once in the part loader, look 
for them under the unstructured tab.
Preferences now exist to limit the number of formats visible in the Format 
chooser.

The Dytran reader has been extended to read Dytran .dat files. This eliminates the 
need for creating a casefile when multiple .ARC files are present in the model.

Also Dytran .ths files can be imported directly into EnSight’s query/plot section.

Interactive Query The interactive query dialog has been modified so that multiple variables can be 
queried simultaneously.

Legends The default size and location has been changed to the lower right corner of the 
graphics window. Also the preference for automatically turning on the legend 
when a part is colored by a variable is now by default on. To get the old behavior 
(namely, not automatically show the legend when a part is colored) go to Edit-
Preferences->Color Palettes and turn off the preference for “Display Legend 
When Part is Colored”, then click on “Save To Preference File”.
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Massed Particles Particles can now be traced with drag, gravity, and pressure force terms.

Math Functions Less Than (LT), Greater Than (GT) and Round (RND) have been added as math 
functions in the calculator.

New Variables 1D Force has been added to the calculator.
It is now possible to set preferences to minimize the list of predefined functions.
It is now possible to provide your own predefined functions for the calculator 
through the use of User Defined Math Functions (UDMF).

Part Loading Plot3D now uses the standard EnSight part loader.
It is now possible to specify a delta offset for structured parts in order to extract 
multiple surfaces (or thick slices).
It is now possible to specify a negative number for the maximum I/J/K value 
indicating maximum value minus specified value.
Transformations are no longer reset when loading additional parts.

Plotting A preference can now be set to automatically plot any new query.

Preferences A preference can be set to automatically average per element variables to the 
nodes for fringe and contour display on the client.

Query Queries of two variables (i.e., “scatter plots) generated over time or distance have 
been added.
It is now possible to scale and/or add queries together.
The marker size now automatically sizes itself according to the current view.

Rubber Band Zoom Rubber Band Zoom operations now maintain perspective if in use. The center of 
transform is also modified during this operation to lie at the center of the selected 
geometry.

Save Geometry STL files can now be saved from EnSight.

User-Defined
Input API

The user-defined input device API has been updated to version 2.0. Libraries 
using the version 1.0 API are no longer supported. See $CEI_HOME/ensight74/
src/input/README.v2 for more information on updating to the latest interface.

Vector Arrow The surface normal can now be shown as vector arrows.

Viewports The main viewport can now be 2D. It will automatically change to 3D if out-of-
plane geometry is received and made visible in this viewport.

VR It is now possible to display to non-planar displays such as CAVE and RAVE 
configurations.
A part list and part attribute slider are now available for display together with the 
HUM.
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Performance
EnSight Gold now uses a new multi-pipe configuration file.

The SoS functionality has been expanded to include all functions except particle traces and some new 
value computations/queries.

The EnSight Gold client can now build the geometry display lists in parallel (must use the 
ENSIGHT7_MAX_CTHREADS environment variable). Improvements have also eliminated the need to 
build both solid and wireframe displays when in shaded mode.

Archives and Command Language
Archives are NOT compatible between earlier 7.x versions and 7.4

Command language is compatible between earlier 7.x version and 7.4
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