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Introduction
Use the Online Documentation

INTRODUCTION
The EnSight online documentation consists of:

WHERE TO START?
If you are new to EnSight you should read the EnSight Overview article.  Chapter 1 and Chapter 5 in the User 
Manual also provide overview information.  The Introduction to Part Creation provides fundamental information on 
EnSight’s part concept.

ACROBAT READER
The EnSight online documentation uses the Acrobat® Reader software from Adobe Systems, Inc.  Acrobat Reader 
provides much the same functionality as a World Wide Web browser while providing greater control over document 
content quality.  See How To Use the How To Manual for more information on Acrobat Reader.

Installation Guide Consists of a .pdf file in the doc directory (as well as being available for easy reading 
from the web install page). Also goes out as hardcopy with an EnSight distribution CD.

Getting Started
Manual

The Getting Started Manual contains basic Graphical User Interface overview 
information and several tutorials. This manual is not cross-referenced with any of the 
other manuals.

How To Manual The How To documentation consists of relatively short articles that describe how to 
perform a specific operation in EnSight, such as change the color of an object or 
create an isosurface.  Step-by-step instructions and pictures of relevant dialogs are 
included.  In addition, each How To article typically contains numerous hyperlinks 
(colored blue) to other related articles (and relevant sections of the User Manual).

Note that, although the entries in the How To table of contents and index are not 
colored blue, you can still click on an entry and jump to the appropriate document.

How To Use the How To Manual
How To Table of Contents
How To Index

User Manual The User Manual is a more traditional document providing a detailed reference for 
EnSight. The User Manual contains blue hyperlinks as well. Both the User Manual 
table of contents and index entries are hotlinked as well as cross-reference entries 
within chapters (which typically start with “See Section ...” or “See How To ...”).

User Manual Table of Contents
User Manual Index

Command Language
Manual

The Command Language Reference Manual documents command language used 
within EnSight. This manual contains some cross-references to the How To and User 
Manuals, but cross-referencing from them back is extremely minimal.
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HOW TO PRINT THE DOCUMENTATION

Printing Topics From The Acrobat Reader
You can easily print any topic in the How To manual or any pages from the other documentation from within Acrobat. 
The documents have been optimized for screen manipulation, but will still produce decent hardcopy printouts. To print 
a topic:

1. Navigate to the topic you want to print.
2. Choose Print... from the File menu of Acrobat Reader.
3. Be sure the Printer Command setting is correct for your environment and then click OK.  Your document should 

print to the selected (or default) printer.  If you do not have a printer available on your network or you wish to save 
the PostScript file to disk, you can do so: click the File button, enter a filename, and click OK.

Printing EnSight Manuals
You can print (all or portions of) the EnSight manuals from provided .pdf files. These files have been print optimized 
and should produce reasonably high quality hardcopy. They have all been formatted for letter size paper. These files 
are located in the doc/Manuals directory of the EnSight installation.

$CEI_HOME/ensight80/doc/Manuals/GettingStarted.pdf
$CEI_HOME/ensight80/doc/Manuals/HowTo.pdf
$CEI_HOME/ensight80/doc/Manuals/UserManual.pdf
$CEI_HOME/ensight80/doc/Manuals/CLmanual.pdf

You can open these manuals in Acrobat and print any or all pages, or send them to an outside source for printing.

CONTACTING CEI
If you have questions or problems, please contact CEI:

Computational Engineering International, Inc.
2166 N. Salem Street, Suite 101
Apex, NC 27523  USA

Email: support@ensight.com
Hotline: 800-551-4448 (U.S.)

919-363-0883 (Non-U.S.)
Phone: 919-363-0883
FAX: 919-363-0833
WWW: http://www.ceintl.com     or     http://www.ensight.com
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Using The How To Manual

INTRODUCTION
The “How To” documentation provides quick access to various topics of interest.  The topics provide basic and some 
advanced usage information about a specific tool or feature of EnSight.  Each topic will provide links to the 
appropriate section of the EnSight User Manual as well as links to other applicable How To articles.

Topics typically contain the following sections:

(See below for how to quickly jump to a specific section.)

The header and footer of each article page provides simple navigation controls:

In addition, links to other documents are displayed as highlighted text. Note that all links and navigation controls 
(except index and table of contents) are colored blue.

ACROBAT READER
The EnSight online documentation uses the Acrobat® Reader software from Adobe Systems, Inc.  Acrobat Reader 
provides much the same functionality as a World Wide Web browser while providing greater control over document 
content quality.  The user interface is very simple and provides intuitive navigation controls.  Keep in mind that the 
pages were designed to be viewed at 100% magnification.  Although you can use other magnification settings, the 
quality of the dialog images may be degraded.

The Acrobat Reader toolbar provides quick access to various display options and navigation controls.

The “Go back/forward” buttons are particularly useful – they operate somewhat like the “Back” and “Forward” buttons 
on standard Web browsers.  If your previously viewed page was in a different document, Acrobat will automatically 
reload the appropriate file and jump to the correct page.  Note that Acrobat also considers a change of view (e.g. 
scrolling) or magnification as an event to remember in the back/forward list.

For additional information on Acrobat Reader, you can load the online help by selecting “Reader Online Guide” from 
the Help menu.

Introduction Introduction to the topic
Basic Operation Quick steps for simple usage
Advanced Usage Detailed information on topic
Other Notes Other items of interest
See Also Links to related topics and documentation

Return to How To 
Topics List

Access this page

First page of 
current topic Last page of 

current topic

Previous page
Next page

Display setting:
  Page only or
  Page with Bookmarks or
  Thumbnails

Grab and move page

Click and zoom in
(Ctl-click to zoom out)

Select text

Standard page
navigation

Standard page
magnifications

Go back to last
viewed page

Go forward to previously 
viewed page

Search for text

Print
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Each How To topic provides a set of bookmarks that match the standard section titles.  You can quickly navigate to 
one of these sections by using the bookmark list in the left column of the Acrobat user interface:

PRINTING

Printing Topics From The Acrobat Reader
You can easily print any topic in the How To manual or pages from the other documentation from within Acrobat. The 
documents will produce decent hardcopy printouts. To print a topic:

1. Navigate to the topic you want to print.
2. Choose Print... from the File menu of Acrobat Reader.
3. Be sure the Printer Command setting is correct for your environment and then click OK. Your document should 

print to the selected (or default) printer. If you do not have a printer available on your network or you wish to save 
the PostScript file to disk, you can do so: click the File button, enter a filename, and click OK.

Printing EnSight Manuals
You can print (all or portions of) the EnSight manuals from provided .pdf files. These files have been print 

optimized and should produce reasonably high quality hardcopy. They have all been formatted for letter size paper. 
These files are located in the doc/Manuals directory of the EnSight installation.

$CEI_HOME/ensight80/doc/Manuals/GettingStarted.pdf
$CEI_HOME/ensight80/doc/Manuals/HowTo.pdf
$CEI_HOME/ensight80/doc/Manuals/UserManual.pdf
$CEI_HOME/ensight80/doc/Manuals/CLmanual.pdf

You can open these manuals in Acrobat and print any or all pages, or send them to an outside source for printing.

Be sure Bookmark/Thumbnails 
display is selected

Click the turndown to hide 
or reveal subsections

Click on any title to jump to 
that section

Be sure Bookmarks tab is 
selected
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EnSight Overview

ENSIGHT OVERVIEW
EnSight is a powerful software package for the postprocessing, visualization, and animation of complex datasets.  
Although EnSight is designed primarily for use with the results of computational analyses, it can also be used for 
other types of data.

This document provides a very brief overview of EnSight.  Consult Chapter 1 in the User Manual for additional 
overview information.  This article is divided into the following sections:

Graphical User Interface
Client / Server Architecture
EnSight’s Parts Concept
Online Documentation

Graphical User Interface
The graphical user interface (GUI) of EnSight contains the following major components:

Chapter 5 in the User Manual provides additional overview information on the user interface.

Main Menu
Feature Icon Bar
Sets the current feature.  Click an 
icon to open the associated Quick 
Interaction area.

Main Parts List
All parts from your model as well as 
created parts (e.g. clips, isosurfaces) 
are listed here.  Click an item to 
select part(s) to operate on.

Mode Selection Area
Sets the major mode of EnSight (Part, 
Annot, Plot, VPort, ...) and loads the 
applicable set of icons into the 
vertical Mode Icon Bar. Click the 
button to select the Mode.

Mode Icon Bar
The set of icons associated with the 
current Mode. Click the icon to 
access the function. If Tool Tips are 
on (bottom right of desktop), the 
icon’s function name will be shown 
when mouse is over the icon. If 
necessary, use the vertical scroll bar 
to access the remainder of the icons.

Transformation Control Area
Buttons that control the current 
transformation operation (e.g. rotate 
or translate) associated with mouse 
action in the Graphics Window.  Other 
buttons open dialogs providing 
detailed transformation control.

Information Area Button
Click to see information dialog.

Message Area
Quick Interaction Area
Interface controls associated with the current 
feature selected from the Feature Icon Bar.

Graphics Window showing inset plot and viewport

Note: This whole upper level of the GUI 
is referred to as the “Desktop”
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Client / Server Architecture
To facilitate the handling of large datasets and efficiently use networked resources, EnSight was designed to 
distribute the postprocessing workload.  Data I/O and all compute intensive functions are performed by a server 
process.  The server transmits 3D geometry (and other information) to a client running on a graphics workstation.  
The client handles all user interface interaction and graphic rendering using the workstation’s built-in graphics 
hardware.

The client and server each run as separate processes on one or more computers.  When distributed between a 
compute server and a graphics workstation, EnSight leverages the strengths of both machines.  When both tasks 
reside on the same machine, a stand-alone capability is achieved.  The client–server architecture allows EnSight to 
be used effectively, even on systems widely separated geographically.

Before EnSight can be used, the client and server must be connected. For standalone operation, you simply run the 
“ensight8” script and the client and server are started and connected for you. For distributed operation (as well as for 
standalone operation when more control is desired), there are two methods of achieving a connection: a manual 
connection (described in the Getting Started manual) or an automatic connection (described in How To Connect 
Automatically).

EnSight’s cases feature allows you to postprocess multiple datasets simultaneously.  Cases is implemented by 
having a single client connected to multiple servers running on the same or different machines.

EnSight’s Parts Concept
One of the central concepts of EnSight is that of the part.  A part is a named collection of elements (or cells) and 
associated nodes.  The nodes and/or elements may have zero or more variables (such as pressure or stress).  All 
components of a part share the same set of attributes (such as color or line width).

Parts are either built during the loading process (based on your computational mesh and associated surfaces) or 
created during an EnSight session.  Parts created during loading are called model parts.

All other parts are created during an EnSight session and are called created or derived parts.  Created parts are built 
using one or more other parts as the parent parts.  The created parts are said to depend on the parent parts.  If one or 
more of the parent parts change, all parts depending on those parent parts are automatically recalculated and 
redisplayed to reflect the change.  As an example, consider the following case.  A clipping plane is created through 
some 3D computational domain and a contour is created on the clipping plane.  The contour’s parent is the clipping 
plane, and the clipping plane’s parent is the 3D domain.  If the 3D domain is changed (e.g. the time step changes), 
the clipping plane will first be recalculated, followed by the contour.  In this way, part coherence is maintained.

One of the major modes of EnSight is Part Mode.  Operations in Part Mode (performed by clicking one of the icons in 
the vertical Mode Icon bar) operate on the parts currently selected in the Main Parts list.  See How To Select Parts 
for more information.

See the Introduction to Part Creation for more information on parts.

Online Documentation
Documentation for EnSight is available online. See How To Use the Online Documentation for more information as 
well as hyperlinks to the main documents. Online documentation is accessed from the Main Help menu in the user 
interface. In addition, major dialog windows contain Help buttons that will open a relevant “How To” article.

Server

Client

Stand-alone Operation

host1

Requests 3D objects

Server

Client

Distributed Operation

host2

host1
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Start EnSight
Connect Automatically

INTRODUCTION
EnSight is a distributed application with a client that manages the user interface and graphics, and a server that reads 
data and performs compute-intensive calculations. The client and server each run as separate processes on one or 
more computers. Before EnSight can do anything useful, the client process must be connected to the server process. 
For a standalone operation, you can simply start EnSight with the “ensight8” script and the client and server 
processes will be started and connected for you.   If you desire more control over the standalone operation or want to 
take advantage of a distributed operation, you have the options described below.

There are two basic types of connection: manual and automatic.  A manual connection is made by starting the client, 
telling it to listen for a server connection, and then starting the server (and telling it what machine the client is running 
on).  Manual connection is covered in detail in the How To Connect Manually.  Automatic connection is covered here.

BASIC OPERATION
The auto-connect mechanism requires that certain conditions exist in your computing environment:

On Unix Systems:
1. You have a valid .rhosts file in your home directory on all systems on which you wish to run the EnSight server. 

The file permission for this file must be such that only the owner (you) has write permission (e.g. 
chmod 600 ~/.rhosts). A .rhosts file grants permission for certain commands (e.g. rsh or rlogin) 
originating on a remote host to execute on the system containing the .rhosts file. For example, the following line 
grants permission for remote commands from host clienthost executed by user username to execute on the 
system containing the .rhosts file:

clienthost username

There should be one line like this for every client host system that you wish to be able issue remote commands 
from. It is sometimes necessary to add an additional line for each client host of the form 
clienthost.domain.com username (where domain.com should be changed to the full Internet domain 
name of the client host system).

2. You have a .cshrc file (even if you are running some other command shell such as /bin/sh) in your home 
directory on the EnSight server host that contains valid settings for CEI_HOME, and that your path variable 
includes the bin directory of CEI_HOME. For example, if your EnSight distribution is installed in /usr/local/
CEI and you are running EnSight on an SGI system (other architectures use a different library path variable), your 
.cshrc should contain: 

setenv CEI_HOME /usr/local/CEI
set path = ( $path $CEI_HOME/bin )

3. Your .cshrc file (or files sourced or executed from there) has no commands that cause output to be written (e.g. 
date or pwd). Any output would be interpreted as an EnSight server startup error.

4. You can successfully execute a remote shell command from the client host system to the server host system. The 
name of the remote shell command varies from system to system. While logged on to the client host system, 
execute one of the following (where serverhost is the name of your server host system):

rsh serverhost date
remsh serverhost date

If successful, the command should print the current date.

If any of these conditions are not met, you will be unable to establish a connection automatically and will have to use 
the manual connection mechanism.  Note that it is not uncommon for system administrators to disable operation of all 
remote commands for security reasons.  Consult your local system administrator for help or more information.
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On Windows Systems:
1. You have the EnSight server (ens80sv.exe) installed on the same system as your EnSight client (if you plan to 

connect to the same system)
       ---- OR ----

2. You can successfully execute a remote shell command from the client host system to the server host system. 
 
Note: While all Windows workstations have the ability to issue RSH (Remote Shell) requests, only systems 
running Windows Server have the RSH deamon and can respond by executing the EnSight server. 

The name of the remote shell command varies from system to system. While logged on to the client host system, 
execute one of the following (where serverhost is the name of your server host system):

rsh serverhost date
remsh serverhost date

If successful, the command should print the current date.

If condition 1. or 2. is not met, you will be unable to establish a connection automatically and will have to use the 
manual connection mechanism.   Note that it is not uncommon for system administrators to disable operation of all 
remote commands for security reasons.  Consult your local system administrator for help or more information.
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In an initial session, you must provide the connection information to EnSight.  Once this is done correctly, you can 
start future sessions and make the connection automatically.  To set up for an automatic connection:

Once an automatic connection has been successfully performed, you can start subsequent sessions of EnSight and 
connect automatically with the following command:

% ensight8

(This assumes that your command search path on the client host has been set up to include the client execution 
directory –e.g.   for Unix, set path = ( $CEI_HOME/bin $path ).

1. Select File > Connect... to open the Connect Server dialog.

2. Set the Type to Auto.

3. Enter the host name of the system on which you wish to run the EnSight 
server.

4. Enter the full path name of the EnSight server executable.
If the server executable is in your default command search path on the server 
machine, you do not have to provide the full path name – only the name of the 
server executable.

5. Enter the full path name of the directory from which you wish to start the 
EnSight server.

This is typically the directory containing your results files.  If this field is left 
blank, the working directory will default to the directory from which the client was 
started (if both client and server are running on the same system) or your home 
directory on the server system (if the server is running on a remote machine).

6. If your login name on the server host is different from your login name 
on the client host, enter your server login name here.

7. Click Connect Server to initiate the connection process.
See the Troubleshooting section below if the connection attempt fails.

8. Click Close to close the dialog.
You can restore the connection defaults (as stored in
~/.ensight8/ensight.connect.default) by clicking Show Server 
Defaults.

You can open the Connect Server dialog at any time and 
check the Transfer Summary.  This section shows how many 
bytes have been Sent from the client to the server and how 
many have been Received in return.
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TROUBLESHOOTING
An automatic connection can fail for any of several reasons. Because of the complexity of networking and customized 
computing environments, we recommend that you consult your local system administrator and/or CEI support if the 
following remedies fail to resolve the problem.

Problem Probable Causes Solutions

For Unix Systems:

Automatic connection fails or is 
refused

Server (remote) host name is 
incorrect for some reason.

Is the server host entered correctly in the Machine Name 
field? Try running telnet serverhost from the client 
machine.

Incorrect or missing .rhosts file 
in your home directory on the 
server host.

Follow the instructions on .rhosts files (as described in 
the Basic Operation section, step 1 above). If you cannot 
successfully execute a remote command (such rlogin 
or rsh) from the client host to the server host, you will not 
be able to connect automatically.

The user account (i.e. login name) 
on the client host does not exist on 
the server host.

Enter your login name on the server host in the Alternate 
Login ID field.

The server executable is not found 
on the server system

Is the entry in the Executable [path/]name field correct? If 
the server executable is NOT in your default command 
search path on the server, you must include the full path 
name to the executable. For example, /usr/local/
bin/ensight80/server/ensight8.server.

Your .cshrc does not contain a 
valid setting for CEI_HOME.

Add the appropriate line as described in the Basic 
Operation section, step 2 above.

Your .cshrc file (or files executed 
by it) causes output to be written. 
This is interpreted as a server 
startup error.

Remove the offending commands from your .cshrc file. 
As a test, do the following:

% cd
% mv .cshrc .cshrc-SAVE

Create a new .cshrc file that contains only the lines to set 
CEI_HOME and path as described in the Basic 
Operation section, step 2 above. If that test works, you 
will need to examine your .cshrc to find and remove the 
offending lines.

For Windows Systems:

Automatic connection fails or is 
refused (trying to connect to 
same host system)

Server not installed or not 
executable.

You should be able to locate the server executable 
(ens6sv.exe) using Windows Explorer. Double click on it 
and see if a console window opens with “This is EnSight 
Server 8.0” etc. If this doesn’t happen, refer to 
“Troubleshooting the Installation” in the Getting Started 
Manual.

Path to the server is incorrect If using the EnSight Connect dialog, check that the 
correct path is specified in the “default path” field.

If running from the ensight8 command, first ensure that 
your PATH environment variable contains the paths for 
the ensight8 “client” and “server” directories. You can 
check and correct the value of PATH in the Start 
>Settings >ControlPanel >System_Environment dialog.

Incorrect hostname entered in the 
“Machine Name” field of the 
Connect dialog.

Make sure that the hostname is correct, including the 
case of all letters. The ONLY way to confidently see the 
hostname (in the correct case) from Windows is to open 
a Command Prompt window and type:
>  ipconfig /all

The Host Name will be one of the first things listed.

Automatic connection fails or is 
refused (trying to connect to a 
remote server)

Same causes as for a Unix system See “For Unix Systems” portion of this table above.
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OTHER NOTES
The automatic connection information is stored in the file ~/.ensight8/ensight.connect.default. The 
information contained in this file is loaded to the text fields in the Connect Server dialog when it is opened. If required, 
the file can be edited with any text editor.

By default, the connection between the client and server uses a standard TCP/IP socket mechanism.  However, if an 
automatic connection is being made and EnSight determines that the server will be running on the same machine as 
the client, it will use a different connection mechanism (known as named pipes).  This mechanism results in much 
faster communications between the client and server (from 2 to 5 times speedup).  Automatic connection should 
therefore always be used when running both client and server on the same machine.

SEE ALSO
Chapter 2 of the Getting Started manual.

How To Connect Manually
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Connect Manually

INTRODUCTION
EnSight is a distributed application with a client that manages the user interface and graphics, and a server that reads 
data and performs compute-intensive calculations. The client and server each run as separate processes on one or 
more computers. Before EnSight can do anything useful, the client process must be connected to the server process. 
For a standalone operation, you can simply start EnSight with the “ensight8” script (or icon, if on a windows or Mac) 
and the client and server processes will be started and connected for you.   If you desire more control over the 
standalone operation or want to take advantage of a distributed operation, you have the options described below.

There are two basic types of connection: manual and automatic.  A manual connection is made by starting the client, 
telling it to listen for a server connection, and then starting the server (and telling it what machine the client is running 
on).  Manual connection is covered here.  Automatic connection is covered in How To Connect Automatically.

BASIC OPERATION

Necessary Prerequisites
EnSight must have been installed, the CEI_HOME and other ENSIGHT8 environment variables setup, and the 
command search path set properly. If you successfully performed the installation verification as described in the 
Installation Guide, you have verified that these things are correct.

(See $CEI_HOME/ensight80/doc/Manuals/Installation.pdf if you need this manual.)

Starting EnSight for Distributed Use - Manual Connection
Note: In the instructions that follow, CLIENT_HOST refers to the system on which the EnSight Client was installed and 
will be run, and SERVER_HOST refers to the system on which the EnSight Server was installed and will be run. 

1. Log onto to the client machine (CLIENT_HOST).
This can be a machine of any of the types on which EnSight runs (windows, mac, unix or linux 
machine).

2. Open two windows.
On a non-windows machine these would be shell or terminal windows.  On a windows machine 
these would be Command Prompt windows.

Note: Since the EnSight user interface comes up by default on the right side of the screen or 
desktop, it is helpful to place these two windows on the left side of the desktop.

3. In the first window, start the EnSight client by using the appropriate script  and the -cm 
option.

If the CLIENT_HOST machine is
Windows:             ensight8_client -cm     Note the difference ( . vs _ )
Non-Windows:    ensight8.client -cm

The -cm option tells the Client to begin listening for a connection from the Server.

Example in a linux 
machine shell window.

Example in a windows machine 
Command Prompt window.
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The Server should now make the connection. To see if the connection is successful, you can click on the Information 
button on the Desktop. You should see “Connection accepted” in the EnSight Message Window which comes up. 
Licensing information should also appear in the Graphics Window.  If the connection failed, please consult 
Troubleshooting the Connection in the Installation Guide before contacting CEI support.

The EnSight Client user interface should now appear on your screen.

4. In the second window, log onto the SERVER_HOST machine using telnet (or ssh or 
equivalent).

This CLIENT_HOST can be a machine of any of the types on which EnSight runs (windows, mac, 
unix or linux machine). It does not have to be of the same type as the CLIENT_HOST.

5. Start the ensight server on the SERVER_HOST machine, using the appropiate script and 
the -c option.

If the SERVER_HOST machine is
Windows:             ensight8_server -c CLIENT_HOST    Note the difference ( . vs _ )
Non-Windows:    ensight8.server -c CLIENT_HOST

The -c CLIENT_HOST option tells the EnSight Server to connect to the EnSight Client 
listening on CLIENT_HOST.

Example if telneted 
into a SERVER_HOST 
which is a windows 
machine

Example if telneted into a 
SERVER_HOST which is a 
linux machine.

Example of telneting from 
a linux machine to a unix 
machine.

Example of telneting 
from a windows 
machine to a 
windows machine.
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TROUBLESHOOTING
An manual connection can fail for any of several reasons. Because of the complexity of networking and customized 
computing environments, we recommend that you consult your local system administrator and/or CEI support if the 
following remedies fail to resolve the problem.

OTHER NOTES

Connecting to SOS instead of a regular server
To connect to a SOS (Server of Servers) instead of a regular server, you simply need to change step 5. to be:

5. Start the ensight server of server (SOS) on the SERVER_HOST machine, using the appropiate script and the -c option.
If the SERVER_HOST machine is
Windows:             ensight8_sos -c CLIENT_HOST    Note the difference ( . vs _ )
Non-Windows:    ensight8.sos -c CLIENT_HOST

SEE ALSO
Chapter 2 of the Getting Started Manual

How To Connect Automatically

Problem Probable Causes Solutions

For Unix Systems:

EnSight client does not start in 
step 3.

EnSight is not properly installed on 
the CLIENT_HOST

Verify the installation on the CLIENT_HOST as described 
in the Installation Guide.  Making sure that the proper 
environment variables and command path have been set.

Unable to telnet into the 
SERVER_HOST machine in 
step 4.

Telnet service not allowed or not 
running on the SERVER_HOST 
machine.

Get system administration help to be able to perform this 
operation.  It may be that your site requires the use of ssh 
or some other equivalent.

Ensight server does not start in 
step 5.

EnSight is not properly installed on 
the SERVER_HOST

Verify the installation on the SERVER_HOST as described 
in the Installation Guide.  Making sure that the proper 
environment variables and command path have been set.
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Command Line Start-up Options

INTRODUCTION
There are a number of options that can be included on the command line when starting EnSight. The following tables 
indicate the commands that can be issued for the EnSight script (ensight8), the EnSight client (ensight8.client), the 
EnSight server (ensight8.server), or the EnSight server-of-servers (ensight8.sos). To see the most current listing for 
any of these, issue one or more of the following:

ensight8 -help
ensight8.client -help
ensight8.server -help
ensight8.sos -help

BASIC USAGE
ensight8 [options]

or
ensight8.client [options]

Section 1.  EnSight Startup/Client-Server Options
-ar <f> Restore from specified archive file “f”
-c <host> Do an auto connection to machine named “host”. EnSight server will run on “host”
-case <f> Read EnSight casefile name ”f” and display part loader
-cm Do a manual connection of server
-collab_port <#> Specify the port for collaboration socket communication.
-ctx <f> Applies context file “f” as soon as connection is made
-custom Force the license manager to look for a custom token
-delay_refresh Graphics window is not updated during command file playback, until finished
-extcfd Extended CFD variables automatically placed in variable list
-externalcmdport Specify the port on which to receive external commands. See -externalcmds.
-externalcmds Has EnSight start listening for a connection on port 1104 (or the port specified with the     

-externalcmdport) for an external command stream. Once connected, all commands 
must then come from the external source - as the GUI commands will be ignored.

-gold Force the license manager to look for a gold token
-localhostname <host> Host name to force server(s) to use to connect to client
-no_delay_refresh Graphics window is updated during command file playback, until finished
-p <f> Plays playfile “f” as soon as connection is made
-ports # Allows user specification of socket communication port. (passed on to server or sos)
-prdist # Specify a parallel rendering distribution config file.
-rsh <cmd> Remote shell program to use for automatic connection. (passed on to server or sos)
-security [#] Forces a handshake between the client and server using the # provided or a random 

number
-sos Set up to connect to the Server-of-Servers (ensight8.sos) instead of normal server.
-soshostname <host> Host name to force server(s) to use to connect to Server-of-Servers
-standard Force the license manager to look for a standard token
-timeout <#> Number of seconds to wait for server connection; default = 60, infinite = -1
-token_try_again <#> If can’t obtain a license token, try again in # minutes. where # is a float value. If neither

 -token_wait_for nor -token_wait_until is specified, will try for 1 hour.
-token_wait_for # If can’t obtain a license token, try again for # minutes, where # is a float value.

If -token_try_again is not specified, sets -token_try_again to 10.
Supersedes -token_wait_until.

-token_wait_until # If can’t obtain a license token, try again until the time is hour:minute. If -token_try_again 
is not specified, sets -token_try_again to 10.

-v Prints out EnSight’s version number.  (Does not start EnSight)
-version Prints out EnSight’s version number.  (Does not start EnSight)

Section 2.  EnSight Client GUI Options
-ff Use the default EnSight fixed font
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-hc <c> Current Selection Highlight Color Name “c”
-iconlblf <#> Mode panel icon label font size
-largeicons Uses larger feature icons in EnSight. (default)
-ni Will use text in place of icons
-sc <c> Section Label color name “c”
-smallscreen Sets window attributes based on the screen size of 1024x768
-smallicons Uses smaller feature icons in EnSight.

Section 3.  EnSight Server Specific Options
-gdbg Print some debugging info for EnSight format geometries  (passed from client to server)
-iwd Ignore the working directory in the ensight.connect.default file
-time Prints out timing information  (passed from client to server)
-readerdbg Prints user-defined-reader library loading information in shell window upon startup of 

server  (passed from client to server)
-writerdbg Prints user-defined-writer library loading information in shell window upon startup of 

server  (passed from client to server)
-maxoff Turns off maxsize checking  (passed from client to server)
-scaleg <#> Provide scale factor to scale geometry by  (passed from client to server)
-scalev <#> Provide scale factor to scale all vectors by  (passed from client to server)
-swd <dir> Set the server working directory

Section 4.  Miscellaneous Options
-h,  -help,  -Z Prints the usage list
-helvetica Use Helvetica font instead of the default Times-Roman for annotation text in the 

graphics window
-inputdbg Prints user-defined input device information
-nb No automatic backup recording
-no_file_locking Turns off file locking (lock()). Some systems don’t support this properly
-no_prefs Do not load saved user preferences (uses all original defaults)
-range10 Use palette ranges which are 10% in from the extremes
-silent Causes all stdout and stderr messages to be thrown away
-slimtimeout # Allow slimd token to expire if idle.
-stderr <f> Cause all stderr messages to be written to the file.
-stdout <f> Causes all stdout messages to be written to the file.

Section 5.  Rendering Options
-batch <width>< height> Batch mode with optional width and height. Only available if running X version of 

EnSight, which you get by using -X option
-bbox Render only bounding boxes in the GUI window (useful for detached displays with

 -prsd2 option). (See How To Setup For Parallel Rendering)
-box_resolution <#> Resolution of bounding boxes for part culling (max 9). Implies -no_display_list
-ctarget Set the number of polygons per “chunk” target size for parallel rendering (passed from 

client to server(s)).
-dconfig Specify a display configuration file
-display_list Use OpenGL display lists
-frustrum_cull Use frustrum culling where possible
-glconfig Prints current OpenGL configuration parameter defaults to screen
-glsw Forces use of software implementation of OpenGL, bypassing the hardware graphics 

card (same as -X)
-gl Sets line drawing mode to draw polygons
-ogl Sets line drawing mode to draw lines
-no_display_list Force EnSight to use immediate mode graphics
-no_frustrum_cull Do not use frustrum culling
-norm_per_vert Use one normal per vertex for flat-shading
-norm_per_poly Use one normal per polygon for flat-shading
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Client Examples:
       ensight8 -cm -p myplayfile

This will allow the user to do a manual connection, after which the “myplayfile” will be run.

       ensight8 -c -gold -ports 1310 -case myfile.case

This will do an automatic connection (according to information in the user’s ensight.connect.default file) on port 1310, 
using a gold seat. After the connection is made, the “myfile.case” casefile will be run.

       ensight8 -rsh ssh -hc yellow                (or   ensight8.client -c -rsh ssh -hc yellow)

This will use ssh as the remote shell for an automatic connection, and will set the highlight color to yellow (instead of 
the default color of green). 

-multi_sampling Turns MultiSampling on
-multi_sampling_sw Use software MultiSampling
-no_multi_sampling Do not use MultiSampling
-no_start_screen Ignore the start screen image (Good for HP using TGS OpenGL)
-num_samples <#> Specify number of samples for software multi-sampling
-num_samples_st <#> Specify number of samples for hardware stereo multi-sampling
-occlusion_test Use the HP occlusion extension if available
-no_occlusion_test Do not use the HP occlusion extension
-stencil_buff Use the OpenGL stencil buffer (even if not enabled by default)
-no_stencil_buff Assumes there is not a working stencil buffer (some Windows video cards)
-double_buffer Use double-buffering for the graphics window (default)
-single_buffer Do not use double-buffering
-sort_first Sets the default parallel rendering sorting method to be the sort first method
-sort_last Sets the default parallel rendering sorting method to be the sort last method
-unmapdd Don’t map the detached display on startup
-X Starts the X version of EnSight (uses Mesa OpenGL instead of native OpenGL, 

bypassing the hardware graphics card). This option is mandatory if the -batch option is 
desired. (This is the same as -glsw)

Section 5.  X Window Specific Options
-bg <c> Background Color colorname “c”
-fg <c> Foreground Color colorname “c”
-fn <fn> Font Name “fn”
-font <fn> Same as -fn

ensight8.server [options]
-c <host> “host” indicates where the client is running
-ctarget Set the number of polygons per “chunk” target size for parallel rendering.
-ctries <#> The number of times (1 second per try) to try to connect client and server.
-ether Ethernet device name such as ln0
-gdbg Print some debugging info for EnSight format geometries
-h,  -help Prints the usage list
-maxoff Turns off maxsize checking
-pipe Forces the server to use a named pipe connection (must be on same machine)
-ports <#> Allows user specification of socket communication port.
-readerdbg Prints user-defined-reader lib loading information in shell window upon startup of server
-writerdbg Prints user-defined-reader lib loading information in shell window upon startup of server
-sock Forces the server to use a socket connection
-time Prints out timing information
-scaleg <#> Provide scale factor to scale geometry by
-scalev <#> Provide scale factor to scale all vectors by
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Server Examples (when started manually):
       ensight8.server -c clientmachine -readerdbg

Specifies “clientmachine” as the machine on which the client is running, and that information on user-defined-reader 
library loading should be printed out.

       ensight8.server -ports 1310 -scaleg 10.0 -scalev 10.0

Specifies that communication is to occur on port 1310, and that the geometry and all vectors are to be scaled by a 
factor of 10.

SOS (Server-of-Servers) Examples (when started manually):
        ensight8.sos -c clientmachinename -soshostname sosmachinename

Specifies “clientmachinename” as the machine on which the client is running, and that the individual servers should 
connect back to “sosmachinename”.

      ensight8.sos -readerdbg -gdbg

Specifies that the sos and any servers print out user-defined-reader library loading information, and that the servers 
print out EnSight data format geometry loading information.

-security <#> Provide number for client to server security check
-soshostname <host> Allows different name for servers to connect back to Server-of-Servers with

ensight8.sos [options]
-c <host> “host” indicates where the client is running
-cports Allows specification of socket communication port to the client.

See also -ports, -sports.
-ctarget Set the number of polygons per “chunk” target size for parallel rendering (passed on to 

servers).
-ctries <#> The number of times (1 second per try) to try to connect client and server.
-ether Ethernet device name such as ln0
-gdbg Print some debugging info for EnSight format geometries  (passes on to servers)
-h,  -help Prints the usage list
-maxoff Turns off maxsize checking  (passes on to servers)
-pipe Forces the server to use a named pipe connection (must be on same machine) (passes 

on to servers)
-ports <#> Allows user specification of socket communication port. (passes on to servers)

Has the effect of setting -cports and -sports to be the same.
-readerdbg Prints user-defined-reader library loading information in shell window upon startup of 

server  (passes on to servers)
-writerdbg Prints user-defined-reader library loading information in shell window upon startup of 

server  (passes on to servers)
-rsh <cmd> Remote shell program to use for automatic connection of servers. (passes on to servers)
-sock Forces the server to use a socket connection
-scaleg <#> Provide scale factor to scale geometry by  (passes on to servers)
-scalev <#> Provide scale factor to scale all vectors by  (passes on to server)
-security <#> Provide number for client to server security check  (passes on to servers)
-soshostname <host> Allows different name for servers to connect back to Server-of-Servers with  (passes on 

to servers)
-sports Allows specification of socket communication port to the servers.

See also -ports, -cports.
-time Prints out timing information  (passes on to servers)
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Use Collaboration

INTRODUCTION

Collaboration between an EnSight session (Client and Server) and another EnSight client can be accomplished via 
the EnSight collaboration hub. This feature provides a way for a user to allow another colleague to connect to his/her 
running EnSight session and interactively work in a master/slave manner. The master drives the session until the 
slave requests and is allowed to become the master (or Pilot). The colleague will only need to start an EnSight client 
because, when connected via the hub, they share the EnSight server of the originating user. The master will go about 
the normal postprocessing operations, but will be issuing commands to the slave client to perform transformations, 
part editing, etc., to keep the slave current.

The EnSight collaboration hub (ensight8.collabhub) is now available on the release CD. This hub can be run on any 
supported computer on the network to route data between the two clients and the server. The initial connection 
between the originating user’s client and server will be redirected through the hub when the connection is made. The 
colleague joins by contacting the hub which then asks the originating user if it is okay for this person to join the 
collaboration session. All communication between the server and client processes will transfer through the hub.

BASIC OPERATION

To start a new session:
1. Select File->Collaboration...

2. Select Session Control->New...

3. Enter Your Name.

4. Enter the Hub Hostname.

5. Enter the Hub Port Number.

6. Select Start Session to start the session and 
allow colleagues to make requests to join.

7. When a colleague requests to join your session 
you will be prompted with the name and machine 
information to allow them to join. Select the 
appropriate button as indicated in the dialog that 
pops up.
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OTHER NOTES
You close or “Break Off” your session in a similar manner under File -> Collaboration -> Session Control -> Break Off

To join session:
1. Select File->Collaboration...

2. Select Session Control->Join Existing...

3. Enter Your Name.
5. Enter the Hub Hostname given to you by the 

person who started the collaboration session.
6. Enter the Hob Port Number given to you by the 

person who started the collaboration session.
7. Select Join Session to request permission to join 

the session.
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Read and Load Data
Read Data

INTRODUCTION
EnSight supports a number of file formats common in computational analysis. In addition, CEI has defined generic 
data formats (in both ASCII and binary versions) that can be used for both structured and unstructured data. In many 
cases analysis codes output this data directly (i.e. FLUENT, STAR-CD, KIVA, etc.)

One-Step Quick Method (File->Open...)
     Ensight_reader_extension.map file example:
Two-Step Method (File->Data (reader)...)
     First Step (Specifying Files):
     Second Step (Loading Parts): 

BASIC OPERATION
One-Step Quick Method (File->Open...)
The one-step method of reading data into EnSight works for most formats and requires a file extension-to-reader 
mapping file (ensight_reader_extension.map). This file can reside in the site_preferences directory and/or each user 
can have his own personal one in his .ensight8 directory. A sample of this file is shown below. The mapping file 
associates file extensions to readers. If this file is not provided or an association is not known, or the format doesn’t 
allow it due to required intermediate information (such as Plot3D currently), the one-step method (Open...) will default 
to the first step of the two-step method (Data (reader)...)

Reading data into Ensight can be a one-step quick process if an association is 
known for the data format type and you wish to load all parts. This simplified 
method will be shown below. It is accessed under File->Open...

A two-step process is also available. It is accessed under File->Data (reader)...
This is the more traditional method for EnSight, and provides more control over the 
reading of data files and the part creation process. The first step is the selection of 
appropriate files. The second step is the loading of parts. Both steps have many 
similarities regardless of the data format. These basic steps are described below. 
Variations from the methods shown will be described in Chapter 2 (Reader Basics) 
of the User Manual for the various formats.

1. Select File > Open...
2. Select the desired data directory using 

the Directories list.
You can also enter a directory name directly 
in the Filter field to jump to that directory. The 
Filter can also provide file name filtering, e.g. 
using *.case to display in the Files list only 
those files that end with .case.

3. Select whether to replace any currently 
loaded data, or keep it and append the 
new data.

4. Select the desired file in the Files list.
This file’s extension is what will be mapped 
to a reader in the 
ensight_reader_extension.map.

5. Click Okay.
(Double clicking the file in step 4. is also 
allowed.)

At this point (provided the association is successful and the data is readable) all parts of the model will be loaded 
into EnSight and will appear in the graphics screen and in the Parts List.   If the association is not successful, the 
File Selection dialog for the Data (reader) method will appear and you will default to the two-step method.
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Ensight_reader_extension.map file example:
The following is a sample containing associations for EnSight Case, EnSight5, STL and MSC/Dytran:

EnSight file extension to format association file
Version 1.0
#
# Comment lines start with a #
#
#
# The format of this file is as follows:
#
# READER_NAME: reader name as it appears in the Format chooser in the EnSight Data Reader dialog
# NUM_FILE_1: the number of file_1_ext lines to follow
# FILE_1_EXT: the extension that follows a file name minus the “.”, i.e., “geo”, “case”, etc.
#             There should be one definition after the :.  Multiple FILE_1_EXT lines may exist
# NUM_FILE_2: the number of file_2_ext lines to follow
# FILE_2_EXT: the extension of a second file that will act as the result file.  This is only used
#             for formats that require two file names.  As with FILE_1_EXT, there may be multiple
#             FILE_2_EXT lines.
# ELEMENT_REP: A key word that describes how the parts will be loaded (all parts will be loaded the
#              same way).  One of the following:
#                               “3D border, 2D full”
#                               “3D feature, 2D full”
#                               “3D nonvisual, 2D full”
#                               “Border”
#                               “Feature angle”
#                               “Bounding Box”
#                               “Full”
#                               “Non Visual”
#              If option is not set then 3D border, 2D full is used
# READ_BEFORE: (optional) The name of a command file to play before reading the file(s)
# READ_AFTER: (optional) The name of a command file to read after loading the parts

# Definition for Case files

READER_NAME: Case
NUM_FILE_1: 2
FILE_1_EXT: case
FILE_1_EXT: encas
ELEMENT_REP: 3D feature, 2D full

# Definition for EnSight5 files

READER_NAME: EnSight 5
NUM_FILE_1: 2
FILE_1_EXT: geo
FILE_1_EXT: GEOM
NUM_FILE_2: 2
FILE_2_EXT: res
FILE_2_EXT: RESULTS
ELEMENT_REP: 3D feature, 2D full

# Definition for STL files

READER_NAME: STL
NUM_FILE_1: 2
FILE_1_EXT: stl
FILE_1_EXT: STL
ELEMENT_REP: 3D feature, 2D full

# Definition for Dytran files

READER_NAME: MSC/Dytran
NUM_FILE_1: 2
FILE_1_EXT: dat
FILE_1_EXT: ARC
ELEMENT_REP: 3D border, 2D full
READ_AFTER: ~/.ensight8/read_after_dytran.cmd
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Two-Step Method (File->Data (reader)...)
First Step (Specifying Files):
Each data format requires a different set of files for proper data loading. A table is provided below that briefly 
describes these files for various formats. Links to the User Manual are also provided - so you can get detailed 
information for each format
 

1. Select File > Data (Reader)...
2. Select the desired data directory  using 

the Directories list.
You can also enter a directory name 
directly in the Filter field to jump to that 
directory. The Filter can also provide file 
name filtering, e.g. using *.geo to display 
in the Files list only those files that end with 
.geo.

3. Select the desired format.
The list shown is dependent on the 
presence of internal and user-defined 
readers at your site, and on your 
preference settings.

4. If desired, specify a starting time
The default is the last time step, unless you 
have set a preference otherwise.

5. If the file is binary, set the correct byte 
order.
For most formats, EnSight can determine 
this automatically, and your selection is 
ignored. But if it can’t determine, it will use 
this selection.

6. Select the desired file(s) in the Files list 
one at a time and click the appropriate 
(Set) button for the file.
The required files vary per Format type. 
See the table on the next page.
1st field: (Set) Geometry (or something 
similar). All formats will require something 
in this field. 
2nd Field: (Set) Results or (Set) Params.  
Some formats will require input of a file in 
this field. A few formats will allow special 
parameters in this field.
3rd Field: (Set) measured. All but the 
Casefile format will allow input of measured 
data. See EnSight5 Measured/Particle 
File Format
4th Field: (Set) boundary. Only the Plot3d, 
Casefile, and Special HDF5 structured 
formats will pay attention to input in this 
field. See EnSight Boundary File Format

Case ESTET Nastran OP2

EnSight 5 ExodusIIgold N3S

ABAQUS FAST UNSTRUCTURED NetCDF

ABAQUS_ODB FIDAP NEUTRAL Plot3D

Medina bif/bof D_Fluent RADIOSS_4.x

ANSYS RESULTS FLUENT UNIVERSAL SCRYU

Ansys Results(v8) Special HDF5 Silo

AVUS LS-DYNA3D STL

CFF Movie Tecplot_ASCII

CFX-4 MPGS 4.1 TECPLOT_7.x

CGNS MSC/Dytran Vectis

The Data Part Loader dialog for the applicable format will now open and you are 
ready for the second step in the data reading process.

There are a couple of exceptions to this, where additional information must be 
entered. For example, the Plot3D reader requires some confirmation on various 
formatting possibilities, the ESTET reader allows for vector building from scalar 
components, etc. If not obvious, please see the details for specific readers in 
Chapter 2 ( Other Readers ) of the User Manual

7. Select any appropriate extra options if the chosen format has any.  
(Most do not.)

8. Click Okay, once you have specified the files and any options.
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The following table details the files required for each file type for the Data (reader)... method:

Format Type Description Geometry Field (1st Field) Result Field (2nd Field)
Blank field indicates not used

Extra 
Options?

Case

A “wrapper” 
format for 
other formats 

EnSight 
Gold

CEI format defined for version 7.x of 
EnSight. Loads into EnSight much 
quicker and is much more memory 
efficient. (To troubleshoot, see How 
To Use ens_checker)

file.case

EnSight6 CEI format defined for version 6.x of 
EnSight. Typically a superset of 
EnSight 5 format with support for 
structured data. (To troubleshoot, 
see How To Use ens_checker)

 file.case

EnSight5 CEI format defined for version 5.x of 
EnSight. Unstructured only

file.geo file.res   If variables provided.

ABAQUS Data written from ABAQUS 
(commercial FEM solver).

file.fil    Will also read 
file.dat if present in the 
same directory with the 
same root file name.

ABAQUS_ODB Data written from ABAQUS 
(commercial FEM solver).

file.odb Optional parameter string. 
See ...

ANSYS RESULTS Older reader for data written from 
ANSYS (commercial FEM solver).

file.rst  (also .rth, .rfl, .rmq)

Ansys Results (v8) Newer reader for data written from 
ANSYS (commercial FEM solver).

file.rst  (also .rth, .rfl, .rmq)

AVUS Formerly Cobalt60, for static data file.grd file.sol  (solution or restart 
file)

Case Formerly Cobalt60 Case, for 
transient data

file.txt  (text AVUS case file) file.sol  (solution or restart 
file)

CFF Unsupported CFF reader file

CFX-4 Data written from CFX (commercial 
CFD solver).

file.dmp

CGNS file.cgns

ESTET Data written from ESTET 
(commercial CFD solver).

file

ExodusIIgold Data written from Exodus II CFD 
solver

file.exo  (or similar) Yes

FAST UNSTRUCTURED NASA FAST format for unstructured 
(tetrahedral) data.

file.xyz  (or similar) file.res.  NOTE! Do not use 
your solution file (e.g. file.q) 
here. You must create a 
special results file to handle 
FAST variable files. See 
FAST UNSTRUCTURED 
Result file format.

FIDAP NEUTRAL Data written from FIDAP 
(commercial CFD solver) in the 
NEUTRAL format.

file.fdneut  (or similar)

D_Fluent Data written from Fluent (commercial 
CFD solver) in the UNIVERSAL 
format

file.cas file.dat

FLUENT UNIVERSAL Data written from Fluent (commercial 
CFD solver) in the UNIVERSAL 
format

file.unv  (or similar)

Special HDF5 Data written for specific 
implementation of HDF5 format 

file

LS-DYNA3D Data written from LS-Dyna3D 
(commercial FEM solver) in single or 
multiple unstructured C-binary format

file.d3plot Yes
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Medina bif/bof Data written from Medina BIF/BOF 
PERMAS code. (commercial solver).

file.konfig  (Ascii)  

Movie Data in MOVIE.BYU format. file.geo file.res

MPGS 4.1 CEI format for EnSight prior to 
version 5.0

file.geo file.res

MSC/Dytran Data written for Dytran (commercial 
solver)

file.dat or file.arc

Nastran OP2 Data written for NASTRAN 
(commercial FEM solver) in .op2 
format. Only PDA Patran (PARAM 
POST = -1) and SDRC Ideas 
(PARAM POST = -2) are supported.

file.op2

N3S Data written from N3S (commercial 
CFD solver).

file.geo N3S format file.res

NetCDF Data written for specific 
implementation of Unidata NetCDF

file.ncase

PLOT3D NASA format for multiblock, 
structured data.

file.x  (or similar) If your solution (Q) file 
contains the five standard 
variables, you can use it as 
the results file.
If you have a non-standard Q 
file (or a function file) you 
must create a special results 
file to handle PLOT3D 
variable files. See PLOT3D 
Results File Format.

RADIOSS_4.x Data written for Radioss solver file.anim  (or similar)

SCRYU Data written for SCRYU solver file.pre

Silo Data written for Silo format file.silo or file.case

STL Data written in STL format file.stl  (or similar)

TECPLOT 7.x Data written for Tecplot binary 7 file.plt

Tecplot_ASCII Data written for Tecplot ASCII 10 file.dat

Vectis Data written for Vectis solver file.TRI, file.POS (or similar)

Other User Defined Any format for which a shared library 
data reader has been developed. 

Depends on reader Depends on reader Depends 
on reader

Format Type Description Geometry Field (1st Field) Result Field (2nd Field)
Blank field indicates not used

Extra 
Options?
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Second Step (Loading Parts):
There are several ways that parts are specified for loading into EnSight. Many formats use similar procedures, while 
a few have custom methods. Below we present the more common part loading methods. For formats that vary from 
these - you will be referred to the User Manual which gives the details for each.

To build unstructured parts for EnSight Case (Ensight Gold, EnSight6), EnSight5, ABAQUS_ODB, Medina bif/bof, 
Ansys Results (v8), AVUS, AVUS Case, CFF, CFX-4, CGNS, ExodusIIgold, Special HDF5, LS-DYNA3D, MSC/
Dytran, Nastran OP2, NetCDF, RADIOSS_4.x, SCRYU, Silo, TECPLOT 7.x, Tecplot_ASCII, Vectis, and any other 
User-defined formats:

For ANSYS RESULTS, FAST UNSTRUCTURED, FIDAP NEUTRAL, FLUENT UNIVERSAL, Movie, and MPGS 4.1 
formats:

For the N3S format, see N3S Reader
For the Abaqus_fil format all parts are automatically loaded.

1.  If the Data Part Loader dialog is not open, 
select File > Data (Part Loader)...

The available parts are listed in the Parts List. You can build 
them all by clicking Load All at the bottom. Alternately, you 
can build the selected ones or even one by one and choose a 
different visual representation and part name for each.

To build selected parts:
2. Select the desired part(s) in the Parts list.

3. Choose the desired initial Visual 
Representation for the select part(s).

4. If desired, enter a name for the part (to use in 
the Main Parts list). The default name is the 
same as the entry in this Parts List.

5. Click Load Selected.

6. Click Close when done.

Note that you can re-enter the part loader and build more parts later for formats which use this method.

All parts defined in the file will be loaded to the EnSight 
server. However, you have a choice for the initial visual 
representation of some parts as displayed on the client. The 
choice is made with the Load pull-down:

All Parts: all parts are loaded to the client in the default visual 
representation (typically 3D Border, 2D Full).

Part 1 Only: Only the first part is loaded to the client in the default 
visual representation. The other parts will have the NonVisual 
representation.

All But Part 1:  All parts other than part 1 are loaded to the client in 
the default visual representation. Part 1 will be NonVisual.

No Parts: No parts are loaded to the client (i.e. the representation of 
all parts is set to NonVisual).

Note that you can easily change the visual representation of 
a part at any time. See How To Change Visual 
Representation for more information.

1. Select the desired Load option.

2. Click Okay.

Note that you will not be able to re-enter the part loader for formats which use this method
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To build structured parts for EnSight Case (EnSight Gold, EnSight6), Special HDF5, Plot3D, and any other User-
defined formats:

For the ESTET format the procedure is similar. See ESTET Reader

1.  If the Data Part Loader dialog is not 
open, select File > Data (Part Loader)...

2. Be sure Structured Data is selected to 
display only the structured parts in the 
Parts List.

3. Select the desired part(s) in the Parts 
List.

4. Choose the desired initial Visual 
Representation for the select part(s).

5. If the selected part has Iblanking, you 
can build based on the value (Inside 
selects cells where Iblank=1, Outside 
selects Iblank=0, All selects all cells 
ignoring Iblanking).

6. You can specify From, To, and Step IJK 
values for the selected part(s). The From 
and To values are inclusive. 

Valid values in the From and To fields are numbers   
advancing from 1(the min for each part), or numbers 
decreasing from 0(the max for each part):

        1,2,3,... --->            <--- ...-3,-2,-1,0
        |-------------------------------------------|
     min                                                max
   (always 1)                             (varies per part)

If you specify values that will be outside of the range 
of an individual part, the proper min or max values 
for the given part will be used. 

The Min and Max fields are for reference only.
8. If desired, enter a name for the part (to 

use in the Main Parts list). The default 
name is the same as the entry in the 
Parts List.

9. Open this turndown section to create 
unstructured parts based on boundary 
Iblanking from any parts created above.

10. Click Create and Load Part.
11. Click Close when done.

7. If you desire to extract multiple 
surfaces (at a constant delta) from the 
same zone, set one of the directions to 
the desired non-zero delta value. 
This is a “blade row” kind of operation. 
Please note that this results in an 
unstructured part instead of a structured one.
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SEE ALSO
How To Use ens_checker

User Manual:
Reader Basics
EnSight Case Reader
EnSight5 Reader
ABAQUS_FIL Reader
ABAQUS_ODB Reader
Medina BIF-BOF PERMAS Reader
ANSYS Reader
AVUS Reader
CFF Reader
CFX4 Reader
CGNS Reader
ESTET Reader
EXODUS II Gold Reader
FAST UNSTRUCTURED Reader
FIDAP NEUTRAL Reader
FLUENT Direct Reader
FLUENT UNIVERSAL Reader
HDF Reader
LS-DYNA Reader
Movie.BYU Reader
MPGS 4.1 Reader
MSC.DYTRAN Reader
MSC.NASTRAN Reader
N3S Reader
NetCDF Reader
PLOT3D Reader
RADIOSS Reader
SCRYU Reader
SILO Reader
STL Reader
Tecplot Reader
Vectis Reader
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Use ens_checker

INTRODUCTION
This program attempts to check the integrity of the EnSight Gold (or EnSight6) file formats. Most files that pass this 
check will be able to be read by EnSight (see Other Notes below). If EnSight Gold (or EnSight6) data fails to read into 
Ensight, one should run it through this checker to see if any problems are found.

Ens_checker makes no attempt to check the validity of floating point values, such as coordinates, results, etc.  It is 
just checking the existence and format of such.

BASIC OPERATION
Program invocation:

If you invoke the program without any arguments, it will prompt you for the casefile to read.  For example:

> ens_checker

*****************************************************************
*  EnSight Data Format Checker                                  *
*  ===========================                                  *
*   Currently,                                                  *
*   1. Must be run from directory in which casefile is located. *
*   2. Handles EnSight6 and EnSight Gold formats only.          *
*   3. Does not process SOS casefiles.                          *
*****************************************************************

<Enter casefile name (must be in directory containing it!) > mydata.case

You can alternatively invoke the program with the casefile on the command line.

> ens_checker mydata.case

Sample runs:

As ens_checker works it will be providing feedback.  This feedback is important in interpreting what is wrong in the 
files.  Here is a sample run, which was successful:

> ens_checker 3by3.case

*****************************************************************
*  EnSight Data Format Checker                                  *
*  ===========================                                  *
*   Currently,                                                  *
*   1. Must be run from directory in which casefile is located. *
*   2. Handles EnSight6 and EnSight Gold formats only.          *
*   3. Does not process SOS casefiles.                          *
*****************************************************************

<Enter casefile name (must be in directory containing it!) > 3by3.case

Casefile to Process:
--------------------
3by3.case   (Opened successfully)

---------------------
Major Sections Found:
---------------------
Required FORMAT   section    (at line 1)
Required GEOMETRY section    (at line 4)
Optional VARIABLE section    (at line 7)
Optional TIME     section    (at line 11)

---------------
FORMAT Section:
---------------
EnSight 6 Format   (set at line 2)
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-------------
TIME section:
-------------
Info for timeset number: 1
----------------------------
Time set: 1   (at line 12)
   No description provided
   Number of steps:       1   (at line 13)
   Time values:           (starting on line 14)
                          time values[1] = 0

  >-------------------<
  > TIME section OKAY <
  >-------------------<

-----------------
GEOMETRY Section:
-----------------

--------
Model filename is:   3by3.geo      (at line 5)

   Static geometry

   --------
   Opened 3by3.geo successfully

   File type is:    ASCII
   Description 1:   EnSight test geometry file
   Description 2:   ==========================
   node ids:        assign
   element ids:     assign

   Global section:
      Number of nodes: 64
         Coordinates for (64) nodes found

   Part 1:
      Description is: 3 x 3 xy
      Unstructured Part
      Number of quad4 elements is: 9
         Connectivities for (9) quad4 elements found

   Part 2:
      Description is: 3 x 3 yz
      Unstructured Part
      Number of quad4 elements is: 9
         Connectivities for (9) quad4 elements found

   Part 3:
      Description is: 3 x 3 xz
      Unstructured Part
      Number of quad4 elements is: 9
         Connectivities for (9) quad4 elements found

   Part 4:
      Description is: 3 x 3 45
      Unstructured Part
      Number of quad4 elements is: 9
         Connectivities for (9) quad4 elements found

  >-----------------------<
  > GEOMETRY section OKAY <
  >-----------------------<

-----------------
VARIABLE Section:
-----------------

scalar per node:   scalar      (at line 8)
   Filename is: 3by3.scl
   Non transient variable
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   --------
   Opened 3by3.scl successfully

   Description: 3by3 scalar variable

   Global section:
      (64) Nodal scalar values for unstructured nodes found

vector per node:   vector      (at line 9)
   Filename is: 3by3.vct
   Non transient variable

   --------
   Opened 3by3.vct successfully

   Description: 3by3 vector variable

   Global section:
      (192) Nodal vector values for unstructured nodes found

  >-----------------------<
  > VARIABLE section OKAY <
  >-----------------------<

                      >----------- Hooray! ----------<
                      >                              <
                      > Data verification SUCCESSFUL <
                      >                              <
                      >       with No Warnings       <
                      >                              <
                      >------------------------------<

And here is a sample run, with a problem, namely a ‘block’ line is missing:

> ens_checker 3by3s.case

*****************************************************************
*  EnSight Data Format Checker                                  *
*  ===========================                                  *
*   Currently,                                                  *
*   1. Must be run from directory in which casefile is located. *
*   2. Handles EnSight6 and EnSight Gold formats only.          *
*   3. Does not process SOS casefiles.                          *
*****************************************************************

Casefile to Process:
--------------------
3by3s.case   (Opened successfully)

---------------------
Major Sections Found:
---------------------
Required FORMAT   section    (at line 1)
Required GEOMETRY section    (at line 4)
Optional VARIABLE section    (at line 7)
Optional TIME     section    (at line 11)

---------------
FORMAT Section:
---------------
EnSight 6 Format   (set at line 2)

-------------
TIME section:
-------------
Info for timeset number: 1
----------------------------
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Time set: 1   (at line 12)
   No description provided
   Number of steps:       1   (at line 13)
   Time values:           (starting on line 14)
                          time values[1] = 0

  >-------------------<
  > TIME section OKAY <
  >-------------------<

-----------------
GEOMETRY Section:
-----------------

--------
Model filename is:   3by3s.geo      (at line 5)

   Static geometry

   --------
   Opened 3by3s.geo successfully

   File type is:    ASCII
   Description 1:   EnSight test geometry file
   Description 2:   ==========================
   node ids:        assign
   element ids:     assign

   Global section:
      Number of nodes: 0

   Part 1:
      Description is: 3 x 3 xy block
      Structured Part
      Not iblanked
      i j k = 4 4 1
      Number of nodes: 16
      Number of cells: 9
         Block X coordinates for (16) nodes found
         Block Y coordinates for (16) nodes found
         Block Z coordinates for (16) nodes found

   Part 2:
      Description is: 3 x 3 yz block

===> Problem:
-------------
Looking for one of the following valid line types:
   element type      (unstructured types, any of the following:
                         point    tria6    tetra10     penta15
                         bar2     quad4    pyramid5    hexa8
                         bar3     quad8    pyramid13   hexa20
                         tria3    tetra4   penta6
   block             (structured block)
   part              (the next part)
but found the following:
4       4       1

  >-------------------------<
  > GEOMETRY section FAILED <
  >-------------------------<

  >-*-*-*-*-*-* bummer! *-*-*-*-*-*-<
  >                                 <
  > Verification of the data FAILED <
  >                                 <
  >-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-<

After fixing the ‘block’ line and running the program again, another problem is encountered - namely, an extra space 
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at the end of the second line of x coordinates for the block that is part 2.

> ens_checker 3by3s.case

*****************************************************************
*  EnSight Data Format Checker                                  *
*  ===========================                                  *
*   Currently,                                                  *
*   1. Must be run from directory in which casefile is located. *
*   2. Handles EnSight6 and EnSight Gold formats only.          *
*   3. Does not process SOS casefiles.                          *
*****************************************************************

Casefile to Process:
--------------------
3by3s.case   (Opened successfully)

---------------------
Major Sections Found:
---------------------
Required FORMAT   section    (at line 1)
Required GEOMETRY section    (at line 4)
Optional VARIABLE section    (at line 7)
Optional TIME     section    (at line 11)

---------------
FORMAT Section:
---------------
EnSight 6 Format   (set at line 2)

-------------
TIME section:
-------------
Info for timeset number: 1
----------------------------
Time set: 1   (at line 12)
   No description provided
   Number of steps:       1   (at line 13)
   Time values:           (starting on line 14)
                          time values[1] = 0

  >-------------------<
  > TIME section OKAY <
  >-------------------<

-----------------
GEOMETRY Section:
-----------------

--------
Model filename is:   3by3s.geo      (at line 5)

   Static geometry

   --------
   Opened 3by3s.geo successfully

   File type is:    ASCII
   Description 1:   EnSight test geometry file
   Description 2:   ==========================
   node ids:        assign
   element ids:     assign

   Global section:
      Number of nodes: 0

   Part 1:
      Description is: 3 x 3 xy block
      Structured Part
      Not iblanked
      i j k = 4 4 1
      Number of nodes: 16
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      Number of cells: 9
         Block X coordinates for (16) nodes found
         Block Y coordinates for (16) nodes found
         Block Z coordinates for (16) nodes found

   Part 2:
      Description is: 3 x 3 yz block
      Structured Part
      Not iblanked
      i j k = 4 4 1
      Number of nodes: 16
      Number of cells: 9

===> Problem:
-------------
Previous lines end with 1 extra chars on the line,
but line 2 has 2 extra chars. The lines must be consistent
or EnSight will have trouble reading it.

===> Problem:
-------------
Not successful reading 16 X block coordinates

  >-------------------------<
  > GEOMETRY section FAILED <
  >-------------------------<

  >-*-*-*-*-*-* bummer! *-*-*-*-*-*-<
  >                                 <
  > Verification of the data FAILED <
  >                                 <
  >-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-<

After eliminating the extra space, the file then checked out fine.

ADVANCED USAGE
Redirecting Output to a File:

ens_checker is writing to stderr, so if you want to redirect output to a file, you need to use “>&”.  For example, the 
following will place the output of the run into a file called output.file:

> ens_checker 3by3.case >& output.file 

OTHER NOTES
The word “most” is used above because one of the things that could pass the checker, but fail in EnSight is element 
connectivity of EnSight6 files with node ids. The ens_checker checks that node ids used in the element connectivities 
lie within the min and max range of the node ids, but does not verify that there is actually a node with each individual 
id. 

The validity of model extents, presence of nan’s, etc. are currently checked to some degree in ens_checker, but 
again, this is a format checker - not a model integrity checker.

SEE ALSO
User Manual:

EnSight Gold Casefile Format
EnSight6 Casefile Format
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Load Multiple Datasets (Cases)

INTRODUCTION
Normal operation of EnSight involves one client process (the graphics and GUI) interfacing with one server process 
(data I/O and computation) to postprocess your data. There however several other configurations possible. One of 
these is the ability to connect a single client to multiple servers at the same time, with each server maintaining a 
unique dataset. Each of these servers can potentially run on different machines.

The main use of this capability is to visualize multiple datasets simultaneously. Each dataset is loaded into a separate 
case and can be viewed in the same window or in separate viewports. You can perform before and after comparisons 
of the same problem or compare experimental with simulated results. The same operation (such as a clip or a particle 
trace) can be performed in both cases simultaneously. Created parts always belong to the same case as the parent 
from which the part was created. As a consequence, you cannot perform operations that combine parts (such as a 
merge) from multiple cases.

When EnSight reads a new case, it searches the current list of variables for matches with the variables from the new 
case.  If it finds a match (based on an exact match of the variable name), it will not enter the new variable in the list.  
Rather, the matched name will be used for both.  This behavior is based on the assumption that the identical variable 
names represent the same physical entity and should therefore be treated the same.  If the new variable name does 
not match any existing name, the new variable is added to the list as usual.

Up to 16 cases can be active at one time. You can add a new case or replace an existing case to a running session 
by using the File->Open... process (if you want to load all parts and don’t need to control other options available when 
loading cases) or the File->Data (reader)... process (which provides greater control). Adding a case starts a new 
server process, connects it to the client, and either loads all the parts (if you used Open...) or allows you to specify the 
data format and files as well as which parts to load into the new server and what optional settings to use as the case 
is created. One of the helpful uses of the replace case option is to load a new dataset into EnSight without re-starting 
the client. You can of course also delete cases you no longer need.

Server

Client

Server

Client

Server

Normal Operation Two Cases
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BASIC OPERATION
Simplified case operations (Add or Replace and load all parts) can be accessed through the File->Open dialog. All 
other case operations (including control of various options can be accessed through the Case menu or through the 
File->Data (reader) dialog. Both methods will be shown below. 

Add a Case
To add a case to a running EnSight session

Using simple File->Open dialog 
method:

1.Select File->Open... to open 
the File Selection dialog.

2. Select Keep currently loaded 
data
This will add, rather than 
replace, the case

3. Select the desired directory 
and files for the new case.

4. Click Okay.

The EnSight client will now start the connection process for the new server. If your original connection was 
automatic, the new server will be started automatically. If your original connection was manual, you will have to 
manually start another server. You can follow the progress of the connection in the Message area. See the 
EnSight Getting Started Manual or  How To Start and Connect Automatically for more information. Once 
connected, EnSight will also load all parts of this new case if you use this method.
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Using File->Data (reader) dialog method:

1. Select Case > Add, Replace, Delete... to open the data reader File Selection dialog.

2. If the Case section is not 
open, click the turndown.

3. Click Add...

4. If desired, enter a name for the 
case (other than the default).

The name will be displayed in the 
Case menu so this case can be 
selected as the current case.

5. Set optional settings.

Create new viewport for this case will 
place the new case in a new viewport.

Apply Context From Case 1 will cause 
the new case to inherit positioning etc. 
from case 1.

Reflect Model About Axis allows the 
model to be reflected as it is read in. 
Pick the axis and specify the origin 
location.

6. Click Okay.

The EnSight client will now start the connection process for the new server.  If your original 
connection was automatic, the new server will be started automatically.  If your original connection 
was manual, you will have to manually start another server.  You can follow the progress of the 
connection in the Message area.  See the EnSight Getting Started Manual or  How To Start and 
Connect Automatically for more information.
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Replace a Case
You can replace an existing case.  This is most useful when you wish to load a new dataset without having to stop 
and re-start the client.  To replace a case:

Using simple File->Open dialog method:
Do the same thing you do for adding a case, but select the Replace currently loaded data toggle.

Using File->Data (reader) dialog method
1. Select the case you wish to replace in the Case menu (Case > casename).

2. Select Case > Add, Replace, Delete... to open the data reader File Selection dialog.

3. If the Case section is not open, click the turndown.

4. Click Replace...
You will be asked to confirm the replacement.  If confirmed, the server associated with the selected case is 
terminated and the EnSight client will now start the connection process for the new server.  If your original connection 
was automatic, the new server will be started automatically.  If your original connection was manual, you will have to 
manually start another server.  You can follow the progress of the connection in the Message area.  See How To 
Start and Connect Automatically for more information.

Delete a Case
To delete a case:

1. Select the case you wish to delete in the Case menu (Case > casename).

2. Select Case > Add, Replace, Delete... to open the data reader File Selection dialog.

3. If the Case section is not open, click the turndown.

4. Click Delete...
You will be asked to confirm the deletion.  If confirmed, the server associated with the selected case is terminated.

Displaying Parts by Case
By default all parts from all cases are displayed in the Main Parts list and they are displayed in a hierarchical manner 
by case. There are several different ways to show or not show things in the list. These are controlled by the Sort... 
button under the list.  See How To... Introduction to Part Creation for more details on viewing the parts list.
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Case Viewport Display
One of the chief advantages of the case feature is the ability to perform side-by-side comparisons of different 
datasets. One way to do this is to display each case in a separate viewport. To do this:

ADVANCED USAGE
EnSight’s cases capability has also been used to achieve coarse-grained parallelism for very large datasets by 
partitioning a mesh into blocks and reading each block into a different case. Each case can run on different machines 
or on different CPUs of a multiprocessor host. Since the EnSight client places the geometry from the different cases 
in the same coordinate system, the blocks are effectively “stitched” back together for viewing. Operations such as 
clipping and isosurface calculation are then automatically performed in parallel. However, since there is no 
communication between the servers (in the current release) you cannot trace particles originating in one block and 
expect them to cross a block boundary into a different block. (It should be noted that EnSight’s server-of-server 
capability is an alternate, and usually better way to do parallel operations on a model.) 

OTHER NOTES
When you perform an archive operation, a binary dump file is produced for each active server (case).  The archive 
information file contains details about the cases and can be used to restart the EnSight client as well as all servers 
active when the archive was performed.  See How To Save and Restore an Archive for more information.

SEE ALSO
User Manual: Case Menu Functions

1. Create as many additional viewports as you need to 
display your cases.  See How To Define and Change 
Viewports for more information.

2. Select the case whose parts you wish to display only in 
certain viewports in the Case menu (Case > casename).

3. Select Case > Viewport Visibility...

4. Click in the desired viewport to enable or disable 
display of the selected case. Black means the selected 
case is not displayed in the viewport, green means that 
it is displayed.
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Load Transient Data

INTRODUCTION
From it’s inception, EnSight has been used extensively to postprocess time-varying or transient data. In many cases, 
dynamic phenomena can only be understood through interactive exploration as a transient case is animated.  
EnSight handles all types of transient data. All variables as well as mesh coordinates and connectivity can vary over 
time. The rate at which variables (or the mesh) change can differ (supported through the EnSight Gold and EnSight6 
Case data format only).

EnSight can postprocess transient data in many ways. The Solution Time Quick Interaction area lets you easily set 
the current time step, step through time (manually or automatically), or restrict the range of time to a region of 
interest. You can perform query operations to extract information over time. You can use the flipbook capability to 
create an on-screen animation of your data changing over time and continue to interact with it during animation 
playback. EnSight’s keyframe animation capability can be used to create high-quality video animations of transient 
data.

This article covers reading transient data into EnSight.

BASIC OPERATION
Reading transient data into EnSight is essentially the same as reading static data (see How To Read Data for more 
information).  By default, the last time step will become the current time step.  This behavior is based on the 
assumption that the last step will contain the largest dynamic range of the variable data so that variable palettes will 
be initialized properly.  However, you can override this by clicking the Specify Starting Time Step toggle and entering 
the desired time step in the data reader File Selection dialog (File > Data (Reader)...).

For most data formats, the “results” file supplies the necessary time information, including number of steps, actual 
solution time at each step, and how to access the dynamic variable and geometry files. However, some formats 
supported by EnSight include this information in the same file that contains other geometry or variable data. The 
following table lists how transient data is specified for each format type.

Format Type What File Contains Time Info? Notes

Case EnSight 6 file.case Standard EnSight case file

EnSight Gold file.case Standard EnSight case file

EnSight 5 file.res Standard EnSight results file

ABAQUS file.fil

ABAQUS_ODB file.odb

ANSYS RESULTS file.rst, file.rth, etc.

Ansys Results (v8) file.rst, file.rth, etc.

AVUS Does not handle transient data directly

AVUS Case file.txt AVUS text case file

CFF file

CFX-4 file.dmp

CGNS file.cgns

ESTET Does not handle transient data

ExodusIIgold file.exo

FAST UNSTRUCTURED file.res.  Can handle transient geometry 
as well as solution and function files.

Special FAST format results file. See FAST 
UNSTRUCTURED Results File Format

FIDAP NEUTRAL file.fdneut All time steps must be contained in the same neutral 
file (i.e. there is only one file, not one for every time 
step).

D_Fluent file.cas, file.dat

FLUENT UNIVERSAL file.unv Special FLUENT format results file. See FLUENT 
UNIVERSAL Results File Format
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SEE ALSO
How To Change Time Steps, How To Animate Transient Data, How To Query/Plot

User Manual: Flipbook Animation, Query/Plot

Special HDF5 file  (each file contains one time value) Special casefile containing number of files and the list 
of files to use.

LS-DYNA3D file.d3plot Can be all in one file or in a family of d3plot files.

Medina bif/bof file.konfig

Movie file.res Standard EnSight results file

MPGS 4.1 file.res Standard EnSight results file

MSC/Dytran file.arc files Remember file.dat can be used to assemble multiple 
“parts”  from multiple file.arc files.

Nastran OP2 file.op2

N3S file.res N3S results file

NetCDF file.ncase

PLOT3D file.res.  Can handle transient geometry 
as well as solution and function files.

Special PLOT3D format results file. See PLOT3D 
Results File Format.

RADIOSS_4.x file.anim

SCRYU file.pre

Silo file.silo or file.case Multiple times can be in the file.silo file, or the 
file.case file can contain reference to multiple files 
and their times.

STL Does not handle transient data

TECPLOT 7.x file.plt

Tecplot_ASCII file.dat

Vectis

Other User Defined varies with each reader See How to Read User Defined

Format Type What File Contains Time Info? Notes
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Use Server of Servers

INTRODUCTION
ensight8 (with gold license key) has the capability of dealing with partitioned data in an efficient distributed manner by 
utilizing what we call a server-of-servers (SOS for short). An SOS server resides between a normal client and a 
number of normal servers. Thus, it appears as a normal server to the client, and as a normal client to the various 
normal servers. 

This arrangement allows for distributed parallel processing of the various portions of a model, and has been shown to 
scale quite well.

Currently, EnSight SOS capability is only available for EnSight5, EnSight6, EnSight Gold, Plot3d, and any EnSight 
User-Defined Reader data.  (It is not directly available for Fidap Neutral, Fluent Universal, N3S, Estet, MPGS4, 
Movie, Ansys, Abaqus, or FAST Unstructured data.)

Please recognize that your data must be partitioned in some manner (hopefully in a way that will be reasonably load 
balanced) in order for this approach to be useful. (The exception to this is the use of the auto_distribute capability for 
structured data. This option can be used if the data is structured and is available to all servers defined. It will 
automatically distribute each portion of each structured block over the defined servers - without the user having to 
partition the data.)

(Included in the EnSight distribution is an unsupported utility that will take most EnSight Gold binary unstructured 
datasets and partition it for you. The source for this utility (called “chopper”) can be found in the $CEI_HOME/
ensight80/unsupported/partitioner directory.)

Note: If you do your own partitioning of data into EnSight6 or EnSight Gold format, please be aware that each part 
must be in each partition - but, any given part can be “empty” in any given partition. (All that is required for an empty 
part is the “part” line, the part number, and the “description” line.)

You should place each partitioned portion of the model on the machine that will compute that portion. Each 
partitioned portion is actually a self contained set of EnSight data files, which could typically be read by a normal 
client - server session of EnSight. For example, if it were EnSight gold format, there will be a casefile and associated 
gold geometry and variable results file(s). On the machine where the EnSight SOS will be run, you will need to place 
the sos casefile. The sos casefile is a simple ascii file which informs the SOS about pertinent information needed to 
run a server on each of the machines that will compute the various portions.
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The format for this file is as follows: (Note that [ ] indicates optional information, and a blank line or a line with # in the 
first column are comments.)

FORMAT (Required)
type: master_server datatype (Required)            

where: datatype is required and is one of the formats of EnSight’s internal readers (which
use the Part builder), namely:
gold ensight6 ensight5 plot3d

or it can be the string used to name any of the user-defined readers.
Note: For user-defined readers, the string must be exactly that which is defined in the
USERD_get_name_of_reader routine of the reader (which is what is presented in the Format
pulldown of the Data Reader dialog).
If datatype is blank, it will default to EnSight6 data type.

[auto_distribute: on/off]    (Optional for structured, Ignored for unstructured)
For structured data only, EnSight will automatically distribute data to the servers specified below
if this option is present and set to “on”.  This will require that each of the servers have access to
the same data (or identical copies of it).

[plot3d_iblanked:         true/false] (Required only if datatype is plot3d)
[plot3d_multi_zone:      true/false] (Required only if datatype is plot3d)
[plot3d_dimension:       1d/2d/3d] (Required only if datatype is plot3d)
[plot3d_source:     ascii/cbin/fortranbin](Required only if datatype is plot3d)
[plot3d_grid_double:     true/false] (Required only if datatype is plot3d)
[plot3d_results_double:  true/false] (Required only if datatype is plot3d)

where: iblanking, multi_zone, dimension, source type, grid file double precision, and results file
double precision information should be provided. If it is not provided, it will default to the
following (which is likely not to be correct):

plot3d_iblanked: false
plot3d_muti_zone: false
plot3d_dimension: 3d
plot3d_source: cbin
plot3d_grid_double: false
plot3d_results_double: false

NETWORK_INTERFACES (Note: This whole section is optional.  It is needed only when more than one network 
interface to the sos host is available and it is desired to use them.  Thus, distributing the servers 
to sos communication over more than one network interface)

number of network interfaces:  num(Required - if section used)
where: num is the number of network interfaces to be used for the sos host.

network interface:  sos_network_interface_name_1(Required - if section used)
network interface:  sos_network_interface_name_2(Required - if section used)
                                                                                       .                                                                                       .
network interface:  sos_network_interface_name_num(Required - if section used)

SERVERS (Required)
number of servers:  num (Required)

where: num is the number of servers that will be started and run concurrently.

#Server 1 (Comment only)
machine id:  mid (Required)

where: mid is the machine id of the server.

executable:  /.../ensight8.server (Required, must use full path)
[directory:  wd] (Optional)

where: wd is the working directory from which ensight8.server will be run

[login id:  id] (Optional)
where: id is the login id. Only needed if it is different on this machine.

[data_path: /.../dd] (Optional)
where: dd is the directory where the data resides. Full path must be provided if you use this line. 
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casefile: yourfile.case (Required, but depending on format, may vary as to whether it is a casefile, geometry file,
                  neutral file, universal file, etc. Relates to the first data field of the Data Reader Dialog.)
[resfile: yourfile.res] (Depends on format as to whether required or not. Relates to the second data field of the Data

 Reader Dialog.)

[measfile: yourfile.mea] (Depends on format as to whether required or not. Relates to the third data field of the Data
 Reader Dialog.)

[bndfile: yourfile.bnd] (Depends on format as to whether required or not. Relates to the fourth data field of the Data
 Reader Dialog.)

--- Repeat pertinent lines for as many servers as declared to be in this file ---

BASIC OPERATION
To use Server of Servers, you must:

1. Partition your data, and distribute it (or make it available) to the various machines on which you will run servers. 
(Or if you have structured data, you can use the auto_distribute option in the sos casefile.)

2. Create the sos casefile, which defines the server machines, the location of server executables on those machines, 
and the name and location of the partitioned data for the servers.

3. Use ensight8.sos in place of ensight8.server, and provide it with the sos casefile.

Example SOS Casefile
This example deals with a EnSight Gold dataset that has been partitioned into 3 portions, each running on a different 
machine. The machines are named joe, sally, and bill. The executables for all machines are located in similar 
locations, but the data is not. Note that the optional data_path line is used on two of the servers, but not the third. 

FORMAT
type: master_server gold

SERVERS
number of servers:  3

#Server 1
machine id:  joe
executable:  /usr/local/bin/ensight80/bin/ensight8.server
data_path: /usr/people/john/data
casefile: portion_1.case

#Server 2
machine id:  sally
executable:  /usr/local/bin/ensight80/bin/ensight8.server
data_path: /scratch/sally/john/data
casefile: portion_2.case

#Server 3
machine id:  bill
executable:  /usr/local/bin/ensight80/bin/ensight8.server
casefile: /scratch/temp/john/portion_3.case

If we name this example sos casefile - “all.sos”, and we run it on yet another machine - one named george, you would 
want the data distributed as follows:

On george:   all.sos
On joe (in /usr/people/john/data): portion_1.case, and all files referenced by it.
On sally (in /scratch/sally/john/data): portion_2.case, and all files referenced by it.
On bill (in /scratch/temp/john): portion_3.case, and all file referenced by it.

By starting EnSight with the -sos command line option (which will autoconnect using ensight8.sos instead of 
ensight8.server), or by manually running ensight8.sos in place of ensight8.server, and providing all.sos as the 
casefile to read in the Data Reader dialog - EnSight will actually start three servers and compute the respective 
portions on them in parallel.
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So, one could do the following (after preparing the all.sos file):

On “george”, run the client and the sos by invoking the ensight8 script in a shell window (non-windows) or Command 
Prompt window (windows), like:
george>> ensight8 -sos

Or one could run the client on the “myclient” machine, telnet (or equivalent) into the “george” machine and run the sos 
there, by using the following commands:

:

In either case, you would enter the all.sos command as the file to read in the Data Reader dialog once EnSight is up 
and connected.  And the servers on “joe”, “sally”, and “bill” would be started and used automatically.

Optional NETWORK_INTERFACES section notes

If the machine named george had more than one network interface (say it had its main one named george, but also 
had one named george2), we could add the section shown below to our casefile example:

NETWORK_INTERFACES
number of network interfaces:  2
network interface:   george
network interface:   george2

This would cause machine joe to connect back to george, machine sally to connect back to george2, and machine bill 
to connect back to george. This is because the sos will cycle through its available network interfaces as it connects 
the servers.   Remember that this is an optional section, and most users will probably not use it. Also, the contents of 
this section will be ignored if the -soshostname command line option is used.

If “myclient” is a non-windows machine:

In a window on “myclient”: In a window that is telneted into the “george” machine:

myclient>> ensight8.client -cm If “george: is a non-windows machine:

george>> ensight8.sos -c myclient

If “george is a windows machine:

george>> ensight8_sos -c myclient

If “myclient” is a windows machine:

In a Command Prompt window on “myclient”: In a Command Prompt window that is telneted into the 
“george” machine:

myclient>> ensight8_client -cm If “george: is a non-windows machine:

george>> ensight8.sos -c myclient

If “george is a windows machine:

george>> ensight8_sos -c myclient
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Example SOS Casefile for PLOT3D, Using auto_distribute
This example shows a plot3d dataset (post.x and post.q) that has not been partitioned, but is on an nfs mounted disk 
available to each server machine. EnSight will distribute the data to the 3 servers defined. IO will not necessarily be 
great since each server will be reading from the same file, but execution will be enhanced by the partitioning. We will 
use the same machines used in the previous example.

FORMAT
type: master_server plot3d
auto_distribute:  on
plot3d_iblanked:  true
plot3d_multi_zone:  false
plot3d_dimension:  3d
plot3d_source:  cbin
plot3d_grid_double:   false
plot3d_results_double:  false

SERVERS
number of servers:  3

#Server 1
machine id:  joe
executable:  /usr/local/bin/ensight80/bin/ensight8.server
data_path: /scratch/data
casefile:  post_x
resfile: post.q

#Server 2
machine id:  sally
executable:  /usr/local/bin/ensight80/bin/ensight8.server
data_path: /scratch/data
casefile: post.x
resfile: post.q

#Server 3
machine id:  bill
executable:  /usr/local/bin/ensight80/bin/ensight8.server
data_path: /scratch/data
casefile: post.x
resfile: post.q

SEE ALSO
How To Read Data
How To Read User Defined

User Manual: Server-of-Server Casefile Format
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Read User Defined

INTRODUCTION
EnSight provides a mechanism for users to write their own readers and have the code automatically link and execute 
at run-time (using a shared library). Since this is a capability which is somewhat subject to change, usage information 
is best provided in README files in the EnSight Distribution. See the README files in $CEI_HOME/ensight80/
src/readers/ for details. A couple of sample readers, as well as the code for several actual readers are also 
provided below this directory.

Additionally, a udr_checker.c file is provided in $CEI_HOME/ensight80/src/readers/checker which can be 
used to debug your User-defined reader before using it with EnSight.   See the README in this directory.

OTHER NOTES
When starting EnSight (ensight8 or ensight8.server), you use the command line option “-readerdbg” to echo user 
defined reader loading status. This will allow you to see what readers are actually being loaded.

Set the environment variable ENSIGHT8_READER to point to the path where additional user defined readers exist.

SEE ALSO
How To Read Data



Do Structured Extraction

INTRODUCTION
When building parts from the Data Part Loader dialog for structured parts (Ensight6 structured parts, EnSight gold 
structured parts, PLOT3D parts), there is some flexibility in what is actually extracted. If the model contains iblanking, 
then you have control over which iblanking domain to use, namely Inside, Outside (blanked out), or All (which ignores 
the iblanking). If no iblanking in the model, the domain is All by default. You can extract all or portions of zones at 
original or coarser resolutions, do the extractions on single or multiple zones, extract planes at every delta value 
within a zone, etc.

BASIC OPERATION
When extracting the domain parts, whether iblanked or not, some (but definitely not all combinations) of the options 
include:

Extracting a complete zone at original resolution,

1. Select the structured zone desired.

Optionally you can change the domain and provide a part 
description.

2. Hit the Create/Load from selected button.

The part will be created and shown in the graphics window. 
In the example below, it is shown in border representation 
mode.
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Extracting a complete zone at coarser resolution,
1. Select the structured zone desired.

Optionally you can change the domain and provide a part 
description.

2. Modify the Step values.

These should be positive integer values. A step of two means 
to deal with every other plane, a step of four means every 
fourth plane, etc.

3. Hit the Create/Load from selected button.

The part will be created and shown in the graphics window. In 
the example below, it is shown in border representation mode. 
Note that it is considerably coarser than the previous because 
step values of 2, 4, and 5 were used in the ijk directions 
respectively.
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Extracting portions of a zone,
1. Select the structured zone desired.

Optionally you can change the domain and provide a part 
description.

2. Modify the From and To values.

These can be anything between the ranges shown in the 
Min and Max columns. By default they will be the entire 
range, but you can modify them.

3. Hit the Create/Load from selected button.

The part will be created and shown in the graphics 
window. In the example below, it is shown in border 
representation mode. Note that you now get a portion 
instead of the whole. Note also that we got original 
resolution because we set step values back to one. The 
step values can be other than one, and your portion will be 
at the coarser resolution.
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Extracting multiple planes within the same zone (these become unstructured),
1. Select the structured zone desired.

Optionally you can change the domain and provide a part 
description.

2. Modify the From and To values so that one 
dimension is a plane.

One of I, J, or K must have the same values for both From 
and To - indicating a plane in the other two dimensions.

3. Enter a value in the Delta field for the dimension that 
is a plane.

Only one of the Delta fields may be non-zero, and it must 
be one where the From and To values are the same.

4. Hit the Create/Load from selected button.

The part will be created and shown in the graphics 
window. In the example below, it is shown in border 
representation mode. Note that you now get an IK surface 
at J = 1, 6, 11, 16, 21, 26, ...
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Extracting the same portions over multiple parts,
1. Select the structured zones desired.

Optionally you can change the domain

2. Modify the From and To values.
These can be anything between the ranges shown in the Min 
and Max columns (which will now be the min and max of all 
parts selected). By default they will be the entire range, but 
you can modify them. Additionally, “-1” is a valid entry, 
indicating the last plane. Minus numbers are ways to specify 
the plane from the max back toward the min, thus -2 equals 
the next to last plane. (Note: Zero is treated the same as -1)

3. Hit the Create/Load from selected button or the
Create/load all button.
In this example, 4 parts will be created, and they will each be 
the full extent IK plane at J = 1 for each of the four zones. 
Note that the IK ranges can actually vary per part because the 
max is specified, but each zone may be less than the max.

In our example, we then changed From and To to be “0”, thus 
extracting the last plane in each zone. Note the image below. 
The image at the right includes complete zones that were 
extracted, but shown in feature angle representation so 
you get the feel of the complete zone.
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Extracting unstructured iblanked parts.

SEE ALSO
How To Read Data
User Manual: Using Node Ranges:

1. Select the structured zones desired.

Optionally you can change the Domain, From, To, and 
Step values.

2. Hit the Create/Load from selected button.

In this example, 4 parts will be created, and they will each 
be the full extents at original resolution. Iblanking for the 
domain will be ignored.

3. Open the Iblanked Part Creation turndown.

4. Select from the domain parts that you have 
previously created.

5. Select the iblanking value to use.

Optionally you can specify your own name for the part 
that will be created.

6. Hit the Create and Load Iblanked Unstructured Part 
button.

This will create an unstructured part consisting of the 
elements which have the selected iblank value from the 
selected parts.
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Save or Output
Save or Restore an Archive

INTRODUCTION
EnSight command files are useful for restoring the system to a state reached in a previous session.  However, 
restoring a long session dealing with large files can be a tedious process.  Fortunately, EnSight provides an archiving 
mechanism that saves only the current state of the system, rather than the entire history of a session.

This capability is useful not only for large data files with several active variables, but also for saving a standard 
starting point for sessions.  In the initial session, geometry can be loaded, variables activated, a good viewpoint 
selected, and an archive written.  Subsequent sessions take advantage of this investment by merely loading the 
archive (which can be done as you start EnSight from the command line).

The client and server each write separate binary files containing the complete current state of the respective 
processes. Since these files are binary, they can be quickly written and restored. Note that an archive only contains 
information resident in either client or server memory at the time of the archive. No information is available for 
variables that were inactive or time steps other than the current. For this reason, you should never remove the 
original dataset and attempt to use the archive as a substitute (unless you know what you’re doing).

IMPORTANT NOTE: Currently archive save/restore operations are not supported when running EnSight 
Server-of-Servers.

BASIC OPERATION
An EnSight archive consists of three files:

1. The Archive Information File.  This file provides pointers to the client and server archive files as well as additional 
information required to load the archive.  An example is given in the Advanced Usage section below.

2. The Client Archive file.  This is the client’s binary dump file.
3. The Server Archive file.  This is the server’s binary dump file.
Although each file has a default location, you can override the default during the archiving process.

Saving an Archive
1. Close all open EnSight windows except the main window.
2. Select File > Save > Full Backup... to open the Save Full Backup Archive dialog.

2. If desired, enter a new name for the Archive Information file.  You can set the directory for 
the Archive Information File by clicking the Archive Information File... button to open a 
standard File Selection dialog.

3. If desired, select a directory for the client’s binary dump file by either entering the directory 
in the Client Directory field or clicking the Client Directory... button to open a standard File 
Selection dialog.

4. If desired, select a directory for the server’s binary dump file by either entering the 
directory in the Server Directory field or clicking the Server Directory... button to open a 
standard File Selection dialog.

5. Click Okay.
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You also have the option of saving an archive as you exit EnSight.

Restoring an Archive
You can restore an archive either as part of EnSight startup or during an active session.  To load an archive on 
startup:

1. Use the “-ar archive_info_file” option when you start EnSight. For example,

% ensight8 -ar load.ar

where load.ar is an Archive Information file saved in a previous session.

To restore an archive during an active session:

1. Select File > Restore > Full Backup... to open the File Selection dialog.

2. Select the desired Archive Information file and click Okay.

3. If the original connection (when the archive was saved) was manual, you will need to manually restart the 
server.

ADVANCED USAGE
There are times when you may want to modify the contents of the Archive Information file.  If you wish to use the 
archive on a different machine or change the location of the binary dump files, you can simply edit the file with a text 
editor.  The following example shows the contents:

1. Select File > Quit... to open the Quit Confirmation 
dialog.

2. Click the Save Full backup Archive To toggle and, 
if desired, enter a new name for the Archive 
information file.

3. Click Yes to save the archive and exit.

When saving an archive via the Quit Confirmation dialog, 
you do not have the option of specifying the directories 
for the archive files.

Wed Apr  2 15:31:51 1997
client ./ensight0402_153151.clientbkup

# server for Case ‘Case 1’. **Warning Don’t Modify The Internal Number**.

case_internal_number 0
case_name Case 1
case_connect_type auto
case_connect_machine indigo2
case_connect_executable /usr/local/bin/ensight/server/ensight.server
case_connect_directory /usr/people/joe/data
case_connect_login_id 
server ./ensight_c1_0402_153151.serverbkup

Date saved
Path to client’s binary file

comment
Case internal number

Case name
Connect type (auto or manual)

Server host machine
Server executable

Server data directory
Alternate server login ID

Path to server’s binary file

Note that there will be a section for all the case_ variables for each current case in the EnSight session.  See How 
To Load Multiple Datasets for more information on cases.
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OTHER NOTES
Important note!  Archives are typically not upwardly compatible with new major – and some minor – releases of 
EnSight. For this reason, the complete current command file is also saved as part of the client’s binary dump. If you 
attempt to restore an archive and EnSight determines that the archive is not compatible with the current release, the 
command file will be restored to a default location.

IMPORTANT NOTE: Currently archive save/restore operations are not supported when running EnSight 
Server-of-Servers.

SEE ALSO
User Manual: Saving and Restoring a Full backup
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Record and Play Command Files

INTRODUCTION
Most powerful software systems have a built-in language that provides additional levels of power and functionality to 
complement and enhance a graphical user interface.  EnSight is no exception.  Any action that you can perform with 
the mouse or keyboard has a counterpart in the EnSight command language.  A sequence of commands can be 
saved during a session to automate repetitive or tedious tasks.  Command files can be automatically executed on 
EnSight startup to initialize the system to a desired state.  Execution of command files can also be bound to keyboard 
keys for user-defined macros.

BASIC OPERATION
During an EnSight session, all actions are recorded and saved to a file known as the default command file. This file 
name typically starts with “ensigDAA” and is saved in /usr/tmp (unless you have redefined your TMPDIR 
environment variable). The default command file can be saved (and renamed) when exiting EnSight.

Recording Commands
To record a series of commands: 

1. Select File > Command... to open the 
Command dialog.

2. Toggle the Record button on.

3. A File Selection dialog opens.  Select the 
desired file to save commands to and click 
Okay.

4. When you wish to stop recording, toggle the 
Record button off.
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Playing a Command File
To replay a command file:

Playing a Command File on Startup
You can execute a command file as part of EnSight startup:

1. Use the “-p command_file” option when you start EnSight. For example,

% ensight8 -p redo.cmd

where redo.cmd is a command file saved in a previous session.

ADVANCED USAGE
Command files are simple ASCII text and can be edited with any text editor.  To easily determine the command for a 
given action, open the Command dialog and watch the list at the top as you perform various operations.  Keep in 
mind that the successful execution of some commands depends on the proper state existing at the time of execution.  
For example, creating a part when the parent part (as referenced by the part number) does not exist will cause an 
error.

Command files can be nested: if you have a file that performs a certain task, you can “call” that command file from 
another file with the “play: filename” command. An “exit:” command will cause EnSight to quit. An 
“interrupt:” command will cause the command file to pause execution and open the command dialog.

You can save the command file for the current session when you exit EnSight, or you can use File > Save > 
Command from this session... to save the commands up to that point.

1. Select File > Command... to open the Command 
dialog.

2. Toggle the Play button on.

3. A File Selection dialog opens.  Select the desired 
command file and click Okay.

You can control command execution by interrupting the 
playback.  Once playback is stopped, you can single step 
through commands or even skip commands.

1. To stop command execution, click the Interrupt 
button.

2. To single-step through the commands, click the 
Step button.

3. To skip a command, click the Skip button.

4. To continue execution, click the Continue button.

Note that the next command to be executed is shown in 
the Command Entry field.  You can also enter commands 
to be immediately executed in this field.  
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OTHER NOTES
Command files provide an excellent method of documenting problems or potential bugs encountered during your use 
of EnSight.  The command file can be transmitted to CEI electronically to help determine the nature of the problem.

SEE ALSO
How To Define and Use Macros

User Manual: Command Files
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Print/Save an Image

INTRODUCTION
The image displayed in the Graphics Window can be saved to disk or printed in a variety of formats: Apple PICT, 
JPEG,TIFF, PCL, PostScript (supporting image, “move-draw”, and EPS), RGB (Silicon Graphics), TARGA, CEI RGB 
with depth, EnVideo, MPEG1, MPEG2, AVI, and POVRAY.

If you wish to save a sequence of images (e.g. for a smooth animation or a transient data display), use EnSight’s 
keyframe animation facility.

BASIC OPERATION

1. Select File > Print/Save Image....

2. Select Format... to choose 
the desired output format 
and format options.

3. Enter a file name prefix to 
save the image to disk.

     – AND/OR –

4. Toggle the “To Printer ...” 
button on and enter a print 
command (see Notes 
below).

5. If desired, automatically 
convert colors for printing 
(see notes below).

Notes:
1. The file is saved or printed from the EnSight client machine – not the server.
2. The printer command should not include the file name. For example, if you normally print with 

“lpr -Plaser1 file.ps” then enter “lpr -Plaser1” in the To Printer Using Command 
field.

3. If you toggle on Convert to default print colors, all viewport background colors are changed to 
white and any object (part, viewport border, annotation, etc.) currently colored pure white (RGB 
= 1,1,1) will be changed to black.

6. If desired, select a window size option.  Normal is 
the current size of the Graphics Window and Full 
is full screen size.  If the setting is User Defined, 
you can enter the desired size in the X and Y text 
fields.

7. Click Print.
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Options for Apple PICT Format

Options for JPEG Format

Options for TIFF Format

Options for PCL Format

Set the saturation factor for color images.  Full 
saturation is 1.0 and no saturation (i.e. white) is 0.0.

Select either color or black and white output.

Select either color or black and white output.

Set the saturation factor for color images.  Full
saturation is 1.0 and no saturation (i.e. white) is 0.0

Set the desired output quality. The value represents a 
trade-off between fidelity and compression: 100 
means maximum fidelity and 0 means maximum 
compression. You can use the slider to set this value.

Set the saturation factor for color images.  Full
saturation is 1.0 and no saturation (i.e. white) is 0.0

Select either color or black and white output.

Set the saturation factor for color images. Full
saturation is 1.0 and no saturation (i.e. white) is 0.0.

Select Portrait or Landscape output orientation.

Set gamma correction factor. Gamma can correct for
nonlinearities in monitor brightness.

Select the destination PCL printer model.
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Options for PostScript Format

The PostScript format handles primitives either as precise drawing instructions (e.g. move to here, draw a line to 
here, fill this region) or as sampled images (pixel data).  There are advantages and disadvantages to both.

Move/draw output is resolution-independent and will reproduce fine lines and text.  Since even low resolution printers 
have 3-4 times the resolution of a typical graphics workstation (in dots/inch), move/draw PostScript typically produces 
higher quality output.  However, for very large models, the output files can become quite large (even with visibility 
culling on) and subsequent printing can be slow.

In contrast, image or pixel PostScript saves the pixels of the image in the Graphics Window.  Such an image is, by 
definition, fixed resolution.  When printed, the pixels will be scaled to fit the page.  Since the printer resolution is 
higher than the screen resolution, each pixel must be printed larger than it appeared on the screen resulting in visible 
pixels and jagged edges.  To improve the quality of image PostScript output, EnSight will print only 3D geometry as 
pixels – the remaining objects (annotation text, color legends, and plots) will be output as move-draw instructions and 
will overlay the image.

Options for SGI RGB Format

Options for TARGA Format

 
           Toggle on to remove invisible geometry.

Toggle on to subdivide geometry for smooth color and 
shading output.

Select either color or black and white output.

Set the saturation factor for color images.  Full 
saturation is 1.0 and no saturation (i.e. white) is 0.0.

Select Portrait or Landscape output orientation.

Set the page scale factor.

Select either “Move/Draw” or “Image” PostScript 
output (see below).

Toggle on for Encapsulated Postscript output.

Toggle on to enable a preview image for EPS files 
(for import into PC Windows applications ONLY – 
see Other Notes below).

Select either color or black and white output.

Set the saturation factor for color images.  Full 
saturation is 1.0 and no saturation (i.e. white) is 0.0.

Select either color or black and white output.

Set the saturation factor for color images.  Full
saturation is 1.0 and no saturation (i.e. white) is 0.0
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Options for CEI RGB with depth Format

Options for EnVideo Format

Options for MPEG1 or MPEG2 Format

Options for AVI Format

Note: AVI files are a Microsoft standard format for movies, audio, icons, and other data types.

Uncompressed AVI files can be quite large for even small animations. You can compress these files on your Windows 
PC using the utility avi_compress.exe found in the “unsupported” directory of the EnSight distribution. This is a 

Select either color or black and white output.

Set the saturation factor for color images. Full 
saturation is 1.0 and no saturation (i.e. white) is 0.0.

Note: This format cannot be viewed or printed. It 
is used for compositing two or more images 
according to depth values.

Select Run Length Encoding or JPEG type.

Set the saturation factor for color images. Full
saturation is 1.0 and no saturation (i.e. white) is 0.0

Select IBP or I type.

Set the saturation factor for color images. Full
saturation is 1.0 and no saturation (i.e. white) is 0.0

Set the desired Frame rate (frames per sec).

Set the maximum bit rate.

Select MJPEG or Uncompressed type.

Set the saturation factor for color images. Full
saturation is 1.0 and no saturation (i.e. white) is 0.0

Set the desired quality. Slider can be used.

Set the desired frame rate (frames per sec).

Set the maximum bit rate.
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Windows command line based program. To use the utility, copy it and the AVI movie file to a folder on your PC. Then 
open a ‘Command Prompt’ window (DOS shell) and change to the folder containing the files. Next, run the command 
using the following syntax:         avi_compress in.avi out.avi
where ‘in.avi’ is the name of the uncompressed movie file and ‘out.avi’ is the name to use for the compressed movie 
file. The utility will open a simple dialog box presenting a choice of compression methods available on your PC. For 
portability reasons, you should probably choose ‘Cinepak’. You may choose others but they may not generate 
portable movies that others can view on their PC.

Options for POVRAY Geometry Format

ADVANCED USAGE
Most workstations provide tools to display and manipulate images. Silicon Graphics provides a rich image 
manipulation environment. See, for example, the manual pages for imgworks and dmconvert.

There are also some excellent public domain (i.e. free) tools for manipulating images. A suite of tools for manipulating 
and converting images is available from the San Diego Supercomputing Center. You can download pre-complied 
binaries for most UNIX workstations from the SDSC FTP server: ftp.sdsc.edu in pub/sdsc/graphics/
imtools. ImageMagick is a public domain, X-windows based program for displaying both images and animations 
(loaded as sequences of images) on a wide variety of platforms. Visit the Web site
http://www.wizards.dupont.com/cristy/ImageMagick.html for more information.

OTHER NOTES
Almost all desktop publishing, page-layout, or word-processing packages permit importation of Encapsulated 
PostScript files or PICT files. Macintosh packages recognize files by explicit file typing based on a four letter code 
(unlike UNIX, which has no intrinsic file-typing). This code is not stored in the file itself, but in an “information file” 
used by the Finder (the Mac OS) to handle files. EPS files are recognized by the code “EPSF” and PICT images by 
the code “PICT”. There are various methods of setting this code. File transfer utilities such as “fetch” can set the code 
during the transfer process. The “FileTyper” utility can be used to directly edit the Finder Information File. Unless this 
file type is set properly, it is likely that applications will refuse to recognize your EPS or PICT files. Send email to 
fetch@dartmouth.edu for information on fetch.

EPS files typically contain a “preview image” that lets the importing application display a facsimile of the actual 
graphic for ease in interactive positioning, scaling, or clipping.  There are different methods of specifying this image 
(e.g. PICT resources for Macintosh or TIFF files for Windows).  Unfortunately, the different methods of specifying the 
preview image preclude EnSight from providing this capability for import into Macintosh applications.  When you 
import an EPS file, most Macintosh applications will display it as a gray box.  You can, however, still resize and 
position the image and it should print fine.   EnSight can, however, attach a preview image that can be used by 
Windows applications.  Enable the “Windows (PC) Preview Capable” toggle in the Image Format Options dialog.  The 
suffix “.EPS” should be used for the resulting files.

Do not attempt to send a PostScript file containing a preview image to a printer!

SEE ALSO
User Manual:  Saving and Printing Graphic Images

No options to set for this format.
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Save Geometric Entities

INTRODUCTION
EnSight can has three internal writers that allow saving geometric data and variable values in Brick of Values, Case 
(EnSight Gold) or VRML. EnSight also allows the user to create their own writer as a dynamic shared library that is 
loaded at runtime and listed in the addition to the internal writer formats.

BASIC OPERATION

Saving Parts in EnSight Gold or VRML Formats   

Both internal and user-defined writers have access only to the geometry of selected parts and each of their active 
variables.  Only parts located on the server can be saved.  This includes all original model parts, and the following 
created parts:  2D-clips, Elevated Surfaces, Developed Surfaces, and Isosurfaces.  The VRML internal writer saves 
all the visible parts on the server (thus, particle traces, vector arrows, contours, etc. will not be saved) in their current 
visible state except for Parts which have limit fringes set to transparent.  The VRML file will be saved on the client. 

Output in the EnSight formats is intended to provide a method to save both model and created parts (with active 
variables) for subsequent reuse with EnSight.  VRML output is intended for export to other systems.
Most World Wide Web browsers come with either built-in or plug-in support for VRML file viewing.  Since VRML is a 
subset of the Inventor format, you can also import it into programs accepting Inventor files.  You may, however, have 
to modify the first line of the file (with any text editor) to read:

#Inventor V2.0 ascii

This may work when importing VRML into Showcase from Silicon Graphics (a presentation layout tool). Once 
imported, the 3D model can still be manipulated – even during a presentation.

There are some important differences in how EnSight saves parts according to format chosen.

Case(EnSight Gold) VRML

Which parts are saved? All parts currently selected in the Main Parts List (except those indicated below) All visible parts

Saved from where? EnSight server EnSight client

Which parts cannot be saved? Any client-based part: contours, vector arrows, particle traces, profiles.

1. Select File > 

2. Be sure the desired output format is selected.
3. Follow the instructions given.
4. Enter a file root name.
5. If the dataset is transient, specify the beginning, ending, and step values.

For EnSight Gold only:
6. Toggle to save as binary files or not.
7. If the dataset is transient you can choose to save the multiple timesteps in one file 

(one file per variable).  If you choose this option, you can also specify the maximum 
file size.

8. Click Okay.
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Saving Parts in Brick of Values Format

Brick of Bytes and Brick of Floats is intended to give you an interface mechanism to volume rendering codes.
When you click the Okay button the selected parts are discritized to the resolution indicated using the box tool as the 
bounds and orientation (x/y/z resolution refers to the x/y/z directions for the box tool).
For Brick of Bytes (BoB) format a value of 0 is reserved for undefined (i.e., the discritized point found no variable 
information).  The value of 1 is tied to all variable values less than or equal to the minimum palette value tied to the 
variable chosen while 255 is tied to all values greater to or equal to the maximum palette value.
For Brick of Floats (BoF) format undefined values are assigned the undefined value indicated in dialog.
Both BoB and BoF files are written out without any metadata - only the values for the discritized points is written. The 
order of the data is according to the following pseudo code:
num_values = 0
for(z=0; z<z_resolution; ++z) {
  for(y=0; y<y_resolution; ++y) {
    for(x=0; x<x_resolution; ++x) {
      value_array[num_values] = value_at_this_location
    }
  }
}
write(file_name,value_array)

2. Be sure Brick of Values is selected as the Format type.
3. Follow the instructions given.
4. Select the desired variable.
5. If the variable is a vector, select the component desired.
6. Select the sampling resolution.
7. Select the sampling format, Brick of Bytes or Brick of Floats.
8. Enter a file root name.
9. Click Okay.

1. Select File > Save > Geometric Entities...
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Saving Parts in User Defined Writer Formats
(Flatfile, HDF 5.0, ...)

The userd-defined writers can call the routines of an EnSight API to retrieve, for example, nodal coordinates, node 
ids, element ids of parts selected in the Parts window, to be passed by value to be used, manipulated and/or written 
out in any format desired. The User-defined writer dialog includes a Parameter field that allows the passing of text 
into the writer from the GUI.  This text could contain extra options which the writer understands. 

Several example writers (including source code header files, Makefile and the corresponding shared library) are 
included to demonstrate this capability. 

The Case (Gold) Lite reader is included to demonstrate how to exercise most of the API and output a subset of the 
Case (Gold) format. Complex numbers and custom Gold format are not supported with this writer. The Case (Gold) 
writer ignores the Parameter field. While the writer is not compiled, the source code of this writer, the required header 
files, and the Makefile are included.

The Flatfile user-defined writer is designed to demonstrate the output of selected part nodal data (coordinates & IDs) 
as well as active variable values (scalar and/or vector only) in a comma delimited format easily imported into other 
applications.  If any of the keywords ‘ANSYS’ or ‘force’ or ‘body’ is entered into the Parameter field, then Flatfile will 
output an ANSYS body force file.  

The HDF 5.0 writer is designed to write out selected parts and their corresponding active variables using the HDF 5.0 
API which is compatible with the EnSight HDF user-defined reader. The HDF writer ignores the Parameter field.

The STL user-defined writer is designed to write out the border geometry in the form of triangular 2D elements of the 
selected part(s) at the beginning timestep.  The end time and the step time are ignored.  The STL format does not 
support multiple parts in a single binary file, but does support multiple parts in a single ASCII file.  Therefore, if multi-
ple parts are selected and ascii is checked, the STL writer outputs an ascii file with the border of each of the parts.  If 
multiple parts are selected and binary is checked, the STL writer outputs a binary file containing a single border of the 
multiple parts.  The STL writer only saves the beginning timestep and ignores the End Timestep and Step By fields.  
The STL writer ignores the Parameter field.

2. Select the desired user defined writer format.
3. Follow the instructions given.
4. If the writer accepts parameters, enter any desired ones in the 

Parameter(s) field.
5. Enter a file root name.
6. Save as binary or Ascii file, based on this toggle.
7. If the dataset is transient, specify the Time Step info.

(Note that some writers produce static data, and thus may only use the 
Begin Time Step info)

8. Click Okay.

1. Select File > Save > Geometric Entities...
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There are some important differences in how EnSight saves parts according to format chosen.

More user-defined writers may be distributed with EnSight in the future.

SEE ALSO
User Manual: Saving Geometric Entities

Readme file is $CEI_HOME/ensight80/src/writers/README

User Defined Writers (UDW)

Which parts are available to the UDW? All parts currently selected in the Main Parts List (except those indicated below)

Where are the available parts located? EnSight server

Which parts are unavailable to the UDW? Any client-based part: contours, vector arrows, particle traces, profiles
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Save/Restore Context

INTRODUCTION
EnSight context files can be used to duplicate the current EnSight state with the same or a different, but similar, 
dataset. The context file works best if the dataset it is being applied to contains the same variable names and parts, 
but can also be used when this is not the case.

BASIC OPERATION

An EnSight context consists of a set of files: the context file itself as well as associated palette, view, and keyframe 
animation files.  The names of the associated files will be that of the context file with a standard extension.

Saving a Context

Restoring a Context
Three options:
1) Start EnSight and restore a context as described below. This will recreate the parts of the original dataset 

and restore them to their saved condition. 
2) Start EnSight, read a new dataset, cancel the part loader without creating parts, and restore a context as 

described below. This will create the parts of the new dataset (mapping as directed) and restore the 
context of the original dataset.

3) Start EnSight, read a new dataset, create the desired parts, and restore a context as described below. This 
will do the mapping (as directed) of parts and restore the context of the original dataset.

1. Select File > Save > Context... to open the Save Current Context dialog.

2. Toggle Save Current Case Only or Save All Cases.
3. Enter a name for the Context File.

You can set the directory for the Context File by clicking the 
Select File... button to open a standard File Selection dialog.

4. Click Okay.

1. Select File > Restore > 
Context...

2. Select the case to 
restore the context to.
Note: If the context file 
contains information for 
multiple cases, ignores the 
selection

3. Enter or select the 
desired context file

4. Click Okay.
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OTHER NOTES
The same part names (and variable names) do not have to exist in the new case. If this situation arises, a pop-up 
dialog will appear where you will be asked to match the part names (or variable names) from the context file with the 
parts (or variables) from the new case. This dialog is not available in batch mode. Therefore, you can’t use a context 
file that needs matching in batch mode.

When restoring context files with multiple cases, the needed cases will be started, if needed, according to the 
connection scheme of the current run of EnSight.

Flipbook animations are not restored using the context file because it is unknown at the time the context file is 
created what state existed when the flipbook was saved.

If data is not read before restoring the context file, the data that was used when the context file was saved will be 
loaded.

Context files use EnSight’s command language and other state files (such as palette, view, and keyframe animation) 
to recreate the parts, variables, and view state.

SEE ALSO
User Manual:  File Menu Functions
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Save Scenario

INTRODUCTION
Scenario files are used by CEI’s EnLiten product which is capable of viewing all geometry (such as parts, annotation, 
plots, etc.) that EnSight can display, including flipbook, keyframe, and particle trace animations.

A “scenario” defines all visible entities you wish to view with EnLiten and includes any saved views and notes that you 
want to make available to the EnLiten user.

BASIC OPERATION
1. Create the display you want to share with 

the EnLiten user.

2. Select File > Save > Scenario... to open 
the Save Scenario dialog.

3. Select File to save a scenario file only, or 
Project to save the scenario, jpg image 
file, and EnSight context file.

4. Choose the EnLiten1 or CSF format.

5. Enter a name for the Scenario file/
directory. You can set the root directory 
for the Scenario by clicking the Select... 
button to open a standard File Selection 
dialog.

6. If you currently have flipbook, keyframe, 
and/or particle trace animations, indicate 
if you want these saved to the scenario 
file.

7.  Save the scenario.

ADVANCED USAGE
After the scenario has been saved you may 
save additional views by setting the desired 
view in EnSight, then selecting the “Add 
Current View...”.  You will be asked to name 
the view in a resulting pop-up dialog.

After the scenario has been saved you may 
write notes regarding the scenario by entering 
a Subject line and typing in the notes input 
area.  When satisfied, select the “Save Note” 
button.
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OTHER NOTES
EnLiten is a geometry viewer only. As such it is not capable of creating or modifying any new/existing information 
such as variables or parts, or of changing timesteps. 

Since EnLiten is only a geometry viewer, only keyframe transformation information is stored when saving a scenario 
file, i.e., no transient data keyframing is possible (consider loading a flipbook instead).

SEE ALSO
User Manual:  File Menu Functions
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Output for Povray

INTRODUCTION
EnSight can output a file which can be read into POVRAY (Persistence of Vision Ray Tracing). This allows EnSight 
images to be able to have shadows and reflections which ray tracing can provide. POVRAY must be downloaded and 
installed separately from EnSight (www.povray.org).

Note: This option requires that you have an EnSight Gold license

BASIC OPERATION
The process is:
1. Run ensight and produce the desired image in the graphics window.
2. Go to File > Print/Save Image and set the Format to POVRAY Geometry and save.

This will produce the following files (samples of which are given in the Other Data section below):
                filename.pov
                filename.inc
                ensight_to_pov_globals.inc
3. Edit ensight_to_pov_globals.inc as desired to control global information. You may also edit the filename.inc file 

which contains information for each part.
4. Run POVRAY
                povray width=800 height=600 filename.pov

This will produce the file:
                filename.png
5. Run Envideo8 using this file:
                envideo8 filename.png

EnSight Images - No POVRAY
EnSight Images which have been run 
through POVRAY
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OTHER DATA

ensight_to_pov_globals.inc
This is the editable text file to be used to customize the camera and lightsource information, and the part by part color 
and material properties (ambient, diffuse, specular, roughness, and reflectivity). This file will be included into 
filename.inc and parameters in this file will supersede the default values in filename.inc. 

////////////////sample ensight_to_pov_globals.inc //////////////////////
//
// This file is useful in controlling multiple file outputs
// (i.e., output from the keyframe animator).  Uncomment/edit items
// and they will be used instead of the settings in the .inc file
//

// Uncomment this next line if you uncomment anything
//#declare display_warning = 1;

//#declare camera_location = <-0 0 8366.19>; 
//#declare camera_look_at  = <-0 0 -16.7612>; 
//#declare camera_angle    = 28.000000;

//#declare light_location  = <-15241.7 15241.7 76191.9>; 
//#declare light_color     = rgb <1 1 1>;

// This will set reflective value for all parts 
//#declare reflect_value   = .1;

// If you want to set the color for a part you would do this 
// (useful if you have many .pov files since all the .inc files 
// include this file)

//#declare Part_1_material = texture { 
//  pigment { color rgbt <1. 0. 0. 0.> } 
//  finish { 
//    ambient 0.3 
//    diffuse 1.0 
//    specular 0.0 
//    roughness 0.2 
//#ifdef (reflect_value) 
//    reflection reflect_value 
//#else 
//    reflection .1 
//#end 
//  } 
//} 
#declare Part_495_material = texture {
   pigment { color rgbt <0.600000 0.600000 0.600000 0.000000> }
   finish {
     ambient 0.300000
     diffuse 1.0
     specular 0.000000
     roughness 0.027778 
#ifdef (reflect_value)
     reflection .2 
#else
     reflection .2 
#end
  }
}

Page 2 of 4



filename.inc
This text file has a statement that includes ensight_to_pov_globals.inc and then has the default global camera and 
lightsource information as well as default Part by Part values of color and material properties.     

///////////////////////sample filename.inc ///////////////////////////// 
#include “ensight_to_pov_globals.inc”

#ifdef (display_warning) 
#debug “\n*********************************************************\n” 
#debug “                                                           \n” 
#debug “  Have applied settings for ensight_to_pov_globals.inc!!   \n” 
#debug “                                                           \n” 
#debug “\n*********************************************************\n” 
#end

camera { 
#ifdef (camera_location)
    location camera_location 
#else
    location <-0 0 8837.74> 
#end 
#ifdef (camera_look_at)
    look_at camera_look_at 
#else
    look_at  <-0 0 0> 
#end 
#ifdef (camera_angle)
    angle camera_angle 
#else
    angle 28.000000 
#end
}

light_source { 
#ifdef (light_location)
    light_location 
#else
    <-14334 10667.6 78331> 
#end 
#ifdef (light_color)
    color light_color 
#else
    color red 1 green 1 blue 1 
#end }

#ifndef (Part_1_material) 
#declare Part_1_material = texture {
   pigment { color rgbt <1.000000 0.000000 0.000000 0.000000> }
   finish {
     ambient 0.300000
     diffuse 1.0
     specular 0.300000
     roughness 0.027778
#ifdef (reflect_value)
     reflection reflect_value 
#else
     reflection .1 
#end
   }
} 
#end

#ifndef (Part_2_material) 
#declare Part_2_material = texture {
   pigment { color rgbt <1.000000 0.000000 0.000000 0.000000> }
   finish {
     ambient 0.300000
     diffuse 1.0
     specular 0.300000
     roughness 0.027778 
#ifdef (reflect_value)
     reflection reflect_value 
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#else
     reflection .1 
#end
   }
}
#end

filename.pov
A text file that has a statement including filename.inc to define camera, lightsource and Part properties. The 
remainder of the file contains coordinates and connectivity defining the surface of the Ensight parts as Povray surface 
triangular elements. This file shouldn’t be edited by the user.

//////////////////////sample filename.pov //////////////////////////// 
#version 3.5;

#include “carapov00.inc” 
#declare Part_1=
mesh2 {
    vertex_vectors {
       297
       <-243.353, -1002.62, 3.4535>,
       <723.621, -213.728, -129.889>,
       <731.815, -205.655, -144.313>,
       <740.01, -197.583, -158.737>,
       <748.204, -189.51, -173.161>,
       <722.484, -203.276, -123.341>,
       <730.534, -195.257, -137.655>,
       <738.584, -187.239, -151.97>,
 .... 
  }
    face_indices {
       490, 
      <1,2,6>,
       <1,6,5>, 
       <2,3,7>,
       <2,7,6>,
       <3,4,8>,
 ...
    } 
}
#declare Part_2= 
mesh2 {
    vertex_vectors {
       2001
       <-243.353, -1002.62, 3.4535>,
       <788.215, -136.402, -241.148>,
       <781.139, -143.803, -228.672>,
     ...
    }
    face_indices {
       490,
       <1,2,6>,
       <1,6,5>,
       <2,3,7>,
       <2,7,6>,
       <3,4,8>,
 ...
    } 
}

object {
   Part_1
   texture {Part_1_material}
   scale <-1 1 1>
}
...

object {
   Part_495
   texture {Part_495_material}
   scale <-1 1 1> 
} 
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Manipulate Viewing Parameters
Rotate, Zoom, Translate, Scale

INTRODUCTION
EnSight provides global transformations (rotation, translation, and zooming) to permit user manipulation of objects in 
the Graphics Window.  The transformations can either be performed interactively with the mouse, or precisely by 
entering explicit values.  The mouse buttons can be user-programmed to perform different transformations.

BASIC OPERATION
The Transformation Control Area controls the operation of the left mouse button (by default) in the Graphics Window.  
The icon of the current action will be highlighted (e.g. Rotate is current below):

Select Part [or View] mode in the Mode Selection area.

To rotate:
1. Click the rotate icon.
2. Move the mouse pointer into the Graphics Window.
3. Click and hold the left mouse button and:

• move the mouse left and right to rotate about the screen Y (vertical) axis, or
• move the mouse up and down to rotate about the screen X (horizontal) axis, or
• hold down the Control key and move the mouse left and right to rotate about the screen Z axis.

4. Press the F1, F2 or F3 keys for 45 degree rotation about the X, Y, or Z axis, respectively. Hold the Control 
key down for -45 degree rotation. (Note: cursor must be in the EnSight window for F keys to work)

5. Press +X to view the scene from the positive X axis (looking toward the origin).  The +Y, +Z, -X, -Y, -Z 
buttons are similar.  Press the “Last” button to get the scene back to the view that existed before any of 
the +/-XYZ keys were pressed.

To translate:
1. Click the translate icon  (or use the middle mouse button in steps 2 and 3 (default)).
2. Move the mouse pointer into the Graphics Window.
3. Click and hold the left mouse button and:

• move the mouse left and right to translate in the screen X (horizontal) direction, or
• move the mouse up and down to translate about the screen Y (vertical) direction, or
• hold down the Control key and move the mouse left and right to translate in the screen Z
   direction.

To zoom:
1. Click the zoom icon  (or use the middle mouse button in steps 2 through 5 (default)).
2. Move the mouse pointer into the Graphics Window.
3. Click and hold the left mouse button.
4. Drag down to zoom in or drag up to zoom out.
5. Hold down the Control key and move the mouse to pan.

To rubber-band zoom:
1. Click the rubber-band zoom icon.
2. Move the mouse pointer into the Graphics Window and position it at one corner of the desired viewing 

region.
3. Click and hold the left mouse button.
4. Drag to include the desired viewing region.  An outline of the region will appear as you drag.

Zoom

Open the Transformation
Editor dialog

Translate Rubber-band zoom

Open the Reset Tools and 
Viewport(s) dialog

Rotate

View from directions

Store / Recall 
stored view

Undo last transformation

Selection Tool
Rubber-band Positioning

Fit to window
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To rubber-band zoom using the selection tool:
1. Click the Selection Tool Rubber-band Positioning icon.
2. Move the mouse pointer into the Graphics Window and position it approximately at one corner of the 

desired viewing region.
3. Click and hold the left mouse button.
4. Drag to include the desired viewing region. An outline of the region will appear as you drag.
5. Manipulate the tool as desired, by clicking at the center and dragging to a new position or clicking on any 

corner and resizing. (Note that the aspect ratio will be preserved as indicated by the dotted lines within the 
tool.)

6. Click the zoom (magnifying glass) indicator at the top left of the tool.

Note that zooming actually changes the location of EnSight’s virtual “camera” or “look-from” point. Zooming in moves 
the camera closer to the object; zooming out moves it farther away. The look-from/look-at points can also be edited 
explicitly.

If you have multiple viewports visible, each one can be manipulated independently.  To transform in a different 
viewport, place the mouse pointer within the bounds of that viewport before you click the left mouse button.

You can reset transformation parameters (as well as tool and frame transforms) by clicking the Reset....   See How 
To Reset Tools and Viewports for more information.

The Fit button is useful in causing the currently visible parts to be centered and zoomed to fit within the viewport.

ADVANCED USAGE
All EnSight transformations can be controlled precisely by specifying explicit transforms in the Transformations Editor 
dialog. To open the dialog, click the Transf Edit... icon on the desktop. The slider performs the requested 
transformation (based on the selected transformation action) in the selected viewport(s).

You can also perform scaling in any or all dimensions (to, for example, magnify subtle differences in a surface).  
Although you cannot perform the scaling operation with the mouse, you can scale using the Transformations dialog.  
Click the Scale icon in the Transformation Control area and specify the scaling as described above.

You can copy the transformations from one viewport to another. First select the viewport you wish to copy, select  
Editor Function->Copy Transformation State, then select the viewport(s) you wish to modify and select  Editor 
Function->Paste Transformation State.

Slider to specify 
transform.

Set (by clicking within 
the desired region) the 
viewport that the 
transform applies to.

Specify axis to which 
the transform applies

Limit controls the sensitivity and 
limit of the slider action.

Increment controls the 
step size for the slider 
end arrows.

Enter explicit values in 
the Increment field 
(and press return) to 
transform by a precise 
amount.

To interactively perform 
transformations on multiple 
viewports, select viewports 
then toggle on.

Select the desired 
transformation action.
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OTHER NOTES
By default, EnSight uses the left mouse button for performing the selected transformations. You can, however, 
program the transformation action attached to each mouse button. See Customize Mouse Button Actions for more 
information.

The transformation operations described here also apply to frame transformations.  If additional frames have been 
created and if the mode has been set to Frame, then any transform will apply to the currently selected frame.  See 
Create and Manipulate Frames for more information.

Pressing the F5, F6, or F7 keys while the mouse is within the EnSight graphics window or desktop area will transform 
the scene to show a standard right, top, or front view, respectively. Pressing the F8 key will return the scene to that 
which existed prior to F5, F6, or F7 being pressed. Further, holding the Control key down while pressing F5, F6, or F7 
will store the current view to the selected Fx button.

Pressing F9 while the mouse is in the Graphics Window or the desktop area will zoom the display to full screen.  
Press F9 again to return to the normal display.

SEE ALSO
Other viewing operations: How To Set LookFrom/LookAt, How To Set Z Clipping, How To Create and 
Manipulate Frames, How To Reset Tools and Viewports, How To Use the Selection Tool.

User Manual: Global Transform, Frame Transform
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Set Drawing Mode (Line, Surface, Hidden Line)

INTRODUCTION
EnSight provides two basic drawing styles for graphics objects: line or shaded.  Line mode draws only the line 
segments of an object – regardless of the whether the lines are polygon edges or not.  Shaded mode displays all 
objects consisting of polygons (e.g. element or cell faces) as solid filled regions with light source shading enabled.

These drawing styles can be enhanced by enabling hidden-line mode.  If the current mode is line, hidden-line will 
eliminate all those lines that would be invisible if the object were a solid surface.  If the current mode is shaded, 
hidden-line mode will draw lines overlaying face edges.  In shaded mode, hidden-line overlays are particularly useful 
for visualizing computational grids.

The setting of line or shaded mode is a global toggle.  You can also set the mode on a per part basis so that some 
parts are displayed as lines and others as shaded surfaces.  Each viewport also provides individual controls so that 
the drawing mode can differ from viewport to viewport.

BASIC OPERATION
The global toggles for shaded and hidden-line mode are available from the desktop.  You can also enable these 
modes by selected View > Shaded or View > Hidden Line. To use the desktop toggles:

Note that hidden-line and hidden-line overlay are disabled during interactive transformations.  The drawing 
calculations required for these modes can be quite substantial for large models – so much so that interactive 
manipulation would be unacceptably slow.

Note also that hidden line overlay mode is disabled if transparency is on.

Line mode Shaded mode Hidden-line mode Hidden-line overlay mode

1. Click the Shaded toggle to switch from line to 
shaded mode (or vice-versa).

2. Click the Hidden Line toggle to enable or 
disable hidden-line mode.

If the current mode is Shaded when you toggle on 
Hidden Line, the Hidden Line Overlay dialog is 
displayed.  This dialog allows you to specify a color for 
the overlay edges.  If Specify Line Overlay Color is not 
enabled, overlay color will be set to the native color of 
each part.  If it is enabled, the color can be specified 
either by entering red, green, blue color values, or by 
clicking the Mix... button and picking a color with the 
standard Color Selector dialog.

Line Shaded

Unhidden Hidden
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The per-part toggles for shaded and hidden-line mode are available in Part mode.

Note that enabling shaded mode for a part has no effect unless the global shading toggle is also enabled (on the 
desktop or under the View menu). The same is true for hidden-line: unless the global hidden-line toggle is enabled, 
the part will be drawn without hidden lines.

ADVANCED USAGE
Drawing modes can also be set on a per-viewport basis.  As with per-part settings, these toggles require that the 
corresponding global toggle is also set to have any effect.

OTHER NOTES
When a part is drawn in shaded mode (with or without hidden-line overlay) the surface is displayed with light source 
shading enabled. EnSight uses two pre-defined light sources: one at the look-from point (the camera) and one on the 
opposite side of the model (for back-lighting).   The location of one of the light sources can be changed, see How To 
Control Lighting Attributes.

In computer graphics, the appearance of a shaded surface is governed by a lighting model controlled by various 
parameters.  In EnSight, these parameters are part of the part’s attributes and can be changed on a per-part basis.  
See How To Set Attributes for more information.

SEE ALSO
How To Control Lighting Attributes

User Manual: Global Shaded, Global Hidden Line

1. Select Part in the Mode Selection area.

2. Click the Shaded toggle to switch from line to 
shaded (or vice-versa).

3. Click the Hidden Line toggle to enable or 
disable hidden-line mode.

Line Shaded

Unhidden Hidden

1. Select VPort in the Mode Selection area.

2. Select (click in) the desired viewport in the Graphics 
Window.

3. Click Viewport Special Attributes...  to open the 
Viewport Special Attributes dialog.

4. Click the Shaded button to disable shading in the 
current viewport.

5. Click the Hidden Line button to disable hidden-line in 
the current viewport.
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Set Global Viewing Parameters

INTRODUCTION
EnSight provides various modes that control global viewing behavior.  Three of these modes are discussed here: 
perspective/orthographic projection, bounding box display modes, and static lighting.

EnSight can display viewports in either perspective or orthographic projection.  A perspective projection is how we 
normally view the world: objects that are farther away appear smaller.  An orthographic projection removes this effect: 
objects appear the same size regardless of distance.  The projection setting can be specified on a per-viewport basis.

By default EnSight draws every point, line, and polygon for every visible part each time the Graphics Window 
updates. For very large models (or slow graphics hardware), this behavior leads to unresponsive manipulations since 
the update lags behind the corresponding mouse motion. Fortunately, EnSight provides other display modes that 
improve responsiveness. Fast Display mode displays a bounding box around, a point cloud for, polygon reduced 
version, or if using immediate mode - a percentage only of all visible parts to be displayed during interactive 
manipulations. When the mouse button is released, parts are drawn normally. The Fast Display mode can also be set 
such that the bounding display is used until the mode is changed - even when the mouse is released. (Edit-
>Preferences... Performance - Static Fast Display)

Surface shading operations are expensive for very large models.  Since the shading is dependent on the orientation 
of the model with respect to the light sources, the surface colors must be recalculated each time the model moves.  
Static lighting mode precalculates surface colors for a given orientation and then uses these colors during 
subsequent transformations, resulting in improved interactive response.

BASIC OPERATION

Perspective/Orthographic Projection
The projection mode can be toggled either from a menu (View > Perspective) or in the VPort icon bar. To set the 
projection from the icon bar:

1. Select VPort in the Mode Selection area.

2. Select (click in) the desired viewport in the Graphics 
Window.

3. Click Viewport Special Attributes... to open the 
Viewport Special Attributes dialog.

4. Click the Perspective button to toggle the projection 
type in the current viewport.

Note that a viewport will only display a perspective projection 
if the global toggle (as set with View > Perspective) is on as 
well.
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Fast Display Mode
The Fast Display Mode can be set either from a menu (View > Fast Display > ) or by the Fast Display toggle on the 
desktop. To change between the Dynamic or Static operation of this mode, go to Edit->Preferences... Performance. 
To change the part representation for Fast Display Mode:

Static Lighting
The Static Lighting setting is only available from the View menu. Select View > Static Lighting to enable or disable 
static lighting. Although interaction speed is improved in static lighting mode, note that the light source appears to 
rotate with the object. This is often an acceptable trade-off.

ADVANCED USAGE
If using immediate mode, and you desire to use the Sparse Model option for Fast Display, you can control the 
percentage of the model that is displayed.  See “Performance Preferences” . This mode is intended for large 
models. It generally will not be pleasing (nor should it be needed) for small models.

SEE ALSO
User Manual: See “Part Mode”  and Static Lighting

1. Click the Fast Display Representation pull-
down icon.

2. Select Dynamic Box.

    or

3. Select Points.

    or

4. Select Reduced poly.

Select Off to return to standard display 
mode.

Note, if using immediate mode a Sparse 
Model option will also be available here.
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Set Z Clipping

INTRODUCTION
As you apply zoom transformations in EnSight, you may have noticed that the model begins to progressively 
disappear as you move close to the model.  This happens when the visible model parts intersect the front Z clipping 
planes.  The Z-clip planes (which are always perpendicular to your line of sight) are specified as distances from the 
look-from point (the camera position).  The Z clipping plane positions can be set by the user and can be used to 
remove unneeded geometry from the display.  Each viewport has it’s own set of Z clipping planes. By default, the Z-
clip planes adjust (float) with the model - thus stay out of the way if possible.

BASIC OPERATION
The initial position of the Z clipping planes is set based on the Z (depth) extent of the visible geometry – plus quite a 
bit extra to leave room for transformations.  The plane positions can only be set via the Transformation Editor dialog.

Each viewport maintains it’s own independent Z clipping planes.  The operation described above will change the 
planes for the current viewport (as set by clicking in the desired viewport in the Graphics Window).

Note that clicking Reinitialize, in the Reset Tools and Viewport(s) dialog found under the Reset... button of the 
Transformations area, will reset the Z clipping planes of the current viewport based on the Z extent of all objects 
currently visible in that viewport.

OTHER NOTES
EnSight uses your workstation’s graphics hardware to implement Z clipping.  The same hardware is used for Z-
buffering – determining which objects are visible based on Z (depth) values.  The Z buffer typically provides 24 bits of 
resolution.  EnSight attempts to make the best use of this limited resolution by setting the front and back clipping 
planes reasonably close together.   If the planes are too far apart, relative Z resolution is reduced and the hardware 

1. In the Transformation Control area, Click Transf... > Editor Function > Z_clip to open the 
Transformation Editor.

The graphics display shows the relative positions 
of the front and back clipping planes (left and right 
vertical red lines) to the Z extent of all currently 
visible objects (white box).

2. Toggle the Float Z-Clip Planes option on to 
have the Z-clip planes automatically adjust.

OR
    Toggle the option off to manually adjust the 

Z-clip plane locations.

If the Float Z-Clip option is off, you can edit the 
plane positions either by dragging the red lines or 
by entering explicit values in the Front and Back 
text fields.  Recall that the values represent the 
distance from the look-from point to the plane.

3. Place the mouse pointer over the desired 
plane marker and click the left mouse 
button.

4. Drag the marker left or right to the desired 
location.  The Graphics Window will update 
as the marker is moved.

        – OR –
3. Enter explicit values in the Front and/or 

Back text fields and press return.

If the markers become difficult to manipulate due 
to changes, click the Redraw Z-Clip Area Above 
button to rescale the markers.

If the Float Z-Clip Planes With Transform option is on,
you can specify the minimum Z value that the Front clip
plane can float to. 
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may not be able to accurately determine surface visibility.  If you see artifacts like this, move the clipping planes 
closer together.

EnSight also provides an additional clipping plane: the auxiliary clipping plane.  Unlike the Z clipping planes which are 
always perpendicular to your line of sight, the auxiliary clipping plane can be placed at any location in any orientation.  
The Plane Tool specifies the location of the auxiliary clipping plane.  By default, all geometry on the negative Z side of 
the Plane Tool is removed.  However, you can specify auxiliary clipping on a per part basis – some parts are clipped 
while others are not.  See How To Set Auxiliary Clipping for more information.

SEE ALSO
How To Define and Change Viewports, How To Set Auxiliary Clipping

User Manual: Z-Clip
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Set LookFrom / LookAt

INTRODUCTION
In addition to providing control over model manipulations, EnSight also provides control over the virtual camera used 
to view the scene in the Graphics Window.  The two control parameters are the look-from point (the position of the 
camera) and the look-at point (a point on the camera’s line-of-sight vector).  The Global Axis is positioned at the look-
at point and is always in the center of the Graphics Window.

Initially, the look-at point is set to the geometric center of all visible objects and the look-from point is set to a point on 
the positive Z axis such that all visible objects fit in the Graphics Window (as shown in the top image below).  The 
white axis triad is the Global Axis and can be displayed by selecting View > Axis Visibility > Axis - Global.  The bottom 
image shows the view after the look-from point has been repositioned between the X and Z axes.  The diagrams to 
the right of each image show a top-down schematic of each viewing case.

BASIC OPERATION
The look-from, look-at points are controlled via the Transformation Editor dialog.

1. Click Transf... in the Transformation Control Area.

2. Select Editor Function > Look At/Look From.

x

z

x

z
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The Transformation Editor dialog provides two methods for setting the look-at and look-from points.  Numeric values 
can be entered directly into the X,Y,Z Look At, Look From text fields (remember to press return).  You can also enter 
a value in the Distance field to explicitly move the look-from point a certain distance away from the look-at point.

Alternately, the Viewer Area can be used to interactively manipulate the points.  The presentation of the Viewer Area 
depends on the which plane toggle is set: X-Y (view from the positive Z axis), Y-Z (view from the positive X axis), or 
X-Z (view from the positive Y axis – the default).  In each case, the gray box represents the extent of all visible parts.  
The intersection of the two red lines is the look-from point.  The opposite end of the long red line is the look-at point 
(which is initially near the center of the gray box).   The example below shows the X-Z Plane presentation, the others 
behave analogously.

During your manipulation, the display in the View Area may become difficult to use.  Click the “Redraw Viewer Area 
Above” button to rescale the display.

The Viewer Area Control Lock pull-down menu effects interactive operation in the Viewer Area as follows:

None No constraints are placed on movement of either the look-from point or the look-at point.

Distance Movement of the look-from (look-at) point is restricted to a circle whose radius is the current Distance 
value and whose center is the look-at (look-from) point.

Together The movement of both points is locked such that movements applied to one are applied to the other.

You can easily reset the look-from and look-at points such that all currently visible parts are displayed. Click Reset... 
in the Transformation Control area to open the Reset Tools and Viewports dialog. Click the Reinitialize button to reset 
the currently selected viewports.

Text fields for 
entering numeric 
values

Viewer Area for 
interactive 
manipulation

Viewer Area plane 
toggles

Text field for 
moving look-from 
by setting an 
explicit distance

To change the look-from point:
1. Place the mouse pointer over the 

intersection of the two red lines.

2. Click and drag to the desired 
location.  Note that the Graphics 
Window updates as the look-from 
point is moved.

To change the look-at point:
1. Place the mouse pointer over the free 

end-point of the long red line.

2. Click and drag to the desired location.  
Note that the Graphics Window 
updates as the look-from point is 
moved.
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OTHER NOTES
You can also set the look-at point by picking an object with the mouse in the Graphics Window:

Other camera parameters, such as the camera up direction and the field-of-view angle, cannot be set in this release.

SEE ALSO
How To Define and Change Viewports.

User Manual: Look At/Look From

1. Click Reinitialize in the Reset Tools and Viewport(s) 
dialog to clear all global transformations.

2. Click the Pick button in the global area above the 
graphics window on the desktop.

3. Select Pick Look/At Point from the Pick Pull-down 
icon.

4. Move the mouse into the Graphics Window. Place the 
mouse pointer over the point you wish to set to the 
look-at point and press the ‘p’ key (or whatever 
mouse button you have set for “Selected Pick 
Action” in Edit > Preferences > Mouse and 
Keyboard).
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Set Auxiliary Clipping

INTRODUCTION
Unlike standard Z clipping where the front and back planes are always perpendicular to your line of sight, auxiliary 
clipping lets you clip parts against a plane with arbitrary position and orientation.  In addition, the auxiliary clip 
attribute can be set on a per-part basis.  This permits selective clipping to reveal objects of interest.

EnSight’s Plane Tool is used to provide the location for auxiliary clips.  As the Plane Tool is manipulated (either 
interactively with the mouse or via the Transformations dialog), the display in the Graphics Window updates to reflect 
the new location of the plane.

BASIC OPERATION

The Plane Tool will become visible and all objects on the negative Z side of the plane will be clipped (assuming the 
plane currently intersects some visible part). You can now manipulate the Plane Tool to achieve the desired display 
effect (see How To Use the Plane Tool for details). Note that Auxiliary Clipping always uses the infinite extent of the 
plane specified by the Plane Tool – there is no way to restrict it to the rectangular bounds of the tool.

Each part has an attribute that controls whether it is clipped by the Auxiliary Clipping plane or not.  To toggle this 
setting:

SEE ALSO
How To Use the Plane Tool,  How To Set Z Clipping.

User Manual: Part Auxiliary Clipping, Global Auxiliary Clipping

Auxiliary clipping can be globally enabled by 
selecting it in the View menu:

1. Select the desired part (see How To Select Parts).

2. Select Part Mode in the Mode Selection area.

3. Click the Auxiliary Clipping toggle.

(This attribute can also be toggled in the Feature Detail Editor 
dialog for the part.  See How to Set Attributes for more 
information.)

Off On



Define and Change Viewports

INTRODUCTION
EnSight provides up to sixteen user-defined viewports in the Graphics Window.  Each viewport is a rectangular region 
of the screen (with or without a border) displaying some or all of the currently visible parts.  Each viewport can be 
transformed (e.g. rotated or zoomed), sized, and  positioned independently.  Viewports have several display 
attributes including background and border color.  Viewports provide a very flexible environment for data display.

This article is divided into the following sections:

Create a New Viewport
Select Viewports
Move and Resize Viewports
Set Viewport Background Color or Image
Set Viewport Attributes
Display Selected Parts in Viewports
Set Case Visibility Per Viewport
Perform Transformations in Viewports
Reset Viewport Transformations
Delete Viewports

BASIC OPERATION

Create a New Viewport
On startup, EnSight creates a single viewport that fills the Graphics Window.   To create a new viewport:

Select Viewports
When you create a new viewport, it automatically becomes the currently selected viewport (as shown by the border 
drawn in the default highlight color). Any action to change viewport attributes always operates on the currently 
selected viewport(s). To select viewports:

1. Click VPort in the Mode Selection area to 
enter Viewport mode.

2. Click the Viewports Layout pull-down icon 
to select any of the standard viewport 
layouts. 

OR
2. Click the New Viewport icon.

1. Click VPort in the Mode Selection area to enter Viewport mode.

2. Move the mouse pointer into the Graphics Window and click the left mouse button anywhere within 
the desired viewport.  You can add to an existing selection by holding down the Control key as you 
click in additional viewports.

To select all viewports, click the icon:

 

Note that the selected viewport is also changed in other modes (such as View) any time you perform some action 
in a viewport (such as rotation). There is however, no visual feedback of this change until you enter VPort mode 
again.
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Move and Resize Viewports
Viewports can be easily moved and resized.  You can either reposition a viewport with the mouse in the Graphics 
Window, or precisely by entering exact values.  To move or resize a viewport:

1. Click VPort in the Mode Selection area to enter Viewport mode.

2. Select the desired viewport.

3. To move a viewport, move the mouse pointer into the Graphics Window and into the selected viewport.  
Click and hold the left mouse button and drag the viewport to the desired location.

4. To resize a viewport, move the mouse pointer into the Graphics Window and place it over one corner of 
the selected viewport.  Click and hold the left mouse button and drag the corner to the desired 
location.

To precisely reposition a viewport:

3. Click the Viewport Location Attributes icon 
to open the Viewport Location Attributes 
dialog.

4. Enter new values in the Origin X,Y, Width, or 
Height fields (and press return).

The origin (at 0,0) is the lower left corner of the 
Graphics Window.  Note that the values are 
normalized to the width and height of the default 
viewport (i.e. the Graphics Window).

EnSight permits overlapping viewports.  You can 
control the ordering (from front to back):

Click The Viewport Forward icon to bring the 
selected viewports to the top.

Click The Viewport Back icon to send the 
selected viewports to the bottom.

Note: Viewport 0 is always displayed first, thus it 
cannot be pushed or popped with these icons.
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Set Viewport Background Color or Image
Viewport background colors can be constant, blended, or inherited from the default viewport.  To set viewport 
background color:

1. Click VPort in the Mode Selection area to enter 
Viewport mode.

2. Select the desired viewport(s).

3. Click the Color icon to open the Viewport 
Background Color Attributes dialog.

The Type pull-down controls the type of background 
coloring used. There are four types: Constant, blended, 
inherit, and image.

Constant
A constant color will be used for the entire background.  
To set a constant color:

4. Select Constant from the Type pull-down.

5. Either enter values in the RGB color fields (and 
press return OR click the Mix Color... button to 
open the Color Selector dialog.

6. Click Refresh Viewport.
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Blended
Up to 5 horizontal level colors can be specified with 
interpolation between levels.  To set a blended 
background:

1. Select Blended from the Type pull-down.

2. Enter the desired number of levels in the # of 
Levels field (and press return).  Up to five 
levels are supported.

3. To edit a color, first select it by clicking on the 
number label in the Viewport Color window.  
As shown, level 2 is currently selected. 
Alternately, you can enter a value in the Edit 
Level field or click the up/down arrows.

4. Change the selected color by either entering 
new values in the RGB fields (and pressing 
return) or clicking the Mix Color... button to 
open the Color Selector dialog.

5. You can also change the relative vertical 
position of a level by either clicking on the 
level number with the left mouse button and 
dragging up or down OR by entering a new 
value in the Position field (and pressing 
return).

6. Click Refresh Viewport.

Inherit
The selected viewports inherit the background type 
and color from the default viewport.  To set an 
inherited background:

1. Select Inherit from the Type pull-down.

2. Click Refresh Viewport.

Image
The selected viewports inherit the background type 
and color from the default viewport. To set an 
inherited background:

1. Select Inherit from the Type pull-down.

2. Enter the filename for the background image 
to use or click the Select... button and 
navigate to it.
Note, that the image must be either a .xpm or 
.bmp file.

2. Click Refresh Viewport.
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Set Viewport Attributes
Viewports can be displayed with a variety of attributes:

1. Click VPort in the Mode Selection area to enter 
Viewport mode.

2. Select the desired viewport(s).

3. Set the desired attribute as described below:

Click the Viewport Visibility Toggle to toggle display 
of the selected viewports on or off (when not in 
VPort Mode).

Click the Viewport Border Attributes icon to open the 
Viewport Border Attributes dialog.

Click the Visible toggle to display a border.

Enter values in the RGB fields (and press return) or 
click the Mix... button to open a Color Selector 
dialog.

Click the Viewport Special Attributes icon to open 
the Viewport Special Attributes dialog.

Each viewport has it’s own toggles for perspective, 
hidden surface, and hidden line drawing styles.  These 
controls will toggle the respective attribute for the 
selected viewports.  See How To Set Drawing Style 
and/or How To Set Global Viewing for more 
information.

In addition, a viewport can be 3D or 2D in nature. If the 
viewport is designated as 2D, only planar parts may be 
displayed in the viewport and transformations will 
become 2D limited.

A viewport can be set such that it will track a node 
number, a part centroid, or one of the part min or max 
values. Thus as a model changes in time, the viewport 
will stay centered on that location. See How To Do 
Viewport Tracking for more information.

Off On
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Display Selected Parts in Viewports
Part visibility can be a set on a per-viewport basis such that some parts are visible in some viewports but not in 
others.  To set part visibility per viewport:

Set Case Visibility Per Viewport
If you have multiple cases in your session of EnSight, you can set viewport visibility for all parts associated with a 
case.  This makes it easy to display one case per viewport.  To set case visibility per viewport:

Perform Transformations in Viewports
You can transform objects in a user-created viewport as easily as in the default viewport (See How To Rotate, Zoom, 
Translate, Scale for details).  For precise viewport transformations, you can use the Transformations Editor on a per 
viewport basis:

1. Select the desired part(s) in the Main Parts list.

2. Click the Part Visibility in Viewport Toggle icon.

The Part Visible in Which Viewport? dialog displays a 
schematic of the current viewports.   The part is currently 
visible in the green viewports but invisible in the black 
viewports.

3. Click in a green viewport to disable display of the 
selected part(s) in that viewport OR click in a black 
viewport to enable display of the selected part(s) 
in that viewport.

Note that a similar interface for setting this attribute 
appears in the General Attributes section of the Feature 
Detail Editor dialog.

1. Select the desired case from the Case menu (Case > casename).

2. Select Case > Viewport Visibility to open the Case Visible in Which Viewport? dialog.

3.  Click in a green viewport to disable display of the selected case in that viewport OR click in 
a red viewport to enable display of the case in that viewport.

1. Click Transf... in the Transformations Control 
area.

2. To perform precise transformations in a 
viewport, click the desired viewport in the 
Which Viewport(s) window and perform the 
transformation.
To select more than one viewport, 
simultaneously hold down the control key 
and click on additional viewports.

Note that this action will change the currently 
selected viewport(s).
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Reset Viewport Transformations
The transformations for one or more viewports can be reset at any time in the Reset Tools and Viewports dialog.

Setting/Changing Viewport Part Bounds
Part bounds can be displayed within a viewport. This is useful for understanding the size of the model domain.

1. Click the Reset... button on the bottom of the desktop.

2. Select the viewport(s) on which the reset will act.

3. Click on the appropriate button to perform the reset 
action desired. 
You can reset the selected action only, all rotates translates 
and scales at once, or do a complete reinitialization of the 
viewport.

1. To turn on part bounds globally, toggle the 
Bounds button on.
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Delete Viewports
A created viewport can be deleted at any time:

Other Notes
You can interactively transform multiple viewports simultaneously by selecting the viewports you want to link together 
and turning on the Link Interactive Transforms toggle. Those viewports that are highlighted in green will now 
transform together for any transformations performed in the Transformation dialog. Linking does not apply to 
transformations performed by the mouse in the graphics window.

You can copy the transformations from one viewport to another. First select the viewport you wish to copy, then select 
Editor Function->Copy Transformation State. Next select the viewport(s) you wish to modify and select
Editor Function->Paste Transformation State.

2. To modify, in Vport mode, any of the settings 
for the bounds display, click the Select 
Viewport(s) Part Bounds Attributes icon.

3. Select General or the XYZ axes tabs.

4. Modify any attributes desired.

Including the visibility toggle if you don’t desire to 
see the bounds in the selected viewports.

1. Click VPort in the Mode Selection area to 
enter Viewport mode.

2. Select the desired viewport(s).
(Hold down the control key to select multiple viewports)

3. Click the Delete icon.
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SEE ALSO
How To Rotate, Zoom, Translate, Scale, How To Control Lighting Attributes

User Manual: VPort Mode
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Control Lighting Attributes

INTRODUCTION
EnSight allows control over the location of the light source for each viewport. This location is specified in terms of 
Azimuth and Elevation relative to the viewport or in what is called “absolute position” - which is relative to the model 
coordinate system. A intensity of a second light source can also be set, but its position is always at the viewer’s 
(camera’s) location.

BASIC OPERATION
To specify the available lighting attributes In EnSight: 

SEE ALSO
User Manual: Lighting Attributes

1. Click Vport mode.

2. Select the viewport(s) for which you want to modify the 
lighting attributes.

3. Click the Selected viewports lighting button.
Which will bring up the Viewport lighting attributes dialog.

4. Choose whether lighting will be relative to the viewport 
(Relative) or relative to the model axis system (Absolute).

5. Manipulate the position of 
Light 1 by typing in Azimuth 
and Elevation or using the 
sliders.

6. If desired, also modify the 
intensity of Light 2 (which is 
at the viewer’s location).

If you are in Relative position 
mode, you can convert to 
Absolute by clicking.

Note that one can easily set the 
light(s) back to the default 
settings.

The effect of using a Relative position, is that when the model is rotated - the light source 
does not rotate - so lighting changes on the model.

The effect of using an Absolute position, is that when the model is rotated - the light source 
rotates with the model - so lighting on the model does not change.
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Display Remotely

INTRODUCTION
EnSight does not support the running of the client on one machine and setting the system display environment back 
to a different machine. It is intended that you actually run the client from the console of the client machine.

The server(s) can of course be run on remote machine(s).

And, of course the various VR combinations of display are valid.

SEE ALSO
How To Use Server of Servers
How  To Setup for Parallel Rendering 
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Save and Restore Viewing Parameters

INTRODUCTION
EnSight’s viewports provide a great deal of flexibility in how objects are displayed in the Graphics Window.  Given the 
complicated transformations that can be performed, it is imperative that users be able to save and restore 
accumulated viewport transforms.

BASIC OPERATION
View saving and restoring is accessed from the Transformations dialog.

Saving Viewing Parameters

EnSight provides a maximum of 16 viewports: the main viewport (which you cannot change) and 15 additional 
viewports.  When EnSight saves one or more viewports, it also includes the viewport number (which is equal to the 
creation order) as a tag.  When you request that one or more viewports be restored, EnSight looks in the saved file 
and searches for tag numbers corresponding to the currently selected viewports.  If it finds a match, it restores that 
viewport.  If there is no match for a selected viewport, it is left unchanged.

Restoring Viewing Parameters
Click Transf... in the Transformations Control area to open the Transformations dialog.

1. Select the viewports you want to restore.  As shown above, click within a viewport to select it.  Hold down 
the control key as you click to select additional viewports.

2. Select Restore View... from the File menu.  Select a file name in the file browser and click OK.

What is Saved
Only global and local (frame) transformations are stored in a view parameters file.  No information is stored for 
viewport attributes, look-from/look-at points, or Z clipping.

Other Notes
By default, the F5, F6, or F7 buttons restore a standard right, top, or front view (respectively) of the selected viewport.  
However, by holding down the Control key while pressing one of these keys, the current view will be saved to that 
key. Subsequent pressing of that key will restore the saved view.  Only Global  transforms are saved / restored by 
these operations, not Frame transforms.

SEE ALSO
How to Define and Change Viewports, How to Create and Manipulate Frames.

User Manual: Save/Restore View

Click Transf... in the Transformations 
Control area to open the Transformations 
dialog.

1. Select the viewports you want to save.  
Click within a viewport to select it.  Hold 
down the control key as you click to 
select additional viewports.

2. Select Save View... from the File menu.  
Select a directory and enter a file name 
in the file browser and click OK.



Create and Manipulate Frames

INTRODUCTION
By default, all parts are assigned to the same frame of reference.  You can, however, create additional coordinate 
frames and assign parts to them.  These frames (and the parts assigned to them) can be manipulated (rotated, 
translated, scaled) independently of other frames.  Some examples of frame usage:

1. You wish to create a copy of a part and display a different variable on the copy.  When you create the copy, a new 
frame is automatically created and the copy is assigned to it.  The new frame can be translated away from the 
original to visualize both variables simultaneously.

2. You wish to create an animation of parts moving independently (e.g. for an exploding view or to “open” a closed 
object with a “hinged door”).  Each dynamic part is assigned to a new frame.  During keyframe animation, the 
frames are manipulated independently to achieve the desired motion.

3. You have a dataset with rotational periodicity but the symmetry axis is not aligned with a major axis.  A new 
frame is created and positioned such that one of it’s axes is aligned with the symmetry axis.

4. You have a dataset that makes correct positioning of EnSight tools difficult, e.g.  a duct not aligned with a major 
axis.  Create a new frame and align one of the axes with the duct.  Since tool positions are always specified with 
respect to the current frame, you can now use the Transformation Editor to accurately position tools along the axis 
of the duct.

In addition to position and orientation, frames have a number of display attributes such as visibility, line width, and 
color.  You can also specify the length of each axis separately and display a series of evenly spaced labels to use as 
a 3D measuring tool.

Frames are a powerful but complex feature of EnSight.  Understanding the basics of frames is essential for proper 
use.  This article is divided into the following sections:

Introduction
Create a New Frame
Select Frames
Assign Parts to Frames
Move and Rotate Frames
Reset Frame Transform
Set Frame Attributes
Determine What Frame a Part is Assigned To
Delete Frames
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BASIC OPERATION

Introduction
On startup, EnSight creates a default frame – frame 0 – located at 0,0,0 of the right-handed “world” or model 
coordinate system and aligned with the X, Y, Z axes. All parts (model and newly created) are assigned to frame 0 
initially. Frame 0 is special in that it cannot be repositioned or deleted.

Note: Frame mode is reserved for the expert user.  By default, it is not enabled.  To enable it, go to Edit-
>Preferences..., select General User Interface and toggle on Frame Mode Allowed.

Frames are selected either by clicking the frame axis triad (while in Frame mode) in the Graphics Window or by 
selecting the frame in the “Which Frame” list of the Transformation Editor dialog.  Any frame operation (such as 
setting attributes) acts on the currently selected frames.

The EnSight positioning tools (Cursor, Line, Plane, and Quadric tools) are always positioned with respect to the 
currently selected frame. If more than one frame is selected, frame 0 is the reference frame for tools. If you have tools 
visible, you will notice them changing position as the selected frame is changed.

EnSight implements computational periodicity (such as rotational symmetry) as an attribute of frames.  If a frame has 
symmetry enabled, all parts assigned to the frame will be duplicated as specified by the particular type of symmetry.

All frame axis triads are visible when in Frame mode.  The axis triad consists of three lines representing the X, Y, and 
Z orientation vectors plus labels.  Selected frames are colored with the default highlight color (typically green).  If the 
frame is visible (meaning it will be displayed in all modes) the frame axes are drawn with solid lines.  Otherwise, 
dashed lines are used.

EnSight does not support hierarchical frames: you cannot assign a frame to another frame to implement nested 
transformations.  All frames are embedded in the same world coordinate system (i.e. frame 0).

Create a New Frame
In general, you have to explicitly create new frames.  However, EnSight will automatically create a new frame each 
time you create a copy of a part and assign the copy to the frame.

To create a frame:

1. Click Frame in the Mode Selection area to enter Frame mode.

  (Note: If Frame does not appear as an available mode, first go to Edit-
>Preferences..., select General User Interface and toggle on Frame 
Mode Allowed.)

The initial position of a new frame can either be set to 0,0,0 or 
automatically centered on a set of parts.
2. If desired, select one or more parts in the Main Parts list – the new 

frame will be centered on the selected parts.

3. Click the New Frame icon to create the frame.

The new frame also becomes the currently selected frame.
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Select Frames
There are two ways to select frames.  You can click on the frame axis triad in the Graphics Window or select frames 
in the “Which Frame” list in the Transformation Editor dialog.  Selected frames are colored with the default highlight 
color (typically green).

To select frames in the Graphics Window:

To select frames using the Transformation Editor dialog:

Assign Parts to Frames
To assign a part to a frame:

1. Click Frame in the Mode Selection area to enter Frame mode.

 (Note: If Frame does not appear as an available mode, first go to Edit->Preferences..., select General User 
Interface and toggle on Frame Mode Allowed.)

2. Position the mouse pointer over the frame axis triad (the lines – not the XYZ labels) and click the left 
mouse button.

You can extend a selection of frames by holding down the Control key as you click on frames.

You can select all frames by clicking:

1. Click the Transf... icon in the Transformation 
Control area to open the Transformation 
Editor dialog.

2. Select Frame > Transform from the Editor 
Function menu.  Note that this puts EnSight 
into Frame mode.

3. Select the desired frames in the Which Frame 
list.

You can use standard Motif list selection techniques, 
such as shift-click to extend a selection or control-
click to de-select an item.

The Which Frame list is also displayed if the Editor 
Function menu is set to one of the Tool modes (e.g. 
Tools > Cursor).

1. Click Frame in the Mode Selection area to enter Frame mode.
 
(Note: If Frame does not appear as an available mode, first go to Edit-

>Preferences..., select General User Interface and toggle on Frame 
Mode Allowed.)

2. Select the desired part(s) in the Main Parts list.

3. Select the desired frame (as described above).

4. Click the Part Assignment icon to assign the part(s) to the frame.

A message is printed to the Status History area confirming the assignment.
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Move and Rotate Frames
You transform a frame (and all parts assigned to it) when you perform any transformation while in Frame Transform 
mode.  Frame Transform mode is set automatically when you enter Frame Mode.  You can also set it explicitly from 
the Editor Function menu in the Transformation Editor dialog.

To transform in Frame Transform mode:

Frame transforms are implemented as a transformation applied with respect to the frame’s position and orientation.  
At times you will need to modify the position and orientation of the frame independent of the parts assigned to it.  This 
is done while in Frame Definition mode.  You enter Frame Definition mode either explicitly from the mode menu in the 
Transformation Editor dialog (Editor Function > Frame > Definition), or via the Transform/Definition pull-down icon 
while in Frame Mode.

Important!  You cannot change the frame definition if you have performed any frame transformations (if you attempt 
to do so, a dialog will remind you).  Any frame definition must be applied prior to a frame transformation.  If you have 
already made frame transforms you can clear them by returning to frame transform mode and using the Reset Tools 
and Viewports dialog (click Reset... to open).

To transform the Frame Definition:

1. Click Frame in the Mode Selection area to enter Frame 
mode.

 (Note: If Frame does not appear as an available mode, first go to 
Edit->Preferences..., select General User Interface and toggle 
on Frame Mode Allowed.)

2. Toggle the Transform/Definition button to be.

3. Select the desired frame(s) (as described above).

4. Perform the desired transformation either interactively 
(using the Transformations Control icons and the mouse 
in the Graphics Window) or via the Transformation Editor 
dialog.  See How To Rotate, Zoom, Translate, and Scale 
for more information.

1. Click Frame in the Mode Selection area to enter Frame 
mode.

2. Toggle the Transform/Definition button to be.

3. Select the desired frame(s) (as described above).

4. Perform the desired transformation.  This can be done either interactively (with the mouse in the 
Graphics Window) or via the Transformation Editor dialog.  To translate the frame interactively, move the 
mouse pointer into the Graphics Window and click and drag the left mouse button.  To rotate the frame 
interactively, click and hold the left mouse button on one of the frame axes and drag the mouse.  Clicking 
on the X axis will rotate the frame about its Y axis.  Clicking on the Y axis will rotate the frame about its X 
axis.  Clicking the Z axis will rotate about both X and Y.  Use the Transformation Editor dialog to rotate 
about the Z axis only.
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You can also edit the frame’s definition explicitly using the Transformation Editor dialog:

Reset Frame Transform
The frame transform can be reset back to the default position and orientation by using the Reset Tools and Viewports 
dialog.  To clear the frame transform:

1. Click Frame in the Mode Selection area to enter Frame mode.

 (Note: If Frame does not appear as an available mode, first go to Edit-
>Preferences..., select General User Interface and toggle on Frame 
Mode Allowed.)

2. Click the Frame Location Attributes icon.

This opens the Transformation Editor dialog in Frame Definition mode.

3. Select the desired frame(s).

4. If desired, enter new value(s) in the XYZ 
fields to change the frame’s origin 
(remember to press return).

5. If desired, enter new value(s) for the 
orientation vectors (remember to press 
return).

Note that the orientation vectors are 
normalized afresh when you press return.

1. Click Frame in the Mode Selection area to enter Frame mode.

2. Make sure the Transform/Definition button is set to transform

3. Select the desired frame(s) (as described above).

4. Click the Reset... button in the Transformation Control area to open the 
Reset Tools and Viewports dialog.

5. In the Reset Tools and Viewports dialog, click the desired button:
Reset By Selected Transform Only: clear only the transformation component 
currently selected (e.g. rotate or translate) in the Transformation Control area
Reset Rotate/Translate/Scale: clear all transformation components

See How To Reset Tools and Viewports for more information.
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Set Frame Attributes
Frames can be displayed with a variety of attributes:

1. Click Frame in the Mode Selection area to enter Frame mode.  (If needed, first enable Frame Mode 
under Edit->Preferences..., General User Interface.)

2. Select the desired frame(s) (as described above).

3. Set the desired attribute as described below:

Click the Frame Visibility Toggle to toggle display of the axis triad of selected 
frames on or off (when not in Frame Mode).

Click (opens the Color Selector) to set the color for the axis triad of selected 
frames.

Click the Frame Line Width pull-down to set the line width for the axis triad of 
selected frames.

Click the Axis Triad Attributes icon to set axis attributes (described below).

To adjust the length of the frame axes, enter 
new values in the X, Y, and Z Length fields and 
press return.

To display a series of evenly spaced labels 
along an axis (showing distance from the axis 
origin), toggle on the applicable Label button, 
enter the desired number of labels in the # of 
field, and press return.

Off On
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Determine What Frame a Part is Assigned To
You can determine what frame a part is assigned to (and change it) by opening the Feature Detail Editor for the part:

Delete Frames
Selected frames can be deleted.  Note that a frame cannot be deleted if any parts are currently assigned to it.  All 
parts assigned to the frame must be assigned to other frames prior to deletion.

SEE ALSO
How To Set Symmetry, How To Rotate, Zoom, Translate, and Scale, How To Reset Tools and Viewports

User Manual: Frame Mode

1. Open the Feature Detail Editor for the 
part type (Edit > Part Feature Detail 
Editors >) or double click on the 
appropriate Feature Icon.

2. Select the desired part in the parts list at 
the top of the Feature Detail Editor.

3. Open the General Attributes section.

The part’s current frame number is shown in 
the Ref. Frame field.  You can reassign a part 
to a different frame by entering a new value 
and pressing return.

1. Click Frame in the Mode Selection area to 
enter Frame mode.

2. Select the desired frame(s) (as described 
above).

3. Click the Delete icon.
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Reset Tools and Viewports

INTRODUCTION
EnSight provides support for complex transformations of various entities (e.g. the scene, tools, frames).  It is often 
necessary to clear all or part of the transformation associated with an entity; the Reset Tools and Viewports dialog 
provides this capability.

BASIC OPERATION
To clear global transformations or tool positions:

1. Click Part in the Mode Selection area (to be sure 
that EnSight is in Global Transform rather than 
Frame transform).

2. Click the Reset... button in the 
Transformation Control area to open the Reset 
Tools and Viewports dialog.

3. Perform the desired operation as described 
below.

4. Click Close.

Transformations will only be reset for 
the current viewport(s).  Click in a 
viewport to select it.  Control-click to 
extend the selection or de-select a 
selected item.

Click the applicable button to reset the 
corresponding tool.

Click to clear only the transformation 
component currently selected in the 
Transformation Control area (e.g. 
Rotate or Translate).

Click to clear all transformations as well 
as reset the camera look-from/look-at 
points so that all currently visible parts 
are centered in the selected viewport(s).

Click to clear all 
transformations in the 
selected viewport(s). Note 
that zoom is not a scene 
transformation and is not 
cleared. Zoom is 
implemented by moving the 
look-from point (the camera 
position). To clear zoom, click 
Reinitialize.

Toggle selects whether tool is 
reset based on the global XYZ 
space or reset based only on 
the selected viewport.
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ADVANCED USAGE
The Reset Tools and Viewports dialog is also used to clear Frame transformations.  See How To Create and 
Manipulate Frames for more information on frames and frame transforms.

To clear frame transformations:

SEE ALSO
How To Rotate, Zoom, Translate, Scale, How To Define and Change Viewports, How To Create and Manipulate 
Frames

1. Click Frame in the Mode Selection area to enter 
Frame mode.  (If needed, first enable Frame mode 
under Edit->Preferences... General User Interface.)

2. Make sure the Transform/Definition button is in the 
transform state

3. Select the desired frame(s).

4. Click the Reset... button in the Transformation 
Control area to open the Reset Tools and 
Viewports dialog.

5. Perform the desired operation as described 
below.

6. Click Close.

Frame transformations will only be reset 
for the current viewport(s).  Click in a 
viewport to select it.  Control-click to 
extend the selection or de-select a 
selected item.

Click to clear only the frame 
transformation component currently 
selected in the Transformation Control 
area (e.g. Rotate or Translate) for the 
selected frame(s) in the selected 
viewport(s).

Click to clear all frame 
transformations for the 
selected frame(s) in the 
selected viewport(s).
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Use the Color Selector

INTRODUCTION
Several operations in EnSight require that you select a color.  The Color Selector dialog is used throughout the user 
interface to provide a powerful and easy-to-use color selection mechanism.

BASIC OPERATION
The selector operates using one of two basic color models: RGB or HSV.  The RGB color model specifies color by the 
percentage of red, green, and blue and closely mimics the way computers deal with color.  The HVS color model 
specifies colors as percentages of hue (the actual color with red equal to both 0.0 and 1.0, green equal to 0.33, and 
blue equal to 0.66), saturation (the “amount” of color, where 0.0 is white and 1.0 is full), and the value (the brightness, 
where 0.0 is black and 1.0 is full).  The HSV model is often more intuitive for mixing custom colors.  Although HSV is 
the default, you can switch to RGB by clicking the RGB toggle button.

The dialog provides four basic methods of selecting colors:

When you have selected a color, click the Apply button to have the selected color applied to the object being edited 
(e.g. part, color map level, text, etc.).

Specify Custom Colors
If you have colors that you use frequently that are not represented in the color grid, you can save them by replacing 
selected cells.  Your custom colors are automatically saved for future sessions.  To set custom colors:

1. Select the desired color using any of the methods described above.
2. Toggle on Change Color Cell.
3. Click in the color cell you wish to replace.
4. Continue to select colors and replace cells.
5. Toggle off Change Color Cell when done.

The color information is saved in ~/.ensight8/ensight.colpal.default.

SEE ALSO
User Manual: Color Selector

1. By picking one of the 
predefined colors from the 
grid of color cells.

2. By grabbing the marker in the 
color cube and moving it with 
the mouse.

3. By entering values for HSV 
(or RGB, depending on 
mode) directly in the fields 
and pressing return.

4. By grabbing and moving the 
sliders associated with each 
color component.

Color square always displays 
the current color selection.



Enable Stereo Viewing

INTRODUCTION
EnSight supports active stereo display on workstations with quad-buffered OpenGL stereo capability, in addition to 
passive (polarized) stereo support for detached displays (see How To Setup Parallel Rendering).  Active stereo 
works by rapidly displaying alternating left and right eye views on the screen.  An emitter (which sits on top of your 
display monitor) sends an infrared signal to special glasses worn by the viewer(s).  The glasses contain liquid crystal 
shutters that alternately open and close the left and right eye lenses in response to the signal from the emitter in sync 
with the monitor display.  The update frequency is such that the viewer effectively fuses the left and right views into a 
single stereo image.

Stereo is useful for viewing any type of visually complex geometry.  It is especially helpful for visualizing amorphous 
objects such as animating particle traces, trace ribbons, or discrete particles.  It has also been noted that 
management and customers are typically quite impressed by stereo display.

See the “See Also” section below for information on purchasing NuVision stereo glasses through CEI.

BASIC OPERATION
In EnSight, stereo display is enabled by pressing the F12 key on your keyboard. Pressing the F12 key again will 
return to normal display. The stereo separation angle can be controlled by pressing the F10 and F11 keys. F10 
decreases the angle and F11 increases the angle. When EnSight is configured to use a detached display (see How 
To Setup Parallel Rendering), these commands affect only the detached display. The GUI window remains 
monoscopic.

Configuring your display
On most platforms the display is not initialized by default in a mode which enables stereo viewing. In general quad-
buffered stereo requires a refresh rate of 96Hz or higher. On some monitors it may be necessary to decrease the 
display resolution in order to accommodate this higher refresh rate. Check your monitor documentation before 
attempting to change the refresh rate.

For Unix platforms there is a utility distributed with EnSight which can be used to determine if your display has stereo 
capability. Run ‘glx_info’ and look for X visuals with a ‘y’ the column ‘stro’. If none exist, then the current display 
parameters do not allow for stereo viewing.

Below are example instructions for various platform configurations which have been tested and confirmed to work 
with EnSight. When in doubt, refer to your system documentation for OpenGL as well as the X server (Unix) or video 
adapter device driver (Windows).

Compaq Tru64 Unix
1. Edit the file /usr/var/X11/Xserver.conf

Find the section that looks similar to:
args <
! PowerStorm 300/350 Server args start
        -pn -su -bs -nice -2
! PowerStorm 300/350 Server args end
        -pn
>

Modify to something like:
args <
! PowerStorm 300/350 Server args start
        -pn -su -bs -nice -2 -screen 1280x992 -vsync 100
! PowerStorm 300/350 Server args end
        -pn
>

Restart the Xserver with /usr/sbin/xsetup

2. Connect an appropriate emitter. The NuVision emitter with a 3-pin to 5-pin converted has been tested. CrystalEyes 
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users should be able to use an ‘ESGI’ emitter with a 5-pin cable.

HP-UX 10.2 - 11.0
1. Configure the display settings using:

/opt/graphics/common/bin/setmon

Select a setting which includes “Stereo in a Window”

2. Connect a 3-pin emitter to the graphic card. The NuVision emitter works fine. For CrystalEyes a converter cable 
may be needed.

IBM AIX 4.3
1. First, make sure that the graphics card is properly configured for OpenGL and stereo display. See the file /usr/
lpp/X11/README for directions on configuring the X server. You may need to edit the file /usr/lpp/X11/
defaults/xserverrc to add a “-stereo” argument similar to:

#-------------------------------------------------------------------------
# Load GLX extension to the X server for OpenGL
#-------------------------------------------------------------------------
if [ -f /usr/lpp/OpenGL/bin/loadGL -a   \
     -f /usr/lpp/X11/bin/loadAbx -a     \
     -f /usr/lpp/X11/bin/loadDBE ] ; then
  EXTENSIONS=”$EXTENSIONS -x abx -x dbe -x GLX -stereo”
fi

2. Next you need to set the refresh rate to a stereo-capable setting. Stereo settings are usually 96+Hz vertical 
refresh. Use the ‘smit’ tool to see which settings you can use. When running smit, select:

Devices->Graphic Displays->Select the Display Resolution...

You will be prompted to select your graphics adapter. After selecting your graphics adapter you will see the current 
setting, and you can now query for the available settings. Hopefully you will find something at 96+Hz. If not, you 
may have a monitor which cannot support such high refresh. Connect a new monitor and reboot the machine, run 
smit again. Note that many monitors can only handle high refresh at lower resolution (i.e. 1024x768 at 96Hz or 
120Hz). 

3. The last step is to hook up a stereo emitter to sync with the glasses. We have successfully used the NuVision 
emitter with built-in 3-pin connector. The CrystalEyes EPRO emitter with external power and 3-pin to BNC cable 
should work as well.

SGI Irix 6.5
1. Configure the video resolution/refresh rate for stereo. On an Infinite Reality pipe this may be done with something 

like:
/usr/gfx/ircombine -destination eeprom -source file \

/usr/gfx/ucode/KONA/dg4/cmb/1024x768_120s.cmb -target :0.0

On other platforms the ‘/usr/gfx/setmon’ command can be used to select the correct mode. An example may 
be:

/usr/gfx/setmon 1024x768_96s

See the man page for platform specific information and the locations of the configuration files. You may get a 
message telling you that the format is not available, however in some cases all that is needed is a reboot in order 
to switch the resolution.

2. Hook up your stereo emitter. The CrystalEyes ESGI emitter works with the SGI, and there is a 3-pin to 9-pin cable 
to use the NuVision emitter on the SGI.

Sun Solaris 8
1. Configure the video resolution/refresh rate for stereo. On an Expert3D Card this is done with a command similar to:

fbconfig -dev /dev/fbs/ifb0 -res stereo

The fbconfig utility is a wrapper tool that calls afbconfig/ffbconfig depending on the type of graphics adapter.

2. Hook up a stereo emitter. The Expert3D uses a 7-pin cable.
Page 2 of 3



Linux
A few OpenGL drivers are known to support stereo OpenGL under Linux, including the HP fx-5/fx-10 and the ATI 
FireGL2/FireGL4. Documentation is included with the drivers, which may be downloaded from the card vendors 
web sites.

MS Windows
Configuration of stereo under Microsoft Windows is dependent upon the graphics card driver which is installed.  
Right-click on the background and choose “Properties” to open to Display Properties dialog. Look for a tab which 
such as “OpenGL Properties” or “Advanced” and search for a stereo option. In many cases there is a toggle button 
for enabling stereo display. You will usually need to restart the machine in order for changes to take effect. If stereo 
still does not work, try changing the display resolution, as stereo may not be available at higher resolutions.

SEE ALSO
Most SGI hardware is “stereo ready” meaning that you need no additional hardware (other than glasses and the 
emitter). However, check with your local SGI technical representative to be sure. The O2, in particular is not stereo 
ready and additional hardware must be purchased.

In the U.S., NuVision hardware (glasses and emitters) can be purchased through CEI. Contact Sales and Marketing 
for pricing and availability:

CEI, Inc.
919-363-0883
919-363-0833 FAX
ensight@ceintl.com

Outside the U.S., contact your local EnSight distributor.
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Pick Center of Transformation

INTRODUCTION
EnSight allows you to pick where you would like the center of transformation to be for the model. 

BASIC OPERATION

You can also set or change the exact location of the center of transform by using the Transformation Editor.

SEE ALSO
User Manual:  Center Of Transform

1. Click the Pick button in the global area above the 
graphics window on the desktop.

2. Toggle on Pick Center of Transformation.

3. Position the mouse cursor on your model at the 
desired location for the center of transformation.

4. Press the “p-key” (or whatever mouse button you 
have set for “Selected Pick Action” in Edit > 
Preferences > Mouse and Keyboard).

Your model will now rotate about the position on the model 
that you just picked.

1. Click the “Transf...” button on the desktop 
below the graphics screen.

2. Under “Editor Function”, select “Center of 
Transform”.

3. Set of modify the x,y,z coordinate location 
of the center of transform in the dialog which 
comes up.



Set Model Axis/Extent Bounds

INTRODUCTION
EnSight provides model axes and extent bounds to help in orienting your model. These features are toggled on/off via 
the quick access area on the desktop.

BASIC OPERATION

Model Directional Triad
The model axes help maintain awareness of the principal directions of the reference frame of the model. This is 
especially helpful during model transformations.

Click the Axis toggle to display the model directional 
triad.
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Model Extent Bounds
The model extent bounds also help maintain dimensional information pertaining to the extents of the model.

SEE ALSO
User Manual:  Part Bounds Attributes

Click the Bounds toggle to display the model extents

To control the various attributes associated with the model 
extents:

1. Select the Viewport Mode icon.

2. Select the Model Extent Bounds icon, which opens the 
Viewport 2D/3D Grid attributes dialog.

3. Modify the various general and/or axes attributes as 
desired.
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Do Viewport Tracking

INTRODUCTION
EnSight provides the capability to “track” a particular location on the model parts displayed in a viewport. Tracking 
means that the viewport will be caused to center on the chosen location as time is changed. This is particularly useful 
for models with changing geometry or applied displacements - allowing one to stay focused on the moving bodies 
during an animation.

BASIC OPERATION
Viewports can be displayed with a variety of attributes:

SEE ALSO
How To Define and Change Viewports

User Manual: VPort Mode

1. Click VPort in the Mode Selection area to 
enter Viewport mode.

2. Select the desired viewport(s).

3. Click the Viewport Special Attributes icon to 
open the Viewport Special Attributes dialog.

4. Select the Tracking option desired,

5. And supply the node or part id appropriately.

6. Change time step, load a transient flipbook, 
or the like and note that the viewport will stay 
centered on the location chosen.



Manipulate Tools
Use the Cursor (Point) Tool

INTRODUCTION
EnSight provides a 3D point specification tool called the “Cursor” tool.  When visible, the Cursor appears as a 3D 
cross colored red (X axis), green (Y axis), and blue (Z axis).  The Cursor tool is used to supply EnSight with point 
information, for example to specify the location for a query or the starting point for a particle trace.

BASIC OPERATION
In many cases, the Cursor tool will automatically turn on when performing some function that requires it. You can also 
turn the tool on and off manually by toggling the Cursor entry in the Tools menu or by clicking the Cursor toggle on the 
Desktop.

The Cursor tool can be placed in three ways: interactively through direct manipulation with the mouse, by positioning 
the mouse pointer over a part and pressing the ‘p’ key, or precisely positioned by typing coordinates into a dialog.

To position the Cursor with the mouse:

Cursor translation is restricted to the plane perpendicular to your line of sight. If you need to move the cursor in 
another plane, rotate the model such that the desired translation plane is perpendicular to your new line of sight.  
(Note that the Cursor may not exactly track the location of the mouse pointer.)

To position the Cursor on a part with the ‘p’ key:

1. Place the mouse pointer over the center of the tool.
Note that the mouse cursor will change when over the center 
of the cursor tool (if in Part or Frame mode).

2. Click (and hold) the left mouse button.
3. Drag the Cursor to the desired location.
4. Release the mouse button.
(Undo/Redo button at the bottom of screen can be used to undo/redo the 
tool transformation)

1. Click the Pick button in the global area above the 
graphics window on the desktop.

2. Select “Pick cursor tool location” from the pop-up 
menu.

3. Place the mouse pointer over the desired location on 
a part in the graphics window and press the ‘p’ key 
(or whatever mouse button you have set for the 
“Selected Pick Action” in Edit > Preferences > Mouse 
and Keyboard).
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To set the Cursor by specifying coordinates:

You can also move the Cursor by setting the desired axis of translation in the Axis pop-up and manipulating the slider 
bar.  In this case, the values in the “Scale Settings” section control the sensitivity and limit of the slider action.

Note that you can also use this dialog to view (rather than set) the position of the Cursor since the X,Y,Z numeric 
values always update to reflect the current location.  If you are positioning the Cursor interactively with the mouse, the 
values will update when the mouse button is released.

ADVANCED USAGE
After a model has been loaded, the initial location of the Cursor is set to the “look-at” point – the geometric center of 
all visible geometry.  The coordinates of the Cursor are specified with respect to the default frame: frame 0.  However, 
if you have created additional frames, you can position the Cursor relative to the origin of a different frame.  This is 
accomplished by selecting the desired frame in the “Which Frame” list in the Transformation Editor dialog.

You can easily reset the position of the Cursor tool to the default.  See How To Reset Tools and Viewports for more 
information.

Positioning a 3D tool with a 2D device (the mouse) can be difficult.  Multiple viewports are sometimes helpful in 
positioning tools since you can see the tool simultaneously from multiple vantage points.

SEE ALSO
Other tools: Line, Plane, Box, Cylinder, Sphere, Cone, Surface of Revolution. See the How To article on Frames 
for additional information on how frames effect tools.

User Manual: Tools Menu Functions

1. Open the Transformation Editor dialog by 
clicking Transf... on the desktop.

2. Select Editor Function > Tools > Cursor.

3. Enter the desired coordinates into the X, Y, 
and Z type-ins and hit return.
Page 2 of 2



Use the Line Tool

INTRODUCTION
EnSight provides a 3D linear specification tool called the “Line” tool.  When visible, the Line tool appears as a 
(typically white) line with a cross at the center point.  The Line tool is used to supply EnSight with a linear 
specification, for example to specify the location for a line clip or a “rake” for a particle trace.

BASIC OPERATION
In many cases, the Line tool will automatically turn on when performing some function that requires it. You can also 
turn the tool on and off manually by toggling the Line entry in the Tools menu or by clicking the Line toggle on the 
Desktop.

The Line tool can be placed in three ways: interactively through direct manipulation of tool “hotpoints” with the mouse, 
by positioning the mouse pointer over a part and typing the ‘p’ key, or precisely positioned by typing coordinates into 
a dialog.

Line moving and stretching is restricted to the plane perpendicular to your line of sight.  If you need to move the Line 
in another plane, rotate the model such that the desired translation plane is perpendicular to your new line of sight.  
(Note that the Line will not exactly track the location of the mouse pointer.)

To move the Line with the mouse:
1. Place the mouse pointer over the center of the tool.
2. Click (and hold) the left mouse button.
3. Drag the Line to the desired location.
4. Release the mouse button.

To stretch the Line with the mouse:
1. Place the mouse pointer over one of the Line endpoints.
2. Click (and hold) the left mouse button.
3. Drag the endpoint to the desired location.
4. Release the mouse button.
Note that the mouse pointer will change when it is over a hotpoint (if you are in Part or 
Frame mode).

(Undo/Redo button at the bottom of screen can be used to undo/redo the tool 
transformation)
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To position the Line on a part with the ‘p’ key:

To set the Line by specifying coordinates:

You can also move the Line by setting the desired axis of translation in the Axis pop-up and manipulating the slider 
bar.  In this case, the values in the “Scale Settings” section control the sensitivity and limit of the slider action.

Note that you can also use this dialog to view (rather than set) the position of the Line since the X,Y,Z numeric values 
always update to reflect the current location.  If you are positioning the Line interactively with the mouse, the values 
will update when the mouse button is released.

1. Click the Pick button in the global area above the 
graphics window on the desktop.

2. Select “Pick line tool location” from the pop-up 
menu.

3. In the Graphics Window, place the mouse pointer on 
a part over the desired location for the first Line 
endpoint and press the ‘p’ key (or whatever mouse 
button you have set for the “Selected Pick Action” in 
Edit > Preferences > Mouse and Keyboard).

4. Move the mouse pointer to the desired location for 
the second Line endpoint and again press the ‘p’ key.

1. Open the Transformation Editor dialog by 
clicking Transf... on the desktop.

2. Select Editor Function > Tools > Line.

3. Enter the desired coordinates for the 
endpoints into the X, Y, and Z fields and 
press return.
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ADVANCED USAGE
After a model has been loaded, the initial location of the Line center is set to the “look-at” point – the geometric center 
of all visible geometry and parallel to the X axis.  The coordinates of the Line are specified with respect to the default 
frame: frame 0.  However, if you have created additional frames, you can position the Line relative to the origin of a 
different frame.  This is accomplished by selecting the desired frame in the “Which Frame” list in the Transformation 
Editor dialog.

You can easily reset the position and orientation of the Line tool to the default.  See How To Reset Tools and 
Viewports for more information.

Positioning a 3D tool with a 2D device (the mouse) can be difficult. Multiple viewports are sometimes helpful in 
positioning tools since you can see the tool simultaneously from multiple vantage points.

To find the distance between two nodes that have IDs, you can use the calculator function Dist2Nodes. However, to 
find the distance between two nodes on different parts, or between two nodes if one or both don’t have IDs, use the 
line tool. First drag down to Pick Line Tool Location on the pick part icon to the left of the GUI screen, then move the 
cursor over the first location, hit ‘p’ key, move to the second location and hit the ‘p’ key, then open up the 
transformation editor and in the transformation editor menu, Edit>Tools>Line you’ll find the length of the line tool 
which is the distance between those two points.

SEE ALSO
Other tools: Cursor, Plane, Box, Cylinder, Sphere,  Cone, Surface of Revolution. See the How To article on 
Frames for additional information on how frames effect tools.

User Manual: Tools Menu Functions
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Use the Plane Tool

INTRODUCTION
EnSight provides a plane specification tool called the “Plane” tool.  When visible, the Plane tool appears as a 
(typically white) rectangular region with an axis located at the center point.    The Plane can also have a semi-
transparent “filled” center that enhances visibility of the region.   The Plane tool is used to supply EnSight with a 
planar specification, for example to specify the location for a planar clip or a “net” for a particle trace.

BASIC OPERATION
In many cases, the Plane tool will automatically turn on when performing some function that requires it. You can also 
turn the tool on and off manually by toggling one of the Plane entries in the Tools menu (e.g. Tools > Plane) or by 
clicking the Plane toggle on the Desktop.

The Plane tool can be placed in three ways: interactively through direct manipulation of tool “hotpoints” with the 
mouse, by positioning the mouse pointer over a part and typing the ‘p’ key, or precisely positioned by typing 
coordinates into a dialog.

Plane moving is restricted to the plane perpendicular to your line of sight.  If you need to move the Plane in another 
plane, rotate the model such that the desired translation plane is perpendicular to your new line of sight.  (Note that 
the Plane will not exactly track the location of the mouse pointer.)

To move the Plane with the mouse:
1. Place the mouse pointer over the center of the tool.
2. Click (and hold) the left mouse button.
3. Drag the Plane to the desired location.
4. Release the mouse button.

To stretch (or scale) the Plane with the mouse:
1. Place the mouse pointer over the corner between the X and Y axis 

labels.
2. Click (and hold) the left mouse button.
3. Drag the corner to the desired location.
4. Release the mouse button.

To rotate the Plane tool with the mouse:
1. Place the mouse pointer over one of the axis labels (X, Y, or Z).
2. Click and drag to the desired orientation. Grabbing the X (Y) label 

will rotate around the plane’s Y (X) axis. Grabbing the Z label 
enables free rotation about the Plane’s center point.

Note that the mouse pointer will change when it is over a hotpoint (if you are in Part or 
Frame mode).

(Undo/Redo button at the bottom of screen can be used to undo/redo the tool 
transformation)

X

Y
Z
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To position the Plane on a part (by specifying three points) with the ‘p’ key:

You can also position the Plane Tool by tracing out a line on the screen.  The Plane orientation will be changed such 
that it is both parallel to the specified line and perpendicular to the screen.

To position the Plane (by specifying a line):

You can also position the Plane Tool by picking an origin, then a point out on the normal. This takes two picking 
operations to accomplish.

To position the Plane (by picking origin, then point on normal):

1. Click the Pick button in the global area above the 
graphics window on the desktop.

2. Select “Pick plane (3 Pts.) tool location” from the 
pop-up menu.

3. In the Graphics Window, place the mouse pointer on 
a part and press the ‘p’ key (or whatever mouse 
button you have set for the “Selected Pick Action” in 
Edit > Preferences > Mouse and Keyboard).

4. Repeat two more times. Note that you are not 
specifying corner points – just three unique points.

1. Click the Pick button in the global area above the 
graphics window on the desktop.

2. Select “Pick plane (2 Pts.) tool location” from the 
pop-up menu.

3. Move the mouse pointer into the Graphics Window 
and press the ‘p’ key.  Place the pointer over the 
desired starting point.  Click and hold the left mouse 
button as you trace out the desired line.

4. Release the mouse button.

1. Click the Pick button in the global area above the 
graphics window on the desktop.

2. Select “Pick plane tool origin” from the pop-up menu.

3. Move the mouse pointer into the Graphics Window 
and place the pointer over the desired origin of the 
plane tool - then press the ‘p’ key.

4. Select “Pick plane tool normal” from the pop-up 
menu.

5. Place the pointer over a point along the normal 
vector (from the origin of the plane tool) - then press 
the ‘p’ key.
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To set the Plane by specifying coordinates:

You can also rotate the Plane by setting the desired axis of rotation in the Axis pop-up and manipulating the slider bar.  
In this case, the values in the “Scale Settings” section control the sensitivity and limit of the slider action.

Note that you can also use this dialog to view (rather than set) the position of the Plane since the X,Y,Z numeric 
values always update to reflect the current location. If you are positioning the Plane interactively with the mouse, the 
values will update when the mouse button is released.

The Undo/Redo button at the bottom of screen can be used to undo/redo the tool transformation.

ADVANCED USAGE
After a model has been loaded, the initial location of the Plane center is set to the “look-at” point – the geometric 
center of all visible geometry and parallel to the X-Y plane.  The coordinates of the Plane are specified with respect to 
the default frame: frame 0.  However, if you have created additional frames, you can position the Plane relative to the 
origin of a different frame.  This is accomplished by selecting the desired frame in the “Which Frame” list in the 
Transformation Editor dialog.

You can easily reset the position and orientation of the Plane tool to the default.  See How To Reset Tools and 
Viewports for more information.

By default the plane tool will be displayed in line mode.  You can display the tool as a transparent plane by changing 
the setting for Edit > Preferences... View - Plane Tool Filled.

Positioning a 3D tool with a 2D device (the mouse) can be difficult.  Multiple viewports are sometimes helpful in 
positioning tools since you can see the tool simultaneously from multiple vantage points.

1. Open the Transformation Editor dialog from 
the desktop by clicking Transf...

2. Select Editor Function > Tools > Plane.

3. Enter the desired coordinates for the origin, 
the components of the normal vector, and 
the x and y size, and press return.

     – OR –

3. Enter the plane equation parameters (Ax + 
By + Cz = D) and press return.

     – OR –

3. Enter the desired coordinates for three 
corner points into the X, Y, and Z fields and 
press return.
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SEE ALSO
Other tools: Cursor, Line, Box, Cylinder, Sphere,  Cone, Surface of Revolution. See the How To article on 
Frames for additional information on how frames effect tools.

The Plane Tool is also used to specify the location of the clip plane for Auxiliary Clipping.  

User Manual: Tools Menu Functions
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Use the Box Tool

INTRODUCTION
EnSight provides a hexahedron shaped specification tool called the “Box” tool. When visible, the Box tool appears as 
a (typically white) wireframe box icon with a triad at one corner.   The Box tool is used to supply EnSight with a 3D 
volume specification, for example to specify the location for a box clip or cut.

BASIC OPERATION
In many cases, the Box tool will automatically turn on when performing some function that requires it. You can also 
turn the tool on and off manually by toggling Tools > Box. 

The Box tool can be placed in two ways: interactively through direct manipulation of tool “hotpoints” with the mouse or 
precisely positioned by typing coordinates into a dialog.

Box tool moving and stretching is in 3 space. (Note the Box may not exactly track the location of the mouse pointer.)

To move the Box Tool with the mouse:
1. Place the mouse pointer over the origin corner 

of the tool.
2. Click (and hold) the left mouse button.
3. Drag the Box to the desired location.
4. Release the mouse button.

To stretch the Box Tool with the mouse:
1. Place the mouse pointer over any of the corner 

points (except the origin).
2. Click (and hold) the left mouse button.
3. Drag the endpoint to produce the desired 

stretched size.
4. Release the mouse button.

To rotate the Box Tool with the mouse:
1. Place the mouse pointer over the center of the 

x, y, or z edge(not at the endpoints).
2. Click and drag to rotate.

Note: Selection of the X axis edge will rotate the 
box about the Y axis edge. Selection of the Y 
axis edge will rotate about the X axis edge.  
Selection about the Z axis edge will rotate 
about the origin.

Note that the mouse pointer will change when it is over a 
hotpoint (if you are in Part or Frame mode).

(Undo/Redo button at the bottom of screen can be used to 
undo/redo the tool transformation)
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To set the Box Tool by specifying coordinates:

You can also rotate, translate or stretch the Box Tool by selecting the desired Transform Action, setting the desired 
axis, and then manipulating the slider bar. For these tool actions, the values in the “Scale Settings” section control the 
sensitivity and limit of the slider action.

Note that you can also use this dialog to view (rather than set) the position of the Box Tool since the numeric values 
always update to reflect the current location, size, and orientation. If you are positioning the Box Tool interactively with 
the mouse, the values will update when the mouse button is released.

ADVANCED USAGE
After a model has been loaded, the initial location of the Box Tool is centered about the “look-at” point – the geometric 
center of all visible geometry - and is aligned with the model axis system. The coordinates of the Cylinder are 
specified with respect to the default frame: frame 0. However, if you have created additional frames, you can position 
the Box Tool relative to the origin of a different frame. This is accomplished by selecting the desired frame in the 
“Which Frame” list in the Transformation Editor dialog.

You can easily reset the position and orientation of the Box tool to the default. See How To Reset Tools and 
Viewports for more information.

Positioning a 3D tool with a 2D device (the mouse) can be difficult.  Multiple viewports are sometimes helpful in 
positioning tools since you can see the tool simultaneously from multiple vantage points.

SEE ALSO
Other tools: Cursor, Line, Plane, Cylinder, Sphere,  Cone, Surface of Revolution. See the How To article on 
Frames for additional information on how frames effect tools.

User Manual: Tools Menu Functions

1. Open the Transformation Editor dialog by 
clicking Transf... on the desktop.

2. Select Editor Function > Tools > Box.

3. To place and size, enter the desired 
coordinates for the Origin corner and 
the length in each of the directions, 
and press return.

4. To orient, enter the components of the 
orthogonal axis orientation vectors
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Use the Cylinder Tool

INTRODUCTION
EnSight provides a cylindrical specification tool called the “Cylinder” tool.  When visible, the Cylinder tool appears as 
a (typically white) cylinder icon with a line running down the central axis.   The Cylinder tool is used to supply EnSight 
with a cylindrical specification, for example to specify the location for a cylinder clip or cut.

BASIC OPERATION
In many cases, the Cylinder tool will automatically turn on when performing some function that requires it.  You can 
also turn the tool on and off manually by toggling Tools > Quadric > Cylinder.  The Cylinder tool can be placed in two 
ways: interactively through direct manipulation of tool “hotpoints” with the mouse or precisely positioned by typing 
coordinates into a dialog.

Cylinder moving and stretching is restricted to the plane perpendicular to your line of sight.  If you need to move the 
Cylinder in another plane, rotate the model such that the desired translation plane is perpendicular to your new line of 
sight.  (Note that the Cylinder will not exactly track the location of the mouse pointer.)

To move the Cylinder with the mouse:
1. Place the mouse pointer over the center of the tool.
2. Click (and hold) the left mouse button.
3. Drag the Cylinder to the desired location.
4. Release the mouse button.

To stretch the Cylinder with the mouse:
1. Place the mouse pointer over either of the center line’s endpoints.
2. Click (and hold) the left mouse button.
3. Drag the endpoint to the desired location.
4. Release the mouse button.

To change the Cylinder radius with the mouse:
1. Place the mouse pointer over the center ring.
2. Click and drag to the desired radius.
Note that the mouse pointer will change when it is over a hotpoint (if in Part or Frame 
mode).

(Undo/Redo button at the bottom of screen can be used to undo/redo the tool 
transformation)
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To set the Cylinder by specifying coordinates:

You can also translate the Cylinder by setting the desired axis of translation in the Axis pop-up and manipulating the 
slider bar.  In this case, the values in the “Scale Settings” section control the sensitivity and limit of the slider action.

Note that you can also use this dialog to view (rather than set) the position of the Cylinder since the numeric values 
always update to reflect the current location.  If you are positioning the Cylinder interactively with the mouse, the 
values will update when the mouse button is released.

ADVANCED USAGE
After a model has been loaded, the initial location of the Cylinder center is set to the “look-at” point – the geometric 
center of all visible geometry and aligned with the X axis.  The coordinates of the Cylinder are specified with respect 
to the default frame: frame 0.  However, if you have created additional frames, you can position the Cylinder relative 
to the origin of a different frame.  This is accomplished by selecting the desired frame in the “Which Frame” list in the 
Transformation Editor dialog.

You can easily reset the position and orientation of the Cylinder tool to the default.  See How To Reset Tools and 
Viewports for more information.

Positioning a 3D tool with a 2D device (the mouse) can be difficult.  Multiple viewports are sometimes helpful in 
positioning tools since you can see the tool simultaneously from multiple vantage points.

SEE ALSO
Other tools: Cursor, Line, Plane, Box, Sphere,  Cone, Surface of Revolution. See the How To article on Frames 
for additional information on how frames effect tools.

User Manual: Tools Menu Functions

1. Open the Transformation Editor dialog by 
clicking Transf... on the desktop.

2. Select Editor Function > Tools > Cylinder.

3. Enter the desired coordinates for the 
Origin (location of the center point), 
the Axis (direction vector), and the 
Radius and press return.
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Use the Sphere Tool

INTRODUCTION
EnSight provides a spherical specification tool called the “Sphere” tool.  When visible, the Sphere tool appears as a 
(typically white) sphere icon with a line running down the central axis.   The Sphere tool is used to supply EnSight with 
a spherical specification, for example to specify the location for a sphere clip or cut.

BASIC OPERATION
In many cases, the Sphere tool will automatically turn on when performing some function that requires it.  You can 
also turn the tool on and off manually by toggling Tools > Quadric > Sphere.  The Sphere tool can be placed in two 
ways: interactively through direct manipulation of tool “hotpoints” with the mouse or precisely positioned by typing 
coordinates into a dialog.

Sphere moving and stretching is restricted to the plane perpendicular to your line of sight.  If you need to move the 
Sphere in another plane, rotate the model such that the desired translation plane is perpendicular to your new line of 
sight.  (Note that the Sphere will not exactly track the location of the mouse pointer.)

To set the Sphere by specifying coordinates:

To move the Sphere with the mouse:
1. Place the mouse pointer over the center of the tool.
2. Click (and hold) the left mouse button.
3. Drag the Sphere to the desired location.
4. Release the mouse button.

To stretch the Sphere with the mouse:
1. Place the mouse pointer over either of the center line’s endpoints.
2. Click (and hold) the left mouse button.
3. Drag the endpoint to the desired location.
4. Release the mouse button.
Note that the mouse pointer will change when it is over a hotpoint (if in Part or Frame mode).
(Undo/Redo button at the bottom of screen can be used to undo/redo the tool transformation)

1. Open the Transformation Editor dialog by 
clicking Transf... on the desktop.

2. Select Editor Function > Tools > Sphere.

3. Enter the desired coordinates for the 
Origin (location of the center point), 
the Axis (direction vector), and/or the 
Radius and press return.

if you are going to create a developed surface from 
a spherical clip, you need to be aware of how the 
spherical axis orientation affects this operation.  
(See How To Create a Developed Surface) 
Page 1 of 2



You can also translate the Sphere by setting the desired axis of translation in the Axis pop-up and manipulating the 
slider bar.  In this case, the values in the “Scale Settings” section control the sensitivity and limit of the slider action.

Note that you can also use this dialog to view (rather than set) the position of the Sphere since the numeric values 
always update to reflect the current location.  If you are positioning the Sphere interactively with the mouse, the 
values will update when the mouse button is released.

ADVANCED USAGE
After a model has been loaded, the initial location of the Sphere center is set to the “look-at” point – the geometric 
center of all visible geometry and aligned with the X axis.  The coordinates of the Sphere are specified with respect to 
the default frame: frame 0.  However, if you have created additional frames, you can position the Sphere relative to 
the origin of a different frame.  This is accomplished by selecting the desired frame in the “Which Frame” list in the 
Transformation Editor dialog.

You can easily reset the position and orientation of the Sphere tool to the default.  See How To Reset Tools and 
Viewports for more information.

Positioning a 3D tool with a 2D device (the mouse) can be difficult.  Multiple viewports are sometimes helpful in 
positioning tools since you can see the tool simultaneously from multiple vantage points.

SEE ALSO
Other tools: Cursor, Line, Plane, Box, Cylinder,  Cone, Surface of Revolution. See the How To article on Frames 
for additional information on how frames effect tools.

User Manual: Tools Menu Functions
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Use the Cone Tool

INTRODUCTION
EnSight provides a conical specification tool called the “Cone” tool.  When visible, the Cone tool appears as a 
(typically white) cone icon with a line running down the center axis.   The Cone tool is used to supply EnSight with a 
conical specification, for example to specify the location for a conical clip or cut.

BASIC OPERATION
In many cases, the Cone tool will automatically turn on when performing some function that requires it.  You can also 
turn the tool on and off manually by toggling Tools > Quadric > Cone.  The Cone tool can be placed in two ways: 
interactively through direct manipulation of tool “hotpoints” with the mouse or precisely positioned by typing 
coordinates into a dialog.

Cone moving and stretching is restricted to the plane perpendicular to your line of sight.  If you need to move the 
Cone in another plane, rotate the model such that the desired translation plane is perpendicular to your new line of 
sight.  (Note that the Cone will not exactly track the location of the mouse pointer.)

To move the Cone with the mouse:
1. Place the mouse pointer over the center of the tool.
2. Click (and hold) the left mouse button.
3. Drag the Cone to the desired location.
4. Release the mouse button.

To stretch the Cone with the mouse:
1. Place the mouse pointer over either of the center line’s endpoints.
2. Click (and hold) the left mouse button.
3. Drag the endpoint to the desired location.
4. Release the mouse button.

To change the Cone radius with the mouse:
1. Place the mouse pointer over the base ring.
2. Click and drag to the desired radius.
Note that the mouse pointer will change when it is over a hotpoint (if in Part or Frame 
mode).

(Undo/Redo button at the bottom of screen can be used to undo/redo the tool 
transformation)
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To set the Cone by specifying coordinates:

You can also translate the Cone by setting the desired axis of translation and manipulating the slider bar. In this case, 
the values in the “Scale Settings” section control the sensitivity and limit of the slider action.

Note that you can also use this dialog to view (rather than set) the position of the Cone since the numeric values 
always update to reflect the current location. If you are positioning the Cone interactively with the mouse, the values 
will update when the mouse button is released.

The clip/cut from the cone tool will extend infinitely from the tip outwards. To limit the extent of the cone clip/cut, use 
the plane tool and cut the cone clip/cut as desired.

ADVANCED USAGE
After a model has been loaded, the initial location of the Cone center is set to the “look-at” point – the geometric 
center of all visible geometry and aligned with the X axis.  The coordinates of the Cone are specified with respect to 
the default frame: frame 0.  However, if you have created additional frames, you can position the Cone relative to the 
origin of a different frame.  This is accomplished by selecting the desired frame in the “Which Frame” list in the 
Transformation Editor dialog.

You can easily reset the position and orientation of the Cone tool to the default.  See How To Reset Tools and 
Viewports for more information.

Positioning a 3D tool with a 2D device (the mouse) can be difficult.  Multiple viewports are sometimes helpful in 
positioning tools since you can see the tool simultaneously from multiple vantage points.

SEE ALSO
Other tools: Cursor, Line, Plane, Box, Cylinder, Sphere, Surface of Revolution. See the How To article on 
Frames for additional information on how frames effect tools.

User Manual: Tools Menu Functions

1. Open the Transformation Editor dialog by 
clicking Transf... on the desktop.

2. Select Editor Function > Tools > Cone.

3. Enter the desired coordinates for the 
Origin (location of the cone tip), the 
Axis (direction vector), and the 
conical half angle (in degrees) and 
press return.
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Use the Surface of Revolution Tool

INTRODUCTION
EnSight provides a surface of revolution specification tool called the “Revolution” tool. When visible, the Revolution 
tool appears as a (typically white) icon with a line running down the center axis.   By default, the distance of five 
planar points from the central axis defines the profile curve of the revolution surface (although you can add points up 
to a maximum of ten). The Revolution tool is used to supply EnSight with a surface of revolution specification, for 
example to specify the location for a revolution clip or cut.

BASIC OPERATION
In many cases, the Revolution tool will automatically turn on when performing some function that requires it. You can 
also turn the tool on and off manually by toggling Tools > Quadric > Revolution. The Revolution tool can be placed in 
two ways: interactively through direct manipulation of tool “hotpoints” with the mouse or precisely positioned by typing 
coordinates into a dialog.

Revolution tool moving and stretching is restricted to the plane perpendicular to your line of sight. If you need to move 
the Revolution tool in another plane, rotate the model such that the desired translation plane is perpendicular to your 
new line of sight. (Note that the Revolution tool will not exactly track the location of the mouse pointer.)

To move the Revolution tool with the mouse:
1. Place the mouse pointer over the center of the tool.
2. Click (and hold) the left mouse button.
3. Drag the tool to the desired location.
4. Release the mouse button.

To reorient the Revolution tool with the mouse:
1. Place the mouse pointer over either of the center line’s endpoints.
2. Click (and hold) the left mouse button.
3. Drag the endpoint to achieve the desired orientation.
4. Release the mouse button.
Note that the mouse pointer will change when it is over a hotpoint (if in Part or Frame 
mode).

(Undo/Redo button at the bottom of screen can be used to undo/redo the tool 
transformation)
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To set the Revolution tool by specifying coordinates:

You can also translate the Revolution tool by setting the desired axis of translation in the Axis option menu and 
manipulating the slider bar. In this case, the values in the “Scale Settings” section control the sensitivity and limit of 
the slider action.

Note that you can also use this dialog to view (rather than set) the position of the Revolution tool since the numeric 
values always update to reflect the current location. If you are positioning the Revolution tool interactively with the 
mouse, the values will update when the mouse button is released.

1. Open the Transformations dialog by 
clicking Transf... on the desktop.

2. Select Editor Function > Tools > 
Revolution.

The dialog displays the profile curve as a series 
of connected line segments with stars 
positioned at the curve points. You can edit the 
curve by clicking and dragging the points or by 
manually entering distance-radius pairs. You 
can also add or delete points. As you make 
changes, the tool in the graphics window 
updates interactively.

To edit points with the mouse:
1. Click on the point and drag to the desired 

location.

To add points (up to a maximum of 10):
1. Click Add Point.
2. Move the mouse pointer into the curve 

window and click the left mouse button in 
the location of the desired new point. 
Clicking Delete Point will remove the 
currently selected point.

To manually edit a point:
1. Click the point (to select it) in the curve 

window or click the desired point in 
either the Distance or Radius lists.

2. The distance and radius of the selected 
point are shown in the text fields below 
each list.

3. Edit the point’s distance and/or radius 
value and press return.

To edit the position or orientation:
1. Enter the desired coordinates for the 

Origin (location of the axis center point) 
or Axis (direction vector) and press 
return.
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ADVANCED USAGE
After a model has been loaded, the initial location of the Revolution tool center is set to the “look-at” point – the 
geometric center of all visible geometry and aligned with the X axis. The coordinates of the Revolution tool are 
specified with respect to the default frame: frame 0. However, if you have created additional frames, you can position 
the Revolution tool relative to the origin of a different frame. This is accomplished by selecting the desired frame in 
the “Which Frame” list in the Transformations dialog.

You can easily reset the position and orientation of the Revolution tool to the default. See How To Reset Tools and 
Viewports for more information.

Positioning a 3D tool with a 2D device (the mouse) can be difficult. Multiple viewports are sometimes helpful in 
positioning tools since you can see the tool simultaneously from multiple vantage points.

SEE ALSO
Other tools: Cursor, Line, Plane, Box, Cylinder, Sphere, Cone. See the How To article on Frames for additional 
information on how frames effect tools.
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Use the Selection Tool

INTRODUCTION
EnSight provides a 2D screen selection tool called the “Selection” tool or “Region Selector”. It is different than most of 
the other tools - in that it is not used to create other parts. It is basically used for selection purposes. For example, it 
can be used to select a screen region to zoom in to. It can be used in the part selection process. And it can be used 
for the element blanking operation.

BASIC OPERATION

Zoom to Region
To use the selection tool to perform a zoom operation:

1. Click the Selection tool 
rubberband positioning button.

2. Click in the graphics window 
(to set one corner) and drag (to 
set the opposite corner) to place 
the selection tool.

3. Fine tune the location of the 
tool, if needed, by the methods 
described below.

4. Click the Zoom symbol, at the 
upper left of the tool, to cause 
the zoom to occur.

Note: the Undo button is useful if 
you want to undo the last 
transformation.

You manipulate the tool by:

- clicking and dragging on any 
corner to rubberband the tool.

- clicking and dragging on the 
center of the tool to move it.

Note: the dotted box indicates the 
actual region being used. It is 
preserving the aspect ratio.
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Element Blanking
The selection tool can be used in the element blanking operation.:

1. Select the part(s) on which to do element 
blanking.

2. Click on the Selection tool icon to turn on the 
tool.

3. Position the tool as desired.

4. Click on the element blanking symbol at the 
upper left of the tool.

Note, in order for this to work, the Element blanking 
allowed toggle needs to be on (the default).
To undo the blanking, click the Clear or Clear all 
parts button.

Results in the following:
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Part Selection
To use the tool in the part selection process:

SEE ALSO
How To Do Element Blanking
How To Rotate, Zoom, Translate, Scale

User Manual: Tools Menu Functions

1. Turn on the selection tool by clicking the icon.
2. Manipulate the tool until at least some portion of the desired parts 

are contained within the tool’s dotted area.
3. Click the Select... button and select “Region”

Note that the selected parts will now be highlighted in the parts list.
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Visualize Data
Introduction to Part Creation

INTRODUCTION
Much of the strength of EnSight derives from it’s flexible and powerful part creation mechanism.  Since virtually every 
task you perform in EnSight will involve some form of part manipulation, it is vital to understand these concepts.

In EnSight, a part is a named collection of elements (or cells) and associated nodes.  The nodes may have zero or 
more variables (such as pressure or stress) currently defined at the node positions.  All components of a part share 
the same set of attributes (such as color or line width).

Parts are either built during the loading process (based on your computational mesh and associated surfaces) or 
created during an EnSight session.  Parts created during loading are called model parts.  Model parts can also be 
created during an EnSight session by performing a copy on other model parts.

All other parts are created during an EnSight session and are called created or derived parts.  Created parts are built 
using one or more other parts as the parent parts.  The created parts are said to depend on the parent parts.  If one or 
more of the parent parts change, all parts depending on those parent parts are automatically recalculated and 
redisplayed to reflect the change.  As an example, consider the following case.  A clipping plane is created through 
some 3D computational domain and a contour is created on the clipping plane.  The contour’s parent is the clipping 
plane, and the clipping plane’s parent is the 3D domain.  If the 3D domain is changed (e.g. the time step changes), 
the clipping plane will first be recalculated, followed by the contour.  In this way, part coherence is maintained.

This article is divided into the following sections:

The Parts List
Creating Parts
Part Types
Part Operations
Part Attributes
Where Parts Are Created and Maintained
Hints and Tips

The Parts List
Both model parts as well as all derived parts are displayed as items in the Parts List. There are several ways that the 
Parts list can be displayed, the default looks something like:

Part numbers

Case number (important when 
multiple datasets have been 
loaded)

Part descriptionP indicates Parent of 
currently selected part

Currently selected part

The Sort... button gives you control over many other ways to 
display the parts in the Part list - including the order, whether 
parent child hierarchy is to be shown, and whether other 
details will be shown.
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This shows the same part list as before, but using the 
parent/child tree - which quickly and efficiently shows 
the parent of each part.

Selected parts can be deleted here.

There are several ways to 
easily select multiple parts.

For models with many parts, the large 
part list can be used - which will expand 
the list down the left side of the desktop.

If you right click on a selected part (or parts) in the part list, you 
have access to a number of part operations
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Also, Items in the Parts List are selected using standard Motif methods:

Creating Parts
The mechanism for creating derived parts is largely the same regardless of part type:

1. In the Parts List, select the part(s) to use as parents.
2. Click the desired feature icon.  This will open the corresponding creation section for the part type in the Quick 

Interaction area.
3. If necessary, select a variable to use from the Variables List (e.g. for contours or isosurfaces).
4. Set the desired creation attributes in the Quick Interaction area.  IMPORTANT: if you change a text field, you must 

press return to have the change take effect!
5. Click the Create button in the Quick Interaction area.
The example below shows Isosurface part creation:

To ... Do this ... Details ...

Select an item Select
(or single-click)

Place the mouse pointer over the item and click the left mouse button.  The item is 
highlighted to reflect the “selected” state.

Extend a contiguous 
selection

Select-drag Place the mouse pointer over the first item.  Click and hold the left mouse button as 
you drag over the remaining items to be selected.  Only contiguous items may be 
selected in this fashion.

Extend a  (possibly long) 
contiguous selection

Shift-click Select the first item.  Place the mouse pointer over the last item in the list to be 
selected.  Press the shift key and click the left mouse button.  This action will 
extend a selection to include all those items sequentially listed between the first 
selection and this one.

Extend a non-contiguous 
selection

Control-click Place the mouse pointer over the item.  Press the control key and click the left 
mouse button.  This action will extend a selection by adding the new item, but not 
those in-between any previously selected items.

De-select an item Control-click Place the mouse pointer over the selected item.  Press the control key and click the 
left mouse button.  This action will de-select the item.

Open the Quick 
Interaction Area for a part

Double-click Place the mouse pointer over the item and click the left mouse button twice in rapid 
succession.

1. Select the parent part(s). 3. Select the variable to use.

2. Click the isosurface 
creation icon.

4. Select an appropriate isovalue.
(Often there is a sensible default)

5. Click “Create”.
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Part Types
The following table provides information on the available part types in EnSight:

Part Type Symbol Feature Icon Description

Clip 2 A surface or line resulting from a clip of parts using an IJK, XYZ, or 
RTZ surface of the parts; or a clip of other parts using the Line, 
Plane, Box, Cylinder, Sphere, Cone, or Surface of Revolution tool; 
or a clip of other parts by revolving an existing 1D part.

Contour C Lines of constant value on 2D elements.

Developed 
Surface

D A planar surface derived by unrolling a surface of revolution (e.g. 
unrolling a clip created with the Cylinder tool).

Elevated Surface E A part created by scaling a 2D part (in the direction of the local 
surface normal) based on the value of a variable.

Isosurface I A surface of constant value through 3D elements.

Model M An original part (i.e.loaded from a disk file) or created through some 
operation (e.g. copy or extract) on a model part.

Particle Trace T A part consisting of the paths taken by one or more massless 
particles as integrated through a vector (typically velocity) field.

Profile P Plot of a variable along a line (the 2D counterpart to an elevated 
surface).

Vector Arrow V A part consisting of a set of arrows showing direction and 
magnitude of a vector variable.

Subset S A part created by node and/or element label range(s) from model 
part(s).

Tensor Glyph G A part consisting of tensor glyphs showing direction and relative 
magnitude of the eigenvectors of a tensor variable.

Material Part A A part created according to the intersection of or domains of 
material values.

Vortex Core X A part consisting of line segments down the center of flow vortices.

Shock Surface/
Region

K A part consisting of the surface or volume elements where shock is 
higher than a threshold.

Separation/
Attachment Line

L A part consisting of line segments on a surface where flow 
separation and attachment is occurring.
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Part Operations
EnSight provides several powerful part operators. These operations are accessible from the Edit > Part submenu.

Part Attributes
All parts have numerous attributes that control behavior and display.  Although many attributes can be controlled 
either through the Quick Interaction area or the Part Mode icons, complete access is provided by the various Feature 
Detail Editor dialogs.  Part attributes and the Feature Detail editors are covered in detail in How To Set Attributes.

Copy The copy operation creates a dependent copy of another part.  The part is created on the client and 
is not known to the server.  The new part has its own set of attributes (except for representation), but 
shares geometric and variable data with the original.

One of the best reasons to create a copy is to show multiple variables on one part at the same time 
in a side-by-side configuration.  The copies can be moved independently since each new copy is 
automatically assigned a new frame.

See How To Copy a Part for more information.

Group This operation will collapse the selected parts into a new “umbrella” part.  Grouping is most often 
used to combine a series of parts into a single part for ease in handling.  The part is created on the 
client and is not known to the server.  The operation is reversible through the Ungroup command.

See How To Group Parts for more information.

Delete The delete operation completely removes not only the currently selected parts, but also any parts 
derived from the selected parts.

See How To Delete a Part for more information.

Extract The extract operation is closely tied to part representations. Extract creates a new dependent part 
using only the geometry of the current representation of the part. For example, if the current 
representation of a part consisting of 3D elements is Border, the result of extraction will be a part 
consisting of all unshared 2D elements (the surface).

Extract is most often used to reduce the amount of information for a part (e.g. for faster display or for 
geometry output) or to create a surface shell part – perhaps for subsequent cutting – of a 3D 
computational domain.

See How To Extract Part Representations for more information.

Merge Merge creates one new dependent part from one or more selected parts.  The original parts are 
unchanged.  If only a single part is selected for the operation, merge will create a “true” copy of the 
part (as opposed to the “shallow” copy that the Copy operation creates).

Merging is most often used to combine a series of parts into a single part for ease in handling (such 
as attribute setting).

See How To Merge Parts for more information.
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Where Parts Are Created and Maintained
Part creation occurs on either the EnSight client or the server.  Since the data that is available on the client and server 
are different, it is useful to understand where parts are created and where the data is stored.  For example, you can 
only perform a query operation for parts that are stored on the server.  The following table provides this information 
for each part type:

In the last column, “depending on representation” means the current visual representation for the part.  For 
example, if the part’s visual representation is “Not Loaded”, then no data is currently present on the client.

Hints and Tips
With some datasets that contain many parts, it sometimes becomes difficult to maintain the connection between a 
part as displayed in the Graphics Window and the corresponding item in the Parts List.  To see which part(s) are 
currently selected in the Parts List, select View > Show Selected Parts...  This will open a new graphics window (titled 
Part(s) Selected Viewport) that will display only those parts that are currently selected in the Parts List.

You can rapidly cycle through items in the Parts List using the up/down arrow keys on your keyboard.  Select any item 
in the list and then press the up arrow (to move to previous entries) or down arrow (to move to subsequent entries).  
This is particularly helpful when used in conjunction with the Part(s) Selected Viewport window (as described above) 
to quickly locate a part of interest.

You can select parts in the Parts List by picking the part in the Graphics Window. In Part Mode, select Pick Part from 
the Pick pull-down. In the Graphics Window, place the mouse pointer over any portion of the desired part and press 
the ‘p’ key. If you hold down the control key at the same time, the part is added to the list of currently selected parts.

Selected parts can be written to disk and loaded in a future session. Select File > Save > Geometric Entities ...  You 
have the option of saving either in EnSight format, VRML format, STL format, or other user-defined formats. See How 
To Save Geometric Entities for more information.

SEE ALSO
User Manual: Features, Part Operations

Part Type Where Created Data on Server? Data on Client?

Clip server yes depending on representation

Contour client no yes

Developed Surface server yes depending on representation

Discrete Particle N/A yes depending on representation

Elevated Surface server yes depending on representation

Isosurface server yes depending on representation

Model N/A yes depending on representation

Particle Trace server no yes

Profile client no yes

Vector Arrow client no yes

Subset server yes depending on representation

Tensor Glyph client no yes

Vortex Core server yes depending on representation

Shock Surface/Region server yes depending on representation

Separation/Attachment Line server yes depending on representation

Material server yes depending on representation
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Create Contours

INTRODUCTION
A contour is a line of constant value on a two-dimensional (though not necessarily planar) surface.  The region on one 
side of the line is larger than the isovalue; the region on the other side is less than the isovalue.  EnSight creates 
contour lines in groups where the isovalues either correspond to the levels in the palette defined for the contour 
variable, or a user specified range and distribution.  The main level contour lines can also be labeled with the 
corresponding palette value.

BASIC OPERATION

The Contour Quick Interaction area lets you set the number of contour levels (and sublevels) as well as attach labels 
to the contour lines. Contour lines can be synced to the palette levels or can be chosen manually. 

1. Select the parent part. 3. Select the variable to use.

2. Click the Contours icon.

4. Click Create.

In the parts list, double-click the contour part you wish to edit.

If you want the levels of the variable palette to be used for contours: 

1. Select the Variable.

2. Toggle on Sync To 
Palette.

3. Select the number of 
sublevels desired (if 
any). And make sure 
Visible toggles are set as 
desired.

See  How To Edit Color Maps for how to set the color 
palette levels.

4. Set the Visibility, Spacing, Color, and 
Format of the contour labels.

Note that only the main contour levels (not the 
sublevels) are labeled.
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ADVANCED USAGE
When Sync To Palette is specified, the levels of the variable palette are used as the contour levels.  You must edit the 
palette using the Feature Detail Editor for Variables to modify the number of levels, distribution, etc.  See   How To 
Edit Color Maps for guidance.

OTHER NOTES
The default behavior is to color the contour part by the creation variable. If you toggle this off, the contour part will not 
be colored by a variable automatically, but will be white.

Unlike most part creation operators, contours are created from the client’s representation of the part – not the 
server’s. If the parent part of the contour consists of one-dimensional elements or has no client-side visual 
representation at all, the resulting contour will be empty. This would be the case if the parent part was currently 
displayed as feature angle, border representation, or not loaded. The 3D border, 2D full representation is typically 
used for contour part parents. See How to Change Visual Representation for more information.

SEE ALSO
Introduction to Part Creation, How To Edit Color Maps.

User Manual: Contour Create/Update

If you want contour levels to be independent of Variable palette levels: 

In the parts list, double-click the contour part you wish to edit.

1. Select the Variable.

2. Toggle off Sync To 
Palette.

3. Specify the Min and 
Max Range.

4. Specify the number 
of Levels and 
sublevels.

5. Specify the Distribution method for the Range.

6. Set the Visibility, Spacing, Color, and Format of the 
contour labels.
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Create Isosurfaces

INTRODUCTION
An isosurface is a surface of constant value in a three-dimensional field.  It is the 3D counterpart to the contour loop: 
the region on one side of the isosurface has values greater than the isovalue; the region on the other side has values 
less than the isovalue.  In EnSight, an isosurface can be generated from a scalar variable, a component or magnitude 
of a vector variable, or a component of the model coordinates.

An isosurface of a scalar or vector variable is typically a complex surface reflecting the distribution of the underlying 
variable.  Isosurfaces of coordinates, however, are typically regular geometric shapes such as planes, cylinders, 
cones or spheres.

BASIC OPERATION

ADVANCED USAGE

Interactive Isosurfaces
You can have EnSight automatically generate and display isosurfaces as you adjust a slider with the mouse.

You can also set the Interactive mode to Auto and EnSight will automatically sweep from Range Min to Max with step 
size equal to Increment.

1. Select the parent part. 3. Select the variable to use.

2. Click the Isosurface 
creation icon.

4. Select an appropriate isovalue.
(the default will be a mid-range value)

5. Click Create.

1. Set the Interactive mode to Manual. 2. Adjust the slider to the desired location.
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Isosurface Animation
A range of isosurfaces can be automatically generated and viewed in a flipbook. Flipbooks provide on-screen 
animation of various dynamic events and (in the default setting) permit graphic manipulation (e.g. rotation or zoom) 
while the animation runs.

 

EnSight can also automatically calculate a range of isosurfaces during keyframe animation.

1. Open the Feature Detail Editor for isosurfaces (Edit > Part Detail Editors > Isosurfaces ...).

2. Select the isosurface part.

3. In the Creation Attributes section, set the 
Animation Delta to an appropriate value and hit 
return.  For each page (frame) of the flipbook, 
this value will be added to the current value to 
yield the new isovalue.

4. Click the Flipbook icon.

5. Set the Load Type to 
Create Data.

6. Set the number of pages 
to an appropriate value.

7. Click Load.

8. When loading is complete, the flipbook will begin to be displayed. You can then control the various run 
options under the Run tab.
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Creating Multiple Offset Isosurfaces:
You can have EnSight create multiple isosurfaces at a specified delta value. The results is a group of isosurfaces:

Isovolume Creation
An isovolume is a volume whose constituents (e.g. nodes and elements) are constrained to a constant interval range 
in a scalar field. In EnSight, you can constrain the isovolume to ranges less than an interval minimum, greater than an 
interval maximum, or between the interval minimum and maximum.

1. Select the parent part. 3. Select the variable to use.

2. Click the Isosurface 
creation icon.

4. Select an appropriate isovalue.
(the default will be a mid-range value)

6. Click Create.

5. Set the number of surfaces and the delta between 
them.

1. Open the Feature Detail Editor for isosurfaces 
(either: Edit > Part Detail Editors > Isosurfaces ... , 
or double click the Isosurface Feature Icon).

2. Select the isosurface part.

3. In the Creation Attributes section, set Type to 
Isovolume.

4. Set the Constraint to Band to constrain the 
isovolume within an appropriate Min and Max 
range of the scalar variable.
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OTHER NOTES
Effective display of more than two nested isosurfaces is difficult.  Set transparency on the outermost isosurface(s) to 
reveal the inner surfaces.  To avoid confusion, don’t try to display isosurfaces of more than one variable 
simultaneously, or multiple isosurfaces of the same variable colored by different variables.

SEE ALSO
How-To Create a Flipbook Animation, How-To Create a Keyframe Animation

User Manual: Isosurface Create/Update
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Create Particle Traces

INTRODUCTION
A particle trace represents the path a massless particle would take if released in a flow field. From an initial seed point 
(the emitter), a path is formed by integrating through the velocity field over time. The path is therefore everywhere 
parallel to the flow. Traces calculated in a steady-state flow field are called streamlines. For transient flow, the path is 
known as a pathline.

EnSight provides a great deal of control over emitter definition and trace appearance:

• Emitters can be defined using one of the built-in tools (Cursor, Line, or Plane) or by clicking on any 
surface in the Graphics Window. The nodes of an arbitrary part can be used as an emitter, or the emitter 
time and locations can be read from a file (see EnSight Particle Emitter File Format in the Chapter 11 of 
the User Manual). 

• The streamline path can be generated in the positive, negative, or positive and negative time directions.
• Traces can be restricted to lie on any surface to search for flow topology and separation features.
• For transient cases, an emitter can have a delta time that controls the periodic release of additional 

particles into the dynamic flow.
• Emitters can be interactive: as you move the emitter with the mouse, the associated traces 

automatically recalculate and redisplay.
• Trace paths can be displayed as lines, ribbons, or as square tubes, where ribbon or tube twist follows 

the local flow rotation around the path.
• Particle traces can be easily animated to provide intuitive comprehension of the flow field.  Complete 

control over all aspects of the animating tracers is provided, including length, speed, and release 
interval for multiple pulses.

BASIC OPERATION
To trace particles through a steady-state flow field:

1. Select the flow field 
mesh part(s) to trace 
through.

3. Select the vector variable to 
use.

2. Click the Particle Traces icon.

4. Select the desired emitter.

5. If the emitter is a tool (Cursor, Line, Plane), position the 
tool at the desired emitter location. You can also click 
the Tool Location button to precisely position the tool.  
If the chosen emitter is Part, then enter the part number 
in the Part ID field and press return.

6. Click Create.   The particle traces will be 
created from the desired emitter. Their 
maximum time duration is controlled via 
the Total Time Limit found under Emit...
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The following are the available Emit From options.  Note that traces will only be generated for those emitter points 
that actually lie within an element of the selected flow field part(s).

The complete set of particle trace attributes can be edited in the Feature Detail Editor for Traces.  However, some 
emitter attributes can be changed from the Particle Traces Quick Interaction area by clicking the Emit... button:

Display Traces as Ribbons or Square Tubes, and control Arrowheads
Particle paths can be displayed as lines, ribbons, or square tubes, where ribbon or tube twist follows the local flow 
rotation. To enable ribbon or square tube display, and change trace arrowheads:

Cursor A single trace will be emitted from the Cursor tool.

Line Multiple traces will be emitted from evenly spaced points along the Line tool.  
Enter the desired number of traces in the # Points field and press return.

Plane Multiple traces will be emitted from evenly spaced points in a grid pattern over the 
Plane tool.  Enter the desired number of traces in the X and Y direction (with 
respect to the Plane tool’s axis) in the # Points X/Y fields and press return.  The 
total number of traces will be the product of X and Y.

Part One trace will be emitted from the number of nodes of the part you specify. This 
number of nodes will be randomly selected. Enter the number (from the Main 
Parts list) of the part you wish to use as an emitter, and the number of nodes.

File Traces will be emitted from the locations, and at the times, specified in an EnSight 
Particle Emitter file. See EnSight Particle Emitter File Format in Chapter 11 of the 
User Manual.

Click to set the trace direction:

+: forwards in time (positive 
velocity direction) from the 
emission point(s)

-: backwards in time (negative 
velocity direction) from the 
emission point(s) towards the 
entering flow boundary

+/-: both forwards and 
backwards

Toggle on to have start time be 
the current time, otherwise 
specify the start time.

Set the total amount of time 
a trace will last (it may 
terminate for other reasons 
as well). An intelligent 
default will be set for you.

Solution time at which to 
begin pathline trace 
(pathlines only).

Delta emission time for 
pathlines. If not zero, a new 
set of traces will be emitted 
at S, S+D, S+2D, etc. into 
the changing flow field 
(where S is the Start time 
and D is the delta value). 
Used to create streaklines 
or smoke traces. Animated 
streaklines are one of the 
most powerful methods for 
visualizing transient flow.

1. Double-click the desired particle trace part in the Main Parts 
list (to open the Quick Interaction area for the trace part).

2. Click Show As... to open the Trace Show As Attributes dialog.
3. Set Show As to Ribbon or Square Tubes.
4. If desired, change the default ribbon or square tube width and 

press return.
5. Select the Arrowhead representation desired.
        (Cone, Normal, or Triangles)
6. Set the number of arrowheads to display along a trace.
7. Set the arrowhead size.
5. Click Close.
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Animate Particles
Any type of particle trace can be animated.  See How To Animate Particle Traces for more information.

Pick a Surface to Trace a Particle

Rather than emit from a tool or a part, you can also interactively pick points on a surface in the Graphics Window to 
define emitter locations.  To do this:

1. Execute steps 1-3 as described under Basic Operation above.

2. Click the Pick Surface toggle.

3. Click Create.

4. Move the mouse into the Graphics Window and click the left mouse button when the cursor is over the 
desired location.  The clicked point must be found within some element of the selected flow field mesh 
part to result in a trace.

5. You can click to create as many point emitters as you like.  When done, move the mouse out of the 
Graphics Window.

6. Toggle off the Pick Surface button.

Note that you can also specify a rake (line) or net (plane) emitter by picking on a surface.  Just set the emitter to Line 
or Plane prior to clicking Create.  Then follow in the instructions in the pop-up window.

Interactive Particle Tracing
If a particle trace was created from one of the tool emitters (Cursor, Line, or Plane) and the trace is not a pathline 
trace, the emitter can be made interactive.  When interactive, the tool that created the particle trace part can be 
moved with the mouse.  As the tool is moved, new particle traces are automatically recalculated and redisplayed.  To 
trace interactively:

1. Either create a particle trace part as described above (based on a tool) or double-click an existing particle 
trace part to open the Quick Interaction area for that part.

2. Toggle on Interactive Emitter.  If the tool that originally defined the emitter is not visible, it will be turned on 
by this operation.

3. Move the mouse into the Graphics Window and manipulate the tool as desired.  See the article on the 
applicable tool for information on tool manipulation (Cursor, Line, or Plane).

4. When done, toggle off Interactive Emitter.
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Trace Surface-Restricted Particles
EnSight can trace particles such that they are constrained to lie on a (not necessarily planar) 2D surface – even if the 
velocity is zero at the surface.  The trace is calculated by projecting a short distance off the surface into the 3D flow 
field and using the velocity value found there.  Both the projection distance (variable offset) and a display offset are 
user definable.
Surface-restricted trace emitters are defined by mouse action in the Graphics Window.  When you click and drag over 
the desired surface, the emitter is defined by projecting the mouse path onto the surface.  To trace surface-restricted 
particle traces:

1. Select the desired surface part(s) in the Main Parts list.  
This should be the surface you wish to trace on.

2. Set the desired vector variable to use for tracing.

3. Select the desired emitter type (Cursor, Line, or 
Plane). Note that the applicable tool will not actually 
be used in this operation (a pick action will be used).

4. Toggle on the Surface Restricted button. Note that all 
subsequent tracing will be assumed to be surface 
restricted until this is toggled off.

5. If the Emit From is set to Line or Plane, enter the 
desired number of points (Line) or X and Y points 
(Plane).

9. Click the Create button.

10. Move the mouse pointer into the Graphics Window 
and:

for a Cursor emitter: click the left mouse button on the 
desired location.
for a Line emitter: click and hold the left mouse button 
on one endpoint of the desired line. Drag to the other 
endpoint (a white line will provide feedback).
for a Plane emitter: click and hold the left mouse button 
on one corner of the desired region. Drag to the 
opposite corner (a white rectangle will provide 
feedback).

11. You can continue to specify emitters of the selected 
type as long as the mouse pointer remains in the 
Graphics Window. When the pointer exits the window, 
the trace part will be created.

12. When done, toggle off Surface Restricted.

Note that this operation can also be done in the Feature Detail Editor for Traces.
In this dialog, you have control over the various other attributes of the trace - including variable offset, display 
offset, trace direction, etc.
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Trace Pathlines
EnSight provides complete control over transient particle tracing.  Both the start time and the stop time can be 
specified.  In addition, you can specify a delta value for an emitter that will cause additional particles to be emitted into 
the flow at regular intervals.  This type of pathline is also called a streakline or smoke trace.

You create a pathline trace by setting the Type to Path (rather than Stream) prior to clicking Create.  By default, the 
pathlines will start at the first time step of your simulation and terminate at the last step (unless stopped earlier).  You 
can change these defaults with the Emission Detail Attributes dialog as described above (click Emit... to open).

Edit Emitter Attributes
Although the Particle Trace Quick Interaction area provides most tracing controls, the Feature Detail Editor for Traces 
provides complete control over all creation attributes. To use the editor:

1. Select Edit > Part Feature Detail Editors > Particle Traces... to open the Feature Detail Editor (Traces) 
dialog.

2. Select the desired particle trace part in the part list at the top of the dialog.

Set the desired flow field 
variable

Set the fraction of each 
component of the vector 
variable to use in the trace 
calculation.

Trace type

Line or ribbon display

Number of arrowheads along 
the trace.

List of the emitters belonging 
to the selected trace part

Set interactive emitter

Set emitter direction, total time

Set to emit at current time, or 
set emission time.

Set emission start and delta

Toggle on Surface Restricted 
tracing

Set surface restricted variable 
and display offsets.

Set ribbon width

Set Arrowhead size.

Emission tool for currently 
selected emitter

Number of points (If Line or 
Plane emitter)

Add Emit: add a new emitter to 
the selected part based on the 
current attributes.

Delete Emit: delete the 
selected emitter.

Set Total Time to the default.

Toggle on surface picking for 
emitter definition
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Massed Particle Traces
Ensight also provides massed particle traces via the Feature Detail Editor for Traces.

OTHER NOTES
Particle trace calculation can be expensive for large or transient datasets and/or a large number of particles.  Be 
careful when you initiate a trace operation – there is currently no way to abort it.  If you are calculating pathlines, you 
should specify as many particles as possible at one time.  Much of the pathline execution time is in reading the 
transient data from disk and this operation has to be performed regardless of how many traces were specified.

The EnSight particle trace algorithm integrates the vector flow field over time using a 4th-order Runge-Kutta method 
with a time varying integration step. Several of the integration parameters can be changed by the user. See Particle 
Trace Create/Update in the User Manual for more information.

If you have trace data for other types of particles (e.g. for multi-phase flow simulations) you can use the discrete/
measured data facility to load the particle path positions and animate them over time.

SEE ALSO
How To Animate Particle Traces

User Manual: Particle Trace Create/Update

1. Select Edit > Part Feature Detail Editors > Particle 
Traces...  to open the Feature Detail Editor 
(Traces) dialog.

2. Select the desired the particle trace part in the 
part list at the top of the dialog.

3. Click the Massed Particle turn-down to reveal the 
massed particle parameters.

4. Modify the massed particle parameters according 
to your dataset. For instance, to compute only 
the drag force term in the momentum balance 
equation, toggle off the Gravity force term.

5. Toggle on Massed Particles.

The selected particle trace part will update to a massed 
particle trace(s) taking into consideration the drag force 
term parameters only.

For the theory used in massed particle traces, see the 
User Manual: Particle Trace Create/Update
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Create Clips

INTRODUCTION
EnSight provides a powerful set of clipping operators. See the following How To articles for more information:

Create Line Clips Clip lines are linear clips through 2D or 3D models with samples taken at evenly spaced 
intervals (using the Line Tool). Values along a clip line can be visualized using profiles or 
queried and sent to a plotter.

Create Plane Clips A clipping plane is a planar slice through a 3D mesh using the Plane Tool. EnSight’s clipping 
operation can take arbitrary cuts through either structured or unstructured meshes. The clip 
can be infinite in extent (at least to the bounds of the parts it is created from) or restricted to 
the bounds of the Plane tool. The nodes of the resulting clipping plane can be based on the 
topology and resolution of the underlying mesh or sampled on a regular grid.
You can also create a clip that contains all the elements that intersect the plane value via the 
crinkly domain specification. These clips help view the integrity of the mesh at these values.

Create Box Clips A Box clip is a 3D volumetric hexahedral-shaped clip or cut. This clip uses the box tool (which 
can be manipulated anywhere in space), and the result can be the surface intersection of the 
box tool walls and the model, the volume portion of the model inside the tool, the volume 
portion of the model outside the tool, or the crinkly surface elements of the intersection. Be 
aware that due to the algorithm used, this clip can (and most often does) have chamfered 
edges, the size of which depends on the coarseness of the model elements.

Create Quadric Clips In addition to standard clipping planes, EnSight also provides clipping against quadric shapes. 
These clips use the corresponding quadric tool (Cylinder, Sphere, Cone, Surface of 
Revolution) to specify the location of the clip.
You can also create a clip that contains all the elements that intersect the quadric value via the 
crinkly domain specification. These clips help view the integrity of the mesh at these values.

Create IJK Clips An IJK clip is a 1D or 2D slice through a structured mesh. The resulting clip is a 1D line or 2D 
surface where one dimension (e.g. I) is held fixed while the other one or two dimensions (e.g. 
J and K) vary. The minimum and maximum range of the free dimensions can be set by the 
user, as well as the step size. IJK clips can be interactively animated throughout the range of 
the fixed dimension by manipulating a slider.
Although planar clips can still be created through structured meshes, it is often preferable to 
create IJK clips since they are faster to calculate and use less memory. In addition, IJK clips 
are often more intuitive for the user (who typically built the mesh).

Create XYZ Clips An XYZ clip is a 1D or 2D slice through a 2D or 3D mesh (structured or unstructured). The 
resulting clip is a 1D or 2D mesh slice where one of the dimensions (e.g.  X) is held constant 
(or fixed) while the other two dimensions (e.g. Y and Z) vary in reference to the local frame of 
the mesh.   XYZ clips can be interactively animated throughout the range of the fixed 
dimension by manipulating a slider. The minimum, maximum, and step size of the range of the 
fixed dimension can be set by the user. 
Although plane clips can still be created through meshes, it is often preferable to create XYZ 
clips since they are constrained to the local frame of the meshed part.
You can also create a clip that contains all the elements that intersect the mesh slice value via 
the crinkly domain specification. These clips help view the integrity of the mesh at these 
values.

Create RTZ Clips An RTZ clip is a 1D or 2D slice through 2D or 3D meshes (structured or unstructured). The 
resulting clip is a 1D or 2D mesh slice where one of the dimensions (e.g. R,”radial 
component”) is held constant (or fixed) while the other one or two dimensions (e.g.  T, ”theta 
component” and Z, “z axis component”) vary in reference to the local frame of the mesh.   RTZ 
clips can be interactively animated throughout the range of the fixed dimension by 
manipulating a slider. The minimum, maximum, and step size of the range of the interactive 
fixed dimension can be set by the user. 

Revolution Tool Clips A Revolution Tool clip can be made using the surface of revolution tool. It can be the surface 
created by the intersection of the surface of revolution tool and the model, the elements 
intersected by the surface of revolution tool (crinkly), or the volume of the inside and/or the 
outside domain swept by the revolution tool.  This clip does not have interactive manipulation 
capability, with a slider or by dragging the tool with the mouse.  However, the tool can be 
manipulated and the clip updated.

Revolve 1D Part Clips A Revolution of 1D Part clip can be made using a 1D part and a user specified axis. It can be 
the surface created by the intersection of the 1D part about the axis and the model, the 
elements intersected by the 1D part about the axis(crinkly), or the volume of the inside and/or 
the outside domain swept by the 1D part about the axis. This clip does not have interactive 
manipulation capability, with a slider or by dragging the tool with the mouse. However, if the 1D 
part is capable of being moved, you can move it and the revolution clip will update.

Create General 
Quadric Clips

A general quadric clip AX2+BY2+CZ2+DXY+EYZ+FXZ+GX+HY+IZ=J  can be created.  This is 
only available from the Clip Feature Detail Editor.



Create Clip Lines

INTRODUCTION
In addition to standard clipping planes, EnSight also provides one dimensional clipping.  Clip lines are linear clips 
through 2D or 3D models with samples taken at evenly spaced intervals.  Values along a clip line can be visualized 
using profiles or queried and sent to a plotter.

BASIC OPERATION

ADVANCED USAGE
Like the other clipping tools in EnSight, clip lines can be interactive: as you drag the Line tool with the mouse, the clip 
line is automatically recalculated and redisplayed.  If a query has been created from the clip line, the plotted curve will 
automatically redisplay as well.  To perform interactive line clips:

1. Select the parent part.

2. Click the Clip icon.

6. Click Create.

3. Select Line from the Use Tool pull-down.

4. Enter the desired number of 
samples on the line.

5. Position the Line tool as 
desired (see How To Use the 
Line Tool).

1. Double-click the desired clip line part 
in the parts list.

2. Toggle on Interactive Tool in 
the Quick Interaction area.

3. Move the mouse into the 
Graphics Window.  Click on 
one of the Line tool hotpoints (either 
endpoint or center cross) and drag 
the tool to the desired location.
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OTHER NOTES
It is sometimes useful to display just the nodes of a line clip.  Using the Feature Detail Editor, you can change the 
display such that only nodes (not lines or elements) are displayed.  The nodes can be shown as dots, crosses, or 
spheres.  If displayed as crosses or spheres, the size (radius) can be constant or scaled by the value of a variable.  
See How to Set Attributes for more information.

SEE ALSO
Introduction to Part Creation
How To Use the Line Tool
How to Create Profile Plots
How to Query/Plot.

Other clips:
How to Create Clip Planes
How to Create Quadric Clips
How to Create Box Clips
How to Create IJK Clips
How to Create XYZ Clips
How to Create RTZ Clips.

User Manual: Clip Create/Update
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Create Clip Planes

INTRODUCTION
A clipping plane is a planar slice through a 3D mesh.  EnSight’s clipping operation can take arbitrary cuts through 
either structured or unstructured meshes.  The clip can be infinite in extent (at least to the bounds of the parts it is 
created from) or restricted to the bounds of the Plane tool.  The nodes of the resulting clipping plane can be based on 
the topology and resolution of the underlying mesh or sampled on a regular grid.

Besides creating the intersection of a plane through a domain, which is the normal mode for clipping, a clipping plane 
can also be used to create parts which are what would result from a cut of its parent domain into “front” (inside) and or 
“back” (outside) parts.  These parts contain valid elements of the same order as the original domain parts.

Like other clip tools, clipping planes can be interactively manipulated with the mouse providing a powerful volume 
visualization capability.  Clipping planes can also be automatically animated to display results throughout a region of 
space or over time.

BASIC OPERATION

ADVANCED USAGE

Interactive Clipping Planes
Like the other clipping tools in EnSight, intersection clip planes can be interactive: as you drag the Plane tool with the 
mouse, the clipping plane is automatically recalculated and redisplayed.  To perform interactive plane clips:

1. Select the parent part.

2. Click the Clip icon.

5. Click Create.

3. Select Plane from the Use Tool pull-down. 

4. Position the Plane tool as desired (see 
How To Use the Plane Tool).

Note: Multiple plane clips with a delta in the normal direction can be created easily by setting these values.

1. Double-click the 
desired clip plane 
part in the parts list.

2. Toggle on Interactive 
Tool in the Quick 
Interaction area.

3. Move the mouse into the Graphics Window. Click on one of the Plane tool 
hotpoints (centerpoint or axis labels) and drag the tool to the desired location.
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Grid Clips and Finite Clips
By default, clipping planes are calculated based on the resolution and topology of the underlying mesh (parent 
part(s)).  Clipping planes can also be calculated using a regular sampling of the mesh.  Such a clip is called a grid clip 
and is typically used for clipping unstructured meshes where element volumes vary widely.  Creating vector arrows 
on a grid clip typically yields a more useful visualization than on a standard mesh clip.

By default, clipping planes extend to the bounds of the parent part.  A clipping plane can also be restricted to the 
bounds of the Plane tool.

To change an existing clipping plane to a grid clip or to have finite extent:

Clipping Plane Animation
Although you can interactively sweep a clipping plane through a volume, it is sometimes desirable to have EnSight 
automatically calculate a series of clipping planes for you.  These can then be replayed (as fast as your graphics 
hardware will permit) using EnSight’s Flipbook Animation facility.  The flipbook can animate a series of clipping planes 
using a starting and ending position for the Plane tool.  You can also use the Keyframe Animation facility to animate 
clipping planes.

For a description of calculating a series of clipping planes with the Flipbook, see How To Create a Flipbook 
Animation.  For more information on keyframing, see How to Create a Keyframe Animation.

Cutting with Planes
A plane can be used to create parts which are the result of a cut of its parent domain into “front” (inside) and or “back” 
(outside) parts.  These parts contain valid elements of the same order as the original domain parts.  Cutting can be 
used to slice away portions of a model that are not needed or to create animation effects such as “opening” closed 
regions to view the interior.

1. Double-click the desired clipping plane part in the parts list.

2. To change to a grid 
clip, select Grid 
from the Plane Type 
pull-down.

3. To change to a 
finite-extent clipping plane, select Finite from the Plane Extents pull-down.

1. Select  the desired parent parts in the parts list.

2. Click the Clip 
feature icon.

3. Select the Plane 
Tool.

4. Set the Domain to 
Inside, Outside, or 
In/Out (both inside 
and outside).

5. Hit the Create button.
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Crinkly Plane Clips
You can also check the integrity of your mesh by clipping with a crinkly intersection. Specifying a Crinkly Domain 
results in a part composed of all the mesh elements that intersect the plane tool..

OTHER NOTES
Use clipping planes to create planar clips through arbitrary meshes.  If you have a structured mesh (such as those in 
PLOT3D format), you may wish to use IJK clips instead.  An IJK clip displays a “plane” of constant I, J, or K.  An 
interactive IJK clip will sweep through the range of (for example) I displaying the JK plane at each I value.  See How 
to Create IJK Clips for more information.

SEE ALSO
Introduction to Part Creation
How To Use the Plane Tool
How To Create a Flipbook Animation.

Other clips:
How To Create Clip Lines
How To Create IJK Clips
How To Create Quadric Clips
How To Create XYZ Clips
How To Create RTZ Clips
How To Create Box Clips.

User Manual: Clip Create/Update

1. Change the Domain 
to Crinkly.

2. Click the Apply Tool 
Change button.
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Create Box Clips

INTRODUCTION
A Box clip is a 3D volumetric hexahedral-shaped clip or cut. This clip uses the box tool (which can be manipulated 
anywhere in space), and the result can be the surface intersection of the box tool walls and the model, the volume 
portion of the model inside the tool, the volume portion of the model outside the tool, or the crinkly surface elements 
of the intersection.

Be aware that due to the algorithm used, this clip can (and most often does) have 
chamfered edges, the size of which depends on the coarseness of the model 
elements.

BASIC OPERATION

SEE ALSO
Introduction to Part Creation
How To Use Box Tool

Other clips:
How to Create Clip Lines
How to Create Clip Planes
How to Create Quadric Clips
How to Create IJK Clips
How to Create XYZ Clips
How to Create RTZ Clips.    
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1. Select the parent part 2. Click the Clip Icon 3. Select Box Tool

4. Position the Box Tool as desired. 5. Click Create



Create Quadric Clips

INTRODUCTION
In addition to standard clipping planes, EnSight also provides clipping against quadric shapes.  These clips use the 
corresponding quadric tool Cylinder, Sphere, Cone, Surface of Revolution) to specify the location of the clip.

As with clip planes, these tools can also be used to perform cut operations, creating parts which are the “inside” or 
“outside” of the parent domain. 

As with intersection clip planes, quadric clips can be changed interactively by manipulating the corresponding tool 
with the mouse.

BASIC OPERATION

ADVANCED USAGE
Like the other clipping tools in EnSight, intersection quadric clips (except those created with the revolution tool) can 
be interactive: as you drag the applicable tool with the mouse, the clip is automatically recalculated and redisplayed.  
To perform interactive quadric clips:

1. Select the parent part.

2. Click the Clip icon.

5. Click Create.

3. Select the desired quadric tool from the 
Use Tool pulldown. 

4. Position the tool as desired (see the How 
to for the applicable tool).

1. Double-click the desired 
quadric clip part in the parts 
list.

2. Toggle on Interactive Tool in 
the Quick Interaction area.

3. Move the mouse into the 
Graphics Window.  Click on 
one of the tool hotpoints (see 
the How to for the applicable tool) 
and drag the tool to the desired 
location.
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Cutting with Quadric Tools
A quadric tool can be used to create parts which are the result of a cut of its parent domain into “inside” and or 
“outside” parts. These parts contain valid elements of the same order as the original domain parts.

Crinkly Quadric Clips
You can check the integrity of your mesh by clipping with a crinkly intersection. Specifying a Crinkly Domain results in 
a part composed of all the elements of the mesh that intersect the quadric tool.

SEE ALSO
Introduction to Part Creation

How To Use the {Cylinder, Sphere, Cone, Surface of Revolution} Tool. 

Other clips:
How to Create Clip Planes
How to Create Clip Lines
How to Create IJK Clips
How to Create XYZ Clips
How to Create RTZ Clips
How to Create Box Clips.

User Manual: Clip Create/Update

1. Select  the desired parent 
parts in the parts list.

2. Click the Clip feature icon.

3. Select the desired Quadric 
Tool.

4. Set the Domain to Inside, 
Outside, or In/Out (both 
inside and outside).

5. Hit the Create button.

4. Change the Domain to 
Crinkly.

5. Click the Apply Tool Change 
button.
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Create IJK Clips

INTRODUCTION
An IJK clip is a 1D or 2D slice through a structured mesh.  The resulting clip is a 1D line or 2D surface where one 
dimension (e.g. I) is held fixed while the other one or two dimensions (e.g. J and K) vary.  The minimum and 
maximum range of the free dimensions can be set by the user, as well as the step size.  IJK clips can be animated 
throughout the range of the fixed dimension by manipulating a slider.

Although planar clips can still be created through structured meshes, it is often preferable to create IJK clips since 
they are faster to calculate and use less memory.  In addition, IJK clips are often more intuitive for the user (who 
typically built the mesh).

BASIC OPERATION

Note that you can change the fixed dimension of an IJK clip at any time (with the Mesh Slice pulldown).  If you change 
one of the numeric values, remember to press return for the change to take effect.

1. Select the parent part.

2. Click the Clip icon.

4. Select the desired fixed dimension from the 
Mesh Slice pulldown.

5. Enter the value for the fixed dimension in 
the Value text field and press return.

3. Select IJK from the Use Tool pulldown.

6. If you desire to modify values for the Min, 
Max, and Step for the two free 
dimensions, click this and the dialog 
below will open up.

7. Click Create.
Page 1 of 3



ADVANCED USAGE

Interactive IJK Clipping
You can interactively sweep through the range of the fixed dimension by adjusting a slider with the mouse.

Changing IJK Step Refinement
You can modify block-structured model parts to any level of IJK step refinement with proper updating of all dependent 
parts and variables.

Clipping Plane Animation
Although you can interactively sweep an IJK clip through a mesh, it is sometimes desirable to have EnSight 
automatically calculate a series of IJK clips for you.  These can then be replayed (as fast as your graphics hardware 
will permit) using EnSight’s Flipbook Animation facility.  See How To Create a Flipbook Animation for more 
information.

1. Double-click the desired IJK clip part 
in the parts list.

2. Change Interactive to Manual, to 
enable sweeping.

3. Adjust the slider with the mouse.

1. Select Edit > Part Feature Detail 
Editors > Model Parts ...  to open the 
Feature Detail Editor (Model) dialog.

2. Select the structured part (or parts).

3. In the Creation Attributes area, enter 
values into the From, To, and Step 
fields based on their Min and Max 
limits to update the refinement of the 
respective I, J, and/or K mesh 
component directions (remember to 
press Return).
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SEE ALSO
Introduction to Part Creation
How To Create a Flipbook Animation.

Other clips:
How to Create Clip Lines
How to Create Clip Planes
How to Create Quadric Clips
How to Create XYZ Clips
How to Create RTZ Clips
How to Create Box Clips.    

User Manual: Clip Create/Update
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Create XYZ Clips

INTRODUCTION
An XYZ clip is a 1D or 2D slice through 2D or 3D meshes (structured or unstructured).  The resulting clip is a 1D or 
2D mesh slice where one of the dimensions (e.g.  X) is held constant (or fixed) while the other one or two dimensions 
(e.g.  Y and Z) vary in reference to the local frame of the mesh.   XYZ clips can be interactively animated throughout 
the range of the fixed dimension by manipulating a slider. The minimum, maximum, and step size of the  range of the 
interactive fixed dimension can be set by the user. 

BASIC OPERATION

Note that you can change the fixed dimension of an XYZ clip at any time (with the Mesh Slice pulldown).  If you 
change the numeric value, remember to press return for the change to take effect.

1. Select the parent part.

2. Click the Clip icon.

4. Select the desired fixed dimension from the 
Mesh Slice pulldown.

5. Enter the value for the fixed dimension in 
the Value text field and press return.

3. Select XYZ from the Use Tool pulldown.

6. Click Create.

Note: Multiple slices with a delta in the normal direction can be created easily by setting these values.
Page 1 of 2



ADVANCED USAGE

Interactive XYZ Clipping
You can interactively sweep through the range of the fixed dimension by adjusting a slider with the mouse.

Crinkly XYZ Clipping
You can check the integrity of your mesh by clipping with a crinkly intersection. Specifying a crinkly domain results in 
a part composed of all the elements that intersect the mesh slice value.

Clipping Plane Animation
Although you can interactively sweep an XYZ clip through a mesh, it is sometimes desirable to have EnSight 
automatically calculate a series of XYZ clips for you.  These can then be replayed (as fast as your graphics hardware 
will permit) using EnSight’s Flipbook Animation facility.  See How To Create a Flipbook Animation for more 
information.

SEE ALSO
Introduction to Part Creation
How To Create a Flipbook Animation

Other clips:
How to Create Clip Lines
How to Create Clip Planes
How to Create Quadric Clips
How to Create IJK Clips
How to Create RTZ Clips
How to Create Box Clips.    

User Manual: Clip Create/Update

1. Double-click the desired XYZ clip 
part in the main parts list.

2. Change Interactive to Manual to 
enable sweeping.

3. If desired, enter values for the Min, 
Max, and Increment to override the 
defaults (remember to press return).

4. Adjust the slider with the mouse.

1. Change the Domain to Crinkly
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Create RTZ Clips

INTRODUCTION
An RTZ clip is a 1D or 2D slice through 2D or 3D meshes (structured or unstructured). The resulting clip is a 1D or 2D 
mesh slice where one of the dimensions (e.g. R,”radial component”) is held constant (or fixed) while the other one or 
two dimensions (e.g.  T, ”theta component” and Z, “z axis component”) vary in reference to the local frame of the 
mesh.   RTZ clips can be interactively animated throughout the range of the fixed dimension by manipulating a slider. 
The minimum, maximum, and step size of the range of the interactive fixed dimension can be set by the user.

BASIC OPERATION

Note that you can change the fixed dimension of an RTZ clip at any time (with the Slice pulldown). If you change the 
numeric value, remember to press return for the change to take effect.

ADVANCED USAGE

Interactive RTZ Clipping
You can interactively sweep through the range of the fixed dimension by adjusting a slider with the mouse.

1. Select the parent part.

2. Click the Clip icon.
3. Select RTZ from the Use Tool pulldown
4. Select the Axis that describes the 

cylindrical length.
5. Select the desired fixed dimension of the 

slice (R, T, or Z).
6. Enter the value for the slice (the value of 

R, T, or Z), and press return.

7. Click Create.

1. Double-click the desired RTZ clip 
part in the main parts list.

2. Change Interactive to Manual to 
enable sweeping.

3. If desired, enter values for the Min, 
Max, and Increment to override the 
defaults (remember to press return).

4. Adjust the slider with the mouse.
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Crinkly RTZ Clipping
You can check the integrity of your mesh by clipping with a crinkly intersection. Specifying a crinkly domain results in 
a part composed of all the elements that intersect the mesh slice value. Crinkly clipping cannot be done interactively.

Clipping Plane Animation
Although you can interactively sweep an RTZ clip through a mesh, it is sometimes desirable to have EnSight 
automatically calculate a series of RTZ clips for you. These can then be replayed (as fast as your graphics hardware 
will permit) using EnSight’s Flipbook Animation facility. See How To Create a Flipbook Animation for more 
information.

OTHER NOTES
Inside, Outside, and In/Out cutting are disabled for this clipping type because it has no meaning for T. And if you 
desire this effect for Z or R, you can use a plane clip or cylindrical clip instead.

SEE ALSO
Introduction to Part Creation
How To Create a Flipbook Animation

Other clips:
How to Create Clip Lines
How to Create Clip Planes
How to Create Quadric Clips
How to Create IJK Clips
How to Create XYZ Clips
How to Create Box Clips.    

User Manual: Clip Create/Update

1. Change the Domain to Crinkly
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Create Revolution Tool Clips

INTRODUCTION
A Revolution Tool clip can be made using the surface of revolution tool. It can be the surface created by the 
intersection of the surface of revolution tool and the model, the elements intersected by the surface of revolution tool 
(crinkly), or the volume of the inside and/or the outside domain swept by the revolution tool. This clip does not have 
interactive manipulation capability, with a slider or by dragging the tool with the mouse. However, the tool can be 
manipulated and the clip updated.

BASIC OPERATION

ADVANCED USAGE

SEE ALSO
Introduction to Part Creation

Other clips:
How to Create Clip Lines
How to Create Clip Planes
How to Create Quadric Clips
How to Create XYZ Clips
How to Create RTZ Clips
How to Create Box Clips
How to Create IJK Clips
How to Create Revolution of 1D Part Clips.    

User Manual: Clip Create/Update

1. Place the Surface of Revolution Tool at the 
desired location. See How To Use the 
Surface of Revolution Tool.

2. Select the parent part.
3. Click the Clip icon.
4. Select Revolution Tool from the Use Tool 

pulldown.
5. Select the desired Domain.

6. Click Create.

Note that you can manipulate the Surface 
of Revolution tool and update your clip by 
and clicking Apply Tool Change.

You can also change the domain, and the 
clip will change.
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Create Revolution of 1D Part Clips

INTRODUCTION
A Revolution of 1D Part clip can be made using a 1D part and a user specified axis. It can be the surface created by 
the intersection of the 1D part about the axis and the model, the elements intersected by the 1D part about the 
axis(crinkly), or the volume of the inside and/or the outside domain swept by the 1D part about the axis. This clip does 
not have interactive manipulation capability, with a slider or by dragging the tool with the mouse. However, if the 1D 
part is capable of being moved, you can move it and the revolution clip will update.

BASIC OPERATION

ADVANCED USAGE

SEE ALSO
Introduction to Part Creation

Other clips:
How to Create Clip Lines
How to Create Clip Planes
How to Create Quadric Clips
How to Create XYZ Clips
How to Create RTZ Clips
How to Create Box Clips
How to Create IJK Clips
How to Create Revolution Tool Clips.    

User Manual: Clip Create/Update

1. Select the parent part.
2. Click the Clip Icon.
3. Select Revolve 1D Part from the Use Tool 

pulldown.
4. Enter the 1D part to use.
5. Set the desired origin and axis of the 

revolution.
6. Select the desired Domain.

6. Click Create.

Note that you can manipulate the 1D part 
or the origin and axis and the clip will 
update.

You can also change the domain, and the 
clip will change.



Create General Quadric Clips

INTRODUCTION
Double Clicking on the Clip Create/Update Icon brings up the Feature Detail Editor (Clips), the Creation attributes 
section of which offers access to one type of clip creation which is not available in the Quick Interaction area. It is 
possible to create a 3D Quadric clip using the General Quadric option by directly specifying the coefficients of a 
general quadric equation.

These coefficient values represent the general equation of a Quadric surface. They can be changed by modifying the 
coefficient values. No tool exists corresponding to this equation.

                                                     AX2+BY2+CZ2+DXY+EYZ+FXZ+GX+HY+IZ=J

BASIC OPERATION

1. Get to the Feature Detail Editor for clips.  
The easiest way to do this is to double click 
the Clip Feature Icon.

2. Select the parent part(s) in the Parts list.

3. Choose the General Quadric Tool.
4. Choose the desired Domain (Intersect, 

Crinkly, Inside, Outside, or In/Out)

5. Edit the coefficients.

3. Click the Create button.

Note:  The Animation Delta is not available for 
general quadric clips.
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SEE ALSO
Introduction to Part Creation

Other clips:
How to Create Clip Lines
How to Create Clip Planes
How to Create Quadric Clips
How to Create XYZ Clips
How to Create RTZ Clips
How to Create Box Clips
How to Create IJK Clips
How to Create Revolution Tool Clips.    

User Manual: Clip Create/Update
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Create Vector Arrows

INTRODUCTION
Vector arrows display the direction and magnitude of a vector at discrete locations in a model.  Although vector 
magnitude can be visualized with other methods (e.g. color), important directional information is provided by the 
arrows.

Vector arrows have numerous attributes including length scale, tip style and size, projection, origin location, and 
display filters based on vector magnitude.

BASIC OPERATION

Arrow Tips
To change the arrow tip shape, click the Arrow Tips button to open the Vector Arrow Tip Settings dialog:

1. Select the parent. 
part.

3. Select the vector variable to use.

2. Click the Vector Arrows icon.

4. Click Get Default to load a suitable Scale Factor.

5. Click “Create”.

Tip Shape Choices:

None No tip (default).

Cone Solid cone shape

Normal Single wedge.  Good for 2D 
problems.  Plane of the 
wedge is based on the 
relative magnitudes of the 
components.

Triangles Two intersecting triangles.  
Good for 2D/3D problems.

Tipped End of the shaft colored in a 
different color.  Good where 
other shapes yield too much 
visual clutter.

1. Select the desired tip shape from the 
Shape pulldown (see description at right).

2. Select a color (for Tipped shape only).

3. From the Size pulldown, select whether tip 
scaling is Fixed (and enter an appropriate 
value in the text field) or Proportional to the 
local vector magnitude.
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Other Vector Arrow Attributes
Other vector arrow attributes control the type of arrow, the location of the arrow origin, and arrow filtering options 
based on vector magnitude:

1. Double-click the desired vector arrow part in the parts list.

2. Select the desired type from the Type pulldown.
Choices are:

Rectilinear Standard vector arrows: shaft points in local vector direction with 
length equal to vector magnitude scaled by Scale Factor Value.

Rect. Fixed Same as Rectilinear except that length is set by Scale Factor value 
independent of vector magnitude.

Curved Arrow shaft is the path of a particle trace in the local flow field.  Scale 
Factor becomes “Time” and controls the duration (stopping criteria) 
for each trace.  WARNING!  This can take a great deal of time for 
large numbers of vector arrows and/or long Time values! 

3. Select the desired filter type from the Filter 
pulldown.

Choices are:

None No filtering – all vector arrows appear.

Low Display only those arrows with magnitude 
above the value in the Low text field.

Band Display only those arrows with magnitude 
below Low and above High (opposite of Low/
High).

High Display only those arrows with magnitude 
below the value in the High text field.

Low/High Display only those arrows with magnitude 
between Low and High (opposite of Band).

5. Select the desired arrow origin from the 
Location pulldown.

Choices are:

Node Arrows originate from each node of the parent 
part(s).

Vertices Arrows originate only from those nodes that 
are also vertices of the parent part(s).

Element Center    Arrows originate from the geometric center 
of all elements of the parent part(s).

4. Select the desired density (0.0 to 1.0).
A density of the arrows will vary from no arrows (0.0) to 
arrows at every location (1.0).  At intermediate densities 
the arrows are placed randomly.
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ADVANCED USAGE
Although not accessible from the Vector Arrows Quick Interaction area, you can also change the projection of vector 
arrows and the display offset.

OTHER NOTES
Vector arrows can be animated by animating the parent part (e.g. a clip plane) over space or time using flipbook or 
keyframe animation.  See How To Create a Flipbook Animation or How to Create a Keyframe Animation for 
more information.

If vector arrows are created on a clip through an unstructured mesh, the resulting arrows can be difficult to visualize if 
the resolution of the underlying mesh varies substantially or is highly irregular.  One solution is to create the vector 
arrows on a grid clip rather than the default mesh clip.  See How to Create Clip Planes for more information.

1. Open the Feature Detail Editor for Vector 
Arrows (Edit > Part Detail Editors... > Vector 
Arrows).

2. Select the desired vector arrow part.

3. Select the desired projection type from the 
Projection pulldown.

The projection choices are modified by the settings 
in the Projection components X,Y,Z numeric fields.  
These values represent a scaling factor for the 
component.  Zero means that the component 
should not be considered (and therefore confine the 
arrows to the plane perpendicular to that axis).  One 
is the default setting; values less than 1 diminish the 
contribution of the component while values greater 
than 1 exaggerate the contribution.

Choices for Projection are:

All Display arrows based on the vector direction 
as modified by the Projection Component 
values.

Normal Display arrows based on the “All” vector but 
in the direction of the surface normal at the 
arrow origin.

Tangential Display arrows based on the “All” vector but 
projected tangential to the surface at the 
arrow origin.  This is good for locating flow 
components perpendicular to the main flow 
direction (such as vortices).

Component Display both the Normal and the Tangential 
arrows.

4. Set the desired display offset.
The display offset is used to displace the vector arrows a 
short distance away from the surface on which they are 
defined (typically for hardcopy or animation purposes).  This 
is typically necessary when a tangential projection is used 
and the arrows are coincident with the parent part’s surface.  
Note that a negative offset may be appropriate (depending on 
orientation).
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Unlike most part creation operators, vector arrows are created from the client’s representation of the part – not the 
server’s.  For example, if you have a clip plane that is displayed using a feature-angle or border representation, only 
those elements comprising the reduced display will yield vector arrows – even though all elements of the clip plane 
reside on the server.  See How to Change Visual Representation for more information.

Vector arrows with a tangential projection can sometimes by occluded by the surface on which the arrows are 
defined.  To solve this problem, use the Display Offset field to add a small displacement to move the arrows away 
from the surface.  This is most useful for presentation (e.g. hardcopy or animation) output.

SEE ALSO
Introduction to Part Creation.

User Manual: Vector Arrow Create/Update
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Create Elevated Surfaces

INTRODUCTION
An Elevated Surface is a 2D surface scaled (in the direction of the local surface normal of the parent part) based on 
the value of a variable. Elevated surfaces resemble topographic maps and are useful for accentuating relative 
differences in the value of a variable.

BASIC OPERATION

SEE ALSO
User Manual: Elevated Surface Create/Update

1. Select the parent part.

3. Select the variable to use.

2. Click the elevated surface creation icon.

4. Select an appropriate scale factor 
(or click the Get Default button).

7. Click “Create”.

5. If desired, enter an Offset value and press return.
The Offset allows you to “shift” the elevated surface 
away from the parent, but does not affect the shape.

6. If desired, toggle Surface or Sidewalls off.
The Surface is the actual elevated surface.  You can 
also have Sidewalls which stretch from the border of 
the parent to the border of the Surface to enclose the 
created part.
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Create Profile Plots

INTRODUCTION
A profile plot is the 2D counterpart to an elevated surface: a projection away from a 1D part based on the value of a 
variable.  Profile plots can be created on any 1D part: clip lines, contours, particle traces, or model parts consisting 
of 1D elements.

BASIC OPERATION

For each node of the parent part, the corresponding node on the profile curve is determined by adding the value of 
the Offset to the selected variable and then multiplying the sum by the Scale Factor.  The projectors of the profile are 
the lines that connect the nodes of the parent part to the nodes of the profile curve.  The Plane tool is used to specify 
the orientation and direction of the projectors.  The projectors are created parallel to the Plane tool projecting away 
from the center of the Plane tool (at least where the value of the selected variable plus the Offset is positive).

Although the parent part of a profile plot must be 1D, the nodes that make up the part do not have to be linear.  For 
curved parents, the projectors of the resulting profile plot are still parallel, but they do not all lie in the same plane.

SEE ALSO
User Manual: Profile Create/Update

1. Select the parent part.

3. Select the variable to use.

2. Click the profile creation icon.

4. Select an appropriate Scale Factor (or click 
Get Default).

7. Click “Create”.

5. If desired, enter an Offset value and press return.
The Offset allows you to “shift” the profile away from the 
parent, but does not effect the shape.

6. If desired, adjust the orientation of the Plane tool.
The Plane Tool is used to specify the orientation and 
direction of the profile plot.  See below for more 
information.
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Create Developed (Unrolled) Surfaces

INTRODUCTION
EnSight provides several sophisticated tools for extracting computational surfaces from meshes.  For clipped 
surfaces with a defined axis of rotation (such as those created with the quadric clipping tools), the surface can 
“developed” or unrolled onto a plane.  All variables defined on the clip are properly interpolated onto to the developed 
surface.

A clip can be developed based on curvilinear (radius, z), (theta, z), or (meridian, theta) coordinate projections.  The 
“seam” of the clip can be specified interactively.

BASIC OPERATION
To create a developed surface:

A part is developed by specifying one of three curvilinear mappings called developed projections. The projections are 
based on the curvilinear coordinates r (radius), z, θ (theta), and m (meridian or longitude). These coordinates are 
defined relative to the local origin and axis of the tool that created the parent part (e.g. the Cylinder tool). The 
projections are (r,z), (θ, z), and (m, θ). The u, v scale factors (only for (θ, z) or (m, θ) projections) provide scaling for 
the coordinates in the listed order. For example, if the projection is (θ, z) then u scales θ and v scales z.

SEE ALSO
How To Create Quadric Clips

User Manual: Developed Surface Create/Update

1. First, create the desired quadric clip (cylinder, sphere, or cone).

3. Click the Developed 
Surface icon.4. Select the desired projection type (see 

below for details on the types).

5. If applicable for the projection type (and desired) 
enter u,v scaling factors and press return).

6. To display and change the cutting seam, click the 
Show Cutting Seam button, and adjust the slider.

7. Click Create.

2. Select the parent part for the 
developed surface (i.e. the part 
you created in step 1).
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Create Subset Parts

INTRODUCTION
A Subset Part can be created by specifying node and/or element label ranges of a model part. Subset Parts can only 
be created from model parts that have node and/or element labels. The Subset Part feature can be used to isolate 
specified nodal and element regions of interest in large data sets.

BASIC OPERATION

SEE ALSO
 User Manual: Subset Parts Create/Update

1. First, click the Subset Parts creation icon.

2. Now, for each parent model part, 
    enter the part number of the 
    desired parent part in the Add field 
    and press return.

3. Select Elements (or Nodes) to Show.

4. Enter the element (or node) label range(s) in 
the Show List text field (ranges are separated 
by commas).

OR
Toggle on “Pick elements” and select 
elements using pick selection, which by 
default is the “p” keyboard key.

OR
Turn on the selection tool and place it where 
desired, then click “Add elements from 
selection tool” to pick all the elements within 
the tool.

5. Click Create



Create Tensor Glyphs

INTRODUCTION
Tensor glyphs display the direction of the eigenvectors for a tensor variable. Controls exist to show just the 
compressive or tensile eigenvectors, and to selectively show the minor, middle, or major vectors.

Tensor glyphs have numerous attributes including length scale, tips, color, and line width which can be used to 
indicate compression or tension.

BASIC OPERATION

1. Select the parent 
parts.

2. Click the Tensor Glyph icon (by default this icon is 
not displayed unless you have enabled it through 
Edit > Preferences > General User Interface  
“Modify and save icon layout”).

3. Select the tensor 
variable to use.

4. Select which 
eigenvectors to display.

5. Click Create.

Display Attributes
The glyph’s attributes to indicate tension or compression can be modified in several ways.  Click the Display 
Attributes button to open the Tensor Display Attributes dialog:

2. The glyph can either be colored by 
the part color, or show a specified 
color for compressions and tension.

1. Select the desired tip shape from the Tip Shape pulldown.

Tip Shape Choices:

None No tip (default)

Normal Single wedge.  Good for 2D problems.  
Plane of the wedge is based on the 
relative magnitudes of the components.

Triangles Two intersecting triangles. Good for 2D/
3D problems.

3. The glyph can either be shown with the line width attribute of the glyph, 
or show a different line width for tension and compression.
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OTHER NOTES
Tensor glyphs can be animated by animating the parent part (e.g. a clip plane) over space or time using flipbook or 
keyframe animation.  See How To Create Flipbook Animation or How to Create a Keyframe Animation for more 
information.

Unlike most part creation operators, tensor glyphs are created from the client’s representation of the part - not the 
server’s.  For example, if you have a clip plane that is displayed using a feature angle or border representation, only 
those elements comprising the reduced display will yield tensor glyphs - even though all elements of the clip plane 
reside on the server.  See How to Change Visual Representation for more information.

SEE ALSO
Introduction to Part Creation.

User Manual:  Tensor Glyph Parts Create/Update
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Display Displacements

INTRODUCTION
In structural mechanics simulations, a common output variable is a set of vectors representing the movement or 
displacement of geometry.  Each displacement vector specifies a translation of a node from its original position (an 
offset).  EnSight can display and animate these displacements to help visualize the relative motion of geometry.

In many cases, the magnitude of the actual displacements is extremely small relative to the size of the model.  
EnSight provides a displacement factor to scale the vectors and exaggerate the displacement.

BASIC OPERATION

Note that your changes in the Quick Interaction area are immediate.  Specifying a displacement does not create a 
new part, it merely sets the displacement attributes for the selected parts.

1. Select the parent parts.

2. Click the Part tab.

4. Select the variable to use.

3. Click the displacement 
creation icon.

5. If desired, enter a value for the 
Displacement Factor and press 
return.
Page 1 of 2



ADVANCED USAGE
Vibrational analysis typically produces eigenvectors.  EnSight can animate these vectors as mode shapes to 
visualize selected vibration modes (each represented by a different displacement vector).  The EnSight Flipbook is 
used to build and load the animation.  Once loaded, the animation can be replayed while still providing viewing 
control.  To create a mode shape flipbook:

The first page of the animation shows the full displacement (as it is shown in the Graphics Window without the 
Flipbook) while the last page shows full displacement in the opposite direction.  Intermediate pages show 
displacements as driven by the cosine function.

Note that you can create copies or extracts of parts and simultaneously display them with different mode shape 
variables or to show the initial static state along with the mode shape animation.

SEE ALSO
See How To Create a Flipbook Animation for more information on Flipbooks.

User Manual: Part Displacement, Flipbook Animation

1. Be sure displacements are active 
and the Displacement Factor is set 
to a suitable value (as described 
above).

2. Click the Flipbook icon.

3. Select Mode Shapes from 
the Load Type pulldown.

4. Enter the desired number of 
Flipbook pages to create.

5. Click “Load”.

6. Once loading is complete it will 
automatically change to the Run 
tab and the animation will be 
running.
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Display Discrete or Experimental Data

INTRODUCTION
In addition to meshed data consisting of nodes and elements, EnSight also supports discrete or measured data.  A 
measured dataset consists of a series of arbitrary points in space with no connectivity.  Measured data can have 
associated variable data and can vary over time.  Examples of measured data include fuel sprays, multi-phase flows, 
and experimental data.

Measured data cannot be loaded by itself – you must also specify a regular geometric mesh.  

BASIC OPERATION
Measured data is read into EnSight via the same dialog used to read meshed data:

1. Select File > Data (Reader)... to open the File Selection dialog for data file selection.

2. Find the directory containing the 
data (see How To Read Data for 
more information on using File 
Selection).

3.  If desired, select and specify a 
(meshed) geometry file and the 
corresponding result file.

4. Select the measured result file in 
the Files list.

5. If desired, specify an initial time 
step (the last step is the default).

6. If you are reading a meshed 
dataset (as directed in step 3), 
select the file format.

7. Click (Set) Measured to specify 
the selected measured result file.

8. Click Okay to begin the reading 
process.

9. The Data Part Loader dialog 
corresponding to the selected data file 
format (as set in step 6) will open.  You do not have to perform any further action to load the 
measured data.  However, if you are also loading meshed data, continue with the usual part loading 
process.  For details, see the How To article for the chosen file format.
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Measured data is represented as a single part.  In the Main Parts list you should see a part named “Measured/
Particle” after loading.

Measured data is represented as a set of unconnected nodes.  You can use EnSight’s ability to display nodes in 
various ways to accentuate measured data visualization.  To change node display:

OTHER NOTES
The file formats for measured data and the measured results file are detailed in EnSight5 Measured/Particle File 
Format.

Transient measured data can be animated using either the flipbook or keyframe animation capability.

You can load multiple measured datasets simultaneously by using EnSight’s cases capability.

SEE ALSO
User Manual: EnSight5 Measured/Particle File Format

1. Select the desired measured data part in the 
Main Parts list.

2. Click Part in the Mode Selection area to enter 
Part Mode.

3. Click the Node Representation icon to open 
the Part Node Representation dialog.

4. Select the desired node display type (Dot, 
Cross, or Sphere).  See below for details on 
each type.

5. If applicable, set desired values for Scale, 
Detail, Size By, and Variable.

• Dot: nodes are displayed as points.

• Cross: nodes are displayed as crosses and can be 
fixed size (size set by the Scale value) or sized 
based on a Variable (and scaled by the Scale 
value).

• Sphere: nodes are displayed as spheres and can 
be fixed size (size set by the Scale value) or sized 
based on a Variable (and scaled by the Scale 
value).  Sphere detail controlled by Detail value.
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Change Time Steps

INTRODUCTION
From it’s inception, EnSight has been used extensively to postprocess time-varying or transient data.  In many cases, 
dynamic phenomena can only be understood through interactive exploration.  The Solution Time Quick Interaction 
area provides the interface for working with transient data and provides comprehensive control over time handling.

BASIC OPERATION
EnSight provides two ways to work with transient data.  By default, time is presented as a series of discrete steps 
running from zero to the total number of steps minus one.  However, you can also present time based on the actual 
simulation time values found in your results data.  The presentation mode is controlled by the Time As pulldown 
menu.  In the dialog below, Time As is set to Step and time is presented as discrete steps running from 0 to 159 (160 
total steps).  The simulation time (as reported in the top line of the dialog) runs from 1.0 to 160.0.

The current time range is displayed in the Beg and End fields with the current time step shown in the Cur field.  You 
can modify the time range displayed in the slider by editing the Beg and/or End fields (remember to press return).  
You can change the current time step by editing the Cur field (press return), manipulating the slider, or clicking the 
left/right slider arrows.  Clicking Reset Time Range will reset Beg and End to the full range.

Time scaling and stepping (as manipulated through the slider bar and Beg, Cur, and End fields) can either be 
Discrete or Continuous. If scaling is Discrete, only your actual time steps as written in the results data can be 
visualized. In addition, the Beg, Cur, and End fields can only be set to integer values (if Time As is set to Step and 
Scale Type is Discrete) or actual simulation times represented in your results data (if Time As is set to Sim. Time). If 
scaling is Continuous, you can display results between your actual output time steps (all variable values are linearly 
interpolated between the two surrounding time steps). Note that if your mesh is changing over time (either set of 
elements or element connectivity) you cannot display results continuously.

When you manipulate the slider or change the Cur field, EnSight will perform all tasks necessary to correctly display 
the new time step in the Graphics Window.  Depending on the size of the dataset and the number of additional parts 
you have created, this may take a significant amount of time.  If you wish to create an on-screen animation of your 
results, use the Flipbook facility (click Animate Over Time to quickly jump to the Flipbook Quick Interaction area).

To use the Solution Time Quick Interaction area:

1. Click the Solution Time icon in the Feature 
Icon bar.

2. Make changes as desired.

The slider bar lets you step through time. Grab the slider and dial to 
the desired time or click the left/right slider arrows to increment (the 
increment can be set by changing the Increment field).

The Beg and End fields control the available 
time range (and also the range of the slider 
action). The range markers on the slider can 
be moved to set these values or you can 
enter new values into the fields and press 
return.

The Current field sets the current time step.  
Either move the center slider or enter a new 
value in the field and press return.

Click to display time as annotation in the 
graphics window.

Click to open the Flipbook Animation Quick 
Interaction area.

Set Scale Type to Discrete or Continuous 
(see above for details).

Set Units to Step or Sim. Time 
(see above for details).

Set the step increment size for the 
slider arrows.  Must be an integer 
if Scale Type is Discrete.

Set the number of time cycles in 
the time range.
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Recording an Animation of your data:

You can stream data from disk by using 
the VCR type controls.  Namely, hit the 
Play button.

While this is occuring, the Record button will be brightly colored red and can 
be clicked to record the animation that is occcuring.

Note: This is similar to a flipbook animation loaded as images, but 
does not require additional workstation memory. Thus, it is a 
simple way to record an animation of your transient data.

Available recording file formats are:

Apple PICT Flipbook files saved as sequence of Apple PICT files.

JPEG Flipbook files saved as sequence of JPEG files.

TIFF Flipbook files saved as sequence of TIFF files.

PCL Flipbook files saved as sequence of Page Control Language files.

PostScript Flipbook files saved as sequence of PostScript files.

Silicon Graphics RGB Flipbook files saved as sequence of SGI RGB files.

TARGA Flipbook files saved as sequence of TARGA files.

CEI RGB with depth Flipbook files saved as sequence of RGB files with depth.

EnVideo Flipbook files are saved to EnVideo file.

MPEG1 / MPEG2 Flipbook files are saved to an MPEG file.

AVI Flipbook files are saved to an AVI file.
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ADVANCED USAGE
EnSight allows geometry and variables to behave in a transient manner on different timelines, i.e., a variable called 
Temperature can be defined at t = 0., 3., and 6. while a variable called Pressure can be defined at t = 0., 2., and 5.5.  
The Timeset Details button will bring up the Timeset Details dialog which allows the user to view the various timelines 
as well as specify how the variables will behave when they are not defined.

The EnSight case file defines the timesets (name and associated time values) and associates a timeset with each of 
the variables and geometry.

By default the Solution Time dialog will show a composite of all of the timesteps that exist across all of the timesets.  
This can, however be changed to show just the time values associated with a particular timeset.

In the Timeset Details dialog shown below, multiple timesets exists. Three timesets (from the Which Timeset(s) list) 
are selected and are thus shown in detail.  The graphics for each timeset shows (a) the minimum and maximum 
overall time value, (b) white tick marks immediately under the timeline indicate the total (composite) time values 
available from the solution time dialog, (c) green tick marks indicating the time values defined for the timeset, (d) the 
current time value (indicated with the long green line) associated with the timeset. 

SEE ALSO
How To Load Transient Data, How To Animate Transient Data

User Manual: Flipbook Animation

The current solution time (as 
set in the Solution Time dialog.

Select the timeline to be 
viewed.

To modify all the timelines to 
behave the same way, select 
which range is to be modified, 
then select how they will be 
displayed.

The timeset can either be 
shown having a time range 
over the total number of time 
values or can be shown 
according to the timeset’s 
range.

By default the Solution 
Time dialog shows the 
composite timeline.  
This button will modify 
the Solution Time 
dialog’s Beg and End 
values to those of the 
selected timeset.

Shows the time value being 
used at the current time.

The timeset is used by the 
variables (or geometry) 
shown in this list.

When the current time (from the 
Solution Time dialog and indicated 
in the upper left corner of this 
dialog) is set to a value less than 
what is available for this timeline, 
use the Nearest value or make the 
variable Undefined.

When the current time (from the 
Solution Time dialog and indicated 
in the upper left corner of this 
dialog) is set to a value that does 
not exist for this timeline, 
Interpolate between defined time 
values, use the Left, Right, or 
Nearest value, or make the 
variable Undefined.

When the current time (from the 
Solution Time dialog and indicated in 
the upper left corner of this dialog) is 
set to a value greater than what is 
available for this timeline, use the 
Nearest value or make the variable 
Undefined.
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Extract Vortex Cores

INTRODUCTION
Vortex cores are centers of swirling flow where the velocity is parallel to the vorticity. For a more complete description 
refer to the User Manual section below.

BASIC OPERATION
1. Select the parent part. 2. Select the Vortex Core icon on the second row of icons.

3. Bring up the Vortex Core 
Variable Settings dialog by 
clicking here.

6. Click Create.

4. Define either (Density and 
Momentum) or Velocity, as well 
as the Ratio of Specific Heats.

The variables can be set by 
either typing them into the 
fields, or selecting them from 
the list above and clicking the 
Set button.

5. Click Okay to finish the 
variable setup.
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ADVANCED USAGE
The resulting vortex core lines can be filtered by the vortex core strength or by any other active variable.

OTHER NOTES
Extract Vortex Cores does not work with more than one case.

SEE ALSO
User Manual:  Vortex Core Create/Update

1. Select the variable to filter by.

2. Set the Threshold filter to remove the portion of 
the vortex core that is larger or less than the 
specified threshold value.

3. Enter a threshold value
          - or -
3. Slide the slider to a new threshold value.
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Extract Separation and Attachment Lines

INTRODUCTION
Separation and attachment lines are created on any 2D surface and show interfaces where flow abruptly leaves 
(separates) or returns (attaches) to the surface.   For a more complete description refer to the User Manual section 
below.

BASIC OPERATION
1. Select the 2D parent part.

2. Click the Separation/Attachment part 
icon.

4. Define either Density and 
Momentum or velocity, as 
well as the Ratio of Specific 
Heats.  

The variables can be set by 
either typing them into the 
fields or be selecting them 
from the list above and 
clicking the Set button.

5. Click Okay to finish the 
variable setup.

3. Bring up the dialog 
defining the necessary 
variables by clicking here.

6. Click Create

This will create two parts - 
one each for the separation 
and attachment lines.  You 
can modify the visual 
attributes of these parts 
separately, but when you 
change any creation 
attribute, both parts will be 
modified.
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ADVANCED USAGE

The resulting separation/attachment parts can be filtered by the fx_sep_att_strength variable or by any other active 
variable. 

OTHER NOTES
The separation and attachment parts are linked together with regard to their creation attributes, i.e. when one is 
modified the other is also. Further, when one is deleted the other is also deleted.

Separation and Attachment feature extraction only works with one case.

The separation and attachment line parts should generally not interfere visually with the 2D parent parts they lie on 
(as long as the preference for graphics hardware offset is on - see View Preferences), but they may interfere if 
printed. In either case you can apply a display offset manually to avoid the interference in the Feature Detail Editor for 
the part. The display offset will be in the direction of the parent surface normal.

SEE ALSO
User Manual:  Separation/Attachment Lines Create/Update

1. Select the variable to filter by.

2. Set the Threshold filter to remove the portion of the 
separation/attachment line that is larger or smaller than 
the specified threshold value.

3. Enter a threshold value
        - or -
3. Slide the slider to a new threshold value.
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Extract Shock Surfaces

INTRODUCTION
Shock surfaces and regions help visualize shock waves in 3D (trans/super-sonic) flow. For a more complete 
description, refer to the User Manual section below.

BASIC OPERATION
1. Select the parent part.

2. Click the Shock Surface/Region icon.

3. Bring up the dialog defining 
the necessary variables by 
clicking here.

6. Choose Region or
 Surface.

7. Click Create.

4. Define either Density 
or (Temperature and 
Pressure), (Energy or 
Pressure), (Momentum or 
Velocity), and Ratio of 
Specific Heats.

The variables can be set 
by either typing them into 
the fields, or selecting 
them from the list and 
clicking the Set button.

5. Click Okay to finish the 
variable setup.
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ADVANCED USAGE
The resulting shock can be filtered by any of the threshold variables

OTHER NOTES
See Other Notes in the Shock Surface/Region Create/Update section of the User Manual for options on how to pre-
filter flow field regions, and/or post-filter shock regions via a specified mach number. Also to apply the transient 
correction term for moving shocks when using the shock Region method.

Shock Surface feature extraction does not work with multiple cases.

SEE ALSO
User Manual:  Shock Surface/Region Create/Update

1. Select the variable to filter by.

2. Set the Threshold filter to remove the portion of the shock 
surface or region that is greater or less than the specified 
threshold value.

3. Enter a threshold value
     - or -
3. Slide the slider to a new threshold value

4. The shock is usually defined in a very narrow band, so the 
slider min/max values may need to be adjusted by either 
entering new values in the min/max fields, or clicking on the 
up/down buttons to change by an order of magnitude.
Page 2 of 2



Create Material Parts

INTRODUCTION
A Material Part can be created as either a domain or an interface.
A material Domain is a solid region (or regions) composed of one or more specified materials.  Parts with 2D 
elements yield 2D material elements, and parts with 3D elements yield 3D material elements.
A material Interface is a boundary region (or regions) between adjacent materials composed of at least two or more 
specified materials.  Parts with 2D elements yield 1D material elements, and parts with 3D elements yield 2D material 
elements.
The Material Part feature can be used to isolate specified elemental regions of interest in data sets with material 
fractions.

BASIC OPERATION
For Material Domain:
1. Click the Material Parts creation icon.

2. Select the parent model part(s).
3. Set Type to Domain.
4. Select 1 or more materials.
5. Click Create.

For Material Interface:
1. Click the Material Parts creation Icon.

2. Select the parent model part(s).
3. Set Type to Interface.
4. Select 2 or more materials.
5. Click Create.
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ADVANCED USAGE
Increased Element Resolution

You can increase the element resolution of the Material Part by increasing the Subdivide option from Level 1 to either 
Level 2 or Level 3.  

Each 3D (or 2D) part element is first decomposed into tetrahedrons (or triangles) before it is processed.  Level 1 
simply processes each of these decomposed elements.  Level 2 subdivides each of these decomposed elements into 
3 sub-tetrahedrons (or sub-triangles).  Level 2 subdivides each of these decomposed elements into 6 sub-
tetrahedrons (or sub-triangles).  Each subdivided element is then processed.

SEE ALSO
User Manual: 
Material Parts Create/Update
In Section 11.1, EnSight Gold Casefile Format, see EnSight Gold Material Files Format
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Remove Failed Elements

INTRODUCTION
A variable can be used within EnSight as a means of removing elements that have “failed”.   This can be something 
as simple as a variable with two states (one state to indicate the element is failed, and the other state to indicate that 
the element is not failed), or it can be a variable of values (such as a Von Mises stress/strain) for which you specify 
limiting values and conditions for failure. The variable used must be a per-element variable.  Also, this operation can 
only be performed on model parts. So if its effect is desired on created parts, such as clip planes or isosurfaces, one 
should apply this operation to the model parent parts of the desired created parts.

BASIC OPERATION
To use a per-element variable for removing failed elements:

1. Select the model part(s) to use.

2. Select Part Mode.

3. Click on the Failed elements button.

4. Select the per-element variable to 
use for failure (in this example we use 
Failure_Stress).

5. Set the desired condition(s) and 
value(s) (in this case we fail if the 
Failure_Stress is greater than 0.70)

6. Click Apply

Those elements which satisfy the 
failure criteria will be removed from the 
model.
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ADVANCED USAGE
EnSight’s User-defined reader API is capable of dealing with designated failure variables and the failure values and 
conditions. Thus, a reader can be set up to use failure conditions that solvers provide and automatically apply the 
failed element operations for you. An example of this is the LS-DYNA3D reader provided with EnSight. 

SEE ALSO
How-To Read User Defined

User Manual:  Failed Elements 

Note the extra GUI option provided by this reader, 
entitled: “Remove Failed Elements”.

By checking this option, a “Delete_Flag” variable is 
created, and the failed element feature of EnSight will 
be automatically on - with the conditions and values set 
that will remove the failed elements that the solver 
flagged as such. (Which for LS-DYNA3D is a value 
equal to 0.0 in the Delete_Flag variable)
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Do Element Blanking

INTRODUCTION
EnSight allows you to pick elements in the model and make them disappear - “blank them out”. This may be desirable 
if you want to peek inside of certain parts or remove portions of a part (without making the entire part invisible or 
transparent).   Element blanking is a temporary state that can easily be “cleared” - making the elements visible again.

BASIC OPERATION
Using picking to do element blanking:

1. Place the mouse pointer over the element 
you wish to blank out and perform the 
picking action which does element blanking.

By default this action is double clicking of the 
right mouse button.

You will see the element under the mouse 
disappear as you do the picking.

2. To cause the elements to reappear, click 
the Element blanking/visibility icon and click 
the clear button in the dialog which comes 
up.

Note, in order for the element blanking to work, 
the Element blanking allowed toggle needs to 
be on (the default).

Note that the button and clicking action that 
performs the desired pick action is actually 
dependent upon the settings in Edit > 
Preferences > Mouse and Keyboard.

For example, given the settings shown, one 
could also set the pick action to “Pick element(s) 
to blank” and either use the keyboard “P” key or 
double clicking of the left mouse button.

Note the default for element blanking.
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The selection tool can be used to do element blanking on a larger scale:

SEE ALSO
How To Use Selection Tool

User Manual: Element Blanking

1. Select the part(s) on which to do element 
blanking.

2. Click on the Selection tool icon to turn on the 
tool.

3. Position the tool as desired.

4. Click on the element blanking symbol at the 
upper left of the tool.

Note, in order for this to work, the Element blanking 
allowed toggle needs to be on (the default).
To undo the blanking, click the Clear or Clear all 
parts button.

Results in the following:
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Create and Manipulate Variables
Activate Variables

INTRODUCTION
When a results dataset is read into EnSight, associated variables are noted and listed in the Main Variables List.  
However, a variable will remain deactivated (not loaded into memory) until some operation requires it or it is explicitly 
activated (read into memory).

If an active variable is no longer required, you can deactivate it and free the associated memory.

BASIC OPERATION

Variable Activation
In most instances, variables are automatically activated as required.  For example, if you create a contour using a 
deactivated variable, EnSight will automatically activate the variable prior to creating the contour.

You can also activate variables explicitly using the Feature Detail Editor for Variables.

1. Open the Feature Detail Editor for Variables.

You can open this dialog in several ways. You can 
do Edit > Variables editor... from the main menu

or

double click the Color/transparency icon in the Part 
mode icons

or

after single clicking the Color/transparency icon, you 
can double click on one of the variables in the list of 
the Part color, lighting, & transparency dialog.

2. Select the variable(s) you wish to activate.

3. Click the Activate button.

        OR

2. Click the Activate All button to 
activate all variables in the list.

The (*) in the variable listing indicates 
that the variable is currently loaded.
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Variable Deactivation
Variables are never deactivated automatically.  To deactivate a variable:

SEE ALSO
How To Edit Color Palettes, How To Create New Variables

User Manual: Variable Selection and Activation

1. Open the Feature Detail Editor for Variables.

You can open this dialog in several ways. You can 
do Edit > Variables editor... from the main menu, or 
double click the Color/transparency icon in the Part 
mode icons, or after single clicking the Color/
transparency icon, you can double click on one of 
the variables in the list of the Part color, lighting, & 
transparency dialog.

2. Select the variable(s) you wish to deactivate.

3. Click the Deactivate button.

Note that variable deactivation can result in the modification or deletion of parts.  If this is the case, you will be 
asked to confirm the deactivation.  A part could be modified if it used the deactivated variable for coloring.  A part 
could be deleted if it was based on the deactivated variable (such as a contour or an isosurface).
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Create New Variables

INTRODUCTION
EnSight provides a powerful capability to derive new variables from existing variables and parts.  For example, in a 
fluids dynamics problem, if you have momentum, density, and stagnation energy you can calculate temperature, 
Mach number, pressure, or velocity.  In addition to the built-in functions, you can also compose your own functions 
using the equation editor in conjunction with previously defined variables.

This article is divided into the following sections:

Introduction
Variable Creation
Examples of Expressions
Built-in Function Reference
Extended CFD Variables

BASIC OPERATION

Introduction
EnSight provides five distinct types of variables:

Variables are either given (read from the dataset or automatically provided by EnSight) or computed (derived from 
existing variables during an EnSight session). The variable type and whether it is given (shown as “Gvn”) or 
computed (shown as “Cmp”) are shown in the Variables list in the Feature Detail Editor for Variables. If you have any 
element-based variables in a model, the variable names in the Main Variables list will be preceded by “(E)” for 
element-based or “(N)” for node-based.

Every non-constant variable (both given as well as computed) has an associated color palette that defines the 
mapping from variable values to color.  These palettes can be edited to change the mapping (see How To Edit Color 
Maps for details).  The value of a constant variable can be displayed as a text string in the Graphics Window (see 
How To Create Text Annotation for details).

For time-dependent data, calculated variables will automatically recalculate when the current time step is changed.

Constant A constant variable is a single value.  Constants do not vary across a part 
although a constant can vary over time.  Examples include Analysis_Time, 
Temperature[123] (the value of temperature at node 123), Stress{3}[321] 
(the value of stress at node 321 at time step 3), or the value of a function 
that produces a constant (e.g. Area).

Scalar A scalar variable is a set of values: one for each node or element of the 
applicable part(s). Examples include Pressure, Velocity[Z] (the Z component 
of velocity), Stress{3} (the value of stress at time step 3), or the value of a 
function that produces a scalar (e.g.  Flow)

Vector A vector variable is a set of values: three (the X,Y,Z components) for each 
node or element of the applicable part(s).  Examples include Velocity, 
Velocity{3} (the value of velocity at time step 3), Coordinates (a given 
variable equal to the XYZ coordinate at a node), or the value of a function 
that produces a vector (e.g. Vorticity).

Tensor A tensor variable is a set of values: six (if symmetric) or nine (if asymmetric), 
for each node or element of the applicable part(s). Tensor variables can be 
represented by Tensor Glyphs directly, and within the variable calculator 
eigenvalues, eigenvectors, determinant, VonMises or Tresca, etc. can be 
computed.

Complex A complex variable, which within Ensight can be either scalar or vector, 
includes the real and imaginary portions of the values.  The variable 
calculator allows the user to compute things like modulus, argument, 
transient response, etc.
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Variable Creation
Derived variables are easily created using the Feature Detail Editor Variable Calculator. To create new variables:

1. Double-click the Variable Calculator icon in 
the Feature Icon bar to open the Feature Detail 
Editor (Calculator).

3. Select the desired function from the General 
list or the Math list.

When you select a function, the Variable Name field 
(at the top of the section) is loaded with the name of 
the function.  This will be the name of the variable as 
seen in the Main Variables list.  You can change this 
name by entering a new value (and pressing return).

A description of the function parameters appears in 
the feedback section, as well as instructions for 
properly composing the required parameters.

The expression is built in the Working Expression 
section.  As you insert parameters, they are 
automatically added to the expression and the 
instructions for the next parameter will appear.  
Parameters can be inserted as follows:

Parts: by selecting the desired part(s) in the Main 
Parts list (and clicking Okay) or by entering the part 
number directly in the Working Expression area. 
Note that the place holder “plist” appears in the 
expression denoting the list of currently selected 
parts.

Variables:  by clicking on the desired variable in the 
Active Variables list.

Constants/other: by typing the desired constant or 
other text directly into the Working Expression or by 
clicking the desired item in the Calculator keypad.

4. Follow the instructions to build the desired 
expression and then click Evaluate.
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Examples of Expressions
The following examples demonstrate usage of the variable calculator. In each case, first enter a name in the Variable 
Name field and click in the Working Expression area to activate it. The examples assume that Analysis_Time (a given 
constant variable if the dataset is transient), pressure, density, and velocity are all given variables.

Since EnSight can compute only one variable at a time, one must break down involved equations into multiple 
smaller ones, using temporary or intermediate variables.

Calculator limitations include the following:

1. The variable name cannot be used in the expression. The following is invalid:
temperature = temperature + 100

Instead use:
temperature2 = temperature + 100

2. The result of a function cannot be used in an expression.
(pressure / MAX(plist,pressure) )^2

Instead use two steps.  Define p_max as:
MAX(plist,pressure)

then define norm_press_sqr as:
(pressure / p_max)^2

3. Created parts (or changing geometry model parts) cannot be used with a time calculation (using { }).
4. Calculations occur only on server-based parts. Client-based parts are ignored, and variable values may be 

undefined.

Expression Description and How to Build

-13.5/3.5 A simple constant.
To build, either type the text on the keyboard or click in the Calculator keypad.

Analysis_Time/60.0 A constant variable.  Assuming the solution time was given in seconds, this expression will 
provide a variable giving the time in minutes.
To build, select Analysis_Time from the Active Variable list and either type or click  /60.0

velocity*density Momemtum – a vector variable.
To build, select velocity from the Active Variable list, click or type *, and select density 
from the Active Variable list.

SQRT(pressure[73]*2.5) 
+ velocity[X][73]

Square root of (pressure at node 73 * 2.5 + the X component of velocity at node 73)
To build, select SQRT from the Math function list, select pressure from the Active Variable 
list, click or type [73]*2.5)+, select velocity from the Active Variable list, and click or 
type [X][73].

pressure{19} Scalar variable equal to pressure at time 19.  This variable will not change if the current 
time step is changed.
To build, select pressure from the Active Variable list and click or type {19}.

MAX(plist, pressure) Constant variable equal to the maximum value for pressure over all nodes of all parts in 
plist.
To build, select MAX from the General function list and follow the instructions in the Feedback 
area.

(pressure/max_pres)^2 Scalar variable equal to squared normalized pressure.
To build, first calculate the MAX constant variable as described in the preceding example 
(here named max_pres). Click or type (, select pressure from the Active Variable list, click 
or type /, select max_pres from the Active Variable list, and click or type )^2.
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Built-in Function Reference
Although all built-in functions are listed here, consult the User Manual for the complete definition of a function. 
EnSight provides the following built-in general variable calculation functions:

Function Abbreviation (if 
any)

Description

Area Surface area
Boundary Layer Cf at Wall BL_CfWall Boundary Layer Cf at the wall

Displacement 
Thickness

BL_DispThick Boundary Layer displacement thickness

Distance to 
Value from Wall

BL_DistToValue Boundary Layer distance to value from the wall

Momentum 
Thickness

BL_MomeThick Boundary Layer momentum thickness

Thickness BL_Thick Boundary Layer thickness
Y1 off Wall BL_Y1Plus Boundary Layer Y1 off wall

Case Map CaseMap Map values of a variable from one case onto the nodes of another case.
Coefficient Coeff Coefficient
Complex Cmplx Create complex variable from variables representing the real and 

imaginary portions.
Argument CmplxArg Argument of complex variable
Conjugate CmplxConj Conjugate of complex variable
Imaginary CmplxImag Imaginary portion of complex variable
Modulus CmplxModu Modulus of complex variable
Real CmplxReal Real portion of complex variable
Transient 
Response

CmplxTransResp Complex transient response

Curl Curl of a vector
Density Density
Distance Between 2 Nodes Dist2Nodes Distance between two nodes
Divergence Div Divergence
Dynamic Pressure PresDynam
Element to Node ElemToNode Make node-based variable from element-based variable (via average)
Energy, Total EnergyT Total Energy
Enthalpy
Entropy
Flow Integrated flow through 1D/2D part

Rate FlowRate
Fluid Shear 
Stress

FluidShear Fluid shear stress
Max FluidShearMax Max of fluid shear stress

Force Force Vector
on 1D part Force1D Force Vector on 1D part

Gradient Grad 3D gradient of a variable
Approximation GradApprox Linear, closed-form gradient approximation
Tensor GradTensor 3D tensor gradient
Tensor 
Approximation

GradTensorApprox Linear, closed-form tensor gradient approximation

Helicity Density HelicityDensity
Relative HelicityRelative
Relative Filtered HelicityRelFilter

Iblanking Values IblankingValues Scalar that is the iblanking flag per node
Kinetic Energy KinEn Kinetic energy
Length Summed length of all 1D elements
Line Integral IntegralLine Integral over 1D elements
Log of 
Normalized 

Density DensityLogNorm
Pressure PresLogNorm
Temperature TemperLogNorm

Mach Number Mach number
Make Scalar at Elements MakeScalElem Scalar created, by placing a constant value at each element
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Make Scalar at Nodes MakeScalNode Scalar created, by placing a constant value at each node
Make Vector MakeVect Build a vector variable from scalars
Massed Particle Scalar MassedParticle Massed particle scalar
Mass Flux Average MassFluxAvg
Maximum Max Find spatial max of variable over part(s) at current time
Minimum Min Find spatial min of variable over part(s) at current time
Moment Moment component of a force component based on the current position 

of the Cursor Tool. This is a constant.
Moment Vector MomentVector Moment component of a force component at each node of selected 

parts. This is a field of vectors.
Momentum Momentum
Node To Element NodeToElem Make an element-based variable from node-based (via average)
Normal Surface normal vector
Normal Constraints NormC NC
Normalized Density DensityNorm

Enthalpy EnthalpyNorm
Pressure PresNorm
Stagnation 
Density

DensityNormStag

Stagnation 
Enthalpy

EnthalpyNormStag

Stagnation 
Pressure

PresNormStag

Stagnation 
Temperature

TemperNormStag

Temperature TemperNorm
Vector NormalizeVector Vector field expressed as unit vectors.

Offset Field OffsetField Offset distance field (from boundary)
Variable OffsetVar Variable Value offset from boundary of part into the field (placed on  

boundary)
Pitot  Pressure PresPito

Pressure Ratio PresPitoRatio
Pressure Pres Pressure

Coefficient PresCoef
Rectangular To Cylindrical Vector RectToCyl Calculate vector in cylindrical coordinates
Shock Plot3d ShockPlot3d
Sonic Speed SonicSpeed
Spatial Mean SpaMean Mean of a variable over a part
Speed Magnitude of velocity
Stagnation Density DensityStag

Enthalpy EnthalpyStag
Pressure PresStag
Pressure 
Coefficient

PresStagCoef

Temperature TemperStag
Stream Function Stream Stream
Surface Integral IntegralSurface Integral over 2D elements
Swirl Swirl
Temperature Temperature
Temporal Mean TempMean Mean of a variable over time

Function Abbreviation (if 
any)

Description
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The following standard math functions are also available:

For information on the arguments (and equations), see General Functions or Math Functions in the User Manual.

Tensor Component TensorComponent Component of a tensor variable
Determinant TensorDeterminant Determinant of a tensor variable
Eigenvalue TensorEigenvalue Eigenvalue of a tensor
Eigenvector TensorEigenvector Eigenvector of a tensor
Make TensorMake Make symmetric tensor from variables representing components
Make 
Asymmetric

TensorMakeAsym Make asymmetric tensor from variables representing components

Tresca TensorTresca Tresca failure theory of a tensor
Von Mises TensorVonMises Von Mises failure theory of a tensor

Total Pressure PressT Total pressure
Velocity Velo Momentum/density
Volume Vol Volume of 3D elements
Volume Integral IntegralVolume Integral over 3D elements
Vorticity Vort Vorticity

Function Abbreviation Function Abbreviation

Absolute Value ABS Greater Than GT

Arccosine ACOS Less Than LT

Arcsine ASIN Log Natural LOG

Arctangent ATAN Log Base 10 LOG10

Arctangent (y / x) ATAN2 Root Mean Squared RMS

Cosine COS Round RND

Cross Product CROSS Sine SIN

Dot Product DOT Square Root SQRT

Exponent EXP Tangent TAN

Function Abbreviation (if 
any)

Description
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Extended CFD Variables
Rather than having to individually create the various common CFD variables, EnSight can automatically make them 
available for use if the appropriate basis variables and constants have been provided.  This can be accomplished 
after loading the model with the Extended CFD Variable Settings Dialog:

SEE ALSO
How to Edit Color Maps

User Manual: Variable Creation

2. Select the variable name in the list and then 
click the appropriate SET button.

For example, select Density in the list and then 
click the SET button to right of the Density field.

3. After all variables and constants have been 
specified, click Show Extended CFD 
Variables.

4. Click Okay.

The common CFD variables will now be listed in 
the main variables list.  Note that they will NOT 
actually be computed until activated.

If you have a “standard” PLOT3D Q file, the above 
process can be accomplished automatically by 
starting EnSight with the “-cfd” option on the 
command line.

1. From either the Variable or the Calculator 
Feature Detail Editor, click the Extended 
CFD Variables... button.
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Extract Boundary Layer Variables

INTRODUCTION
EnSight can compute the following boundary layer parameters:

boundary layer thickness named: (bl_thickness)
displacement thickness (bl_displ_thickness)
momentum thickness (bl_momen_thickness)
shape parameter (bl_shape_parameter)
skin friction coefficient (bl_skin_friction)

You must have a 2D surface in a 3D field and specify the 2D surface as the parent part(s).

For a complete description of these variables, refer to the User Manual section below.

BASIC OPERATION
1. Select the 2D parent part(s).

2. Click the Boundary Layer variable icon.

3. Bring up the dialog 
defining the necessary 
variables by clicking here.

6. Choose the method that 
will be used to determine 
the velocity outside the 
boundary layer.

7. Click Create/Update.

4. Define either (Density 
and Momentum) or 
velocity.

The variables can be 
set by either typing 
them into the fields, or 
selecting them from the 
list and clicking on the 
Set button.

5. Click Okay to finish 
the variable setup.

This will create the five new 
variables, which can be used for 
further operations - such as part 
coloring.
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OTHER NOTES
These variables and more are also individually available in the Variable calculator. See the Boundary Layer 
Variables section of Chapter 4 in the User Manual

Boundary Layer variables do not work with multiple cases.

SEE ALSO
How To Create New Variables

User Manual:  Boundary Layer Variables Create/Update
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Edit Color Palettes

INTRODUCTION
All scalar and vector variables have an associated color palette that defines the mapping from variable values to 
colors.  These palettes can be easily edited to customize the mapping.  Color palettes can also be saved to disk and 
restored during a subsequent session.

BASIC OPERATION
Color Palettes have five basic components:

The default color palette created for each variable has five Levels (with the minimum and maximum set to the range 
of the variable at the time step selected when the variable was activated), a linear scale, and is of type Continuous. 
The color ramp is a standard spectrum with the five Levels set to (from min to max) blue, cyan, green, yellow, and 
red.

EnSight can display multiple color legends in the Graphics Window:

Color legends have a number of display attributes including size, position, and how/where the variable labels are 
formatted.  See How To Create Color Legends for details.

Levels A palette can have up to 21 Levels at which the variable value is specified.  Note that the number 
of Levels also controls the number of contour loops created for contour parts that depend on the 
variable.

Scale The palette scale controls how variable values are assigned to Levels between the minimum and 
maximum.  Choices are linear (the default), quadratic (x2), or logarithmic (log10).

Type The palette type controls how color is interpolated across part elements and from Level to Level:

Continuous: Color is linearly interpolated across elements.

Banded: Geometry is colored in discrete bands of uniform color where the band boundaries  
are permitted to cross element faces (as controlled by the nodal variable values).

Constant:  Each element is colored by the color of the first node of the element.

Limit Fringes Limit Fringes controls how color is set for nodes outside the range of variable values specified by 
the palette:

No: Nodes above the range are colored by the maximum color; those below by the minimum 
color.

By Model Color: Nodes outside the range are colored by the underlying part color.

By Invisible: Elements whose nodes are outside the range are not displayed at all.

Display
Undefined

Controls how coloring is set when the variable value for nodes / elements are undefined:

By Part Color:  Color the element by the part color.

By Invisible:  Do not display the element.

1. Click the Legend... button on the desktop.

2. Select the desired variable(s) in the list.

For vector variables, you can select magnitude (or click Show 
Components to be able to select the components as well).

To remove a legend:
Repeat 1. and 2. above
    or
You can remove all legends by clicking the All Off 
button.
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The Feature Detail Editor for Variables provides access to all aspects of variables. The following shows the 
components of the dialog in Advanced Interface mode:

Use the File menu to save and 
restore palettes.

Available variable list.  A * 
indicates that the variable is 
currently active.  Selected 
variable is highlighted.

Buttons to activate and 
deactivate selected variables.

Histogram of the distribution of 
the selected variable.  Provides 
control for:

Minimum Palette Value Slider

Histogram Scale Adjustment

Overall min/max for the selected 
variable

Calculate overall min/max from 
Beg to End time steps (and 
update histogram)

Color palette – click on a label to 
set the current Edit Level

Swap the colors from
top to bottom

Variable type (constant, 
scalar, vector).

Whether given (Gvn) or 
computed (Cmp).

Select component of vector 
variables

Maximum Palette Value 
Slider

Palette type (Continuous, 
Banded, Constant)

Palette scale (Linear, 
Quadratic, Logarithmic)

Limit Fringes toggle

Display Undefined Regions 
(By Part Color or Invisible)

Number of Levels in the 
palette

Current Edit Level

Automatic Level 
interpolation toggle

Variable value assigned to 
current Edit Level

RGB color assigned to 
current Edit Level

1. Double-click the Color icon in the Part Mode bar 
to open the Feature Detail Editor for Variables.
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Changing Color Palettes - Basic Operation:

1. Double-click the Color icon in the Part Mode bar to open the Feature Detail Editor for Variables 
(or double-click the desired variable in the Part color, lighting, &transparency dialog).

By default, the changes you make to a color palette have an immediate effect.  For large models, the 
response rate for interactive editing (e.g. changing the minimum by moving the Minimum Palette Value slider in 
the histogram) can be too slow.  To disable this behavior, select Edit > Immediate Modification (in the Feature 
Detail Editor) to toggle this setting off.  To apply your changes, click the Apply Changes button at the bottom of 
the dialog.

2. Select the desired 
variable.  Click 
Activate if it has not 
been activated.

3. Select Simple 
Interface

To change the minimum 
or maximum:

4. Grab the Minimum 
(or Maximum) Palette 
Value slider (the 
white vertical bars) 
and adjust to the 
desired location.

or:

5. Enter new Minimum 
(or Maximum).

or
6. Select the desired 

parts and click this 
button to get min/
max values based on 
these parts.

To change the number of 
levels:

7. Enter new number of 
levels(2 to 21)

To change the colors 
associated with the values:

8. Select a new palette 
and click Restore

To undo changes from a 
palette:

9. Select the palette and 
click Undo Restore
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ADVANCED USAGE

1. Double-click the Color icon in the Part mode bar to open the Feature Detail Editor for 
Variables (or double-click the desired variable Part color, lighting, &transparency dialog).

By default, the changes you make to a color palette have an immediate effect.  For large models, 
the response rate for interactive editing (e.g. changing the minimum by moving the Minimum 
Palette Value slider in the histogram) can be too slow.  To disable this behavior, select Edit > 
Immediate Modification (in the Feature Detail Editor) to 
toggle this setting off.  To apply your changes, click the 
Apply Changes button at the bottom of the dialog.

2. Select Advanced Interface

There are several ways to edit a color map.

3. Select the desired variable.  Click Activate if it 
has not been activated.

To change the minimum or maximum (and have the 
intermediate Levels adjust accordingly):

4. Grab the Minimum (or Maximum) Palette Value 
slider (the white vertical bars) and adjust to the 
desired location.

To change the number of  Levels:

4. Enter the desired value (between 2 and 21) in 
the # of Levels field and press return.

Note that this will also change the number of contour 
loops for any current contour parts that depend on the 
selected variable.

To edit individual Levels:

4. Select the desired Level: either click on the 
Level label,

    OR enter the Level number into the Edit Level 
field and press return.

5. If you wish to automatically interpolate the 
variable values at preceding (lower) Levels, 
toggle on Interpolate to Level and enter the 
desired Level to interpolate to.

6. To change the variable value associated with 
the Level, enter the new value in the Value field 
and press return.

7. To change the color associated with the Level, 
enter the new color in the RGB fields OR click 
Mix... to open a Color Selector.
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OTHER NOTES
When a variable is first activated, the minimum/maximum settings for the associated palette are set to the minimum/
maximum values of the variable.  Although this is the standard way of initializing color maps, it can result in under 
utilization of the palette since typically only one node has the minimum or maximum value.  You can override this 
default behavior by using the option “-range10” when you start EnSight.  This will shrink the palette towards the 
median value by 10% off the top and the bottom.  In previous releases of EnSight this was the default behavior.

SEE ALSO
How To Create Color Legends, How To Create New Variables, How To Create Contours

User Manual: Variable Summary & Palette and Palette File Formats
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Query, Probe, Plot
Get Point, Node, Element, and Part Information

INTRODUCTION
EnSight provides many methods for extracting exact quantitative data from your results. Specific information about 
nodes, elements, parts, IJK locations, or arbitrary points can be displayed.

BASIC OPERATION

Show Point Information
To show information about an arbitrary point:

Show Node Information
To show information about a specific node, you must have either given or automatically assigned node labels for your 
data.  You must also know the number of the node of interest.  If you do not know the number, you can display node 
labels for the part or, if you know an element that contains the node, you can display element information for the 
element (as described in the next section).  To show node information:

1. If your data is transient, set the desired time using the Solution Time Quick Interaction area (Edit > 
Solution Time Editor...).

2. If you have multiple Cases, select the desired case using Case > casename.

3. Position the Cursor Tool to the desired location.

4. Select the desired part(s) in the Main Parts List.  The query will only be successful if the Cursor Tool 
is found within an element of a selected part.

5. Select Query > Show Information > Cursor.
The query results will be printed to the EnSight message window, which will pop up.
It can also be accessed from the Info icon. 
         The following shows sample output from a point query:

Point (6.19810e-01,2.77589e-01,2.41451e-01)(In Frame 0) Query Information.
Found in structured part # 2.
Found in element # 168379.
Closest node # 1782  (within the element)
Value for Variable density is 9.96230e-01.
Values for Variable momentum are:
x=3.03989e-01,y=-1.42727e-02,z=8.51241e-02,mag=3.16005e-01.

1. If your data is transient, set the desired time using the Solution Time Quick Interaction area (Edit > 
Solution Time Editor...).

2. If you have multiple Cases, select the desired case using Case > casename.

3. Select the desired part(s) in the Main Parts List.  The query will only be successful if the specified 
node is found in a selected part.

4. Select the variable(s) you wish to query in the Main Variables List (only node-based variables will be 
queried).

5. Select Query > Show Information > Node.  The Query Prompt dialog opens.  Enter the ID number of 
the desired node in the text field and click Okay.

The query results will be printed to the EnSight message window, which will pop up.
It can also be accessed from the Info icon.
          The following shows sample output from a node query: 

Node 123 Query Information.
Coordinates (In Frame 0) are: (-2.00000e+00,0.00000e+00,1.19320e+00)
Found in unstructured part # 1.
Values for Variable velocity are:
x=5.82290e-01,y=3.70160e-02,z=-1.82780e-03,mag=5.83468e-01.
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Show IJK Information
To show information about a specific IJK location for structured models:

Show Element Information
To show information about a specific element, you must have either given or automatically assigned element labels 
for your data. You must also know the number of the element of interest. If you do not know the number, you can 
display element labels for the part. To show element information:

1. If your data is transient, set the desired time using the Solution Time Quick Interaction area (Edit > 
Solution Time Editor...).

2. If you have multiple Cases, select the desired case using Case > casename.

3. Select the desired part (one only) in the Main Parts List. The query will only be successful if the 
specified IJK is found in the selected part.

4. Select the variable(s) you wish to query in the Main Variables List (only node-based variables will be 
queried).

5. Select Query > Show Information > IJK. The Query Prompt dialog opens. Enter the values for the 
desired IJK location in the text fields and click Okay.

The query results will be printed to the EnSight message window, which will pop up.
It can also be accessed from the Info icon.
          The following shows sample output from an IJK query: 

IJK 2 5 10 Query Information.
Node Id is: 26146
Found in iblanked structured part # 1.
Coordinates (In Frame 0) are: (4.72982e-01,1.64710e-01,6.50679e-02)
No variables active to show values at the IJK location.

1. If your data is transient, set the desired time using the Solution Time Quick Interaction area (Edit > 
Solution Time Editor...).

2. If you have multiple Cases, select the desired case using Case > casename.

3. Select the desired part(s) in the Main Parts List.  The query will only be successful if the specified 
element is found in a selected part.

4. Select the variable(s) you wish to query in the Main Variables List (only element-based variables will 
be queried).

5. Select Query > Show Information > Element.  The Query Prompt dialog opens.  Enter the ID number 
of the desired element in the text field and click Okay.

The query results will be printed to the EnSight message window, which will pop up.
It can also be accessed from the Info icon.
       The following shows sample output from an element query:

Element 321 Query Information.
Found in unstructured part # 2.
Type of element is 6 Noded triangle
Number of nodes is 6
Node IDs are:  1050  910  1054  1052  1053  1055 
Neighboring Element Information is: 
Element neighbor 318 is of type 6 Noded triangle
Element neighbor 322 is of type 6 Noded triangle
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Show Part Information
To show information about a part:

SEE ALSO
How To Query/Plot,  How To Probe Interactively.

User Manual: Show Information

1. If your data is transient, set the desired time using the Solution Time Quick Interaction area (Edit > 
Solution Time Editor...).

2. Select the desired part in the Main Parts List.

3. Select Query > Show Information > Part.
The query results will be printed to the EnSight message window, which will pop up.
It can also be accessed from the Info icon.

       The following shows sample output from a part query:

Part 2 Query Information.
Unstructured part.
Number of nodes 2380
Minimum coordinate(In Frame 0) is (0.00000e+00,0.00000e+00,0.00000e+00)
Maximum coordinate(In Frame 0) is (3.80000e+01,1.20000e+01,0.00000e+00)
Min node label in part is (1)
Max node label in part is (2380)
Element Information is: 
Element type: 6 Noded triangle, count = 1128.
Min element label in part is (1)
Max element label in part is (1128)
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Probe Interactively

INTRODUCTION
EnSight provides an interactive query capability that displays variable data in the Graphics Window as you move the 
mouse pointer over geometry, as you move the cursor tool within the model, or at specified node, element, ijk or xyz 
locations. The probe can display the value directly under the mouse pointer (by interpolating the nodal values of the 
applicable element) or search for and display the value at the node closest to the mouse pointer.

BASIC OPERATION
To probe interactively:

1. Click the Probe Icon (or select 
Query > Interactive Probe...).

2. Set the Query pulldown to 
desired operation.

3. Select the desired variable to 
display.

Surface Pick: Interpolate to any picked 
position on the surface of the model.

Cursor: Interpolate to location of cursor 
tool within the model.

Node: At a specific node number.

IJK: At a specific IJK location.

Element: At a specific element number.

XYZ: At a specific XYZ location.

4. If Query is set to Surface Pick, 
you can select:

a) whether the probe will snap 
to closest node or

b) use exact location.

And whether the information will 
be sampled:

c) when you click the “p” 
keyboard key or

d) continuously as you move 
the mouse.

If Query is set to Node, Element, 
IJK, or XYZ, enter ID or values 
needed followed by Enter.
If Query is set to Cursor, move 
the cursor tool to desired 
location and press the “p” 
keyboard key (while the mouse 
is in the graphics window).

5. Enter a value controlling the number of 
simultaneous probe markers displayed.  Once 
this number has been reached, the oldest 
marker is replaced by each new marker.

6. If the selected variable is a vector variable, 
you can specify which component (or the 
magnitude) of the variable is displayed.

7. In addition to having the results displayed on 
the model in the graphics window, you can 
open a table that displays the results

8. When done, change the Query to None to 
disable interactive probing.
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Probe Display Attributes
Probes are displayed as a marker (sphere) and the query text label.  The appearance of the marker and label can be 
changed:

OTHER NOTES
Note that interactive query actions do not generate corresponding command language!

When in query mode with the Action set to Request, other picking options that use the ‘p’ key are disabled (such as 
the picks in Part Mode: Part, Cursor, Line, Plane, and LookAt Point).

The Quick Interaction area contains all the attributes that can be set for Probe Interactively. There is no Probe 
Feature Detail Editor.

SEE ALSO
How To Query/Plot

User Manual: Interactive Probe Query

Toggle visibility for the query 
text label.

Set the color of the label.

Toggle visibility for the probe 
marker.

Set the color of the marker.

Set the radius of all probe 
markers.

Toggle whether query text 
labels are “always on top” 
(never hidden by geometry) or 
occluded by geometry that is 
closer.

1. Click the Display 
Attributes... button in the 
Probe Quick Interaction 
area.

Toggle visibility for the id label.  
(Node id, element id, etc.)
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Query/Plot

INTRODUCTION
EnSight can perform a number of different kinds of queries over time or space. The result is a Query Entity that can 
be plotted using EnSight’s built-in Plotting facility or that can be printed as a table or written to a disk file.

BASIC OPERATION
One first must create query items, which can be any of the following types:

As one of these is selected, the Quick Interaction Area changes to reflect the information needed (such as variable to 
use) for the selected type.  One can control whether the query entity will be a curve or a scatter plot by the choice for 
Variable 1 and 2. 

Query entities can be printed to the Status History Area, saved to a file, deleted, or plotted.

Sample Query Creation and Plot (At Maximum Over time)

At Line Tool Over Distance.
At 1D Part Over Distance.

At Node Over Time
At Element Over Time
At IJK Over Time
At XYZ Over Time
At Minimum Over Time
At Maximum Over Time

By Operating on Existing Queries

Read From An External File

1. Select the part to query.

3. Select the Sample type for the 
query.

2. Click the Query/Plot icon (or select 
Query > Over Time/Distance...).

4. Select the variable for 
Variable: 1.

Leave Variable: 2 as None and 
it will default to Time, because 
of sample type.

5. Click Create
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Managing Query Entities
The Quick Interaction area provides various controls for managing existing Query Entities:

6. Click Plot

7. Select the Query Item to 
plot.

8. Click New Plotter.

Note: If any previous plotter has 
the correct type, it will show up 
in the list and can be selected 
instead of creating a new one, if desired. 

The plot will be displayed in the graphics window and will be listed in the Plotters Of Query’s Type list. 
For more information on plotting, see the Plotting section towards the end of this How To.

List of current Query 
Entities.  Selected items are 
operated on by the following 
actions.

Plot the selected Query 
Entity as described above.

Append the text of the selected Query Entity to the 
Status History window.

Save the selected Query Entity to a disk file, either as 
xy data or in a formatted report-like manner. 

Note that previously created and saved query entities are 
restored through the use of the Read From An External 
File query Sample option.

Delete the selected Query Entity.

Update the selected query when any of 
its attributes or have been modified.

For various queries, marker visibility, as 
well as size and color can be controlled 
here as well.
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Over Distance Queries
EnSight can perform queries at uniform points along the line tool or at nodes along a 1D part. One-dimensional parts 
include model parts consisting of bar elements, 1D (Line) Clips, and particle traces.

At Line Tool Over Distance.

At 1D Part Over Distance.

For the two over distance query types, the variable is plotted against the selected “Distance” metric.  The node with 
the lowest node ID number is queried first.  Since the nodes for 1D part over distance are not necessarily evenly 
spaced, the reported distance is one of the following:

If the 1D part contains more than one set of contiguous 1D elements (such as a particle trace from a Line emitter), the 
resulting query will contain one plot entity for each set.

Distance In Setting Reported Distance
Arc Length The distance along the part from the first node to each subsequent node (i.e. the 

sum of the 1D element lengths)
X Arc Length The X coordinate value of each node accumulated from the start
Y Arc Length The Y coordinate value of each node accumulated from the start
Z Arc Length The Z coordinate value of each node accumulated from the start
From Origin The distance from the origin

X From Origin The X distance from the origin
Y From Origin The Y distance from the origin
Z From Origin The Z distance from the origin

After selecting the part to query 
and clicking the Query/Plot icon

1. Select Sample as “At Line 
Tool Over Distance”

2. Select the variable to 
query over the distance in 
“Variable: 1”. 

 Leave “Variable: 2” as None unless you want a scatter 
query of two different variables along the line tool.

3. Optionally, select the Distance option desired, 
number of points along the line, and modify the tool 
location if needed.

4. Click Create

1. Select the part containing only 1D elements.

2. Select Sample as “At 1D Part Over Distance”

3. Select the variable to query in “Variable: 1”.

4. Optionally modify Distance, origin and multiple segment attributes.

5. Click Create.
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Over Time Queries
For transient dataset, EnSight can query the variable values over a range of time at a particular node, element (or 
specific IJK coordinate for structured data) or an arbitrary point.  You can also search the minimum or maximum of a 
variable over all nodes over a time range.

At Node Over Time

At Element Over Time

At IJK Over Time

After selecting the part to query 
and clicking the Query/Plot icon

1. Select Sample as “At Node 
Over Time”

2. Select the variable to query 
over time in “Variable: 1”. 

Leave “Variable: 2” as None unless you want a scatter query of two different 
variables over time.

3. Enter the Node ID.

4. Optionally, change the number of Samples (defaults to number of time 
steps), and whether to sample by Value of FFT.

5. Click Create

After selecting the part to query 
and clicking the Query/Plot icon

1. Select Sample as “At 
Element Over Time”

2. Select the variable to query 
over time in “Variable: 1”. 

Leave “Variable: 2” as None 
unless you want a scatter query of two different variables over time.

3. Enter the Element ID.

4. Optionally, change the number of Samples (defaults to number of time 
steps), and whether to sample by Value of FFT.

5. Click Create

After selecting the part to query and 
clicking the Query/Plot icon

1. Select Sample as “At IJK Over 
Time”

2. Select the variable to query in 
“Variable: 1”. 

Leave “Variable: 2” as None unless 
you want a scatter query of two different variables over time.

3. Enter IJK for the point.

4. Optionally, change the number of Samples (defaults to number of time 
steps), and whether to sample by Value of FFT.

5. Click Create
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At XYZ Over Time

At Minimum Over Time

At Maximum Over Time

After selecting the part to query 
and clicking the Query/Plot icon

1. Select Sample as “At XYZ 
Over Time”

2. Select the variable to query 
over time in “Variable: 1”. 

Leave “Variable: 2” as None 
unless you want a scatter query of two different variables over time.

3. Either type in the desired xyz location or place the cursor where 
desired in the model, either through picking, or other transformation 
methods and click the cursor Get button. 

4. Optionally, change the number of Samples (defaults to number of 
time steps), and whether to sample by Value of FFT.

5. Click Create

After selecting the part to query 
and clicking the Query/Plot icon

1. Select Sample as “At 
Minimum Over Time”

2. Select the variable to query 
over time in “Variable: 1”. 

Leave “Variable: 2” as None 
unless you want a scatter query of two different variables over time.

3. Optionally, change the number of Samples (defaults to number of 
time steps), and whether to sample by Value of FFT.

4. Click Create

After selecting the part to query 
and clicking the Query/Plot icon

1. Select Sample as “At 
Maximum Over Time”

2. Select the variable to query 
over time in “Variable: 1”. 

Leave “Variable: 2” as None 
unless you want a scatter query of two different variables over time.

3. Optionally, change the number of Samples (defaults to number of 
time steps), and whether to sample by Value of FFT.

4. Click Create
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Scatter Query Example

Operations on Existing Queries
You can perform a scaling of an existing query, or a scaling and algebraic addition of two queries, or an integration or 
differentiation of a query.

By Operating on Existing Queries

Queries From External Sources
You can import previously created and saved (or externally generated) EnSight queries or Dytran time history (.ths) 
files.

Read From An External File

Everything is done like a 
regular query except you 
select another variable in the 
Variable: 2 field, instead of 
leaving it as None.

1. Select Sample as “By Operating On Existing Queries”

2. Select the operation. 
(Combine/Scale, Integrate or 
Differentiate).

For Combine/Scale (shown):
3. Select the Query Item and 
the set the Scale Factor if 
you want to scale a single 
query  - or - Select both 
Query Items and set both Scale Factors if you want to scale and add algebraically.

3. Click Create

Note, if integrate or differentiate is chosen, you will only need to choose the query to operate on.

1. Select Sample as “Read 
From An External File”.

2. Click the “Load XY Data 
From File ...” button to open 
the File Selection dialog, and 
select any previously saved 
EnSight XY data file or a Dytran 
.ths file.
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Plotting
Once Queries exist, they can be easily plotted in a new plotter in EnSight, or if an existing plotter of the correct type 
exists, they can be added to the existing plotter.

OTHER NOTES
See XY Plot Data Format in the User Manual for a description of the plot file format.

SEE ALSO
How To Probe Interactively
How To Change Plot Attributes

User Manual: Query/Plot

1. Select the Query Item to be 
plotted.

2. Click the New Plotter button if a 
new plotter is desired.

In this case we did not choose to plot 
the displacement vs. Time query on 
the already existing Maximum plastic 
vs. Time plot. Instead we created a 
new plotter.

3. Select the next Query Item to be plotted.

4. Select the existing plotter on 
which to add this query plot.

In this case, the Minimum plastic vs. 
Time query is added to the existing 
plot for Maximum plastic vs. Time ) - 
thus the plotter will now have two 
curves on it. 

Note: the toggle indicated controls whether the plot is automatically rescaled 
whenever a curve is assigned to it, or not.
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Change Plot Attributes

INTRODUCTION
EnSight provides a full-featured X-Y plotting system fully integrated with the query and transient data handling 
capabilities.  Query entities (see How To Query/Plot) are assigned to plotters.  Plotters display one or more curves 
where each curve is based on the data from a single query entity.  If the query entity is changed, the corresponding 
curve will automatically update.  Plotter attributes (controlling aspects of appearance such as color of curves and 
titles, axis labeling, gradation and tick marks, and border/background color) can be edited in Plot Mode.

This article is divided into the following sections:

Anatomy of a Plotter
Create Plotters
Select Plotters and Curves
Move and Resize Plotters
Set Plotter Visibility
Set Title, Background, Legend, Border, Position, Time Attributes
Set Axis Attributes
Set Curve Attributes
Delete Plotters

Anatomy of a Plotter
Plotters are composed of the following fundamental components:

Plot Title

Legend

Curves

X Axis Title

Y Axis Title

Legend Position Handle

Plot border (red indicates 
that it is currently selected)

X Axis Value Labels

Y Axis Value Labels

Plot Scale Handle (grab to 
scale all except Plot Title 
and Legend)

Y Axis Gradation

Y Axis Subgradation
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Create Plotters
Plotters are automatically created when you assign a query entity to a new plotter (see How To Query/Plot for 
details).

Select Plotters and Curves
When you create a new plotter, it automatically becomes the currently selected plotter (as shown by the border drawn 
in the default highlight color).  Any action to change plotter attributes always operates on the currently selected 
plotter(s) (or the plotter defaults if none are selected).  To select plotters:

Since plotters may contain multiple curves, it is necessary to select individual curves within a plotter for subsequent 
action.  If no curves are selected, changes to curve attributes reset the defaults for subsequently created curves.  To 
select curves within a plotter:

Move and Resize Plotters
Plotters can be easily moved and resized.  You can either reposition a plotter with the mouse in the Graphics Window, 
or precisely by entering exact values.  To move or resize a plotter interactively:

A plotter can also be positioned precisely. See below for details.

Set Plotter Visibility
Selected plotters can be made invisible:

Plotters that are currently invisible are displayed dimmed while in Plot mode.

1. Click Plot in the Mode Selection area to enter Plot mode.

2. Move the mouse pointer into the Graphics Window and click the left mouse button anywhere within 
the desired plotter.  You can add to an existing selection by holding down the Control key as you click 
in additional plotters.

1. Click Plot in the Mode Selection area to enter Plot mode.

2. Move the mouse pointer into the graphics window and click the left mouse button on the desired 
curve.  You can add to an existing selection by holding down the Control key as you click on 
additional curves.

1. Click Plot in the Mode Selection area to enter Plot mode.

2. Select the desired plotter (as described above).

3. To move a plotter, move the mouse pointer into the Graphics Window and into the selected plotter.  
Click and hold the left mouse button and drag the plotter to the desired location.

4. To resize a plotter, move the mouse pointer into the Graphics Window and place the it over one corner 
or side of the selected plotter.  Click and hold the left mouse button and drag the corner or side to the 
desired location.

1. Click Plot in the Mode Selection area to enter Plot mode.

2. Select the desired plotter(s).

3. Click the Plotter Visibility Toggle to toggle display of the 
selected plotters on or off (when not in Plot Mode).

Off On
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Set Title, Background, Legend, Border, Position, Time Attributes
Overall attributes of plotters are controlled through the Plotter Specific Attributes dialog:

The Plotter Specific Attributes dialog contains six sections: Background, Border, Legend, Position, Time, and Title.  
Click the tab at the top to display the corresponding section.

The Background section controls the type and color of the plotter background:

The Border section controls the visibility and color of the plotter border:

The Legend section controls the plotter legend text. The actual text in the legend is specific to the individual curves 
displayed in the plotter. See Set Curve Attributes below.

1. Click Plot in the Mode Selection area to enter Plot mode.

2. Select the desired plotter(s).

3. Click the Graph Attributes icon.

Set background type to either None or Solid.  
A solid background is opaque.

If the background type is Solid, set the color 
(either enter new values in the RGB fields or 
click the Mix... button to open the Color 
Selector dialog).

Toggle border visibility

Set border color (either enter new values in 
the RGB fields or click the Mix... button to 
open the Color Selector dialog)

Toggle legend visibility

Set text size

Set origin (with respect to lower left corner 
of plotter)

Set text color (either enter new values in the 
RGB fields or click the Mix... button to open 
the Color Selector dialog)
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The Position section controls the size and position of the plotter:

The Time section controls whether the curves will animate and whether the plot will be swept out during the animation 
or whether a time marker will sweep along the curve in the plotter:

The Title section controls the main title at the top of the plotter (remember to press return after changing a text field):

Set the origin of the plotter (with respect to 
the lower left corner of the Graphics 
Window).

Set the plotter width/height (0-1 normalized 
to the width and height of the Graphics 
WIndow)

Select Animate curves if you want the curve 
to be swept out or a time marker to be swept 
along the curve during animation.

Toggle Display time marker on if you want a 
vertical line to sweep along the curve during 
animation. Otherwise the curve itself will be 
swept as animation proceeds.

You can control the line width, style, and 
color of a time marker.

Set title text

Set the size of the title text

Set the text color (either enter new values in 
the RGB fields or click the Mix... button to 
open the Color Selector dialog)

If you desire special symbols, click Insert 
Symbol, pick the symbol(s), close, then hit 
return in the title field.
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Set Axis Attributes
Axis attributes of plotters are controlled through the Axis Specific Attributes dialog:

The Axis Specific Attributes dialog contains three sections: General, X-Axis, and Y-Axis.  Click the button at the top to 
display the corresponding section.

The General section controls axis width, color, and scaling as well as Gradation and Subgradation marks.

1. Click Plot in the Mode Selection area to enter Plot mode.

2. Select the desired plotter(s).

3. Click the Axis Attributes icon.

Set line width of axes

Set color of axes

Set auto scaling - when on, the Min/Max values and the 
number of gradations (attributes for the X-Axis and Y-Axis) will 
be used as suggested values to arrive at pleasing numbers for 
the axis labels.

Set line width, style, and color for major gradations (gradations 
are enabled on a per-axis basis in the X-Axis and Y-Axis 
sections)

Set line width, style, and color for subgradations 
(subgradations are enabled on a per-axis basis in the X-Axis 
and Y-Axis sections)
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The X/Y-Axis section controls the title, value labels, and gradation marks for the X or Y axis..

Choose which axis to deal with

Toggle visibility of the axis line

Set the origin location of the plot (with respect to the left/
bottom edge of the plotter)

Set the width/height of the plot (with respect to the width/
height of the plotter)

Set the title of the axis

Set the size of the title of the axis

Set the color of the title of the axis

Set the type of axis label: None (show no value labels), All 
(show value labels at each gradation), or Beg/End (show 
only the first and last value labels)

Set the size of the axis value labels

Set the scale to linear or logarithmic(log10)

Set the min/max range of the variable displayed on the axis 
(Note: will be used as exact values only if the Auto Axis 
Scaling toggle under the General Section is off.)

Set the display format of the value labels (or click Format... 
to select common formats from a list)

Set the color of the axis value labels

Set the type of gradation: None (no gradation marker), Grid 
(a vertical line), or Tick (a mark on the axis at the value label 
positions)

Set the approximate number of gradations (also depends on 
the min/max range)

Set the type of subgradation: None (no subgradation 
marker), Grid (a vertical line), or Tick (marks on the axis 
between the value label positions)

Set the number of subgradations between each value label

By swapping the min and max can swap the positive 
direction.
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Set Curve Attributes
Curve attributes are controlled through the Curve Specific Attributes dialog:

Delete Plotters
Existing plotters can be deleted:

Select All

1. Click Plot in the Mode Selection area to enter Plot mode.

2. Select the desired curve(s) by clicking on them in the 
Graphics Window (control-click to select multiple curves).

If no curves are selected, any changes are applied to the curve 
defaults which will effect any curves created in the future.

3. Click the Curve Attributes icon.

Set the description text for the curve (this will appear as the 
legend)

If desired, you can apply scale factors to your x and/or y data

Set the line width

Set the line style

Set the line type:
None (only curve markers are drawn),
Connect Dots (data points are connected by straight lines), 
Smooth (a piece wise spline is fit to the data points using the 
number of points specified in the Smooth Sub-points field)

Set the marker type

Set the size of the markers

Normalize x and/or y values, if desired.

Set the color of the curve

1. Click Plot in the Mode Selection area to enter Plot mode.

2. Select the desired plotter(s).

3. Click the Delete icon.

Note that deleting a plotter 
has no effect on any query 
entities that were attached 
to the plotter

You can select all curves or all plotters.
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SEE ALSO
How To Query/Plot

User Manual: Plot Mode
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Query Datasets

INTRODUCTION
Results datasets often consist of multiple files.  EnSight provides a mechanism to quickly ascertain basic information 
about dataset files.

BASIC OPERATION
To display dataset information:

SEE ALSO
User Manual: Query Dataset

1. Select Query > Dataset...

The Associated Files section displays all 
dataset files giving the size in bytes and 
last modification date.

The File Specific Information section 
displays information about the file 
currently selected in the Associated Files 
list.  The information presented varies 
based on the file type and format.

The General Geometric section displays 
the 3D extent of all geometry as well as 
the number of nodes and elements.

The Element Detail section shows the 
type and number of all unique element 
types in the dataset.



Manipulate Parts
Change Color

INTRODUCTION
In EnSight, parts can be colored either by a constant color or based on the value of a variable. Coloring geometry by 
variables is one of the simplest and most effective means of visualizing the distribution of a variable.

You can also set a “default” color – all parts subsequently created will automatically be colored by the default color 
(described in the Other Notes section below).

This article covers changing the color of a part.  See How To Edit Color Maps for information on changing the 
mapping from variable values to color.

BASIC OPERATION
To change a part’s color:

1. Select the desired 
part(s) in the Main 
Parts List.

3. If coloring by a variable, 
select the variable in the 
Variables List.

2. Click the Color 
icon.

Which will open the 
Part Color dialog.

     – OR –

4. If coloring by a constant, either enter the 
desired RGB values in the appropriate fields 
(remember to press return)

or click the More... area to open the Color 
Selector dialog 

As long as the Apply modifications immediately 
toggle is on, once step 3. or 4. is completed, the 
part(s) will immediately be colored appropriately in 
the graphics window. If this is toggled off, then the 
Apply button will need to be clicked in order to have 
the color change take place.
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OTHER NOTES
You can set a default variable that will be used to color all subsequently created parts. To do this, be sure no parts are 
selected in the Main Parts list. (To de-select a part, hold down the control key as you click on the selected item.)  
Select the desired default variable in the Variables list of the Part color, lighting, & transparency dialog as described in 
3. and 4. above. Any part created subsequently will automatically be colored by the default variable.

If you are coloring by a vector variable, you can choose whether to color by the magnitude (default) or (by showing 
the components in the list) you can choose to color by one of the components.

SEE ALSO
How To Edit Color Maps.

User Manual: Color Selector
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Copy a Part

INTRODUCTION
The copy operation creates a dependent shallow copy of another part.  The new part has its own set of attributes 
(except for representation), but shares geometric and variable data with the original.  One of the best reasons to 
create a copy is to show multiple variables on one part at the same time in a side-by-side configuration.  The copy 
can be moved independently since new copies are automatically assigned a new frame.

BASIC OPERATION
To create a copy of a part or parts:

1. Select the desired part(s) in the Parts List.  A separate copy will be created for each selected part.

The new copies will be added to the end of the Parts List with “– COPY” appended to the part description.

ADVANCED USAGE
The most common reason for needing a copy of a part is to display multiple variables on the same geometry 
simultaneously.  When you create a copy, a new Frame is also created and the copy is assigned to it (when you 
create multiple copies at the same time, a new frame is created for each new copy).  Using Frame Mode, frames can 
be manipulated (e.g. translated or rotated) independently.  See How To Create and Manipulate Frames for more 
information.

OTHER NOTES

The dependence of the copy on the original has some important consequences:
1. If you change the visual representation of the original, the representation of the copy will change as well.
2. You cannot delete the original until the copy has also been deleted.
3. Since the part copy only exists on the client, you cannot save a part copy to disk.
If you want to create a dependent, non-shallow copy of a part, you can perform a merge operation on a single part.  
This type of copy does now have the same consequences: the resulting “copy” is basically independent except that it 
cannot exist without its parent.

SEE ALSO
User Manual: Part Operations

2. Select Edit > Part > Copy.
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Group Parts

INTRODUCTION
In many types of analysis, multiple parts are used to distinguish between various components or material types. To 
the extent allowed by the particular data format, EnSight maintains this distinction by assigning these entities to 
separate model parts. In many cases however, this distinction is no longer useful for postprocessing. When 
manipulating parts, you often need to apply the same set of attributes to all of them. If the number of parts to be 
treated identically is large, this process can become unwieldy. EnSight provides a group operator to combine multiple 
parts of the same type and case into a single part. The selected parts for the group are automatically removed from 
the user interface, leaving only the newly formed group part. The operation can be reversed by performing the 
Ungroup command.

BASIC OPERATION
  1. Select the desired part(s) in the Parts List.

The selected parts for the group are removed from the part list, and a new Group part is added to the end of the Parts 
List.

OTHER NOTES
The operation can be reversed by selecting Edit > Part > Ungroup

Grouped parts cannot contain other grouped parts.

SEE ALSO
User Manual: “Part Operations”

2. Select Edit > Part > Group
(or right click in the part list)

3. Enter a new part name in the 
pop-up dialog.
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Merge Parts

INTRODUCTION
In many types of analysis, multiple parts are used to distinguish between various components or material types.  To 
the extent allowed by the particular data format, EnSight maintains this distinction by assigning these entities to 
separate model parts.  In many cases however, this distinction is no longer useful for postprocessing.  When 
manipulating parts, you often need to apply the same set of attributes to all of them.  If the number of parts to be 
treated identically is large, this process can become unwieldy.  EnSight provides a merge operator to combine 
multiple parts into a single part.

The merge operation creates one new part from one or more selected parent parts.  The original parts are 
unchanged.  If only a single part is selected for the operation, merge will create a “true” copy of the part (as opposed 
to the shallow copy that the Copy operation creates), with the only dependence being that the parent must exist.

If you delete any of the original parts after the merge, these components will be deleted from the merged part as well.

BASIC OPERATION
 1. Select the desired part(s) in the Parts List.

The new merged part is added to the end of the Parts List with the description “Merge of parts #,#,#” where # are the 
part numbers of the originally selected parts.

OTHER NOTES
Unlike Copy, merge creates true, server-based parts.  Unlike Extract, merge creates parts based on the full, server-
based representation of the part.

If you merge a structured (IJK) part, the resulting part will be unstructured.

SEE ALSO
How To Group Parts.

User Manual: “Part Operations”

2. Select Edit > Part > Merge
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Extract Part Representations

INTRODUCTION
The extract operation is closely tied to part representations.  Extract creates a single new part using only the 
geometry of the current representation of the selected part(s).  For example, if the current representation of a part 
consisting of 3D elements is Border, the result of extraction will be a part consisting of all unshared 2D elements (the 
surface).

Extract is most often used to reduce the amount of information for a part (e.g. for faster display or for geometry 
output) or to create a surface shell part – perhaps for subsequent cutting – of a 3D computational domain.

BASIC OPERATION
 1. Select the desired part(s) in the Parts List.

The new part is added to the end of the Parts List with the description “Extract of parts #,#,#” where # are the part 
numbers of the originally selected parts.

SEE ALSO
See How To Change Visual Representation.

User Manual: “Part Operations”

2. Select Edit > Part > Extract
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Cut Parts

INTRODUCTION
It is sometimes desirable to cut parts to, for example, reveal the interior of a solid or remove unwanted or unneeded 
portions of a model. EnSight can cut any server-based part and either keep both “sides” or discard one. Any of the 3D 
tools (Plane, Quadric, or Box) can be used as the cutting surface.

The cut operation produces dependent copies of the parent part. The part(s) resulting from a cut are completely valid 
parts consisting of standard element types. These parts can be used for any operation – including further cuts.

BASIC OPERATION
To cut a part:

1. Select the part(s) in the Main Parts list.

For the Plane tool, the inside is the positive Z side of the tool.  For the quadric tools, the inside and outside are 
intuitive.  In the Main Parts list, the original part remains and cannot be deleted without also deleting the cut parts (but 
can easily be made invisible if desired).  If In/Out was used, two new parts are added to the end of the Main Parts list 
with the same name as the original part with “+” added to the name of the Inside part and “–” appended to the name 
of the Outside part.  If Inside or Outside was used, one new part is created with “+” added to the beginning of the 
name.

OTHER NOTES
A part copy cannot be cut.  However, if the parent of the copy is cut, the copy will be cut as well (since part copies 
share geometry with the parent).

The cut operation maintains the order of the elements, e.g. 3D elements yield 3D elements and 3D quadric elements 
yield 3D quadric elements.

The cut algorithm breaks elements intersecting the cutting surface into tetrahedrons.  Since there is no transition 
zone created between these tetrahedrons and their non-cut neighbors, non-shared element faces are possible.  
These non-shared faces can result in undesired lines and/or elements during border and/or feature angle 
representations.

If you cut a structured (IJK) part the resulting parts will be unstructured.

Cuts with the Box are not true cuts, but simply a division of all elements that fall completely within the box or not.

SEE ALSO
User Manual: Part Operations

2. Click the Clip Feature icon.

3. Select the desired cutting tool (Plane, 
Box, Cylinder, Sphere, Cone, Surface of 
Revolution or Revolve 1D Part).

4. Position the desired cutting tool in the 
desired location.

5. Select which “sides” to keep.

.
Inside: Keeps inside of quadrics or box and “front” of plane.

Outside: Keeps outside of quadrics or box and “back” of plane.

In/Out: Keeps both sides

Crinkly: Keeps all elements that intersect the plane.
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Delete a Part

INTRODUCTION
The delete operation removes selected parts and any parts dependent on them.  All information associated with the 
parts on both the client and server is removed.  Deletion cannot be undone.

BASIC OPERATION
 1. Select the desired part(s) in the Parts List.

OTHER NOTES
In some cases, variables that depend on a deleted part may have to be updated.  For example, if you have a variable 
such as Area calculated on a set of parts and one of the parts is deleted, the Area variable will automatically be 
recalculated.

If you delete a grouped part, all parts in the group will be deleted.

SEE ALSO
User Manual: “Part Operations”

2. Select Edit > Part > Delete

or click the Delete... button 
below the main parts list

or click the Delete key on your 
keyboard while the mouse is 
in the EnSight window

or right click and select 
Delete.

3. Confirm the deletion.



Change the Visual Representation

INTRODUCTION
The ability to change part representations is a powerful management tool in EnSight.  Not only can you select the 
visual representation that best meets your needs, you can also manage memory more effectively.  Part 
representations exist on the client, the full part is maintained by the server.  Using simpler representations both 
reduces your client memory consumption as well as improving graphics display speed.

EnSight provides five representation modes for parts (as well as three modes that are a combination of the five 
depending on the dimensional order of parts):

Full Every face and edge of every element is displayed.

Border Only unshared faces (for 3D parts) or unshared edges (for 2D parts) are 
displayed.

3D Border, 2D Full Display 3D parts in Border representation; display 2D parts in Full 
representation.  This is the default representation for all parts.

3D Feature, 2D Full Display 3D parts in Feature representation; display 2D parts in Full 
representation.

3D nonvisual, 2D Full Display 3D parts in Non Visual representation; display 2D parts in Full 
representation.

Feature Angle Only those edges joining faces in the Border representation for which the 
angle between the faces is less than some threshold are displayed.  
Feature Angle typically extracts the topological features of interest in a 
model.

Bounding Box Only a wireframe box representing the XYZ extents is displayed.

Non Visual No visual representation exists on the client.  It is often useful to use Non 
Visual as the representation for 3D computational domain parts – 
provided you also have some sort of shell part to display the outer 
surface.
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BASIC OPERATION

OTHER NOTES
Note that some derived parts (such as contours or vector arrows) are based on the client’s representation of the 
parent part.  If the parent’s representation changes, the derived parts will change as well.

You cannot change the representation of a copied part.  A copy always exhibits the current representation of the 
original part.

A part’s representation can be made “permanent” by creating a new part based on the current representation.  See 
How to Extract Part Representations for more information.

SEE ALSO
User Manual: Element Representation

1. Select the desired part(s) in the Parts List.

2. Select Part in the Mode Selection area to enter 
Part mode.

3. Click the Element Representation icon to open 
the Part Element Settings dialog.

4. Select the desired visual representation.
    Options are:

5. If desired, you can apply polygon reduction.
Polygon reduction is designed to speed up visualization 
processing by thinning out the number of polygons that are 
rendered.  There is naturally a trade off in image quality and 
speed.  Note that the original model is not modified, just its 
rendered image.
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Set Attributes

INTRODUCTION
Part attributes control the appearance and behavior of parts. Much of the power of EnSight derives from the broad 
range of attributes available and the ease with which they can be changed. Attributes are grouped into several 
classes:

Most (if not all) of the Creation attributes for non-model parts can be edited in the Quick Interaction area by double-
clicking on the part in the Main Parts list.  Most display attributes (such as color and visibility) can be controlled via the 
icons in Part mode.  If required, the Feature Detail Editor can be opened for complete access to all attributes.  See 
How To Use the Feature Detail Editors for more information.

Since Creation attributes are specific to each (non-model) part type, they are not covered here.  Look in the How To 
article for the specific part type for details on those particular Creation attributes.

This article is divided into the following sections:

Part Mode Attribute Icons
General Attributes
Node, Element, and Line Attributes
Displacement Attributes
IJK Axis Display Attributes

Creation Creation attributes are unique for each (non-model) part type (e.g. the isovalue of an isosurface). Most (if 
not all) of the creation attributes for a part are accessible in the Quick Interaction area after double-
clicking the part in the Main Parts List, or by the main menu structure Edit->Part Feature Detail Editors-
>Isosurfaces (for example).

General Visibility
Susceptibility to auxiliary clipping
Reference Frame
Response to change in time (active or frozen)
Symmetry options
Viewport visibility
Coloration (by variable or constant color)
Hidden surface toggle
Hidden line toggle
Shading type (flat, Gouraud, smooth)
Transparency
Lighting (diffuse, shininess, highlight intensity)
Visual symmetry

Node, Element, 
and Line

Node, line, element visibility toggles
Node type (dot, cross, sphere)
Node scale (constant or variable)
Node detail (for spheres)
Node and element label toggle
Element-line width
Element-line style (solid, dotted, or dot-dash)
Element representation on client (full, border, 3D border/2D full, 3D feature/2D full, 3D nonvisual/2d full, 
feature angle, bounding box, nonvisual)
Element shrink factor
Polygon reduction factor
Failed element variable and rules

Displacement Displacement variable
Displacement scaling factor

IJK Axis Display IJK Axis visibility
IJK Axis scale value
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BASIC OPERATION

Part Mode Attribute Icons
The Part mode icons can be used to quickly set attributes for parts.  To use these controls:

1. Select the desired part(s) in the Main Parts list.

2. Click Part in the Mode Selection area.

3. Click appropriate icon to set the desired attribute:

Part Visibility

Color, Lighting, & transparency

Line Width

Visibility Per Viewport

Element Visual Representation

Displacement

Visual Symmetry

Node and Element Labeling

Node Representation

Failed Elements

Element Blanking

Shading Type

Hidden Line

Auxiliary Clipping

Fast Display Representation
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General Attributes
The General Attributes section in the Feature Detail Editor duplicates many of the controls available in Part mode.  To 
set attributes using the General Attributes section:

1. Select Edit > Part Feature Detail Editors > part type.

2. In the parts list at the top of the Feature Detail Editor dialog, select the desired part(s).

By default, any changes you make to attributes will take effect immediately.  If you wish to “batch” a 
series of changes, select Edit > Immediate Modification (be sure to use the Edit menu in the 
Feature Detail Editor dialog) to toggle this setting off.  When toggled off, a button at the bottom of 
the dialog becomes active: Apply Changes.  Click it when you are ready to apply a set of changes.

3. Set the desired attribute(s):

Set part detail representation 
(according to  Global 
Viewing Detail Mode):                                     

• Box: part is represented as 
bounding box. 

• Elements: part is represented 
according to Element 
Representation

• Points: part is represented as 
a point cloud

Set part reference frame

Set part graphical symmetry

Set shading type:

• Flat: color and shading are 
constant across elements

• Gouraud: color and shading 
vary linearly across elements

• Smooth: color and shading 
calculated based on surface 
normal interpolated  across      

   elements to simulate a 
smooth surface.

Toggle part visibility

Toggle auxiliary clipping on/off

Toggle whether the client’s portion 
of the part changes if the current 
time step changes

Set color by constant or color by 
variable

Set the part color if constant

Toggle part hidden surface

Toggle part hidden line

Set part transparency as “true”
or with a fill pattern

Set part shading parameters:

• Diff: diffuse shading – the 
amount of light that a surface 
reflects.  0 is none and 1 is full.

• Shin: Degree of shininess – 0 is 
dull and 100 is very shiny.

• H Int: Degree of highlight 
intensity – 0 is none and 1 is full. 

SEE ALSO
Set Global Viewing Parameters
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Node, Element, and Line Attributes
Node, element, and line attributes control how a part’s nodes and elements are displayed.  Nodes can be displayed 
as dots, crosses, or spheres.  If displayed as crosses or spheres, the radius can be set by the value of a variable at 
that node.  To set attributes using the Node, Element, and Line Attributes section:

1. Select Edit > Part Feature Detail Editors > part type.

2. In the parts list at the top of the Feature Detail Editor dialog, select the desired part(s).
By default, any changes you make to attributes will take effect immediately.  If you wish to “batch” a series of 
changes, select Edit > Immediate Modification (be sure to use the Edit menu in the Feature Detail Editor dialog) to 
toggle this setting off.  When toggled off, a button at the bottom of the dialog becomes active: Apply Changes.  
Click it when you are ready to apply a set of changes.

3. Set the desired attribute(s):

Set visibility of nodes, lines, 
elements

Set node/element label visibility

Set Line width and Style (Solid, 
Dotted, or Dot-dashed)

Set element representation 
(described below)

Set element shrink factor (shrink 
elements toward the centroid)

Set angle for Feature Angle 
representation

Set variable to use for failed 
element removal.

Set the values and rules for failed 
element variable values

Set node representation

• Dot: nodes are displayed as 
points.

• Cross: nodes are displayed as 
crosses and can be fixed size 
(size set by the Scale value) or 
sized based on a variable (and 
scaled by the Scale value).

• Sphere: nodes are displayed as 
spheres and can be fixed size 
(size set by the Scale value) or 
sized based on a variable (and 
scaled by the Scale value).  
Sphere detail controlled by Detail 
value.

Set polygon reduction. Same 
model, but simpler representation. 
Trade-off of visual fidelity and 
rendering speed.
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EnSight provides five representation modes (and three combination modes) for parts (see also How To Change 
Visual Representation):

Displacement Attributes
In structural mechanics simulations, a common output variable is a set of vectors representing the movement or 
displacement of geometry. Each displacement vector specifies a translation of a node from its original position (an 
offset). EnSight can display and animate these displacements to help visualize the relative motion of geometry. To set 
Displacement attributes (see also How To Display Displacements):

IJK Axis Display Attributes
Model Parts and clips (because they can be structured parts) will have these attributes available. These attributes will 
only be applicable to structured parts.

SEE ALSO
Introduction to Part Creation
User Manual: Part Attributes

Full Every face and edge of every element is displayed.

Border Only unshared faces (for 3D parts) or unshared edges (for 2D parts) are displayed.

3D Border, 2D Full Display 3D parts in Border representation; display 2D parts in Full representation.  This is the 
default representation for all parts.

3D Feature, 2D Full Display 3D parts in Feature representation; display 2D parts in Full representation.

3D nonvisual, 2D Full Display 3D parts in Non Visual representation; display 2D parts in Full representation. 

Feature Angle Only those edges joining faces in the Border representation for which the angle between the 
faces is less than some threshold are displayed.  Feature Angle typically extracts the 
topological features of interest in a model.

Non Visual No visual representation exists on the client.  It is often useful to use Non Visual as the 
representation for 3D computational domain parts – provided you also have some sort of shell 
part to display the outer surface.

Bounding Box Displays a bounding box surrounding (and in place of)  the nodes and elements.

Set Displace By to either None (no displacement) or the vector variable to 
use for displacement.

Set nodal displacement factor to reduce or exaggerate a displacement

Toggle IJK Axis Visible to display an IJK axis for the part.

The scale factor for the IJK Axis triad can be modified in this field.
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Display Labels

INTRODUCTION
It is often useful to be able to identify specific nodes or elements within your model. EnSight can display node and 
element labels in the Graphics Window. If your data provides explicit node or element labels (or you are using 
EnSight data formats and have asked EnSight to assign ids), EnSight will be able to display those values. Only model 
parts can have labels.

Displaying labels on parts with thousands of nodes or elements can obscure both the geometry as well as the labels 
of interest (as well as degrading display performance). EnSight provides a filtering mechanism to display only 
selected ranges of labels.

BASIC OPERATION

Displaying Node and/or Element Labels
To display labels (and to control filtering and coloring):

1. Select the desired part(s) in the Main Parts list.

2. Select Part mode in the Mode Selection area.

3. Click the Node/Element Label icon to display the Node/Element 
labeling attributes dialog.

4. Click the appropriate 
toggle(s) to turn on/off node 
and/or element labels.

5. To set filters for node/
element labels, select the 
desired filter and enter the 
appropriate values in the 
Low and/or High fields.

6. Set the node/element label 
color.

The label filters operate as follows:

None Display all labels.

Low Remove all labels < the Low value

Band Remove all labels >= Low and <= High

High Remove all labels > the High value

Low/High Remove all labels < the Low value as well as those > the High value.
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Note that the Node and Element Label toggles also have counterpart toggles in the View Menu. These act as global 
toggles that enable or disable any per-part node or element labels.

OTHER NOTES
Note that created parts do not have node or element labels.

Another useful technique for reducing label clutter is to use the front and back Z clipping planes to display only a thin 
slice of interest. See How To Set Z Clipping for more information.

SEE ALSO
User Manual: Label Visibility
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Set Transparency

INTRODUCTION
EnSight can display parts as transparent using two different methods:

Transparency is not available on all platforms.

Note: Hidden line overlays cannot be displayed while using transparency

BASIC OPERATION

SEE ALSO
User Manual: Part Transparency

True (alpha) True transparency uses the hardware alpha planes.  Although the resulting visual effect is 
superior to fill patterns, true transparency is much slower to draw (especially for large 
models) since all geometry must be sorted from back to front prior to each redraw.

Fill Pattern Fill pattern or screen-door transparency uses polygon fill patterns to control where polygons 
are drawn (typically a fine grid specifying on and off).  EnSight provides three patterns that 
yield varying degrees of pseudo-transparency.

1. Select the desired part(s) in the Parts List.

2. Select Part in the Mode Selection area to enter 
Part mode.

3. Click the Part color, lighting, & transparency 
icon to open corresponding dialog.

For true transparency:

4. Adjust the slider to the desired 
setting.

The Graphics Window will dynamically 
update as the slider is adjusted.

    OR

For Fill Pattern transparency:

4. Select the desired pattern from the 
Fill Pattern pulldown.

Fill pattern 0 is solid.



Select Parts

INTRODUCTION
Manipulating parts is one of the fundamental operations in EnSight.  Before you operate on parts, they must be 
selected in the Main Parts list.  Parts can either be selected through standard mouse interaction with the items in the 
Main Parts list or selected by picking parts in the Graphics window.

BASIC OPERATION

Selecting Parts using the Main Parts List
Items in the Parts List itself are selected using standard Motif methods:

Selecting Parts using the Select... Options

There are several other useful options for selecting parts:

To ... Do this ... Details ...

Select an item Select (or single-click) Place the mouse pointer over the item and click the left mouse 
button.  The item is highlighted to reflect the “selected” state.

Extend a contiguous 
selection

Select-drag Place the mouse pointer over the first item.  Click and hold the left 
mouse button as you drag over the remaining items to be 
selected.  Only contiguous items may be selected in this fashion.

Extend a  (possibly long) 
contiguous selection

Shift-click Select the first item.  Place the mouse pointer over the last item in 
the list to be selected.  Press the shift key and click the left mouse 
button.  This action will extend a selection to include all those 
items sequentially listed between the first selection and this one.

Extend a non-contiguous 
selection

Control-click Place the mouse pointer over the item.  Press the control key and 
click the left mouse button.  This action will extend a selection by 
adding the new item, but not those in-between any previously 
selected items.

De-select an item Control-click Place the mouse pointer over the selected item.  Press the control 
key and click the left mouse button.  This action will de-select the 
item.

Open the Quick 
Interaction Area for a part

Double-click Place the mouse pointer over the item and click the left mouse 
button twice in rapid succession.

1. Click the Select... button just below the main parts list.

2. Select the desired option.

All Selects all parts in the list.

Invert Inverts the selection. Namely, all parts currently 
selected become unselected and all unselected 
become selected.

Invisible Selects all visible parts.

Visible Selects all invisible parts

Region Selects all parts that are within the selection tool. 
(Requires that the selection tool be on)

Showing Selects all visible parts which are showing in the 
graphics window.

Keyword... Opens a dialog which allows for selections using 
keywords and regular expressions.

Unselect Unselects all parts in the list.
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Selecting Parts by Picking

Parts can also be selected by “picking” them in the Graphics window.  To select parts by picking:

Parts are identified for picking as follows.  If the part (as represented on the client) consists of surface (2D) elements, 
a pick will occur if the mouse cursor is over any portion of the surface – even if the part is drawn in line mode and the 
mouse was over the middle of the element (and not over one of the visible lines).  If the part is drawn as 1D elements 
(e.g. the part is in feature angle representation), the mouse must be over one of the visible lines of the part.

By default, when you press the ‘p’ key any previously selected parts are de-selected.  Holding down the Control key 
as you hit ‘p’ modifies this behavior: if the picked part is not currently selected, it will be added to the existing selection 
(so you can select multiple parts by picking), otherwise the picked part is de-selected.

OTHER NOTES
Selecting View > Show Selected Parts will open a small graphics window that will only display the parts currently 
selected in the Main Parts list.  This can be helpful when trying to select multiple parts from a large list.

SEE ALSO
User Manual: “Part Selection and Identification”

1. From the Pick pulldown icon, select Pick Part.                  
(Note that this is the default, and this setting will be retained 
until explicitly changed.)

2. Position the mouse pointer over the desired part in the 
Graphics Window and press the ‘p’ key (or perform the 
mouse action which has been set to “Selected pick action” 
in Edit > Preferences > Mouse and Keyboard).

See below regarding how parts are identified.

Note that the picked part is now selected in the Main Parts list.
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Set Symmetry

INTRODUCTION
In many instances, a modeler can take advantage of symmetry present in a problem to reduce the computational 
complexity of a subsequent analysis.  EnSight can impart visual realism to such models by mirroring parts around any 
or all axes of the part’s reference frame or performing rotational symmetry about any of the axes.  Although the 
mirrored or rotated portions appear identical to the source part (except for the reflection or rotation), they are only 
visual (client-based) and cannot be used for calculation.  For example, you cannot start a particle trace in one half 
and expect the trace to cross the plane of symmetry into the other half (although you can make the particle trace part 
symmetric as well).

EnSight also provides “true” or “computational” symmetry operations (mirror, rotational, translational) as an attribute 
of the part’s reference frame.  With computational symmetry, you can trace particles across a periodic boundary.

Both types of symmetry (visual or computational) are based on the part’s reference frame.  Although you can use 
simple visual or computational symmetry without having to manipulate the frame, more advanced usage of symmetry 
could require a working knowledge of frames.  See How To Create and Manipulate Frames for more information.

BASIC OPERATION

Visual Symmetry
Visual symmetry is an attribute of parts. You can enable display of a mirrored copy of a part into one or more of the 
seven octants (opposite of  +,+,+) of the part’s reference frame. You can also enable display of a number of rotational 
instances about the x,y, or z axes of the part’s reference frame. To display visual symmetry:

Recall that symmetry is performed with respect to the reference frame of the part. The frame’s axes define the 
partitioning of space into the octants that attached parts are mirrored into, or the rotational axis. If the symmetry 
operation did not produce the desired effect, it is probably due to the fact that the part’s frame is not aligned with the 
plane of symmetry, or the rotational symmetry axis, as designed for the model. The solution is to create a new frame, 
assign the part(s) to the new frame, and position the frame such that two of its axes lie in the plane of symmetry, or 
one of its axes align with the rotational axis. There operations are discussed in How To Create and Manipulate 
Frames.

4. Select Mirror from the Type pulldown menu.

5. Select the desired octant(s) from the menu.

Visual Mirror Symmetry:

Visual Rotational Symmetry:

4. Select Rotational from the Type 
pulldown menu.

5. Select rotational axis, instance 
angle, and number of instances.

1. Select the desired part(s) in the Main Parts list.

2. Click Part in the Mode Selection area to enter Part mode.

3. Click the Visual Symmetry icon.
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Computational Symmetry
Computational symmetry can be used for unstructured and structured model parts with periodic boundary conditions.  
(Note, it does not work for created parts.)  Computational symmetry can handle rotational, translational, and mirror 
symmetry. Unlike visual symmetry, computational symmetry actually produces the symmetric geometry and variables 
on the server - allowing for more than just visual symmetry.

You enable computational symmetry by selecting the frame, specifying the type (Mirror, Translational, Rotational), 
and setting type specific attributes (such as the rotation angle and the number of instances to create).  Each part 
assigned to the frame will be updated on the server to reflect the specified symmetry.

Note that each new instance of a part created through computational symmetry creates a new part on the server.

To use computational symmetry, you will need to enable Frame Mode if it isn’t already enabled. (Edit > Preferences... 
General User Interface - Frame Mode Allowed). Then:

1. Click Frame in the Mode Selection area to enter Frame mode.

2. If the default frame (frame 0) is not correctly positioned for the desired 
symmetry operation, create a new frame, position the frame in the 
proper location and orientation, and assign the part(s) to the new frame.  
(See How To Create and Manipulate Frames for details.)

3. Select the desired frame.

4. Click the Computational Symmetry Attributes Icon.

The remaining steps depend on the type of symmetry desired.

Mirror Symmetry is similar to graphical symmetry as 
described above.

5. Select Mirror from the Type pulldown.

6. Select the desired octant(s) from the Mirror In 
pulldown.

7. Click Update.

Rotational Symmetry creates instances by rotating, 
around the selected axis of the frame, the specified 
number of degrees. The selected frame’s axis must 
be aligned with the desired symmetry axis.

5. Select Rotational from the Type pulldown.
6. Select the frame rotational axis.
7. Set the desired rotation angle (in degrees) in 

the Angle field.
8. Set the desired number of instances in the 

Instances field (number 1 is the original, set 
Instances to 2 to yield one copy).

9. If a periodic match file is available, toggle Use 
Periodic File and enter the file name.

Periodic match files are discussed below.

10. Click Update.
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Periodic Matching for Computational Symmetry
When a model is created with periodic boundary conditions, there is typically a built-in correspondence or “match” 
between certain nodes and elements.  For example:

When instances are added to a part, it is desirable to eliminate these duplicate nodes.  Without a match file, EnSight 
will attempt to find and remove them using a hashing scheme.  This method works quite well, but may not find all 
duplicates.  (Remaining duplicates are usually noticed when the part is in feature angle representation since EnSight 
treats elements with duplicate nodes as separate – even if they are coincident.)

Note that if you have a periodic match file you do not need to specify the rotation axis and angle in the Frame 
Computational Symmetry Attributes dialog – the value is provided in the file.

A user-supplied matching file can be used to quickly find and remove all duplicates.  The match file is a simple ASCII 
text file.  The file for the example above would be (the text in italics is not part of the file):

rotate_z specifies rotational symmetry and the applicable axis
52.34 the angle of rotation (in degrees)
3 the number of node pairs to follow
1 1 first node pair
2 6 second node pair ...
3 7

See Periodic Match File for more information on periodic match files.

SEE ALSO
How To Create and Manipulate Frames

Translational Symmetry creates instances in the 
direction of the specified translation vector.  The 
translation vector is first rotated by the frame’s 
rotation, but is independent of the frame’s origin 
location.

5. Select Translational from the Type pulldown.

6. Enter the desired translation vector in the XYZ 
fields and press return.

7. Set the desired number of instances in the 
Instances field (number 1 is the original, set 
Instances to 2 to yield one copy).

8. If a periodic match file is available, toggle Use 
Periodic File and enter the file name.

Periodic match files are discussed below.

9. Click Update.

1

2

34

5

6

7

The elements defined by nodes 1,2,3 and nodes 1,6,7 should 
match when rotated about an axis passing through node 1 
(perpendicular to the screen).  When another instance is 
created, node 2 matches with 6 and node 3 matches with 7.
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Animate
Animate Transient Data

INTRODUCTION
Transient data can be animated through EnSight’s flipbook capability.  During the flipbook load process, all parts 
(both model and created) are automatically rebuilt (if necessary) using the data from each time step in sequence.  At 
each step, a graphical “page” is created and stored in memory.  When the flipbook is active, the pages are displayed 
in order as rapidly as the hardware allows (although you can slow it down).   You can also step through pages 
manually.

The graphical pages can be one of two types: object or image.  An object flipbook saves each page as 3D geometry 
so you can continue to manipulate the model (e.g. rotate or zoom) during playback.  However, for very large models 
and/or long sequences, the memory requirements can be substantial.  In this case, you can create image flipbooks 
that save only the image pixels for each page.  Although the size of each page is now fixed, you cannot change the 
viewing parameters without reloading the flipbook.

This article covers using the flipbook capability for transient data (and assumes that you have successfully loaded 
your transient data).  See How To Create a Flipbook Animation for more details on flipbooks.  EnSight’s keyframe 
animation capability also works with transient data and provides a flexible mechanism for synchronizing your 
available time steps with the output animation frames.  See How To Create a Keyframe Animation for more 
information.

BASIC OPERATION
Prior to loading the flipbook, you should create all parts of interest (e.g. clips, contours, isosurfaces, etc.). These parts 
will automatically be recalculated for each time step. To load a transient flipbook:

1. Click the Flipbook Animation icon in 
the Feature Icon Bar.

2. Be sure that the Load tab is selected.

3. Be sure the Load Type is set to 
Transient.

7. Click Load.

4. Select the desired page type (Object or 
Image).

5. If desired, reset the current beginning and 
ending time.

  (Clicking this button will replace the 
Flipbook Quick Interaction area with the 
Solution Time Quick Interaction area.  
When you are done, click the Flipbook 
animation... button to return).

6. If desired, you can specify a time 
increment for the load.

For example, using 0.5 would create pages 
representing time steps 0, 0.5, 1, 1.5, 2, 2.5, 
etc. The in-between steps are calculated by 
linear interpolation.
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The Load Flipbook Status dialog will open and show the progress of the load. You can cancel the load by clicking the 
Cancel button and retain all the pages loaded to that point. Once the load is complete, you can run the flipbook using 
VCR type controls:

After a flipbook load, the next 3 steps will 
generally be the default already.
1. Make sure the Run tab is selected.
2. Make sure the Display is set to 

flipbook pages.
3. Click the run forward or backward 

button.
The flipbook will begin to run.

OR

You can also step through the pages 
manually:

3. Click the forward/backward single 
step buttons (once for each page).

You can also enter values in the Current 
Page field (and press return) to jump to a 
specific page.

4. To change the range of displayed pages, enter new 
values in the Begin Page and/or End Page fields (and 
press return) or click and drag the left/right slider 
handles.

5. To change the display speed, enter a new value in the 
Display Speed field (and press return) or simply slide 
the slider.

A speed of 1.00 represents “full” hardware speed with no 
delays; a value of 0.5 is half of full speed.

6. To cycle the page display, click Cycle.
Cycle will replay the pages in reverse order when the last 
page is reached.

7. To stop the animation, click the stop button.

8. When done, set the Display to “original model” instead 
of “flipbook pages”.
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Record
Once a flipbook is playing, it can be recorded.  

Available recording file formats:

Delete
Any type of flipbook can be deleted:

1. Click Delete... in the Flipbook Quick Interaction Editor.
2. Confirm the deletion.

All memory associated with the flipbook is freed.

ADVANCED USAGE
If you have created transient particle traces (pathlines) and set up a particle trace animation, you can also load a 
flipbook and show the particle trace animation synchronized with the flipbook. The trace animation will automatically 
play through the time range of the flipbook and stay in sync with the flipbook pages. See How To Create Particle 
Traces and How To Animate Particle Traces for more information.

Apple PICT Flipbook files saved as sequence of Apple PICT files.

JPEG Flipbook files saved as sequence of JPEG files.

TIFF Flipbook files saved as sequence of TIFF files.

PCL Flipbook files saved as sequence of Page Control Language files.

PostScript Flipbook files saved as sequence of PostScript files.

Silicon Graphics RGB Flipbook files saved as sequence of SGI RGB files.

TARGA Flipbook files saved as sequence of TARGA files.

CEI RGB with depth Flipbook files saved as sequence of RGB files with depth.

EnVideo Flipbook files are saved to EnVideo file.

MPEG1 / MPEG2 Flipbook files are saved to an MPEG file.

AVI Flipbook files are saved to an AVI file.

The “Record current graphics window 
animation” icon will be on.

Click it to open the Save Animation dialog.

Set the recording format, and the window 
size under the Record and Advanced tabs.

Off On
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OTHER NOTES
Since both object and image flipbooks build pages from the current set of parts based on their current attributes, if 
you make a change (such as color a part by a different variable or create a new part), you must reload the flipbook.  
There are exceptions.  With an object flipbook, you can make a part invisible while the flipbook is running.

SEE ALSO
How To Load Transient Data
 How To Create a Flipbook Animation

User Manual: Flipbook Animation, Flipbook Animation
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Create a Flipbook Animation

INTRODUCTION
Various types of data can be animated through EnSight’s flipbook capability.  During the flipbook load process, 
selected parts are automatically rebuilt based on some criteria (such as a delta for a clipping plane).  For each step, a 
graphical “page” is created and stored in memory.  When the flipbook is active, the pages are displayed in order as 
rapidly as the hardware allows (although you can slow it down).   You can also step through pages manually.

The graphical pages can be one of two types: object or image.  An object flipbook saves each page as 3D geometry 
so you can continue to manipulate the model (e.g. rotate or zoom) during playback.  However, for very large models 
and/or long sequences, the memory requirements can be substantial.  In this case, you can create image flipbooks 
that save only the image pixels for each page.  Although the size of each page is now fixed, you cannot change the 
viewing parameters without reloading the flipbook.

There are four distinct types of flipbooks:

This article covers only the “Create Data” type of flipbook.  See How To Animate Transient Data for details on 
transient flipbooks.  See How To Display Displacements for details on mode shape flipbooks.

For more sophisticated animations, use EnSight’s keyframe animation capability.

BASIC OPERATION
For each page of the flipbook, a delta value will be applied to all active clip parts and isosurfaces. For clips, the delta 
represents a translation vector; for isosurfaces it is an increment to the isovalue. There are two ways to specify these 
delta values: either through interactive manipulation or via the applicable Feature Detail Editor for the part. The 
former method is discussed below, the latter in the Other Notes section at the end.

Prior to loading the flipbook, you should create all parts that you wish to animate (clips and/or isosurfaces) and 

Transient Pages are constructed by stepping from the current beginning to ending 
time range and rebuilding all time-dependent parts based on each time 
step in sequence.

Mode Shapes Pages are constructed by applying a cosine-driven scaling factor to a 
displacement variable.

Create Data Pages are constructed by applying a delta to either a clip part or an 
isosurface.

Linear Load Pages are constructed by applying linear interpolation ranging from zero 
to the maximum (displacement) vector field value.
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manipulate the part so that it is in the desired location for the start of the flipbook. To load the flipbook:

1. Click the Flipbook Animation icon in 
the Feature Icon Bar.

2. Be sure that the Load tab is selected.

3. Be sure the Load Type is set to 
Create data.

4. Select the desired page type (Object or 
Image).

5. Set the desired number of pages.
The delta value will be added to the appropriate 
entities for each page

6. Click Start to begin recording interactive 
part manipulations.

6a. For clipping plane parts, reopen the Quick Interaction area for the part 
(double-click on the part in the Main Parts list).

6b. Toggle on Interactive Tool, move the mouse into the Graphics Window and 
interactively position the tool to the desired location for the end of the 
flipbook.

6a. For isosurface parts, reopen the Quick Interaction area for the part (double-
click on the part in the Main Parts list).

6b.  Change the Interactive Pulldown to Manual and adjust the slider until the 
isovalue is as desired for the end of the flipbook.

7. Return to the Flipbook Quick Interaction area (i.e. perform step 1 again).

8. Click Stop to end recording interactive Iso/Clip.

9. Click Load.
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The Load Flipbook Status dialog will open and show the progress of the load. You can cancel the load by clicking the 
Cancel button and retain all the pages loaded to that point. Once the load is complete, you can run the flipbook using 
VCR type controls:

After a flipbook load, the next 3 steps will 
generally be the default already.
1. Make sure the Run tab is selected.
2. Make sure the Display is set to 

flipbook pages.
3. Click the run forward or backward 

button.
The flipbook will begin to run.

OR

You can also step through the pages 
manually:

3. Click the forward/backward single 
step buttons (once for each page).

You can also enter values in the Current 
Page field (and press return) to jump to a 
specific page.

4. To change the range of displayed pages, enter new 
values in the Begin Page and/or End Page fields (and 
press return) or move the slider range markers.

5. To change the display speed, enter a new value in the 
Display Speed field (and press return) or simply slide 
the slider.

A speed of 1.00 represents “full” hardware speed with no 
delays; a value of 0.5 is half of full speed.

6. To cycle the page display, click Cycle.
Cycle will replay the pages in reverse order when the last 
page is reached.

7. To stop the animation, click the stop button.

8. When done, set the Display to “original model” instead 
of “flipbook pages”.
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Record...
Once a flipbook is playing, it can be recorded.  

Available recording file formats:

Delete
Any type of flipbook can be deleted:

1. Click Delete... in the Flipbook Quick Interaction Editor.
2. Confirm the deletion.

All memory associated with the flipbook is freed.

Apple PICT Flipbook files saved as sequence of Apple PICT files.

JPEG Flipbook files saved as sequence of JPEG files.

TIFF Flipbook files saved as sequence of TIFF files.

PCL Flipbook files saved as sequence of Page Control Language files.

PostScript Flipbook files saved as sequence of PostScript files.

Silicon Graphics RGB Flipbook files saved as sequence of SGI RGB files.

TARGA Flipbook files saved as sequence of TARGA files.

CEI RGB with depth Flipbook files saved as sequence of RGB files with depth.

EnVideo Flipbook files are saved to EnVideo file.

MPEG1 / MPEG2 Flipbook files are saved to an MPEG file.

AVI Flipbook files are saved to an AVI file.

The “Record current graphics window 
animation” icon will be on.

Click it to open the Save Animation dialog.

Set the recording format, and the window size under the Record 
and Advanced tabs.

Note: This same kind of recording can also be done for:
1. Streaming transient data from disk in the Solution Time dialog.
2. Animated particle traces.
3. Spin Mode using the F4 key.
4. Isosurface auto cycle.
5. Clip auto cycle.
Simply start the animation and click on the Record Animation 
icon when it is bright red.

Off On
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OTHER NOTES
Rather than specify the part delta values through interactive part manipulation as described above, you can set the 
values explicitly using the Feature Detail Editor for the part.  For clip parts:

1. Select Edit > Part Feature Detail Editors > Clips... to open Feature Detail Editor (Clips).

2. Select the desired part in the parts list of the Feature Detail Editor (Clips).

3. In the Animation Delta section, enter the desired values in the X, Y, and Z fields and press return.

For isosurfaces:

1.  Select Edit > Part Feature Detail Editors > Isosurfaces... to open Feature Detail Editor (Isosurfaces).

2. Select the desired part in the parts list of the Feature Detail Editor (Isosurfaces).

3. In the Animation Delta field, enter the desired isovalue delta value and press return.

When a flipbook is subsequently loaded, active clips and/or isosurfaces will update based on these animation delta 
values.

Since both object and image flipbooks build pages from the current set of parts based on their current attributes, if 
you make a change (such as color a part by a different variable or create a new part), you must reload the flipbook.  
There are exceptions.  With an object flipbook, you can make a part invisible while the flipbook is running.

SEE ALSO
User Manual: “Flipbook Animation” on page 6
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Create a Keyframe Animation

INTRODUCTION
EnSight’s ability to handle large, transient datasets has led to its use in the production of many video animations of 
engineering and scientific data.  EnSight uses a keyframe animation system.  A keyframe is a set of viewing 
parameters that specify a particular view of the scene in the Graphics Window.  The view may be notable because of 
what is visible, or because the view represents the transition point from one scene to another.  Once a set of 
keyframes has been selected, EnSight can automatically generate frames to interpolate the viewing parameters 
between keyframes for a smooth animation.

The changes to viewing parameters between keyframes are not limited to simple rotations, translations, or zoom 
operations.  You can also use EnSight’s frames capability to move parts independently, e.g. to animate an exploded 
view of a complex assembly.  You can also animate the global look-from and look-at points for “fly-by” style 
animations.

While refining your animation, you can display it directly in the Graphics Window.  When complete, you can specify 
the output resolution (e.g. for NTSC or PAL video) and set the recording device (e.g. to a disk file).

Although the production of adequate animation is easy, good animation takes experience. A sequence that looks 
good on your high resolution workstation screen may look less than acceptable when transferred to VHS videotape. 
An object rotating in ten degree increments may be an appropriate speed for your workstation graphics. At thirty 
frames per second, however, the rotation will complete in just over a second – too fast for normal viewing. See the 
Other Notes section for some additional hints and tips.

BASIC OPERATION
All keyframe animation functions are controlled through the Keyframe Quick Interaction area. You can define the 
transformations between keyframes, or you can create standard animations

To define your own keyframes:
1. Click the Keyframe Animation icon in the Feature Icon bar.
2. Set all viewing parameters to the desired location for keyframe 1.

Important Notes!

You can abort a running animation by 
moving the mouse into the animation 
display window and pressing the ‘a’ key.

If you toggle-off the Keyframing button, any 
keyframes currently defined will be deleted.  
If you wish to save a set of keyframes, click 
the Save... button.

3. Click Create Keyframe to save the first keyframe.
Note that the Keyframing toggle is automatically switched on 
when you begin saving keyframes.

4. Change the viewing parameters to the desired location 
for keyframe 2.

5. Click Create Keyframe to save keyframe 2.
You can play your animation at any time to check your results.  
The animation will play the keyframe range specified in the 
Run From/To fields in Run Attributes...

6. Click Run Animation to play the animation.
7. Continue to change viewing parameters and click 

Create Keyframe until you have saved all desired 
keyframes.
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There are many ways to specify the desired transformations between keyframes.  See the following articles for more 
information:
How To Rotate, Zoom, Translate, Scale
How To Create and Manipulate Frames
How To Set LookFrom/LookAt
How To Define and Change Viewports

To Create Keyframes using Predefined Animations:
1. Click the Keyframe Animation icon in the Feature Icon bar.
2. Set all viewing parameters to the desired location for keyframe 1.

3. Click Quick Animations... to bring up the Keyframe Quick Animations Dialog.
In this dialog you will be able to create keyframes which define transformations which will (a) fly the viewer 
around your model, (b) rotate your model, or (c) create exploded views of your parts.  Any one of these, or a 
combination may be used.

4. Set the number of frames which will be 
created

5. Acceleration at the first and last 
keyframes that will be created is on by 
default.  If you do not want to accelerate/
decelerate toggle these off.

6. Toggle Fly Around on if you wish to move 
the viewer (camera) in a circle.
(a) You can choose Right (start the viewer 
moving to the right) or Left. 
(b) Specify the number of revolutions.

7. Toggle Rotate Objects if you wish to rotate 
the scene.
You can rotate positively or negatively about 
all three axis.  For each axis you set the 
number of revolutions.

8. Toggle Explode View if you want your 
parts to be translated in reference to an 
origin.
You can specify the origin or set the origin to 
the transformation center.
Direction sets the explode direction and can 
be one of:
X,Y,Z  - translate in the coordinate direction
XYZ    - translate in the dominant coordinate direction
Radial - translate in the direction from the origin 
specified through the part centroid

The part that is farthest from the origin 
specified will be transformed Distance units

9. Click Create Keyframes to create the 
keyframes which will transform according  
to the selections made.
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The following sections provide details on the animation control dialogs opened from Run Attributes... in the 
Keyframing Quick Interaction area.

Speed/Actions

The Speed/Actions tab allows you to set the number of sub-frames between each pair of consecutive keyframes as 
well as specify run attributes such as acceleration and commands to execute:

The number of sub-frames controls the speed with which objects transform between keyframes.  More sub-frames 
yields slower motion.

You can insert any valid EnSight command to be executed at a keyframe.  If your command sequence is more than a 
few lines, it is best to save the sequence in a file and just enter the command play: filename.  There is a special 
case of executing a command at a keyframe.  If you insert the command shell: filename, The file filename 
(which is assumed to be a UNIX executable command) will be executed after each sub-frame and each surrounding 
keyframe.  In addition, if you are saving animation frames to disk files, the name of the image file just written is 
passed to the executable as the first argument.  This capability can be used to postprocess the image files, for 
example to resize and re-sample an image or copy it to a different location.  If this capability is used, the shell: 
filename command must be the only command specified.

1. Click Run Attributes... in the 
Keyframing Quick Interaction area 
to bring up the Keyframe Run 
Attributes dialog.

2. Click the Set Speed/Actions tab.

3. Select the desired keyframe to 
edit: either enter the value or use 
the up/down buttons.

4. Enter the desired number of sub-
frames between the keyframe 
selected in step 1 and the next 
(the default is 20).

5. If desired, set the number of 
frames to hold for the keyframe 
(default is 1).

6. If desired, enter EnSight 
commands to execute when the 
selected keyframe is reached. The 
command(s) will be executed 
before the frame is displayed.

7. If you added or changed the 
commands to be executed at a 
keyframe, click Update 
Commands.

8. If you want the transformation to accelerate out 
(or into) the keyframe, toggle Acceleration on.

9. Continue by selecting a new keyframe to edit 
and click Close when done.

Use Interactive Iso/Clip
By turning this toggle on, any clip or isosurface interactively moved 
during the keyframe will animate.

Animate Transparency Change
By turning this toggle on, transparency changes to parts during the 
definition of the keyframes will be part of the animation.
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Viewing Window

The Keyframe Viewing Window tab allows you to set the size and location of the animation display window:

1. Click Run Attributes... in the Keyframing 
Quick Interaction area to bring up the 
Keyframe Run Attributes dialog.

2. Click the Viewing Window tab.

3. Select the desired window type:

The Min setting for User Defined specifies the position of 
the lower-left corner of the animation window (as an offset 
from the lower-left corner of your monitor screen).  The Max 
setting is the upper right corner of the animation window.

Normal Use the current Graphics Window 
(initially 794 x 659)

Full Use the full screen with no window 
borders (typically 1280 x1024)

NTSC Use NTSC video resolution (640 x 480) 
and position at the lower-left corner

PAL Use PAL video resolution (720 x 576) 
and position at the lower-left corner

User Defined Use the Min/Max X and Y settings

Detached Display Use the detached display and set Min/
Max settings

4. Click Close.
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Run From/To

The Run From/To tab allows you to specify the range of keyframes to play.

1. Click Run Attributes... in the 
Keyframing Quick Interaction area to 
bring up the Keyframe Run Attributes 
dialog.

2. Click the Run From/To tab.

3. If you wish to limit the animation 
playback to certain keyframes set the 
Run From and To fields.  By default they 
are set to cover all of the keyframes you 
have created.
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Transient

If you have transient data you can specify how it will be used during the keyframe animation.

 Record...

The Keyframe Animation Recorder dialog specifies the type of recording device:

1. Click Run Attributes... in the 
Keyframing Quick Interaction area to 
bring up the Keyframe Run Attributes 
dialog.

2. Click the Transient tab.

3. Toggle Use Transient Data on if you 
want to use transient data during the 
animation.
Transient data does NOT have to be on 
(and should not) to play back a flipbook 
animation during the keyframe animation.

4. Timelines allow you to use transient 
data during each defined timeline.
If the timelines do not cover all of the 
keyframes you will have a portion of your 
animation with no transient data.

By default a single timeline exists which 
covers all of the defined keyframes. To 
create more timelines click New

5. For each timeline you can specify the begin and 
ending time value (either step or simulation time - 
See Solution Time dialog).

6. Time will be interpolated such that the Start Time 
occurs at the Start At Keyframe and the End Time 
will occur at the End At Keyframe unless the Specify 
Time Increment is toggled on. If the Specify Time 
Increment is on each frame during the timeline is 
incremented by the time indicated. 
If the Start Time or End Time is encountered before the 
Start At or End At Keyframes the transient data will either 
Loop (go back to the Start Time) or Swing (play in 
reverse).

1. Click Record... in the Keyframing Quick 
Interaction area.

2. Toggle on Record To File.
3. Select the desired file format 

and options.(see below).
4. Provide the File prefix.
5. Click Close.
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Available recording file formats:

Save and Restore

A set of keyframes and related information can be saved to disk and later restored.  To save keyframes:

1. Click Save... in the Keyframing Quick Interaction area.

2. Enter the desired file name in the File Selection dialog and click Okay.

To restore previously saved keyframes:

1. Click Restore... in the Keyframing Quick Interaction area.

2. Enter the desired file name in the File Selection dialog and click Okay.

OTHER NOTES
As pointed out in the introduction to this article, high-quality animation takes time and experience.  CEI has produced 
a great deal of animation over the years and has learned a variety of lessons.  In the hope that EnSight users can 
avoid many of the pitfalls inherent in the process, many of these lessons and rules of thumb are presented here.

EnSight’s keyframe animation methodology is borrowed from the animated film industry. In making animated films, 
the master animator defines how the scene will look at certain points in time (the keyframes) and then hands the work 
off to an “in-betweener”, with instructions on how many frames to add between each pair of keyframes. The in-
betweener then draws the missing frames. EnSight’s approach is similar with the user as the master animator and 
EnSight as the in-betweener. Some of the strengths of this approach include:

1. When keyframing is on, EnSight is not only recording the viewing parameters when you click Create Keyframe, it 
also records the actions taken to get from the last keyframe to the current one.  This approach permits certain 
operations to be performed without ambiguity (such as rotating by 180 degrees or more).

2. Each Viewport can be animated independently.
3. Flipbooks can be played during an animation.
4. Animated particle traces can be played during an animation.
5. Transient data is easily synchronized with the generated frames. When the animation is run, EnSight will 

automatically step through time and recalculate all time-dependent entities.
6. Output can go directly to disk files for later recording, manipulation, or conversion to other formats (e.g. MPEG or 

QuickTime).
7. Additional power and flexibility can be achieved since EnSight command language statements can be issued at 

keyframes.

Apple PICT Flipbook files saved as sequence of Apple PICT files.

JPEG Flipbook files saved as sequence of JPEG files.

TIFF Flipbook files saved as sequence of TIFF files.

PCL Flipbook files saved as sequence of Page Control Language files.

PostScript Flipbook files saved as sequence of PostScript files.

Silicon Graphics RGB Flipbook files saved as sequence of SGI RGB files.

TARGA Flipbook files saved as sequence of TARGA files.

CEI RGB with depth Flipbook files saved as sequence of RGB files with depth.

EnVideo Flipbook files are saved to EnVideo file.

MPEG1 / MPEG2 Flipbook files are saved to an MPEG file.

AVI Flipbook files are saved to an AVI file.

POVRAY Geometry Flipbook files are saved as a sequence of POVRAY geometry files
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The keyframe capability was designed to enable engineers and scientists to produce quality animation.  As such, it 
lacks most of the more elaborate controls available in commercial animation packages (which typically cost 2-3 times 
more than EnSight).  Some limitations:

1. Only transformation parameters (global, frame and camera transforms) are saved through the keyframing 
process.  Other parameters and part attributes are not interpolated between keyframes.

2. Light sources are fixed in EnSight – they cannot move during the animation. 
3. The shading and lighting model used by EnSight is fairly simplistic.

Tips for Video Recording
Animation Holds

Whenever an animation is started or stopped use a “hold” to allow your viewers to establish the visual context of the 
scene.  A hold of 3 seconds at the beginning and 2 seconds at the end usually works well. For complex imagery, 
longer holds may be required.  Note that a hold can typically be performed at the recording level – it is not necessary 
to have EnSight compute multiple frames for a hold.

Rate Control

The speed at which events occur during an animation is one of the most difficult aspects to master.  Viewers become 
confused and disoriented if motion is too fast; too slow and your viewer may lose interest. The frame rate for NTSC 
(the video format used in North America) is 30 frames per second.  Although there is a great deal of variation 
(depending on graphics hardware speed and model size), your workstation will typically have a much slower frame 
rate.  Therefore, what appears to be good speed on your workstation may be much too fast when recorded to video 
at 30 frames per second.

Trial and error is one method to determine proper rates.  Although you may end up doing some “line test” video 
recording to refine your rates, use the method described here to derive good starting values:

1. Define all the keyframes.
2. Set up the animation to play back at full screen.
3. Set up the animation to play only from the first to the second keyframe.
4. Set the number of sub-frames between keyframes 1 and 2 to be 300.
5. Select View > Bounding Box > Static Box.
6. Using a watch with a second hand, time how long it takes to play the animation.  Call this time “T”.  We know that 

it will take 10 seconds to play 300 frames on video.  Compute the following:
factor = T/10.

For example, if you find T to be about 12 seconds, then factor is 1.2, which means that the rate you see on the screen 
is 1.2 times slower than what you will see on video.

7. Iteratively adjust the number of sub-frames between keyframe 1 and 2 (running the animation after each 
adjustment) until you like the rate you see on the screen.

8. Finally, adjust the number of sub-frames by the factor found in step 6.  For example, if 150 sub-frames were 
required for a good rate of speed, then change the number of sub-frames to 150*factor to see the same rate on 
video.

9. Perform steps 3 through 8 for the next set of keyframes.

Transient Data

Animation is particular useful for presenting transient data. However, since both viewing parameters and time can 
change simultaneously, the potential for confusing viewers is very high.  In general, you should never change both 
viewing parameters and time simultaneously.  It is typically much better to use transformations in an opening scene to 
present the model to the viewer.  The transformations should end at a vantage point suitable for viewing the transient 
phenomena.  At that point, the time-dependent data can be displayed.  If you must alter the scene during transient 
display, do so with great care to avoid disorienting viewers.

Note that you can animate time-dependent information without transformations by merely creating two keyframes 
without performing any transformations between them.
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In many instances, there will not be enough time steps in the simulation to produce an animation of adequate 
duration.  If the simulation does not involve changing geometries, EnSight can interpolate between time steps 
(linearly) to yield additional frames. However, keep in mind that your simulated phenomena is almost certainly not 
linear in nature.  If you have EnSight generate more than a few interpolating frames between each actual time step, 
the resulting discontinuity at keyframes (from the piece-wise linear interpolation) is quite visible in the resulting video.

Frame count

The total number of frames that EnSight will produce during the animation is the sum of all sub-frames plus the 
number of keyframes. This is especially important to keep in mind when synchronizing transient data with animation 
frames.

Animated Traces

If you display animating particle traces during keyframe animation, you may have noticed that the trace animation 
always resets at the beginning of the keyframe animation.  However, in most cases it is desirable to have the trace 
animation fully in progress when the animation begins.  This can be accomplished by creating an additional keyframe 
at the beginning of the animation.  Set the number of sub-frames between keyframes 1 and 2 to a value high enough 
to yield the desired tracer saturation.  When you run the animation, set the Run From field to 2 so that the animation 
begins generating frames with keyframe 2.  At that point, the tracer animation process will have executed once for 
each sub-frame between keyframes 1 and 2.

 Color

The color gamut (the range of colors a device is capable of displaying) of video (especially NTSC) is significantly less 
than that of your workstation monitor.  The result is that certain colors that look fine on your workstation cannot be 
reproduced on video.  Fully saturated colors (especially red and blue which “bleed” across the screen) are particularly 
troublesome.  However, it is quite easy to de-saturate your images prior to recording.  There are actually three ways 
to do this:

1. Modify all of the colors in use to de-saturate them. For example, if a color is pure red (1., 0., 0.), change it to be a 
more pastel red (.85, .1, .1).

2. Modify the saturation factor in the Image Format Options.  A factor of 0.85 is usually good.

3. Create your animation, then de-saturate the images using an image tool such as the one available from the San 
Diego Supercomputing Center (it’s free). This will only work, of course, if you are saving animation images to disk 
files.

Dark backgrounds work much better than light backgrounds.  Black is often the best choice.

Lines

Moving single-width lines have a tendency to “crawl” on video.  Use a minimum line width of 2.

Anti-aliasing

Without correction, computer-generated imagery exhibits aliasing artifacts that typically show up as jagged edges.  
For our purposes it is sufficient to say that aliasing results from sampling at a resolution too low to capture the “signal” 
represented by the underlying geometry.  We can only sample our geometry at the available pixels.  Since the 
effective number of pixels in the NTSC video signal is only one quarter the number of your workstation screen, what 
looks fine on your workstation may be less than acceptable on video. Although EnSight provides no direct anti-
aliasing support, there are ways to mitigate this problem.

1. If you are recording images from EnSight directly to a video recorder, use a scan converter (a piece of hardware) 
to filter full screen images to NTSC resolution images.

2. If you are recording images to disk files, record them at full screen resolution and then use an image re-scaling 
tool (such as izoom on SGI hardware) to down-sample the images to the desired video resolution. This down-
sampling averages several pixels to yield one output pixel, effectively preserving much of the resolution contained 
in the original full screen image.

Annotation

The smallest annotation text that can be clearly read on video has a font size of 40.  For title sequences, use a size of 
about 65.
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If you display parts colored by variables, you should always include the applicable color legend so viewers 
understand what the coloration represents.  For color legends, it is often sufficient to display just one value at the top 
(the maximum) and one at the bottom (the minimum) in addition to the name of the variable.  In fact, sometimes just 
using “High” and “Low” are sufficient if only the relative magnitudes of the variable are important.

Screen Space

The region of a video display that is “safe” for viewing is typically smaller than your animation display window. You 
should plan your scenes such that objects of interest (especially annotation entities) do not come “too close” to the 
edge. If you keep these objects within the range (in EnSight viewport coordinates) .06 to .94 for X (width) and .05 to 
.95 for Y (height) you should be safe.

Introductory Sequence

Your animation should begin with some title slides explaining the problem domain to your viewers.  Try not to put too 
many words on any one slide and display each one for at least four seconds.

Next, before displaying your results, provide a sequence that introduces viewers to your model. This sequence 
should be long enough and complete enough to orient the average target viewer to your problem. It is difficult to 
overestimate the need for this sequence. Without it, viewers are often confused and disoriented for the entire 
animation.

Credits

You should always include proper credits on any animation you produce. Even animations initially intended only for 
internal consumption often end up shown to broader audiences.

Stretching an Animation

Ten minutes of video requires 18,000 frames. Only after you have created your first animation will you realize that this 
can represent a logistical nightmare. In many cases, you can reduce the number of generated frames required using 
each frame multiple times. If you record two video frames for each actual frame you have, in effect, slowed your 
animation by half since there are only 15 new frames per second. Although 15 frames per second produces less 
smooth motion than 30, it is still usually acceptable. Further reduction however, say to 10 unique frames per second, 
produces noticeable jerkiness.

The Recording Process
There are three basic ways to go about recording your animation:

1. The cheapest method (and the one that typically yields the poorest results) is to simply record the animation 
directly off the workstation.  This can be done either by pointing a video camera at the screen or using the built-in 
video out signal available on some workstations.
Although this may be suitable for some simple steady-state problems, the resulting video is usually of very poor 
quality.  Note also that the frame refresh rate is dependent on the complexity of your geometry (which can vary 
throughout the animation) and the speed of your hardware.

2. EnSight can also write each generated frame to a disk file. Given the current state-of-the-art in hardware and 
software for video production, this is the preferred method. The images can be further manipulated on disk (e.g. 
color de-saturation or pixel averaging) prior to recording. If a problem occurred, missing or bad frames can be 
regenerated. Tools also exist to convert sequences of image files to popular animation formats such as MPEG and 
QuickTime.

3. EnSight can directly output popular animation formats, including MPEG, AVI and its own format - EnVideo. 

SEE ALSO
User Manual: “Keyframe Animation” on page 12
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Animate Particle Traces

INTRODUCTION
EnSight’s powerful particle tracing facility can trace particles (either steady-state or transient) through flow fields.  
Animating the resulting traces often promotes intuitive comprehension of the characteristics of the underlying flow 
field. Traces are animated by displaying one or more tracers on all traces of the trace part. A tracer moves along the 
path of a trace with length proportional to the local velocity. EnSight provides complete control over all aspects of the 
tracers including length, speed, and release interval for multiple pulses.

This article covers particle trace animation and assumes that you have already created one or more particle trace 
parts.  See How To Create Particle Traces for more information.

BASIC OPERATION
To enable particle trace animation and adjust the animation parameters:

1. Double-click the desired particle trace part in the Main Parts list.
2. Toggle on Animate in the Quick Interaction area.
3. Click Animate to open the Trace Animation Settings dialog. Make changes as desired (remember 

to press return for changes to text fields).

Set the color of the tracers to either Trace 
Color (i.e. the same color as the parent 
trace part) or Constant (and set the desired 
color using the Mix... button or the RGB 
fields.

Set the line width of the tracers.

If transient traces (pathlines), set the Start 
Time and/or Max Time.

Set the tracers length factor (see below).

Set the tracers speed factor (see below).

Set tracers head representation.  Either 
None or Spheres.  If Spheres, the radius can 
be Constant (set by the Scale value) or 
sized by a variable and scaled by the Scale 
value.  Sphere detail set via Detail field.

Click to load good default values to the 
Tracer Time, Tracer Delta, and Pulse 
Intervals fields. Toggle on Multiple pulses and set the 

interval between pulses (see below).
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Tracer Parameter Descriptions:

Record...
Once traces are animating, they can be recorded.  

Available recording file formats:

Tracer Time (Length) The Tracer Time (Length) parameter acts as a scaling factor for all tracer lengths 
(the higher the value the longer the tracer).  Tracer length varies as the local 
velocity changes along the trace.  For example, the tracer will lengthen as the 
leading edge of the tracer moves into a higher velocity region.

Tracer Delta (Speed) The Tracer Delta (Speed) parameter acts as a scaling factor for the tracer speed 
(the higher the value the faster the tracer).  The speed of the leading and trailing 
tracer edges varies as the local velocity changes along the trace.

Pulse Interval The interval between successive tracer emissions when in multiple pulse mode 
(the higher the value the longer the interval between pulses).  Note that the 
distance between tracers will increase when the local velocity increases.

Apple PICT Flipbook files saved as sequence of Apple PICT files.

JPEG Flipbook files saved as sequence of JPEG files.

TIFF Flipbook files saved as sequence of TIFF files.

PCL Flipbook files saved as sequence of Page Control Language files.

PostScript Flipbook files saved as sequence of PostScript files.

Silicon Graphics RGB Flipbook files saved as sequence of SGI RGB files.

TARGA Flipbook files saved as sequence of TARGA files.

CEI RGB with depth Flipbook files saved as sequence of RGB files with depth.

EnVideo Flipbook files are saved to EnVideo file.

MPEG1 / MPEG2 Flipbook files are saved to an MPEG file.

AVI Flipbook files are saved to an AVI file.

The “Record current graphics window 
animation” icon will be on.

Click it to open the Save Animation dialog.

Set the recording format, and the window 
size under the Record and Advanced tabs.

Off On
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ADVANCED USAGE
If you have time-dependent data and have calculated transient particle traces (pathlines), you can enable trace 
animation, load a transient flipbook, and view the animating pathlines simultaneously with the dynamic flipbook.  See 
How To Create Particle Traces and How To Animate Transient Data for more information.

OTHER NOTES
The parameters in the Trace Animation Settings dialog are not specific to the currently selected particle trace part – 
the settings apply to all currently animating particle trace parts.

SEE ALSO
User Manual: Particle Trace Animation
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Annotate
Create Color Legends

INTRODUCTION
Every currently active variable has an associated color legend that can be displayed in the Graphics Window.  Color 
legends provide essential information about images that use parts colored by variable values (color fringes).  
Legends are particularly important if the image is to be viewed by others.

Legends are drawn as a vertical or horizontal color bar with associated variable values. The size and position of the 
color legend can be changed. This article discusses changing the appearance of color legends using Annotation 
mode. To edit the color palette itself (change colors or change the mapping from variable values to colors) see How 
To Edit Color Palettes.

BASIC OPERATION
To display a color legend:

1. On the desktop, click the Variable 
legend visibility button.

2. Click the variable legend(s) you 
wish to display (or not display).

The list contains legends for scalar 
variables and for magnitude of vector 
variables.  The components of vector 
variables will become available in the 
list if Show Components is toggled on.

More than one legend can be selected 
concurrently.

A button is provided to allow you to 
easily turn them all off.

You can also easily get to the palette 
editor from here.

Note: ( ) indicates legend not currently visible,
          (*) indicates currently visible legend.
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Resize or Reposition Color Legends in Graphics Window
In Annotation Mode, color legends can be selected in the graphics window and then scaled or moved:

Manipulating Other Legend Attributes

1. Make a color legend visible as described above.
2. Click Annot in the Mode Selection area.
Like other annotation entities, color legends must be selected prior to 
performing an operation. A selected color legend has handles surrounding 
the color bar colored in the highlight color (typically green). Unselected color 
legends have white handles.

3. Select the desired color legend: move the mouse into the 
Graphics Window and click the left mouse button anywhere 
within the color bar.

4. To move the color legend, place the mouse pointer within the color bar, click 
the left mouse button, and drag to the desired location.

5. To resize the color legend, place the mouse pointer over one of the four 
corner handles, click the left mouse button, and drag to the desired size.

Handles (currently selected)

1. Click Annot in the Mode Selection 
Area.

2. Click Legend icon from the Mode 
Icon Bar to bring up the Annotation 
dialog.

3. Select the legend(s) of interest in the 
list (or in the graphics window), then:

To change visibility:
Toggle Visible on or off.

To change color of text and colorbar 
outline:
Select the desired color from the matrix, 
enter RGB values in the fields, or click 
More... to open the Color Selector dialog.

To change legend orientation:
Click the desired Layout (Vertical or Horizontal).

To change title position:
Click the Title Pulldown and select either Above (the default), 
Below, or None.
To change text position:
Click the Values Pulldown and select either Left/Bottom (the 
default), Right/Top, or None.
To change legend type:
Click the Type Pulldown and select either Continuous (the 
default) or Discrete.
To change text size:
Enter the desired text size and press return.

To change Value label format:
Either select a pre-defined format from the Value format List or 
enter a new format string in the Text Format field.

To change location:
Enter values for X & Y (lower left corner) and width and height, and press return.
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SEE ALSO
How To Edit Color Palettes

User Manual: Annot Mode
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Create Lines and Arrows

INTRODUCTION
EnSight can display 2D lines with or without arrowheads.  These annotations overlay the Graphics Window and are 
not associated with any viewport.

BASIC OPERATION

   To delete a line, click the Delete button.

1. Click Annot in the 
Mode Selection Area.

2. Click Line icon from the Mode 
Icon Bar to bring up the 
Annotation dialog.

3. Create a new line in the 
Graphics Window by clicking 
the New button.

     

To manipulate a line attributes, first select the
line(s) of interest in the list (or while in Annot
Mode, pick them in the graphics window), then:

To change visibility:
Toggle Visible on or off. Note that in Annot Mode invisible 
lines are drawn in a subdued color. 

To change color:
Select the desired color from the matrix, enter RGB values 
in the fields, or click More... to open the Color Selector 
dialog

To change location:
Either select the center of the line and drag it to the desired 
location, or type appropriate coordinates in the X1, Y1, X2, 
and Y2 endpoint fields.

To change orientation and length:
Either select and drag the endpoints of the line to the 
desired location, or type appropriate coordinates in the X1, 
Y1, X2, and Y2 endpoint fields.

To change line width:
Click the Width Pulldown and select the desired line width.

To change Arrowhead status:
Click the Arrows Pulldown and select the desired state. 
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SEE ALSO
User Manual: Annot Mode
Page 2 of 2



Create Text Annotation

INTRODUCTION
EnSight has comprehensive features for text annotation.  Not only can you display and position user-specified text, 
you can also display text contained in the description lines of some data formats as well as dynamic text that changes 
over time.

BASIC OPERATION
1. Click Annot in the Mode Selection 

Area.

2. Click Text icon from the Mode Icon 
Bar to open the Annotation dialog.

3. Click the New button, which will 
open the Text annotation creation 
dialog.
Make sure it is in Create mode.

4. Enter the desired text, and hit a 
return in the field.
The text should now show up in the 
graphics window.

While entering text, you can change the 
script to super, sub, or normal by clicking 
the Superscript, Subscript, or Normal 
buttons which will insert <up>, <dn>, or 
<no> into the string.
The Special Coded Items, which can be 
inserted into a string are discussed 
below.
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To manipulate text string attributes, first select the string(s) of interest in the list (or while in Annot mode, 
pick them in the graphics window), then:

To change visibility:
Toggle Visible off or on. Note that in Annot Mode, the text 
will not be completely invisible but will be displayed in a 
subdued color.

To change color:
Select the desired color from the matrix, enter RGB 
values in the fields, or click More... to open the Color 
Selector dialog.

To change justification:
Select the desired Left, Right, or Center justification from 
the Justify pulldown.

To change text size:
Either resize the text interactively by grabbing the Resize 
Point of the text string (bottom right) and dragging, or by 
precisely specifying the font size in the Size field of the 
dialog (or using the slider to change the font size).
Important Note!  The text size specified is relative to the 
size of the Graphics Window. If you increase the size of 
the Graphics Window, all text will also rescale to 
maintain the same relative size.

To change text rotation:
The orientation of text about the text justification point 
may be specified interactively by grabbing the Rotation 
Point of the text string (cross shape at upper right) and 
rotating the text to the desired orientation, or by precisely 
specifying the rotation angle (in degrees) in the Rotation 
field (or using the slider to change rotation angle).

To change location of the justification point in the 
graphics window:
Either interactively drag the text to the desired location, 
or precisely specify the location in the Origin XY fields.

You can also specify the viewport that the text is to be 
positioned relative to. If 0, the position is relative to the 
graphics window.
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Special Coded Items
EnSight can automatically build text strings based on information from various sources. To use one of these special 
strings, select the desired item from the Special String list, select any required options, and click Insert Special String.  
A code will be inserted into the Text field. Hit return in the Text field to create the text entity and display it.

The following special strings are available. If multiple cases are loaded, any reference to parts or variables applies to 
the currently selected case (select Case > casename to changes cases)

Delete Annotations

Select All

SEE ALSO
User Manual: Annot Mode

Symbols Brings up a symbol dialog. Click on any symbol to insert it at the current character 
insertion point of the string. The symbol will be inserted in to the string via a <sy>xxx, 
where xxx is the ASCII number for the selected symbol.

Constant Variable The value of a constant variable (such as Time or Length).  Select the variable from the 
Constant Variables list and select the desired numeric display format from the Number 
Format list.

If the constant variable changes, the corresponding text will automatically update.  This 
is very useful for displaying the current solution time during a transient animation.

Date Current date.  Example: Wed Jan  1 12:34:56 1997

Geometry Header The first or second text line of the geometry file of the current case.  Select Line 1 or Line 
2.

Measured Header The first line of the measured (discrete) data file of the current case.

Variable Header The first line (typically the description line) from a variable file.  Select the desired 
variable from the Variable(s) list.

Part Value The “value” of a part.  Currently only works for isosurface parts where the value is the 
corresponding isovalue.  Select the isosurface part in the Part(s) list and select the 
desired numeric display format from the Number Format list.

Part Description The description of the part as displayed in the Main Parts list. (Note that you can change 
this text by editing the Desc field in the applicable Feature Detail Editor for the part.)

Version The name and current version number.  Example: EnSight Version 6.0.

Existing annotations can be deleted in the Annotation dialog 
or can be selected and the Delete icon can be clicked:

You can select all of the current annotation type by clicking:
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Load Custom Logos

INTRODUCTION
EnSight can display bit mapped graphics loaded from disk files.  A bitmap can be any image, however, the most 
common use is to include a logo or other signature graphic to identify the source of images or animations.  Bitmaps 
are drawn over all geometric objects in the Graphics Window (at least where the bitmap is opaque), but under all 
other annotation entities.

Bitmaps are stored in X Pixmap(.xpm) or (.bmp) format. See the Other Notes section for more information.

BASIC OPERATION
To load a logo:

OTHER NOTES
The X Pixmap format is a widely used format for storing pixel maps for use in X Windows environments. For more 
information on the format, visit http://koala.ilog.fr/lehors/xpm.html. In the Windows world, .bmp files 
are widely used and understood.

Please note that EnSight requires that the color values in the .xpm files be hex numbers. Color names cannot be 
used. The program “xv” seems to convert them such that Ensight can read them if your application uses color names. 

To manipulate logo attributes, first select the logo(s) of 
interest in the list (or in the graphics window), then:

To change visibility:
Toggle Visible off or on. Note that in Annot Mode, the logo will not 
be completely invisible but will be displayed in a subdued color.

To change location in the graphics window:
Either position the logo interactively by selecting the desired logo 
in the Graphics Window (while in Annot Mode) and dragging it to 
the desired location, or specify the precise coordinates in the X 
and Y fields.

To change size:
Typing the desired scaling factors into the X & Y fields and press 
return.
Note that the size of a logo cannot be adjusted interactively.

1. Select Annot in the Mode Selection 
Area

2. Click the Logo icon from the Mode 
Icon Bar to open the Annotation 
dialog.

3. Click New button and select the 
desired .xpm or .bmp file using the 
File selection dialog which comes up, 
and click Okay.
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SEE ALSO
User Manual: Annot Mode
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Configure EnSight
Customize Icon Bars

INTRODUCTION
EnSight uses several sets of icons to group functionality.  To suit personal preferences or simplify the interface, the 
order of the icons within each set can be changed or icons can be removed altogether (typically eliminating access to 
that portion of functionality).
The icon sets correspond to the seven major groupings of function within EnSight: Main Feature (the icons in the 
Feature Icon bar) and the six Modes: View, Part, Annot, Plot, VPort, and Frame.  By default, EnSight displays 
informative text labels underneath each icon in the Mode icon bars.  Once the icon functions have been learned, 
these can be removed to save space in the icon bar.

BASIC OPERATION
To customize an icon bar:

To edit, click the left mouse button at the desired location and change the text.  Each entry in the list controls one icon 
and has the following components:

Note that changes will not take effect until the next time you run EnSight.  To save your changes, click the Save As 
Default button and then click Close.  To exit the dialog without saving your changes, just click Close.

Menu ID Internal ID.  (Included for potential future usage – do not change).

Button Name The name of the icon.  (Included for potential future usage – do not change)

Visible status Either ON or OFF.

Order Icon order within the bar.

Description Description printed in the Message Area when the left mouse button is clicked and held on the 
icon.

1. Select Edit > Preferences..., select General User_Interface and click the Modify and Save Icon Layout... 
button.

3. To disable display of the icon help labels, toggle off the Show 
Help Labels For Mode Icons button. (Off by default)

2. Select the desired icon bar from the Which Icon 
Bar pulldown.
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ADVANCED USAGE
The lists presented in the Icon Bar Preferences dialog are stored on disk as text files in the .ensight8/ directory 
(which is located in your home directory). If you prefer, you can edit these files directly with any text editor and the 
changes will take effect during your next EnSight session. The files are named as follows:

SEE ALSO
User Manual: Icon Bars

Main Feature ensight_feat_panel.def

View ensight_view_panel.def

Part ensight_part_panel.def

Annot ensight_annot_panel.def

Plot ensight_plot_panel.def

VPort ensight_viewp_panel.def

Frame ensight_frame_panel.def
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Customize Mouse Button Actions

INTRODUCTION
When the mouse pointer is in the Graphics Window, clicking and holding the left mouse button as you drag will 
perform the current transformation (e.g. rotate or zoom) as selected in the Transformation Control area. To perform a 
different transformation, you have to move the mouse to the Transformation Control area, select the new operation, 
and move back to the Graphics Window. To avoid this, you can redefine how the left mouse works as well as map 
additional transformation operations onto the middle and right mouse buttons, combinations of mouse buttons, and 
double-clicking of mouse buttons.

This customization only effects the mouse usage while in the Graphics Window.  The left button is still used for other 
user-interface actions.

BASIC OPERATION
To change the behavior of mouse buttons in the Graphics Window:

1. Select Edit > Preferences..., then click on Mouse and 
Keyboard

2. Set each mouse button pulldown (Left, Middle, Right and 
combinations of such) as desired (see below).

3. Set the double-click action for each mouse (see below).

4. Set the action for the keyboard ‘P’ key (see below).

5. Set desired Zoom Style.
Automatic slide will zoom based on the direction and distance the 
mouse is moved. To the right or up zooms away, while to the left or 
down zooms towards. The distance the mouse is dragged 
determines the rate of continuous zoom.
Manual drag zooms in the same directions, but only a distance 
relative to the distance the mouse is dragged.

6. Click Save To Preference File to save your changes (if you 
want these changes to be the default for future sessions of 
EnSight) and Close to exit the dialog.

The new settings will take effect as soon as you hit the close 
button.  If you clicked Save To Preference Files, your changes are 
also written to a file and automatically loaded during future EnSight 
sessions.
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Each mouse button (or combination of mouse buttons) can have one of the following associated behaviors:

Note that at least one of the mouse buttons(or combinations) must be set to “Selected transform action”!

Each double-click mouse action or the keyboard ‘P’ key can be set to the following:

Note that at least one of the mouse buttons, double-click options or the “P” key must be set to “Selected pick 
action”!

SEE ALSO
User Manual: Mouse and Keyboard Preferences

Selected
transform action

When this mouse button is clicked and dragged, the operation performed will be the currently 
selected function in the Transformation Control area.

Rotate When this mouse button is clicked and dragged, the operation performed will be rotate.

Translate When this mouse button is clicked and dragged, the operation performed will be translate.

Zoom When this mouse button is clicked and dragged, if Zoom Style is Manual Drag then a zoom 
displacement will occur, and if Zoom Style is Automatic Slide then a zoom velocity will occur

Rubberband
zoom

When this mouse button is clicked and dragged, the operation performed will be a rubberband 
zoom.

Rubberband
selection tool

When this mouse button is clicked and dragged, the operation performed will be a rubberband 
selection tool manipulation.

Selected pick
action

When this mouse button is clicked, the currently selected pick action (as previously selected 
under the pick icon) will be performed.

Pick part When this mouse button is clicked, the pick part action will be performed - causing the part under 
the mouse to be selected in the main parts list.

Pick cursor tool
location

When this mouse button is clicked, the pick cursor tool action will be performed - causing the 
cursor tool to move to the picked location.

Pick transf. center When this mouse button is clicked, the pick transformation center action will be performed - 
causing the center of transformation to move to the picked location.

Pick elements to
blank

When this mouse button is clicked, the element blanking action will be performed - causing the 
element under the mouse to be removed.

Nothing When this mouse button is clicked, no action will be performed.

Selected pick
action

When this mouse button is clicked, the currently selected pick action (as previously selected 
under the pick icon) will be performed.

Pick part When this mouse button is clicked, the pick part action will be performed - causing the part under 
the mouse to be selected in the main parts list.

Pick cursor tool
location

When this mouse button is clicked, the pick cursor tool action will be performed - causing the 
cursor tool to move to the picked location.

Pick transf. center When this mouse button is clicked, the pick transformation center action will be performed - 
causing the center of transformation to move to the picked location.

Pick elements to
blank

When this mouse button is clicked, the element blanking action will be performed - causing the 
element under the mouse to be removed.

Nothing When this mouse button is clicked, no action will be performed.
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Save GUI Settings

INTRODUCTION
The default size and position of the EnSight user interface windows was chosen to try to minimize window overlap.  
Since some users may have different criteria for window placement, EnSight provides a method for saving this 
information.

BASIC OPERATION
You can move and resize windows using the standard window manager operations.  Once you have positioned your 
windows as desired:

1. Select Edit > Preferences..., select General User Interface and click Save Size and Position of Main 
Windows.

The information is saved in your .ensight8/ directory (which is located in your home directory) in the file 
ensight.winpos.default.

This and many other preference settings can be set and saved, see How To Set and Modify Preferences.

SEE ALSO
User Manual: Save Window Positions under the General User Interface of Prefs.



Define and Use Macros

INTRODUCTION
Advanced users of EnSight often find themselves performing repetitive tasks.  EnSight’s macro facility lets you save a 
sequence of commands and then assign a keyboard key or mouse button to those commands such that they are 
executed when the key or button is pressed.

Pressing a key/button assigned to a macro causes the associated command file to be read and executed.  
Depending on how it is set up, a macro can execute it’s file in one of three ways:

1. The command file is executed once for each key/button press.  This mode is useful for one-time operations such 
as cutting flipbook animation on/off or saving an image.

2. The command file repeatedly executes as long as the key/button is held down.  This is useful for operations that 
are continuous in nature, such as rotating around the Y axis by 5 degrees.

3. Multiple command files execute in a cycle for each keystroke or mouse button click.

Note: In the 8.0 release, EnSight uses a separate utility program (macromake) to create macros. In a subsequent 
release, this facility may be integrated into the user interface.

BASIC OPERATION
The first step in creating macros is to save the various command sequences that perform the desired actions.  See 
How To Record and Play Command Files for more information.  Be careful as you perform the operations that are 
saved to the command files.  Superfluous or errant commands will slow down macro operation or cause errors.  You 
may wish to view the resulting command files with a text editor and possibly make changes.

Once created, you should move the command files to your ~/.ensight8/macros directory. Although not required, 
it is useful to be able to distinguish these files from others – a common suffix such as “.mac” is often used.

Once the command files are ready, run the macro utility program, macromake. The executable is located in the
$CEI_HOME/bin  directory so it should already be in your command search path.

1. From a UNIX shell window, run macromake:
% macromake

The utility will print requests for action to the UNIX shell window. It also opens a graphics window (titled “Macromake”) 
that is used to capture keyboard and mouse event codes. The basic macro definition process is as follows:

2. Specify the keyboard/mouse action by moving the mouse pointer into the Macromake window and 
pressing the desired keyboard key or mouse button. The Macromake window will close.

3. Respond to the questions in the UNIX shell window: 

If EnSight is still running, you can click Reload Macros in the Command dialog (File > Command) to make your new 
macros active.  Otherwise, they will be available during your next session of EnSight.

How many command files are 
tied to this key?

Enter the number of command files that will execute (in turn) when the 
macro is executed.

Enter command file 1 to be 
tied to this key:

Enter the name of the first command file to execute.  If the response to the 
first question was greater than one, then enter each subsequent command 
file name (in the desired order of execution) when prompted.

Is this a repeatable macro? Answer y for a repeatable macro (executes continuously as long as the key/
button is depressed) or n for single execution.

Do you wish to define 
another macro?

Answer y to define another macro or n to quit.
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OTHER NOTES
The mapping from keys/buttons to command files is saved in the macro.define file. This file and associated macro 
command files are saved in your  ~/.ensight8/macros directory. Your local EnSight administrator can also define 
a common set of macros that are located in the $CEI_HOME/ensight80/site_preferences/macros/ 
directory. These macros (if present) will be read first, followed by user-specific macros. User-specific key/button 
assignments therefore take precedence over site macros.

A common use of tying more than one command file to the same key is to create a toggle. Make the first command 
file turn the option on, and the second command file turn the option off. Then tie both of these to the same key. You 
will now cycle through the two command files, effectively creating a toggle situation.

SEE ALSO
How To Record and Play Command Files

User Manual: Keyboard Macro Maker (macromake)
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Set or Modify Preferences

INTRODUCTION
Nearly every operation and function in EnSight is initially set to a default value. Preferences allow you to set these 
initial values as well as set some default behaviors such as which time step to initially load for transient data, how the 
mouse buttons are defined, etc. When EnSight starts, the preference settings are read from the $CEI_HOME/
ensight80/site_preferences directory and then overlaid by the preference settings found in your .ensight8 directory.

BASIC OPERATION

The following preference categories are available in the Preferences dialog (and will be explained below):

     To Set Annotation Preferences:
     To Set Color Palette Defaults:
     To Set Command Line Preferences:
     To Set Data Preferences:
     To Set General User Interface Preferences:
     To Set Image Saving and Printing Preferences:
     To Set Interactive Probe Query Preferences:
     To Set Mouse and Keyboard Preferences:
     To Set Part Preferences:
     To Set Performance Preferences:
     To Set Plotter Preferences:
     To Set Query Preferences:
     To Set User Defined Input Preferences:
     To Set Variable Preferences:
     To Set View Preferences:
     To Set Viewports Preferences:

1. Bring up the Preferences dialog by selecting Preferences 
from the Edit pull-down menu.
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To Set Annotation Preferences:
1. Select Annotation from the Preference 
Categories list.

2. Click the “Click Here To Start” button. 

3. Click the Select button in the Annot mode 
icons and click Deselect All Annotations.

4. Set any attribute, for example line widths to 2 
Pixels, text to left justification, etc.

5. You can also define any annotation (text, line, 
and logo) and have it be part of your 
preferences. Legends can also be part of the 
preferences, but these preferences are 
independent of the variable tied to the legend, 
i.e., the preference file keeps attributes for the 
first, second, third, etc. visible legends.

5. Click Save to Preference File to save the 
default annotation attributes. If you have 
defined any annotations, a pop-up will ask you 
if you want to save this annotation as part of 
your default or if your intent is to save the 
default attributes only.
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To Set Color Palette Defaults:

1. Select Color Palettes from the Preference 
Categories list. 

2. Choose to color by RGB or Textures.

3. Toggle on if you want the color legend to 
automatically appear when you color a part by a 
variable.

4. Toggle on if you want color legends to be 
replaced when the current legend is no longer in 
use (i.e., no parts are colored by the variable) 
and a new variable is in use.

5. Toggle on if you wish the legend ranges to be 
updated when time is changed, thus based on 
values of variable at the current time.

6. Set the default legend for per element 
variables to be constant over the element or to 
vary continuously over the element (averages 
with neighbors).

7. Set the default legend editing interface to 
simple or advanced

8. If you have predefined color palettes, you can 
set one of them to be the default by entering the 
name or picking one from the list of defined 
palettes.

9. To set default legend attributes, click here. 
This will bring up the detail editor for color 
legends with no legends selected. In the feature 
detail editor, set the desired attributes such as 
linear/logarithmic scale, and continuous or 
banded type.

10. Click here to save the preferences.
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To Set Command Line Preferences:
A number of command line parameters exist for 
EnSight. These parameters can be set in your 
preference file so you do not have to specify them on 
the start line each time you use EnSight.

1. Select Command Line Parameters from the 
Preference Categories list.

2. Select a command line argument.

An explanation of the selected argument will appear
in the dialog.

3. Click here to add the parameter.

It will be placed in the edit area.

If you make a mistake and add an unwanted 
parameter, simply highlight it in the feedback area and 
delete it.

If additional information is required, a note will be 
posted here to help you.

4. If you need to add additional information, add 
any text needed into the edit area.

5. Click here to save the preferences. 
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To Set Data Preferences:

1. Select Data from the Preference Categories 
list.

2. If you want to specify a path to look for data, 
specify it here.

3. You can specify the default binary file type 
here.

4. When transient data is loaded into EnSight 
you can choose to specify a beginning time 
step. If you do not specify a beginning time step, 
either the first or the last time step will be loaded 
depending on this preference.

5. After successfully reading data into EnSight 
you are presented (for most data formats) with a 
part loader if this attribute is set to No Parts. If 
set to any other attribute the parts specified will 
be loaded and displayed without intervention 
from the part loader.

Concerns periodic model updating while 
EnSight is running - Please Contact CEI Support 
regarding this option.

6. The readers shown with a * will show up in the 
pull-down for data format in the EnSight data 
reader dialog. You can take readers off of the 
pull-down list if you toggle the * off (select the 
reader in the list).

7. You can specify the default data type by 
typing in the exact name of the reader.

8. Click here to save the preferences.
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To Set General User Interface Preferences:

1. Select General User Interface from the 
Preference Categories list.

2. Toggle to show tool tips (balloon help).

3. Toggle to show long part list.

4. Toggle to show Frame mode as an available 
mode.

6. EnSight’s command language records part 
names or numbers according to this choice.  
Recording by name is more portable for using 
the command language with a different dataset 
since the part numbers do not need to match 
up.  However, recording by name produces 
slightly larger command files.

7. Click Save Above Items To Preference File to 
save the GUI items to your preference file.

8. To Modify EnSight’s Icon Layout, click here.

9. To save as a preference the location and size 
of EnSight’s windows, click here.
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To Set Image Saving and Printing Preferences:

1. Select Image Saving and Printing from the 
Preference Categories list.

2. Click the “Click Here To Start” button.  This 
will bring up the Print/Save Image dialog.

3. Modify the attributes you want for your 
preference such as the image format.

4. Click here to save the preferences. 
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To Set Interactive Probe Query Preferences:

1. Select Interactive Probe Query from the 
Preference Categories list.

2. Click the “Click Here To Start” button.  This 
will bring up Interactive Probe quick 
interaction area.

3. Modify the attributes you want for your 
preference such as Report By, and # Items 
Displayed.

4. Click here to save the preferences. 
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To Set Mouse and Keyboard Preferences:

This preference allows you to modify the behavior 
of the mouse buttons used during EnSight 
transformations. Several different actions are 
available for the various single click, multiple-
button single click, and double click options. Note, 
it is required to set at least one button to “Selected 
transform action” (which means that the button is 
set to the action as shown in transformation icons 
at the bottom of the EnSight dialog - set to rotate 
by default). Also, one mouse or the “p” keyboard 
key must be set to “Selected pick action”.

1. Select Mouse and Keyboard from the 
Preference Categories list.

2. Modify the preference for each of the mouse 
buttons (and keyboard ‘P’ key). 

Single click actions 
available are:

Double-click picking 
options are:

And the possible zoom styles are:

3. Click here to save the preferences. 
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To Set Part Preferences:

1. Select Parts from the Preferences Categories 
list.

2. Click Allow editing part defaults if you want 
to be able to edit part defaults when no parts 
are selected.

3. Click the “Click Here To Start” button. This 
will bring up Part mode in EnSight and deselect 
any parts (so you can edit defaults).

4. Modify any part attribute such as line 
thickness.

5. Click Save General Part Preferences To File 
to save the default visual attributes for parts.

6. If you want to modify creation attributes for 
created parts, specify which dialog you want to 
use.

7. Set the part type.

8. Modify the attribute. For example, set 
subcontours to 3 for contour parts.

9. Click Save Preferences For Part Type 
Chosen To File to save the attributes for the 
part type edited.
Page 10 of 17



To Set Performance Preferences:

1. Select Performance from the Preferences 
Categories list.

2. To take advantage of pixel saving when 
redrawing a window movement, set this 
toggle. (Graphics card speed for reading/writing 
of pixels needs to be reasonable to use.)

2. To cull duplicate lines in line drawing mode, 
set this toggle.

3. To set fast mode to static, toggle on.  The 
default is off meaning that the fast display 
(i.e., bounding box) is only active during 
transformations such that the image returns 
back to full graphics display when the mouse 
buttons are not depressed.  In static mode the 
fast representation is continuously displayed.

4. To sort the geometry during 
transformations, thereby creating correct 
transparent image at all times (but at a 
performance cost), set this toggle on.  To 
delay the re-sort until the mouse is released, 
set this toggle off  (better performance with 
often acceptable enough image)

4. If using point display for fast display mode, 
set the point resolution here.

5. If using sparse geometry display for fast 
display mode, set the percent of the model to 
show here.
(Only used if immediate mode is being used.)

6. Click here to save the preferences.
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To Set Plotter Preferences:

1. Select Plotter from the Preferences 
Categories list.

2. Click the “Click Here To Start” button.  This 
will bring up Plotter mode in EnSight and 
deselect any plots and curves.

3. Set any attribute, for example line width for 
curves, tick marks for axis, etc.

4. Click here to save the preferences.
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To Set Query Preferences:

1. Select Query from the Preferences 
Categories list.

2. Click this toggle on so that once you create 
a query it will be automatically plotted.

3. If Auto Plot Queries is toggled on, then you 
have the option to check this toggle. If on and 
an existing plot uses the same variables, you 
query will be added to this existing plot.  
Otherwise an new plot will be created.

4. Click the “Click Here To Start” button. This 
will bring up the Query quick interaction area 
with all query items deselected.

5. Set any attribute, for example Distance Type 
and 30 Samples for the Line tool constraint.

6. Click here to save the preferences.
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To Set User Defined Input Preferences:

1. Select User Defined Input from the 
Preferences Categories list.

2. Turn this on to show the macro panel display

3. Toggle to select the default to display a part 
list in the graphics window. This is especially 
helpful in full screen mode or a VR environment.

4. Turn this on to activate the user defined input 
device (ensight8_INPUT must be set to the 
proper device).

5. A Valuator can be used for zoom operations 
(like a virtual joy stick), or Position which 
simply means to delta movement in the Z 
direction will be used.

6. Sets the sensitivity for the zoom operation. 
The values for zoom are scaled by this setting, 
so values larger than 1.0 will make the inputs 
larger while less than 1.0 will make them 
smaller.

7. Mixed mode will use the input devices z 
rotate directly but use x and y translation values 
for x/y rotations. Direct mode will use the 
rotation angles from the input device directly 
for all three axis.

8. Sensitivity will set a scaling factor for the 
rotation values.

9. Click here to save the preferences.
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To Set Variable Preferences:

1. Select Variables from the Preferences 
Categories list.

2. Turn this on if you want to be notified 
before a variable is activated.

3. Toggle to select visibility of functions in the 
General Functions list of the New Variable 
Calculator dialog.

4. Save this notification request and function 
visibilities to the preference file by clicking 
here.

5. Brings up the dialog for setting extended 
CFD settings.

Save these settings by clicking here.
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To Set View Preferences:

1. Select View from the Preferences 
Categories list.

2. Turn on if you want the plane tool to be 
shown as a transparent plane, or off if you 
want it shown in line drawing mode.

3. There are two offsets employed in EnSight.
This one, hardware offset, is perpendicular to 
the monitor screen, and done in hardware if 
this toggle is on. This will allow, for example 
contour lines to appear closer to the viewer 
than their parent part so they are visible no 
matter what orientation the part is viewed 
from.

The second offset is the display offset. The display offset 
can be set in the feature detail editor for line parts such as 
contour lines, particle trace lines, vector arrows, and 
separation/attachment lines. The display offset is the 
distance in the direction of the element normal 
(perpendicular to the surface).

4. Select the default viewing orientation.

5. Pull down “View” menu and set items 
desired.

6. Click here to save the preferences.
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To Set Viewports Preferences:

SEE ALSO
User Manual:  Edit Menu Functions 

1. Select the Viewports Category.

2. Click the Click Here To Start button.

This will bring up the Viewports quick interaction 
area with all viewport items selected.

3. Set any viewport attributes (for example, 
background color to blended).

4. Click here to save the attributes set in 2. to 
the preference file as defaults for future 
sessions.

5. Click her to save the current viewport layout 
to the preference file.
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Enable User Defined Input Devices

INTRODUCTION
EnSight offers user defined input devices that have been specifically designed for (but not limited to) typical input 
devices used in VR environments (such as the Immersadesk). Implementation of these input devices requires 
adherence to the instructions outlined in the respective reference files listed below.

BASIC OPERATION
Manual Panel Interface:

SEE ALSO
User Manual: “User Defined Input Preferences” 

1. Select Edit > Preferences..., and click User 
Defined Input.

2. Toggle Macro Panel Interface

The Main Graphics window updates the Macro Panel as 
defined in the file:           

~/.ensight8/macros/hum.define    

(If you have not created this file, an example is provided 
in:

$CEI_HOME/ensight80/src/input/HUM/hum.define

on your EnSight Client host system.)

3. Toggle Part Panel Interface (if you desire a 
part list in the graphics window).

4. Toggle User Defined Input.

(Detailed steps to implement the User Defined Input 
Device are outlined in the file:

$CEI_HOME/ensight80/src/input/README

on your EnSight Client host system.)

5. Set Zoom Using to the appropriate type of 
input device you are using to record zoom 
transformations, adjusting the Sensitivity as 
needed (i.e., 0 < slower < 1 faster).

6. Set Rotate Using to the appropriate type of 
input device you are using to record rotation 
transformations, adjusting the Sensitivity as 
needed (i.e., 0 < slower < 1 faster).
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Setup For Parallel Computation

INTRODUCTION
Ensight supports shared-memory parallel computation via POSIX threads on all of our supported platforms.

BASIC OPERATION
Configuration

Each executable of EnSight can be configured individually to control the number of threads used. 
The following environment variables are used to specify the maximum number of threads that the 
executable should use for computation.

ENSIGHT8_MAX_THREADS
The maximum number of threads to use for each EnSight server. Threads are used to 
accelerate the computation of streamlines, clips, isosurfaces, and other compute-intensive 
operations.

ENSIGHT8_MAX_CTHREADS
The maximum number of threads to use for each EnSight client. Threads in the client are 
used to accelerate sorting of transparent surfaces.

ENSIGHT8_MAX_SOSTHREADS
The maximum number of threads to use for each EnSight server-of-servers. This variable is 
introduced for planned future use, but at the time of this writing no operations in the server-of-
servers are accelerated with threads.

OTHER NOTES
The number of threads is limited to 2 (per client or server) with a Standard license, while the upper limit for a Gold 
license is 128. When setting these parameters it is a good idea to take into account the number of processors on the 
system. In general, you will not see benefit from setting the parameters higher than the number of total processors. 
Because the server, server-of-servers and client operate in a pipelined fashion, it is not necessary to limit one in order 
to apply more threads to another.

Compute intensive server operations that make use of shared memory parallel computations include isosurface, 
clipping, and particle trace computations. Client threaded operations include transparency resort and display list 
creation.
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Setup For Parallel Rendering

INTRODUCTION
EnSight Gold now supports general parallel rendering for increased performance, increased display resolution, and 
arbitrary screen orientations. The configuration file format and several examples are described in the User Manual. 
Just click the link below to see this information.

SEE ALSO
User Manual:  Parallel Rendering and Virtual Reality



Miscellaneous
Select Files

INTRODUCTION
Many operations in EnSight (such as loading data) require that you specify a file.  EnSight uses a standard file 
selection dialog that lets you quickly search through directories to find the desired file.

BASIC OPERATION
By default, the File Selection dialog opens with the directory from which the EnSight client was started as the current 
directory.  When opened subsequently, the directory that was last selected will be current.

The following shows the basic components of the File Selection dialog:

The Filter displays the name of the current 
directory and controls the listing of files in 
the Files list. You can use standard 
wildcard characters (such as *) to restrict 
the list to only those file names that 
match the wildcard. See Wildcarding 
below for more information.

The Directories list displays all 
directories in the current directory. Note 
that the current directory is shown ending 
with “.” and the parent of the current 
directory is shown ending with “..” 
(standard UNIX nomenclature). To open 
a directory, double-click it.

The Selection field contains the full path 
name of the file currently selected in the 
Files list.  This is the file that will be 
chosen if Okay is clicked.  Change the 
selection either by clicking a file in the 
Files list or editing the field directly.  
Pressing return will accept the 
Selection and close the dialog.

The Files list displays the list of files contained in the 
current directory (possibly modified by the wildcard in 
the Filter field).  To make a file the current Selection, 
click it.  To accept a file and close the dialog, 
double-click it.

Click to accept the current 
Selection and close the 
dialog.

Click to apply the Filter 
after a change (you can 
also just press return after 
making a filter change).

Click to cancel the 
selection and close the 
dialog.
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Wildcarding
The EnSight File Selection Filter field accepts a standard set of regular expression characters that let you restrict the 
display of files in the Files list to those that match the regular expression. This can be useful when trying to quickly 
locate specific files in directories that contain large numbers of items. By default, the Filter field displays the current 
directory with “*” appended. The “*” is a special character that matches a sequence of zero or more characters of 
any type. For example, “*.geo” will match all files in the current directory that end with “.geo”. This form of regular 
expression matching is essentially identical to that used by the UNIX shell programs (such as csh) to match file 
names when issuing commands.

You enter a wildcard by clicking the left mouse button in the Filter field and entering the desired text.  When done, 
either press return or click the Apply Filter button.  The Files list will then update to reflect the new filter.

The recognized regular expressions are:

Special 
Character

Description Examples

* Match any (zero or more) characters. *.geo
widget*.cmd

? Match any single character. gadget?.geo

[...] Match any single character in the enclosed list(s) or 
range(s).  A list is a string of characters.  A range is two 
characters separated by a minus-sign (-), and includes all 
the characters in between in the ASCII collating sequence.

file[13579].rgb
file[1-9].rgb

~ Matches your home directory.  This is a special case: 
entering ~ (and pressing return) will set the current directory 
to your home directory and display all files in the Files list.

~
~/*.geo

~user Matches the home directory of user.  This is a special case: 
entering ~user (and pressing return) will set the current 
directory to the home directory of user and display all files in 
the Files list.

~joeuser
~joeuser/*.cmd
Page 2 of 2



Use The Feature Detail Editor

INTRODUCTION
Although most attributes of EnSight parts can be edited either through the appropriate Quick Interaction area or the 
Part Mode icon bar, full control is provided by the Feature Detail Editors for the various part types.  Full control over 
variables (e.g. activation, color palette editing, and new variable calculation) is also provided through a Feature Detail 
Editor.

BASIC OPERATION
You can open the Feature Detail Editor by either selecting the appropriate item from the Edit > Part Feature Detail 
Editors menu or by double-clicking the appropriate part icon in the Feature Icon bar. All Feature Detail Editors (except 
the two dealing with Variables – see below) contain the same basic components:

Menu:

File (these items are only available for the Variables Feature 
Detail Editor – see below)

Edit

Select All: Select all parts listed in the dialog’s parts list

Copy: Make a copy of the selected part(s)

Delete: Delete the selected part(s)

Immediate Modification: If on, all changes in the dialog have 
an immediate effect.  If off, the Apply Changes button at the 
bottom must be clicked to apply your changes (good for 
batching several expensive changes).

View

Show Selected Part(s)...:  Open the Selected Part(s) 
window to display only the selected parts.

List of variable/part icons; click to change to the desired 
Feature Detail Editor type.

Parts list of the current Feature Detail Editor type; lists only 
those parts of the current type.  (For example, the contour 
Feature Detail Editor is shown and only the current contour 
parts are listed.)

Description of the currently selected part in the parts list.  Click 
to type, make changes, and press return.

Creation Attributes section.  This section (which is missing for 
Model parts) is unique to the Feature Detail Editor type and 
controls part-specific attributes (e.g. the isovalue of an 
isosurface).

The remaining sections (General, Node/Element/Line, and 
Displacement) control attributes common to all part types.  See 
How To Set Attributes for more information.

Click to Close the Feature Detail Editor dialog.

Click to Create a new part based on the attributes as currently 
set and with parent part(s) as selected in the Main Parts list.

Click to change the parent part(s) of the selected part(s).  The 
new parent part(s) must be selected in the Main Parts list.

Click to apply any changes you have made (only 
active when Immediate Modification is toggled off 
in the Feature Detail Editor Edit Menu).
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The Feature Detail Editor for variables is different from the part Feature Detail Editors:

Menu:

File

Save Selected Palette(s)...: Write palettes for selected 
variables to a disk file

Save All Palettes...: Write palettes for all variables to a disk 
file

Restore Palette(s)...: Load palettes from a disk file

Edit

Select All: Select all parts listed in the dialog’s parts list

Immediate Modification: If on, all changes in the dialog 
have an immediate effect.  If off, the Apply Changes button 
at the bottom must be clicked to apply your changes (good 
for batching several expensive changes).

View

Show Selected Part(s)...:  Not available in Variables 
Feature Detail Editor.

List of available variables.  Click to select a variable.

Buttons to control variable activation/deactivation.  See How 
To Activate Variables for more information.

Variable Summary and Palette section (Simple Interface is 
Shown). See How To Edit Color Palettes for more 
information.

Click to Close the Feature Detail Editor dialog.

Click to apply any changes you have made (only 
active when Immediate Modification is toggled off 
in the Feature Detail Editor Edit Menu).

1. To open the Feature Detail Editor for Variables either 
select Edit > Variables Editor... or double-click the Color 
icon in one of the modes (such as Part mode).
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The Feature Detail Editor for variable Calculator is also different from the part Feature Detail Editors:

SEE ALSO
Most of the creation attributes for parts can also be set in the Quick Interaction area for the part type.  See the How To 
article for the desired part type for more information.

1. To open the Feature Detail Editor for variable Calculator click 
the Calculator icon in the Feature Icon bar.

Variable Calculator section. See Variable Creation in the 
User Manual for more information.
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interactive
clipping

IJK
line
plane
quadric
RTZ
XYZ

isosurfaces
particle traces
probe preferences
query

isosurface
animation
creation
interactive

isovolume
creation

J
JPEG output

K
keyboard macros
keyframe animation

Record
Run From/To
Save and Restore
Speed/Actions
Tips
Transient
Viewing Window

L
labels

element
node

legend, color
light source

attributes
location

lighting
attributes
model
static

line
annotation
clip
tool

logo annotation

look-at
look-from

M
macros
material part
measured data
merge (part)
mode shapes
Model Axis
Model Extent Bounds
mouse

buttons, customizing
preferences

MPEG
out from flipbook
output options

N
node

labels
query

not loaded representation

O
online documentation use
orthographic projection
output formats

AVI
EnVideo
JPEG
MPEG
PCL
PICT
Postscript
POVRAY
SGI RGB
TARGA
TIFF

overview
client/server architecture
graphical user interface
parts concept

P
palette

editing
preferences

parallel computation
configuration
setup

parallel rendering
setup

part
attributes
box clip
clip plane

clips
color
contour
copy
creation
cut
delete
developed surface
displacements
element labels
elevated surface
extract
group
IJK clip
introduction
isosurface
isovolume
line clip
material
merge
node labels
particle trace
preferences
profile
quadric clips
query
revolution of 1D part clip
revolution tool clip
RTZ clip
save to disk file
selection
separation/attachment line
shock surfaces/regions
subset
symmetry

computational
visual

tensor glyphs
transparency
vector arrows
vortex core
XYZ clip

Part Bounds Display
particle traces

animation
creating
interactive
pathlines
record
streaklines
surface restricted

parts concept
PCL output
performance

preferences
periodicity
perspective projection
phone numbers
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pick
center of transformation
cursor tool
elements to blank
line tool
look-at point
part
plane tool

PICT output
plane clip
Plane tool
plotter

anatomy
attributes
create
delete
moving/resizing
preferences
selecting
visibility

point
query

PostScript output
POVRAY

output
preferences

annotation
color palettes
command line
data
general user interface
icon bar
image saving/printing
interactive probe
macros
mouse and keyboard
part
performance
plotter
query
user defined input
variables
view
window positions

printing
documentation
images

probe query
profile plot

Q
quadric clip
query

dataset
element
IJK
interactive
node

over distance
part
point
preferences

R
reading

data (introduction)
ens_checker
ensight_reader_extension.map file
File->Data(reader)...
File->Open...
new data without quitting
Quick method
server of servers
transient data
Two-Step method
user defined data reader

reference
icons

rendering
setup for parallel

representation
border
bounding box
feature angle
full
non visual

reset
frame transform
transformations

restart
session (archive)
without quitting client

restore
context
keyframe animation
session (archive)
viewing parameters

result file
revolution of 1D part clip
revolution tool

clip
RGB image output
rotate
RTZ

clip

S
save

command file
context
geometry
image
keyframe animation
POVRAY
preferences
scenario

session (archive)
viewing parameters

scale
scenario

save
selecting

colors
elements to blank
files
parts

selection tool
element blanking
for subset parts
zooming

separation line
Server of Servers

using
setup for parallel computation
setup for parallel rendering
shaded surface drawing
shock

surface/region
Silicon Graphics RGB output
solution time

recording animation
sphere

clip
tool

starting
automatically
options

static lighting
stereo display
subset parts

pick elements
selection tool

surface of revolution tool
surfaces, developed
symmetry

computational
visual

T
TARGA output
tensor glyph parts
text annotation
threads

ENSIGHT8_MAX_CTHREADS
ENSIGHT8_MAX_SOSTHREADS
ENSIGHT8_MAX_THREADS

TIFF output
time

stepping through
tools

box
cone
cursor
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cylinder
line
Plane
resetting
selection
sphere
surface of revolution

traces
animation
creating
interactive
pathlines
streaklines
surface restricted

tracking
tracking in viewports
transformations

frames
resetting
rotate
scale
translate
zoom

transient data
animation
reading
setting current time
stepping through

translate
transparency

U
unrolling surfaces
user defined

data reader
input devices
input preferences

Using Server of Servers
SOS

V
variable

activation
and cases
boundary layer
calculator
color palette
common CFD
deactivation
preferences

vector arrows
density

view
preferences

viewport
2D or 3D
attributes
background image

camera projection
case visibility
color
creating
deleting
lighting attributes
Part Bounds Display
part display
repositioning
resetting
saving viewing parameters
standard layouts
tracking

viewport tracking
Virtual Reality setup
visual representation
vortex cores
VR setup
VRML

W
window positions, customizing
working variable (default color)

X
XYZ

clip
interactive plane sweep

Z
Z clipping
zoom

rubberband
to region
using selection tool
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